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Chapter 1: Getting Started
American Innovations PCS software allows you to manage your corrosion program across your entire 
network with a single, integrated system that captures, analyzes, and reports on critical pipeline and facility 
data.

Before using  PCS 2.3, refer to the topics in this section. If you need additional assistance,  contact the  AI 
Support team.

The information in this section is intended for all PCS users and the PCS system administrator.

This chapter  includes the following topics:

 l Start PCS on page 1

 l Activate Bridge Import for Operation on page 2

 l Activate Telluric Compensation on page 4

 l System Overview on page 4

 l Modules and Related Options on page 5

 l System Recommendations on page 7

 l View Information About PCS on page 9

 l Technical Support on page 10

Start PCS
The Windows user name and password of the person currently logged into the computer is used to start 
the software and log into the database. If PCS is set up with the security option Requires Windows 
Password, a password is required to log into the database. See Set Options on page 20 for more 
information.

Complete the following steps to start PCS:

 1. Double-click the PCS desktop shortcut  or click the Windows Start button  and select PCS to start 
the software.
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 2. If the Login window opens, type your Windows password in the Password field and then click the  
icon to start the software.

Figure  1-1. Login

Activate Bridge Import for Operation
If your company purchased the optional Bridge add-on for importing raw data from a third-party 
application, running a Basic Bridge import for the first time requires you to activate Bridge using the license 
file provided by American Innovations (AI). A Bridge license is required only for those operations that use the 
Basic Bridge function to import data.

Operations using the Bullhorn Bridge function to import data do not require a Bridge license. Likewise, 
using Bridge to export data from PCS also does not require a Bridge license.

The Bridge license becomes part of the PCS database during the activation process, which allows a single 
license to apply to all PCS users in your company.

If you are unable to locate your Bridge license file, contact Technical Support for assistance at 
support@aiworldwide.com.

Complete the following steps to activate Bridge import for operation:

mailto:support@aiworldwide.com?subject=AI Support
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 1. Start PCS if the software is not running.

 2. Click Tools > Job Service Viewer in the header bar to open the Job Service Console window.

Figure  1-2. Job Service Console

 3. Click Activate Bridge Import License. When the Activation Key window opens, navigate to the license 
file and select it.

 4. Click Open to open the license file and return to the Job Service Console window.

 5. Verify that Running displays in the Status field and Valid displays in the License field. If these 
messages are not currently displayed, please contact Technical Support for assistance at 
support@aiworldwide.com.

mailto:support@aiworldwide.com?subject=AI Support
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Figure  1-3. Valid Bridge License

Activate Telluric Compensation
If your company purchased the optional Telluric Compensation feature, it becomes operational after 
activating your PCS license during the software installation process.

Customers with an existing PCS license who want to use Telluric Compensation will need a new PCS 
license and software upgrade. For more information about upgrading your PCS license, contact Technical 
Support on page 10.

System Overview
PCS is a database application used worldwide by distribution and transmission companies to manage 
pipeline compliance and integrity data. The application uses a SQL server database to store and manage 
data for one or more modules. All modules share a common interface that allows users to easily work with 
data regardless of which module they use. Modules are based on common industry practices and various 
Department of Transportation (DOT) regulations. These include DOT 192 titled Transportation of Natural 
Gas and Other Gas by Pipeline: Minimum Federal Standards Safety and DOT 195 titled Transportation of 
Hazardous Liquids by Pipeline.
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The PCS database is fully ODBC compliant allowing for integration with other databases, such as GIS 
(geographic information system) and ERP (enterprise resource planning) databases.

Figure  1-4. PCS System Overview

Modules and Related Options
PCS modules are purchased either separately or as a package. Modules and related options, such as 
Bridge Import and Telluric Compensation, become operational after entering the software activation key 
provided by American Innovations (AI).
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Modules/Related Options Description

Cathodic Protection Data Manager 
(CPDM)

CPDM manages cathodic protection (CP) data for facility types 
such as test points, rectifiers, foreign bonds, galvanic anodes, 
and tanks. Distribution and transmission companies use this 
module to manage and track corrosion data as well as other 
types of corrosion-related data.

Indirect Survey Manager (ISM) ISM manages and analyzes survey data for above ground 
continuous surveys (also referred to as indirect surveys). You 
can enter survey readings manually or use the Allegro field 
computer or mobile device or PCS Bridge to transfer survey 
readings in ISM. The types of continuous surveys supported in 
ISM include: Close Interval Survey (CIS), AC Close Interval 
Survey (AC CIS), DC Voltage Gradient (DCVG), AC Voltage 
Gradient (ACVG), AC Current Attenuation (ACCA), Soil 
Resistivity, and ILI.

Atmospheric Corrosion Manager 
(ACM)

ACM manages atmospheric corrosion data as required by US 
DOT 192 and 195 regulations.

Valve Manager (VM) VM manages valve inspection and repair data. The module 
provides compliance scheduling, data management, and 
reporting of valve information.

Internal Corrosion Manager (ICM) ICM tracks internal corrosion data in compliance with US DOT 
192 and 195 regulations. ICM supports facility types such as 
inhibitor injectors, coupons, samples, and probes.

Leak Survey Manager (LSM) LSM manages and provides compliance scheduling for leak 
surveys, classifies leaks and repair data, and supports follow-
up activities.

Custom Module Management (CMM) CMM is an optional module available for purchase that 
becomes operational after activating your PCS license. PCS 
supports up to ten (10) user defined modules with each module 
supporting up to ten (10) user defined facility types. Features 
and functionality available in the various modules distributed 
with PCS are also available in CMM. These include routes, 
schedules, reports/graphs, user defined fields (UDFs), themes, 
and so on.

Table 1-1.  Modules and Related Options       
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Modules/Related Options Description

Bridge Import An optional feature available for purchase that requires a Bridge 
activation key for use. This feature allows you to transfer data 
between PCS and an external system, such Bullhorn Web or a 
GIS or work management system.

Telluric Compensation An optional feature available for purchase that becomes 
operational after applying your PCS license. This feature 
provides support for telluric current compensation of survey 
readings and management of stationary survey data used in 
telluric compensation. PCS enhancements for telluric 
compensation include CPDM, ISM, Stationary Survey 
Maintenance, Field Computer, and Reports/Graphs.

Table 1-1.  Modules and Related Options        cont'd

System Recommendations
The system specifications that the server, job service, and client machines require will vary depending on 
the size of your database, the amount of data that is to be accessed on the machines, and the number of 
simultaneous client-server connections. The following are the minimum specifications we recommend for 
the server and client machines with a basic setup. Your company’s configurations may require additional 
RAM, more powerful processors, or more disk space.

Server System Recommendations

Properties Recommended

Processor Intel Xeon

Processor Speed 2  Quad Core CPUs at 2.4 GHz or better

RAM 32 GB

Operating System Windows Server 2019

Relational Database Software SQL Server 2019

Table 1-2.  Dedicated Central Database Server Recommendations

Notes: 

 l RAM — for optimal performance, additional RAM may be required for larger databases or if a large 
number of clients will connect to the PCS database at the same time. 

 l Disk Space — consult with your company’s IT personnel or DBA to determine where database 
backups will be created. 
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Job Service System Recommendations

Properties Recommended

Processor Intel Core i7

Processor Speed 2.3 GHz or better

RAM 8-32 GB  *depends on the largest anticipated job size. See Table 1-4.

Operating System Windows Server 2019

Available Disk Space 720 MB

Microsoft .NET Framework Version 4.6.2

Table 1-3.  Job Service Dedicated Machine Recommendations

 

Maximum Anticipated Job Size Sample Job Recommended RAM 
Size

Small — up to 8 million pieces of data 50 thousand rows, 125 columns 8 GB

Medium — up to 16 million pieces of 
data

100 thousand rows, 125 
columns

16 GB

Large — up to 32 million pieces of data 250 thousand rows, 125 
columns

32 GB

Table 1-4.  Job Service Memory Recommendations

Notes: 

 l Microsoft .NET Framework — If the target computer does not have Microsoft .NET Framework 
v4.6.2 installed, the PCS installation automatically installs it for you. This feature requires an active 
Internet connection to complete the installation of .NET Framework.

 l RAM — If a job has more data than the Job Service can handle efficiently, processing time increases 
dramatically.

Client System Recommendations

Properties Recommended

Processor Intel Core i7

Processor Speed 2.4 GHz or better

RAM 8 GB

Operating System Windows 10, 64-bit

Available Disk Space 720 MB

Table 1-5.  Local Client Computer Requirements
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Properties Recommended

Display Resolution 1920x1080

Microsoft .NET Framework Version 4.6.2

Notes: 

 l Microsoft .NET Framework — If the target computer does not have Microsoft .NET Framework 
v4.6.2 installed, the PCS installation automatically installs it for you. This feature requires an active 
Internet connection to complete the installation of .NET Framework.

 l RAM — 8 GB of RAM is sufficient for average use. However, if a client is accessing a large amount of 
data in PCS, additional RAM may be necessary to achieve optimal performance. 

View Information About PCS
The PCS About window contains details about the specific installation of PCS on your computer, such as 
database connection, software application version, and build information (date and time). This information 
is useful when contacting AI Support.

Complete the following steps to view or share this information:
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 1. Click Help > About PCS to open the About window.

Figure  1-5. About PCS

 2. Click Copy To Clipboard to copy the PCS connection and build information to the Windows 
clipboard. Paste the copied content into an email or another type of document, such as Microsoft 
Word, to store or share the information.

Technical Support
AI Support is available to provide assistance with PCS. Use the following information to contact AI Support:

Telephone: 1-800-229-3404

Email: support@aiworldwide.com

mailto:support@aiworldwide.com?subject=AI Support
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Chapter 2: PCS Set Up
PCS modules share a common interface and many similar functions. This section includes topics and 
instructions on how to set up features that are common to all PCS modules.

If you are unable to access a PCS menu or perform a particular function, check with your system 
administrator to verify your PCS user account is set up with an appropriate user role.

This chapter  includes the following topics:

 l Prepare to Set Up PCS on page 11

 l A Typical PCS Workflow on page 13

 l The System Hierarchy on page 14

 l Set the System Hierarchy on page 15

 l Set Up PCS on page 19

 l Custom Security Roles on page 47

 l Pipeline Series on page 141

 l Manage Custom Modules and Facilities on page 149

Prepare to Set Up PCS
After installing PCS, consider the following questions before you begin setting up PCS for operation. 
Answers to these questions determine how you set up PCS to fit your company's business needs.

How is your company's pipeline system organized?

 l Pipeline companies organize their distribution or transmission pipeline system using certain terms to 
describe how the system is organized. For example, terms such as Right-of-way (ROW), Pipeline 
Segment, Section, Section Map, District, County, Region, or State may be used.

Setting up PCS for operation requires that you define a pipeline system hierarchy. PCS supports up 
to five (5) hierarchy levels and can be organized and named in the same manner as your company's 
pipeline system.

How does your company identify inspection points on a pipeline?



PCS v2.5 User Guide

Chapter 2: PCS Set Up 12

 l A location name and location format must be set up for inspection points on a pipeline before users 
begin entering survey data in PCS. Once this information has been established, it is recommended 
that you do not change it in order to maintain data integrity.

When you first install PCS, default settings for location name and location format are Milepost and 
Station Number respectively. However you can change both of these to match your company's 
method for identifying inspection points on a pipeline.

What is your company's policy for scheduling surveys?

 l Default settings in PCS for survey schedules and grace periods are based on current regulations. 
You can however edit these default settings to match your company's survey policies instead.

For example, the grace period for surveying long lines is three months. However your company's 
policy may be less than three months. When setting up PCS survey schedules, enter your 
company's grace period to ensure surveys are scheduled correctly.

Does your company want to use PCS security features?

 l The User Management feature in PCS controls system security using a role based method. Each 
PCS user is assigned a user role. Users with SysAdmin security permissions have full control of the 
hierarchy and all system features. Users with User or Read Only security permissions have limited 
control.

For a list of user role permissions assigned to the User and Read Only user roles, refer to   System 
Security.

Will your company need unique data recorded in PCS?

 l Although PCS provides many fields for entering data, you can create what is called a User-Defined 
Field (UDF) when a PCS field does not exist. Your company's data collection forms are a good place 
to gather data for a UDF you may want to create.

For example, if test points are identified by map numbers, create a UDF to be used for data entry of 
test point map numbers.

Will PCS themes need to be customized to fit your company's business needs?

 l PCS uses themes for many operations, such as themes for data entry grids, sorting methods, 
filtering data, and field computer prompts. The PCS software installation includes several installed 
themes ready for use.

You can modify PCS installed themes and also add new themes to include only those features that fit 
your business needs. For example, you might want to include specific data fields for entering and 
viewing a particular type of survey data.
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Do you want to set up picklists that allow users to choose from a list of acceptable choices when entering 
survey data?

 l When a data entry field is limited to certain data, consider creating a picklist that includes only those 
items for selection, such as repair codes, priority levels, or status conditions.

For example, you may want to create a picklist with items for selection that identify insulator status as 
good, missing, and shorted. Picklists are helpful in reducing data entry errors by allowing users to 
select an item from a list of approved choices instead of entering data manually.

A Typical PCS Workflow
A typical workflow for working in PCS is shown in the figure below. Some operations are required and only 
occur once when setting up PCS, such as setting up system Options and Edit ROW Detail identified in the 
following figure. Others may occur more often as needed by PCS users with appropriate security 
permissions, such as adding or moving pipeline segments in the hierarchy; adding survey folders; 
customizing themes and reports; or creating routes and schedules for facility survey inspections.
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Figure  2-1. Typical PCS Workflow

The System Hierarchy
Before you begin entering data in PCS, you first need to establish the system hierarchy and enter your 
company's name. The hierarchy determines how PCS organizes data. The company name displays at the 
top of all reports and graphs.

You can create a hierarchy that reflects how your company categorizes its pipeline system. For example, 
you may want to create a hierarchy based on one or more of the following criteria: division, district, county, 
region, system, right-of-way (ROW), or section map.
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PCS supports a hierarchy structure with up to 5 levels. The top hierarchy level includes either your 
company's name or other type of descriptor. The following figure shows a hierarchy structure with 3 
hierarchy levels. The names of hierarchy folders as well as ROW Code and ROW name support up to 100 
characters.

IMPORTANT: It is recommended that you do not change the hierarchy structure after entering data in the 
database.

Figure  2-2. Example of Hierarchy Structure

Set the System Hierarchy
This procedure explains how to set up PCS with the following required system settings: your company's 
name, the number of levels in the system hierarchy, and a name for inspection points on a pipeline. A Public 
caption in this Options window indicates the associated property setting applies globally to all users and 
can only be changed by a SysAdmin.

The required User Location Formatsetting in Edit ROW Details window will not be completed during the 
initial system set up. After adding pipeline records in the system hierarchy, the User Location Format can be 
configured for each pipeline record to identify how inspection points are located on a pipeline. For more 
information, see Understanding Default Location Formats on page 189.

Complete the following steps to create the system hierarchy:
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 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-3. Options Window

 2. Click the General tab on the left side of the window to open the General pane.
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Figure  2-4. Options - General Pane

 3. In the Company Name field, type the name of your company.

 4. In the User Location Name field, enter an description of how your company refers to inspection 

points on a pipeline. For example, type Milepost, Station Number, Reference Reading, or 
other type of descriptor.

 5. Click the Hierarchy tab to open Hierarchy pane.
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Figure  2-5. Hierarchy Levels

 6. Select Hide Parallel Lines check box if you want to hide features in PCS that allow you to create and 
display parallel lines in the hierarchy.

When Hide Parallel Lines is enabled, parallel lines are hidden in Select ROWs and in the Add New 
Node windows. Distribution companies with no parallel lines typically use this setting. PCS identifies 
parallel lines using the Pipe, Pipeline Code, and Pipeline Name fields. For a description of these fields 
refer to  System Field Descriptions.

 7. In the Levels field, identify how many levels to include in the hierarchy. Click the down arrow and 
select the number of hierarchy levels in the selection list.  The pane updates to include level fields for 
the number of levels you selected. The example above shows the additional Level One, Level Two, 
and Level Three fields below the Levels field because 3 Levels was selected for that field.

 8. For each of the level fields below the Levels field, identify how pipelines are referred to in the system. 

For example, type ROW or Segment in the Level One field.

 9. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 10. Click  Save.

Continue with Set Up PCS to  complete the set up process.
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Set Up PCS
PCS provides several property settings that allow you to customize the software according to your 
company's business needs. Other settings affect the functionality of certain PCS features. Information in 
this section explains how to set each of these property settings. 

This chapter  includes the following topics:

 l Public and Private Property Settings

 l Set Options on page 20

 l Custom Security Roles on page 47

 l Set Properties in Field and UDF Customizations on page 55

 l Using an Application Scheme, page 1

 l Choosing a Printer for PCS on page 141

Public and Private Property Settings

Some property settings in Options, once configured, apply to all users, while others can be changed by an 
individual user for their login. 

Property settings that include a Public caption can only be changed by a SysAdmin. The setting made by 
the SysAdmin applies globally to all users. 

For property settings that include a Private check box, the SysAdmin can determine whether or not a 
general user can modify the property setting.

When the Private check box is checked, the currently logged in user can change the associated property 
setting. Changes are "private" and only apply to the logged in user who makes a change to the setting. If a 
Private check box is unchecked, the associated property setting made by the SysAdmin applies globally to 
all users and only the SysAdmin can change this value.

../../../../../Content/PCS_UserGuide/Using_an_Application_Scheme.htm
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Figure  2-6. Options Public and Private Property Settings 

Only a SysAdmin can see Private check boxes. For all other users, a Private caption displays next to the 
"private" and editable property settings. A Public caption  displays for globally-applied settings.

Set Options

PCS uses property settings in the Options window to perform many functions across all modules, such as 
arranging data, performing calculations, generating reports, and allowing user-access to certain features. 
Required settings include Hierarchy Levels, Company Name, User Location Name, and Criteria. If optional 
add-ons have been purchased, such as Bridge or Bridge with Bullhorn integration, setting properties for 
these features are also required.

To access PCS settings in the Options window, click Tools > Options in the header bar. The Options 
window includes all PCS settings.
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Figure  2-7. PCS Options

This chapter  includes the following topics:

 l Set Criteria Options on page 22

 l Set Editing Options on page 25

 l Set Email Notification Options on page 29

 l Set Field Computer Options on page 32

 l Set General Options on page 34

 l Set Hierarchy Options on page 37

 l Set Integration Options on page 41

 l Set Reports Options on page 43

 l Set Security Options on page 44



PCS v2.5 User Guide

Chapter 2: PCS Set Up 22

NOTE: A Public caption indicates the associated property setting applies globally to all users and can only 
be changed by a SysAdmin.

 (SysAdmin only) For options accompanied by a Private check box, check or uncheck the check box based 
on your company's requirements. When the Private check box is checked, the currently logged in user can 
change the associated property setting. For more information, see Public and Private Property Settings on 
page 19.

Set Criteria Options

The Criteria pane of the Options window sets the following property settings: 

 l (if available) Telluric threshold

 l days between an inspection reading and pipe-to-soil reading

 l casing criteria

 l test point criteria custom settings

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set the options shown in the Criteria window:
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 1. Click Tools > Options in the header bar to open the Options window. 

Figure  2-8. Options Window

 2. Click the Criteria tab to open the Criteria pane.
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Figure  2-9. Options - Criteria Pane

 3. If your PCS license includes the optional Telluric Compensation feature, two Telluric fields are 
included in the Criteria pane. Modify the following fields as needed:

 l Telluric Default Cycle Duration (Sec) — enter a time in seconds in the field provided to define 
the amount of time for a GPS synchronized on and off cycle.

 l Default Telluric Threshold — enter a value in volts in the field provided to define the threshold 
used to identify telluric effects in an SDL (stationary data logger) data set.

PCS calculates a baseline average for survey measurements in an SDL data set. If any survey 
measurement in the data set is above or below the baseline average by the amount specified 
in the Default Telluric Threshold field, this indicates the data set exhibits telluric current effects.

For information about how to upgrade a PCS license to include Telluric Compensation, contact 
Technical Support on page 10.

 4. Identify the isolation criteria for casing inspections. Type a value in the Casing Criteria Minimum 
Difference Between P/S and C/S field to set the minimum difference allowed between pipe-to-soil 
(P/S) and casing pipe-to-soil (C/S) readings before the casing is considered shorted. The default 
setting is 100 mV.

PCS displays a warning message when the minimum difference does not meet the casing criteria for 
an inspection reading entered in the data entry grid. Similarly, an entry is added in the Field Computer 
Log when inspection readings transferred from the Allegro do not meet casing criteria.

 5. Identify the number of days after an inspection reading is taken that a native pipe-to-soil (P/S) reading 
is taken. Type the number of days in the Days To Look Forward From Inspection For Native P/S field.
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The number of days effects the system calculation for the Effective Native P/S and Effective Native 
Date fields in data entry grids. Native P/S is a potential reading taken prior to any current placed on 
the pipeline. It is also referred to as a depolarized or static potential reading.

 6. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 7. If necessary, replace the default values in the fields under Test Point Protection Criteria Custom 
Settings.

Settings in the Test Point Protection Criteria Custom Settings fields are used to determine whether a 
test point inspection record meets criteria or not  when Custom On, Custom IRF, or Custom mV Shift 
are selected as the Test Point Protection Criteria in the CPDM data grid. 

Figure  2-10. Test Point Protection Criteria

 8. Click  Save to save changes.

Set Editing Options

Making changes to the Editing properties alters the behavior when entering data in data entry grids. 



PCS v2.5 User Guide

Chapter 2: PCS Set Up 26

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps in the Editing pane of Options:

 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-11. Options Window

 2. Click the Editing tab to open the Editing pane.
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Figure  2-12. Options - Editing Pane

 3. Check or uncheck the following option's check boxes or select from the drop downs as needed:

 l Date Carry Forward Enabled Option — check the check box to use the survey date that was 
last entered as the survey date for the next record when working in an Inspection grid or form.

 l Technician Carry Forward Enabled Option — check the check box to pre-fill the Technician 
field (in the Inspection grid) or Repair Technician field (in the Maintenance grid) with a default 
value when a new record is created. The default value for these fields is determined by the 
value selected in the Technician Carry Forward Method Option field.

 l Technician Carry Forward Method Option — Select a person's name from the drop-down to 
set the default value for the Technician field (in the Inspection grid) or Repair Technician field (in 
the Maintenance grid). These fields are pre-filled for new records with the default value only 
when the Technician Carry Forward Enabled Option is checked. The following values are 
available in the drop-down:
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 — Last Technician: uses the name of the last person entered in the Technician field.

 — Security: uses the name of the person currently logged into PCS.

 l Timestamp Readings Enabled Option — check the check box to automatically update the 
timestamp in the Inspection Date field to the current time for new inspections. The Inspection 
Date is updated after enough survey data is added to mark the inspection as Surveyed only if 
the inspection has an Inspection Date that matches today's date.

 l Turn On Change Tracking — check the check box to enable change tracking and keep a 
history of changes made to records in PCS. The Field and UDF Customizations window allows 
you to configure which fields' changes are recorded. Refer to Set Up Change Tracking for 
Individual Fields on page 70.

When change tracking is turned on, the Change History button appears in the data entry grid. 
For more information about setting up and using Change History, refer to View a Record's 
Change History on page 289.

 l Bypass Options On Loaded Grid — check the check box to have the data load immediately 
upon selecting a grid for the second time after entering Edit <Module> Data. The first time you 
view a specific type of grid, the grid's Options show first. However, when you visit that grid 
again, the Options will not display, and the data that loads is based on the previously 
configured settings. 

If the check box is cleared, the grid's Options will always show first, allowing you to define what 
records to show before loading data.

 l Show Detail Inspection Entry Grid — check the check box to display the CPDM Test Point 
Inspection Detail mini-grid.

The Show Detail Inspection Entry Grid check box is not available when using the optional PCS 
Telluric Compensation feature. The mini-grid displays by default with Telluric Compensation 
and cannot be disabled.

 l Show Grid Tooltips Option — check the check box to display a description of the field when 
you move the mouse over a data entry field.

 l Warn When Below Protection Criteria Enabled Option — check the check box to display a 
warning message when an inspection reading is entered that is below the protection criteria 
value specified in the Test Point Protection Criteria field.

 l Require Remarks When Range Or Criteria Is Violated Option — check the check box to 
require that remarks are entered in the Inspection Remarks field any time an entered reading is 
out of range.
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 l Warn Before Permanent History Record Changed Option — check the check box to display a 
warning message before changes are made to information fields in permanent history 
records. The warning will appear for pre-existing records in which the effective date is in the 
past.

 l Warn When Outside Established Range Values Enabled Option — check the check box to 
display a warning message when an inspection reading is entered that is out of range.

 4. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 5. When you finish, click  Save to save changes.

Set Email Notification Options

The Email Notification options determine how email reports should be sent. 

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set Email Notification property settings:
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 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-13. Options Window

 2. Click the Email Notification tab to open the Email Notification pane.
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Figure  2-14. Options - Email Notification Pane

 3. Fill out the following fields to set up PCS to send emails via your company's Simple Mail Transfer 
Protocol (SMTP) email server:

 l Type the host name of the SMTP email server your company uses to send email in the Email 
Smtp Host Name field.

 l Type a user name in the  Email Smtp User Name field that is associated with the email address 
you plan to use for sending email notifications.

 l Type a password in the Email Smtp Password field that is associated with the user name and 
email address you plan to use for sending email notifications.

 l In the Email From field, type the email address you plan to use for sending email notifications.

 l If the email server supports encryption via the secure socket layer (SSL) protocol, click to 
select the Email Enable Ssl check box.

 4. To stop or start email notifications, check to select or deselect the Disable Email Service check box.
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When the Disable Email Service check box is selected, email notifications will not be sent to any email 
recipient. When the Disable Email Service check box is deselected, email notifications will be sent 
according to the currently configured email notification schedules. The next incremental or last run 
email notifications will send data based on changes or additions since the last time the email was run.

 5. Fill out the following fields to define the email notification defaults, log retention policy, and size 
limitations:

 l Enter the desired time for sending email notifications in 12-hour time format (HH:MM AM/PM) 
in the Email Default Time field.

The default time can be overwritten when defining an email report.

 l Enter the number of days to store a copy of the email log in the Email Log Retention In Days 
field. Entries in the email log are purged from the log after the specified number of days.

The email log is stored in the database and contains information about each email that was 
sent, including recipient information, delivery mode and frequency, hierarchy assignments, 
and the actual emailed report file. A longer retention period will result in a larger database.

 l Enter the maximum email size in megabytes (MB) allowed by your email server in the Email 
Max Attachment Size In Mb field. Because some email servers are set up to process emails 
that are larger than a certain size, it may be necessary to contact your IT department for this 
information to ensure email recipients receive email notifications.

 6. Click  Save to save changes.

Set Field Computer Options

The Field Computer options provides access to property settings related to the Allegro field computer. 

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

If your company plans to use the Allegro field computer with PCS, complete the following steps to set up 
Field Computer options:
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 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-15. Options Window

 2. Click the Field Computer tab to open the Field Computer pane.
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Figure  2-16. Options - Field Computer Pane

 3. Set a previous reading limit by entering a value in the field provided. The previous reading limit 
determines the maximum number of historical readings that can be sent with any survey file. 

The number of historical readings that are sent with a survey is defined in Allegro Send options and 
cannot exceed the Previous Reading Limit value set in Options. Allowing more historical readings 
results in larger data sets sent with the Allegro or mobile device. Sending too many historical records 
may result in connection and time out problems when sending survey files.

 4. To only use the field computer or mobile device's digital voltmeter to record voltage readings, enable 
the option Require Voltage Readings By Voltmeter. Enabling this option prevents manual data entry 
of voltage readings on the Allegro.

 5. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 6. Click  Save to save changes.

Set General Options

The General options set general PCS property settings, such as display settings and general behaviors. 
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A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set property settings in the General pane of the Options window:

 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-17. Options Window

 2. Click the General tab to open the General options pane.
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Figure  2-18. Options - General Pane

 3. Check or uncheck the following option's check boxes or select from the drop downs as needed:

 l Enable Bridge Import Status Logging — click to select the check box and start capturing any 
warnings and rejections to a status log during a bridge import.

 l Disable Attached Document Preview — click to select the check box and disable the ability to 
preview attached documents within PCS. Documents can still be opened but a preview of the 
document will not show in the Preview Attached Documents window. To show a preview of 
selected documents in the Preview Attached Documents window, click to clear the check 
box. See View an Attached Document on page 215 for related information.

 l Include Unit of Measure in All Captions — click to select the check box to include the unit of 
measure in the description of column headings and field captions, such as Structure P/S 
(Volts).

 l Company Name — enter your company's name in the field provided. The company name 
appears in the header of all reports and in the system hierarchy.

 l Metric Milepost Delimiter — select a delimiter from the drop down. This delimiter is used to 
separate the kilometer from the meter when formatting mileposts in PCS.
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 l Surveyed Status Behavior — select a behavior from the drop down to determine how many of 
an inspection's required fields must be populated before a facility will be marked as Surveyed.

 — Any: a record will be marked as Surveyed as soon as one of the required fields is 
populated.

 — All: a record will only be marked as Surveyed when all of the required fields are 
populated.

You can define which PCS fields are required for an inspection by setting the System 
Inspection Surveyed Indicator status to Yes in Field and UDF Customizations. If activate is 
required for the field, the field must also be activated in the Information grid to be defined as 
required for an inspection. Refer to Set Properties in Field and UDF Customizations on page 
55 for more details about setting the System Inspection Surveyed Indicator and activate 
properties.

 l Use Date Only — click to select the check box to display only the date for date-based fields. 
Click to clear the check box to show both the date and time for date-based fields.

 l User Location Name — enter the word used by your company to refer to inspection points on 

a pipeline. Common names are Milepost or Station Number.

 l Disable Link Attachments — click to select the check box to limit attachments to embedded 
documents only. Click to clear the check box to allow documents to be attached with links.

 4. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 5. Click  Save to save changes.

Set Hierarchy Options

Hierarchy options determine how PCS organizes data in the system. 

For additional information about how to set up the PCS system hierarchy, refer to the following topics:

 l The System Hierarchy on page 14 

 l Set the System Hierarchy on page 15

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set Hierarchy property settings in Hierarchy pane of the Options window:
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 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-19. Options Window

 2. Click the General tab on the left side of the window to open the General pane.
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Figure  2-20. Options - General Pane

 3. In the Company Name field, type the name of your company.

 4. In the User Location Name field, enter an description of how your company refers to inspection 

points on a pipeline. For example, type Milepost, Station Number, Reference Reading, or 
other type of descriptor.

 5. Click the Hierarchy tab to open Hierarchy pane.
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Figure  2-21. Hierarchy Levels

 6. Select Hide Parallel Lines check box if you want to hide features in PCS that allow you to create and 
display parallel lines in the hierarchy.

When Hide Parallel Lines is enabled, parallel lines are hidden in Select ROWs and in the Add New 
Node windows. Distribution companies with no parallel lines typically use this setting. PCS identifies 
parallel lines using the Pipe, Pipeline Code, and Pipeline Name fields. For a description of these fields 
refer to  System Field Descriptions.

 7. In the Levels field, identify how many levels to include in the hierarchy. Click the down arrow and 
select the number of hierarchy levels in the selection list.  The pane updates to include level fields for 
the number of levels you selected. The example above shows the additional Level One, Level Two, 
and Level Three fields below the Levels field because 3 Levels was selected for that field.

 8. For each of the level fields below the Levels field, identify how pipelines are referred to in the system. 

For example, type ROW or Segment in the Level One field.

 9. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, see 
Public and Private Property Settings on page 19.

 10. Click  Save.
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Set Integration Options

If you plan to use Bridge to transfer data from your account on Bullhorn Web, or PCS Wireless Sync to 
securely sync field survey data to and from the PCS Field Data Collector app, ensure the Integration options 
are set first.

NOTE: Refer to the PCS Wireless Sync data sheet for PCS Wireless Sync requirements and FAQs.

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to configure settings in the Integration pane of the Options window:

 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-22. Options Window

 2. Click the Integration tab to open the Integration pane.

https://www.aiworldwide.com/uploads/common/pcs-wireless-data-sheet.pdf
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Figure  2-23. Options - Integration Pane

 3. Perform the following steps if you plan to use Bridge to transfer data from your account on Bullhorn 
Web:

 a. Verify that the correct URL 

(http://www.bullhornsys.com/BATAPI/BATAPI.svc/extract) is entered in the 
Extract Endpoint Url field. If necessary, type the correct URL in the field provided.

 b. Verify that the correct URL 

(http://www.bullhornsys.com/BATAPI/BATAPI.svc/mapping) is entered in the 
Mapping Endpoint Url field. If necessary, type the correct URL in the field provided.

 c. Click Save to save changes.

 4. Perform the following steps if you plan to use PCS Wireless Sync to securely sync field survey data to 
and from the PCSField Data Collector app:

 a. Follow the steps in PCS Wireless Sync Integration to generate and copy a cloud integration 
token in [[[Undefined variable productsInfo_ai/cn/sm.softwareName]]].

http://support.aiworldwide.com/products/cn1/content/feat_admin/pcs_integration.htm?tocpath=PCS%20Survey%20Manager%20User%20Guide%7CAdmin%20and%20Manager%20%20Functions%7C_____8
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 b. Paste the cloud integration token into the PCS Cloud Integration Token field.

 c. Click Save to save changes.

Set Reports Options

The Reports options determine which signature line caption is used. 

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set report property settings in the Reports pane of the Options window:

 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-24. Options Window

 2. Click the Reports tab to open the Reports pane.



PCS v2.5 User Guide

Chapter 2: PCS Set Up 44

Figure  2-25. Options - Reports Pane

 3. If you want to change the default setting used as the caption below the signature line in a Columnar 
report (Surveyor), type a name in the Signature Line Caption field.

 4. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, refer to 
Public and Private Property Settings on page 19.

 5. Click  Save to save changes.

Set Security Options

Security-related property settings can be configured in the Security pane of Options. 

A Public caption in this  pane indicates the associated property setting applies globally to all users and can 
only be changed by a SysAdmin.

Complete the following steps to set security options in the Security pane of Options window:
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 1. Click Tools > Options in the header bar to open the Options window.

Figure  2-26. Options Window

 2. Click the Security tab to open the Security pane.
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Figure  2-27. Options - Security Pane

 3. Review the following information and then set options as needed.

 l Use Hierarchical Security — hierarchical security allows you to assign users access rights to 
individual hierarchy folders. Assigning a user access rights to a hierarchy folders restricts 
access to the data in the other hierarchy folders. Click to select the check box to enable 
hierarchical security. Click to clear the check box to remove hierarchical security and grant all 
users access to all hierarchy folders.

 l Concurrent License Heartbeat Interval (Hours) — enter a length of time in hours to determine 
the heartbeat interval for concurrent license verification and refresh

 l Requires Windows Password — click to select the check box to require that the PCS user 
enter his or her Windows password upon opening PCS. Click to clear the check box to allow 
PCS to automatically log the user in with their Windows login credentials.

 4. (SysAdmin only) For property settings accompanied by a Private check box, check or uncheck the 
check box based on your company's requirements. When the Private check box is checked, the 
currently logged in user can change the associated property setting. For more information, refer to 
Public and Private Property Settings on page 19.

 5. When you finish, click  Save to save changes.
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Custom Security Roles

Custom security roles are an optional feature in PCS that is setup by the PCS administrator. The security 
feature allows you to grant or deny user access to PCS menus and menu commands as well as data entry 
fields. 

Security Role Management window is used to add and edit a custom security role. A custom security role is 
a named set of permissions based on your company's business requirements. You create a custom 
security role using a Parent Role as a template and then modify permissions in the custom security role as 
needed. Roles include permissions for menu-level items (File, Modules, Data Entry, Report/Graphs, Tools, 
and Field Computer) as well as field-level items (Facility Surveys, Continuous Surveys, and ROW and 
Pipeline).

A Parent Role is a PCS installed security role with predefined permissions that cannot be modified. Parent 
roles include the SysAdmin, User, and Read Only security roles. After creating a custom security role based 
on a parent role, you can then assign it to a PCS user who was set up in User Management.

This chapter  includes the following topics:

 l Add a Custom Security Role on page 47

 l Use Copy to Add a Custom Security Role on page 49

 l Edit a Custom Security Role on page 51

 l   Delete a Custom Security Role on page 54

Also refer to Assign a Custom Security Role to a User on page 168 for instructions on how to assign a 
security role to a user.

A Search box is available above the Display Name column to allow you to quickly find a command name. 

To adjust the width of a column, hover over the dividing line between columns until the cursor changes to 
 . Click and drag the cursor until the column has expanded to the desired width.

Add a Custom Security Role

Complete the following steps to add a custom security role:

 1. Click Tools > Security Role Management in the header bar to open the Security Role Management 
window.



PCS v2.5 User Guide

Chapter 2: PCS Set Up 48

Figure  2-28. Security Role Management

Fields that are unavailable for this role contain the  icon.

 2. Click  Add to open the Add Security Role window.

Figure  2-29. Add Security Role

 3. Select a Parent Role to use as a template to create the custom security role. Click the down arrow in 
the Parent Role field and select a PCS installed security role in the selection list.
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Figure  2-30. Parent Role Drop-down List

 4. Type a name for the custom security role in the Name field. Fields marked with  are required.

 5. If desired, type a description for the custom security role in the Description field.

 6. Click  OK to save changes and return to Security Role Management window. 

NOTE: OK does not become active until all fields have been completed.

The information you entered in the Add Security Role window for the custom security role displays in 
the Parent Role, Role, and Description fields. 

 

Figure  2-31. New User Information   

 7. Repeat these steps as needed to add additional custom security roles. To make changes to the 
custom security role's permissions, refer to Edit a Custom Security Role on page 51.

Use Copy to Add a Custom Security Role

When you want to add a custom security role with permissions that are slightly different than those in an 
existing customer security role, use the Copy command to copy permissions from the existing custom 
security role.

Complete the following steps to add a custom security role using the Copy command:

 1. Click Tools > Security Role Management in the header bar to open the Security Role Management 
window.
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Figure  2-32. Security Role Management

Fields that are unavailable for this role contain the  icon.

 2. Click  Copy to open the Copy Security Role window.

Figure  2-33. Copy Security Role

 3. Click the down arrow in the Parent Role field and select the parent role associated with the existing 
custom security role.

 4. Click the down arrow in the Role field and select the existing custom security role with permissions 
you want to copy to the new custom security role.

 5. Type a name for the new custom security role in the Name field. Fields marked with  are required.

 6. If desired, type a description for the custom role in the Description field.

 7. Click OK to save changes and return to Security Role Management window. 
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NOTE: OK does not become active until all fields have been completed.

 8. Repeat these steps as needed to copy additional custom security roles. To make changes to the 
custom security role's permissions, refer to Edit a Custom Security Role.

Edit a Custom Security Role

Compete the following steps to edit permissions in a custom security role:

 1. Click Tools > Security Role Management in the header bar to open the Security Role Management 
window.

Figure  2-34. Security Role Management

Fields that are unavailable for this role contain the  icon.

 2. Click the down arrow in the Role field and select a custom security role in the selection list.

If the custom security role is not visible in the selection list, click the down arrow in the Parent Role 
field and select a user role. Then select the custom security role in the Role field.

 3. Click  Edit. 

The permissions grid updates to display editable check boxes in place of check marks and  icons. 
A disabled check box indicates that the specific menu item or field is not available for customization 
for the current role. A shaded check box indicates selection of some, not all, child menu or field 
options.
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Figure  2-35. Security Role Management - Edit Role

 4. The text in the Name and Description boxes can be edited by deleting and re-typing. You can also 
use Ctrl-Z to undo a change.

 5. To edit menu permissions for the custom security role, click the Menu Edit tab and use any of the 
following methods to grant or deny access to menu options:

 l To grant access to all menu options available to the current security role, click  All.

 l To deny access to all menu options, click  None.

 l To grant access to all options available to the current security role in a menu listed in the 
Display Name column, click the adjacent check box to place a check mark inside the check 
box.

If an option within the selected menu is unavailable for the current role, that option will revert to 
its original value upon save and the check box for the menu will become shaded.

 l To deny access to an entire menu listed in the Display Name column, click the adjacent check 
box to remove the check mark inside the check box.

 l To grant or deny access to individual options within a menu command, click the arrow next to 
the main menu name to expand the list.
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Figure  2-36. Expanded Item in Display Name Column

Grant or deny access to the expanded list:

 — To grant access to a specific option listed in the Display Name column, click the 
adjacent check box to place a check mark inside the check box.

 — To deny access to a specific option listed in the Display Name column, click the 
adjacent check box to remove the check mark inside the check box.

 6. To edit field permissions for the custom security role, click the Fields Edit tab.

Figure  2-37. Fields Edit Tab



PCS v2.5 User Guide

Chapter 2: PCS Set Up 54

Grant or deny access to specific fields:

 l To grant access to all menu options available to the current security role, click  All.

 l To deny access to all menu options, click  None.

 l To grant or deny access to individual fields, find the desired field by clicking the arrow(s) next to 
the category name(s) to expand the list.

Figure  2-38. Fields Edit - Expanded

Grant or deny access to the expanded list:

 — To grant access to a field, click the adjacent check box to place a check mark inside the 
check box.

 — To deny access to a field, click the adjacent check box to remove the check mark inside 
the check box.

 7. Click  Save to save changes.

To assign a custom security role to a user previously set up in User Management, refer to Assign a Custom 
Security Role to a User on page 168.

  Delete a Custom Security Role

Compete the following steps to delete a custom security role:

 1. Click Tools > Security Role Management in the header bar to open the Security Role Management 
window.
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Figure  2-39. Security Role Management

Fields that are unavailable for this role contain the  icon.

 2. Click the down arrow in the Parent Role field and select the parent role associated with the custom 
security role you want to delete.

 3. Click the down arrow in the Role field and select the custom security role you want to delete.

 4. Click  Delete. A Confirm Delete window displays.

Figure  2-40. Confirm Delete Window

 5. Click  Yes to delete the custom security role and set users tied to this role to the PCS installed role 

or  No to cancel the operation.

Set Properties in Field and UDF Customizations

Use Field and UDF Customizations to modify property settings for certain PCS installed fields and add one 
or more user-defined fields (UDFs) when PCS does not provide a specific field for data entry.

Information in this section explains how to use the most common features of Field and UDF 
Customizations. Topics include those in the following list:
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 l Navigate Field and UDF Customizations

 l Edit a PCS Installed Layout Theme on page 57

 l Add a Layout Theme Addition on page 60

 l Rename Field Captions on page 64

 l Set Up Range Checking for Inspection Fields on page 68

 l Set Up Change Tracking for Individual Fields on page 70

 l Add User Defined Fields on page 73

Navigate Field and UDF Customizations

The selection tree in the Properties pane of Field and UDF Customizations window includes three main 
categories labeled Facility Surveys, Continuous Surveys, and ROW and Pipeline. Each of these categories 
includes related items for selection. For example, items for selection in Facility Surveys are based on 
module and data grid. Items for selection in Continuous Surveys are based on data grid and the various 
continuous survey types.

When you select an item in the selection tree,  a list of related fields and property settings displays in the 
adjacent grid. The grid layout includes columns, rows and cells similar to a spreadsheet. Grid columns at 
the top of the grid identify the names of the various properties you can set up for a field. Each grid row 
contains property settings for a specific field, such as Casing IRF shown in the following figure. When a 
property setting is shaded gray or includes the label N/A (not applicable), this indicates the setting cannot 
be modified.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the grid. Click 
the bar again to expand the Properties pane.
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Figure  2-41. Field and UDF Customizations

Edit a PCS Installed Layout Theme

A layout theme is a named set of fields that are present in the grid when working in Field and UDF 
Customizations. PCS includes two types of layout themes: installed and addition. 

An installed layout theme is one that has been installed during the PCS software installation, such as [PCS] 
All Fields. 

An addition layout theme is one that you create.

The following procedure explains how to complete the following tasks to edit a PCS installed layout theme:

 l add and remove fields in an installed layout theme

 l revert an installed layout theme

 l save changes as a new baseline installed layout theme

Compete the following steps to edit, revert, and save a PCS installed layout theme:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-42. Field and UDF Customizations

 2. Click  Customize to open the Column Selections window.
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Figure  2-43. Column Selections Window

 3. Click the down arrow in the Select Layout Theme field and select a theme in the selection list, such as 

 [PCS] All Fields.

By default all fields are included in the [PCS] All Fields layout theme. If you want to clear all fields listed 

in the right pane and subsequently remove them from the layout theme, click  Toggle Select. If you 
click the button again, all fields are moved to the right pane and added in the layout theme.

 4. To add or remove one or more fields in the layout theme, complete one of the following steps:

 a. To add a field in the left pane to the right pane, select the field and click the   button  to 
move the field to the right pane. You can also click in the check box to add a check mark to the 
field (if it is not already checked). This will automatically add the field to the right pane.

The grid layout theme includes all fields listed in the right pane  of the Column Selections 
window.

 b. To remove a field in the right pane, select a field in the right pane and then click the   
button.
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 5. Click  Save to save changes. The Column Selections window closes.

 6. To revert an installed theme and restore settings prior to editing, open the Column Selections 
window and click  Revert. Click Yes when the Confirm Revert message displays.

Figure  2-44. Confirm Revert Message Window

 7. To save current changes as new baseline settings, click  New Baseline. When future changes are 
made and then reverted, PCS restores the theme with baseline settings.

Add a Layout Theme Addition

Adding a layout theme allows you to choose which fields to include in the grid and then save the new layout 
as a theme for later use.

Complete the following steps to add a grid layout theme:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-45. Field and UDF Customizations

 2. Click  Customize to open the Column Selections window.
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Figure  2-46. Column Selections

 3. Click  Add to open the New Layout Theme window.
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Figure  2-47. New Layout Theme

 4. Type a name for the layout theme in the field Enter Theme Name. 

 5. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. If you do not select Public, the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it. Also, only public themes will be available for 
selection for layouts, sorts, or reports.

 6. Select a layout theme from the Copy Fields From Theme field. The fields in the selected theme 
display in the box below Fields in the Selected Theme.
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 7. Click  Save to save changes and return to the Column Selections window.

 8. If you want to clear all fields listed in the right pane of the Column Selections window and 

subsequently remove them from the grid, click  Toggle Select. Clicking the button again moves all 
fields to the right pane and adds them in the grid.

 9. Choose which fields to include in the layout theme. Select a field in the left pane and then click the 

 button to move the field to the right pane. Repeat this step as needed. You can also click in the 
check box to select the field and move it to the right pane.

Figure  2-48. Column Selections

 10. If you want to remove a field in the layout theme, select a field in the right pane and then click the  
button.

The grid layout theme includes all fields listed in the right pane of the Column Selections window.

 11. Click  Save to save changes and return to the Field and UDF Customizations grid.

Rename Field Captions

You can rename many of the original PCS field captions with a caption that is more familiar to users in your 
company.
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NOTE: Only users with SysAdmin user permissions can rename field captions.

Complete the following steps to rename a field caption:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

 2. Select an item in the Properties pane to display related fields and property settings in the grid.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.

Figure  2-49. Field and UDF Customizations

 3. Place your cursor in the Caption grid column and edit the name as desired.
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Figure  2-50. Renaming a Field Caption

When you click out of the field, the new Caption name is automatically placed in alphabetical order 
with the other fields and the name is no longer italicized.

Return a Field Caption to the Original Name

A Caption name that had been renamed can be restored to its original name.

NOTE: Only users with SysAdmin user permissions can rename field captions.

Complete these steps to return a field caption to the original name:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

 2. Select an item in the Properties pane to display related fields and property settings in the grid.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-51. Field and UDF Customizations

 3. Place your cursor in the Caption grid cell of the renamed caption and delete the name.

Figure  2-52. Renaming a Field Caption

When you click out of the field, the original Caption name is automatically restored, and the grid is re-
alphabetized.
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Figure  2-53. Original Caption Restored

Set Up Range Checking for Inspection Fields

Range checking is the acceptable range of values allowed for data entry in an inspection field.

Setting up range checking allows PCS to alert the user when an incorrect value has been entered in an 
inspection field. For example, if the acceptable range of values is in a range of -10 to 0, and the user enters a 
value that is outside this range, a warning message will display. The user can then correct the invalid entry. 
Data entry errors are less likely to occur when inspection fields are set up with range checking.

Settings are applied system-wide when range checking is set up for an inspection field in Field and UDF 
Customizations. You can also set up range checking at the facility level using the minimum/maximum fields 
available in the Information and Inspections data entry grid. Range checking at the facility level overrides 
range checking at the system level.

Complete the following steps to set up range checking for an inspection field:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

 2. If the System – Default Minimum Range and System – Default Maximum Range (in red) columns are 
not included in the grid, modify the layout theme to include these columns. Refer to Edit a PCS 
Installed Layout Theme.

 3. Select an item in the Properties pane that includes the inspection field you want to set up for range 
checking.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-54. Field and UDF Customizations

 4. In the grid, select the inspection field you want to set up for range checking.

Figure  2-55. System - Default Minimum and Maximum Range

 5. Type a minimum range value in the field labeled System–Default Minimum Range for the selected 
field.
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 6. Type a maximum range in the field labeled System–Default Maximum Range field for the selected 
field.

 7. If you want to set up another inspection field with range checking, repeat these steps. 

 8. When finished,  close the Field and UDF Customizations window.

Set Up Change Tracking for Individual Fields

If enabled in the Options window (Tools > Options), PCS keeps a record of all changes made to PCS data. 
The Field and UDF Customizations window allows you to specify which tables or fields will have their 
changes tracked if change history is enabled in PCS. By default, all fields are set to track changes when 
change history is enabled.

Refer to Set Editing Options for more information on setting Change Tracking.

Modifications to an individual field's change tracking status is not meant to be made while PCS is in use by 
general users. A field becomes locked while its change history setting is modified in Field and UDF 
Customizations window. That is, users are prevented from adding, modifying, or deleting data that contains 
the field. For this reason, it is recommended that change tracking configurations are made during the initial 
configuration of PCS or while performing system maintenance.

Complete the following steps to determine whether changes to an individual field are recorded:



PCS v2.5 User Guide

Chapter 2: PCS Set Up 71

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-56. Field and UDF Customization Window

 2. Select an item in the Properties pane to display related fields and property settings in the grid.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-57. Field and UDF Customizations

 3. If the Enable Change History column is not visible in the grid, use the slide bar at the bottom to move 
the columns until the Enable Change History is visible.

Figure  2-58. Grid Slider

 4. Select the field you want to set up for change tracking.

 5. In the Enable Change History column, select Yes to track changes made in the selected field while 
change history is enabled. Select No to not record any changes made in the field, even if change 
history is enabled in the Options window.
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Figure  2-59. Enabling Change Tracking

 6. Repeat these steps  for any additional fields. Your changes are saved when you close the Field and 
UDF Customizations window.

 7. If change history is already enabled in the Options window, disable change history in Options and 
then re-enable change history to implement the new change tracking set up. For more information 
about enabling change history in Options, refer to Set Editing Options on page 25.

Add User Defined Fields

A user defined field (UDF) is a field you create when PCS does not provide a field for data entry. The 
following types of UDFs can be added:

 l Normal— set up a normal UDF when you want to add any of the following types of fields: character, 
numeric, date, logical, memo, or date/time field.

 l Calculated— set up a calculated UDF when you want PCS to perform calculations based on 
expressions you set up for the UDF.

 l Milepost— set up a Milepost UDF when you want to assign a different milepost format to one or more 
facility types on a pipeline.

 l Standard Picklist— set up a Standard Picklist UDF when you want to limit data entry to a list of valid 
choices in a selection list. (A Standard Picklist in PCS is similar to a validation table in PCS 7.)

 l Dynamic Picklist — set up a Dynamic Picklist with a drop-down list of data items that change based 
on a data item selected in another picklist. This type of picklist uses a cascading parent/child 
relationship allowing you to set up more than five levels of interdependent picklists.
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 l On/Off Pair — set up a custom pair of on/off fields when PCS does not provide a pair of installed 
on/off fields for recording inspection readings in a data grid or form. This UDF is available for both 
facility and continuous surveys.

 l Summation — set up a Summation UDF when you want PCS to perform an aggregation for a 
selected Information, Inspection, or Maintenance field. This UDF type supports aggregation on a 
user-selected target field using any one of the following operators: Average, Count, Latest, 
Maximum, Minimum, and Sum. You can also include one or more user-defined filters in the set up of 
the UDF to further filter the results of aggregated data. Summation UDF is a Permanent Information 
field available for use in data grids, forms, reports, and as a filter in scheduling.

If change tracking is configured for your database, review the change tracking configurations after adding a 
user defined field to ensure that the desired settings were applied to the new field. Refer to Track Data 
Changes on page 896.

This chapter  includes the following topics:

 l Add a Normal User Defined Field on page 74

 l Add a Calculated User Defined Field on page 79

 l Add a Milepost User Defined Field on page 89

 l Add a Standard Picklist User Defined Field on page 93

 l Set Up a Data Entry Field as a Standard Picklist on page 101

 l Add a Dynamic Picklist User Defined Field on page 107

 l Edit a Standard or Dynamic Picklist on page 124

 l Add an On/Off Pair User Defined Field on page 127

 l Summation User Defined Fields on page 132

Add a Normal User Defined Field

Complete the following steps to set up a normal user defined field (UDF) for common data entry:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-60. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-61. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-62. Field and UDF Customizations

 4. Click  Normal in the toolbar to open the Add Normal Field window.

Figure  2-63. Add Normal Field

 5. Type a unique name for the UDF in the Caption field.

 6. Select the type of field you want to add from the Data Type drop-down field and select one of the 
following options:
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 l Character— supports characters such as A, B, and C. This data type can be used for both 
character and numeric data. If you plan to use mixed data, such as a number and a character 
or dash, define the data type as a character. If you plan to create a picklist for the UDF, use the 
Character data type. For more information about picklists, see Add a Standard Picklist User 
Defined Field on page 93.

 l Numeric— supports values such as 1, 2,  3, and numeric values that use formats such as 
999.999 or –99.999.

 l Date— supports a date format using MM/DD/YYYY (month, day, year), such as 11/12/2012.

 l Logical— supports a yes/no selection in the form of a check box to enable or disable an option 
in the data entry grid.

 l Memo— supports more than 255 characters and carriage returns.

 l DateTime2— supports a date and time format using HH:MM:SS (hours, minutes, seconds) 
and MM/DD/YYYY (month, day, year), such as 11:15:45, 12/11/2012.

 l Integer— supports a positive or negative whole number or zero, such as -2, 4, 123, and 
3,245.

 7. If you selected either the Character or Numeric data type, set the length of the field by typing the 
number of characters required for the UDF in the Width field.

Clicking the up arrow in the Width field increases the value; clicking the down arrow decreases the 
value.

 8. If you selected the Numeric data type, set the number of decimal places required for the UDF by 
typing a value in the Decimals field.

 9. If you selected the Numeric data type and want to set up range checking for the UDF, click the Range 
Checking option and then type a minimum and maximum value in the respective fields.
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Figure  2-64. Add Normal Field Window - Numeric Data Type

Range checking is the acceptable range of values allowed for data entry in a field. Setting up range 
checking allows PCS to alert the user when an incorrect value has been entered.

 10. Click  Save to close the window and return to the Field and UDF Customizations window.

The UDF is now available for adding in a data entry grid. 

If needed, refer to Themes and Filter Groups on page 368 for information about how to add fields in a data 
entry grid.

Add a Calculated User Defined Field

Set up a calculated user defined field (UDF) when you want to include an expression for a specific 
calculated outcome. Calculated fields are read-only.

Complete the following steps to add a calculated UDF:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-65. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-66. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-67. Field and UDF Customizations

 4. Click   Calculated in the toolbar to open the Add Calculated Expression window.     

Figure  2-68. Add Calculated Expression     

 5. Type a unique name for the field in the Caption field. 

 6. Select a data type from the Data Type drop-down field.
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Figure  2-69. Add Calculated Expression - Data Type

 7. If you selected either the Character or Numeric data type, set the length of the field by typing the 
number of characters required for the field in the Width field. Clicking the up arrow in the Width field 
increases the value; clicking the down arrow decreases the value.     

 8. If you selected the Numeric data type, set the number of decimal places required for the field by      
typing a value in the Decimals field. Decimals refer to the number of digits      that will be shown to the 
right of the decimal point.       

Numeric fields will have the width and/or decimal values displayed next to the field type in the Field      
Definition column. For example, a numeric field with a width of 4 and decimal value of 3 will display as      

Numeric (4,3).      

WARNING: Once the width and decimal values have been set and saved for a calculated field,      they 
cannot be edited. 

 9. Define the expression. Calculations can be creating in either a simple mode or a more advanced      
mode. The simple mode can be used for simple calculations, while the advanced mode can be used 
for more      complex calculations with one or more operators and/or functions. The following steps 
describe how to create a calculated expression in either of the modes.
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 l Simple Mode — to create a calculated field in simple mode:

 a. Select a field from the list shown in the left pane that will be used first in the calculation  
and double-click the name to add it to the Left Operand field.  You can also type a value 
in the Left Operand field.

Figure  2-70. Left Operand Field

 b. Select an operator from the  Operator drop-down field.
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Figure  2-71. Operator

 c. Select a field from the list shown in the right pane that will be used after the operator and 
double-click the name to add it to the Right Operand field.  You can also type a value in 
the field.
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Figure  2-72. Right Operand

 l Advanced Mode — to create a calculated field in advanced mode:
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 a. Click  Switch To Advanced Mode.

Figure  2-73. Add Calculated Expression (Advanced Mode)

 b. Define the field's calculation in the Expression field by adding fields from the list of fields 
and the operator and function buttons. You can also type values in the Expression field. 
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Figure  2-74. Add Calculated Expression - Advanced Mode

 10. Click  Save to save the new field and close the window. The field is now included in the Field and 
UDF Customizations window grid.
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Figure  2-75. Completed Calculated User Defined Field

Add a Milepost User Defined Field

Set up a milepost user defined field (UDF) when you want to assign a different milepost format to a facility 
type on a pipeline. For example, if coupons require a different milepost format than other facility types on a 
pipeline, set up a milepost UDF and then assign the UDF at the facility type level in the Facility Location ID 
Formats mini-grid of Edit ROW Detail (Data Entry > Edit ROW Detail).

Complete the following steps to add a milepost UDF:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-76. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-77. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-78. Field and UDF Customizations

 4. Click  Milepost in the toolbar to open the Add Milepost Field window.

Figure  2-79. Add Milepost Field

 5. Type a unique name for the UDF in the Caption field.

 6. Select a milepost format from the  Milepost Formats drop-down field.
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Figure  2-80. Milepost Format Drop-down

 7. Click  Save to close the window and return to the Field and UDF Customizations window.

The UDF is now available for selection in the Facility Location ID Formats mini-grid of Edit ROW Detail. Refer 
to  Pipeline Records on page 171 for more information.

Add a Standard Picklist User Defined Field

A Standard Picklist is a list of acceptable choices for a field in a data entry grid that a user selects from when 
entering data. This feature improves data consistency and accuracy by allowing users to select from a list of 
predefined choices instead entering data manually.

A Standard Picklist contains a list of valid items for selection, a description of each item, and a value 
assigned to each item that determines the sorting order of items in the list.

Refer to Add a Dynamic Picklist User Defined Field for more information on setting up a Dynamic Picklist.

NOTE: A Standard Picklist in PCS is similar to a validation table in PCS 7.x.

Complete the following steps to add a Standard Picklist user defined field (UDF):
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-81. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-82. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-83. Field and UDF Customizations

 4. Click  Picklist in the toolbar to open the Select Picklist Type window.

Figure  2-84. Select Picklist Type

 5. Click Standard radio button.

 6. Click  OK. The Select Picklist Type window closes, and a Add Picklist Field window opens.
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Figure  2-85. Add Picklist Field Window

 7. Type a unique name for the UDF in the Caption field.
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Figure  2-86. Add Picklist Field

 8. Set the length of the field by typing the number of characters required for the UDF in the Width field.

Clicking the up arrow in the Width field increases the value; clicking the down arrow decreases the 
value.

 9. Select an option from the Cell Style field drop-down for how the  UDF field will display in data entry 
grids. The options include:

 l Show Value — displays the assigned value of the selected item in the picklist.

 l Show Description — displays the description of the selected item in the picklist.

 l Show Value And Description — displays the assigned value and description of the selected 
item in the picklist.

 l Show Description And Value — displays the description and assigned value of the selected 
item in the picklist.

 10. Select and option from the Dropdown Style drop-down field for how items will display in the picklist. 
The options include:
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 l Show Value — displays only the assigned value of items in the picklist.

 l Show Description — displays only the description of items in the picklist.

 l Show Value And Description — displays the assigned value and description of items in the 
picklist.

 l Show Description And Value — displays the description and assigned value of items in the 
picklist.

 11. Select and option from the Validation Order drop-down field for how items  in the picklist will be 
sorted. The options include:

 l Value — sorts items numerically based on values assigned to items in the picklist.

 l Description — sorts items alphanumerically based on the description of items in the picklist.

 l Defined — sorts items based on the order of items listed in the Customize Picklist window.

 12. If you want the UDF to support multiple selections in the picklist, click the check box Allow Multiple 
Selections.

 13. If you want the UDF to allow data entry of other data in addition to picklist items for selection, click the 
check box Allow Other Entry.

 14. To add picklist items for selection:
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 a. Click the message Click here to add new row to add an empty row of fields for data entry.

Figure  2-87. Add Picklist Field

 b. Type a value in the Value field to associate a code number with the picklist item. They type a 
description for the picklist item in the Description field. You can press Tab to move to the 
Description field.

 c. Press Enter on the keyboard to add another empty row of fields for data entry.

 d. Repeat   as needed until all picklist items have been added. 

 e. To reorder the items in the list, use the  and  buttons. These buttons become active 
after items have been added to the grid.
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Figure  2-88. Add Picklist Field - List of Items and Reorder Buttons

 f. When finished, click  Save to close the window and return to the Field and UDF 
Customizations window.

 

The UDF is now available for adding in a data entry grid. 

If needed, refer to Themes and Filter Groups on page 368 for information about how to add fields in a data 
entry grid.

Set Up a Data Entry Field as a Standard Picklist

A Standard Picklist is a list of acceptable choices for  a data entry grid field. A user selects one of these 
choices when entering data into the field. This feature improves data consistency and accuracy by allowing 
users to select from a list of predefined choices instead entering data manually.

For example, setting up a picklist with valid repair codes or status conditions allows users to choose from a 
list of valid items instead of typing information to describe the repair status or condition of a facility test 
station or pipeline.

A Standard Picklist contains a list of valid items for selection, a description of each item, and a value 
assigned to each item that determines the sorting order of items in the list.
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NOTE: A Standard Picklist in PCS is similar to a validation table in PCS.

Complete the following steps to set up a data entry field as a Standard Picklist:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-89. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-90. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-91. Field and UDF Customizations

 4. Use the horizontal scroll bar near the bottom of the grid to display the  Grids – Picklist Definition grid 
column. 

Figure  2-92. Field and UDF Customizations - Grids - Picklist Definition

 5. Select the data entry field you want to set up as a Standard Picklist. 
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Figure  2-93. Convert To Picklist

 6. Click the edit icon  in the Grids - Picklist Definition cell for the selected data entry field. 

When a data entry grid includes existing data for the data entry field you want to convert to a 
Standard Picklist, PCS displays a message to notify you of the number of affected records. You can 
either click Yes in the message to continue converting the field to a Standard Picklist or No to cancel 
the operation. Selecting Yes allows PCS to use existing data as valid items for selection in the 
Standard Picklist. 

Figure  2-94. Merge a Picklist
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If you decide later you want to convert the Standard Picklist to a normal data entry field, click the  
revert icon and then click Yes when a confirmation message displays. PCS then re-populates 
affected fields in the data entry grids with unaltered data that was available prior to the field 
conversion.

 7. Use the  merge icon merge picklist items as needed. In the Merge Picklist Items window, move 
items from the left pane to merge them with items in the right pane and click   Save when finished.

Figure  2-95. Merge Picklist Items Window

 8. Edit picklist items in the Edit Picklist Field window.
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Figure  2-96. Edit Picklist Field

Refer to Add a Standard Picklist User Defined Field for descriptions of the different options and how 
to add list items.

 9. Click  Saveto save changes and close the Edit Picklist Field window.

The UDF is now available for adding in a data entry grid. If needed, refer to Themes and Filter Groups on 
page 368 for information about how to add fields in a data entry grid.

For information about how to edit a picklist refer to Edit a Standard or Dynamic Picklist on page 124.

Add a Dynamic Picklist User Defined Field

The information in this section is intended for the PCS SysAdmin or a user with SysAdmin user permissions.

A Dynamic Picklist UDF is a dynamic drop-down list with data items that change based on a data item 
selected in another picklist. This dependency uses a cascading parent/child relationship. For example, 
selecting a data item in the drop-down list of picklist A (parent) determines which data items are available for 
selection in the drop-down list of picklist B (child).

Dynamic Picklists are helpful to users when entering data in a data grid or form. It allows for easier and more 
accurate data entry.
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Building a Dynamic Picklist allows you to control the data entered in a field by limiting the choices to those in 
a pre-defined list. For example, instead of a user typing a lengthy description for sub-station locations 
throughout the country, you might want to build a Dynamic Picklist with a parent picklist named My Sub-
Station Type that includes three associated child picklists labeled My Sub-Station State, My Sub-Station 
County, and My Sub-Station City. Each of these are dependent upon the other and form the Dynamic 
Picklist.

Building a Dynamic Picklist is a 2-part process. You begin with creating the initial parent picklist as a 
Standard Picklist and then add and map one or more child Dynamic Picklists. Once this process is 
complete, you can then add the parent and child picklists in data entry grids/forms, reports, and prompts 
sent to the Allegro Field Computer or other mobile devices.

Topics in this section explain how to add and edit a Dynamic Picklist. They include those in the following list:

 l Add the Initial Parent Picklist on page 108

 l Add a Child Picklist and Mapping Data Items on page 116

As an example to demonstrate how to build a Dynamic Picklist, information in this section uses a 2-level 
Dynamic Picklist with My Pipeline State as the initial parent picklist and My Pipeline County as the 
associated child picklist. Although Dynamic Picklists support an unlimited number of child picklists, the 
example uses one for clarity purposes. The process for adding multiple child picklists is the same as adding 
one child picklist.

Add the Initial Parent Picklist

Complete the following steps to add the initial parent picklist:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-97. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-98. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-99. Field and UDF Customizations

 4. Click  Picklist in the toolbar of the Field and UDF Customizations window to open the Select 
Picklist Type window.

Figure  2-100. Select Picklist Type

 5. Click Standard and then click  OK to close the window. A Add Picklist Field window opens.
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Figure  2-101. Add Picklist Field

 6. Type a unique name for the parent picklist in the Caption field.

 7. Type a value in the Width field to indicate the number of characters to allow in the name of the parent 
picklist. You can alternatively use the up/down arrows to select a value. Clicking the up arrow 
increases the value; clicking the down arrow decreases the value.

 8. Select an option from the Cell Style drop-down list for how the  UDF field will display in data entry 
grids. The options include:

 l Show Value — displays the assigned value of the selected item in the picklist.

 l Show Description — displays the description of the selected item in the picklist.

 l Show Value And Description — displays the assigned value and description of the selected 
item in the picklist.

 l Show Description And Value — displays the description and assigned value of the selected 
item in the picklist.
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 9. Select and option from the Dropdown Style drop-down list for how items will display in the picklist. 
The options include:

 l Show Value — displays only the assigned value of items in the picklist.

 l Show Description — displays only the description of items in the picklist.

 l Show Value And Description — displays the assigned value and description of items in the 
picklist.

 l Show Description And Value — displays the description and assigned value of items in the 
picklist.

 10. Select and option from the Validation Order drop-down list for how items  in the picklist will be sorted. 
The options include:

 l Value — sorts items numerically based on values assigned to items in the picklist.

 l Description — sorts items alphanumerically based on the description of items in the picklist.

 l Defined — sorts items based on the order of items listed in the Customize Picklist window.

 11. Ensure that the Allow Multiple Selections and Allow Other Entry check boxes are deselected. These 
options do not apply to parent picklists for Dynamic Picklists.

 12. Complete the following steps to add data items that will be available for selection in the drop-down 
list of the parent picklist.

The following figure shows an example of a data item labeled OK-1 Oklahoma, which will be available 
for selection in the parent picklist, My Pipeline States. Data items are set up later as child picklists in 
Add a Child Picklist and Mapping Data Items.
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Figure  2-102. Add Picklist Field
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 a. Click the message Click here to add a new row to add an empty row of fields for data entry.

Figure  2-103. Add Picklist Field - Adding Picklist Items

 b. Associate a code with the name of the data item (child picklist). Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description for the data item 
(child picklist) in the Description field.

 c. Press Enter  to add another empty row of fields for data entry.

 d. Repeat as needed for all items in the picklist.

 e. To reorder the items in the list, use the  and  buttons. These buttons become active 
after items have been added to the grid.
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Figure  2-104. Add Picklist Field - List of Items and Reorder Buttons

 f. When finished adding all items, click  Save to close the window and return to the Field and 
UDF Customizations window.

PCS adds the parent picklist in the list of other fields in the Field and UDF Customizations window.

To add child picklists and map the necessary data items, refer to Add a Child Picklist and Mapping Data 
Items.

Add a Child Picklist and Mapping Data Items

Complete the following steps to add a child picklist and then map data items in the child picklist to data 
items in a parent picklist:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-105. Field and UDF Customization Window

 2. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-106. Field and UDF Customizations

 3. Click  Picklist in the toolbar of the Field and UDF Customizations window to open the Select 
Picklist Type window.

Figure  2-107. Select Picklist Type

 4. Click Dynamic and then select a parent picklist that you want to associate with the child picklist from 
the drop-down field. 
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Figure  2-108. Select Picklist Type - Dynamic

 5. Click OK. The Select Picklist Type window closes, and a Add Picklist Field window opens.

Figure  2-109. Add Picklist Field Window

 6. Type a unique name for the UDF in the Caption field.
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Figure  2-110. Add Picklist Field

 7. Set the length of the field by typing the number of characters required for the UDF in the Width field.

Clicking the up arrow in the Width field increases the value; clicking the down arrow decreases the 
value.

 8. Select an option from the Cell Style drop-down list for how the  UDF field will display in data entry 
grids. The options include:

 l Show Value — displays the assigned value of the selected item in the picklist.

 l Show Description — displays the description of the selected item in the picklist.

 l Show Value And Description — displays the assigned value and description of the selected 
item in the picklist.

 l Show Description And Value — displays the description and assigned value of the selected 
item in the picklist.

 9. Select and option from the Dropdown Style drop-down list for how items will display in the picklist. 
The options include:
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 l Show Value — displays only the assigned value of items in the picklist.

 l Show Description — displays only the description of items in the picklist.

 l Show Value And Description — displays the assigned value and description of items in the 
picklist.

 l Show Description And Value — displays the description and assigned value of items in the 
picklist.

 10. Select and option from the Validation Order drop-down list for how items  in the picklist will be sorted. 
The options include:

 l Value — sorts items numerically based on values assigned to items in the picklist.

 l Description — sorts items alphanumerically based on the description of items in the picklist.

 l Defined — sorts items based on the order of items listed in the Customize Picklist window.

 11. To add picklist items for selection:

 a. Click the message Click here to add new row to add an empty row of fields for data entry.

Figure  2-111. Add Picklist Field
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 b. Type a value in the Value field to associate a code number with the picklist item. They type a 
description for the picklist item in the Description field. You can press Tab to move to the 
Description field.

Figure  2-112. Add Picklist Field - List of Items and Reorder Buttons

 c. Click the  parent picklist icon to open the  Select Parent Picklist Values window.
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Figure  2-113. Select Parent Picklist Values

 d. Map a data item in the parent picklist to the currently selected data item in the child picklist. 

Select a value in the right pane and then click the  button to move it to the right pane.

Figure  2-114. Mapping Picklist Values

 e. When finished, click  Save to save settings and close the window.
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 f. Repeat these steps to add additional data items in the child picklist.

 12. When you finish adding and mapping all data items in the child picklist, click  Save to close the 
window and return to the Field and UDF Customizations window.

The process for adding a Dynamic Picklist UDF is now complete. You can add the Dynamic Picklist (parent 
and child picklist fields) in the layout theme of a data grid, form, or report, as well as in a prompt theme for 
prompts sent to the Allegro or mobile device. Refer to Themes and Filter Groups on page 368 for 
information. For information about editing a picklist, refer to Edit a Standard or Dynamic Picklist on page 
124.

Edit a Standard or Dynamic Picklist

After creating an standard or dynamic picklist, you may edit these picklists to add, delete, or edit the item 
information. 

Complete the following steps to edit either a standard or a dynamic picklist:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-115. Field and UDF Customization Window

 2. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 
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NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.

Figure  2-116. Field and UDF Customizations

 3. Select the picklist UDF you want to work with in the grid of the Field and UDF Customizations 
window.

Figure  2-117. Selected Picklist UDF on Grid
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 4. To delete the picklist UDF, click  Delete in the toolbar of the Field and UDF Customizations 

window. Then click  Yes if the Confirm Delete window.

 5. To delete, edit, or add data items in a picklist UDF, slide the scroll bar at the bottom of the grid until 
the Grids - Pick List Definition column displays. 

Figure  2-118. Edit Icon for Selected Picklist UDF
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 a. Click the  edit icon to open the Edit Picklist Field window.

Figure  2-119. Edit Icon for Selected Picklist UDF

 b. To delete a data item, select the item and then click  Delete. Then click Yes if the Confirm 
Delete window.

 c. To edit a data item, select the item and edit as needed.

 d. To add a data item, click the row with the message Click here to add a new row and enter a 
Value and Description. 

If you are adding a data item in a child dynamic picklist, refer to Add a Child Picklist and 
Mapping Data Items for instructions on how to map the new item.

 6. Click  Save to save settings and close the window.

Add an On/Off Pair User Defined Field

PCS provides several pairs of installed on/off fields for recording inspection readings in a data grid or form, 
including the following:
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 l AC P/S and AC IRF

 l Casing P/S and Casing IRF

 l Foreign P/S and Foreign IRF

 l Insulator P/S and Insulator IRF

 l Structure P/S and Structure IRF

If PCS does not provide an installed pair of on/off fields you can use to record inspection readings for a test 
point facility, you can create a custom On/Off Pair user defined field (UDF). 

Complete the following steps to create an On/Off Pair UDF:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-120. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-121. Column Selections Window

 3. Select a table in the Properties pane that includes the data entry grid to which you want to add a 
UDF. 

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  2-122. Field and UDF Customizations

 4. Click  On/Off Pair in the toolbar to open the Add On/Off Pair Fields window .

Figure  2-123. Add On/Off Pair Fields

 5. Type a unique name in the On Field Caption and Off Field Caption fields .

 6. Select a data type from the  Data Type drop-down field.

A Numeric data type is a positive or negative value with decimal precision, such as 1.123 and –1.123. 
An Integer data type is a positive or negative whole number, such as 5 and –5.

 7. If you selected the Numeric data type, set the length of the field using the Width and Decimal fields.
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Clicking the up arrow in Width or Decimal fields increases the value; clicking the down arrow 
decreases the value.

 8. If you want PCS to apply Range Checking to the On reading in the On/Off Pair, complete the 
following steps:

Range checking is the acceptable range of values allowed for data entry in an inspection field.

Setting up range checking allows PCS to alert the user when an incorrect value has been entered in 
an inspection field. For example, if the acceptable range of values is in a range of -10 to 0 and the 
user enters a value that is outside this range, a warning displays allowing the user to correct the 
invalid entry. Data entry errors are less likely to occur when using Range Checking. For more 
information, see Set Up Range Checking for Inspection Fields on page 68.

Figure  2-124. On Range Checking

 a. Click the  On Range Checking check box.

 b. Type a minimum range value in the On Minimum field.

 c. Type a maximum range value in the On Maximum field.

 9. If you want PCS to apply Range Checking to the Off reading in the On/Off Pair, complete the 
following steps:
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Figure  2-125. Off Range Checking

 a. Click the  Off Range Checking check box.

 b. Type a minimum range value in the Off Minimum field.

 c. Type a maximum range value in the Off Maximum field.

 10. When finished with configuring the On/Off Pair, click  Save.

The On/Off Pair UDF is now available for adding in a data entry grid. If needed, refer to Themes and Filter 
Groups on page 368 for information about how to add fields in a data grid or form.

Summation User Defined Fields

A Summation user defined field (UDF) is a Permanent Information field available for use in a data grid, form, 
report, or as a filter in scheduling. It is a simple yet powerful UDF that provides useful information when 
analyzing pipeline data.

The function of a Summation UDF is to aggregate data for a target field using one of the following operators: 
Average, Count, Latest, Maximum, Minimum, and Sum. As an option, you can also include one or more 
filters that run either before or after the data aggregation.

Refer to the following topics on how to add or edit a Summation UDF:

 l Add a Summation User Defined Field

 l Edit a Summation User Defined Field on page 138
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Add a Summation User Defined Field

Complete the following steps to add a Summation UDF:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-126. Field and UDF Customization Window

 2. If you want to select a grid layout theme, click  Customize to open the Column Selections window, 
select a theme from the Select a Layout Theme field, and click  Save.
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Figure  2-127. Column Selections Window

 3. Double-click Facility Surveys > Common to All Facilities in the Properties pane. Then click Permanent 
Information to display a grid with fields and property settings common to all facilities).
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Figure  2-128. Field and UDF Customizations - Permanent Information Table

 4. Click  Summation in the toolbar to open the Add Summation Field window.

Figure  2-129. Add Summation Field

 5. Type a unique name for the  UDF in the Caption field.
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 6. Select a target field in the list of fields in the selection pane. For example, click the  expand icon for 
Galvanic Anode Information Fields, then double-click Activate Galvanic Anode P/S. A   indicates a 
selection.

Figure  2-130. Summation Target Field

 7. Select an Operator option.

The Summation expression displays in the top right-hand corner of the window, such as Count: 
Activate Galvanic Anode P/S, as shown in the following example.
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Target Field and Operator

 8. If you want to filter the data included in the summation, add an AND filter or OR filter as needed. 
Adding an AND filter group produces a subset of records that meet all filter conditions. Adding an 
OR filter group produces a subset of records that meet any of the filter conditions. PCS processes 
filters in a filter group in descending order beginning with the filter at the top of the filter group. Refer to 
the Themes and Filter Groups for Pipeline Records sections Add or Edit an AND Filter Group for 
Pipeline Records and Add or Edit an OR Filter Group for Pipeline Records for information on using 
these filters.
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Figure  2-131. New 'And' and 'Or' Filters

 9. Click  Save to save your UDF and close the Add Summation Field window.

Edit a Summation User Defined Field

Complete the following steps  to edit a Summation UDF previously added in PCS:
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 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

Figure  2-132. Field and UDF Customizations

 2. Double-click Facility Surveys > Common to All Facilities in the Properties pane. Then click Permanent 
Information to display a grid with fields and property settings common to all facilities).

Figure  2-133. Field and UDF Customizations - Permanent Information Table
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 3. Select the Summation UDF you want to edit in the grid of the Field and UDF Customizations window. 
Then navigate to the  System-User Defined Summation Definition column and click the ... ellipsis 
button next to the UDF name.

Figure  2-134. System-User Defined Summation Definition

 4. In the Edit Summation Field window, edit UDF settings as needed.
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Figure  2-135. Edit Summation

 5. If the Summation UDF includes filter settings you want to change, click the  Filters button to open 
the Filters pane and make changes as needed. Use filter selection fields to set up filter criteria. Select 
a PCS field, operator, and one or more filter conditions.

 6. Click  Save to save settings and return to the Field and UDF Customizations window.

Choosing a Printer for PCS

PCS uses your computer's default printer to print reports and graphs. If a color printer is available, you may 
want to print graphs on a color printer. If you need to add or set up a local or network printer, contact your 
company's network administrator or IT department for assistance.

Pipeline Series
A pipeline series defines each segment of a pipeline, where the starting milepost of a pipeline series 
corresponds to the starting milepost for a segment of the pipeline, and the ending milepost of the pipeline 
series corresponds to the ending milepost for the same segment of pipeline.
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This chapter  includes the following topics:

 l About Pipeline Series

 l Add and Apply Pipeline Series on page 142

About Pipeline Series

When a discontinuity occurs in a pipeline, use Pipeline Series to adjust facility numbers on the pipeline. A 
discontinuity typically occurs when an extension is added to the pipeline, the pipeline is re-routed, or when 
a company designates two pipelines as parallel lines. Instead of physically renumbering pipeline location 
numbers on-site, Pipeline Series allows you to shift pipeline numbering in PCS using Relative Milepost 
locations.

A Pipeline Series is an ordered list of milepost locations with a starting milepost and an ending milepost that 
serve as connectors to preceding and subsequent Pipeline Series. All Pipeline Series snapped end to end 
map the pipeline. Multiple connected Pipeline Series form a Pipeline Series chain.

Additional characteristics of Pipeline Series include the following:

 l All facilities on the pipeline must be assigned to a Pipeline Series when a Pipeline Series is used with a 
segment of the same pipeline. An entire pipeline can be made up of several Pipeline Series.

The starting milepost of a Pipeline Series corresponds to the starting milepost for a segment of the 
pipeline. The ending milepost of the Pipeline Series corresponds to the ending milepost for the same 
segment of pipeline. Each Pipeline Series joins together, end-to-end, to make up the entire pipeline. 
Pipeline Series defines each segment and is then used to calculate the Relative Milepost.

 l A pipeline with several different numbering schemes can be converted into a sequential line using a 
Pipeline Series for each segment of the pipeline. This allows you to graph the entire distance of the 
pipeline using the Relative Milepost.

 l Pipeline Series supports negative milepost locations, which helps identify milepost locations that are 
in an opposite direction of other milepost locations in a series.

 l Red facility records in a data entry grid identify milepost numbers that require a Pipeline Series be 
applied to the record.

Add and Apply Pipeline Series

The Pipeline Series window (Data Entry > Pipeline Series) allows you to add new pipeline series definitions 
and combine the series into a chain. This allows you to easily update milepost locations of points in the 
pipeline series when a discontinuity occurs by modifying the start and end milepost values.
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A pipeline series defines each segment of a pipeline, where the starting milepost of a pipeline series 
corresponds to the starting milepost for a segment of the pipeline, and the ending milepost of the pipeline 
series corresponds to the ending milepost for the same segment of pipeline. Each pipeline series joins 
together, end-to-end, to make up the entire pipeline. The pipeline series definitions are used to calculate the 
Relative Milepost         of facilities on the pipeline.

Figure  2-136. Two Pipeline Series Combined to Form a Chain

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to add new Pipeline Series, combine multiple Pipelines Series into a chain, 
and apply Pipeline Series to facility records:
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 1. Click Data Entry > Pipeline Series to open the Pipeline Series window.

Figure  2-137. Pipeline Series

 2. Complete the following steps for each pipeline series you wish to add:

 a. Click  Add and then select the ROW Code and Pipe you want to work with. 

Figure  2-138. Select Right Of Way Code And Pipeline

 b. Click  Save to open the Add Record window. 
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Figure  2-139. Add Record

 c. Type a unique identifier for the pipeline series in the Series Number field. This field accepts up 
to 10 alphanumeric characters including spaces and special characters, such as a hyphen (–) 
or pound sign (#).

 d. Type the starting milepost for the segment of the pipeline in the Start Milepost field and the 
ending milepost for the same segment of the pipeline in the End Milepost field.

 e. Click  Save to close the window and add the record in the Pipeline Series grid.
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Figure  2-140. Pipeline Series Grid with New Records

 f. If you want to add a description or other type of information for the pipeline series, type the 
information in the Description field. This field supports up to 30 alphanumeric characters.

 3. Complete the following steps to combine multiple pipeline series together in a chain:

 a. Select a pipeline series that is not the first segment of the chain.

Figure  2-141. Second Segment of Pipeline Series

 b. Click the down arrow in the Previous Series field and select the series that precedes the 
currently selected series.

PCS uses the start and end milepost values of the preceding pipeline series in the chain to 
determine the Relative Milepost of any point in a pipeline series.
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Figure  2-142. Pipeline Series

 c. Repeat these steps as necessary to add additional pipeline series to the chain.

 d. When you are done defining pipeline series and creating pipeline chains, click the x icon to 
close the Pipeline Series window.

 4. Complete the following steps to apply a Pipeline Series to facility records:

 a. Click Data Entry > Edit CPDM Data to open the Edit CPDM Data window and select the view. 
Click Apply.

PCS will highlight the Series and Milepost fields for facility records that need to be assigned to 
a series or are assigned to an incompatible series.
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Figure  2-143. Highlighted Fields for Series

 b. To assign a facility record to a pipeline series, click in the Series field of the record. Select the 
correct pipeline series from the drop-down. Repeat this step for each affected facility record in 
the data grid.

Figure  2-144. Pipeline Series

PCS automatically calculates the Relative Milepost for each facility record assigned a pipeline series in the 
data entry grid.
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Manage Custom Modules and Facilities
CMM is an optional add-on feature that requires an activation key for operation.

Custom Module Management (CMM) (Modules > Custom Module Management) allows you to manage 
compliance data for facility types not included within a specific module of PCS or create an entirely new 
module with all new custom facility types. If there is an installed module that contains most, but not all, of the 
facility types you need, you can create a new custom facility type within the existing module. However, if 
your compliance data needs cannot be fulfilled at all by an existing module, you can create a custom 
module that contains only custom facility types.

Custom modules and facilities provides the same basic functionality as a system installed modules and 
facilities and can be used with the same PCS features as system installed modules and facility types. You 
can enter information, inspection, and maintenance data for custom facility types and perform the same 
tasks with data in the custom module as you would with data in a system installed module, including 
running reports, viewing and filtering data, and setting up schedules.

Figure  2-145. Custom Module Management

PCS supports up to ten (10) custom modules with each module supporting up to ten (10) custom facility 
types.

If your company has purchased the CMM module, use the following information to set up a custom module 
and custom facility types:

 l Add a Custom Module — add a new custom module with custom facility type(s).

 l Modify a Custom Module — edit or delete an existing custom module.                 
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 l Add a Custom Facility Type — add a new custom facility type to an existing module.

 l Modify  a Custom Facility Type — edit or delete an existing custom facility type.

 l Configure PCS for the New Module or Facility Type — finish setting up PCS to use the custom 
modules and facility types.

Add a Custom Module

If your compliance data needs cannot be fulfilled at all by an existing module, you can create a custom 
module that contains only custom facility types. A custom module must have at least one facility type and 
supports up to ten (10) custom facility types.

If change tracking is configured for your database, review the change tracking configurations after adding a 
new module to ensure that the desired settings were applied to any new tables or fields for the new module. 
Refer to Track Data Changes on page 896. These instructions start with the assumption that  the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171.

Complete the following steps to add a custom module:

 1. Click Modules > Custom Module Management to open the Custom Module Management window.

Figure  2-146. Custom Module Management Window

 2. Click  Add in the Custom Module pane on the left. A new module is created with a single custom 
facility created.
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Figure  2-147. Custom Module Management

 3. Enter a name for the module in the Name field. The field accepts up to 50 alphanumeric characters 
including spaces and special characters.

 4. Enter a code for the module in the Code field. This field accepts up to four (4) alpha characters. It 
does not support numeric or special characters.

 5. Assign a color to the module from the Color drop-down. To assign a color that does not exist in the 
drop-down, select Advanced in the Color drop-down and create a custom color by doing any of the 
following:

 a. Select a color with the color slider and color field.

 b. Enter a hexadecimal value in the field provided.

 c. Enter Red (R), Green (G), Blue (B), and Alpha (A) values in the field provided.

 6. In the Custom Facilities pane, type the facility type's name in the Name field. The field accepts up to 
30 alphanumeric characters including spaces and special character set the properties for the facility 
type created for the module and add additional facility types as needed by completing the following 
steps:

 7. Type a longer name for the user defined facility in the Long Name field. This field accepts up to 40 
alphanumeric characters including spaces and special characters.

 8. Type an acronym for the user defined field in the Short Name field. The field accepts up to four (4) 
alpha characters. It does not support numeric or special characters.

 9. If you want the facility type available for selection when setting up a schedule, click to select the Is 
Schedulable check box.
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 10. Click to select the Is Routable check box to have the facility type available for selection when setting 
up a route.

 11. Click to select the Is Range Data check box to allow pipeline segments in this facility type to be 
defined based on a starting and ending milepost range regardless of series definitions.

 12. If additional facility types are needed, click  Add and repeat these steps. 

Figure  2-148. Adding Another Facility

 13. Click Save to     save the module information and all custom facility properties.

Modify a Custom Module

A custom module's properties can be edited, the custom module can be removed, and custom facility 
types can be added to, modified in, or removed from the module. A custom module must have at least one 
facility type and supports up to ten (10) custom facility types. These instructions start with the assumption 
that  the correct pipeline segments have been selected. For information detailing how to select pipeline 
segments, refer to Select ROWs on page 171.

Complete the following steps to modify a custom module information or add or delete custom facilities to 
that module:
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 1. Click Modules > Custom Module Management to open the Custom Module Management window.

Figure  2-149. Custom Module Management Window - Custom Modules

 2. Select the module you wish to modify in the Custom Modules pane on the left.

Figure  2-150. Selected Custom Module

 3. To add new facility types, click  Add. Refer to Add a Custom Module for additional information on 
how to add a facility type.

 4. To edit the module information or custom facilities, edit the Name, Code, and Color fields as needed. 
Edit the fields in the Custom Facilities pane for any custom facility you wish to edit. Refer to Add a 
Custom Module for additional information on these fields.
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 5. To delete a custom facility, click the  icon in the facility box. You cannot delete a facility type while 
Job Service is running. If Job Service is running when you try to delete the facility, the following error 
message will display:

Figure  2-151. Error Message

 6. Click  Save to     save the module information and all custom facility properties.

Add a Custom Facility Type

If there is a module that contains most, but not all, of the facility types you need, you can create a new 
custom facility type within the existing module. A new custom facility type can be added to a system 
installed module or to a custom module.

If change tracking is configured for your database, review the change tracking configurations after adding a 
new facility type to ensure that the desired settings were applied to any new tables or fields for the new 
facility. Refer to Track Data Changes on page 896. These instructions start with the assumption that  the 
correct pipeline segments have been selected. For information detailing how to select pipeline segments, 
refer to Select ROWs on page 171.

Complete the following steps to add a custom facility type to an existing module:
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 1. Click Modules > Custom Module Management to open the Custom Module Management window.

Figure  2-152. Custom Module Management Window

 2. Select the module that will contain your new custom facility type from the Installed Modules pane.

 3. Click  Add in the Custom Facilities pane on the right to create your custom facility type. 

Figure  2-153. Custom Facility Descriptions

 4. Enter the facility type's name in the Name field. The field accepts up to 30 alphanumeric characters 
including spaces and special characters.

 5. Enter a longer name for the user defined facility in the Long Name field. This field accepts up to 40 
alphanumeric characters including spaces and special characters.
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 6. Type an acronym for the user defined field in the Short Name field. The field accepts up to four (4) 
alpha characters. It does not support numeric or special characters.

 7. If you want the facility type available for selection when setting up a schedule, click to select the Is 
Schedulable check box.

 8. Click to select the Is Routable check box to have the facility type available for selection when setting 
up a route.

 9. Click to select the Is Range Data check box to allow pipeline segments in this facility type to be 
defined based on a starting and ending milepost range regardless of series definitions.

 10. Click  Save to     save the current facility type's properties.

 11. If additional facility types are needed, click  Add and repeat these steps. 

 12. Click  Save.

Modify  a Custom Facility Type

Custom facility types that had been added to a system installed or custom module can be edited or deleted 
as desired. These instructions start with the assumption that  the correct pipeline segments have been 
selected. For information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to edit or delete a custom facility type:

 1. Click Modules > Custom Module Management to open the Custom Module Management window.

Figure  2-154. Custom Module Management Window - Custom Modules
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 2. Select the module that will contain your new custom facility type from either the Installed Modules or 
Custom Modules pane.

Figure  2-155. Custom Facility for Installed Module

Figure  2-156. Custom Facilities for Custom Module

 3. To edit the facility type, change the facility type's properties as needed: 

 l Enter the facility type's name in the Name field. The field accepts up to 30 alphanumeric 
characters including spaces and special characters.



PCS v2.5 User Guide

Chapter 2: PCS Set Up 158

 l Enter a longer name for the user defined facility in the Long Name field. This field accepts up to 
40 alphanumeric characters including spaces and special characters.

 l Enter an acronym for the user defined field in the Short Name field. The field accepts up to four 
(4) alpha characters. It does not support numeric or special characters.

 l If you want the facility type available for selection when setting up a schedule, click to select the 
Is Schedulable check box.

 l Click to select the Is Routable check box to have the facility type available for selection when 
setting up a route.

 l Click  Save to     save the current facility type's properties.

 4. To delete the facility type, click the  icon in the facility type's box. Confirm the deletion in the 
confirmation window.

NOTE: You cannot delete Custom Module Management content while the Job Service is running.

Figure  2-157. Delete a Custom Facility

Configure PCS for the New Module or Facility Type

Custom modules and facilities provides the same basic functionality as a system installed modules and 
facilities and can be used with the same PCS features as system installed modules and facility types. 
However, to take advantage of the basic functionality and features with the new custom module or facility 
type(s), PCS must be configured further. After creating custom modules or facilities, the following tasks 
should also be completed:

 l Add one or more user defined fields (UDFs) for the new custom module's facility type(s) in Field and 
UDF Customizations. For detailed instructions, refer to Add User Defined Fields on page 73.

 l If change tracking is configured for your database, review the change tracking configurations  to 
ensure that the desired settings were applied to any new tables or fields for the new facility. Refer to 
Track Data Changes on page 896.

 l Configure PCS features for the new module and/or facility types as needed. Some of the tasks you 
may want to perform include:
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 — Set up data entry grid and data entry form themes in Edit <Module> Data (refer to Themes and 
Filter Groups on page 368 in Chapter 5,  Data Entry Grids and Forms on page 236).

 — Create reports and graphs and, if desired, email notifications for the reports (refer to Chapter 
16, Reports and Graphs on page 773 and Chapter 12, Email Notification on page 654).

 — Configure schedules in Edit Schedule Settings and Define Schedules (refer to Chapter 8, 
Schedules on page 509).

 — Define routes (Chapter 7, Routes on page 439).

 — Create prompt, layout, and sort themes in Field Computer Send (refer to Work with Themes 
and Filter Groups on page 693 in Chapter 13, Field Computer on page 677).

 — Set up manual and automatic data imports and exports in Bridge (refer to Bridge).
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Chapter 3: User Management
User Management allows a SysAdmin to add, edit, and work with user accounts. 

You can access the User Management window from the Tools main menu.

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Understanding User Management

 l Use Computer Name User Authentication on page 161

 l Add and Edit Users on page 161

Understanding User Management
User Management (Tools > User Management) controls system security using a role based method. Each 
PCS user is defined in User Management and assigned a PCS installed user role. A user role is a collection 
of security permissions that tells PCS which system features a user has access to and if the user is allowed 
to add and edit data.

The following list identifies the three types of PCS installed user roles. Each type gives users a different level 
of security permissions. Users are assigned only one user role. The SysAdmin user role has full control of all 
PCS features and functions. For a list of user role permissions assigned to the User and Read Only user 
roles, refer to  System Security.

 l SysAdmin

 l User

 l Read Only

When PCS first installs, it creates the first system account using Computer Name user authentication. This 
account is automatically assigned the SysAdmin user role, which has the highest set of privileges. Refer to 
Use Computer Name User Authentication on page 161 for more information.
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Use Computer Name User Authentication
PCS uses Computer Name user authentication when logging users in to the PCS database. If more than 
one user will share a single computer installed with PCS, contact your IT department for information about 
setting up the required Windows user accounts on the computer. Login credentials must be unique for 
each PCS user. If needed, refer to Windows Help and Support (Start > Help and Support), or visit the 
Microsoft website at the following address to learn more about Windows user accounts: 
http://windows.microsoft.com/en-US/windows7/User-accounts-recommended-links.         

Add and Edit Users
The User Management window allows SysAdmin users to work with user accounts. The window can be 
accessed from the Tools main menu.

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Add a New User on page 161

 l Edit an Existing User Account on page 166

 l Change Active User Account Status on page 167

 l Assign a Custom Security Role to a User

Add a New User

Complete the following steps to add a new user in PCS:

http://windows.microsoft.com/en-US/windows7/User-accounts-recommended-links
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 1. Click Tools > User Management to open the User Management window.

Figure  3-1. User Management Window

Clicking the Hierarchy Rights bar collapses the Hierarchy Rights pane allowing you to view more of 
the grid. Clicking the bar again expands the pane.

 2. Click  Add. The User Management side pane presents empty fields for the new user.
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Figure  3-2. New User Fields

 3. Type a user name in the User Name field.

 4. Enter  the user's email address in the Email field.

 5. Enter a First Name, Last Name, and Display Name for the user in the respective fields.

 6. Select a PCS parent role from the Parent Role drop-down field. If needed, see   System Security on 
page 962 for information about user role security permissions.
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Figure  3-3. Parent Role Drop-down Field

 7. Select the user role from the Role drop-down field.

 8. If you want to allow the user to create new facilities on the mobile field computers (such as an 
Allegro), click the  Can Create New Facilities On Field Computer check box.
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 9. If you want to include an image in the user account, complete the following steps. Maximum image 
size is 150 x 150 (measured in pixels). Valid image formats are BMP, JPG, GIF, and PNG.

 a. Hover the mouse over the Image field to display a toolbar .

 b. Click the  icon in the image toolbar to open Windows Explorer. Locate and select an image, 
then click Open to close the window.

 10. If PCS is set up with Hierarchical Security in the Options window (Tools > Options), set permissions in 
Hierarchy Rights to identify which parts of the hierarchy the user will have access. This step applies 
only to users assigned with the User or Read Only user role. SysAdmin has full access to all items in 
the hierarchy.

Figure  3-4. Hierarchy Rights for New User
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To grant access, select an item in the hierarchy to place a check mark inside the check box. To 
remove access, click the check box again to remove the check mark. When you finish, click  Apply. 
For information about Hierarchical Security in Options, see Set Security Options on page 44.

Items in the hierarchy with a check mark indicate the user has access. If a check mark is not present, 
the user does not have access.

 11. Click  Save to save new user information.

Edit an Existing User Account

Complete the following steps to edit an existing user account in User Management:

 1. Click Tools > User Management to open the User Management window.

Figure  3-5. User Management Window

Clicking the Hierarchy Rights bar collapses the Hierarchy Rights pane allowing you to view more of 
the grid. Clicking the bar again expands the pane.

 2. Select a user record in the grid.

 3. Change user information and Hierarchy Rights as needed. 
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Figure  3-6. User Information

 4. Click  Save to save changes.

Change Active User Account Status

You can change the Active status of a user if a user no longer requires access to PCS.

Complete the following steps to change the Active status of a user:

 1. Click Tools > User Management in the header bar to open the User Management window. If the 
Hierarchy Rights pane is open, you can click the title bar to collapse it.
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Figure  3-7. User Account Status

 2. Select a user record in the grid. 

 3. Click the Active check box to remove the check mark and change the user account status from 
active to inactive.

 4. Click Save to save changes.

The Active property setting in the grid changes from Yes to No to indicate the user account is not 
inactive.

Assign a Custom Security Role to a User

The following information explains how to assign a custom security role to a user. Users are created in the 
User Management window. For more information about User Management, see User Management on 
page 160.

Complete the following steps to change the security role for an existing user:

 1. Click Tools > User Management in the header bar to open the User Management window. If the 
Hierarchy Rights pane is open, you can click the title bar to collapse it.
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Figure  3-8. User Management Window

 2. Select a user record in the grid.

 3. Complete the following steps in the Role group box on the left side of the window:

 a. Click the Parent Role field and select the parent role associated with the custom security role 
you want to assign to the user record.

Figure  3-9. Parent Role Drop-down

 b. Click the Role field and select the custom security role you want to assign to the user record.
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 4. Click  Save to save changes.



4
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Chapter 4: Pipeline Records
Pipeline records can be viewed in the system hierarchy tree, which is separated into folders and pipelines. 

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Select ROWs

 l Select How Data Displays in the Information Grid

 l Select  How Data Displays in the Maintenance Grid

 l Add a Folder in the Hierarchy on page 179

 l Add a Pipeline in the Hierarchy on page 182

 l Move and Rename a Pipeline on page 185

 l Delete a Pipeline on page 187

 l Understanding Default Location Formats on page 189

 l Select  a Default Location Format on page 191

 l Add a Pipeline Information Record on page 194

 l Add a Pipeline Maintenance Record on page 199

 l Attach a Document to a Pipeline Record on page 206

 l Themes and Filter Groups for Pipeline Records on page 217

Select ROWs
Selections made in the Selected ROWs pane determine which pipeline segments' data is available for use 
in PCS. Data related to the selected pipeline segments can be seen in Edit [Module] Data, is available to 
send to the Allegro or other mobile device, and is accessible elsewhere in PCS. 
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If the Hierarchical Security check box is selected in the Options window (Tools > Options), the data available 
in PCS is further limited by the selections made for the current user in User Management. Refer to User 
Management for more information.

To open or close the Selected ROWs pane, click in the Selected ROWs title bar. You can also click and drag 
the left border.

The title bar is horizontal when the pane is opened:

Figure  4-1. Selected ROWs pane Open

The title bar is vertical when the pane is closed.
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Figure  4-2. Selected ROWs pane Closed

The currently selected pipeline segments are listed in the Selected ROWs pane. 

Complete the following steps to change the selection:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window. 
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Figure  4-3. Selected ROWs Window

 2. Select or deselect the appropriate pipeline segments as desired by doing any of the following:

 a. To deselect all currently selected segments, click  Clear.

 b. To deselect a single segment, locate the segment and click to clear the segment's check box.

 c. To select a single segment, locate the segment and click to select the segment's check box.

 d. To find and select a specific segment:

 i. Select either Expand Display and/or Persist Expansion to expand the hierarchy after 
search is done. 

 ii. Select one of the radio buttons above the search fields. The selection of radio buttons 
depends on whether or not the  Expand Display check box is selected:

 l If Expand Display is not selected, the search options include Select and Clear 
Selection and Select.

 l If Expand Display is selected, the search options include Find Only, Find and 
Select, and Clear Selection and Select.

 iii. Select whether to search by the pipeline's Name, Code, or Name and Code from the 
drop-down and enter a search term in the Find ROW search box. 

 iv. Click   Find. Depending on which radio buttons are selected, one of the following will 
occur:
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 l Find only: locates and highlights the next segment that matches the search parameters 
but does not select the segment. This option is not available if Expand Display is 
deselected.

 l Select: locates all segments that match the search parameters and selects the 
matching segments.

 l Find and Select: locates all segments that match the search parameters, expands the 
hierarchy that the matching segments are a part of, and selects the matching 
segments.  This option is not available if Expand Display is deselected.

 l Clear Selections, Find and Select: locates all segments that match the search 
parameters, expands the hierarchy that the matching segments are a part of (if Expand 
Display is selected), selects the matching segments, and deselects all segments that do 
not match the search parameters. 

Figure  4-4. Clear Selection, Find and Select Option for Search

 3. Click  Save to close the Select ROWs window.
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Select How Data Displays in the Information Grid
Complete the following steps to select how the data will display in the Information grid of the Edit ROW 
Detail window:

 1. Click Data Entry > Edit ROW Detail.

 2. Click the Information tab, then the Options tab to open the Options window.

Figure  4-5. Information Grid - Options Window

 3. Select how the information will be displayed in the window: Grid, Form, or Grid And Form.

 a. For Grid and Grid And Form options, select a Layout Theme and Sort Theme. Form options 
does not allow a Layout Theme.

 b. For Form and Grid And Form options, select a Form Theme. 
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Figure  4-6. Form View Option and Select Form Theme

 4. Select either Oldest First or Newest First radio button for how dates are sorted.

 5. To include only the most recent information record for each pipeline, select the  Only the most recent 
information record for each facility check box. This option uses the Effective Date to filter the data 
output.

 6. When using the Filters group box to apply additional filters to the data output, the most recent 
information record is found first, and then all other filters are applied to the data output. For more 
information about filters, refer to Add or Edit an AND Filter Group for Pipeline Records on page 226 
and Add or Edit an OR Filter Group for Pipeline Records on page 230.

 7. Click  Apply to save and apply changes. The Information grid displays with the data selected.

 8. To cancel changes, click the  Optionstab or  Cancel to return to the grid.

Select  How Data Displays in the Maintenance Grid
Complete the following steps to select how the data will display in the Maintenance grid of the Edit ROW 
Detail window:

 1. Click Data Entry > Edit ROW Detail.

 2. Click the Maintenance tab, then the Options tab  to open the Options window.
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Figure  4-7. Maintenance Tab - Options

 3. Select how the information will be displayed in the window: Grid, Form, or Grid And Form.

 a. For Grid and Grid And Form options, select a Layout Theme and Sort Theme. Form options 
does not allow a Layout Theme.

 b. For Form and Grid And Form options, select a Form Theme. 

Figure  4-8. Form View Option and Select Form Theme

 4. Review the following descriptions and then select one or more filter options as required:
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 l Only include facilities with maintenance during the reporting time period: The data output for 
this option only includes those maintenance records that meet the filter criteria defined for a 
particular date or date range. Filter criteria is defined by filter settings in the Filters group box for 
any of the following time period fields: Effective Date, Repair Found Date, Repair Initiated Date, 
and Repair Corrected Date.

 l All maintenance that meet the filter criteria: This option includes all maintenance records in the 
data output that meet filter criteria based on filter settings in the Filters group box.

 l Apply other filters to the most recent maintenance found within the report timeframe: This 
option finds the most recent maintenance record within the reporting time frame first, and then 
applies other filter settings to the data output. Filter criteria for both of these are defined in the 
Filters group box. Use any of the following fields when defining filter criteria for the reporting 
time frame: Effective Date, Repair Found, Repair Initiated, and Repair Complete.

 l The most recent maintenance after the filter criteria has been met: The data output for this 
option includes the most recent maintenance record only for those pipeline records that meet 
all other filter criteria first. Filter criteria for both of these are defined in the Filters group box. Use 
any of the following fields when defining a time period for the most recent maintenance record: 
Effective Date, Repair Found, Repair Initiated, and Repair Complete.

 5. When using the Filters group box to apply additional filters to the data output, the most recent 
information record is found first, and then all other filters are applied to the data output. For more 
information about filters, refer to Add or Edit an AND Filter Group for Pipeline Records on page 226 
and Add or Edit an OR Filter Group for Pipeline Records on page 230.

 6. Click  Apply to save and apply changes. The Information grid displays with the data selected.

 7. To cancel changes, click the  Optionstab or  Cancel to return to the grid.

Add a Folder in the Hierarchy
The hierarchy is an organizational structure of one or more folders. Folders are organized in a tree structure 
based on the number of hierarchy levels set up in the system. The top level of the hierarchy is the root level 
that identifies your company's name. All hierarchy folders are added below the root level. The lowest level of 
the hierarchy includes a folder with pipelines added in the system.

NOTE: The names of hierarchy folders as well as the ROW Code and ROW Name fields support up to 100 
characters.

Complete the following steps to add a folder in the hierarchy:
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 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  

Figure  4-9. Selected ROWs Window

 2. Select a level in the hierarchy where you want to add a folder.

Figure  4-10. Selected Folder in Hierarchy

 3. Click  Add to open the Add New Node window.
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NOTE: You can also open the Add New Node window by right-clicking a selection in the hierarchy 
tree and selecting  Add in the shortcut menu.

Figure  4-11. Shortcut menu

NOTE: If you do not select a Region in the hierarchy before clicking  Add, you can add it to the 
Region field in the Add New Node window.
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Figure  4-12. Add New Node

 4. Add information for the new hierarchy folder. Fields requiring information include a  icon, such as 
System and ROW Code.

The names of hierarchy folders, as well as ROW Code and ROW Name fields, support up to 100 
characters.

 5. Click the option Expand After Adding if you want to expand the selection tree after clicking Apply.

 6. Click  Apply. Repeat as needed to add additional folders in the hierarchy tree.

Add a Pipeline in the Hierarchy
The process for adding a pipeline to the hierarchy is the same as for adding a folder, except you select a 
folder in the hierarchy where you want to add the pipeline instead of a level.

Complete the following steps to add a pipeline in the hierarchy:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  
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Figure  4-13. Selected ROWs Window

 2. Select a folder in the hierarchy you want to add a pipeline. 

Figure  4-14. Selected Folder for New Pipeline

 3. Click  Add to open the Add New Node window. 
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NOTE: You can also open the Add New Node window by right-clicking a selection in the hierarchy 
tree and selecting  Add in the shortcut menu.

Figure  4-15. Shortcut menu

Figure  4-16. Add New Node

 4. Enter a pipeline code for the new pipeline in the ROW Code field. Fields requiring information include 
a  red icon, such as ROW Code.
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The names of hierarchy folders, as well as ROW Code and ROW Name fields, support up to 100 
characters.

 5. Type a name for the pipeline in the ROW Name field.

 6. Click the option Expand After Adding if you want to expand the selection tree after clicking Apply.

 7. Click  Apply. Repeat these steps  as needed to add another pipeline in a selected hierarchy folder.

For information about setting this required field for all pipelines in the system, refer to with Understanding 
Default Location Formats on page 189

Move and Rename a Pipeline
Complete the following steps to move or rename a pipeline in the hierarchy:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  

Figure  4-17. Selected ROWs Window

 2. To move the selected pipeline to a different hierarchy folder, right-click the pipeline, and then select 
Cut in the shortcut menu. 
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Figure  4-18. Cut Shortcut Menu

 3. Right-click on the hierarchy folder you want to move the pipeline to, and then select Paste in the 
shortcut menu.
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Figure  4-19. Paste Shortcut Menu

 4. To rename a selected pipeline, click   Rename  (or right-click the pipeline and select Rename in the 
shortcut menu). In the Rename Right of Way window, edit the ROW Code and/or ROW Name fields, 
and click  Save to apply the change and close the window.

Figure  4-20. Rename Pipeline

Delete a Pipeline
Deleting a pipeline also deletes all facilities and history records associated with the pipeline.
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IMPORTANT: Instead of deleting a pipeline, consider creating a new hierarchy folder labeled Sold, 
Abandoned, or something similar and then moving the pipeline to that folder. Another option is to change 
the operational status of the pipeline by disabling the Active check box in Edit ROW Detail window (Data 
Entry > Edit ROW Detail). 

Compete the following steps to delete a pipeline:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  

Figure  4-21. Selected ROWs Window

 2. Click  Delete. Or right-click the selected pipeline in the hierarchy tree and select Delete in the 
shortcut menu.
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Figure  4-22. Delete Shortcut Menu

The Confirm Delete window identifies the pipeline and number of associated facilities to be deleted in 
the Count column.

Figure  4-23. Confirm Delete Window

 3. Click  Delete to delete the pipeline or  Cancel to cancel the operation.

Understanding Default Location Formats
The following table identifies milepost formats available for selection when setting the Default Location 
Format for a pipeline in the Edit ROW Detail window (Data Entry > Edit ROW Detail). 

Selecting a Default Location Format allows PCS to automatically apply the correct formatting to milepost 
values you enter for a facility location on a pipeline.
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Location Format Format Example Description

Metric Milepost 1.234AB, 
1,234AB, or 
1+234AB

Measurements are in metrics. This format can include two 
alpha characters at the end of the milepost and can also be 
graphed. Measurements are in kilometers and meters. 
Based on the metric delimiter set in system Options, this 
format supports a Period, Comma, or Plus sign. For 
example, 1.234AB is 1 kilometer (km) and 234 meters (m).

Milepost (3 
Decimals)

12345.567

-or-

1234.567AB

Format supports two alpha characters at the end of the 
milepost and can also be graphed. This format uses the 
U.S. Standard measurement system.

Milepost (4 
Decimals)

123.5678

-or-

1234.5678A

Format supports one alpha character at the end of the 
milepost and can also be graphed. This format uses the 
U.S. Standard measurement system.

Reading Number 12345678AB This is an alphanumeric format with support for two alpha 
characters at the end. It is typically used for stations. The 
format also uses the U.S. Standard measurement system.

This format cannot be graphed and the CP Compliance 
Report does not calculate total feet, total miles, or miles 
below criteria.

Location ID 1234567891

-or-

ABCDEFGHIJ

Use Location ID when footages are not applicable. This 
format is typically used in distribution systems. Other 
features include those in the following list:

 l Uses the U.S. Standard measurement system, 
accepts alphanumeric characters, and cannot be 
graphed.

 l CP Compliance Report does not calculate total feet, 
total miles, or miles below criteria when using this 
format.

NOTE: Location ID cannot be changed once it is set up.

Station Number 12345+67AB Measurements are in feet. This format can be graphed, 
supports two alpha characters at the end of the milepost, 
and uses the U.S. Standard measurement system.

Table 4-6.  Description of Default Location Formats       
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Location Format Format Example Description

Miles+100 Feet 12345+12

-or-

12345+12AB

Format uses miles plus two digits to the right to indicate 
hundreds of feet. For example, 110+12 indicates 110 miles 
and 1,200 feet. Do not enter values greater than 53 feet; 
doing so indicates another mile.

Other characteristics include:

 l Format can be graphed.

 l Two alpha characters can be used after the first three 
numbers.

 l CP Compliance Report does not calculate total feet, 
total miles, or miles below criteria.

 l Uses the U.S. Standard measurement system.

Miles/Station 
Number

123A 45+67

-or-

123A 12+34

Format uses Miles<space>Station Number with Milepost 
(three decimals) in graphs. This format uses the U.S. 
Standard measurement system.

Table 4-6.  Description of Default Location Formats        cont'd

Select  a Default Location Format
A Default Location Format must be set for each pipeline added in the system hierarchy. Refer to 
Understanding Default Location Formats on page 189 for information about available formats.

Complete the following steps to select a default location format:
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 1. Click File > Select ROWs to open the Select ROWs window.

Figure  4-24. Select ROWs

 2. Select one or more pipelines, and then click  Save to close the window.

 3. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. Ensure that the Information 
tab is selected.

Figure  4-25. Edit ROW Detail Window - Information Tab
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 4. Select a Layout Theme and Sort Theme. Optionally, select the Only the most recent information 
record for each facility check box. Click  Apply.

 5. Select a pipeline in the Information grid.

Figure  4-26. Information Tab with Records

 6. In the Default Location Format field, select a location format in the drop-down list. Refer to 
Understanding Default Location Formats on page 189 for a description of available options.

Figure  4-27. Default Location Format Drop-down List
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 7. In the Facility Location ID Formats mini-grid, click Add  A list of all facility types display in the mini-
grid with the selected location format.

Figure  4-28. Facility Location ID Formats Mini-grid

Complete the following steps if you want to change the location format for a particular facility type 
listed in the mini-grid:

 a. Select a row of records in the mini-grid with the facility type you want to change the location 
format.

 b. In the Default Location Format field, select a location format in the drop-down list

 8. Set up other pipeline information as needed.

 9. Click  Refresh. 

 10. When finished, click the x close icon to close the Edit ROW Detail window.

Add a Pipeline Information Record
Use the Information grid in the Edit ROW Detail window to add an information record for a pipeline selected 
in the Select ROWs window. Adding an information record allows you to maintain history records when 
important permanent information changes, such as when a pipeline is taken out of service or is sold to 
another business.
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NOTE: If you are working with the optional Telluric Compensation feature, the required  Telluric 
Compensation Required field must be added in the Information grid and enabled for each pipeline 
segment requiring telluric compensation. For more information refer to Add a Pipeline Record Layout 
Theme on page 218.

Complete the following steps to add a pipeline information records:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  

Figure  4-29. Selected ROWs Window

 2. Select one or more pipeline segments you want to work with by clicking the check box for each 
pipeline segment. 

A check mark inside a check box indicates a selection. To clear a selection, click the check box again 
to remove the check mark. A shaded check box indicates selection of some, not all, child folders, 
ROWs, and pipelines.

 3. Click  Save to close the window.

 4. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. Ensure that the Information 
tab is selected.
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Figure  4-30. Edit ROW Detail Window - Information Tab

 5. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 6. Select a Layout Theme and Sort Theme. Optionally, select the Only the most recent information 
record for each facility check box. Click  Apply.

Figure  4-31. Information Tab with Records

 7. Click  Add or press F4 on the keyboard to open the Add Record window.
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Figure  4-32. Add Record

 8. Select the pipeline in the window that you want to add an information record. 

 9. Click  Save to open a new Add Record window for the new record.
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Figure  4-33. Add Record

 10. Type a date in the Effective Date field using the format MM/DD/YYYY to indicate the month, day, and 
year. Or click the down arrow in the field and select a date using a calendar.

Effective Date is the date a history record becomes effective, such as when a pipeline becomes 
inactive or is taken out of service. refer to Create History Records Using an Effective Date on page 
285 for more information.

 11. Click  Save to close the Add Record window and add the new information record in the grid for the 
existing pipeline.
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Figure  4-34. ROW Detail Information Grid - New Record

 12. Provide other pipeline data in the grid as needed, such as Permanent Comments.

 13. Click  Refresh to update the grid.

Add a Pipeline Maintenance Record
Use the Maintenance grid in the Edit ROW Detail window to add a maintenance record for a pipeline 
selected in the Select ROWs window. Adding pipeline maintenance records allows you to examine the 
effectiveness of a maintenance program. You can either view data in the maintenance grid of Edit ROW 
Detail or run a ROW maintenance report.

Complete the following steps to add a pipeline maintenance records:

 1. Click the  icon on the Select ROWs title bar (or double-click in the pane or select File > Select 
ROWs) to open the Select ROWs window.  
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Figure  4-35. Selected ROWs Window

 2. Select one or more pipeline segments you want to work with by clicking the check box for each 
pipeline segment. 

A check mark inside a check box indicates a selection. To clear a selection, click the check box again 
to remove the check mark. A shaded check box indicates selection of some, not all, child folders, 
ROWs, and pipelines.

 3. Click  Save to close the window.

 4. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. Ensure that the 
Maintenance tab is selected.
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Figure  4-36. Edit ROW Detail Window - Maintenance Tab

 5. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 6. Select a Layout Theme and Sort Theme. Optionally, select the Only the most recent information 
record for each facility check box. Click  Apply.
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Figure  4-37. Maintenance Tab with Records

 7. Click  Add or press F4 on the keyboard to open the Add Record window.
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Figure  4-38. Add Record

 8. Select the pipeline in the window that you want to add an information record. 

 9. Click  Save to open a new Add Record window for the new record. Required fields are identified 
with the  icon, such as ROW Repair Code.
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Figure  4-39. Add Record

 10. Type a repair code in the ROW Repair Code field. Repair code is a designation used by your 
company to identify the type of repair. The field accepts up to 15 alphanumeric characters including 
special characters such as the pound sign (#), asterisk (*), or hyphen (-).
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Figure  4-40. New Maintenance Record

 11. Type a date in the  ROW Repair Found Date field using the format MM/DD/YYYY to indicate the 
month, day, and year. Or click the down arrow in the field and select a date using a calendar.

 12. Click  Save to close the Add Record window and add a pipeline maintenance record in the grid.
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Figure  4-41. ROW Detail Maintenance Grid - New Record

 13. Provide other maintenance data in the grid as needed. For example, provide a date in the ROW 
Repair Initiated Date and ROW Repair Corrected Datefields, a maintenance reference number in the 
ROW Reference Number field, and remarks about the repair in the ROW Repair Remarks field.

 14. Click  Refresh to update the grid.

Attach a Document to a Pipeline Record
Attaching a document to a pipeline record in Edit ROW Details is similar to attaching a document to a record 
in a data entry grid. Use the Attached Document field in the grids found in the Informationand Maintenance 
tabs of Edit ROW Details to link or embed a file or webpage address to a pipeline record. Supported file 
types include image, video, HTML, XML, music, and text files (such as Microsoft Word, WordPad, 
Notepad, or PowerPoint files). For instructions attaching a document to a record in a data entry grid, refer to 
 Data Entry Grids and Forms.

Examples of attachments include an image of a pipeline, a document describing your company's safety 
procedures, or a document identifying a manufacturer's specification for a piece of equipment.

Linking a document identifies the file location on a local computer, company network, FTP site, or webpage 
on the Internet. Linking documents stored on a local computer are accessible only from that computer. 
Embedding a document stores a copy of the file in the PCS database.

NOTE: Storing copies of documents in the PCS database increases the size of the database.
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If the file type of an attached document is associated with a default software program on the local 
computer, you can preview the file in the Preview Attached Documents window. Additionally, clicking Open 
opens the attached document for editing or viewing purposes.

Editing an embedded document applies changes only to the copy stored in the PCS database; changes do 
not apply to the source file stored outside of PCS. Likewise, editing a source file applies changes only to the 
source file, not the copy stored in PCS.

Refer to the following topics for more information on attaching documents:

 l Add the Attached Document Field in the Grid

 l Attach a Document to a Pipeline Record on page 210

 l View an Attached Document on page 215

For information about how to attach a document to a record in a data entry grid, refer to Data Entry Grids 
and Forms on page 236.

Add the Attached Document Field in the Grid

If the Attached Document field is not present in the grid under the Information or Maintenance tab of the Edit 
ROW Details window, complete the following steps to add the field:

 1. Select one or more pipeline segments you want to work with in the Select ROWs window. Click  
Save to close the window. Refer to Select ROWs for more information.

 2. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. 

Figure  4-42. Edit ROW Detail Window - Information Tab
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 3. If you want to collapse the Selected ROWs pane to view more of the Edit ROW Detail grid, click 
Selected ROWs. To expand the pane, click Selected ROWs again.

 4. Based on the grid you want to add the Attached Document field, click the Information tab or  
Maintenance tab.

 5. Select a Layout Theme and Sort Theme. Optionally, select the Only the most recent information 
record for each facility check box. Click  Apply.

Figure  4-43. Information Tab with Records

 6. Click the  Customize tab to view the Layouts page.

Figure  4-44. Layouts
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 7. Choose a grid layout theme. Click the down arrow in Select Layout Theme and select a layout theme 
in the selection list.

 8. Double-click  ROW Permanent Information Fields in the left pane of the window to view a list of 
fields available for selection.

Figure  4-45. Expanded ROW Permanent Information Fields

 9. Add the ROW Attached Documents field to the layout theme. Double-click ROW Attached 

Documents in the left pane of the Layouts window to move it to the right pane. Or click the   
button to move it. Add other fields as required. The layout theme includes all fields listed in the right 
pane.

NOTE: The   button becomes active after selecting a field and clicking in the check box.
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Figure  4-46. ROW Attached Documents Added to Layout

 10. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or select a field and then click the   or   buttons.

 11. Click   Save and Close to save changes and return to the grid.

Attach a Document to a Pipeline Record

You can attach a document to a pipeline information record or a pipeline maintenance record. 

Complete the following steps to attach a document to a pipeline record in the grids of either the Information 
or Maintenance tabs of the Edit ROW Detail window:

 1. Select one or more pipeline segments you want to work with in the Select ROWs window. Click  
Save to close the window. Refer to Select ROWs for more information.

 2. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. 
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Figure  4-47. Edit ROW Detail Window - Information Tab

 3. Select the tab where you want to attach a document to a pipeline record: if in the Information grid, 
click the Information tab; if in the Maintenance grid, click the Maintenance tab.

 4. Click the  icon in the ROW Attached Document field for the pipeline record you plan to attach a 
document.

Figure  4-48. Edit ROW Detail

 5. Click  Attach in the Maintain Attached Documents window. 
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Figure  4-49. Maintain Attached Documents Window

The Link Document and Embedded Document options become available.

 6. Select one of the following options for attaching a document: 

 l Link Document — select Link Document if you plan to link to a document on a local computer 
or company network. Edits to the document are made on the local computer or company 
network, whether accessed from within PCS or not. If you choose to link to a document on a 
local computer, users who access PCS from another computer may have trouble accessing 
the document.

 l Embedded Document— select Embedded Document if you want to store a copy of an 
attached document in the PCS database. Changes made to the document will not affect 
copies of the document that may be stored on your local computer or company network.

NOTE: Storing copies of attached documents in the database increases the size of the 
database.

 7. Click the  …ellipsis button in the Document field to open the Link File window. Then navigate to the file 
and select it. Click Open to link to the file and close the window.
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 8. Type a description for the linked file in the Description field of the Maintain Attached Documents 
window. When a description is not provided, PCS uses the filename of the linked document as the 
description. The example below shows a linked document and its description. The same process 
would apply to an embedded document.

Figure  4-50. Link Document Information

 9. Click  Save to save changes. 

If the document was linked, the following Confirm document attachment window displays.

Figure  4-51. Confirm Document Attachment Window for Linked Documents

If the document was embedded, the following Confirm document attachment window displays.
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Figure  4-52. Confirm Document Attachment Window for Embedded Documents

 10. Click  OK.

The document is added to the list of attached documents shown in the Maintain Attached 
Documents window.

Figure  4-53. Attached Document Added to Record

 11. Add additional documents as needed. Additional attached documents display in the window. 
Selecting an item in the list displays its location in the Document field.

 12. When finished adding documents, click  Save and Close. A message will appear confirming the 

linked or embedded document. Click  OK.
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View an Attached Document

If the file type of an attached document is associated with a default software program on the local 
computer, you can preview the file in the Preview Attached Documents window. Additionally, clicking Open 
opens the attached document for editing or viewing purposes.

Complete the following steps to view or open an attached document:

 1. Select one or more pipeline segments you want to work with in the Select ROWs window. Click  
Save to close the window. Refer to Select ROWs for more information.

 2. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. 

Figure  4-54. Edit ROW Detail Window - Information Tab

 3. Select the tab where you want to view an attached document: if in the Information grid, click the 
Information tab; if in the Maintenance grid, click the Maintenance tab.

 4. Click the  icon in the ROW Attached Document field for the pipeline record you plan to attach a 
document.
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Figure  4-55. Edit ROW Detail - Attached Documents

The Preview Attached Documents window opens.

Figure  4-56. Preview Attached Documents Window

 5. Select a file in the list on the left side of the window to view the file in the Preview Attached Documents 
window.
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Figure  4-57. Preview Attached Documents

 6. If the file type of the attached document is associated with a default software program on the local 
computer, click  Open to open the file.

 7. Click  to close the Preview Attached Documents window.

When you open and then edit an embedded document, changes apply only to the copy stored in the 
PCS database; changes do not apply to the source file stored outside of PCS. Likewise, editing the 
source file applies changes to the source file, not the copy stored in the PCS database.

Themes and Filter Groups for Pipeline Records
A theme is a group of named settings saved for later use, such as grid layout or sort theme. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 
themes available to all PCS users. These themes are identified with a globe icon and PCS in brackets, such 

as  [PCS] ROW Information.
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NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you would like to use 
a private theme, your company's system administrator must make your private theme a public one.

A filter group is a named set of one or more filters that affect the data output in the Edit ROW Detail grid. PCS 
provides two types of filter groups you can define. These include the AND and OR filter groups.

When you add a filter group, you define filter conditions that determine which records to include or exclude 
in the Edit ROW Detail grid. Adding an AND filter group produces a subset of records that meet all filter 
conditions. Adding an OR filter group produces a subset of records that meet any filter condition. When you 
apply a filter group to the grid, PCS processes filters in descending order beginning with the filter at the top 
of the group.

The following topics describe how to add a layout theme, sort theme, and an optional filter group in the 
Information and Maintenance grids of the Edit ROW Detail window. 

 l Add a Pipeline Record Layout Theme

 l Add a Pipeline Record Sort Theme on page 222

 l Add or Edit an AND Filter Group for Pipeline Records on page 226

 l Add or Edit an OR Filter Group for Pipeline Records on page 230

 l Apply or Remove a Filter Group for Pipeline Records on page 234

Refer to Select How Data Displays in the Information Grid and Select  How Data Displays in the Maintenance 
Grid for information about filtering the data output in a data entry grid.

Add a Pipeline Record Layout Theme

A layout theme is a group of fields that determine which fields are available for use in the Information and 
Maintenance data grid of Edit ROW Detail. Adding a new Layouts theme allows you to choose which fields 
to include in the data grid and then save the layout as a theme for later use.

IMPORTANT: If you are working with the optional Telluric Compensation feature, you can add a layout 
theme that includes the required field Telluric Compensation Required. This field must be enabled in the 
Information data grid of Edit ROW Detail for each pipeline segment requiring telluric compensation.

Complete the following steps to add a layout theme for the Information or Maintenance data entry grid in the 
Edit ROW Detail window:

 1. Select one or more pipeline segments you want to work with in the Select ROWs window. Click  
Save to close the window. Refer to Select ROWs for more information.
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 2. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. 

Figure  4-58. Edit ROW Detail Window - Information Tab

 3. To add a layout theme for the Information grid, click the Information tab  if the grid is not visible. Or 
click the Maintenance tab  to display the Maintenance grid if you want to create a layout theme for this 
grid.

 4. Click the  Customize tab to open the Customize window; ensure Layouts is selected from the 
right-hand menu bar.

Figure  4-59. Layouts Window

 5. Click  Add to open the New Layout Theme window. 



PCS v2.5 User Guide

Chapter 4: Pipeline Records 220

Figure  4-60. New Layout Theme

 6. Type a name for the layout theme in the Enter Theme Name field. 

 7. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.  A public theme is 
available for use by all PCS users. A private theme is available only to the user who creates it.

 8. If you want to copy the content of the selected theme shown in the Copy Field From Theme field, 
select the Copy Content check box. Select a different theme if desired.

 9. Click  OK to save changes and return to the Layouts window with the new layout selected.
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Figure  4-61. Layouts

 10. Complete the following steps in the Layouts window to add and remove fields in the new layout 
theme as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. 

 b. Double-click a field listed in the left pane to move it to the right pane, or select it and then click 

the   button to move it. Repeat this step as needed. The grid layout theme includes all 
fields listed in the right pane of the Layouts window.

NOTE: The   button becomes active after selecting a field and clicking in the check box.

 c. If Telluric Compensation is required for the selected pipeline segment(s), add the  Telluric 
Compensation Requiredfield in the layout theme.

 d. To remove a field in the layout theme, double-click a field listed in the right pane to move it to 

the left pane, or select it and then click the   button to move it. Repeat this step as needed.

NOTE: Fields with a   icon are required and cannot be removed from the theme.

 11. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  buttons.
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 12. Click  Save to save changes.

 13. To apply the new layout theme to the data entry grid:

 a. Click the Options tab.

Figure  4-62. Options with New Layout

 b. If the new layout is not shown in the Select Layout Theme field, select it from the drop-down 
list. 

 c. Select a method for sorting survey folders in the data entry grid based on the survey date in the 
Start Date field. Select either Click Oldest First or Newest First to sort survey folders with the 
oldest or newest survey Start Date first.

 d. Click  Apply to save changes and return to the data entry grid.

 14. If Telluric Compensation is required for the selected pipeline segment(s), click the Telluric 
Compensation Required check box for each pipeline segment requiring compensation.

Add a Pipeline Record Sort Theme

A sort theme determines how PCS sorts records in a data entry grid. Adding a sort theme allows you to 
choose which field(s) to sort records by and if records sort alphanumerically in ascending or descending 
order.

Complete the following steps to add a sort theme:

 1. Select one or more pipeline segments you want to work with in the Select ROWs window. Click  
Save to close the window. Refer to Select ROWs for more information.



PCS v2.5 User Guide

Chapter 4: Pipeline Records 223

 2. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. 

Figure  4-63. Edit ROW Detail Window - Information Tab

 3. To add a sort theme for the Information grid, click the Information tab  if the grid is not visible. Or click 
the Maintenance tab  to display the Maintenance grid if you want to create a sort theme for this grid.

 4. Click the  Customize tab  then the Sorts button to open the Sorts window.

Figure  4-64. Sorts Window

 5. Click  Add to open the New Sort Layout window.
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Figure  4-65. New Sort Layout

 6. Type a name for the sort theme in the field Enter Theme Name. 

 7. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.  A public theme is 
available for use by all PCS users. A private theme is available only to the user who creates it.

 8. If you want to copy the content of the selected theme shown in the Copy Field From Theme field, 
select the Copy Content check box. Select a different theme if desired.

 9. Click  OK to save changes and return to the Sorts window with the new layout selected.
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Figure  4-66. Sort Window with New Sort Theme

 10. Complete the following steps in the Sorts window to add and remove fields in the new sorting theme 
as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. 

 b. Double-click a field listed in the left pane to move it to the right pane, or select it and then click 

the   button to move it. Repeat this step as needed. The grid layout theme includes all 
fields listed in the right pane of the Layouts window.

NOTE: The   button becomes active after selecting a field and clicking in the check box.

 c. To remove a field in the layout theme, double-click a field listed in the right pane to move it to 

the left pane, or select it and then click the   button to move it. Repeat this step as needed.

NOTE: Fields with a   icon are required and cannot be removed from the theme.

 11. Select a sorting method for each field listed in the right pane. To sort grid records in ascending order, 

click the toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 12. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  buttons.
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 13. Click  Save to save changes.

 14. To apply the new sort theme to the data entry grid:

 a. Click the Options tab.

Figure  4-67. Options Window with New Sort Theme

 b. If the new layout is not shown in the Select Sort Theme field, select it from the drop-down list. 

 c. Click  Apply to save and apply changes and then return to the data entry grid. 

Add or Edit an AND Filter Group for Pipeline Records

An AND filter group is a named set of one or more filters that affect the data output in the Edit ROW Detail 
grid. Adding an AND filter group produces a subset of records that meet all filter conditions. PCS processes 
filters in a filter group in descending order beginning with the filter at the top of the filter group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to create or edit an AND filter  for use on the Edit ROW Detail window:

Refer to Apply or Remove a Filter Group for Pipeline Records for information on how to apply a filter.

 1. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window.

 2. Select the grid you want to work with by clicking the Information tab  or the Maintenance tab.

 3. Click the  Customize tab and then the Filters tab to open the Filters window.
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Figure  4-68. Filters Window

 4. To add a new 'And' filter group, click  New 'And' Group to open the filter properties group box.         

Figure  4-69. New 'And' Group Filter         

 5. Type a name for the filter group in the Filter Group Caption field. 

 6. If you want the filter to always remain on, select the  Filter is Always On check box. 

It is recommended that you add filters in the order in which you would like them used. 

icon_circles_joined_black.png
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 7. Use filter selection fields to set up filter criteria for the new filter. Select a PCS field, operator, and one 
or more filter conditions. Filter conditions are based on the PCS field selected. The line above the filter 
selection updates to show how the filter is defined. For example, shown below is a filter based on 
Default Location Format. The field and conditions are also shown in the space above the box. 

  

Figure  4-70. 'And' Filter Operators

The line above the box will update as you add or change conditions.

Figure  4-71. 'And' Filter With Conditions

 8. If desired, type a name for the filter in the Enter Custom Filter Caption field. The line above the filter 
box will update with this name.
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Figure  4-72. Custom Filter Caption Name Update

 9. For fields that include a date (such as ROW Effective Date), click the down arrow in the start date field 
to open a calendar and select a date. You can also type a date in the start and end date fields. Enter a 
start and end date using the format M/DD/YYYY to indicate the month, day, and year. Repeat this 
step for the end date field.

Figure  4-73. Date Filter Start Date

 10. To set a date range using dynamic start and end dates, click the  icon in the start date field and set 

up dynamic date properties. Repeat this step for the end date field. Clicking the icon opens and 
closes dynamic date property fields. 

 11. To close a filter box, click the  icon in the upper left corner.
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Figure  4-74. Close a Filter Box

 12. To delete a filter, click the  icon on the right side of the filter box.

 13. If additional filters are needed within the filter group, click  to add a new filter box and repeat these 
steps. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

 

Figure  4-75. Edit Icon with New Filter Group   

 14. Click the  icon for a filter to open that filter's property settings and change settings as needed. 

 15. Click  Save to save the filter(s).  Add or edit filters as desired.

 16. When finished, click  Save and Close to save filter(s) and close the window. 

Refer to Apply or Remove a Filter Group for Pipeline Records for more information on how to apply a filter 
group to a data grid.

Add or Edit an OR Filter Group for Pipeline Records

An OR filter group is a named set of one or more filters that affect the data output in the Edit ROW Detail grid. 
Adding an OR filter group produces a subset of records that meet any filter condition. PCS processes filters 
in a filter group in descending order beginning with the filter at the top of the filter group.
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These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to create or edit an OR filter  for use on the Edit ROW Detail window:

Refer to Apply or Remove a Filter Group for Pipeline Records for information on how to apply a filter.

 1. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window.

 2. Select the grid you want to work with by clicking the Information tab or the Maintenance tab.

 3. Click the Customize tab and then the Filters tab  to open the Filters window.

Figure  4-76. Filters Window

 4. To add a new 'Or' filter group, click New 'Or' Group to open the filter properties group box. 
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Figure  4-77. Filters         

 5. If you want the filter to always remain on, select the  Filter is Always On check box. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

 6. Use filter selection fields to set up filter criteria for the new filter. Select a PCS field, operator, and one 
or more filter conditions. Filter conditions are based on the PCS field selected. The line above the filter 
selection updates to show how the filter is defined. For example, shown below is a filter based on 
Default Location Format. The field and conditions are also shown in the space above the box. 

Figure  4-78. 'Or' Filter Operators

The line above the box will update as you add or change conditions, for example changing Contains 
to Does Not Contain.
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Figure  4-79. 'Or' Filter With Conditions

 7. If desired, type a name for the filter in the Enter Custom Filter Caption field. The line above the filter 
box will update with this name.

Figure  4-80. Custom Filter Caption Name Update

 8. A field that includes an  icon in the operator line indicates that a dynamic value can be set. 

Figure  4-81. Field Operators with Dynamic Values Option

Click the icon to open dynamic property fields and enter values as needed. Click the to remove 
entered values and clear the fields.

Figure  4-82. Dynamic Field Operators
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 9. Click  Save to save the filter.

 10. To re-open the filter box to view or edit the filter, click the  icon.

 11. To close a filter box, click the  icon in the upper left corner.

Figure  4-83. Close a Filter Box

 12. To delete a filter, click the  icon on the right side of the filter box.

 13. If additional filters are needed within the filter group, click  to add a new filter box and repeat these 
steps. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

Figure  4-84. Adding a New Filter Box

 14. Click  Save to save the filter(s). Add or edit filters as desired.

 15. When finished, click  Save and Close to save filter(s) and close the window. 

Refer to Apply or Remove a Filter Group for Pipeline Records for more information on how to apply a filter 
group to a data grid.

Apply or Remove a Filter Group for Pipeline Records

After creating an AND or an OR filter group, the filter can be applied to or removed from the data entry grid of 
the Edit ROW Detail window using the Options window.

Refer to Add or Edit an AND Filter Group for Pipeline Records and Add or Edit an OR Filter Group for 
Pipeline Records for information on how to create filter groups.
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Complete the following steps to apply or remove one or more filters to the data entry grid of the Edit ROW 
Detail window:

 1. Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window.

 2. Select the grid you want to work with by clicking either the Information tab  or the Maintenance tab.

 3. Ensure that the Options tab  is selected. The filters will display in the Filters pane.

Figure  4-85. Options Window - New Filters in Filters Pane

 4. Click the check box for each filter you want to apply.

 5. Click  Apply to save changes and return to the data entry grid. 

 6. To remove a filter that has been applied, open the Options window and de-select any filter you no 

longer want to apply. Click  Apply to save changes and return to the data entry grid.
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Chapter 5:  Data Entry Grids and Forms
Record data can be viewed using  data entry grids and forms in any of the modules.

The grids and form in any of the modules can be accessed through the Data Entry menu in the header bar. 

This chapter  includes the following topics:

 l Types of Data Entry Grids

 l Field Caption Colors on page 237

 l View Data in a Grid or Form on page 239

 l Work with Records on page 255

 l Build a Survey in the Inspection Grid Based on Schedule on page 342

 l Work with Continuous Survey Data on page 343

 l Themes and Filter Groups on page 368

Types of Data Entry Grids
PCS provides the following data entry grids and mini-grids for organizing and managing facility data. These 
grids are similar to a spreadsheet in appearance with facility data presented in columns, rows, and 
individual fields. Several options are available for customizing the layout and sorting order of a grid, as well 
as applying data filters that allow you to work with a subset of facility records.

 l Information grid — add and edit permanent facility information, such as the milepost number, 
location description, operating status, protection criteria, and permanent comments. The 
Information grid is also used for activating fields in the Inspection grid.

 l Inspection grid — add and edit survey inspection data for facilities on a pipeline segment, such as 
facility inspection readings, GPS coordinates, survey folder assignment, survey remarks, technician 
name, and so on.

 l Maintenance grid — add and edit maintenance and repair records for facilities on a pipeline segment.

 l CPDM Test Point Detail Information and Inspection mini-grids — manage multiple potential 
measurements for survey points linked to a test point record. These mini-grids function in a similar 
manner as the rectifier mini-grids when linking rectifier anodes and negatives. The potential 
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measurement selected for compliance reporting in the Detail Inspection mini-grid copies to the linked 
test point record in the main Inspection grid.

The Test Point Detail mini-grids become available for use after enabling the system option Show 
Detail Inspection Entry Grid. When using the optional Telluric Compensation feature, the mini-grids 
display by default and cannot be disabled.

 l Maintenance Links and Inspection Links mini-grids — use the Maintenance Links mini-grid in the 
Inspection grid to view the maintenance records that are related to the selected inspection record. 
Use the Inspection Links mini-grid in the Maintenance grid to view the inspection records that are 
related to the selected maintenance record.

 l Facility Level Override mini-grid — the Information grid for all modules includes the Facility Level 
Override mini-grid. Scheduling properties in Edit Schedule Settingscan be overridden at the facility 
level using this mini-grid. Refer to Schedules on page 509 for more information.

 l Rectifier Information mini-grids — the CPDM Rectifier Information grid includes the Rectifier Anode 
Information and Rectifier Negative Information mini-grids. Use these mini-grids to add and delete 
records for impressed anodes and negatives linked to a rectifier information record.

 l Rectifier Inspection mini-grids — the CPDM Rectifier Inspection grid includes the Rectifier Anode 
Inspection and Rectifier Negative Inspection mini-grids. Use these mini-grids to enter inspection 
readings for rectifier anode(s) and negatives linked to one or more pipeline segments.

Field Caption Colors
PCS uses a color code system in field captions throughout the system that allows you to easily identify one 
data type from another. Below is an example of how column headers and field names are color-coded in 
the data grid and layout theme, respectively.
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Figure  5-1. Colors in Field Captions

Field captions in column headings of a data entry grid are color-coded to help distinguish different data 
types, such as information, inspection, and maintenance fields. Likewise, field captions in selection lists are 
also color-coded when creating themes in the Customize tab. The following table identifies the different 
data types with corresponding colors.

Data Type Color

Facility Field Black

Facility Information Field Blue

Inspection Field Red

Maintenance Field Red

ROW and Pipeline Field Green

All Others Black

Table 5-7.  Data Type Color Definitions          
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View Data in a Grid or Form
Information, inspection, and maintenance records for all facility types in a module can be accessed through 
the Data Entry main menu and then selecting Edit <Module Name> Data. In this window, you can define 
which records you wish to see and how you want to display the data. You can view and edit data in a table-
like grid or in a form view reminiscent of paper forms. An example of the Edit CPDM Data window is shown 
below.

Figure  5-2. Information Grid

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to view a module's data:
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 1. Select Edit <Module> Data in the Data Entry menu.

 2. Click the Information, Inspection, or Maintenance tab to view information, inspection, or 
maintenance records. 

 3. If available, click the facility type's tab. Facility type tabs will not be available for modules with only one 
facility type.

 4. Depending on the module you are in and the settings configured in Options, the grid's options may 
display immediately upon selecting the grid. For instructions detailing how to configure the grid's 
options, refer to Set Options for Viewing Data on page 240.

The Edit <Module> Data window shows only the records defined in the Options tab. The data is loaded with 
the layout selected for the grid and/or the form selected.

Refer to the following topics for additional information on viewing data in a grid or form:

 l Set Options for Viewing Data

 l Select  Records

 l Arrange a Grid and Form

 l Rearrange and Resize Grid Columns

 l Lock and Unlock Grid Columns

 l Use Find to Search a Data Entry Grid

 l Print, Export, or Email Grid Content

Set Options for Viewing Data

A data grid's Options define which records you see and how you display the data. You can view and edit 
data in a table-like grid or in a form view. These instructions start with the assumption that you have a data 
grid selected. For information about accessing a grid of data, refer to View Data in a Grid or Form on page 
239.

Depending on the module you are in and the settings configured in Options, the options may display 
immediately upon selecting the grid. To access the grid's options at any time, click  Options. 

Complete the following steps to change the data grid's options:

 1. Decide if you want to include data to display based on ROWs selected, defined routes, or a schedule 
definition. Select the radio button for the desired Based On mode and fill out the rest of the fields in 
the Based On pane as needed:



PCS v2.5 User Guide

Chapter 5: Data Entry Grids and Forms 241

 l Selected ROWs — uses the ROWs selected in the Selected ROWs pane. Refer to Select 
ROWs for more information.

 l Route — select a route from the list. To select multiple routes, press Ctrl on the keyboard while 
selecting routes.

 l Schedule — select a schedule definition from the drop down. 

Figure  5-3. Based on Schedule Option

Define the schedule date range by doing one of the following:

 — Using a Calendar: to set up a schedule date range using a calendar:

 a. Set a schedule start date. Click the down arrow in the Start Date field and select a 
date in the calendar.

 b. Set a schedule end date. Click the down arrow in the End Date field and select a 
date in the calendar.

 — Using Dynamic Dates: to set a schedule date range using dynamic start and end dates, 
follow these steps:

 a. Click the Start Date  calculator to open dynamic start date fields.

 b. Click the down arrow in the Start Date field and select one of the following 
options: Today, End Of Month, Beginning Of Year, or End Of Year.

 c. In the remaining two fields, type an offset value in the first field and then click the 
down arrow in the second field and select one of the following options: Day(s), 
Month(s), or Year(s). Click the  pencil button to close dynamic start date fields.

 d. Click the End Date  calculator to open dynamic end date fields.

 e. Click the down arrow in the End Date field and select one of the following options: 
Today, End Of Month, Beginning Of Year, or End Of Year.

 f. In the remaining two fields, type an offset value in the first field and then click the 
down arrow in the second field and select one of the following options: Day(s), 
Month(s), or Year(s). Click the  pencil button to close dynamic end date fields.

For ISM Modules, select a survey folder from the Selected Continuous Survey drop-down. 
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Figure  5-4. ISM Data Selected Continuous Survey Option

 2. In the View pane, select the radio button to determine the format to use when displaying the data. 
The Grid option puts all included records' data in a standard table grid layout. The Form option 
displays data related to a single selected record in a manner similar to paper forms. The Grid and 
Form option puts all included records' data in a standard table grid layout, with a form showing the 
selected record's data next to the grid.

Depending on the format selected, the following options may be available:

 l Select Layout Theme — the layout theme defines the fields to include as a column in the grid 
view. The layout theme is only available to select if Grid or Grid and Form were selected. 
Layout themes are defined in the Customize tab. Refer to Add a Data Grid Layout Theme on 
page 369 for more information.

 l Select Form Theme — the form theme defines which field and form elements are displayed on 
the screen and how they appear. The form theme is only available to select if Form or Grid and 
Form were selected. Form themes are defined in the Customize tab. Refer to Work with Form 
Themes on page 382 for more information.

 l Select Sort Theme — the sort theme defines the order the records are displayed in the grid or 
form and is always available. Sort themes are defined in the Customize tab. Refer to Add a Sort 
Theme on page 374 for more information.

 l Sort Dates — the sort dates radio buttons determine whether dates in the sort theme are 
sorted oldest to newest or newest to oldest.

 3. In the Options pane, select the appropriate check boxes   as available. The options available vary 
depending on which module you are in and if you chose the Information, Inspection, or Maintenance 
tab. The options may include:

 l Only the most recent information record for each facility — select this check box to limit the 
data displayed in the grid or form to only the most recent information record based on the 
Effective Date for each facility. All previous information records will not be displayed.

 l Only show facilities with inspections  — select this check box to limit the data returned so 
facilities that do not have inspections will not be included.
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 l Filter Options — these options determine whether to filter results to show only the most recent 
inspections and if so, whether to apply this most recent inspection filter before or after applying 
the filters defined in the Filters pane. Select the radio button for one of the following options:

 — All Inspections that meet the filter criteria — this option will not filter the data returned by 
the selections made in the Based On pane. The only filters applied to the data will be 
those made in the Filters pane.

 — Apply other filters to the most recent inspection found within report timeframe — this 
option will filter the data to include only the most recent inspections before applying 
additional filters. In other words, the data that shows in the grid or forms will be 
determined by the following rules:

 ¡ First, PCS will gather all data that matches the selections made in the Based On 
pane. 

 ¡ Next, PCS will include only the most recent inspection for each facility in the 
Based On set of data.

 ¡ Finally, PCS will filter the most recent inspections data set based on the filters 
defined in the Filters pane.

 — The most recent inspection after the filter criteria has been met — this option will filter 
the data to include only the most recent inspections after applying additional filters. In 
other words, the data that shows in the grid or forms will be determined by the following 
rules: 

 ¡ First, PCS will gather all data that matches the selections made in the Based On 
pane. 

 ¡ Next, PCS will filter the Based On set of data with the filters defined in the Filters 
pane.

 ¡ Finally, PCS will include only the most recent inspection for each facility in the 
Filters set of data.

 4. In Filters pane, define the filters in the as needed.The Filters pane consists of a set of pre-defined 
filters as well as on demand filters grouped together with AND or OR joins. A filter group is a named 
set of one or more filters that affect the data returned. Adding an AND filter group produces a subset 
of records that meet all filter conditions. Adding an OR filter group produces a subset of records that 
meet any filter condition. PCS processes all filters in AND filter groups together then processes all 
filters in OR filter groups together. 
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Refer to Add or Edit an AND Filter Group for Pipeline Records, beginning with step 3 for more 
information on adding an AND filter. The steps to add the filter group are the same, except for the field 
names.

Refer to Add or Edit an OR Filter Group for Pipeline Records, beginning with step 3, for more 
information on adding an OR filter. The steps to add the filter group are the same, except for the field 
names.

Pre-defined filters — named filter groups that have already been defined are listed at the top of the 
Filters pane. To use one of the pre-defined filters, select the check box next to the filter and fill in the 
filter's fields as appropriate.

 5. Click Apply. The Options tab closes and Edit <Module> Data grid updates to display only the data 
defined in the Options tab. The data is loaded with the layout selected for the grid and/or the form 
selected.

Figure  5-5. Information Grid

Select  Records

Depending on the selections made in the Options window's View pane, the grid's records may show in a 
table-like grid format,  form format, or with both the grid and the form showing. The following is an example 
of the grid showing both the grid and form.
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Figure  5-6. Grid and Form

Specific records can be selected with any of the following methods, depending on the view selected:

 l Selecting records in a grid — scroll up or down in the grid to locate and select the record.

 l Selecting records in a form — click the navigation buttons at the top of the form to view the  first , 

 previous ,  next , and  last    facility record.

Figure  5-7. Navigating Records in Form View

 l Selecting records in a grid and form — select a record in the grid to view or edit in either the grid or 
form, or click the navigation buttons at the top of the form to locate your record and view it in the form 
or grid. When a record is edited in either the grid or form, the record edits are displayed in both the 
grid and the form. 

Complete the following steps to find records based on specific criteria:
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 1. Click  Find  to open the search properties pane.

Figure  5-8. Find

 2. Select a Find Operator radio button. If you want search results to meet all search criteria, select the 
AND operator. If you want search results to meet any search criteria, select the OR operator.

 3. Set up search criteria. Select a PCS field, operator, and value using the selection fields. To add 

another row of selection fields, click Add Field and then select a PCS field, operator and a value 
using the added row of selection fields.

 4. Click Find Next Match to search the grid for the first record that matches the criteria entered. Click 
the button again to find the next match.

 5. Click Reset Find to clear and reset search selection fields and click  Find  to close the search 
properties pane.

Arrange a Grid and Form

When the option Grid And Form is selected in the Options window, you can arrange the grid and form using 
any of the following methods:

 l Right-clicking the title bar in the Form or Grid pane opens a shortcut menu allowing you to select the 
Dock or Float command. Select Dock to anchor a pane within the PCS application. Select Float to 
separate the pane into its own window.
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Figure  5-9. Title Bar Options Menu

 l Double-click the title bar in the Form or Grid pane to float these panes when they are docked. To 

dock the pane again, click and drag the pane to one of the guide boxes  that display (see below).

 l Select the title bar of a form or grid and then drag the pane to display a guide diamond. Drag the form 

or grid pane to a one of the guide boxes  to select where you want the pane to dock in the window. 
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Figure  5-10. Arranging a Grid and Form

The area where you select to move the pane highlights in blue. Release the mouse button to pin it to 
that area.

Figure  5-11. Moving a Pane

The panes are re-arranged accoringly.
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Figure  5-12. Final Placement of Panes

Rearrange and Resize Grid Columns

Rearranging grid columns in a data entry grid is easily accomplished by dragging and dropping a grid 
column to a new position. Performing this function requires appropriate user permissions for modifying a 
data entry grid layout theme. If the data entry grid layout theme is Public, changes apply only to the current 
session of the data entry grid and are not saved in the layout theme. When the data entry grid layout theme 
is Private, the new column order is saved in the data entry grid layout theme.

Rearrange Column Order

Drag and drop a selected grid column to a new position in the data entry grid.

Figure  5-13. Moving a Column
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Figure  5-14. Reorder Columns Complete

Resize Grid Columns

Place the mouse over a column boundary to change the cursor to a  horizontal resize cursor. Then click 
and drag the column boundary to resize the grid column.

Figure  5-15. Resize a Column

Lock and Unlock Grid Columns

You can lock one or more grid columns on the left side of a data entry grid to prevent them from moving 
when scrolling the data entry grid. Grid columns to the right of locked columns remain scrollable.

To lock a grid column, right-click a grid column and then select Lock Column in the shortcut menu that 
opens.
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Figure  5-16. Lock Column Menu Option

To unlock a locked grid column, right-click the locked grid column and then select Unlock Column in the 
shortcut menu that opens.

Use Find to Search a Data Entry Grid

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to search the content of a data entry grid:

 1. Open the Edit <module> Data window. For example, click Data Entry > Edit CPDM Data to open the 
Edit CPDM Data window.

 2. Select a data entry grid. For example, click the Information tab  and then the Test Point tab to display 
the Test Point Information data entry grid.

 3. If the Options window is open, press Enter or click  Apply to view the grid.
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Figure  5-17. CPDM Test Point Information Grid

 4. Click the  Find button to open the search properties pane.

Figure  5-18. Find

 5. Select a Find Operator option. If you want search results to meet all search criteria, select the AND 
operator. If you want search results to meet any search criteria, select the OR operator.

 6. Set up search criteria. Select a PCS field, operator, and value using the selection fields. To add 

another row of selection fields, click  Add Field and then select a PCS field, operator and a value 
using the added row of selection fields.

 7. Click  Find Next Match to search the grid. Click the button again to find the next match.

 8. Click  Reset Find to clear and reset search selection fields.

 9. Click the  Find button to close the search properties pane.
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Print, Export, or Email Grid Content

The following information explains how to print and export a report with content in a data entry grid. 
Supported file formats for exporting a report include PDF, HTML, MHT, RTF, XLS, XLSX, CSV, TXT, and 
Image (BMP, EMF, WMF, GIF, JPEG, PNG, and TIFF).

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to print, export, or email grid content:

 1. Click the Data Entry menu and select a module. For example Data Entry > Edit CPDM Data will open 
the Edit CPDM Data window.

Figure  5-19. Test Point Inspection Grid

 2. Select a data entry grid by selecting both a main tab and a facility type. For example, click the  
Informationtab and then the  Test Point tab to display the Test Point Inspection data entry grid (as 
shown in the example above).
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 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. Click  Print to open a print preview window.

Figure  5-20. Print Preview

 5. To print the report using the default Windows printer, click the  Quick Print button.

 6. To open a print window and select a printer to print the report, click the  Print button.

 7. To select a file format and export the report, click the down arrow in  Export Document and select 
a file format in the selection list.

 a. In the Options window, set up optional property settings and then click OK to close the 
window.

 b. In the Save As window, type a name for the report in the File name field and then navigate to a 
location on your computer to save the report.

 c. Click Save. click Yes or No in the Do you want to open this file message window, 

 8. To select a file format and send the report as an attachment in an email, click the down arrow in  
Send via E-mail and select a file format in the selection list.

 a. In the Options window, set up optional property settings and then click OK to close the 
window.
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 b. In the Save As window, type a name for the report in the File name field and then navigate to 
location on your computer to save the report.

 c. When an email message opens with the report as an attachment, select an email recipient and 
then click Send.

 9. Click the  Exit button to close the print preview window and return to the data entry grid.

Work with Records
You can view, add, attach documents to, and work with various record types in a data entry grid. 

This chapter  includes the following topics:

 l Add Facility Records

 l Activate Facility Inspection Fields for Data Entry on page 279

 l Work with Multiple Test Point Potentials on page 279

 l Replace All Values on page 284

 l Create History Records Using an Effective Date on page 285

 l View a Linked Maintenance or Inspection Record on page 288

 l View a Record's Change History on page 289

 l View Records Based on Selected ROWs

 l View Records Based on a Schedule on page 293

 l View Records Based on a Route on page 295

 l Work with Derived Fields on page 296

 l Work with the Target Structure P/S Field on page 297

 l Record Facility Current Values on page 299

 l Attach a Document to a Grid Record on page 305

 l Work with an Images Field on page 312

 l Link Rectifiers to ROWs on page 327

 l Work with Rectifier Anodes on page 330

 l Work with Rectifier Negatives on page 335
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Add Facility Records

Facility information, including facility inspection and facility maintenance, can be added to the data entry 
grid. 

This chapter  includes the following topics:

 l Add a Facility Information Record

 l Add a Facility Inspection Record on page 263

 l Add a Facility Maintenance Record on page 270

Add a Facility Information Record

Use the Information grid to add a record for a new facility on a pipeline, add an information record for an 
existing facility in the grid, add a history record to maintain permanent information about a facility, and 
activate fields for data entry in the Inspection grid. 

These instructions start with the assumption that you have a facility type's Information grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239.

Complete the following steps to either add add a record for a new facility or add an information record for an 
existing facility  on a pipeline in the Information grid. These steps can be used to add a new facility type or 
record for any of the facility types.

 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Information tab and select a facility type from the selections below the Information, 
Inspection, and Maintenance tabs.
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Figure  5-21. Information Grid

 5. Click  Add to open the Add Record window. 
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Figure  5-22. Add Record - Add New Facility or Information Record

 6. To add a new facility of the selected facility type, select Add New <facility type>. 
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Figure  5-23. Add Record - Add New Facility Record
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 a. Select the pipeline in the window that you want to add a new facility and information record.

Figure  5-24. Add Record - Selected Pipeline for Information Record

 b. Click  Save to display the Add Record window with required field(s) for data entry. Required 
fields are identified with the  icon, such as Milepost.
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Figure  5-25. Add Record - New Facility Information Data Entry Fields

 c. Complete data entry fields as needed.

 d. Click  Save to close the window and add the new facility record in the Information grid.

 e. Activate desired fields for data entry in the Inspection grid by clicking in the check box for an 
"activate" field in the Information grid.

For example, click the  Activate Casing P/S check box for the newly created milepost.

Figure  5-26. Activate Data Entry Field in Information Grid

 7. To add a new information record for the existing facility type in the grid, select Add Information 
Record to Existing <facility type>.
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Figure  5-27. Add Record - Add Information Record for Existing Facility Type
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 a. Click  Save to display the Add Record window with required field(s) for data entry. 

Figure  5-28. Add Record - New Information Record for Facility Type Data Entry Fields

 b. Complete data entry fields as needed. For the date in the Effective Date field, use the format 
MM/DD/YYYY to indicate the month, day, and year. Or click the down arrow in the field and 
select a date using a calendar.

Effective Date is the date a history record becomes effective. New history records are created 
with an Effective Date when important permanent information changes. Refer to Create 
History Records Using an Effective Date on page 285 for more information.

 c. Click  Save to close the Add Record window and add an information record to the grid for 
the existing facility.

 8. Enter other facility data as needed in the grid.

 9. Click  Refresh to update the grid.

Add a Facility Inspection Record

These instructions start with the assumption that you have a facility type's Inspection grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239. 
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Complete the following steps to either           add a new facility with an inspection record or add an inspection 
record for an existing facility or   in the Inspection grid:

 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Inspection tab and select a facility type from the selections below the Information, 
Inspection, and Maintenance tabs.

Figure  5-29. Inspection Grid
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 1. Click  Add to open the Add Record window. 

Figure  5-30. Add Record - Add New Facility or New Inspection Record

 2. To add a new facility with an inspection record in the Inspection grid, select Add New <facility type>.
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 a. Select a pipeline with the facility you want to add an inspection record. 

Figure  5-31. Add Record - Selected Pipeline

 b. Click  Save to display the Add Record window with required field(s) for data entry.



PCS v2.5 User Guide

Chapter 5: Data Entry Grids and Forms 267

Figure  5-32. Add Record - New Facility Record Data Entry Fields

 c. Complete data entry fields as needed.

 d. Type an inspection date in the Inspection Date field using the format MM/DD/YYYY to indicate 
the month, day, and year. Or click the down arrow in the field and select an inspection date 
using a calendar.

 e. Click  Save to close the window and the new facility with an inspection record in the grid.

 3. To add a new inspection record to the existing facility type in the grid, select Add Inspection Record 
to Existing <facility type>.
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Figure  5-33. Add Record - Add Inspection Record to Existing Facility Type
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 a. Select a facility to which to add a new record.

Figure  5-34. Add Record - Selected Pipeline for Inspection Record

 b. Click  Save to display the Add Record window with required field(s) for data entry.  Required 
fields are identified with the  icon.
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Figure  5-35. Add Record - Add Inspection Record for Existing Facility Data Entry Fields

 c. Complete data entry fields as needed.

 d. Type the facility milepost number in the Milepost field. Based on your system configuration, the 
Milepost field may have a different caption for User Location Name, such as Station Number or 
other type of identifier.

 e. Type an inspection date in the Inspection Date field using the format MM/DD/YYYY to indicate 
the month, day, and year. Or click the down arrow in the field and select an inspection date 
using a calendar.

 a. Click  Save to close the window and add the inspection record to the grid.

 4. Enter other inspection data in remaining fields.

 5. Click  Refresh to update the grid.

Add a Facility Maintenance Record

These instructions start with the assumption that you have a facility type's Maintenance grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239. 

Complete the following steps to either add a new facility with a maintenance record or add a maintenance 
record for an existing facility or             in the Maintenance grid:
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 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Maintenancetab and select a facility type from the selections below the Information, 
Inspection, and Maintenance tabs.

Figure  5-36. Maintenance Grid
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 1. Click Add to open the Add Record window. 

Figure  5-37. Add Record - Add Maintenance Facility or Record

 2. To add a new facility in the grid with a maintenance record, select Add New <facility type>.
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Figure  5-38. Add Record - Add New Facility Record
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 a. Select the pipeline in the window that you want to add a new facility and information record.

Figure  5-39. Add Record - Selected Pipeline

 b. Click  Save to display the Add Record window with required field(s) for data entry. Required 
fields are identified with the  icon.
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Figure  5-40. Add Record - New Facility Maintenance

 c. Type the facility milepost number in the Milepost field. Based on your system configuration, the 
Milepost field may have a different caption for User Location Name, such as Station Number or 
other type of identifier.

 d. Type a date in the Repair Found Date field using the format MM/DD/YYYY to indicate the 
month, day, and year. Or click the down arrow in the field and select a date using a calendar.

 e. Complete data entry fields as needed. If required, enter a repair code in the Test Point Repair 
Code field. Repair code is a designation used by your company to identify the type of repair. 
The field accepts up to 15 alphanumeric characters including special characters such as the 
pound sign (#), asterisk (*), or hyphen (-).

 f. Click  Save to close the dialog and add the new facility with an maintenance record in the 
grid.

 3. To add a new information record for the existing facility type in the grid, select Add Maintenance 
Record to Existing <facility type>.
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Figure  5-41. Add Record - Add Maintenance Records to Existing Facility
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 a. Select a pipeline in the window that you want to add a new facility and maintenance record. 

Figure  5-42. Add Record - Selected Pipeline for Maintenance Record

 b. Click  Save to display the Add Record window with required field(s) for data entry.. Required 
fields are identified with the  icon.
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Figure  5-43. Add Record - Add New Record to Existing Facility Data Entry Fields

 c. Complete data entry fields as needed. 

 d. Type the facility milepost number in the Milepost field. Based on your system configuration, the 
Milepost field may have a different caption for User Location Name, such as Station Number or 
other type of identifier.

 e. Type a date in the Repair Found Date field using the format MM/DD/YYYY to indicate the 
month, day, and year. Or click the down arrow in the field and select a date using a calendar.

 f. Type a repair code in the Test Point Repair Code field. Repair code is a designation used by 
your company to identify the type of repair. The field accepts up to 15 alphanumeric 
characters including special characters such as the pound sign (#), asterisk (*), or hyphen (-).

 g. Click  Save to close the dialog and add the new facility with an maintenance record in the 
grid.

 4. Enter other maintenance data as needed in the grid.

 5. Click Refresh to update the grid.
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Activate Facility Inspection Fields for Data Entry

Inspection fields with Activate in the field description must first be added and enabled in the facility 
Information grid to allow data entry of inspection readings in the facility Inspection grid. 

These instructions start with the assumption that you have a facility type's Information grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239.

Complete the following steps to activate facility inspection fields for data entry:

 1. Click the check box of an Activate inspection field for a facility in the grid to place a check mark in the 
check box. For example, click the  Activate Structure P/S (Volts) check box for a facility in the grid.

 2. Click Yes to apply the change when a warning message displays to notify you of a change to the 
facility's permanent history record.

The inspection field is now available for data entry in the Inspection grid for the selected facility. If the 
inspection field is not present in the Inspection grid, refer to Add a Data Grid Layout Theme on page 
369 for information about adding fields in a grid.

Work with Multiple Test Point Potentials

Use the CPDM Test Point Detail Information and Test Point Detail Inspection mini-grids to manage multiple 
potential measurements for test point subfacilities linked to a test point facility. These mini-grids function in 
a similar manner as the rectifier mini-grids when linking rectifier anodes and negatives.

The Test Point Detail Inspection mini-grid allows you to select which potential measurement to use for 
compliance reporting. After selecting a potential measurement for compliance reporting, PCS 
automatically copies it to the associated test point facility in the Inspection grid.

NOTE: The Test Point Detail mini-grids become available for use after enabling the system option Show 
Detail Inspection Entry Grid. When using the optional Telluric Compensation feature, the mini-grids display 
by default and cannot be disabled.

Link Multiple Subfacilities to a Parent Test Point Facility

Multiple subfacilities can be linked to a parent test point facility. 

You can select one of the subfacility potential measurements (survey readings) for compliance reporting. 
Once new subfacility records have been added and linked to a parent test point facility in the Test Point 
Detail Information mini-grid, they are then available for use in the Test Point Detail Inspection mini-grid.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.
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Complete the following steps to link multiple subfacilities to a parent test point facility:

 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Information tab and then select Test Point.

Figure  5-44. Information Grid

 5. Select a test point facility in the Information grid.
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Figure  5-45. Selected Test Point in Information Grid

Repeat these steps for each new subfacility record you want to add and link to the currently selected 
test point facility record.

 6. Click   in the Test Point Detail Information mini-grid.

Figure  5-46. Information Test Point - Test Point Detail Information Mini Grid

 7. In the Add Record window type a unique name for the new subfacility in the Name field. This field 
supports up to 100 alphanumeric characters. Fields requiring information include a  icon. You must 
enter information in the required fields before the record will be added.
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Figure  5-47. Add Record Dialog Box

To prevent adding duplicate subfacility records in the system, it is important to enter a unique name 
in the Name field for each subfacility record. 

 8. Select the name of a PCS field from the PCS Field Name drop-down. Select a PCS field name that 
matches the type of potential measurement associated with the new subfacility.

 9. Click  Save to add the record and close the window. The new sub-facility is added to the mini-grid.
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Figure  5-48. New Subfacility Added to Mini-grid

 10. Open the Test Point Inspections grid. If the Test Point Detail Inspections mini-grid is not visible, 
double-click Test Point Detail Inspection at the bottom of the window to open the mini-grid.

 11. In the Test Point Inspectionsgrid, complete the following steps to add potential measurements 
(survey readings) for subfacilities in the Test Point Detail Inspection mini-grid, and then select one of 
these for compliance reporting:

 a. Select a test point facility in the Inspection grid that includes subfacilities you want to add 
potential measurements. For example, the test point that you created the subfacility for in the 
previous step.
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Figure  5-49. Test Point Detail Inspection Mini-Grid

 b. If potential measurements have not previously been added in the mini-grid, click  to enable 
the mini-grid for data entry.

 c. Select a subfacility in the mini-grid. Then add potential measurements and other related 
survey data in appropriate mini-grid fields. Repeat this step as needed for other linked 
subfacilities in the mini-grid.

 d. To select a potential measurement to use for compliance reporting, click the Compliance 
option button in the mini-grid associated with the subfacility record.

 e. Based on your PCS license, the Compliance field may be named Selected Reading instead.

 f. Click  Refresh to copy the selected potential measurement to the linked test point facility in 
the Inspection grid.

 g. When a value for a dependent field has been updated in a data entry grid, a  notification icon 
displays in the derived field indicating the value has changed and the data entry grid should be 

refreshed. Clicking  Refresh updates all derived values and removes the notification icon. 
Refer to Work with Derived Fields on page 296 for more information.

Replace All Values

You can replace a values in all fields of a selected grid column with the same value. 

NOTE: The Replace All Values command is not available for read-only grid columns, fields in a mini-grid, or 
picklist fields.
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Complete the following steps to replace all values in a grid column:

 1. Right-click the grid column and select Replace All Values in the shortcut menu. 

Figure  5-50. Replace All Values Shortcut

 2. In the Replace All Values window, select a value from the drop-down list that will be used to replace 
the current value in all fields of the selected grid column.

Figure  5-51. Replace All Values Window

 3. Select Replace with empty value if you would like the fields to be replaced with no value.

 4. Select Create history records with date and select a date from the drop-down calendar if you would 
like to create history records with the same date for all fields.

 5. Click OK to save changes.

Create History Records Using an Effective Date

A history record is a record that identifies changes in facility information, such as the operating status 
changing from active to inactive. Instead of deleting a facility record, create a history record.
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History records help ensure compliance reports are accurate and other reports include correct facility data. 
For example, information for inactive facilities does not appear in a compliance or scheduling report. Other 
reports provide an optional filter for excluding inactive facilities. Because information for the time period 
prior to deactivating a facility is still valuable and is often needed for compliance reports, creating a history 
record helps ensure facility reporting is accurate.

The following list describes other scenarios for when to create a history record:

 l A facility is deactivated for a period of time and you want to ensure records exist showing when the 
facility was first activated, then deactivated, and finally reactivated again. By creating history records 
for each of these events, a complete history is available showing (1) when the facility was first active; 
(2) when the facility was deactivated; and (3) when the facility was reactivated.

 l When a change is made to the protection criteria value, such as changing the value from .85 On to 
100 mV, creating a history record with an Effective Date identifying when the change occurred allows 
you to maintain a history for all readings with .85 On prior to the Effective Date, as well as all readings 
with 100 mV after the Effective Date. Creating a history record in this case is important because the 
facility may meet the 100mV criterion but fail the .85 On criterion. If history records do not exist, 
changing the criteria may show readings that were previously within criteria, are now out of criteria.

 l You remove a casing and want to document that you are no longer recording Casing P/S inspection 
readings. Instead of disabling the Activate Casing P/S field in the Information grid, create a history 
record. History records provide useful data for an audit or compliance review.

The following list identifies other considerations when creating a history record:

 l When you create a history record, all fields in the original record copy to the new record. Both records 
are initially the same except for the Effective Date. This allows you to change only the field(s) that are 
different in the new record and also create a history trail that includes the previous record.

 l When the operating status of a facility changes from active to inactive or from inactive to active, do 
not use the original information record to change the operating status. Doing so causes information 
for the original record to be excluded in reports, such as compliance and delinquency reports. Create 
a history record to document this type of change instead.

 l Do not enter the date a facility was put into service as the Effective Date. Use the Effective Date field 
to enter a date when a facility is taken out of service; when a change is made to the protection criteria; 
or when a facility is made inactive. Effective Date is used only with history records; it is empty in the 
original facility record. When a facility is put into service, add the date in the Installation Date field.

 l To help with using history records consistently, enable the Warn Before Permanent History Record 
Changed Option field in Options (Tools > Options). When enabled, PCS displays a warning message 
stating a history record should first be created before making changes.

Complete the following steps to create a history record with the a facility type's Information grid open:
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 1. In the Information grid for the facility type, click  Add to open the Add Record window. The 
following example is for a Test Point facility.

Figure  5-52. Add Record Window

 2. Select Add Information Record to Existing <facility type>.

 3. Select a facility record for which you want to create a history record. 

 4. Click  Save to close the window and return to the Information grid.

PCS adds a new record in the Information grid for the selected facility with today's date showing in 
the Effective Date field. The Facility Active check box is also enabled by default in order for the facility 
to be included in facility survey schedules. The original record becomes the history record.
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Figure  5-53. Added Effective Date to Record

 5. Change information in the new record as needed. 

 6. Enter a comment in the Permanent Comments field about the record change.

View a Linked Maintenance or Inspection Record

You can link new maintenance records to an inspection record using a field computer or mobile device. 
Conversely, with the samefield computer or mobile device you can link inspection records to an existing 
maintenance record.  When a survey file imported from  afield computer or mobile device contains both an 
inspection record and maintenance record for the same site, those records are considered related, and 
PCS will automatically link the inspection and maintenance records. If open maintenance records were sent 
to the field computer or mobile device, the new inspection record created for the same site will be linked to 
the maintenance record. The old inspection record previously associated with the open maintenance 
record will still be linked to the record.

A Linked Maintenance Count field is available in the Inspection grid to view which inspection records have 
linked maintenance records. When a record is selected in the Inspection or Maintenance grid, the linked 
records can be reviewed immediately in the  Maintenance Links or Inspection Links mini-grid, respectively.
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Figure  5-54. Linked Maintenance Records Related to a Selected Inspection Record

If the Linked Maintenance Count field is not in your current grid view, refer to View Data in a Grid or Form 
and Add a Data Grid Layout Theme.

View a Record's Change History

If enabled in Options, PCS keeps a log of all changes made to PCS data. Any additions, modifications, and 
deletions of data are stored, as well as additional information about the data change, such as who made the 
change, what tool was used to make the change, when the change was made, and what the data was 
before the change. If enabled, additions and modifications of individual records can be viewed by any user 
from within PCS, and all changes can be reviewed by anyone with permissions to the database.

To enable change tracking, refer to Set Editing Options on page 25 and Set Properties in Field and UDF 
Customizations on page 55. For more information about the configuration, benefits, and use of change 
logging, refer to Track Data Changes on page 896
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Complete the following steps to view the history of all changes made to an individual record:

 1. Identify and select the record in the data grid.

Figure  5-55. Changed Record Selected

 2. Click  Change History. The Change History window opens. The table includes all changes made to 
the selected record in the last year.

Figure  5-56. Change History
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 3. Review the changes that are associated with the selected record. For each change found, the 
record's old and new values are listed, as well as the date and time of the change, the type of change 
made, which user was logged in when the change was made, and what application made the 
changes to the data.

 4. Click  Close to close the window.

View Records Based on Selected ROWs

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to display records in a data entry grid based on pipeline segments selected in 
the Select ROWs window:

 1. To open the data entry grid, click Edit <module> Data.

 2. Select a data entry grid to view. For example, click the Information tab  and then the Test Point tab to 
display the Test Point Information data entry grid.

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. If the Options window is not open, click Options.

 5. In the Based On section, select Selected ROWs.
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Figure  5-57. Based On Options

 6. If you want to change the grid layout, sorting theme, or apply one or more filters to the grid, complete 
the following steps:

 a. To change the grid layout theme, click the down arrow in the field Select Layout Theme and 
select a theme in the selection list.

 b. To change the grid sorting method, click the down arrow in the field Select Sort Theme and 
select a theme in the selection list.

 c. To apply a filter to the grid, click the check box for a filter listed in the Filters group box. You can 
select more than one.

For example, to include only currently active facilities in the grid, click the Currently Active 
Facilities Only check box. A check mark inside the check box indicates a selection. To remove 
a filter from the grid, clear the check mark by clicking the check box.

To add a new AND or OR filter group, refer to Add, Edit, and Apply an AND or Or Filter Group 
on page 378.

 d. When applying a date filter to the grid, such as Inspection Date is between, set a date range 
using a calendar or dynamic dates in the following manner:
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 i. To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.

 ii. To set a date range using dynamic start and end dates, click the  calculator button in 
the start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields.

 e. Click  Apply to save and apply changes.

Records display in the grid based on selected options.

View Records Based on a Schedule

You can display records in a data entry grid based on a schedule. 

NOTE: Scheduling criteria and a schedule definition must be set up prior to performing the following 
procedure. Refer to Schedules on page 509 for more information.

Examples used in the instructions are based on the CPDM module. However, the information applies to all 
modules. 

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps  to view records in a grid based on a schedule:

 1. Click Data Entry > Edit <module> Data to open the Edit <module> Data window.

 2. Select a data entry grid. For example, click the Inspection tab  and then the Test Point button  to 
display the Test Point Inspection data entry grid.

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. If the Options window is not open, click Options.

 5. In the Based On section, select Schedule.
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Figure  5-58. Inspection Tab Options

 6. Select a schedule definition from the Select Schedule Definition drop-down list.

 7. To set up a schedule date range using a calendar:

 a. In the Start Date field, set a schedule start date by entering a date or selecting a date from the 
calendar. When typing a date, use the format MM/DD/YYYY to indicate the month, day, and 
year.

 b. To set a dynamic value for the Start Date, click the  icon to expand the field. In the first field, 
enter a value for the number of days, months, or years from the Start Date. Select an interval 
from the second drop-down field.

Figure  5-59. Dynamic Start Date
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 c. To close the dynamic fields click the icon.

 d. In the End Date field, set a schedule end date by entering a date or or selecting a date from the 
calendar. When typing a date, use the format MM/DD/YYYY to indicate the month, day, and 
year.

 e. To set a dynamic value for the End Date, click the  icon to expand the field. In the first field, 
enter a value for the number of days, months, or years from the End Date. Select an interval 
from the second drop-down field.

 8. Click  Apply. The Options window will close, and  the data entry grid will open and display records 
based on the selected schedule definition and date range.

View Records Based on a Route

You can display records in a data entry grid based on a route. 

A route is a user-created list of facilities for inspection arranged in a particular order. For example, if a route 
has previously been set up with facilities arranged in survey order, you can work with records in a data entry 
grid using the same route to display the grid in survey order.

NOTE: One or more routes must be set up prior to performing the following procedure. For information 
about how to set up a route, refer to Routes on page 439.

Examples used in the instructions are based on the CPDM module. However, the information applies to all 
modules. 

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to view records in a grid based on a route:

 1. Click Data Entry > Edit <module> Data to open the Edit <module> Data window.

 2. Select a data entry grid. For example, click the Inspection tab  and then the Test Point button  to 
display the Test Point Inspection data entry grid.

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. In the Based On section, select Route.
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Figure  5-60. Inspection Tab Options

 5. Select a Route from the list.

 6. Optionally, select options from the View, Options, and Filter sections if you want to change the grid 
layout theme, sort theme, or apply one or more filters to the grid. Refer to Themes and Filter Groups 
for more information about these options.

Work with Derived Fields

A derived field is a system-calculated field with a value based on values in dependent fields. For example, 
PCS calculates a value for the field Effective IR Correction based on values in the following dependent 
fields:

 l User IR Correction

 l Structure P/S

 l Structure IRF

 l Inspection Date

IMPORTANT: Because some rows share data, making a change to one value could impact multiple rows 
of data.

When a value for a dependent field has been updated in a data entry grid, a  notification icon displays in 

the derived field indicating the value has changed and the data entry grid should be refreshed. Click the  
Refresh button to update all derived values and remove the notification icon.
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Figure  5-61. Derived Field - With Updated Information

Work with the Target Structure P/S Field

The Target  Structure P/S field is a system-generated field available in the CPDM Test Point Inspection grid. 
The field is gray to indicate its contents are system-generated. Target Structure P/S is used by PCS to 
calculate a target reading with a minimum pipe-to-soil (P/S) for meeting criteria. The target reading is 
calculated based on your selected protection criterion and information in other fields.

The following table describes how Target Structure P/S is calculated for each protection criterion. Each 
protection criterion identifies fields required for calculating Target Structure P/S. Equations with pipe 
brackets ( | ) represent absolute values.

Protection Criterion Target Structure P/S Calculation

.85 On (default) –0.850 V

.85 IRF –0.850 – | Structure P/S – Structure IRF |

Example: –0.850 – | –1.200 – –0.800 | = –1.250

Note: The value in the field User IR Correction (if any) is used instead of the 
| Structure P/S – Structure IRF | equation.

Table 5-8.  Calculating Target Structure P/S       
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Protection Criterion Target Structure P/S Calculation

100 mV Native P/S – 0.100 – | Structure P/S – Structure IRF |

Example: –0.550 – 0.100 – | –1.200 – –0.800 | = –1.050

Note: The fields Native P/S and Native Date can be included with any 
survey regardless of how old. PCS always finds the most recent native 
reading and date, and the most recent pair of structure "on/off" readings 
(Structure P/S and Structure IRF). This means if the current-year survey 
includes only "on" readings, PCS uses the last "on/off" reading and native 
date. This is the case until a new "on/off" reading is taken.

300 mV This is no longer recognized by AMP RP0169 or DOT regulations.

Ref Read Add the field Test Point Reference P/S in the grid when using "Ref Read" 
(reference reading) protection criterion.

Ag/AgCl Functions the same as ".85 On" but uses –0.800V instead. Use this 
protection criterion for off-shore (saltwater) or tank "on" readings when 
using silver/silver chloride half cell.

Custom On Functions the same as ".85 On" but uses a custom value instead of -
0.850. 

The user-defined custom value is input under the Criteria pane of the 
Options window. 

Custom IRF User-defined Custom Value – | Structure P/S – Structure IRF |

Functions the same as ".85 IRF" but uses a custom value instead of -
0.850. The user-defined custom value is input under the Criteria pane of 
the Options window. 

Custom mV Shift Native P/S – User-defined Custom Value – | Structure P/S – Structure IRF |

Functions the same as "100 mV" but uses a custom value instead of 
0.100. The user-defined custom value is input under the Criteria pane of 
the Options window. 

The field Target Structure IRF is used for a facility to meet criteria and the calculated minimum value for 
the Structure IRF field.

.85 On criteria Calculation: Target Structure IRF = Null

Table 5-8.  Calculating Target Structure P/S        cont'd
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Protection Criterion Target Structure P/S Calculation

.85 IRF (off) and 100mV 
criteria

Structure IRF can be compared to Target Structure IRF to determine if the 
inspection is in compliance. If Structure IRF is more negative than Target 
Structure IRF, the test point is in compliance.

 l Calculation for .85 IRF Criteria: Target Structure IRF = -.85.

Target Structure P/S is calculated for an inspection that has a 
Structure IRF.

 l Calculation for 100mV Criteria: Target Structure IRF = Native P/S - 
0.1. Native Date must be added in the grid.

Target Structure IRF is calculated for an inspection that has a 
Structure IRF.

Native P/S = Most recent Native P/S before the date of the 
Structure P/S and Structure IRF.

.85 On Calculation: Target Structure IRF = Null

300 mV Calculation: Target Structure IRF = Null

Ref Read Calculation: Structure P/S = Null

Table 5-8.  Calculating Target Structure P/S        cont'd

The default setting for Target Structure P/S is -0.850. 

Complete the following steps to change the setting:

 1. Open the Test Point Inspection grid.

 2. Select the field Test Point Protection Criteria for a test point in the grid. Click the down arrow and 
select a protection criterion in the selection list. Repeat this step for other test points as needed.

 3. Set up other fields used to calculate Target Structure P/S. Based on how your data entry grids are 
arranged, fields may be in the Test Point Information or Inspection grid.

Record Facility Current Values

The following required and optional fields are used for recording facility current values:

 l Record Rectifier Current

 l Record Pipeline Current on page 302

 l Record Bond Current on page 304
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Record Rectifier Current

The following table identifies the fields required for recording rectifier current (rectifier DC amps and volts; 
rectifier anode output current, and rectifier negative output current).
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Facility & Current Type Description

Rectifier:
              DC Amps and DC 
Volts

Add the following fields in the Rectifier Information grid:

 l Activate Rectifier Output Current Found

 l Activate Rectifier Output Volts Found

The following fields make up the shunt conversion factor and can be added to 
the Information grid:

 l Rectifier Output Shunt Factor (A/mV): use this field to enter the amps 
value of the shunt conversion factor. Enter as a whole number value.

 l Rectifier Output Shunt Rating (mV/A): use this field to enter the millivolts 
value of the shunt conversion factor. Enter as a whole number value.

Add the following fields to the Rectifier Inspection grid:

 l Rectifier Output Current Found (Amps)

 l Rectifier Output Volts Found (Volts)

 l Rectifier Output Current Left (Amps)

 l Rectifier Output Volts Left (Volts)

 l Rectifier Current Adjusted

Rectifier:
              Anode Output Current

Add the Number of Impressed Anodesfield to the Rectifier Information or 
Inspection grid.

The Rectifier Anode Information mini-grid in the Rectifier Information grid 
automatically includes the following fields for entering anode data:

 l Impressed Anode Current Minimum (Amps)

 l Impressed Anode Current Maximum (Amps)

 l Impressed Anode Shunt Rating (mV/A)

 l Impressed Anode Shunt Resistance (Ohms)

 l Impressed Anode Shunt Factor (A/mV)

Refer to Work with Rectifier Anodes on page 330 for more information.

Table 5-9.  Recording Rectifier Current Values       
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Facility & Current Type Description

Rectifier:
              Negative Output 
Current

Add the  Number of Negatives field in either the Rectifier Information or 
Inspection grid.

The Rectifier Negative Information mini-grid in the Rectifier Information grid 
automatically includes the following fields for entering rectifier negative data:

 l Negative Current Min (Amps)

 l Negative Current Max (Amps)

 l Negative Current Shunt Rating (mV/A)

 l Negative Current Shunt Resistance (Ohms)

 l Negative Shunt Factor (A/mV)

Refer to Work with Rectifier Negatives on page 335 for more information.

Table 5-9.  Recording Rectifier Current Values        cont'd

Record Pipeline Current

The following table identifies the fields required for recording pipeline current values.
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Facility & Current Type Description

Pipeline Current:
              IR Drop Test Station

Add the following fields in the Test Point Information grid and "activate" fields 
for use.

 l Activate Pipeline Current On - mV Drop

 l Activate Pipeline Current Direction

 l Pipeline Current Calibration Factor (A/mV) — enter the amps value of the 
current factor when using the resistance of the pipeline to measure 
current flow on the pipeline. Enter value as whole number. The value is 
used in the pipeline current calculation.

 l Pipeline Current Measurement Ratio (mV/A)— enter the current factor 
when using the resistance of the pipeline to measure current flow on the 
pipeline. Enter value as whole number. The value is used in the pipeline 
current calculation.

Add the following fields in the Test Point Inspection grid:

 l Pipeline Current On (Amps)— enter amps reading for pipeline current 
measured with rectifier on.

 l Pipeline Current Direction— use this field to describe the direction of the 
current, such as upstream or downstream.

Pipeline Insulator 
Current:
              Shunt for Insulated 
Flange

Add the following fields in the Test Point Information grid and "activate" fields 
for use.

 l Activate Insulator Current

 l Insulator Shunt Factor (A/mV)

 l Insulator Shunt Rating (mV/A)

Add the field Insulator Current (Amps) in the Test Point Inspection grid.

Use the Insulator Current (Amps) field to enter the amps value of the insulator 
shunt reading. PCS uses the reading and the value in the Insulator Shunt 
Rating (mV/A) field  to calculate and enter a value in the Insulator Shunt Factor 
(A/mV) field.

Table 5-10.  Recording Pipeline Current       
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Facility & Current Type Description

Pipeline Insulator P/S  1. Add and enable the Activate Insulator P/S field in the Test Point 
Information grid.

 2. Add the Insulator P/S field in the Test Point Inspection grid.

Use the Insulator P/S field to enter a potential reading for the other side 
of an insulated flange, relative to the soil. This type of reading is also 
referred to as an "insulator-to-soil" potential reading.

If the protection criteria option .85 IRF or 100mV is selected in Test Point 
Protection Criteria, add and enable the Activate Insulator IRF field in the 
Test Point Information grid and then add the Insulator IRF (Volts) field in 
the Test Point Inspection grid.

Pipeline Galvanic 
Current:
              Shunt for Galvanic 
Anode

Add the following fields in the Galvanic Anode Information grid and "activate" 
fields for use.

 l Activate Galvanic Current

 l Galvanic Anode Shunt Factor (A/mV)

 l Galvanic Anode Shunt Rating (mV/A)

Add the field Galvanic Current (Amps) in the Galvanic Anodes Inspection grid.

Use the  Galvanic Anode Current (Amps) field to enter the amps value of the 
galvanic anode shunt reading. PCS uses the reading and the value in the field 
Galvanic Anode Shunt Rating (mV/A) to calculate and enter a value in the  
Galvanic Anode Shunt Factor (A/mV) field.

Table 5-10.  Recording Pipeline Current        cont'd

Record Bond Current

The following table identifies the fields required for recording bond current using the Bond Information and 
Inspection data entry grids (Data Entry > Edit CPDM Data > Foreign Bond).
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Facility Type Description

Bond Current Add the following fields in the Foreign Bond Information grid:

 l Bond Shunt Rating

 l Bond Shunt Resistance

Use the Bond Shunt Rating field to enter the amps reading of the 
bond conversion shunt factor. Use the Bond Shunt Resistancefield  
to enter the millivolt (mV) reading of the bond conversion factor. 
Readings in both of these fields automatically update the Bond Shunt 
Factor field.

Add the following fields in the Foreign Bond Inspection grid:

 l Bond Current Found

 l Bond Current Left

 l Bond Current Adjusted

Use the Bond Current Found field to enter the current reading for a 
foreign bond as it is found (before adjusting the current). The value 
automatically copies to the Bond Current Left field. To adjust the 
Bond Current Found reading, click the Bond Current Adjusted check 
box and then type the adjusted reading in the Bond Current Leftfield.

Table 5-11.  Recording Bond Current Values       

Attach a Document to a Grid Record

When you want to attach a document to a record in the grid, use the Attached Document field to link or 
embed a file or webpage address to a ROW, facility, inspection, or maintenance record. Supported file 
types include image, video, HTML, Excel, XML, music, and text files (such as Microsoft Word, WordPad, 

Notepad, or PowerPoint files). Macro-enabled documents (including .xlsm, and .docm files) are not 
supported.

Linking a document identifies the file location on a local computer, company network, FTP site, or webpage 
on the Internet. Linking documents stored on a local computer are accessible only from that computer. 
Embedding a document stores a copy of the file in the PCS database.

NOTE: Storing copies of documents in the PCS database increases the size of the database.
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If the file type of an attached document is associated with a default software program on the local 
computer, you can preview the file in the Preview Attached Documents window. Additionally, clicking Open 
opens the attached document for editing or viewing purposes.

Editing an embedded document applies changes only to the copy stored in the PCS database; changes do 
not apply to the source file stored outside of PCS. Likewise, editing a source file applies changes only to the 
source file, not the copy stored in PCS.

Each of the following fields allow you to attach a document to a record in the grid. If any of these fields are 
not present in the grid, refer to Themes and Filter Groups on page 368 for information how to add the field to 
the grid.

 l ROW Attached Documents— add this field in the Information, Inspection, or Maintenance grid if you 
plan to attach a document to a ROW record.

 l Facility Attached Documents — add this field in the Information, Inspection, or Maintenance grid if 
you plan to attach a document to a facility record.

 l Inspection Record Attached Documents — add this field in the Inspection grid if you plan to attach a 
document to an inspection record.

 l Maintenance Record Attached Documents —add this field in the Maintenance grid if you plan to 
attach a document to a maintenance record.

For more information, continue with one of the following topics:

 l Attach a Document to a ROW, Facility, Inspection, or Maintenance Record on page 306

 l View an Attached Document on page 310

For information about how to attach a document to a pipeline record, refer to Pipeline Records on page 
171.

Attach a Document to a ROW, Facility, Inspection, or Maintenance Record

Information in this section explains how to attach a document to a record in the grid using the options Link 
Document and Embedded Document. 

These instructions start with the assumption that you have the correct facility type grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239.

NOTE: If the option Link Document is unavailable for selection, your company's PCS administrator has 
disabled this setting in Options.   

Complete the following steps to attach a document to a record in the grid:
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 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Information, Inspection, or Maintenance tab and select a facility type from the selections 
below the Information, Inspection, and Maintenance tabs.

Figure  5-62. Information Grid

 1. Click the icon in the <record type> Attached Documents field for the grid record you plan to attach 
a document. The example below shows the Inspection Record Attached Documents from the 
Inspection grid.
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Figure  5-63. Attached Document Field

 2. In the Maintain Attached Documents window, click  Attach. The Link Document and Embedded 
Document options become available.

Figure  5-64. Maintain Attached Documents Window

 3. Select one of the following options for attaching a document: 
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 l Link Document — select this option if you plan to link to a document on a local computer or 
company network. Edits to the document are made on the local computer or company 
network, whether accessed from within PCS or not. If you choose to link to a document on a 
local computer, users who access PCS from another computer may have trouble accessing 
the document.

 l Embedded Document — select this option if you want to store a copy of an attached 
document in the PCS database. Changes made to the document will not affect copies of the 
document that may be stored on your local computer or company network.

Storing copies of attached documents in the database increases the size of the database.

 4. Click the ellipsis button … in the Document field to open the Link File window. Then navigate to the 
file and select it. Click Open to link to the file and close the window.

 5. Type a description for the linked file in the Description field. When a description is not provided, PCS 
uses the filename of the linked document as the description.

A list of attached documents display in the window. Selecting an item in the list displays its location in 
the Document field.

 6. Click  Save to save changes and add more documents.

 7. Click  Save and Close to save changes and close the window. A message will appear confirming 

whether you intended to link to the document or store a copy in the PCS database. Click OK.

The data grid updates with text in the Attached Documents field to denote that a document or 
documents is/are attached to this record.
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Figure  5-65. Attached Document to Record

View an Attached Document

If the file type of an attached document is associated with a default software program on the local 
computer, you can preview the file in the Preview Attached Documents window. Additionally, you can open 
the attached document for editing or viewing purposes. 

These instructions start with the assumption that you have the correct facility type grid selected. For 
information about accessing a grid of data, refer to View Data in a Grid or Form on page 239.

Complete the following steps to view or open an attached document:
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 1. Click the  icon  for the grid record with the attached document.

Figure  5-66. View Attached Document

 2. In the Preview Attached Documents window, select a file in the list on the left side of the window to 
preview the file (if the previewer supports it).

Figure  5-67. Preview Attached Documents Window

 3. If the file type of the attached document is associated with a default software program on the local 
computer, click  Open (or double-click it) to open the file.

 4. Click the  X icon to close the Preview Attached Documents window.
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When you open and then edit an embedded document, changes apply only to the copy stored in the 
PCS database; changes do not apply to the source file stored outside of PCS. Likewise, editing the 
source file applies changes to the source file, not the copy stored in the PCS database.

Work with an Images Field

Occasionally, inspection data will be accompanied by images that were captured while performing surveys. 
These images will often be used to document corrosion in atmospheric surveys or to depict items 
described within the data fields in any survey. Image fields in PCS allow you to attach these pictures and 
other graphics to information, inspection, and maintenance records for a pipeline or facility or to the pipeline 
or facility's base record itself.

When images fields are added to a Form Report theme, all images in the field or a specified number of 
images from the field can be displayed in the form. The theme can also be restricted to show only the 
primary image from the image field. For more information about displaying images from images fields in a 
form report, refer to Form Report Designer Themes on page 847 in Reports and Graphs.

For more information about the images fields available in the data entry grid and form, refer to Access the 
Images Fields on page 312. Once you've found the images fields, the following topics provide instructions 
detailing how to add, remove and modify, export, and preview images attached to an images field:

 l Add Images to a Record's Images Field on page 313

 l Manage Images in a Record's Images Field on page 318

 l Export Images to a Folder on page 325

 l Preview Images Attached to a Record on page 317

Access the Images Fields

Images attached to a record in PCS provide a visual representation of the pipeline or facility, whether it is a 
schematic design, an identifying picture, or other graphic. Information images can show what the pipeline 
or facility looked like at specific points in time or to demonstrate details included in the information record. 
Inspection images can further illustrate items described in the inspection. Images attached to a 
maintenance record before maintenance is performed can show the specific item that requires 
maintenance, while images attached after the work is done can serve as proof the maintenance was 
complete.

The following image fields are available and can be added to a grid or form in Edit <Module> Data and, 
depending on the report type, to a form report in Reports/Graphs:

 l Pipeline Maintenance Images — attaches images to a pipeline maintenance record.

 l Facility Images — attaches images to a base facility record.
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 l Facility Information Images — attaches images to a facility information record.

 l Facility Inspection Images — attaches images to a facility inspection record.

 l Facility Maintenance Images — attaches images to a facility maintenance record.

The following image fields may be available to view in Edit <Module> Data but are only available for 
managing images in Edit ROW Detail.

 l Pipeline Images — displays attached images to a base pipeline record.

 l Pipeline Information Images — attaches images to a pipeline information record.

For more information about adding the fields to a data entry grid or form or to a form report theme, refer to 
Themes and Filter Groups on page 368 or Work with Form Themes on page 382 or Form Report Designer 
Themes on page 847 in Reports and Graphs.

Add Images to a Record's Images Field

Images can be added to an images field using either an Allegro field computer or PCS. Up to twelve images 
can be attached to a single field when using an Allegro. When attaching images to a field in PCS, there is no 
such limitation. However, attaching several images to each record can take up a lot of space in your images 
database. Contact your PCS database administrator to identify an appropriate number of images to attach 
to your records.

Refer to the following topics for instructions detailing how to add an image to a record's images field:

 l Add Images with a Mobile Device on page 313

 l Add Images in the Data Entry Grid on page 314

 l Add Images in a Data Entry Form on page 315

Add Images with a Mobile Device

While performing a periodic survey, photographs can be taken with a field computer or mobile device to 
graphically record inspection and maintenance information for a facility. Those images are attached to the 
survey's Facility Inspection Images or Facility Maintenance Images fields. When the survey is transferred to 
PCS using Field Computer Receive, the images are imported into PCS alongside the rest of the survey 
data. 

Refer to the field computer or mobile device user guide and Receive a Facility Survey on page 685 for more 
information.

For a field computer or mobile device survey to include images, those images fields must be included in the 
prompt sent to the device. Refer to Manage a Prompt Theme on page 701 for more information about 
creating and modifying a prompt.
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Add Images in the Data Entry Grid

You can add images directly to the field from the data entry grid from the Maintain Attached Images 
window, as long as an images field has been added to the data entry grid's layout theme. Refer to Add a 
Data Grid Layout Theme on page 369 for more information about adding fields to a layout theme.

Figure  5-68. Maintain Attached Images

Click  in the record to open the Maintain Attached Images window. Complete one of the following to add 
an image to an images field in the data entry grid:

 l Navigate to the Image — click  Add Files and navigate to the desired image. Select the image and 
click Open. The image is listed in the left pane and loads in the right. The description field below the 
image is filled out based on the image file name. If desired, select the text in the description field to 
enter a new description for the image. Click  Save to save the image and image description with 
the field.
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 l Drag and Drop an Image — select an image on your computer and drag it to the left pane of the 
Maintain Attached Images window. The image is listed in the left pane and loads in the right. The 
description field below the image is filled out based on the image file name. If desired, select the text 
in the description field to enter a new description for the image. Click  Save to save the image and 
image description with the field.

Repeat these steps to add more images to the images field. Once the images are added to the images field, 
you can manage the images in the field or remove images from the field. Refer to Manage Images in a 
Record's Images Field on page 318 for more information.

Once all images are added to the field, click  Close to close the Maintain Attached Images window.

Add Images in a Data Entry Form

You can add images directly to the field from the data entry form, as long as an images field has been added 
to the data entry form's layout theme. Refer to Work with Form Themes on page 382 for more information 
about adding fields to a form theme.
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Figure  5-69. Data Entry Form with an Images Field

Locate the images field on the data entry form and do one of the following to add an image to the images 
field:

 l Navigate to the Image — Click  Add Files and navigate to the desired image. Select the image and 
click Open. The image loads in the images field box and the description field below the image is filled 
out based on the image file name. If desired, select the text in the description field to enter a new 
description for the image.

 l Drag and Drop an Image — Select an image on your computer and drag it to the images field box. 
The image loads in the images field box and the description field below the image is filled out based 
on the image file name. If desired, select the text in the description field to enter a new description for 
the image.

Repeat these steps to add more images to the images field. Once the images are added to the images field, 
you can manage the images in the field or remove images from the field. Refer to Manage Images in a 
Record's Images Field on page 318 for more information.
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Preview Images Attached to a Record

Images attached to a record's images field can be viewed immediately in a data entry form, as long as the 
images field has been added to the form theme. The data entry grid has a Quickview and a Preview window 
to easily see the primary image or all images, respectively, for an images field.

In form view, the images are presented along with the record information. Refer to Add Images to a 
Record's Images Field and Manage Images in a Record's Images Field for more information.

To preview the images for an images field in the data entry grid, select the desired record and then do one of 
the following:

 l Preview Primary Image — hover your mouse over the  icon for the images field you wish to preview. 
If a primary image is defined for the images field, that image will appear next to the record in a 
Quickview window. If no primary image is defined, the first image in the list of images for the images 
field will be displayed instead.

Figure  5-70. Images Field's Quickview

 l View All Images for a Field — click  in the images field you wish to preview. The Preview Attached 
Images  window displays with all images added to the field and their descriptions showing in a grid. 
Click  Close to close the  window.



PCS v2.5 User Guide

Chapter 5: Data Entry Grids and Forms 318

Figure  5-71. Preview of Images for Field

Manage Images in a Record's Images Field

Images that have been added to an images field can be rearranged to display in a different order, the 
descriptions of the images can be modified, images can be removed from the images field, and a primary 
image for the field can be set. These changes affect what is shown in the data entry grid and data entry 
form, as well as what images are shown and how they display in form reports. For more information about 
viewing images in form reports, refer to Form Report Designer Themes on page 847 in Reports and Graphs.

For instructions detailing how to modify the images in the images field, refer to the following topics:

 l Remove Images from an Images Field on page 319

 l Modify an Image's Description on page 320

 l Set a Primary Image on page 322

 l Rearrange Images on page 325
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Remove Images from an Images Field

You can remove an image from an images field in either the data entry grid or form, as long as the images 
field has been added to the grid layout or form theme.

To remove an image from an images field, locate the desired record in either the data entry grid or form and 
follow either of the following instructions:

 l From the Data Entry Grid — click  to open the Maintain Attached Images window to view all 
images attached to the images field. Select the image you wish to remove and click  Delete to 
remove the image from the left pane. 

Figure  5-72. Maintain Attached Images

Click  Save to save the changes to the images field.

Repeat these steps to remove more images from the images field. Once all desired images are 

removed from the field, click  Save and Close to close the Maintain Attached Images window.

 l From the Data Entry Form — select the image on the form you wish to remove and click  Delete 
Selected to remove the image from the images field. Repeat these steps to remove more images 
from the images field.
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Figure  5-73. Selected Image in Form

Modify an Image's Description

An image's description is a short statement about the image, up to 50 characters long. The description will 
be used to identify the image in a list, such as the Maintain Attached Images window, and will be included 
alongside the image in a form report. You can change the description for an image from an images field in 
either the data entry grid or form, as long as the images field has been added to the grid layout or form 
theme.

To change the description for an image from an images field, locate the desired record in either the data 
entry grid or form and follow either of the following instructions:

 l From the Data Entry Grid — Click  to open the Maintain Attached Images window and select the 
image in the left pane of the  window. The image and its description loads in the right pane. Select the 
existing text in the description field and enter a new description for the image. Click  Save to save 
the new description of the image.
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Figure  5-74. Maintain Attached Images

Once all images are modified for the field, click Save and Close to close the Maintain Attached 
Images window.

 l From the Data Entry Form — select the text in the description field below the image you wish to 
update and enter a new description for the image. Repeat these steps to update more images for the 
images field.
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Figure  5-75. Selected Image in Form

Set a Primary Image

A primary image can be configured for an images field to define an image to show when only one image can 
or should display. Primary images are shown in the Quickview window when you hover over the Preview 
button for a record's images field and, depending on the options chosen when creating a form report, may 
be the only image displayed for a record's images field when a report is created. By default, the first image 
added to the images field is set as the primary image but you can change the primary image for an image 
from an images field in either the data entry grid or form.

To change the primary image for an images field, locate the desired record in either the data entry grid or 
form and follow either of the following instructions:

 l From the Data Entry Grid — Click  to open the Maintain Attached Images window and select the 
image in the left pane of the window. The image and its description loads in the right pane. Select the 
Set Primary check box. The selected image will move to the top of the list in the left pane and a star 
appears next to the description to indicate its status as primary image. 
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Figure  5-76. Maintain Attached Images

Click  Save to save the changes to the images field.

Click Save and Close to close the Maintain Attached Images window.

 l From the Data Entry Form — select  next to the image's description field the image you wish to set 
as primary image. The selected image will move to the beginning of the image field.
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Figure  5-77. Selected Image in Form

The icon changes to  to denote that it is the primary.

Figure  5-78. Primary Photo Selected in Form
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Rearrange Images

By default, images are sorted in the images field based on the order that they were added. When a primary 
image is set for an images field, that image will move to the beginning of the images list. You can rearrange 
the order in which the images display for a field for an images field using either the data entry grid or form, as 
long as the images field has been added to the grid layout or form theme.

To rearrange the images in an images field, locate the desired record in either the data entry grid or form and 
follow either of the following instructions:

 l From the Data Entry Grid — click  to open the Maintain Attached Images window and locate an 
image to move in the left pane of the  window. Select and drag the image to the desired location in the 
list of images. Repeat as needed to achieve the preferred sort order. Click  Save to save the new 
order of images for the field.

Click  Save and Close to cl close the Maintain Attached Images window.

 l From the Data Entry Form — locate an image to move in the images field. Select and drag the image 
to the desired location in the list of images. Repeat as desired to achieve the preferred sort order.

Export Images to a Folder

Images that have been attached to an images field are stored in PCS but can be exported to a folder on 
your computer and emailed or used in other applications, as long as the images field has been added to the 
grid layout or form theme.

Figure  5-79. Export Images from a Grid or Form

To export the images in an images field to a folder on your computer, locate the desired record in either the 
data entry grid or form and follow either of the following instructions:

 l From the Data Entry Grid — click  to open the Maintain Attached Images window and select the 
image or images you wish to export. To select multiple images, click to select the first image, then 
press the Ctrl key on your keyboard while you click to select the additional images. To select all 

images, click  Select All. 
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Figure  5-80. Maintain Attached Images

Click  Export. In the Browse For Folder window, select the folder on your computer where you 
wish to save the images and click OK. 

Click Save and Close to close the Maintain Attached Images window.

 l From the Data Entry Form — select the image or images you wish to export. To select multiple 
images, click to select the first image, then press the Ctrl key on your keyboard while you click to 
select the additional images.

Click  Export. If a Save Changes window displays, click  Yes.

In the Browse For Folder window, select the folder on your computer where you wish to save the 
images and click OK.
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Figure  5-81. Browse For Folder for Export

Link Rectifiers to ROWs

When the same rectifier provides current to one or more pipeline segments, or parallel lines entered in the 
hierarchy as pipeline segments, use the ROW Links mini-grid to link the rectifier to each pipeline segment or 
parallel line. This allows you to enter rectifier information once instead of re-entering the same rectifier 
information for each pipeline segment or parallel line. This in turn reduces the number of database records 
and the potential for data entry errors.

Complete the following steps to link a rectifier to one or more pipeline segments:

 1. Select a module from the Modules main menu.

 2. Click Data Entry and then select Edit <Module> Data.

 3. Click  Apply or press Enter if the Options window is displayed instead of the grid.

 4. Click the Information tab and then the Rectifier tab below it.
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Figure  5-82. Rectifier Information Grid

 5. Select a row of records in the  grid with the rectifier you want to link to a pipeline segment.

Figure  5-83. Selected Record

 6. Click the  — in the upper right-hand corner of the Facility Level Override mini-grid to hide the mini-
grid. 
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Figure  5-84. Facility Level Override Mini-grid

 7. Double-click the ROW Links button  to open the ROW Links mini-grid, if the mini-grid is not already 
open.

Figure  5-85. ROW Links Mini-grid

 8. Click  in the ROW Links mini-grid to open the Add Row Link Title window.
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Figure  5-86. Add Row Link

 9. Identify the milepost number of the pipeline segment you want to link. Type the milepost number in 
the Milepost field, then select the pipeline segment. Click  Save to save changes and close the 
window.

The following operations occur:

 l PCS adds a new ROW link for the selected milepost and pipeline segment in the ROW Links 
mini-grid.

If this is the first link in the mini-grid, it automatically becomes the Primary Link. PCS copies 
rectifier information from the Primary Link to subsequent links added later in the mini-grid. You 
can however set any link in the mini-grid as the Primary Link by clicking the option button. Only 
one link can be set as the Primary Link.

 l PCS adds a new record for the selected milepost and pipeline segment in the Rectifier 
Information grid.

The new record includes rectifier information copied from the record selected as the Primary 
Link in the ROW Links mini-grid.

 10. Provide a date in the Creation Date field to identify when you linked the rectifier to the pipeline 
segment. Select the Creation Date field and then click the down-arrow to select a date using a 
calendar.

Work with Rectifier Anodes

PCS provides two mini-grids for working with rectifier impressed anodes:

 l The Rectifier Anode Information mini-grid provides anode information, such as the shunt rating or 
shunt resistance, for each anode in the ground bed of a rectifier. PCS uses this information to 
automatically calculate the anode shunt factor.
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 l The Rectifier Anode Inspection mini-grid includes inspection readings for each anode in the ground 
bed of a rectifier, such as a current or shunt reading, for each impressed anode in the ground bed.

Tracking rectifier impressed anodes in PCS allows you to monitor the capacity of the anode ground bed for 
a rectifier that produces current. You can track the current flow for each anode to determine which anodes 
have low or no current output.

Refer to the following topics for more information on adding rectifier anode information:

 l Add Rectifier Anode Information on page 331

 l Add Rectifier Anode Inspections on page 334

Add Rectifier Anode Information

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to add a record in the Rectifier Anode Information mini-grid for each anode in 
the ground bed:

 1. In the module's data grid, click the Information tab and then the Rectifier tab. 

 2. Select a row of records with the rectifier you want to add impressed anode records. 

Figure  5-87. Rectifier Anode Information

 3. If the Rectifier Anode Information mini-grid is not visible, click and drag the Rectifier Anode 
Information button  at the bottom of the window to the mini-grid area. 
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The example below shows the Rectifier Anode Information mini-grid being added to the left of an 
existing mini-grid in the mini-grid area. Your setup may be different and include none or more than 
one mini-grids. To replace a mini-grid, move the button over an existing one. To add a mini-grid next 
to any other mini-grid in the area, move the button to the left or right of the existing one. The border 
turns orange to show where the mini-grid will be placed.

Figure  5-88. Adding a Mini-grid to Mini-grid Area

 4. Click  in the Rectifier Anode Information mini-grid to add an empty record in the mini-grid.

Figure  5-89. Rectifier Information Mini-grids
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 5. In the Add Record window, type a name for the anode in the Name field. Fields requiring information 
include a  icon. You must enter information in the required fields before the record will be added.

Figure  5-90. Add Record Window

 6. Click  Save to add the record and close the window.

 7. In the Rectifier Anode Information mini-grid enter a value in either the Impressed Anode Shunt Rating 
or Impressed Anode Shunt Resistance fields.

If entering a shunt rating, enter it as a mV per A ratio using the format nn.n/nn.n, such as 50.0/25.0 for 
the shunt rating 50 mV/25 A. If entering a shunt resistance value, enter the actual resistance of the 
shunt in ohms. When both of these fields are empty, you can enter a value in the Impressed Anode 
Shunt Factor field instead. Otherwise, PCS automatically calculates the shunt factor based on the 
value in the shunt rating or shunt reading field.

Repeat these steps to add additional anode information records.

Click  Refresh to update  derived fields, such as Number of Impressed Anodes. For more information 
about derived fields, refer to Work with Derived Fields on page 296.

PCS displays the total number of anodes in the system calculated Number of Impressed Anodes field in the 
Rectifier Information and Inspection grid. This value is based on the total number of anodes in the Rectifier 
Anode Information mini-grid. If the field is not present in your grid, refer to Add a Data Grid Layout Theme on 
page 369 to add the field.
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Add Rectifier Anode Inspections

If rectifier anode records have not yet been added in the Rectifier Anode Information mini-grid, complete the 
procedure in the previous section first (Add Rectifier Anode Information on page 331) and then continue 
with the procedure in this section.

Complete the following steps to enter anode inspection readings in the Rectifier Anode Inspection mini-
grid:

 1. In the module's data grid, click the Inspection tab and then the Rectifier tab. 

 2. Select a row of records with the rectifier and anodes you want to add anode inspection readings. 

Figure  5-91. Rectifier Inspection Grid

 3. If the Rectifier Anode Inspection mini-grid is not visible, click and drag the Rectifier Anode Inspection 
button  at the bottom of the window to the mini-grid area. 

The example below shows the Rectifier Anode Inspection mini-grid being added to the left of an 
existing mini-grid in the mini-grid area. Your setup may be different and include none or more than 
one mini-grids. To replace a mini-grid, move the button over an existing one. To add a mini-grid next 
to any other mini-grid in the area, move the button to the left or right of the existing one. The border 
turns orange to show where the mini-grid will be placed.
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Figure  5-92. Adding a Mini-grid to Mini-grid Area

 4. Select an anode  in the Rectifier Anode Inspections mini-grid.

Figure  5-93. Rectifier Information Mini-grid

 5. Type an inspection reading in either the Impressed Anode Current or Anode Shunt Reading field.

 6. Click  Refresh to update  derived fields, such as Number of Impressed Anodes.

For more information about  derived fields, refer to Work with Derived Fields on page 296.

 7. Repeat these steps to enter inspection readings for remaining anodes.

Work with Rectifier Negatives

A rectifier can typically have from one to five negative wires that protect different pipelines. Tracking rectifier 
negatives in PCS allows you to easily identify which rectifier negative wire is connected to which pipeline. 
You can also monitor the current flow for each rectifier negative in an effort to determine how much of the 
total current is used to protect each pipeline.

PCS provides two mini-grids for working with rectifier negatives:
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 l The Rectifier Negative Information mini-grid provides negative information, such as the shunt rating 
or shunt resistance, for each negative wire of the rectifier. PCS uses this information to automatically 
calculate the negative shunt factor.

 l The Rectifier Negative Inspections mini-grid includes inspection readings for each negative wire of 
the rectifier, such as a current or shunt reading, for each negative wire.

Refer to the following topics for more information on adding rectifier negatives information:

 l Add Rectifier Negative Information on page 336

 l Add Rectifier Negative Inspections on page 339

Add Rectifier Negative Information

Complete the following steps to add a record in the Rectifier Negative Information mini-grid for each 
negative wire of a rectifier providing current to a pipeline(s):

 1. In the module's data grid, click the Information tab and then the Rectifier tab. 

 2. Select a row of records in the Rectifier Information grid with the rectifier you want to add negative 
records.

Figure  5-94. Rectifier Information Grid

 3. If the Rectifier Negative Information mini-grid is not visible, click and drag the Rectifier Negative 
Information button  at the bottom of the window to the mini-grid area. 
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The example below shows the Rectifier Negative Information mini-grid being added to the left of an 
existing mini-grid in the mini-grid area. Your setup may be different and include none or more than 
one mini-grids. To replace a mini-grid, move the button over an existing one. To add a mini-grid next 
to any other mini-grid in the area, move the button to the left or right of the existing one. The border 
turns orange to show where the mini-grid will be placed.

Figure  5-95. Adding a Mini-grid to Mini-grid Area

 4. Click  in the Rectifier Negative Information mini-grid to add an empty record in the mini-grid.
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Figure  5-96. Rectifier Negative Information Mini-grid

 5. In the Add Record window, type a name for the record  in the Name field. Fields requiring information 
include a  icon. You must enter information in the required fields before the record will be added.

Figure  5-97. Add Record Window

 6. Click  Save to add the record and close the window.
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 7. If the rectifier rating is different than the minimum and maximum values provided by PCS in the 
Negative Current Min and Negative Current Max fields of the Rectifier Negative Information mini-grid, 
type the rectifier rating in these fields.

 8. Type a value in either the Negative Shunt Rating or Negative Shunt Resistance field.

If entering a shunt rating, enter it as a mV per A ratio using the format nn.n/nn.n, such as 50.0/25.0 for 
the shunt rating 50 mV/25 A. If entering a shunt resistance value, enter the actual resistance of the 
shunt in ohms. When both of these fields are empty, you can enter a value in the field Negative Shunt 
Factor instead. Otherwise, PCS automatically calculates the shunt factor based on the value in the 
shunt rating or shunt reading field.

 9. Click  Refresh to update  derived fields, such as Number of Negatives.

For more information about  derived fields, refer to Work with Derived Fields on page 296.

 10. Repeat these steps to add a record for each remaining negative wire.

PCS displays the total number of negatives in the system-calculated Number of Negativesfield in the 
Rectifier Information and Rectifier Inspection grids. If the field is not present in your grid, refer to Add a 
Data Grid Layout Theme on page 369 to add the field.

Add Rectifier Negative Inspections

If rectifier negative records have not yet been added in the Rectifier Negative Information mini-grid, 
complete the procedure in the previous section first (Add Rectifier Negative Information on page 336) and 
then continue with the procedure in this section.

Complete the following steps to enter negative inspection readings in the Rectifier Negative Inspection 
mini-grid:

 1. In the module's data grid, click the Information tab and then the Rectifier tab. 

 2. Select a row of records in the Rectifier Inspection grid with the rectifier and negatives you want to add 
negative inspection readings. 
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Figure  5-98. Rectifier Inspection Grid

 3. If the Rectifier Negative Inspections mini-grid is not visible, click and drag the Rectifier Anode 
Inspection button  at the bottom of the window to the mini-grid area. 

The example below shows the Rectifier Negative Inspections mini-grid being added to the left of an 
existing mini-grid in the mini-grid area. Your setup may be different and include none or more than 
one mini-grids. To replace a mini-grid, move the button over an existing one. To add a mini-grid next 
to any other mini-grid in the area, move the button to the left or right of the existing one. The border 
turns orange to show where the mini-grid will be placed.



PCS v2.5 User Guide

Chapter 5: Data Entry Grids and Forms 341

Figure  5-99. Adding a Mini-grid to Mini-grid Area

 4. Select a row of records in the Rectifier Negative Inspections mini-grid.

Figure  5-100. Rectifier Negative Inspections Mini-grid

 5. If the rectifier output current has been adjusted and the  Rectifier Current Adjusted check box is 
enabled in the Inspection grid, complete the following steps in the Rectifier Negative Inspections 
mini-grid:

 a. Type the amperage reading taken before rectifier adjustments in the Negative Current Found 
field.

 b. Type the amperage reading taken after rectifier adjustments in the Negative Current Left field.

 6. Type an inspection reading in either the Negative Shunt Read Found or Negative Shunt Read Left 
field.
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 7. Click  Refresh to update  derived fields.

For more information about  derived fields, refer to Work with Derived Fields on page 296.

 8. Repeat these steps to enter readings for additional negative inspections.

Build a Survey in the Inspection Grid Based on Schedule
Building a survey in the inspection grid based on a schedule allows PCS to automatically add empty 
inspection records in the grid ready for data entry. This feature saves time by eliminating the need to 
manually add empty inspection records in the grid, one-by-one. These instructions start with the 
assumption that you have a facility type's Inspection grid selected. For information about accessing a grid 
of data, refer to View Data in a Grid or Form on page 239.

Complete the following steps to build a survey in the Inspection grid based on a schedule:

 1. Use the Inspection grid's Options to show the desired inspection records and define the schedule 
date range. For instructions detailing how to use the Options, refer to Set Options for Viewing Data 
on page 240.

 2. Click  Build Survey to open the Build Survey window.

Figure  5-101. Build Survey Window

 3. Select one of the following options in the Build Survey window to assign inspection records to a 
survey folder:
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 l No Assignments— select this option if you do not want to assign inspection records to a 
survey folder.

 l Assign Survey— select this option to assign inspection records to an annual or multi-year 
survey folder. Select a  survey folder in the Survey field drop-down list.

 l Assign Periodic Survey— select this option to assign inspection records to a periodic survey. 
Click the down arrow in the Periodic Survey field and select a survey folder in the selection list. 
Select the survey from the Periodic Survey drop-down list and a year from the Year drop-down 
list. 

 4. Select a date from the Initial Inspection Date drop-down calendar.

 5. Click  Build. Then click OK in the Build Survey window. 

The data entry grid now includes blank inspection records ready for data entry.

Work with Continuous Survey Data
The Indirect Survey Manager (ISM) module can be used to manage survey readings and other data 
associated with a continuous survey.

Data entry grids in the ISM module are organized based on the following continuous survey methods: 

 l CIS (Close Interval Survey)

 l AC CIS (AC Close Interval Survey)

 l DCVG (DC Voltage Gradient)

 l ACVG (AC Voltage Gradient)

 l ACCA (AC Current Attenuation)

 l Soil Resistivity

 l In-line Inspection (ILI)

Refer to the following topics for more information on managing continuous survey readings:

 l Add or Delete a Record in a Continuous Survey

 l Work with Survey Maintenance on page 347 — includes instructions on using the Survey 
Maintenance window to reverse, shift, copy, append, delete, spike filter rubberband, or reset 
records in a continuous survey.                 

 l Print, Export, or Email a Continuous Survey on page 365
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IMPORTANT: Survey readings must be assigned to a survey folder in the Continuous Survey Folder 
window before working with data in the ISM module. Refer to Add a Continuous Survey Folder on page 
411 for more information.

Add or Delete a Record in a Continuous Survey

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to add or delete a record in a continuous survey:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-102. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-103. Select Continuous Survey List

 4. Click  Add to open the Add Record window to add a record in the survey.

Figure  5-104. Add Record Window

 5. Type a survey location in the Station Number field. This field is required.

 6. Click  Save to add the record to the grid.
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Figure  5-105. New Record in CIS Continuous Survey

 7. Enter any survey data as needed for the new record. 

 8. Repeat steps to add additional records as needed.

 9. Click  Refresh to update the grid.

 10. To delete a record in a survey:

 a. Click a station number to select a row of records in the  grid.

 b. Click  Delete.

 c. Click  Delete in the Delete Record window to delete the selected record. Click  Cancel to 
cancel the operation.

Figure  5-106. Delete Record in Continuous Survey
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A Warning message window displays.

Figure  5-107. Warning Message

 d. Click  Yes to delete the survey record or  No to cancel the action.

 e. Click  Refresh to update the grid.

Work with Survey Maintenance

Survey Maintenance window can be accessed from the Edit Ism Data window. 

The Survey Maintenance window provides several functions that simultaneously change a group of 
records. For example, instead of editing one record at a time to reverse the order of survey readings, use 
the Reverse tab to change a range of survey records all at the same time.

The Survey Maintenance window includes the following functions:

 l Reverse Survey Readings on page 348

 l Shift Station Numbers on page 350

 l Copy Station Numbers to a New Survey on page 352

 l Append a Survey on page 354

 l Delete a Range of Station Numbers on page 356

 l Use Spike Filtering on page 358

 l Use Rubber Band on page 361

 l Reset Station Numbers on page 364
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Reverse Survey Readings

Use the Reverse option to reverse the order of survey readings so that the first reading becomes the last 
and the last reading becomes the first. Station numbers for all other survey readings are changed so that 
the survey is reversed or "flipped". This function is typically used when survey readings were taken in an 
upstream direction instead of downstream, or vice versa. 

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to reverse the order of survey readings:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-108. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-109. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Reverse tab if 
the tab is not selected.

Figure  5-110. Reverse Survey Readings

 5. Type a starting station number in the Starting Station Number field. Press Tab and enter ending 
station number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.

 6. If desired, click the close button  to cancel the operation and close the window.

 7. Click  Apply to reverse survey readings and update the data entry grid.
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Shift Station Numbers

Use the Shift option to shift a range of station numbers by a specified number of feet (or meters) or in the 
direction of an existing facility. 

Shift  allows you to add or subtract a fixed distance to station numbers for a range of readings in a survey. 
This function is typically used when station numbers are not known when performing the survey and they 
need to be shifted to correct station numbers. 

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to shift station numbers:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-111. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-112. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Shift tab.

Figure  5-113. Shift Survey Readings

 5. Type a starting station number in the Starting Station Numberfield. Press Tab and enter ending 
station number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.

 1. Select either Distance (feet) to specify an exact measurement or Shift To Facility if you you want to 
shift station numbers in the direction of an existing facility location. 
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 a. For Distance (feet), type or select the number of feet in the Distance (feet) field. Clicking the  
up arrow increases the value; clicking the  down arrow decreases it.

 b. For Shift To Facility, type a facility location in the Shift To Facility field or  click Find to open the 
Select Facility window and select a facility from the list. Then click  Save. 

 2. If desired, click the close button  to cancel the operation and close the window.

 3. Click  Apply to shift station numbers and update the data entry grid.

Copy Station Numbers to a New Survey

Use the Copyoption to copy a range of station numbers with survey readings to a new survey.

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to copy a range of station numbers with survey readings to a new survey:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-114. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-115. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Reverse tab.

Figure  5-116. Copy Survey Readings

 5. Type a starting station number in the Starting Station Number field. Press Tab and enter ending 
station number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.

 6. Type a name for the new survey in the New Survey Name field.

 7. Click the down arrow in the New Survey Date field and select a survey date using a calendar.

 8. If desired, click the close button  to cancel the operation and close the window.
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 9. Click  Apply to copy the range of station numbers with survey readings to a new survey. The new 
survey is available for selection in the Selected Continuous Survey field on the Edit ISM Data grid.

Append a Survey

Use the Append option to append a range of station numbers from another survey to the selected survey.

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to append a survey with a range of station numbers from another survey 
(including associated survey readings):

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-117. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-118. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Append tab.

Figure  5-119. Append Survey Readings

 5. Select a survey with station numbers you want to add (append) to the survey currently displayed in 
the ISM data entry grid. Select a survey from the  Survey To Append From drop-down list. 

 6. Identify a range of station numbers you want to append to the survey currently displayed in the ISM 
data entry grid. Type a starting station number in the Starting Station Number field. Press Tab and 
enter ending station number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.
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 7. If desired, click the close button  to cancel the operation and close the window.

 8. Click  Apply. If no duplicate station numbers exist, PCS adds the range of appended station 
numbers with survey readings to the survey currently displayed in the ISM data entry grid.

 9. If duplicate station numbers exist, a message displays requiring you to make one of the selections.

Figure  5-120. Append Duplicates

 a. Select which option you would like to use to hand the duplicates.

 b. Click OK.

Delete a Range of Station Numbers

Use the Delete option to delete a range of station numbers in a survey. Survey readings associated with the 
range of station numbers are also deleted. Deleting all station numbers in a survey also deletes the survey. 

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Compete the following steps to  delete a range of station numbers in a survey:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 
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Figure  5-121. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.

Figure  5-122. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Delete tab.
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Figure  5-123. Reverse Survey Readings

 5. Identify the range of station numbers you want to delete (includes associated survey readings). Type 
a starting station number in the Starting Station Number field. Press Tab and enter an ending station 
number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.

 6. If desired, click the close button  to cancel the operation and close the window.

 7. Click  Apply.

 8. Click OK in the Delete Survey Readings warning window to delete station numbers and 
associated survey readings. Click  Cancel to cancel the operation.

Figure  5-124. Delete Survey Readings

Use Spike Filtering

Spike filtering is available only when working with a close interval survey (CIS). Use spike filtering to exclude 
inaccurate survey readings in graphs and reports that are typically due to poor contact between the soil and 
reference electrode. Using this feature allows you to consider only those survey readings that are accurate 
when analyzing survey data.
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Inaccurate readings are excluded based on a percentage value you specify for the filter. PCS compares the 
on/off values of the current reading with the on/off values of the previous and next reading. If the current 
survey reading differs from the previous and next survey reading by more than the percentage allowed, 
PCS disables the option Plot This Point for the current survey reading and also excludes it in the CIS Survey 
Graph report.

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to apply spike filtering to a range of station numbers:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-125. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.
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Figure  5-126. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the SpikeFiltering 
tab.

Figure  5-127. Spike Filtering Survey Readings

 5. Type a starting station number in the field Starting Station Number. Press Tab and enter ending 
station number in the Ending Station Number field. 

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number adjusts 
to 10712+32.

 6. Type a value in the Spike Percentage field. Valid entries are in a range of 1-99.

 7. If desired, click the close button  to cancel the operation and close the window.
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 8. Click  Apply and then click  OK when a status message displays.

NOTE: The option Plot This Point is disabled in the Edit ISM Data grid for station numbers that meet Spike 
Filtering criteria.

Use Rubber Band

Use the Rubber Band option to adjust a range of station numbers by stretching or shrinking sections of a 
survey so that station numbers line up with known points along the survey or existing facilities.

Using Rubber Band allows you to re-align station numbers for a selected survey. After entering known 
station numbers for the first, last, and any other station numbers in between, Rubber Band adjusts 
remaining station numbers in a linear manner between known station numbers. Station numbers are then 
listed in ascending order (lowest to highest).

When you first use Rubber Band, the Original and Target fields include two match point records by default. 
These match point records are the first and last station numbers in the selected survey. Station numbers in 
the Original field are the original station numbers initially stored in PCS as a result of importing survey data, 
entering survey data manually, or receiving survey data from the Allegro field computer. Station numbers in 
the Target field are the corrected or adjusted station numbers that you enter or are entered as a result of the 
Rubber Band feature.

These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to adjust a range of station stations using the Rubber Band function:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 
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Figure  5-128. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.

Figure  5-129. Select Continuous Survey List

 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the RubberBand 
tab.
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Figure  5-130. RubberBand Survey Readings

 5. Complete the following steps to re-align station numbers in a survey:

 a. To re-align the first station number in the survey, type a new station number in the Target field 
of the first station number.

For example, enter 1071232 for a station number 10712+32. When you hit Tab, the number 
adjusts to 10712+32.

If you want to re-align the first station number to an existing facility instead, click the  icon to 
open the Select Facility window and select a facility in the grid. Then click  Save.

 b. To re-align the last station number in the survey, type a new station number in the Target field 
of the last station number.

If you want to re-align the last station number to an existing facility instead, click the  icon to 
open the Select Facility window and select a facility in the grid. Then click  Save.

 c. To add new match points for known station numbers, click  New to add empty Original and 
Target match point fields. Then type the station number you want to re-align in the Original field 
and the adjusted (or corrected) station number in the Target field.

If you want to re-align the adjusted station number to an existing facility instead, click the  
icon to open the Select Facility window and select a facility in the grid. Then click  Save.

 d. To delete a row of match points, select the row and then click  Delete.

Click  Reset before clicking  Apply to reset station numbers to their original values.

 e. Click  Apply. When the Apply message displays, click  OK to continue or  Cancel to 
cancel the operation.
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 6. Click  Refresh to update data in the grid.

Reset Station Numbers

Use the Reset option to return all station numbers in the selected survey to original station numbers that 
were collected when the survey was first entered in the ISM data entry grid.

Complete the following steps to reset station numbers:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-131. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to modify from the Selected Continuous Survey 
drop-down list.

Figure  5-132. Select Continuous Survey List
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 4. Click  Survey Maintenance to open the Survey Maintenance window. Then click the Reset tab.

Figure  5-133. Reverse Survey Readings

 5. Click  Apply. 

When the Reset Station Numbers message displays, click  OK to reset all station numbers or  
Cancel to cancel the operation.

Figure  5-134. Reset Station Numbers

The Edit ISM Data entry grid now displays original station numbers.

Print, Export, or Email a Continuous Survey

You can print, export, or email a report for a continuous survey in the Edit ISM Data grid. Supported file 
formats for exporting a report include PDF, HTML, MHT, RTF, XLS, XLSX, CSV, TXT, and image (BMP, 
EMF, WMF, GIF, JPEG, PNG, and TIFF).
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These instructions start with the assumption that the ISM module is already selected and the correct 
pipeline segments have been selected. For information detailing how to select pipeline segments, refer to 
Select ROWs on page 171. 

Complete the following steps to print, export, or send via email a continuous survey report:

 1. Click Data Entry > Edit ISM Data. 

 2. Select a continuous survey data type. 

Figure  5-135. Edit ISM Data Window

 3. Select a survey folder with survey readings you want to print, export, or email from the Selected 
Continuous Survey drop-down list.

Figure  5-136. Select Continuous Survey List

 4. Click  Print to open a print preview window.
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Figure  5-137. Print Preview Window

 5. To print the report using the default Windows printer, click  Quick Print.

 6. To open a print window and select a printer to print the report, click  Print.

 7. To export the report in a file format:

 a. Click the down arrow in  Export Document and select a file format in the selection list. You 

can also just click the  icon to open the Export Document window where you can select the 
file type from the Export format drop-down list (see below).

 b. In the Export Document window, if desired, select the file type from the Export format drop-
down list. Click the ellipsis button to select a file path. Click More Options to see options 
associated with the file type selected. When finished, click OK.

Figure  5-138. Export Document Window
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 8. To send the report as an attachment in an email:

 a. Click the down arrow in   Send and select a file format in the selection list. You can also just 

click the  icon to open the Send via E-Mail window where you can select the file type from 
the Export format drop-down list (see below).

Figure  5-139. Send Via Email Window

 b. Select a file format from the Export format drop-down list. Click the ellipsis button to select a 
file path. Click More Options to see options associated with the file type selected. When 
finished, click OK

 c. When an email message opens with the report as an attachment, select an email recipient and 
then click Send.

 9. Click  to close the print preview window and return to the data entry grid.

Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort theme. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 

themes available to all PCS users. These themes are identified with a  icon and  [PCS], such as   [PCS] 
Test Point Inspections.

A filter group is a named set of one or more filters that determine the data output in the Define Routes grid 
and subsequently, the route itself.

When you add a filter group, you define filter conditions that determine which records to include or exclude 
in the Define Routes grid and the route. Adding an AND filter group produces a subset of records that meet 
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all filter conditions. Adding an OR filter group produces a subset of records that meet any filter condition. 
When you apply a filter group, PCS processes filters in descending order beginning with the filter at the top 
of the group.

The following sections describe how to add a layout theme, sort theme, and one or more optional filter 
groups:

 l Add a Data Grid Layout Theme

 l Add a Sort Theme on page 374

 l Add, Edit, and Apply an AND or Or Filter Group on page 378

 l Work with Form Themes on page 382

Add a Data Grid Layout Theme

A layout theme is a group of fields in a grid layout. Adding a new layout theme allows you to select which 
fields you want to include in the grid layout and then save the layout as a theme for later use. The following 
procedure applies to the grid layout for any data entry grid in PCS.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to add a data grid layout theme:

 1. Click Modules > Edit <module> Data. For example, click Data Entry > Edit CPDM Data to open the 
Edit CPDM Data window.

 2. Open the data entry grid that you want to add a new grid layout theme. For example, click the  
Inspection tab and then the  Test Point tab to display the Test Point Inspection grid.
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Figure  5-140. Edit CPDM Data Grid - Test Point Information

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. Click the  Customize tab.
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Figure  5-141. Customize Window

 5. Click   Add to open the New Layout Theme window.
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Figure  5-142. New Layout Theme Window

 6. Type a name for the layout theme in the  Enter Theme Name field (required).

 7. If you want to create a public theme, select the Public check box. When the option is not selected, 
the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 8. If you want to copy fields from an existing layout theme, select the Copy Content check box. Then 
select a theme from the Copy Fields From Theme drop-down list.

If you do not want to copy fields from an existing layout theme, deselect the Copy Content check 
box.

 9. Click  OK to save changes and return to the Layouts window.

 10. Complete the following steps to add and remove fields in the new layout theme as needed:
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 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click  All Fields.

 b. Check the check box for the field and click   or double-click the field. 

 c. Repeat this step as needed. The grid layout theme includes all fields listed in the right pane of 
the Layouts window.

 d. To remove a field in the layout theme, select the field and click  or double-click a field listed 
in the right pane to move it to the left pane. Repeat this step as needed.

 11. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  button.

 12. Click  Save and Close to save changes and return to the data entry gird.

 13. To apply the new layout theme to the data entry grid, click the Options tab  to open the Options 
window.

Figure  5-143. Options Window

 14. In the View pane, select the new layout theme from the  Select Layout Theme drop-down list.

 15. Click  Apply to apply changes and return to the data entry grid.
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Add a Sort Theme

A sort theme determines how PCS sorts records in the data entry grid. Adding a sort theme allows you to 
select which field(s) to sort records by and if records sort alphanumerically in ascending or descending 
order.

Complete the following steps to add a sort theme:

 1. Click Modules > Edit <module> Data. For example, click Data Entry > Edit CPDM Data to open the 
Edit CPDM Data window.

 2. Open the data entry grid that you want to add a new grid layout theme. For example, click the  
Inspection tab and then the  Test Point tab to display the Test Point Inspection grid.

Figure  5-144. Edit CPDM Data Grid - Test Point Information

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. Click the  Customize tab and then the Sorts tab.
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Figure  5-145. Customize Window - Sorts

 5. Click  Add to open the New Sort Theme window.
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Figure  5-146. New Sort Theme

 6. Type a name for the layout theme in the field Enter Theme Name (required).

 7. If you want to create a public theme, select the Public check box. When the option is not selected, 
the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 8. If you want to copy fields from an existing layout theme, select the Copy Content check box. Then 
select a theme from the Copy Fields From Theme drop-down list.

If you do not want to copy fields from an existing layout theme, remove the check mark inside the 
Copy Content check box by clicking the check box.

 9. Click  OK to save changes and return to the Sorts window.

 10. Complete the following steps to add and remove fields in the new sorts theme as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click  All Fields.
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 b. Check the check box for the field and click   or double-click the field. The field is added to 
the list of sorted fields in the pane on the right.

 c. Repeat these steps as needed until all desired fields are listed in the pane on the right.

 d. To remove a field in the layout theme, select the field and click  or double-click a field listed 
in the right pane to move it to the left pane. Repeat this step as needed.

 11. Select a sorting method for each field listed in the right pane. To sort grid records in ascending order, 

click the toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 12. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  button.

 13. Click  Save and Close to save changes and return to the data entry grid.

 14. To apply the new layout theme to the data entry grid, click the Options tab  to open the Options 
window.

Figure  5-147. Options Window

 15. In the View pane, select the new sort theme from the  Select Sort Theme drop-down list.
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 16. Click  Apply to apply changes and return to the data entry grid.

Add, Edit, and Apply an AND or Or Filter Group

An AND filter group is a named set of one or more filters that affect the data output in a data entry grid in 
Data Entry. Adding an AND filter group produces a subset of records that meet all filter conditions. PCS 
processes filters in a filter group in descending order beginning with the filter at the top of the filter group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to create and edit either an And or Or filter group and then apply it for use in a 
module data entry grid:

 1. Click Modules > Edit <module> Data. For example, click Data Entry > Edit CPDM Data to open the 
Edit CPDM Data window.

 2. Open the data entry grid that you want to add a new grid layout theme. For example, click the  
Inspection tab and then the  Test Point tab to display the Test Point Inspection grid.
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Figure  5-148. Edit CPDM Data Grid - Test Point Information

 3. If you want to collapse the Selected ROWs pane to view more of the grid, click the Selected ROWs 
bar. Clicking the bar again expands the pane.

 4. Click the  Customize tab and then the Filters tab.
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Figure  5-149. Customize Window - Filters

 5. To create a new And group, click New 'And' Group  to open the filter properties group box.         

Figure  5-150. And Group Filters 

 6. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  5-151. Or Group Filters 

 7. Type a name for the filter group in the Filter Group Caption field. 

 8. Select the Filter Is Always On option to keep the filter on.
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 9. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 a. When adding a date filter, set a date range using a calendar or dynamic dates in one of the 
following ways:       

 l Type a date in the start and end date fields. Enter a start and end date using the format 
M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.         

 l To set a date range using dynamic start and end dates, click the  calculator icon in the 
start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields. 

 b. Type a name for the filter in the Enter Custom Filter Caption field. 

 c. If additional filters are needed within the filter group, click  and repeat these steps.       

 10. If necessary, click the  edit icon for a filter to open that filter's property settings and change 
settings as needed. 

 11. Click  Save to save the filter group.         

 12. Click  Save and Close when finished saving all filter groups.         

 13. To apply one or more filters to the data entry grid, click the Options tab  to open the Options window.
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Figure  5-152. Options Window

 14. In the Filters pane, click the check box for each filter you want to apply. The filters that were created 
with the Filter Is Always On option will be automatically selected.

 15. Click  Apply to save changes and return to the data entry grid.

Work with Form Themes

A form theme is a named arrangement of fields and controls that determines which form elements are 
displayed on the screen and how they appear. A form theme can be saved as either public or private; a 
public theme is available for all users, whereas a private theme is only available to the user who creates it.
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Figure  5-153. Forms Editor

From within the Forms editor, a new form theme can be created, a new or existing form theme can be 
modified, and the form theme can be saved or deleted. Once a form theme is saved, it can be used in Edit 
Module Data. 

To close the Forms editor, click  Close (under  Forms). If there are unsaved changes to a form theme in 
the Forms editor, a Save Changes window displays. Click Yes to save all changes in the form themes, No to 
close without saving changes, or Cancel to return to the Forms editor.

Refer to the following topics for more information:

 l The Forms Editor

 l Create a New Form Theme

 l Edit a Form Theme on page 385

 l Manage a Form Theme on page 403

 l Use a Form Theme on page 403
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The Forms Editor

The Forms editor allows you to create a new form theme or edit an existing theme. Once in edit mode, the 
size and color of the data entry form theme can be determined; PCS fields can be added to the form theme; 
labels, images, tabs, and other controls can be placed; and the properties of each item added to the form 
theme can be determined.

To access the Forms editor, click Customize from a data entry grid or form and then click Forms.

Figure  5-154. Forms Editor

From within the Forms editor, a new form theme can be created, a new or existing form theme can be 
modified, and the form theme can be saved or deleted. Once a form theme is saved, it can be used in Edit 
Module Data grid. 

Create a New Form Theme

Complete the following steps to create a new form theme from the Forms editor:
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 1. From within Forms editor, click  Add to open the Add Form Theme window.

Figure  5-155. New Form Theme

 2. Type a name for the theme in the Enter Theme Name field. This field is required.

 3. If you want to create a public theme, select the Public check box. When the option is not selected, 
the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 4. To copy the contents of an existing theme, keep the Copy Content check box checked and select a 
theme from the Copy Fields From Theme drop-down list.

 5. To start with a blank form theme with no pre-existing fields, click to clear the Copy Content check 
box.

 6. Click  OK. A new form theme is created and ready for editing in the Forms editor.

Edit a Form Theme

After a form has been created (refer to Create a New Form Theme) the form theme's general properties can 
be edited, new controls can be added to the theme, and the controls on the theme can be modified to 
create the form theme best suited for your needs.

To edit a form theme, open the Customize window and select Forms. Select a form theme from the Select 
Form Theme drop-down. The workspace area updates to show the selected form theme. If this is a new 
form (no copied from another form) the areas are blank.
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Figure  5-156. Form Theme Ready to Edit

Items can be added to the form theme. The size, shape, style, and contents of the form and its controls can 
be edited. Refer to the following topics for more information:

 l Add Controls to the Form Theme on page 386

 l Configure Form Theme Properties on page 389

 l Lock or Unlock a Form Object on page 391

 l Edit Form Object Properties on page 392

 l Arrange and Adjust Objects on the Form Theme on page 400

Add Controls to the Form Theme

The same data fields and mini-grids that can be shown in a data entry grid can be added to a form theme. In 
addition, labels, images, and borders can be added to improve the design of the form theme. Labels can 
also be used to provide additional information or instruction within the form.
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Tab controls allow objects on the form to be organized within tabs. Data fields, mini-grids, labels, images, 
borders, and even other form items can be grouped under an individual tab within a tab control. Form items 
can only be added to a tab from the Controls and Fields pane, which included separate panes for Controls 
and Fields.

Figure  5-157. Controls and Fields Pane

Items added to the form are called controls and are found within this pane.

You add items to the form in the staging area between the Controls and Fields pane and the Alignment and 
Properties pane.

The following items can be added to the form:
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 l Data Entry Fields. To add a data entry field to the form theme, find the desired field in the Fields pane. 

Figure  5-158. Fields Pane

Click to select the field and drag it to the form theme staging area. A data entry field is added to the 
form theme. The colors, border and fill, font, caption visibility, width, and alignment of the field can be 
edited in the Properties pane.

 l Images Fields. To add an images field, such as Facility Information Images, find the desired field in the 
Fields pane. Click to select the field and drag it to the form theme. An images field is added to the 
form theme. The colors, borders, font, and caption visibility of the field can be edited in the Properties 
pane

 l Mini-Grid Controls. To add a mini-grid to the form theme, click to select the Grid control and drag it to 
the form theme. A mini-grid is added to the form theme. Select the mini-grid from the Grid Source 
drop-down in the Properties pane. The mini-grid's border can also be edited in the Properties pane.

 l Label, Picture, and Border Controls. To add a text label, picture, or border to the form theme, click to 
select the desired control and drag it to the form theme.
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Figure  5-159. Controls Pane

Depending on the control added, various properties can be edited in the Properties pane. A label's 
color, border, alignment, caption text, and font style can be edited; a picture's source file can be 
identified and its size determined; and a border control's color, padding, and border can be set.

 l Tab Controls. Tab controls allow form objects to be grouped into one or many tabs, as well as 
allowing more objects to be added to the form theme without increasing the form's size. One tab 
control can have multiple tabs, each of which contain fields, grids, and other controls. To add a tab 
control to the form theme, click to select the Tab control and drag it to the form theme. The tab 
control is added, consisting of a single tab. Once added to the form theme, edit the tab control in the 
Properties pane to add more tabs, change the tab names, or alter the look of the tabs.

Fields and other controls can only be added to a tab directly from the Controls and Fields panes. 
Once in a tab, a field or control cannot be moved outside of its current tab.

Form objects are added to the control unlocked and ready for editing, resizing, and rearranging.

Configure Form Theme Properties

A form theme's name, size, and background color can be changed using the Forms editor. To change any 
of these properties, click on an empty spot on the form theme. The properties pane updates to show the 
theme's properties.
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Figure  5-160. Form Theme Properties

You can do any of the following within the Properties pane for the theme's properties:

 1. To view properties of the theme, click in an empty spot in the workspace area. The Properties pane 
displays properties for the form theme.

Figure  5-161. Form Theme Properties

 2. To change the background color of the form theme, select the Background Color drop-down. A grid 
of available and standard colors displays. Select a color from the grid or click Advanced to switch to 
the custom color selector and create a custom color from the color palate, enter a hexadecimal value 
in the field provided or use the RGBA sliders to modify the RGBA values.
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Figure  5-162. Advance Background Color Selection

 3. To change the size of the form theme itself, enter a value in the Height and/or Width fields or click the 
up and down arrows to increment the values.

 4. To change the name of the form theme, enter a new name for the form theme in the Name field.

Lock or Unlock a Form Object

Form objects can be locked to disable future editing or unlocked to change the size or location of the 
object. 

In the forms workspace, click the icon inside the object to lock or unlock a form object.

Unlocked form objects are outlined in green.
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Figure  5-163. Unlocked Form Object

Locked form objects are outlined in red.

Figure  5-164. Locked Form Object

Edit Form Object Properties

Once a form object, including the controls and fields listed in the Controls and Fields pane, is added to the 
form, its properties can be set in the associated Properties pane. These properties can include options to 
change the text content and style, the border and fill of the object and/or the text field, the source of a grid or 
image, and the tab details. Depending on the control, some properties may not be available.

To edit a form object's properties after it has been added to the workspace, select the form object and use 
the Properties pane to modify the available properties.

Label properties determine the text that should appear in the form object, the horizontal alignment, 
background color, border color and thickness, and font properties.
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Figure  5-165. Label Control Properties

 l Controls — select background color, border color, border thickness, and whether or not the label 
text is underlined.

 l Header Font — select from the various font options. 

 l Options — enter the label name in the Captiontext field. You can also select how the label will display 
within the field from the Item Horizontal Align drop-down list.

Tab properties  allow you to add, remove, and rename tabs in a tab control, as well as change the overall 
look of the tabs.
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Figure  5-166. Tab Control Properties

 l Controls — select border color and thickness.

 l Header Font — select background color, header background color, and header hover color (the 
color the object will be when a mouse hovers over it).

 l Header Font — select to bold the header, select the font color, font type and size.

 l Options —  to select a tab for editing, select the name from the Selected Tab Item drop-down or click 
the tab's name to select the tab and rename it Selected Tab Caption field. Select the number of tabs 
in the tab control, enter the desired number of tabs in the Tab Count  field or click the up and down 
arrows to increment the count. The tab control adds or removes tabs as necessary to match the 
number of tabs in the Tab Count field.
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Picture properties   modify the display of an image in the picture control. Images smaller than 10MB can be 
loaded into the image control. For optimal performance, however, images larger than 200KB should not be 
used.

Figure  5-167. Picture Control Properties

 l Dimensions — select how the image will fill the space from the Stretch drop-down list. Options 
include: 

 — None: The image is not re-sized within the control.

 — Fill: The image is re-sized to fill the control.

 — Uniform: The image is re-sized to fit within the control's edges while maintaining its original 
aspect ratio.

 — UniformToFill: The image is re-sized to fill the control while maintaining its original aspect ratio. 
If necessary, the image is clipped to fit within the control's edges.

 l  Picture — fill the control with an image by hovering your mouse over the picture placeholder in the 
Picture Editor field. The source menu displays.
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Figure  5-168. Source Menu

 — To load an image file into the picture control, click  and navigate to the desired image file. 
Click to select the image file and click OK.

 — To paste a copied image into the picture control, click . The contents of the clipboard are 
pasted into the picture control.

 — To clear the image from the picture control, click . The current image is removed from the 
picture control.

 — To copy the image for use in other picture controls or to paste in other applications, click . 
The image is copied to the clipboard.

 — To copy the image and clear it from the picture control, click . The image is copied to the 
clipboard and cleared from the control.

 — To save the image to file, click  and navigate to the desired save location. Enter a name for 
the image file in the field provided, select a file type from the drop-down, and click Save. The 
picture is saved as an image file.

Border  properties   alter the look of the entire form object's border and background.
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Figure  5-169. Border Control Properties

 l Border — select border color and thickness. Select the Draw Border check box to add a border.

 l Dimensions — select background color. Select how round a border's corner is in the Corner Radius 
field.    To create a more rounded corner, enter a higher value in the field. To create a square corner, 
enter 0 in the field. To control the amount of space between the form object's contents and the 
border, enter a value in the Padding field.

Grid properties   dictate the display of the mini-grid data.
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Figure  5-170. Grid Control Properties

 l Border — select border color and thickness.

 l Grid — select a mini-grid from the Grid Source drop-down list to determine which mini-grid data 
appears in the control.

Text Field properties —  modify the look of the input text field or text box.
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Figure  5-171. Field Properties

 l Orientation — select Item Orientation and List Orientation from the drop-down list fields. To resize 
the text field a specific size independent of the size of the form object, select the Use Editor Width 
check box. The text field will size to the width specified in the Width of Editor property and align to the 
right side of the form object. To set the width of the text field, enter a value in the Width of Editor field 
or use the up and down arrows to increment the value. The Use Editor Width property must be 
enabled for the width to change.

 l Tab Control — select colors for the background, border brush, and border. For the Border 
Thickness:
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 — To set a simple border of uniform thickness around the entire text field, enter a single number.

 — To set a border whose thickness on the top and bottom are the same and the left and right are 
the same, enter the left/right thickness followed by a comma and the top/right thickness.

 — To set a border whose thickness varies on each side of the text field, enter each border's 
thickness followed by a comma in the following order: right, top, left, bottom.

 l Tab Header Font — select options for the font weight, color, family, and size. 

 l Tab Option — select Show Caption to show the caption for the field.

Arrange and Adjust Objects on the Form Theme

Form objects can be repositioned on the form theme to a general location using the mouse or to a precise 
location using the keyboard or alignment buttons. However, existing objects on the theme cannot be 
moved into or out of a tab container. When a tab container is moved, the objects within the tab container 
move with the tab container.

Form object can also be aligned, re-sized, or have a set tab order using the Alignment pane.

Objects must be selected on the form theme before rearranging or adjusting. You can do any of the 
following to select an object:

 l To select a single form object, click to select the form object.

 l To select multiple form objects, click to select a form object, then press the shift key and click to 
select additional form objects.

 l To select a group of form objects located near each other, click in an empty spot on the form theme 
and drag to create a selection box around the form objects. Release the mouse to select the objects 
within the selection box.

Move Objects Manually

Form objects can be manually moved to a general location using the mouse or to a precise location using 
the keyboard. Select one or more form objects and do one of the following:

 l Click and drag the form object(s) to the desired location.

 l Press the left, right, up, or down arrow keys on the keyboard to move the form object(s) incrementally 
to the left, right, up, or down.

Align, Resize, Arrange, and Set Tab or for Objects with Alignment Pane

Form objects can be repositioned so that the objects' edges or center points are aligned. When form 
objects are aligned, they are repositioned according to the location of the first selected object.
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Use the Alignment pane to align, size, arrange, or set tab order for a selected object.

Figure  5-172. Forms Alignment Pane

Alignment — align horizontally or vertically:

 l Horizontal — select multiple form objects and click , , or  to align the objects according to the 
first selected object's left edge, horizontal center, or right edge. 

 l Vertical — select multiple form objects and click , , or  to align the objects according to the 
first selected object's top edge, vertical center, or bottom edge.

 l Form objects can be repositioned so that there is an equal amount of space vertically or horizontally 
between the selected objects. The top-most and bottom-most form objects stay in place while all 
other form objects are distributed between those two form objects. Select multiple form objects and 
click Horizontal or Vertical to distribute the form objects horizontally or vertically on the form theme.

Size — you can manually re-sized a form object to a general size and shape using the mouse, to a precise 
size using the keyboard, or to match the size of the form object(s) to other form objects using buttons. 
Select one or more form objects and do one of the following:
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 l Hover the mouse over a corner or edge of the form object until the cursor changes to , , . Click 
and drag the corner or edge until the form object(s) reach the desired size or shape.

 l Press the Shift key and the left, right, up, or down arrow keys on the keyboard at the same time to 
move the left, right, up, or down edges of the selected form object(s) incrementally to the left, right, 
up, or down. This increases the form object(s) size incrementally.

 l Press the Shift key, Ctrl key, and the left, right, up, or down arrow keys on the keyboard at the same 
time to move the left, right, up, or down edges of the selected form object(s) incrementally to the 
right, left, down, or up. This decreases the form object(s) size incrementally.

 l Click , , or  in the Alignment pane to resize all selected form object(s) to match the width, 
height, or full size of the first selected object's width, height, or full size.

Arrange — use the options in the Arrange section of the Alignment pane to select how the object relate to 
other objects.

 l Forward — brings object forward one layer.

 l Backward — moves object back one layer.

 l To Front — puts object in front of all other objects.

 l To Back — puts object behind all other objects.

Tab Order — when using a form, you can press the tab key on the keyboard to move between fields, mini-
grids, and tab controls. The tab order determines which form object is next when tabbing between form 
objects. To set the tab order for the form objects, click Tab Order in the Alignment pane. The tab order 
number that was previously determined for the form objects displays on the right side of the fields in a red 
box.

Figure  5-173. Form Objects' Previously Determined Tab Order

To change the tab order, click the form objects' tab order number in the order that you want the tabbing to 
occur. The tab order number box changes to green to indicate that a field has a new tab order number and 
the selected form object is assigned the next number in the tab order series.

Figure  5-174. Forms Objects' New Tab Order
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Tab order numbers that were previously determined may reset to 0 when new tab order numbers are set.

Figure  5-175. Forms Objects' New and Reset Tab Order

Manage a Form Theme

From within the Formswindow, you can manage your form themes as you work with them or after creating 
them.

 l To save the form theme, click  Save. All changes made to the form themes are saved.

 l To save the form theme and close the Forms editor, click  Save and Close. All changes made to 
the form themes are saved and the Forms editor is closed.

 l To undo the most recent change, click  Cancel. 

 l To remove the currently selected form theme, click  Delete   and then   Yes in the Confirm Delete 
window. The currently selected form theme is removed from PCS.

To close the Forms editor, click  Close (under  Forms). If there are unsaved changes to a form theme in 
the Forms editor, a Save Changes window displays. Click Yes to save all changes in the form themes, No to 
close without saving changes, or Cancel to return to the Forms editor.

Use a Form Theme

Complete the following steps to apply the form theme in a data entry module:
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 1. Click Options to open the Options window. 

Figure  5-176. Options Window

 2. In the View pane, click  Form or  Grid And Form radio button.

 3. Select a theme from the Select Form Theme drop-down list.

 4. Click  Apply to apply changes and close the Options window.
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Survey Folder Maintenance
Facility and continuous survey folders can be managed in the Survey Folder Maintenance window, which 
can be access through the Data Entry main menu.

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Facility Survey Folders on page 405 — includes details on how to add, delete, or use a facility survey 
folder. The information in this section applies to all modules except the Indirect Survey Manager (ISM) 
module.

 l Continuous Survey Folders on page 411 — includes details on how to add, delete, or use a 
continuous survey folder. The information in this section only applies to the Indirect Survey Manager 
(ISM) module.

 l Themes and Filter Groups for Continuous Survey Folders on page 419 — includes details on how to 
add themes and filter groups for use with the continuous survey folder.

Facility Survey Folders

A facility survey folder is a group of inspection readings in a facility survey. PCS uses facility survey folders to 
organize and track facility survey data. Facility survey folders are used throughout PCS, including data entry 
grids, reports, Bridge, and Field Computer. You can also use a facility survey folder as an optional filter in a 
grid or report to easily retrieve a specific set of inspection records.

Names of facility survey folders typically follow regulatory requirements for surveying pipeline segments and 
facilities. For example, when you create an annual survey folder labeled 2019 Annual Survey, you can then 
assign inspection readings to the facility survey folder throughout the year as they are completed. Names of 
facility survey folders are editable allowing you to name a survey folder using a naming convention that best 
suits your business needs. 

Continue with the following topics for information about how to add, delete, and manage a facility survey 
folder:

 l Add a Facility Survey Folder

 l Edit a Facility Survey Folder on page 408
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 l Delete a Facility Survey Folder on page 409

 l Use a Facility Survey Folder on page 410

Add a Facility Survey Folder

A facility survey folder is typically added in PCS before entering inspection readings in a data entry grid or 
importing inspection readings using Bridge or Field Computer. 

You must enter a survey folder name, select a survey start date, and then select a survey frequency to add a 
new survey folder. Based on this information, PCS automatically calculates the survey end date.

If no survey folders exist when adding a new survey folder, PCS names the survey folder using the current 
year, for example 2020 Annual Survey. When other survey folders do exist, PCS increments the year by 
one. For example, if the latest annual survey folder is 2019 Annual Survey, PCS names the next new survey 
folder 2020 Annual Survey. Survey folder names are editable to allow you to name a survey folder based on 
your company's standards.

Complete the following steps to add a facility survey folder:

 1. Click Data Entry > Facility Survey Folder Maintenance to open the Survey Folder Maintenance 
window.

Figure  6-1. Survey Folder Maintenance

 2. Click  Add to add a row in the grid. The new row is highlighted.
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Figure  6-2. New Survey Folder

 3. To rename the newly added survey folder, type a name in the Survey Name field.

 4. Click in the Start Date field and enter a start date. Or, click the down arrow in the field to choose a 
date using a calendar.

Figure  6-3. Start Date Calendar

 5. Click in the Survey Frequency field and select a survey frequency from the drop-down list.
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Figure  6-4. Survey Frequency Drop-down List

The new survey folder is now available for use in data entry grids, reports, Bridge, Field Computer, 
and as an optional filter selection. For more information, see Use a Facility Survey Folder on page 
410.

Edit a Facility Survey Folder

Complete the following steps to edit a facility survey folder:

 1. Click Data Entry > Facility Survey Folder Maintenance to open the Survey Folder Maintenance 
window.

Figure  6-5. Survey Folder Maintenance
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 2. Click the survey folder row to highlight it and display an  icon. 

Figure  6-6. Edit Survey Folder

 3. Click  icon next to the Survey Name to edit Survey Name, Start Date, or Survey Frequency fields. 
The changes are automatically saved.

Delete a Facility Survey Folder

Deleting a survey folder removes all references to the survey folder throughout PCS. For example, when 
facility inspection records have been assigned to a survey folder you plan to delete, PCS removes 
references to the survey folder for each inspection record assigned to the survey folder. Inspection records 
are not deleted however, only references to the survey folder are deleted.

Deleting a survey folder typically occurs when you want to clean up data that is no longer needed or when a 
survey folder has been created accidentally. A message displays listing all facility records assigned to the 
survey folder allowing you to either cancel the operation or delete the survey folder.

Compete the following steps to delete a facility survey folder:

 1. Click Data Entry > Facility Survey Folder Maintenance to open the Survey Folder Maintenance 
window.
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Figure  6-7. Survey Folder Maintenance

 2. Select a survey folder in the grid, then click  Delete.

 3. In the Delete message window, click  Yes to delete the survey folder or  No to cancel the 
operation.

Figure  6-8. Delete Message Window

The survey folder and associated survey readings are permanently deleted from PCS.

Use a Facility Survey Folder

You can assign inspection readings to a survey folder in any of the following areas of PCS:

 l Inspection data entry grid. Assign an inspection record to a survey folder using the Survey field in the 
Inspection data entry grid. Refer to  Data Entry Grids and Forms for more information about the 
Inspection grid.
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 l Filter option in the Inspection data entry grid. To view a set of inspection records for a particular 
survey in the Inspection data entry grid, select a survey folder option in the Filters group box of the 
Customize Options window. Refer to  Data Entry Grids and Forms   for more information about the 
Inspection grid.

 l Bridge import file. Use the options in the Add Data Item group box to assign inspection readings to 
an annual and/or periodic survey folder. PCS assigns inspections to the appropriate survey folder 
based on the survey inspection date. Refer to Bridge for more information about using the Bridge.

 l Receiving survey files from the Allegro. Use the Options group box in the Field Computer Receive 
Data window to assign inspection readings to a survey folder. Choosing Automatic Assignment 
allows PCS to assign inspections to the appropriate survey folder based on the survey inspection 
date. Refer to Field Computer for more information about receiving survey files from an PCS or other 
mobile device.

 l Filter option in Reports. To view a set of inspection records for a particular survey in a report, select a 
survey folder option in the Filters group box of the Options window. Refer to Set Options for more 
information about the Options window or Reports and Graphs for more information about reports.

Continuous Survey Folders

A continuous survey folder is a container for a group of survey readings associated with a continuous 
survey, such as survey readings in a close interval (CI) survey or other type of above ground indirect survey. 
Continuous survey folders are used throughout PCS when working with a data entry grid, report, or graph 
in the Indirect Survey Manager (ISM) module. They allow PCS to organize and track continuous survey 
readings.

Information in this section explains how to use the most common features of Survey Folder Maintenance. 
Topics include those in the following list.

For information about other features, see Themes and Filter Groups for Continuous Survey Folders on page 
419.

 l Add a Continuous Survey Folder

 l Delete a Continuous Survey Folder on page 416

 l Use a Continuous Survey Folder on page 418

Add a Continuous Survey Folder

A continuous survey folder must first be added in Survey Folder Maintenance before working with survey 
readings in an ISM data grid, report, or graph. Adding a continuous survey folder includes the following 
tasks:
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 l Select the type of continuous survey, such as CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or 
ILI.

 l Provide the survey start date and survey name. These property settings allow you to identify the 
correct survey folder when adding survey readings or working with reports and graphs in ISM.

 l As an option, provide the name of the surveyor and/or the vendor performing the survey.

Complete the following steps to add a continuous survey folder:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Survey Folder Maintenance 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
CIS selected.

Figure  6-9. CIS Continuous Survey Folder Window

 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.

 4. Select a Layout Theme and/or Sort Theme and click  Apply.
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Figure  6-10. CIS Continuous Survey Folders

 5. Click  Add to open the Add Record window.

 6. Select the pipeline segment that you want to add a continuous survey folder. 

Figure  6-11. Add Record Window

 7. Click  Save. A new Add Record window open to display required fields for data entry. Required 
fields are identified with the  icon.
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Figure  6-12. Add Record

 8. Type a survey start date in the Start Date field using the format MM/DD/YYYY to indicate the month, 
day, and year. Or click the down arrow in the field and select a date using the calendar.

 9. Type a name for the survey folder in the CI Survey Name field. The field accepts up to 50 
alphanumeric characters.
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Figure  6-13. New CI Survey Folder

 10. Click  Save to close the Add Record window. The new row of records in the grid for the new 
continuous survey folder is added to the grid.

Figure  6-14. New Continuous Survey Folder in Grid
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 11. Provide other information about the survey folder as needed. For example, type the surveyor's name 
in the Surveyor field, the survey interval in the Survey Interval field, and the name of the company 
performing the survey in the Vendor field.

 12. Click  Refresh to update the grid.

The survey folder is now available for selection when working with survey readings in Edit ISM Data 
(Data Entry > Edit ISM Data), reports, and graphs.

Delete a Continuous Survey Folder

Deleting a continuous survey folder in Survey Folder Maintenance also deletes survey readings associated 
with the survey folder.

Deleting a continuous survey folder typically occurs when you want to clean up data that is no longer 
needed or when a survey folder has been created accidentally. A message displays listing all facility records 
assigned to the survey folder allowing you to either cancel the operation or delete the survey folder.

Compete the following steps to delete a continuous survey folder:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
CIS selected.

Figure  6-15. CIS Continuous Survey Folder Window
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 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.

 4. Select a Layout Theme and/or Sort Theme and click Apply.

Figure  6-16. CIS Continuous Survey Folders

 5. Select a pipeline segment in the grid that includes the continuous survey folder you want to delete. 

Figure  6-17. Survey Folder Maintenance

 6. Click  Delete. 

 7. In the  Delete Record message window, click  Delete.
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Figure  6-18. Delete Record

 8. In the Delete message window, click  Yes to delete the survey folder or  No to cancel the 
operation.

Figure  6-19. Warning Message

The survey folder and associated survey readings are permanently deleted from PCS.

Use a Continuous Survey Folder

You can use a continuous survey folder in any of the following areas of the Indirect Survey Manager module:

 l Data entry grid. Add survey readings in a continuous survey folder associated with a pipeline 
segment using Edit ISM Data (Data Entry > Edit ISM Data). Refer to  Data Entry Grids and Forms for 
more information.

 l Filter option in Criteria Report. View survey readings based on a survey folder selected in Options 
when working with a columnar Criteria Report. Refer to Reports and Graphs for more information 
about reports.
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 l Filter option in PCS Inspections Graph. View a graph of survey readings based on a survey folder 
selected in Survey Selections when working with a PCS Inspections Graph. Refer to Reports and 
Graphs for more information about graphs.

 l Receiving survey files from the Allegro. Use the Options group box in the Field Computer Receive 
Data window to assign survey readings to a continuous survey folder associated with a pipeline 
segment. Refer to Field Computer for more information about receiving files from a mobile device.

Themes and Filter Groups for Continuous Survey Folders

A theme is a group of named settings saved for later use, such as grid layout or sorting themes. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 
themes available to all PCS users. These themes are identified with a globe icon and PCS in brackets, such 

as  [PCS] CIS Survey Folders.

NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you would like to use 
a private theme, your company's system administrator must make your private theme a public one.

A filter group is a named set of one or more filters that affect the data output in the Survey Folder 
Maintenance grid. PCS provides two types of filter groups you can define. These include the AND and OR 
filter groups.

When you add a filter group, you define filter conditions that determine which records to include or exclude 
in the Survey Folder Maintenance grid. Adding an AND filter group produces a subset of records that meet 
all filter conditions. Adding an OR filter group produces a subset of records that meet any filter condition. 
When you apply a filter group to the grid, PCS processes filters in descending order beginning with the filter 
at the top of the group.

The following topics describe how to add a layout or sort theme in the Survey Folder Maintenance grid. 

 l Add a  Continuous Survey Layout Theme on page 420

 l Add a  Continuous Survey Folders Sort Theme on page 424

 l Add and Edit an AND Filter Group for Continuous Survey Folders on page 428

 l Add or Edit an OR Filter Group for Continuous Survey Folders on page 433

 l Apply or Remove a Filter Group for Continuous Survey Folders on page 437
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Add a  Continuous Survey Layout Theme

A layout theme is a group of fields in a grid layout. Adding a new layout themes allows you to choose which 
fields you want to include in the grid layout. You can then save the layout as a theme for later use.

This topic covers how to create a layout theme for continuous survey folders within the Indirect Survey 
Manager (ISM) module. 

Layout themes are created from the Survey Folder Maintenance window that can be accessed from the 
Data Entry main menu.

NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you would like to use 
a private theme, your company's system administrator must make your private theme a public one.

Complete the following steps to add a layout theme from the Survey Folder Maintenance window:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
CIS selected.

Figure  6-20. CIS Continuous Survey Folder Window

 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.
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 4. Click the  Customize tab to open the Customize window; ensure Layouts is selected from the 
right-hand menu bar. 

Figure  6-21. Continuous Survey Folder Customize Window

 5. Click  Add to open the New Layout Theme window. 
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 6. Type a name for the layout theme in the Enter Theme Name field. 

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 7. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.  A public theme is 
available for use by all PCS users. A private theme is available only to the user who creates it.

 8. If you want to copy the content of the selected theme shown in the Copy Field From Theme field, 
select the Copy Content check box. Select a different theme if desired.

 9. Click OK to save changes and return to the Layouts window with the new layout selected.
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Figure  6-22. Layouts

 10. Complete the following steps in the Layouts page to add and remove fields in the new layout theme 
as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. 

 b. Double-click a field listed in the left pane to move it to the right pane, or select it and then click 

the   button to move it. Repeat this step as needed. The grid layout theme includes all 
fields listed in the right pane of the Layouts window.

NOTE: The   button becomes active after selecting a field and clicking in the check box.

 c. To remove a field in the layout theme, double-click a field listed in the right pane to move it to 

the left pane, or select it and then click the   button to move it. Repeat this step as needed.

NOTE: Fields with a   icon are required and cannot be removed from the theme.

 11. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  buttons.

 12. Click  Save to save changes.
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 13. To apply the new layout theme to the data entry grid:

 a. Click the Options tab.

Figure  6-23. New Layout Theme in Options Window

 b. If the new layout is not shown in the Select Layout Theme field, select it from the drop-down 
list. 

 c. Select a method for sorting survey folders in the data entry grid based on the survey date in the 
Start Date field. Select either Click Oldest First or Newest First to sort survey folders with the 
oldest or newest survey Start Date first.

 d. Click  Apply to save changes and return to the data entry grid.

Add a  Continuous Survey Folders Sort Theme

A sort theme determines how PCS sorts records in a data entry grid. Adding a sort theme allows you to 
choose which field(s) to sort records by and if records sort alphanumerically in ascending or descending 
order.

This topic covers how to create a sort theme for continuous survey folders within the Indirect Survey 
Manager (ISM) module. 

Complete the following steps to add a sort theme for a continuous survey in Survey Folder Maintenance:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
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CIS selected.

Figure  6-24. CIS Continuous Survey Folder Window

 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.

 4. Click the  Customize tab  then the  Sorts button to open the Sorts window.

Figure  6-25. Continuous Survey Folder Sorts Window

 5. Click  Add to open the New Sort Layout window.
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Figure  6-26. New Sort Theme

 6. Type a name for the sort theme in the field Enter Theme Name. 

 7. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.  A public theme is 
available for use by all PCS users. A private theme is available only to the user who creates it.

 8. If you want to copy the content of the selected theme shown in the Copy Field From Theme field, 
select the Copy Content check box. Select a different theme if desired.

 9. Click  OK to save changes and return to the Sorts window with the new layout selected.
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Figure  6-27. Sort Window with New Sort Theme

 10. Complete the following steps in the Sorts window to add and remove fields in the new sorting theme 
as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. 

 b. Double-click a field listed in the left pane to move it to the right pane, or select it and then click 

the   button to move it. Repeat this step as needed. The grid layout theme includes all 
fields listed in the right pane of the Layouts window.

NOTE: The   button becomes active after selecting a field and clicking in the check box.

 c. To remove a field in the layout theme, double-click a field listed in the right pane to move it to 

the left pane, or select it and then click the   button to move it. Repeat this step as needed.

NOTE: Fields with a   icon are required and cannot be removed from the theme.

 11. Select a sorting method for each field listed in the right pane. To sort grid records in ascending order, 

click the toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 12. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  buttons.
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 13. Click  Save to save changes.

 14. To apply the new sort theme to the data entry grid:

 a. Click the Options tab.

Figure  6-28. Options Window with New Sort Theme

 b. If the new layout is not shown in the Select Sort Theme field, select it from the drop-down list. 

 c. Click  Apply to save and apply changes and then return to the data entry grid. 

Add and Edit an AND Filter Group for Continuous Survey Folders

An AND filter group is a named set of one or more filters that affect the data output in the Survey Folder 
Maintenance grid. Adding an AND filter group produces a subset of records that meet all filter conditions. 
PCS processes filters in a filter group in descending order beginning with the filter at the top of the filter 
group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps create or edit an AND filter group for use on the Survey Folder Maintenance 
window for a continuous survey folder:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
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CIS selected.

Figure  6-29. CIS Continuous Survey Folder Window

 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.

 4. Click the  Customize tab and then  Filters tab to open the Filters window.

Figure  6-30. Continuous Survey Folder Filters Window

 5. To add a new 'And' filter group, click New 'And' Group to open the filter properties group box.         

icon_circles_joined_black.png
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Figure  6-31. New 'And' Group Filter         

 6. Type a name for the filter group in the Filter Group Caption field. 

 7. If you want the filter to always remain on, select the  Filter is Always On check box. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

 8. Use filter selection fields to set up filter criteria for the new filter. Select a PCS field, operator, and one 
or more filter conditions. Filter conditions are based on the PCS field selected. The line above the filter 
selection updates to show how the filter is defined. For example, shown below is a filter based on CI 
Survey Name. The field and conditions are also shown in the space above the box. 
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Figure  6-32. 'And' Filter Operators

The line above the box will update as you add or change conditions.

Figure  6-33. 'And' Filter With Conditions

 9. If desired, type a name for the filter in the Enter Custom Filter Caption field. The line above the filter 
box will update with this name.

Figure  6-34. Custom Filter Caption Name Update

 10. For fields that include a date, click the down arrow in the start date field to open a calendar and select 
a date. You can also type a date in the start and end date fields. Enter a start and end date using the 
format M/DD/YYYY to indicate the month, day, and year. Repeat this step for the end date field.

 11. To set a date range using dynamic start and end dates, click the  icon in the start date field and set 

up dynamic date properties. Repeat this step for the end date field. Clicking the icon opens and 
closes dynamic date property fields. 
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 12. To close a filter box, click the  icon in the upper left corner.

Figure  6-35. Close a Filter Box

 13. To delete a filter, click the  icon on the right side of the filter box.

 14. If additional filters are needed within the filter group, click  to add a new filter box and repeat these 
steps. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

 

Figure  6-36. Edit Icon with New Filter Group   

 15. Click the  icon for a filter to open that filter's property settings and change settings as needed. 

 16. Click  Save to save the filter(s).  Add or edit filters as desired.

 17. When finished, click Save and Close to save filter(s) and close the window. 

 18. Refer to Apply or Remove a Filter Group for Pipeline Records for more information on how to apply a 
filter group to a data grid.
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Add or Edit an OR Filter Group for Continuous Survey Folders

An OR filter group is a named set of one or more filters that affect the data output in the Survey Folder 
Maintenance grid. Adding an OR filter group produces a subset of records that meet any filter condition. 
PCS processes filters in a filter group in descending order beginning with the filter at the top of the filter 
group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to create or edit an OR filter group for use on the Survey Folder Maintenance 
window for a continuous survey folder:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
CIS selected.

Figure  6-37. CIS Continuous Survey Folder Window

 3. Click one of the tabs to select the type  of continuous survey that you want to add a survey folder. For 
example, clicking the CIS tab adds a survey folder for close interval survey readings.

 4. Click the Customize tab and then the Filters tab to open the Filters window.
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Figure  6-38. Continuous Survey Folder Filters Window

 5. To add a new 'Or' filter group, c   lick New 'Or' Group to open the filter properties group box. 

Figure  6-39. Filters 

 6. If you want the filter to always remain on, select the  Filter is Always On check box. 

It is recommended that you add filters in the order in which you would like them used. 

 7. Use filter selection fields to set up filter criteria for the new filter. Select a PCS field, operator, and one 
or more filter conditions. Filter conditions are based on the PCS field selected. The line above the filter 
selection updates to show how the filter is defined. For example, shown below is a filter based on CI 
Survey Name. The field and conditions are also shown in the space above the box. 
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Figure  6-40. 'Or' Filter Operators

The line above the box will update as you add or change conditions, for example, changing the first 
condition from Contains to Is Greater Than Or Equal To.

Figure  6-41. 'Or' Filter With Conditions

 8. If needed, click the  icon next to a operator field to remove any text that you entered and re-enter 
values.

 9. If desired, type a name for the filter in the Enter Custom Filter Caption field. The line above the filter 
box will update with this name.

Figure  6-42. Or Filter Group Caption Name

 10. A field  that includes an  icon in the operator line (for example, Start Date) indicates that a dynamic 
value can be set.

Figure  6-43. Field Operators with Dynamic Values Option
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Click the icon to open dynamic property fields and enter values as needed. Click the to remove 
entered values and clear the fields.

Figure  6-44. Dynamic Field Operators

 11. Click  Save to save the filter.

 12. To re-open the filter box, click the  icon.

 13. To close a filter box, click the  icon in the upper left corner.

Figure  6-45. Close a Filter Box

 14. To delete a filter, click the  icon on the right side of the filter box.

 15. If additional filters are needed within the filter group, click  to add a new filter box and repeat these 
steps. 

NOTE: It is recommended that you add filters in the order in which you would like them used.

Figure  6-46. Adding a New Filter Box

 16. Click the  icon for a filter to open that filter's property settings and change settings as needed. 

 17. Click  Save to save the filter(s). Add or edit filters as desired.
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 18. When finished, click  Save and Close to save filter(s) and close the window. 

 19. Refer to Apply or Remove a Filter Group for Pipeline Records for more information on how to apply a 
filter group to a data grid.

Apply or Remove a Filter Group for Continuous Survey Folders

After creating an AND or an OR filter group, the filter can be applied to or removed from the Survey Folder 
Maintenance grid using the Options window.

Refer to  Add and Edit an AND Filter Group for Continuous Survey Folders and Add or Edit an OR Filter 
Group for Continuous Survey Folders for information on how to create filter groups.

Complete the following steps to apply or remove one or more filters to the  Survey Folder Maintenance grid:

 1. Click Modules > Indirect Survey Manager (ISM) to open the ISM module.

 2. Click Data Entry > Continuous Survey Folder Maintenance to open the Continuous Survey Folder 
window. The window that opens is dependent on the type of continuous survey selected from the 
top row of tabs (CIS, AC CIS, DCVG, ACVG, ACCA, Soil Resistivity, or ILI). The example below has 
CIS selected.

Figure  6-47. CIS Continuous Survey Folder Window

 3. Ensure that the Options tab  is selected. The filters will display in the Filters pane.
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Figure  6-48. Options Window - New Filters in Filters Pane

 4. Click the check box for each filter you want to apply.

 5. Click  Apply to save changes and return to the data entry grid. 

 6. To remove a filter that has been applied, open the Options window and de-select any filter you no 

longer want to apply. Then click  Apply to save changes and return to the data entry grid.
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Chapter 7: Routes
A route is a user-created list of facilities for inspection. You can include facilities for one or more facility types 
in the same route, such as test points, valves, and atmospherics. The main advantage in a route is the ability 
to arrange facilities in a particular order that is more suitable in a survey. For example, you can arrange 
facilities in survey order instead of numerically by ROW Code and milepost number.

Routes are used in several areas of PCS. You can view inspection records in a grid based on a route, 
transfer a survey to the  field computer or other mobile device based on a route, and generate reports based 
on a route.

Most PCS users can work with routes.

This chapter  includes the following topics:

 l Create a Route on page 439

 l Routes Quick Start on page 443

 l Change the Order of Facilities on page 447

 l Prepare a Route for an Averaged Reading Survey on page 449

 l Prepare a Route for Inspection GPS Fields on page 467

 l Work with Themes and Filter Groups on page 482

 l Print, Export, or Email a Route on page 502

 l Export and Import a Route on page 506

 l Use a Route in PCS on page 507

Create a Route
The following information explains how to create a route with a list of facilities for inspection. Facilities for 
inspection are based on the pipeline segment(s) you select in the Select ROWs window. These instructions 
start with the assumption that a PCS module is already selected and the correct pipeline segments have 
been selected. For information detailing how to select pipeline segments, refer to Select ROWs on page 
171.

Complete the following steps to create a route:
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 1. Click Data Entry > Define Routes.

 2. Click  Add. the Add New Route window opens.

NOTE: If this is the first route to be created, the window will automatically open.

Figure  7-1. Add New Route

 3. Type a name for the new route in the Enter Route Name field. 

 4. If necessary, click the ellipsis button in the Import Route Records from file field to select a file to 
import records into the route. Select the file and click Open.

 5. Click  OK in the Add New Route window..

 6. Select the facility type(s) you want to work with using the method described in either of the following 
sets of steps:

 a. To select a facility type, click the facility type option button and then click the down arrow and 

select a facility type in the list, such as  [PCS] Rectifier Survey.
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Figure  7-2. Facility Type Theme Option

 b. To select multiple facility types, click Ad Hoc Theme radio button and then select one or more 
facility types in the CPDM, VM, ACM, ICM, LSM, or CMA sections.
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An Ad Hoc Theme only applies to the current session and is not saved. A facility type is 
selected when a check mark appears inside the check box. To clear the check mark, click the 
check box again.

Figure  7-3. Ad Hoc Theme Option

 7. Select which facilities to include in the route in the Facilities Available grid:
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 a. To include all facilities, click  Add All and then click Yes when the Add All message opens.

 b. To only include facilities you select, select individual facilities in the Facilities Available grid. Or 
double-click each facility.

 8. Click  Save to save changes. The route is saved, and the grid is updated.

Figure  7-4. Define Routes

Routes Quick Start
Information in this section assumes one or more routes have previously been created. If no routes exist, 
review Create a Route on page 439.

The following procedure explains how to display and set properties in a route. Property settings include 
selection of a layout and sort theme. Both of these themes determine how PCS displays facility records in a 
route.

As an option, you can also set up one or more filter groups that apply only to the current session. A filter 
group filters data in a route by including or excluding certain facility records. It allows you to work with a 
subset of facility records for the currently selected ROW based on filter selection criteria.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.



PCS v2.5 User Guide

Chapter 7: Routes 444

Complete the following steps to display and set properties for a route:

 1. Click Data Entry > Define Routes to open the Define Routes window.

Figure  7-5. Define Routes Window

 2. Select a route from the Routes drop-down list.

Figure  7-6. Define Routes Selection List

 3. Click the Options tab  to open the Options window.
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Figure  7-7. Define Routes Options

 4. select a layout theme from the  Select Layout Theme drop-down list and a sort theme from the Select 
Sort Theme drop-down list.

 5. If you want to filter records in the grid and route, complete the following steps. Filter settings in the 
Define Routes Options window apply only to the current session and are not saved. See Work with 
Themes and Filter Groups on page 482 for information about saving filter settings in a theme.

 a. To apply a predefined filter, select one or more options in the Filters pane and then click  
Apply. 

A check mark inside a check box indicates a selection. To clear a selection, click the check 
box again to remove the check mark.

 b. To add a new filter to an existing filter group, click the   icon within a field group and then use 
filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

Figure  7-8. Filter Group
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 c. To create a new filter, first decide if you need to add an AND filter group or an OR filter group. 
Adding an AND filter group produces a subset of records that meet all filter conditions. Adding 
an OR filter group produces a subset of records that meet any filter condition. PCS processes 
filters in a filter group in descending order beginning with the filter at the top of the filter group.

 i. To create a new And group, click New 'And' Group  to open the filter properties group 
box.         

Figure  7-9. And Group Filters 

 ii. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  7-10. Or Group Filters 

 iii. Type a name for the filter group in the Filter Group Caption field. 

 iv. Select the Filter Is Always On option to keep the filter on.

 v. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or 
more filter conditions.

 1. When adding a date filter, set a date range using a calendar or dynamic dates in 
one of the following ways:       

 l Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field.         
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 l To set a date range using dynamic start and end dates, click the  
calculator icon in the start date field and set up dynamic date properties. 
Repeat this step for the end date field. Clicking the calculator button opens 
and closes dynamic date property fields. 

 2. Type a name for the filter in the Enter Custom Filter Caption field. 

 3. If additional filters are needed within the filter group, click  and repeat these 
steps.       

 vi. If necessary, click the  edit icon for a filter to open that filter's property settings and 
change settings as needed. 

 vii. Click  Save to save the filter group.         

 viii. Click  Save and Close when finished saving all filter groups.         

 6. Click  Apply to save and apply changes. PCS closes the options page and returns to the Define 
Routes window.

Change the Order of Facilities
The order of facilities shown in the Facilities in Route grid identifies the facility order used in a route. You can 
easily change the order of facilities by dragging and dropping one or more grid rows to a different location in 
the grid. Changing the order allows you to arrange facilities based on particular criteria, such as arranging 
facilities in the order a survey is taken.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to change the order of facilities in a route:
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 2. Click Data Entry > Define Routes. Select a route from the Routes drop-down list.

Figure  7-11. Defined Routes

 3. Arrange the order of facilities listed in the Facilities in Route grid as needed using any of the following 
methods:

 a. To move a single grid row, select the row, then drag and drop the row in a different location in 
the grid. Click  Save to save changes.

A message displays when moving selected grid rows to confirm the new location in the grid.

Figure  7-12. Arranging the Order of Facilities

 b. To move a group of consecutive grid rows, click the first row, press and hold the Shift key, then 
click the last row. Drag and drop selected rows in a different location in the grid. Click   Save 
to save changes.
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 c. To move a group of non-consecutive grid rows, press and hold the Ctrl key, then click each 
row you want to select. Drag and drop selected rows in a different location in the grid. Click   
Save to save changes.

Prepare a Route for an Averaged Reading Survey
This topic only applies to the CPDM module. 

You can prepare and send a survey to a field computer or mobile device based on a route with facilities in an 
averaged reading survey. Facilities for inspection are also set up with timed reading fields in the Test Point 
Information and Inspection data entry grid.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Refer to the following topics for more information on preparing a route for an averaged reading survey:

 l Add Timed Reading Fields in the Information Grid

 l Add Timed Reading Fields in the Inspection Grid on page 453

 l Edit a Route for an Averaged Reading Survey on page 455

 l Send a Survey  Based on a Route with Facilities on page 457

Refer to the following Allegro or mobile device user guides for more information on using these devices:

 l Allegro QX Support Site.

 l PCS Field Data Collector Support Site for the Allegro AX and Mesa 3.

Add Timed Reading Fields in the Information Grid

Timed reading fields are added in the Test Point Information data entry grid to allow data entry of inspection 
readings in the Test Point Inspection data entry grid for an averaged reading survey. Information in this 
section explains how to add timed reading fields in a layout theme and then apply the theme to the 
Information data entry grid.

Complete the following steps to add timed reading fields in the Information grid:

http://support.aiworldwide.com/products/al2/content/topics/index.htm
http://support.aiworldwide.com/products/al3/content/topics/index.htm
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 1. Click Data Entry > Edit CPDM Data.

 2. Click the  Information tab and then the  Test Point tab to open the Test Point Information data entry 
grid.

Figure  7-13. Test Point Information Data Entry Grid

 3. Click the Customize tab to open the Layouts window.
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Figure  7-14. Layouts

 4. Select a data entry grid layout theme from the Select Layout Theme drop-down list.

 5. Click  Test Point Information Fields in the left pane of the window to expand the list of fields available 
for selection.

Figure  7-15. Test Point Information Fields
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 6. Add the following list of timed reading fields in the layout theme. To add fields, double-click each 
timed reading field listed in the left pane of the Layouts window to move fields to the right pane. Add 
other fields as required. The data entry grid layout theme includes all fields listed in the right pane of 
the Layouts window.

 l Activate Average P/S

 l Activate Max P/S

 l Activate Min P/S

 l Activate P/S Sample Time

 7. Click  Save and Close. The Options window displays.

 8. In the Options window, select the layout theme with timed readings from the  Select Layout Theme 
drop-down list to apply the layout theme to the data entry grid. 

 9. Click  Apply to save and apply changes. PCS closes the options page and returns to the Test Point 
Information data entry grid.

 10. In each column labeled with an "Activate" timed reading field, click the check box associated with the 
facility you plan to record  timed readings in a field computer or mobile device.

Figure  7-16. Test Point Information Data Entry Grid
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Add Timed Reading Fields in the Inspection Grid

Complete the following steps to add timed reading fields in a layout theme and then apply the theme to the 
Test Point Inspection data entry grid:

 1. Click Data Entry > Edit CPDM Data.

 2. Click the  Inspection tab and then the  Test Point tab to open the Test Point Information grid.

Figure  7-17. Test Point Information Data Entry Grid

 3. Click the Customize tab to open the Layouts window.
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Figure  7-18. Layouts

 4. Select a layout theme from the Select Layout Theme drop-down list.

 5. Click  Test Point Inspection Fields in the left pane of the window to expand the list of fields available 
for selection.

Figure  7-19. Test Point Inspections Fields Expanded
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 6. Add the following list of timed reading fields in the layout theme. To add a field, double-click a timed 
reading field listed in the left pane to move the field to the right pane. Add other fields as required. The 
layout theme includes all fields listed in the right pane of the Layouts page.

 l Average P/S

 l Max P/S

 l Min P/S

 l P/S Sample Time

 7. Click  Save and Close. 

Edit a Route for an Averaged Reading Survey

Complete the following steps to set up a route with facilities for inspection in an averaged reading survey:

 1. Click Data Entry > Define Routes. 

 2. Select a route from the Routes drop-down list.

 3. Select [PCS] Test Point Survey from the Facility Types drop-down list or select Ad Hoc Theme and 
then the Test Point check box.

Figure  7-20. Select Timed Reading Theme

 4. In the Facilities Available grid, select which facilities to include in the route. To include all facilities, click 
 Add All and then Yes in the Add All message. To only include facilities you select, click the check 

box for each facility in the Facilities Available grid (or double-click each facility).
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Selected facilities display in the Facilities in Route grid.

Figure  7-21. Facilities Available Grid

 5. In the Facilities in Route grid, arrange the survey order of facilities listed  as needed using any of the 
following methods:

 a. To move a single grid row, select the row, then drag and drop the row in a different location in 
the grid. A message displays when moving selected grid rows to confirm the new location in 
the grid.

Figure  7-22. Arranging the Order of Facilities

 b. To move a group of consecutive grid rows, click the first row, press and hold the Shift key, then 
click the last row. Drag and drop selected rows in a different location in the grid.

 c. To move a group of non-consecutive grid rows, press and hold the Ctrl key, then click each 
row you want to select. Drag and drop selected rows in a different location in the grid.

 6. Click  Save to save changes.
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Send a Survey  Based on a Route with Facilities

Information in this section explains how to send a survey to the Allegro based on a route with facilities in an 
averaged reading survey. The process includes adding a theme with prompts for timed reading fields. 
Prompts are data entry fields in an Allegro survey file that require survey data, such as an inspection reading 
at each facility location.  These instructions start with the assumption that  the correct pipeline segments 
have been selected. For information detailing how to select pipeline segments, refer to Select ROWs on 
page 171.

Complete the following steps to send a survey to the field computer or mobile device:

 1. Verify the field computer or mobile device is connected to your computer. If needed, refer to the 
device's user guide for information about how to connect the device.

 2. Click Field Computer > Send to open the Field Computer Send window.

Figure  7-23. Field Computer Send

 3. Click the Customize tab and then the  Prompts tab to open the Prompts window.
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Figure  7-24. Prompts

 4. Click  Add to open the New Prompt window. Required fields are identified with the  icon and must 
be completed to continue.

Figure  7-25. New Prompt

 5. Type a name for the theme in the Enter Theme Name field.
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Figure  7-26. New Prompt

 6. If you want to create a public theme, select the Public check box. When the check box is empty, the 
theme saves as a private theme.

 7. If you want to copy fields from an existing theme, select the Copy Content check box and then select 
a theme from the Copy Fields From Theme drop-down list. If you do not want to copy fields from an 
existing prompt theme, clear the check mark inside the Copy Content check box.

 8. Click  OK to save changes and return to the Prompts window.

 9. Verify the name of the new theme displays in the Select Prompt Theme field. If not,  select the theme 
in the selection list.

 10. Select Test Pointfrom the Select Facility Type drop-down list.

Figure  7-27. Timed Reading Theme and Test Point Facility Selected

 11. Add fields from the Facility, Information and ROW Fields pane's left pane to the right pane.
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 a. Click  to view the list of fields in an un-expanded view. Click the  to expand individual lists.

Figure  7-28. Expand One Set of Fields

 b. Click  to view all the list of fields in an expanded view.
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Figure  7-29. All Fields Expanded

 c. Select fields and then click the  button to move it to the right pane. You can also double-

click the field to move it. To move it back to the left pane, click the  button.

 d. To rearrange the order of the fields in the left pane, use the  and  buttons. You can 
also click and drag field names to move them.

All fields listed in the right pane are included in the prompt theme.

 12. Add the following timed reading prompts from the Inspection and Maintenance Fields left pane to the 
right:

 l Average P/S

 l Max P/S

 l Min P/S

 l P/S Sample Time

 13. Complete the following steps to add site string prompts that help identify one facility from another 
when using the field computer or mobile device. Site string prompts are included with each facility 
and can be viewed in the device's Site List window.

 a. Click  Site Settings (below the Inspection and Maintenance Fields pane) to view a list of 
fields available for selection.
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Figure  7-30. Site Settings Fields

 b. Double-click one or more fields in the selection list to move fields to the right pane. 

 14. If you want to add another page of prompts, click a page number in the Pages pane and add fields 
from Facility, Information and ROW Fields and Inspection and Maintenance Fields panes.

Figure  7-31. Pages Selection

To make a copy of the first page, click the  Copy in either left side pane to copy Page 1 to a new 
page. The following image shows Page 2 with a copy of Page 1's Facility, Information and ROW 
Fields included. 
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Figure  7-32. Creating Page 2 From Page 1

 15. Repeat as needed.

 16. Click  Save and Close to save changes and return to the Field Computer Send window.

 17. Click the Route option and select a route in the selection box. Then click  Apply to update the grid.
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Figure  7-33. Field Computer Send - Route

 18. Select a theme with timed reading fields from the Select Prompt drop-down list.

 19. Select a layout theme from the Select Layout Theme drop-down list.

 20. Select a sort theme from the Select Sort Theme drop-down list.

 21. Select the Send to Allegro (for Allegro MX or QX) or Send to Mobile (for Allegro AX, Mesa 3, or other 
mobile device) radio button in Options pane, depending on the device you are using. 

 22. If you selected the Send to Allegro options, and you want to rename the survey file, type a name in the 

Output File field. Be sure to include the .dat file extension.

 23. If you selected the Send to Mobile options, select the device from the Output Device drop-down list.

 24. If the  Open Maintenance Items check box is available for selection, click the check box if you want to 
include open maintenance records in the survey file.

When the selected prompt theme includes maintenance prompts, the Open Maintenance 
Itemscheck box is available for selection. It is disabled and unavailable for selection when 
maintenance prompts are not included in the currently selected prompt theme.

 25. If you want to filter records in the grid and in the route sent to the Allegro, click the  in the Filters 
pane to open it. 

Filter settings in Field Computer Send apply only to the current session and are not saved. See Work 
with Themes and Filter Groups on page 482 for information about saving filter settings in a theme.
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Figure  7-34. Filters

 a. To apply a predefined filter, click the check box of one or more options in Filters and then click 
 Apply. For example, click Currently Active Facilities Only to only include active facilities.

 b. To add a new filter to an existing filter group, click the  icon within a field group and then use 
filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 c. To create a new filter, first decide if you need to add an AND filter group or an OR filter group. 
Adding an AND filter group produces a subset of records that meet all filter conditions. Adding 
an OR filter group produces a subset of records that meet any filter condition. PCS processes 
filters in a filter group in descending order beginning with the filter at the top of the filter group.

 i. To create a new And group, click New 'And' Group  to open the filter properties group 
box.         

Figure  7-35. And Group Filters 
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 ii. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  7-36. Or Group Filters 

 iii. Type a name for the filter group in the Filter Group Caption field. 

 iv. Select the Filter Is Always On option to keep the filter on.

 v. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or 
more filter conditions.

 1. When adding a date filter, set a date range using a calendar or dynamic dates in 
one of the following ways:       

 l Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field.         

 l To set a date range using dynamic start and end dates, click the  
calculator icon in the start date field and set up dynamic date properties. 
Repeat this step for the end date field. Clicking the calculator button opens 
and closes dynamic date property fields. 

 2. Type a name for the filter in the Enter Custom Filter Caption field. 

 3. If additional filters are needed within the filter group, click  and repeat these 
steps.       

 vi. If necessary, click the  edit icon for a filter to open that filter's property settings and 
change settings as needed. 

 vii. Click  Save to save the filter group.         

 viii. Click  Save and Close when finished saving all filter groups.         

 26. Click  Apply to update the grid.
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 27. Click  Send to send the survey file to the mobile device.

 28. When a message displays confirming the send process is complete, click  OK to close the 
message. PCS sends the survey file to the PSData folder on the mobile device.

Figure  7-37. Send Process Complete

Prepare a Route for Inspection GPS Fields
This section explains how to prepare and send a survey to the Allegro based on a route with inspection GPS 
fields. Facilities for inspection are also set up in the Inspection data entry grid with inspection GPS fields.

Including inspection GPS fields in a survey allows you to capture GPS location data for each facility 
inspection reading. These fields also allow you to verify inspection readings are taken at the correct 
location.

Information in this section applies to all PCS modules. Examples are based on the CPDM module. 

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

 l Add Inspection GPS Fields in the Inspection Grid on page 467

 l Edit a Route with Facilities for Inspection on page 470

 l Send a Survey Based on a Route with GPS Fields on page 472

Add Inspection GPS Fields in the Inspection Grid

The procedure in this section explains how to add inspection GPS fields in a layout theme and then apply 
the theme to an Inspection data entry grid. The procedure uses the Test Point Inspection data entry grid as 
an example.

Complete the following steps to add inspection GPS fields in the Inspection grid:
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 1. Open the Inspection data entry grid for a facility type. For example, click Data Entry > Edit CPDM 
Data, click the  Inspection tab, and then click the Test Point tab to open the Test Point Inspection data 
entry grid.

Figure  7-38. Test Point Inspection Data Entry Grid

 2. Click the Customize tab to view the Layouts window.
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Figure  7-39. Edit CPDM Data Test Point Inspection Layouts

 3. Select a data entry grid layout theme from the  Select Layout Theme drop-down list.

 4. Click the  next to the Inspection fields category in the left pane of the window to view a list of fields 
available for selection. For example, click  Test Point Inspection Fields.

 5. Add the following inspection GPS fields in the layout theme. To add a field, double-click a inspection 
GPS field in the left pane to move the field to the right pane. Add other fields as required. The layout 
theme includes all fields listed in the right pane.

 l Inspection Elevation

 l Inspection GPS Accuracy

 l Inspection GPS Difference

 l Inspection Latitude

 l Inspection Longitude

 6. Click  Save.

 7. Click the Options tab to open the Options window.



PCS v2.5 User Guide

Chapter 7: Routes 470

Figure  7-40. Options

 8. Select the theme with inspection GPS fields from the Select Layout Theme drop-down list to apply 
the layout theme to the data entry grid. 

 9. Click  Apply.

PCS saves and applies changes, then closes the options page and returns to the Test Point 
Inspection data entry grid.

Edit a Route with Facilities for Inspection

Complete the following steps to set up a route with facilities for inspection that include inspection GPS 
fields:
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 1. Click Data Entry > Define Routes. 

Figure  7-41. Define Routes Window

 2. Select a route from the Routes drop-down list.

 3. Select a facility type theme from the  Facility Types drop-down list or select Ad Hoc Theme and then 
click the check box for one or more facility types.

 4. Select which facilities to include in the route. To include all facilities, click  Add All in the Facilities 
Available grid.

To only include facilities you select, click the check box for each facility in the Facilities Available grid. 
Or double-click each facility.

Selected facilities display in the Facilities in Route grid.

 5. Arrange the survey order of facilities listed in the Facilities in Route grid as needed using any of the 
following methods:

 a. To move a single grid row, select the row, then drag and drop it in a different location in the 
grid. A message displays when moving selected grid rows to confirm the new location in the 
grid.
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Figure  7-42. Arranging the Order of Facilities

 b. To move a group of consecutive grid rows, click the first row, press and hold the Shift key, then 
click the last row. Drag and drop selected rows in a different location in the grid.

 c. To move a group of non-consecutive grid rows, press and hold the Ctrl key, then click each 
row you want to select. Drag and drop selected rows in a different location in the grid.

 6. Click  Save to save changes.

Send a Survey Based on a Route with GPS Fields

Information in this section explains how to send a survey to the Allegro based on a route with facilities that 
include inspection GPS fields. The process includes adding a prompts theme with prompts for inspection 
GPS fields. Prompts are data entry fields in an Allegro survey file that require survey data, such as GPS data 
for each facility inspection reading. These instructions start with the assumption that  the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to send a survey to the field computer or mobile device based on a route:

 1. Verify the field computer or mobile device is connected to your computer. If needed, refer to the 
device's user guide for information about how to connect the device.

 2. Click Field Computer > Send to open the Field Computer Send window.
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Figure  7-43. Field Computer Send

 3. Click the Customize tab and then the  Prompts tab to open the Prompts window.

Figure  7-44. Prompts

 4. Click  Add to open the New Prompt window. Required fields are identified with the  icon and must 
be completed to continue.
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Figure  7-45. New Prompt

 5. Type a name for the theme in the Enter Theme Name field.

Figure  7-46. New Prompt

 6. If you want to create a public theme, select the Public check box. When the check box is empty, the 
theme saves as a private theme.

 7. If you want to copy fields from an existing theme, select the Copy Content check box and then select 
a theme from the Copy Fields From Theme drop-down list. If you do not want to copy fields from an 
existing prompt theme, clear the check mark inside the Copy Content check box.

 8. Click  OK to save changes and return to the Prompts window.

 9. Verify the name of the new theme displays in the Select Prompt Theme field. If not,  select the theme 
in the selection list.
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 10. Select a facility type from the Select Facility Type drop-down list.

 11. Add fields from the Facility, Information and ROW Fields pane's left pane to the right pane.

 a. Click  to view the list of fields in an un-expanded view. Click the  to expand individual lists.

Figure  7-47. Expand One Set of Fields

 b. Click  to view all the list of fields in an expanded view.
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Figure  7-48. All Fields Expanded

 c. Select fields and then click the  button to move it to the right pane. You can also double-

click the field to move it. To move it back to the left pane, click the  button.

 d. To rearrange the order of the fields in the left pane, use the  and  buttons. You can 
also click and drag field names to move them.

 e. All fields listed in the right pane are included in the prompt theme.

 12. Add the following inspection GPS prompts from the Inspection and Maintenance Fields left pane to 
the right:

 l Inspection Elevation

 l Inspection GPS Accuracy

 l Inspection Latitude

 l Inspection Longitude

 13. Complete the following steps to add site string prompts that help identify one facility from another 
when using the Allegro. Site string prompts are included with each facility and can be viewed in the 
Allegro Site List window.
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 a. Click  Site Settings (below the Inspection and Maintenance Fields pane) to view a list of 
fields available for selection.

Figure  7-49. Site Settings

 b. Double-click one or more fields in the selection list to move fields to the right pane. 

 14. If you want to add another page of prompts, click a page number in the Pages pane and add fields 
from Facility, Information and ROW Fields and Inspection and Maintenance Fields panes.

Figure  7-50. Pages Selection

To make a copy of the first page, click the  Copy in either left side pane to copy Page 1 to a new 
page. The following image shows Page 2 with a copy of Page 1's Facility, Information and ROW 
Fields included. 
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Figure  7-51. Creating Page 2 From Page 1

 15. Repeat as needed.

 16. Click  Save and Close to save changes and return to the Field Computer Send window.

 17. Click the Route option and select a route in the selection box. Then click  Apply to update the grid.
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Figure  7-52. Field Computer Send - Route

 18. Select a theme with GPS inspection fields from the Select Prompt drop-down list.

 19. Select a layout theme from the Select Layout Theme drop-down list.

 20. Select a sort theme from the Select Sort Theme drop-down list.

 21. Select the Send to Allegro (for Allegro MX or QX) or Send to Mobile (for Allegro AX, Mesa 3, or other 
mobile device) radio button in Options pane, depending on the device you are using. 

 22. For either the Send to Allegro or Send to Mobile options, and you want to rename the survey file, type 
a name in the Output File field. For files being sent to an Allegro MX or QX, be sure to include the

 .dat file extension.

 23. If you selected the Send to Mobile options, also select the device from the Output Device drop-down 
list.

 24. If the  Open Maintenance Itemscheck box is available for selection, click the check box if you want to 
include open maintenance records in the survey file.

When the selected prompt theme includes maintenance prompts, the check box Open Maintenance 
Items is available for selection. It is disabled when maintenance prompts are not included in the 
currently selected prompt theme.

 25. If you want to filter records in the grid and in the route sent to the Allegro, click the  in the Filters 
pane to open it. 

Filter settings in Field Computer Send apply only to the current session and are not saved. Refer to 
Work with Themes and Filter Groups on page 482 for information about saving filter settings in a 
theme.
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Figure  7-53. Filters

 a. To apply a predefined filter, click the check box of one or more options in Filters and then click 
 Apply. For example, click Currently Active Facilities Only to only include active facilities.

 b. To add a new filter to an existing filter group, click the  icon within a field group and then use 
filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 c. To create a new filter, first decide if you need to add an AND filter group or an OR filter group. 
Adding an AND filter group produces a subset of records that meet all filter conditions. Adding 
an OR filter group produces a subset of records that meet any filter condition. PCS processes 
filters in a filter group in descending order beginning with the filter at the top of the filter group.

 i. To create a new And group, click New 'And' Group  to open the filter properties group 
box.         

Figure  7-54. And Group Filters 
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 ii. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  7-55. Or Group Filters 

 iii. Type a name for the filter group in the Filter Group Caption field. 

 iv. Select the Filter Is Always On option to keep the filter on.

 v. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or 
more filter conditions.

 1. When adding a date filter, set a date range using a calendar or dynamic dates in 
one of the following ways:       

 l Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field.         

 l To set a date range using dynamic start and end dates, click the  
calculator icon in the start date field and set up dynamic date properties. 
Repeat this step for the end date field. Clicking the calculator button opens 
and closes dynamic date property fields. 

 2. Type a name for the filter in the Enter Custom Filter Caption field. 

 3. If additional filters are needed within the filter group, click  and repeat these 
steps.       

 vi. If necessary, click the  edit icon for a filter to open that filter's property settings and 
change settings as needed. 

 vii. Click  Save to save the filter group.         

 viii. Click  Save and Close when finished saving all filter groups.         

 26. Click  Apply to update the grid.
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 27. Click  Send to send the survey file to the mobile device.

 28. When a message displays confirming the send process is complete, click  OK to close the 
message. PCS sends the survey file to the PSData folder on the mobile device.

Figure  7-56. Send Process Complete

Work with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort theme. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 
themes available to all PCS users. These themes are identified with a globe icon and PCS in brackets [PCS], 

such as  [PCS] Route Grid.

NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you would like to use 
a private theme, your company's system administrator must make your private theme a public one.

A filter group is a named set of one or more filters that affect the data output in the Define Routes grid and 
subsequently the route itself. PCS provides two types of filter groups you can define. These include the 
AND and OR filter groups.

When you add a filter group, you define filter conditions that determine which records to include or exclude 
in the Define Routes grid and the route. Adding an AND filter group produces a subset of records that meet 
all filter conditions. Adding an OR filter group produces a subset of records that meet any filter condition. 
When you apply a filter group, PCS processes filters in descending order beginning with the filter at the top 
of the group.

The following topics describe how to add a layout theme, sort theme, and one or more optional filter 
groups:
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 l Work with a Layout Theme

 l Work with a Sort Theme on page 490

 l Add, Edit, and Apply an AND or OR Filter Group on page 496

 l Edit and Arrange Filters and Filter Groups on page 499

Work with a Layout Theme

A layout theme is a named set of fields that are present when working in the route grid. A layout theme also 
determines which fields are included when printing a route.

Two types of layout themes are available for use. They include installed and addition layout themes. An 
installed layout theme is one that has been installed during the PCS software installation, such as [PCS] 
Route Grid. A layout theme addition is one that you create.

The following topics explain how to work with a layout theme:

 l Edit an Installed Layout Theme

 l Add a Layout Theme Addition on page 485

 l Edit a Layout Theme Addition on page 488

Edit an Installed Layout Theme

An installed layout theme includes [PCS] in the name of the theme, such as  [PCS] Route Grid. A layout 
theme determines which fields are present when viewing or printing a route. You can edit a PCS-installed 
layout theme by adding or removing fields for the layout theme. If you decide you no longer want the 
changes, the installed layout theme can be reverted to the original format.

Complete the following steps to edit a PCS-installed layout theme:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.
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Figure  7-57. Defined Routes

 2. Click the Customize tab to view the Layouts window.

Figure  7-58. Define Routes - Layouts

 3. Select a PCS-installed layout theme from the Select Layout Theme drop-down list. A PCS-installed 

layout theme includes [PCS] in the name of the theme, such as  [PCS] Route Grid.

 4. Click the  for a field category in the left pane to view a list of fields available for selection, such as  
Facility Fields.

 5. Click the check box for each field you want to include in the theme. Then click the  button  to 
move the selected fields to the right pane. You can also double-click a field to move it. To move it 

back to the left pane, click the  button. 
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To rearrange the order of the fields in the left pane, use the  and  buttons. You can also click 
and drag field names to move them.

The theme will include all fields listed in the right pane.

 6. Click  Save to save changes.

 7. To revert an installed theme and restore settings prior to editing, click  Revert, then click Yes in the 
Confirm Revert message.

 8. Click  Save and Close to save changes and return to the Define Routes window.

Add a Layout Theme Addition

Complete the following steps to add a layout theme addition:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.

Figure  7-59. Defined Routes

 2. Click the  Customize tab to view the Layouts window.

routes_list_of_routes.png
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Figure  7-60. Layouts

 3. Click  Add to open the New Layout Theme window.
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Figure  7-61. New Layout Theme

 4. Type a name for the theme in the Enter Theme Name field.

 5. Select the Public check box if you want the new theme available to all PCS users. When a theme is 
not public, it is a private theme available only to the user who creates it.

Creating public themes is a function available only to users assigned the SysAdmin user role. Private 
themes can be created by users assigned the User, Read Only, or SysAdmin user role. Refer to  
System Security on page 962 for more information.

 6. If you want to copy fields from another theme, select the Copy Content check box and then a theme 
from the Copy Fields From Theme drop-down list.
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 7. Click  OK to save changes and return to the Layouts page.

 8. Verify the name of the new layout theme displays in the Select Layout Theme. If not, select the new 
theme from the Select Layout Theme drop-down list.

 9. Add and remove fields in the new layout theme as required. If needed, refer to Edit an Installed Layout 
Theme on page 483. 

 10. To change the order of fields listed in the right pane and subsequently in the grid, use the  and 

 buttons. You can also click and drag a field to a new position in the list. 

 11. Click  Save and Close to save changes and close the window.

 12. To apply the new layout theme in the Define Routes grid, follow these steps:

 a. Click the  Options tab to open the Options window.

 b. Select the layout theme from the  Select Layout Theme drop-down list.

Figure  7-62. Options Drop-down List

 c. Click  Apply to apply changes and return to the grid in Define Routes window. Click  
Cancel to close the Options window without saving changes.

Edit a Layout Theme Addition

A layout theme addition can be edited by adding or removing fields or creating a new baseline layout theme 
addition. The layout theme can also be deleted or reverted to original settings.

Complete the following steps to edit a layout theme addition:
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 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.

Figure  7-63. Defined Routes

 2. Click the  Customize tab to view the Layouts window.

Figure  7-64. Layouts

 3. Select a layout theme that you created from the  Select Layout Theme drop-down list.

 4. Add and remove fields in the layout theme as required. If needed, refer to Edit an Installed Layout 
Theme on page 483. 

 5. Click  Save to save changes.
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 6. To save current settings as new baseline settings, click  New Baseline. When future changes are 
made and then reverted, PCS restores the theme with these baseline settings.

 7. To revert a layout theme addition and restore settings prior to editing, click  Revert, then click Yes 
in the Confirm Revert message window.

 8. To delete a layout theme addition, select a layout theme addition from the Select Layout Theme 
drop-down list and click  Delete. Click Yes in the Confirm Delete message window.

 9. Click  Save and Close to close the Layouts window and return to the Define Routes window.

Work with a Sort Theme

A sort theme is a named set of one or more fields that indicate the sorting order of grid rows in the route grid. 
A sort theme also determines the sorting order when printing a route.

Two types of sort themes are available for use. They include installed and addition sort themes. An installed 
sort theme is one that has been installed during the PCS software installation, such as [PCS] Address, 
[PCS] Facility ID, and [PCS] ROW Code and Milepost. A sort theme addition is one that you create.

Refer to the following topics for more information on how to work with a sort theme:

 l Edit an Installed Sort Theme

 l Add a Sort Theme Addition on page 492

 l Edit a Sort Theme Addition on page 495

Edit an Installed Sort Theme

An installed sort theme includes [PCS] in the name of the theme, such as  [PCS] Facility ID.

You can edit a PCS-installed sort theme by adding or removing field sort the sort theme. If you decide you 
no longer want the changes, the installed sort theme can be reverted to the original format.

Complete the following steps to edit a PCS-installed sort theme:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.
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Figure  7-65. Defined Routes

 2. Click the  Customize tab and then the Sorts tab to open the Sorts window.

Figure  7-66. Sorts

 3. Select a PCS-installed sort theme from the Select Sort Theme drop-down list. A PCS-installed sort 

theme includes [PCS] in the name of the theme, such as [PCS] ROW Code and Milepost.

 4. Click the  for a field category in the left pane to view a list of fields available for selection, such as  
Facility Fields.

 5. Click the check box for each field you want to include in the theme. Then click the  button  to 
move the selected fields to the right pane. You can also double-click a field to move it. To move it 

back to the left pane, click the  button. 
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To rearrange the order of the fields in the left pane, use the  and  buttons. You can also click 
and drag field names to move them.

The theme will include all fields listed in the right pane.

 6. Select a sort method for each field listed in the right pane. To sort grid rows in ascending order, click 

the toggle button to select  . To sort in descending order, click the toggle button to select  

.

 7. Click  Save and Close to save changes and close the Sorts window.

 8. To apply the sort theme in the Define Routes grid, follow these steps:

 a. Click the  Options tab to open the Options window.

 b. Select the sort theme from the  Select Sort Theme drop-down list.

 c. Click  Apply to apply changes and return to the grid in Define Routes.

Clicking  Cancel allows you to close the Options page without saving changes.

Add a Sort Theme Addition

Complete the following steps to add a sort theme addition:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.

Figure  7-67. Defined Routes

 2. Click the Customize tab to view the Sorts window.
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Figure  7-68. Define Routes - Sorts

 3. Click  Add to open the New Sort Theme window.

Figure  7-69. New Sort Theme

 4. Type a name for the theme in the field Enter Theme Name.
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 5. Select the Public check box if you want the new theme available to all PCS users. When a theme is 
not public, it is a private theme available only to the user who creates it.

Creating public themes is a function available only to users assigned the SysAdmin user role. Private 
themes can be created by users assigned the User, Read Only, or SysAdmin user role. Refer to  
System Security on page 962 for more information.

 6. If you want to copy fields from another theme, select the Copy Content check box and then a theme 
from the Copy Fields From Theme drop-down list.

 7. Click  OK to save changes and return to the Sorts window.

 8. Verify the name of the new sort theme displays in the field Select Sort Theme. If not, and select the 
new from the Select Sort Theme in the selection list.

 9. Add and remove fields in the new theme as required. If needed, refer to Edit an Installed Sort Theme 
on page 490.

 10. To change the order of fields listed in the right pane and subsequently in the grid, use the  and 

 buttons. You can also click and drag a field to a new position in the list. 

 11. Select a sorting method for each field listed in the right pane. To sort grid records in ascending order, 

click the toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 12. Click  Save and Close to save changes and close the window.

 13. To apply the sort theme in the Define Routes grid, follow these steps:

 a. Click the  Options tab to open the Options window.

 b. Select the sort theme from the  Select Sort Theme drop-down list.
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Figure  7-70. Options Drop-down List

 c. Click  Apply to apply changes and return to the grid in Define Routes window. Click  
Cancel to close the Options window without saving changes.

Edit a Sort Theme Addition

A sort theme addition can be edited by adding or removing fields. The sort theme can also be deleted or 
reverted to original settings.

Complete the following steps to edit a sort theme addition:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.

Figure  7-71. Define Routes
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 2. Click the  Customize tab and then the Sorts tab to open the Sorts window.

Figure  7-72. Sorts

 3. Select a sort theme that you created from the Select Sort Theme drop-down list.

 4. Add and remove fields in the sort theme as required. If needed, refer to Edit an Installed Sort Theme 
on page 490. 

 5. Click  Save to save changes.

 6. To revert a sort theme addition and restore settings prior to editing, click  Revert, then click Yes in 
the Confirm Revert message window.

 7. To delete a sort theme addition, select a layout theme addition from the Select Layout Theme drop-
down list and click  Delete. Click Yes in the Confirm Delete message window.

 8. Click  Save and Close to close the Sorts window and return to the Define Routes window.

Add, Edit, and Apply an AND or OR Filter Group

The Filters pane consists of a set of pre-defined filters as well as on demand filters grouped together with 
AND or OR joins. A filter group is a named set of one or more filters that affect the data returned. Adding an 
AND filter group produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. PCS processes all filters in AND filter groups 
together then processes all filters in OR filter groups together. 

An AND filter group is a named set of one or more filters that affect the data output in a route selected in 
Define Routes. Adding an AND filter group produces a subset of records that meet all filter conditions. PCS 
processes filters in a filter group in descending order beginning with the filter at the top of the filter group.
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An OR filter group is a named set of one or more filters that affect the data output of a route selected in 
Define Routes. Adding an OR filter group produces a subset of records that meet any filter condition. PCS 
processes filters in a filter group in descending order beginning with the filter at the top of the filter group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to add and/or edit an AND or an OR filter group and then apply the filter for 
use in the Define Routes window:

 1. Click Data Entry > Define Routes to open the Define Routes window.

 2. Select a route from the Routes drop-down list.

 3. Click the Customize tab and then the Filters tab to open the Filters window.

Figure  7-73. Filters Window

 4. To create a new And group, click New 'And' Group  to open the filter properties group box.         

Figure  7-74. And Group Filters 
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 5. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  7-75. Or Group Filters 

 6. Type a name for the filter group in the Filter Group Caption field. 

 7. Select the Filter Is Always On option to keep the filter on.

 8. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 a. When adding a date filter, set a date range using a calendar or dynamic dates in one of the 
following ways:       

 l Type a date in the start and end date fields. Enter a start and end date using the format 
M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.         

 l To set a date range using dynamic start and end dates, click the  calculator icon in the 
start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields. 

 b. Type a name for the filter in the Enter Custom Filter Caption field. 

 c. If additional filters are needed within the filter group, click  and repeat these steps.       

 9. If necessary, click the  edit icon for a filter to open that filter's property settings and change 
settings as needed. 

 10. Click  Save to save the filter group.         

 11. Click  Save and Close when finished saving all filter groups. 

 12. To apply one or more filters to the selected route in the Define Routes grid, click the Options tab  to 
open the Options window.
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Figure  7-76. Define Routes Options Window

 13. In the Filters pane, click the check box for each filter you want to apply. The filters that were created 
with the Filter Is Always On option will be automatically selected.

 14. Click  Apply to save changes and return to the data entry grid.

Edit and Arrange Filters and Filter Groups

PCS processes filters in a filter group in descending order beginning with the filter at the top of the filter 
group. Filter groups are processed similarly. Information in this section explains how to edit filter property 
settings and how to arrange filters and filter groups.

Complete the following steps to edit and arrange filters and filter groups:

 2. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.
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Figure  7-77. Defined Routes

 3. Click the Customize tab and then the  Filters tab to open the Filters window.

Figure  7-78. Filters Window

 4. Click the edit icon  to display a filter's property settings.
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Figure  7-79. Filter Group's Settings

 5. To rename a filter, type a description in the filter's name field.

 6. To change filter criteria, use filter selection fields to select a PCS field, operator, and one or more filter 
conditions.

 7. To enable a filter for all sessions of the data entry grid, click the check box Filter is Always On to place 
a check mark inside the check box. When this check box is not selected, toggle the filter on and off in 
the options page using the filter's check box.

 8. To delete a filter in a filter group, click the filter's  delete icon. Then click  OK in the Delete 
message window.

 9. Click  Save to save changes or  Save and Close to save changes and close the Filters window.

 10. To apply filter changes to the selected route and the Define Routes grid, click Options tab to open the 

Options window and select (or de-select) any filter you wish to use. Click  Apply to save changes 
and return to the Define Routes grid.
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Figure  7-80. Select Filters for Use

Print, Export, or Email a Route
You can view, print, and export a route with selected or available facilities.

Selected facilities are those included in the route. These facilities are also listed in the Facilities in Route grid 
of the Define Routes window. 

Available facilities are linked to the current ROW selection, but are not included in the route. Available 
facilities are listed in the Facilities Available grid of the Define Routes window.

Complete the following steps to preview, print, export, or send via email a route:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.
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Figure  7-81. Define Routes Window

 2. Selected the facilities you wish to preview from the Facilities Available grid.

Figure  7-82. Facilities Available Grid

 3. Click  Available Facilities. A Print Preview window opens.
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Figure  7-83. Print Preview

 4. To print the report using the default Windows printer, click  Quick Print.

 5. To open a print window and select a printer to print the report, click Print.

 6. To export the report in a file format:

 a. Click the down arrow in  Export Document and select a file format in the selection list. You 

can also just click the  icon to open the Export Document window where you can select the 
file type from the Export format drop-down list (see below).

 b. In the Export Document window, if desired, select the file type from the Export format drop-
down list. Click the ellipsis button to select a file path. Click More Options to see options 
associated with the file type selected. When finished, click OK.
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Figure  7-84. Export Document Window

 7. To send the report as an attachment in an email:

 a. Click the down arrow in  Send and select a file format in the selection list. You can also just 

click the  icon to open the Send via E-Mail window where you can select the file type from 
the Export format drop-down list (see below).

Figure  7-85. Send Via Email Window

 b. Select a file format from the Export format drop-down list. Click the ellipsis button to select a 
file path. Click More Options to see options associated with the file type selected. When 
finished, click OK

 c. When an email message opens with the report as an attachment, select an email recipient and 
then click Send.

 8. If you want to export the route, click the  Export Document button and select any of the following 
file formats: PDF, HTML, MHT, RTF, XLS, XLSX, CSV, TXT, IMG, and XPS.

 9. Click  to close the print preview window and return to the data entry grid.
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Export and Import a Route
The following information explains how to import or export a defined route in either Microsoft Excel (.xls) or 
CSV (.csv) format. Facilities for inspection are based on the pipeline segment(s) you select in the Select 
ROWs window.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to export and import a route:

 1. Click Data Entry > Define Routes to open the Define Routes window. Select a route from the Routes 
drop-down list.

Figure  7-86. Define Routes

If you have not defined any routes, refer to Create a Route for instructions on creating a route.

 2. To add a facility to the Facilities in Route grid, double-click the name of the facility in the Facilities 
Available grid.

 3. Click  Save to save the changes.

 4. To export the route, click  Export.

 5. Click Yes in the Confirm Export window.
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Figure  7-87. Confirm Export Window

 a. Choose an export file type. Click the down arrow in the Save as type field and select one of the 
following file types:

 l Excel files (*.xlsx)

 l Text files (*.csv)

 6. When the file has been created, the Info window displays. Click OK.

Figure  7-88. Export File Created

 7. To import a saved file, select a route from the Routes drop-down list. This route will be replaced by 

the route to be imported. Click  Import.

 8. Navigate to the file and click Open. The file is loaded in the Facilities in a Route grid, and replaces the 
route previously shown.

Use a Route in PCS
You can use a route in PCS to perform any of the following tasks:

 l View inspection records in a grid based on a route. Refer to View Records Based on a Schedule on 
page 293.
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 l Transfer a survey to a field computer or mobile device   based on a route. Refer to Field Computer on 
page 677.
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Chapter 8: Schedules
A schedule is a group of facilities to be surveyed for a specific time period, such as a month or year. The 
same schedule can include multiple facility types as well as facilities requiring bi-monthly, annual, and multi-
year inspections, if those inspections are due in the same year. You can set up some schedules to include 
every facility that may be due for inspection and others to include one type of facility or survey period. PCS 
dynamically generates a schedule with the most current information.

A schedule is different from a route. A schedule is a list of facilities that are due to be inspected, whereas a 
route assigns a specific order to facility inspections.  A schedule is always ordered by due date and then as 
an option, sorted by facility ID, address, or route order. If you plan to create a schedule in route order, routes 
must be defined first (Data Entry > Define Routes).

Scheduling allows you to create a blank survey form based on a schedule for data collection that includes 
prompts only for scheduled facilities. You can also transfer a survey based on a schedule to the field 
computer. Survey data is then transferred from the PCS field computer or other mobile device or entered in 
PCS from the survey form.

A valuable feature of scheduling is the ability to transfer a survey based on a schedule to the  field computer 
or other mobile device. Once the survey is complete, the PCS database is easily updated by transferring 
inspection data from the mobile device to PCS.

Most PCS users can work with schedules.

NOTE: Scheduling properties set up in the Time Between Surveys tab will be applied system-wide. 
However, settings can be overridden at the facility type level in the Facility Level Override mini-grid of the 
Information grid for a module's data entry grid, in the ROW hierarchy pane of the Hierarchy Level Overrides 
tab, or in the Schedule Type Settings tab.  The settings made in the Facility Level Override mini-grid of the 
Information grid for a module's data entry grid override the other two. Therefore, it is not recommended to 
make changes at the facility level.

This chapter  includes the following topics:

 l Schedule Workflow

 l Set Up Scheduling Criteria on page 511

 l Create a Schedule on page 534

 l Work with a Schedule Definition on page 540

 l Use a Schedule in PCS on page 546
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Schedule Workflow
The process for working with a schedule includes the following tasks:

Figure  8-1. Scheduling Workflow Diagram

 l Set up scheduling properties in the Edit Schedule Settings window (Data Entry > Edit Schedule 
Settings). Scheduling properties define the parameters PCS uses to calculate facility inspection due 
dates.

 l Create a schedule definition with one or more schedule types in the Define Schedules window (Data 
Entry > Define Schedules). A schedule type identifies which facility types to include in the schedule, 
and as an option, to include all facility types on a ROW that are due for an inspection.

 l Use a schedule to view facility records in a data grid based on a schedule, transfer a survey based on 
a schedule to the  field computer or mobile device, and view and print a data collection form based on 
a schedule.
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Set Up Scheduling Criteria
Setting up scheduling criteria begins with setting properties in the Time Between Survey Settings tab of the 
Edit Schedule Settings window. Settings are applied system-wide but can be overridden based on your 
company's survey policy. You can set up scheduling overrides by facility type, at the hierarchy level, or at 
the facility level.

Refer to the following topics for information on how to set up scheduling properties using the three tabs in 
the Edit Schedule Settings window:

 l Time Between Survey Settings

 l Schedule Type Settings on page 516

 l Hierarchy Level Overrides on page 527

Settings that are used in the Edit Schedule Settings window may include a different style or format to help 
identify a property:

 l A setting in bold text indicates an override. 

 l A setting inside parentheses indicates a baseline setting. 

 l A setting with N/A (not applicable) indicates the setting does not apply to the scheduling property.

Time Between Survey Settings

Time Between Survey Settings tab of the Edit Schedule Settings window allows you to set up scheduling 
properties for a survey, such as an annual, periodic, 5-year, or 10-year survey. Setting up survey scheduling 
properties includes identifying the survey start month and year, the grace period, the delinquent time 
period, and the number of inspections required in a calendar year.

PCS provides baseline settings based on government compliance regulations and industry standards. 
Baseline settings can be changed so that they match your company's survey policy.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to set up survey scheduling properties:
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 1. Click Data Entry > Edit Schedule Settings and then the Time Between Survey Settings tab.

Figure  8-2. Time Between Survey Settings Tab

 2. Refer to the following table for descriptions of survey property settings and how to set up each of 
these.
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Property 
Name

Property Description

Time 
Between 
Survey

A list of surveys indicating the number of months or years between inspections. These fields 
cannot be changed.

An  or   icon displays beside the survey indicating a selection.

Target 
Month

Target Month is only used when Targets is selected as the scheduling method. Otherwise, 
property settings are ignored and do not need to be set up.

Target Month refers to the first survey month. Options in the selection list are based on the 
Time Between Survey value.

For example, if Time Between Surveys is 2 months and the Target Month (first survey 
month) is January, surveys are set at 2 month intervals beginning in January. The next 
survey is due in March, the next in May, and so on.

To select a target month:

 1. For a survey listed in Time Between Surveys, click the Target Month field to display a 
drop-down arrow.

 2. Click the down arrow and select a target month in the selection list.

Figure  8-3. Target Month Drop-down List

Table 8-12.  Setting Up Time Between Survey Settings       
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Property 
Name

Property Description

Target 
Year

Target Year is only used when Targets is selected as the scheduling method. Otherwise, 
property settings are ignored and do not need to be set up.

Target Year is the year within the survey period when you want the first survey to take place. 
This field is only used for facilities with more than 12 months between surveys. PCS 
calculates Target Year based on the current year and values in the fields Time Between 
Surveys and Multi-Year Survey Start.

The target year selection list includes a list of valid survey years with corresponding target 
year dates.

To select a target year:

 1. For a survey listed in Time Between Surveys, click the Target Year field to display a 
drop down arrow.

 2. Click the down arrow and select a target survey year.

Figure  8-4. Target Year Drop-down List

If an appropriate survey year is not listed, type a different year in the Multi-Year 
Survey Start field to update items in the selection list.

Table 8-12.  Setting Up Time Between Survey Settings        cont'd
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Property 
Name

Property Description

Grace 
Period 
and Grace 
Period 
Unit

A period of time in days or months an inspection can be late without incurring a compliance 
violation.

To set a grace period:

 1. Enter a value in the Grace Period field.

 2. Select the Grace Period Unit field. Click the down arrow and select either Days or 
Months in the selection list.

Figure  8-5. Grace Period Unit Drop-down List

Early 
Survey 
Limit Days

Early Survey Limit Days is only used when Targets is selected as the scheduling method. 
When the selected scheduling method is Last Survey or X years / Y%, PCS displays N/A 
(not applicable) indicating Early Survey Limit Days does not apply.

Early Survey Limit Days refers to how early an inspection can occur before the actual due 
date and still count as an inspection for that survey period.

To set the number of days an inspection can occur before the actual due date, enter a value 
in the Early Survey Limit Days field.

Include 
Delinquen
t Within 
Days

If a facility inspection will become delinquent within a number of days, include the facility in 
the schedule with those due for inspection. For example, if a facility inspection is delinquent 
in 5 days, include that facility in the schedule with others due for inspection.

To set a delinquent time period in days, enter a value in the Include Delinquent Within Days 
field.

Table 8-12.  Setting Up Time Between Survey Settings        cont'd
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Property 
Name

Property Description

Required 
Inspectio
ns Per 
Calendar 
Year

Number of required inspections per calendar year. To set the number of required 
inspections, enter a value in the Required Inspections Per Calendar Year field.

Multi-Year 
Survey 
Start

Refers to the year a multi-year survey starts (starting point). PCS uses the starting year to 
calculate future survey dates available for selection in the Target Year selection list.

To set a starting year for a multi-year survey, enter  a year in the Multi-Year Survey Start field.

Minimum 
Percent 
Schedule
d

Refers to a minimum percentage of facilities that must be inspected. This setting works in 
conjunction with the due date calculation method X years/Y% selected in the Schedule 
Type Settings tab.

To set a minimum percentage of facilities that must be inspected, enter a value in the 
Minimum Percent Scheduled field. The field supports decimal formatting, such as 30.75.

Table 8-12.  Setting Up Time Between Survey Settings        cont'd

Schedule Type Settings

Scheduling properties set up in the Schedule Type Settings tab of the Edit Schedule Settings window apply 
at the facility type level. Some scheduling properties inherit settings from those previously set up in the Time 
Between Survey Settings tab. Inherited settings changed at the facility type level override and have 
precedent over those in the Time Between Survey Settings tab.

Complete the following steps to set up scheduling properties at the facility type level:
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 1. Click Data Entry > Edit Schedule Settings and then the  Schedule Type Settings tab.

Figure  8-6. Schedule Type Settings Tab

 2. Select the facility type you want to work with:

 l To select a facility type theme, select a theme from the Facility Types drop-down list.

 l To select multiple facility types, click the Ad Hoc Theme radio button and then select one or 
more facility types, such as Test Point, Rectifier, or Foreign Bond.

An Ad Hoc Theme only applies  to the current session and is not saved. A facility type is 
selected when a check mark appears inside the check box. To clear the check mark, click the 
check box again.

 3. Refer to the following table for a description of facility type scheduling properties and how to set up 
each of these.

Certain property names in the following table include an asterisk *). The asterisk identifies scheduling 
properties you can set at the facility type level that will override and take precedent over those in the 
Time Between Survey Settings tab.
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Property 
Name

Property Description

Selected Include or exclude schedule settings at the facility type level when generating a schedule 
with facilities due for inspection.

To include or exclude schedule settings, click Selected to display a drop down arrow and 
select one of the following options from the drop-down list:

 l No: Excludes schedule settings when generating a schedule.

 l Yes: Includes schedule settings when generating a schedule.

 l Auto Select: If an Auto Select Expression has previously been created, select to 
include the expression with other schedule settings when generating a schedule.

Refer to Auto Select Expression (below) for information about how to create an 
expression.

Table 8-13.  Schedule Type Settings       
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Property 
Name

Property Description

Scheduli
ng Type 
Name

A named set of schedule settings for a facility type, such as Periodic Rectifier or Annual 
Rectifier.

To add a new scheduling type:

 1. Select a Facility Types theme or set up an Ad Hoc Theme with a facility type you want 
to add a new scheduling type.

 2. Click Add to open the Add Schedule Type window.

Figure  8-7. Add Schedule Type Window

 3. Enter a name for the new scheduling type in the  Scheduling Type Name field.

 4. Set up schedule settings as required.

 5. Click  Save to save the schedule.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

Auto 
Select 
Expressi
on

A database query set up for a scheduling type that defines the criteria for including specific 
facilities in a survey schedule. The expression is a combination of an operator, PCS field, 
condition, and user-selected criteria.

To create an expression for a scheduling type:

 1. In the Auto Select Expression column, click Create Expression to display an ellipsis 
button (…). Click the button to open the Auto Select Expression window.

 2. Select an expression operator by selecting either New 'And' Group or New 'Or' 
Group.

 3. Type a name for the expression in the Filter Group Caption field. 

Figure  8-8. Auto Select Expression - New And Group

 4. Set up expression fields. 

To set up a field, click the down arrow and select a PCS field. Click the down arrow 
and select a condition, such as Is equal to or Is missing, and type a criteria in the last 
expression field if the field is present. This field is present based on selections in the 
previous two expression fields.

 5. Click  icon to add additional fields.

 6. Click Save.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

Schedul-
ing Pri-
ority

Facilities due for inspection are scheduled for survey at the facility type level based on the 
priority level of the scheduling type. Priority level is any value from 1 to 99 with 1 being the 
highest priority. To set a priority level at the facility type level for a scheduling type:

 1. Verify Yes is set for the  Only Highest Priority Due Is Scheduled scheduling property.

 2. Enter a value for Scheduling Priority using any number from 1 to 99.

A priority level set at the facility type level can be overridden at the ROW level in the Hierarchy 
Level Overrides tab.

Due Date 
Calculati
on 
Method

Facilities due for inspection are scheduled for survey at the facility type level based on the 
due date calculation method of the scheduling type.

To set a due date calculation method for a scheduling type, click the field under Due Date 
Calculation Method column in a row to display a drop-down arrow and select one of the 
following options:

Figure  8-9. Due Date Calculation Method Drop-down List

 l Targets: Facilities due for inspection are scheduled for survey based on the Last 
Inspection Date, Target Month and Target Year.

 l Last Survey: Facilities due for inspection are scheduled for survey based on the Last 
Inspection Date and setting for the  Time Between Surveys scheduling property.

 l X years/Y%: Facilities due for inspection are scheduled for survey based on the Last 
Inspection Date and settings for the Time Between Surveys. Multi-Year Survey Start, 
and Minimum Percent Scheduled scheduling properties.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

Only 
Highest 
Priority 
Due Is 
Schedule
d

If the scheduling type is set up with a Scheduling Priority level, include only those facilities 
with the highest priority level that are due for inspection in the survey schedule.

For a scheduling type listed in the Scheduling Type Name column, click the  Only Highest 
Priority Due Is Scheduledfield to display a drop-down arrow.

Click the down arrow and select one of the following options:

Figure  8-10. Only Highest Priority Due Is Schedule Drop-down List

 l Yes: Only those facilities due for inspection with the highest priority level are 
scheduled for survey.

 l No: Any facility due for inspection is scheduled for survey.

Percent 
Needed 
to 
Complete 
Survey

A value from 0 to 100 indicating the percentage of facilities that must be surveyed before the 
survey (annual or multi-year) is considered complete.

To set a percentage:

 l Enter a value in the Percent Needed To Complete Survey field for a scheduling type 
listed in Scheduling Type Name.

Table 8-13.  Schedule Type Settings        cont'd



PCS v2.5 User Guide

Chapter 8: Schedules 523

Property 
Name

Property Description

*Time 
Between 
Surveys

Number of months or years between inspections.

To set the time between surveys:

 1. For a scheduling type listed in Scheduling Type Name, click the Time Between 
Surveys field to display a drop down arrow.

Figure  8-11. Time Between Surveys Drop-down List

 2. Click the down arrow and select the number of months or years from the selection 
list.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

*Target 
Month

Used only when Targets is selected as the scheduling method. Refers to the first survey 
month. Options in the selection list are based on the Time Between Survey value.

As an example, if Time Between Surveys is 2 months and the Target Month (first survey 
month) is January, surveys are set at 2 month intervals beginning in January. The next 
survey is due in March, the next in May, and so on.

To set the target month:

 1. For a scheduling type listed in Scheduling Type Name, click the Target Month field to 
display a drop down arrow.

Figure  8-12. Target Month Drop-down List

 2. Click the down arrow and select a month in the selection list.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

*Target 
Year

Used only when Targets is selected as the scheduling method. Refers to the first survey year 
when Time Between Surveys is more than 12 months.

To set the target year:

 1. For a scheduling type listed in Scheduling Type Name, click the  Target Year field to 
display a drop down arrow.

Figure  8-13. Target Year Drop-down List

 2. Click the down arrow and select a year in the selection list.

*Grace 
Period 
and  
*Grace 
Period 
Unit

Refers to a period of time in days or months an inspection can be late without incurring a 
compliance violation.

To set a grace period for a scheduling type listed in Scheduling Type Name:

 1. Click the Grace Period Unit field to display a drop-down arrow. 

Figure  8-14. Grace Period Drop-down List

 2. Click the drop-down arrow and select either Days or Months in the selection list.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

*Early 
Survey 
Limit 
Days

Refers to how early an inspection can occur before the actual due date and still count as an 
inspection for the survey period.

To set an early survey limit for a scheduling type listed in Scheduling Type Name:

 l Type the number of days in the Early Survey Limit Days field.

*Include 
Delinque
nt Within 
Days

If an inspection will become delinquent within a number of days, include the facility in the 
schedule with facilities due for inspection.

To set a delinquent time period in days for a scheduling type listed in Scheduling Type 
Name:

 l Type the number of days in the Include Delinquent Within Days field.

*
Required 
Inspectio
ns Per 
Calendar 
Year

Number of required inspections per calendar year.

To set the number of required inspections for a scheduling type listed in Scheduling Type 
Name:

 l Type a value in the  Required Inspections Per Calendar Year field.

*Multi-
Year 
Survey 
Start

Refers to the year a multi-year survey starts. PCS uses the starting year to calculate future 
survey dates available for selection in the Target Year selection list. 

To set the starting year of a multi-year survey for a scheduling type listed in Scheduling Type 
Name:

 l Type a year in the Multi-Year Survey Start field.

*
Minimum 
Percent 
Schedule
d

Refers to a minimum percentage of facilities that must be inspected in a multi-year survey. 
This setting works in conjunction with the X years/Y% due date calculation method .

To set a minimum percentage of facilities that must be inspected for a scheduling type listed 
in Scheduling Type Name:

 l Type a value in the  Minimum Percent Scheduled field. The field supports decimal 
formatting, such as 30.75.

Table 8-13.  Schedule Type Settings        cont'd
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Property 
Name

Property Description

*Survey 
Season 
Start 
Month

Refers to the starting month in the survey season for a multi-year survey.

To set the starting month in the survey season for a scheduling type listed in Scheduling 
Type Name:

 1. Click the  Survey Season Start Month field to display a drop down arrow.

 2. Click the drop down arrow and select a starting month in the selection list.

*Survey 
Season 
End 
Month

Refers to the ending month in the survey season for a multi-year survey.

To set the ending month in the survey season for a scheduling type listed in Scheduling 
Type Name:

 1. Click the Survey Season End Month  field to display a drop down arrow.

 2. Click the drop down arrow and select an ending month in the selection list.

Level 
Work 
Load

Refers to PCS balancing the work load for facilities that are due for inspection in a multi-year 
survey. The property setting applies at the facility type level.

To enable this scheduling option, click the  Level Work Load check box for a scheduling type 
listed in Scheduling Type Name.

To disable the option, clear the check mark by clicking the check box again.

Hide Refers to hiding a scheduling type in the Facility Level Override mini-grid of the data entry 
grid. Hiding the mini-grid prevents scheduling changes at the facility level when working with 
the data entry grid based on a schedule.

To enable this scheduling option, click the Hide check box for a scheduling type listed in 
Scheduling Type Name.

To disable the option, clear the check mark by clicking the check box again.

Table 8-13.  Schedule Type Settings        cont'd

Hierarchy Level Overrides

Scheduling properties set up in the Hierarchy Level Overrides tab of the Edit Schedule Settings window 
apply at the ROW (pipeline) level. Some scheduling properties inherit settings from those previously set up 
in the Time Between Survey Settings tab and ROW and Facility Settings. Inherited settings changed at the 
ROW level override and have precedent over those in the Time Between Survey Settings tab and ROW and 
Facility Settings.

Complete the following steps to set up scheduling properties at the ROW level:
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 1. Click Data Entry > Edit Schedule Settings and then the Hierarchy Level Overrides tab.

Figure  8-15. Hierarchy Level Overrides

 2. Select the facility type you want to work with:

 l To select a facility type theme, select a theme from the Facility Types drop-down list.

 l To select multiple facility types, click the Ad Hoc Theme radio button and then select one or 
more facility types, such as Test Point, Rectifier, or Foreign Bond.

An Ad Hoc Theme only applies  to the current session and is not saved. A facility type is 
selected when a check mark appears inside the check box. To clear the check mark, click the 
check box again.

 3. Select the ROW(s) you want to work with by clicking the check box for each ROW in the middle pane 
of the Hierarchy Level Overrides tab.
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Figure  8-16. ROW Selection(s)

 4. Refer to the following table for a description of scheduling properties that apply at the ROW level and 
how to set up each of these.

Certain property names in the following table include an asterisk (*). The asterisk identifies scheduling 
properties you can set at the ROW level that will override and take precedent over those in ROW and 
Facility Settings and Time Between Survey Settings tab.
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Property 
Name

Property Description

Selected Include or exclude schedule settings at the ROW level when generating a schedule with 
facilities due for inspection.

To include or exclude schedule settings, click Selected to display a drop-down arrow and 
select one of the following options in the drop-down list:

Figure  8-17. Selected Drop-down List

 l No: Excludes schedule settings when generating a schedule.

 l Yes: Includes schedule settings when generating a schedule.

 l Auto Select: If an Auto Select Expression has previously been created in the 
Schedule Type Settings tab, select to include the expression with other schedule 
settings when generating a schedule.

For information about how to create an expression, refer to Schedule Type Settings. 

Scheduling 
Type 
Name

A named set of schedule settings for a facility type created in the Schedule Type Settings 
tab.

For information about how to create a Scheduling Type Name, refer to Schedule Type 
Settings. 

Due Date 
Calculation 
Method

Shows the property setting inherited from Due Date Calculation Method column in the 
Schedule Type Settings tab.

Table 8-14.  Hierarchy Level Overrides       
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Property 
Name

Property Description

*Time 
Between 
Surveys

Number of months or years between inspections.

To set the time between surveys:

 1. For a scheduling type listed in Scheduling Type Name, click the Time Between 
Surveys field to display a drop-down arrow.

 2. Click the down arrow and select the number of months or years in the selection list.

Figure  8-18. Time Between Surveys Unit Drop-down List

Table 8-14.  Hierarchy Level Overrides        cont'd
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Property 
Name

Property Description

*Target 
Month

Refers to the first survey month. Options in the selection list are based on the Time 
Between Survey value.

As an example, if Time Between Surveys is 2 months, and the Target Month (first survey 
month) is January, surveys are set at 2-month intervals beginning in January. The next 
survey is due in March, the next in May, and so on.

To set the target month:

 1. For a scheduling type listed in Scheduling Type Name, click the Target Monthfield to 
display a drop-down arrow.

 2. Click the down arrow, and select a month in the selection list.

Figure  8-19. Target Month Drop-down List

Table 8-14.  Hierarchy Level Overrides        cont'd
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Property 
Name

Property Description

*Target 
Year

Refers to the first survey year when Time Between Surveys is more than 12 months.

To set the target year:

 1. For a scheduling type listed in Scheduling Type Name, click the Target Yearfield to 
display a drop down arrow.

 2. Click the down arrow and select a year in the selection list.

Figure  8-20. Target Year Drop-down List

Table 8-14.  Hierarchy Level Overrides        cont'd
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Property 
Name

Property Description

*Grace 
Period / 
*Grace 
Period Unit

Refers to a period of time in days or months an inspection can be late without incurring a 
compliance violation.

To set a grace period for a scheduling type listed in Scheduling Type Name:

 1. Type a value in the Grace Period field.

 2. Click the Grace Period Unit field to display a drop down arrow. Click the drop-down 
arrow and select either Days or Months in the selection list.

Figure  8-21. Grace Period Unit Drop-down List

*Early 
Survey 
Limit Days

Refers to how early an inspection can occur before the actual due date and still count as 
an inspection for the survey period.

To set an early survey limit for a scheduling type listed in Scheduling Type Name, enter the 
number of days in the Early Survey Limit Days field.

Table 8-14.  Hierarchy Level Overrides        cont'd

Create a Schedule
Schedules can be created based on a scheduling method. Scheduling methods include Targets, Last 
Survey, and X years/Y%. The scheduling method in conjunction with other schedule settings determines 
when facilities are due for inspection.

Refer to the following topics for information on how to create a schedule based on a scheduling method:
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 l Create a Schedule Based on Targets

 l Create a Schedule Based on Last Survey on page 536

 l Create a Schedule Based on X years/Y% on page 538

Create a Schedule Based on Targets

If you want to schedule facilities for survey using a recurring time period, such as every January of each 
year, create a schedule based on the Targets scheduling method. With this method, facilities due for 
inspection are scheduled for survey based on the Last Inspection Date, Target Month, and Target Year.

Complete the following steps to create a schedule based on the Targets scheduling method:

 1. Click Data Entry > Edit Schedule Settings and then the Time Between Survey Settings tab.

Figure  8-22. Time Between Survey Settings Tab

 2. Set up all related scheduling properties for a survey selected in the Time Between Surveys tab. 
Scheduling properties marked with N/A (not applicable) are not required, such as Target Year for a 
survey with Time Between Surveys of 12 months or less. If needed, refer to Time Between Survey 
Settings for field descriptions.

Scheduling properties set up in the Time Between Surveys tab will be applied system-wide. 
However, settings can be overridden at the facility type level in the Facility Level Override mini-grid of 
the Information grid for a module's data entry grid, in the ROW hierarchy pane of the Hierarchy Level 
Overrides tab, or in the Schedule Type Settings tab.  The settings made in the Facility Level Override 
mini-grid of the Information grid for a module's data entry grid override the other two. Therefore, it is 
not recommended to make changes at the facility level.

 3. To select the Targets due date method:
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 a. Click the Schedule Type Settings tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. For a scheduling type listed in Scheduling Type Name, click the field Due Date Calculation 
Method to display a drop down arrow. Click the arrow and select Targets in the selection list.

 d. Set up remaining scheduling properties as required. Scheduling properties inherit values from 
those in the Time Between Survey Settings tab and can be overridden at the facility type level 
as needed. Property settings marked N/A (not applicable) are not required. Refer to Schedule 
Type Settings for field descriptions.

 4. If you want to override one or more scheduling properties at the ROW level, complete the following 
steps:

 a. Click the Hierarchy Level Overrides tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. Select the ROW(s) you want to set up a survey schedule. Select one or more ROWs (pipeline 
segments) listed in the middle pane of the window.

 d. For a scheduling type listed in Scheduling Type Name, set up scheduling properties as 
required. Scheduling properties inherit values from those in the Schedule Type Settings tab 
and can be overridden at the ROW level as needed. Refer to Hierarchy Level Overrides for field 
descriptions.

The schedule is now set up with the Targets scheduling method.

Create a Schedule Based on Last Survey

If you want to schedule facilities for survey based on the last time facilities were inspected, create a 
schedule based on the Last Survey scheduling method. With this method, facilities due for inspection are 
scheduled for survey based on Last Inspection Date and settings for the  Time Between Surveys scheduling 
property.

Complete the following steps to create a schedule based on the Last Survey scheduling method:
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 1. Click Data Entry > Edit Schedule Settings and then the Time Between Survey Settings tab.

Figure  8-23. Time Between Survey Settings Tab

 2. Set up all related scheduling properties for a survey selected in the Time Between Surveys tab. 
Scheduling properties marked with N/A (not applicable) are not required, such as Target Year for a 
survey with Time Between Surveys of 12 months or less. If needed, refer to Time Between Survey 
Settings for field descriptions.

Scheduling properties set up in the Time Between Surveys tab will be applied system-wide. 
However, settings can be overridden at the facility type level in the Facility Level Override mini-grid of 
the Information grid for a module's data entry grid, in the ROW hierarchy pane of the Hierarchy Level 
Overrides tab, or in the Schedule Type Settings tab.  The settings made in the Facility Level Override 
mini-grid of the Information grid for a module's data entry grid override the other two. Therefore, it is 
not recommended to make changes at the facility level.

 3. To select the Last Survey due date method:

 a. Click the Schedule Type Settings tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. For a scheduling type listed in Scheduling Type Name, click the Due Date Calculation Method 
field to display a drop down arrow. Click the arrow and select Last Survey in the selection list.

 d. Set up remaining scheduling properties as required. Scheduling properties inherit values from 
those in the Time Between Survey Settings tab and can be overridden at the facility type level 
as needed. Property settings marked N/A (not applicable) are not required. Refer to Schedule 
Type Settings for field descriptions.
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 4. If you want to override one or more scheduling properties at the ROW level, complete the following 
steps:

 a. Click the Hierarchy Level Overrides tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. Select the ROW(s) you want to set up a survey schedule. Select one or more ROWs (pipeline 
segments) listed in the middle pane of the window.

 d. For a scheduling type listed in Scheduling Type Name, set up scheduling properties as 
required. Scheduling properties inherit values from those in the Schedule Type Settings tab 
and can be overridden at the ROW level as needed. Refer to Hierarchy Level Overrides for field 
descriptions.

The schedule is now set up with the Last Survey scheduling method.

Create a Schedule Based on X years/Y%

If facilities require inspection based on a multi-year cycle, use the X years/Y% scheduling method. With this 
method, facilities due for inspection are scheduled for survey based on the Last Inspection Date and 
settings for the scheduling properties Time Between Surveys, Multi-Year Survey Start, and Minimum 
Percent Scheduled.

Compete the following steps to create a schedule for a multi-year survey based on the X years/Y% method:

 1. Click Data Entry > Edit Schedule Settings and then the Time Between Survey Settings tab.

Figure  8-24. Time Between Survey Settings Tab
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 2. Set up all related scheduling properties for a survey selected in the Time Between Surveys tab. 
Scheduling properties marked with N/A (not applicable) are not required, such as Required 
Inspections Per Calendar Year for a survey with Time Between Surveys of 2 years or more. If needed, 
refer to Time Between Survey Settingsfor field descriptions.

Scheduling properties set up in the Time Between Surveys tab will be applied system-wide. 
However, settings can be overridden at the facility type level in the Facility Level Override mini-grid of 
the Information grid for a module's data entry grid, in the ROW hierarchy pane of the Hierarchy Level 
Overrides tab, or in the Schedule Type Settings tab.  The settings made in the Facility Level Override 
mini-grid of the Information grid for a module's data entry grid override the other two. Therefore, it is 
not recommended to make changes at the facility level.

 3. To select the X years/Y% due date method:

 a. Click the Schedule Type Settings tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. For a scheduling type listed in Scheduling Type Name, click the Due Date Calculation Method 
field to display a drop down arrow. Click the arrow and select X years/Y% in the selection list.

 d. Set up remaining scheduling properties as required. Scheduling properties inherit values from 
those in the Time Between Survey Settings tab and can be overridden at the facility type level 
as needed. Property settings marked N/A (not applicable) are not required. Refer toSchedule 
Type Settings for field descriptions.

 4. If you want to override one or more scheduling properties at the ROW level, complete the following 
steps:

 a. Click the Hierarchy Level Overrides tab.

 b. Select one or more facility types in the Facility Types pane using either an installed facility type 
theme or an Ad Hoc Theme.

 c. Select the ROW(s) you want to set up a survey schedule. Select one or more ROWs (pipeline 
segments) listed in the middle pane of the window.

 d. For a scheduling type listed in Scheduling Type Name, set up scheduling properties as 
required. Scheduling properties inherit values from those in the Schedule Type Settings tab 
and can be overridden at the ROW level as needed. Refer to Hierarchy Level Overrides for field 
descriptions.

The schedule is now set up with the X years/Y% scheduling method.
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Work with a Schedule Definition
A schedule definition is a named set of one or more scheduling types to be included in a schedule. For 
example, a schedule definition can include test point, rectifier, and bond scheduling types – each with 
different scheduling properties set up in the Edit Schedule Settings window. 

Refer to Schedule Type Settings on page 516 for a description of fields.

A schedule definition is used when performing any of the following tasks in PCS:

 l viewing facilities in a data entry grid based on a schedule

 l building a survey in a data entry grid based on a schedule

 l transferring a survey that is based on a schedule to the field computer or mobile device

 l printing a data collection form that is based on a schedule for manually recording survey data

Two types of schedule definitions are available for use. They include installed and addition schedule 
definitions. An installed schedule definition is one that has been installed during the PCS software 
installation. An addition schedule definition is one that you create.

Refer to the following topics for information on how to work with a schedule definition:

 l Edit an Installed Schedule Definition

 l Add a Schedule Definition Addition on page 542

 l Edit a Schedule Definition Addition on page 545

Edit an Installed Schedule Definition

An installed schedule definition includes [PCS] in the title of the schedule definition name, such as [PCS] 
Installed Schedule Definition.

The procedure in this section explains how to complete the following tasks to edit an installed schedule 
definition:

 l add a schedule type

 l remove a schedule type

 l revert an installed schedule definition

Complete the following steps to edit an installed schedule definition:
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 1. Click Data Entry > Define Schedules to open the Define Schedules window.

Figure  8-25. Define Schedules

 2. Select an installed schedule definition from the Select Schedule Definition drop-down list, such as 
[PCS] Installed Schedule Definition.

 3. To add one or more schedule types to an installed schedule definition:

 a. Select an available schedule type listed in the Available Schedule Types pane. To select 
multiple schedule types, press the Ctrl key on the computer keyboard while selecting each 
schedule type.

 b. Click the   button to move the schedule type(s) to the Selected Schedule Types pane. You 
can also double-click the schedule name to move it from pane to pane.

 c. Click  Save.

 4. To remove one or more schedule types from an installed schedule definition:

 a. Select a schedule type listed in the Selected Schedule Types pane. To select multiple 
schedule types, press the Ctrl key on the computer keyboard while selecting each schedule 
type.
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 b. Click the   button to move the schedule type to the Available Schedule Types pane. You 
can also double-click the schedule name to move it from pane to pane.

 c. Click  Save.

 5. OPTIONAL: After saving changes to an installed schedule definition, and before closing the window, 

click  Revert to revert the schedule definition to installed values. Click Yes when the Revert 
message displays.

Figure  8-26. Revert Schedule Definition Message

Add a Schedule Definition Addition

Complete the following steps to add a schedule definition addition:
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 1. Click Data Entry > Define Schedules to open the Define Schedules window.

Figure  8-27. Define Schedules

 2. Click  Add.
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Figure  8-28. Add Schedule Definition

 3. Enter a name for the addition in the Schedule Name field. The field supports up to 120 characters 
including spaces.

 4. Select a schedule type listed in the Available Schedule Types pane, such as Periodic Bond-Critical. 
To select multiple schedule types, press the Ctrl key on the computer keyboard while selecting each 
schedule type.

 5. Select the Schedule all facilities on a ROW on the same Due Date check box to enable this option.

 6. Select an available schedule type listed in the Available Schedule Types pane. To select multiple 
schedule types, press the Ctrl key on the computer keyboard while selecting each schedule type.

 7. Click the   button to move the schedule type(s) to the Selected Schedule Types pane. You can 
also double-click the schedule name to move it from pane to pane.

 8. To remove a schedule type from the Selected Schedule Types pane, select the schedule type and 

click the   button to move the schedule type back to the Available Schedule Types pane. You can 
also double-click the schedule name to move it from pane to pane.

 9. Click  Save. The addition is now available in the Select Schedule Definition selection list.
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Edit a Schedule Definition Addition

The following procedure explains how to delete, rename, or edit a schedule definition addition.

Complete the following steps to edit a schedule definition addition:

 1. Click Data Entry > Define Schedules to open the Define Schedules window.

Figure  8-29. Define Schedules

 2. Select an addition schedule from the Select Schedule Definition drop-down list.

 3. If you want to rename an addition, type a new name in the Schedule Name field and then click  
Save.

 4. To add one or more schedule types to the addition, select an available schedule type listed in the 

Available Schedule Types pane and click the   button to move it to the Selected Schedule Types 
pane. You can also double-click the schedule name to move it from pane to pane.

 5. To remove one or more schedule types from the addition, select an schedule type listed in the 

Selected Schedule Types pane and click the   button to move it to the Available Schedule Types 
pane. You can also double-click the schedule name to move it from pane to pane.

 6. To delete the addition, click  Delete, and then click  Yes in the Delete message window.



PCS v2.5 User Guide

Chapter 8: Schedules 546

Figure  8-30. Delete Message

Use a Schedule in PCS
After setting up scheduling criteria in Edit Schedule Settings window and creating a schedule definition in 
Define Schedules window, you can use a schedule in any of the following ways:

 l View records in a grid based on a schedule. Refer to View Records Based on a Schedule on page 
293.

 l Build a survey in an inspection grid based on a schedule. Refer to  Build a Survey in the Inspection 
Grid Based on Schedule on page 342.

 l Transfer a survey to the Allegro field computer based on a schedule. Refer to  Field Computer on 
page 677.

 l Print a Data Collection Report based on a schedule. Refer to Reports and Graphs on page 773.
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Chapter 9: PCS Bullhorn Web Integration
PCS 2.5 includes a robust set of features and utilities designed to streamline integration of Bullhorn Web 
facility survey data (such as rectifier, bond, or test point inspection readings). By leveraging a Bullhorn Web 
API (Application Programming Interface), PCS 2.5 eliminates the need to create multiple Bridge 
configurations for each Bullhorn Web account.

The Bullhorn Bridge Mapping Import feature expedites the import of existing Bullhorn Bridge mappings for 
use in PCS Bullhorn Web Integration functionality.

To further streamline setup, the Auto-Mapping features use a multi-phase process to detect matching PCS 
facility and Bullhorn Web RMU data points, including facility IDs, Unit Labels, facility GPS locations, and 
Bullhorn RMU reporting locations.

PCS 2.5 includes a simplified manual mapping process to align data from Bullhorn RMUs that cannot be 
automatically mapped to PCS facilities. 

Enhanced Issue Detection proactively identifies integration issues, notifies users, and provides solutions via 
a built-in Resolution Wizard informed by your facility data and RMU location.

This chapter  includes the following topics:

 l Before Launching PCS Version 2.5 or Later

 l PCS Setup & Configuration

 l Bullhorn Bridge Mapping Import

 l Issue Detection & Notification

Before Launching PCS Version 2.5 or Later
To take full advantage of PCS Bullhorn Web Integration features, follow the steps below prior launching 
PCS version 2.5 for the first time. 

 l Refer to Bridge and take all necessary steps to confirm or configure the appropriate Bullhorn Bridge 
settings and configurations are in place.

 l Refer to Unit Configuration in the Bullhorn Web User Guide to ensure Bullhorn RMUs are configured 
correctly in the desired Bullhorn accounts. 

https://support.aiworldwide.com/products/bh1/content/bullhornweb/interruption/remote_monitoring_units.htm?tocpath=Bullhorn%20Web%20User%20Guide%7CUnit%20Configuration%7C_____0
https://support.aiworldwide.com/products/bh1/content/topics/index_csh.htm?tocpath=Bullhorn%20Web%20User%20Guide%7C_____0
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 l Refer to Bullhorn API to create and manage Bullhorn Web credentials used in PCS Bullhorn Web 
Integration.

 

PCS Setup & Configuration
Review and follow steps in the following topics to ensure PCS is configured to support PCS Bullhorn Web 
Integration features and utilities. 

 l Bullhorn Web API Overview

 l Bullhorn API

 l PCS Client Service

 l Install PCS Client Service

 l Configure Port Settings

 l Configure Bullhorn Integration Permissions

 l Configure Bullhorn Web Integration Settings

Bullhorn Web API Overview

PCS Bullhorn Web Integration features and utilities  leverage a Bullhorn Web API (Application Programming 
Interface) to ensure seamless automated import of Bullhorn Web account facility survey data (such as 
rectifier, bond, or test point inspection readings).

Bullhorn Web API is configued by Bullhorn Web Admins and is used to generate credentials associated 
with one or more Bullhorn Web accounts. 

Proceed to Bullhorn API for details on creating and managing credentials. 

Bullhorn API

Bullhorn API (Application Programming Interface) can be used to seamlessly integrate certain data, such as 
channel measurement data, with PCS version 2.5 or later.

A Bullhorn Web user with the Client Admin security role can simplify integration by grouping multiple 
Bullhorn accounts into a single send to PCS, eliminating the need for Extract reports and Bullhorn Bridge 
configurations for each  account.     

The following topics include more information about how to configure and manage Bullhorn API:

https://support.aiworldwide.com/products/bh1/content/bullhornweb/security/site_security_page.htm?tocpath=Bullhorn%20Web%20User%20Guide%7CAdministration%20and%20User%20Set%20Up%7CSite%20Security%20Page%7C_____0
https://support.aiworldwide.com/products/bh1/content/bullhornweb/security/site_security_page.htm?tocpath=Bullhorn%20Web%20User%20Guide%7CAdministration%20and%20User%20Set%20Up%7CSite%20Security%20Page%7C_____0
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 l Accessing the Bullhorn API Setup Page

 l Add a New Credential for an Account

 l Add an Existing Credential to an Account

 l Delete a Credential

Accessing the Bullhorn API Setup Page

Bullhorn Web users with the Client Admin security role can access Bullhorn API for the Bullhorn Web 
account they are viewing.

NOTE: Refer to Site Security Page for details about identifying and adjusting a user's security role.

Log into Bullhorn Web and follow these steps to access the Bullhorn API Setup page:

 1. Follow the steps in Search for Clients to ensure the correct account is selected. 

 

Figure  9-1. Client Search      

 2. Hover your mouse pointer over Admin and select Bullhorn API.

../../../../../../bh1/Content/bullhornweb/bullhornAPI/access_bullhorn_API.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/add_new_credential.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/add_existing_credential.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/delete_credential.htm
../../../../../../bh1/Content/bullhornweb/security/Site_Security_Page.htm
../../../../../../bh1/Content/bullhornweb/website/Search_for_Client.htm
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Figure  9-2. Admin Menu

 3. The Bullhorn API Setup page includes option to add new credentials, add existing credentials, and 
access API and PCS Bullhorn Web integration documentation. 
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Figure  9-3. Bullhorn API Setup Options

See Add a New Credential for an Account and Add an Existing Credential to an Account for details about 
managing Credentials.

Add a New Credential for an Account

Adding a new credential creates a security token bound to the company Bullhorn Web account. This token 
can then be used inside of PCS version 2.5 or later to import data from Bullhorn Web.

To create a new credential for an account:     

 1. On the  Bullhorn API Setup page, click Add New Credential. 

 2. Enter a name for the credential in the Add API Credential prompt and click Save. 

 3. Click the  icon next to the newly created credential to view its API Client ID and API Client Secret.

NOTE: Use the Copy buttons to capture the API Client ID and API Client Secret to your computer's 
scratchpad.

Add an Existing Credential to an Account

Adding existing Bullhorn Web credentials to an account allows users with multiple accounts to combine all 
of their Bullhorn Web data for import into PCS version 2.5 or later.

../../../../../../bh1/Content/bullhornweb/bullhornAPI/add_new_credential.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/add_existing_credential.htm
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IMPORTANT: There must be existing credentials associated with an account to be copied and added to 
another account. Refer to Add a New Credential for an Account for details on creating credentials.

To add an existing credential to an account: 

 1. Follow the steps in Search for Clients to select the account with the existing credential.

Figure  9-4. Client Search 

 2. Follow the steps in Accessing the Bullhorn API Setup Page.

 3. Click the  icon next to the credential you intend to copy to view its API Client ID and API Client 
Secret.

 4. Use the Copy buttons to capture the API Client ID and API Client Secret to your computer's 
scratchpad.

 5. Follow the steps in Search for Clients to select the account you want to add the existing credential to 
and follow the steps in Accessing the Bullhorn API Setup Page.

 6. On the  Bullhorn API Setup page, click Add Existing Credential. 

 7. Paste the copied API Client ID and API Client Secret into the Add API Credential prompt and click 
Save. 

NOTE: The Active Customer IDs section of an account's Bullhorn API Setup page indicates which 
accounts are tied together.

Steps to Daisy Chain Multiple Bullhorn Accounts Together

You must perform the following steps to tie together data from multiple Bullhorn accounts successfully:

 l Create a new credential in the first account. 

 l Copy and paste the API Client ID and API Client Secret from the first account into the Add Existing 
Credential prompt of the second account. Both accounts should be listed in the Active Customer IDs 
section when viewing the credential's API Client ID and API Client Secret.

 l Copy and paste the API Client ID and API Client Secret from the second account into the Add 
Existing Credential prompt of the third account. All three accounts should be listed in the Active 
Customer IDs section when viewing the credential's API Client ID and API Client Secret. 

../../../../../../bh1/Content/bullhornweb/bullhornAPI/add_new_credential.htm
../../../../../../bh1/Content/bullhornweb/website/Search_for_Client.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/access_bullhorn_API.htm
../../../../../../bh1/Content/bullhornweb/website/Search_for_Client.htm
../../../../../../bh1/Content/bullhornweb/bullhornAPI/access_bullhorn_API.htm
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 l Repeat until all accounts are captured, rolling forward the API Client ID and API Client Secret from the 
most recently added account. 

Delete a Credential

To delete a credential for an account:     

 1. On the  Bullhorn API Setup page, click the  icon next to a credential to view its API Client ID and API 
Client Secret.

 2. Click the Delete button.

 3. Click the Delete button in the Delete API Credential prompt. 

WARNING: Deleting a credential removes access to API data.

PCS Client Service

Successful integration between PCS and Bullhorn Web requires installation of PCS Client Service.

PCS Client Service is designed to manage and facilitate back end functionality necessary to deliver the 
following PCSBullhorn Web Integration benefits:

 l streamlined importing of Bullhorn data from the Bullhorn Web API

 l staging of data for Bullhorn Web import / hand off to a Job Service queue

 l detecting and reporting integration issues

Prerequisites for successful installation of PCS Client Service include installation of X64 versions of the 
following:

 l ASP.NET Core Runtime 8.0.11

 l .NET Runtime 8.0.11

NOTE: Click here to download .NET 8.0 installers from Microsoft.

PCS Client Service should be installed on a dedicated network server following the guidelines and 
recommendations outlined in the PCS Server Installation guide.

Proceed to Install PCS Client Service.

https://dotnet.microsoft.com/en-us/download/dotnet/8.0
https://support.aiworldwide.com/downloads/pc1/PCS-Server-Installation.pdf
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Install PCS Client Service

To install PCS Client Service:

 1. Download the PCS.ClientService.Installer.msi file. 

 2. Double click the PCS.ClientService.Installer.msi file to launch the installer. 

 3. The PCS Client Service 2.5 installer window includes a status bar indicating progress. Once the 
installation is completed, the installer will automatically close. 

Figure  9-5. PCS Client Service Installer

IMPORTANT: PCS Client Service supports only 1 running instance. 

Proceed to Configure Port Settings.

Configure Port Settings

Follow these steps to configure PCS Integration port settings for successful use of PCS Bullhorn Web 
Integration features and utilities.

IMPORTANT: PCS Client Service must be installed and running before proceeding. See Install PCS 
Client Service for details.

 1. Launch and log into PCS version 2.5.

 2. Click Tools in the menu bar and select Options from the dropdown list.
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Figure  9-6. Tools Menu

 3. Select the Integration tab on the left hand side of the window. 

Figure  9-7. Integration Tab

 4. The default port for PCS Client Service is 9001. American Innovations recommends consulting your 
organization's IT group to confirm access through the port. 
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Figure  9-8. PCS Client Service Settings

NOTE: American Innovationsrecommends enabling the Use Static Port option.

 5. Click the  (Save) icon in the menu bar. 

Proceed to Configure Bullhorn Integration Permissions.

Configure Bullhorn Integration Permissions

Follow these steps to review and configure permissions for user to access to Bullhorn Integration features 
under the Tools menu. 

NOTE: SysAdmin and User roles are granted full Bullhorn Integration permissions by default. These 
permissions can be customized as needed. 

 1. Launch and log into PCS version 2.5.

 2. Click Tools in the menu bar and select Security Role Managementfrom the dropdown list.
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Figure  9-9. Tools Menu

 3. Under the Security Role Management tab, click the arrow to expand Tools on the left hand side of the 
window to view Bullhorn Integration permissions associated with the selected  Parent Role and Role 
settings.
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Figure  9-10. Bullhorn Integration Permissions

 4. Add, edit, or delete custom security roles as per the steps outlined in Custom Security Roles.

Configure Bullhorn Web Integration Settings

Admin users must follow these steps to configure Bullhorn Web Integration settings in PCS. 

 1. Launch and log into PCS.

 2. Click Tools in the menu bar and select Bullhorn Integration from the drop down list.
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Figure  9-11. Tools Menu

 3. Select the Integration Configuration tab on the left hand side of the window. PCS Client Status and 
Status Time are indicated at the top of the Integration Configuration window. 

Figure  9-12. Integration Configuration Settings

 4. Input the appropriate information into the API Client ID and API Client Secret fields and click the  
icon in the blue Integration Configuration menu bar.
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Refer to Bullhorn Web API Overview and the Bullhorn Web User Guide for details on creating or 
obtaining API Client ID and API Client Secret credentials via Bullhorn Web API.

NOTE: Once credentials are input into the fields, associated Bullhorn Web Customer Name and 
Customer ID info will be displayed in the window. 

 5. Set up the following in Inspection Frequency Settings:

 l Start Date - The earliest date from which inspections are imported into PCS.  Determines the 
date subsequent inspections will be imported based on the frequency selected. 

 l Enable Bullhorn Inspection Import - Enables all PCS Bullhorn Web Integration functions. 
Deselecting this option suspends inspection imports, email and other notifications, and 
automated issue detection via the Dashboard.

 l Daily/Weekly/Monthly - Determines the frequency of inspection imports based on the Start 
Date setting. For the purpose of maintaining compliance, American Innovations recommends 
no fewer than 1 inspection import per month. 

 l Recurs Every - Determines the cadence and time of inspection imports in relation to the 
selected frequency and start date. 

NOTE: Recurrence cannot be set beyond 60 days/8 weeks/2 months. 

Figure  9-13. Inspection Frequency Settings

https://support.aiworldwide.com/products/bh1/content/topics/index_csh.htm?tocpath=Bullhorn%20Web%20User%20Guide%7C_____0
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 6. Click the  icon in the blue Inspection Frequency Settings menu bar to save the settings.

 

If you use the Bullhorn Bridge configured with existing mappings, refer to Bullhorn Bridge Mapping Import 
for the next steps. 

Bullhorn Bridge Mapping Import
Designed for customers that use the Bullhorn Bridge configured with existing mappings to import Bullhorn 
RMU data, PCS version 2.5 and later includes an integrated Bullhorn Bridge Mapping Import feature. After 
existing Bullhorn Bridge mappings are imported, users can take full advantage of PCS Bullhorn Web 
Integration features and utilities. 

IMPORTANT: Bullhorn Bridge Mapping Import runs once when PCSBullhorn Web Integration is 
enabled. Subsequent mapping imports and adjustments are subject to manual mapping procedures, 
depending on settings and configuration in both PCS and Bullhorn Web. American Innovations 
recommends reviewing Before Launching PCS Version 2.5 or Later before enabling PCS Bullhorn Web 
Integration features.

Follow the steps in the topics below to complete the Bullhorn Bridge Mapping Import process.

Start Bullhorn Bridge Mapping Import

Working with Bullhorn Bridge Mapping Import Results

 

 

Start Bullhorn Bridge Mapping Import

For customers using Bullhorn Bridge configured with existing mappings, Bullhorn Bridge Mapping Import is 
triggered automatically when a SysAdmin completes the steps outlined in Configure Bullhorn Web 
Integration Settings.

An Import Bullhorn Bridge Mappings tab appears in the Bullhorn Integration menu with a prompt to begin 
the import process.
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Figure  9-14. Import Bullhorn Bridge Mappings Prompt

 1. Click the  Start Import option in the blue Import Bullhorn Bridge Mappings tool bar.

IMPORTANT: Selecting  Hide Tab closes the  tab without importing existing Bullhorn Bridge 
mappings. Once  Hide Tab is selected, Import Bullhorn Bridge Mappings is no longer available. 

 2. Import progress is indicated in the Import Bullhorn Bridge Mappings window by a rotating activity 
icon, total record count, and percentage completed text. 

Figure  9-15. Import Bullhorn Bridge Mappings Progress

 3. A prompt indicates completion of the import process and gives record counts for successful and 
failed imports.

NOTE: Bullhorn Bridge Mapping Import only supports installed facility types. Custom facility types 
will not be imported and should continue to be integrated using the Bullhorn Bridge. For more 
information, see Manage Custom Modules and Facilities

Proceed to the steps in Working with Bullhorn Bridge Mapping Import Results.

Working with Bullhorn Bridge Mapping Import Results

As a result of the Import Bullhorn Bridge Mappings process, imported facilities will be categorized under 
three tabs in the Mapping window.  To review and managed imported facilities:
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 1. select the Mapping tab on the left hand side of the Bullhorn Integration.

Figure  9-16. Mapping

 2. If necessary, expand the Bullhorn Account/Group Filter by clicking the arrow icon in the blue vertical 
bar and select the desired accounts/groups.

Figure  9-17. Account/Group Filter

 3. Follow the steps in the topics listed below:

Mapped Facilities

Unapped Facilities

Facilities Excluded from Configuration Mapping

Mapped Facilities

Imported facilities that appear under the Mapped tab were validated during the Import Bullhorn Bridge 
Mappings process. A counter in the Mapped tab indicates the total number of mapped facilities that have 
been imported for the selected account/group. Facilities are listed in rows that contain the following 
identifying information:
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 l Unit Name

 l Channel Label

 l Bullhorn Engineering Unit Label

 l Bullhorn Facility ID

 l Sub Facility Name

 l Facility Type

 l Row Code And Pipeline

 l Milepost

 l Location Description

 l PCS Property

 l Latitude

 l Longitude

 l Bullhorn Serial Number

 l PCS Serial Number

Follow these steps to review and manage mapped facilities:
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 1. Select the Mapped tab at the top of the Mapping window. 

Figure  9-18. Mapped tab

 2. Review the information for each mapped facility to ensure accuracy.

 3. If necessary, select the check box for any facilities to be unmapped.
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Figure  9-19. Select Facilities

 4. Click Unmap Selected Rows in the vertical blue toolbar.

Figure  9-20. Unmap Selected Rows Option

 5. Click OK in the Save Changes prompt.

Figure  9-21. Save Changes Prompt

NOTE: Unmapped facilities will appear under the Unmapped tab in the Mapping window.

Proceed to the steps in Unapped Facilities.

Unapped Facilities

Imported facilities that appear under the Unmapped tab could not be validated during the Import Bullhorn 
Bridge Mappings process. A counter in the Unmapped tab indicates the total number of unmapped 
facilities that have been imported for the selected account/group. Facilities are listed in rows that contain 
the following identifying information:
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 l Unit Name

 l Channel Label

 l Bullhorn Engineering Unit Label

 l Bullhorn Facility ID

 l Sub Facility Name

 l Facility Type

 l Row Code And Pipeline

 l Milepost

 l Location Description

 l PCS Property

 l Latitude

 l Longitude

 l Bullhorn Serial Number

 l PCS Serial Number

Follow these steps to review and manage unmapped facilities:

 1. Select the Unmapped tab at the top of the Mapping window. 

Figure  9-22. Unmapped tab

 2. Review the information for each unmapped facility. The Auto-mapping feature in PCS will attempt to 
identify matched Bullhorn and PCS facility information.

 l Imported facilities that included matched Facility IDs and Engineering Unit Labels will be 
highlighted blue and their check boxes will be automatically selected, indicating that they can 
be successfully mapped. 
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 l Facilities without matched Facility IDs and Engineering Unit Labels can be managed using the 
drop down menus for the following:

 — PCS Facility ID

 — Subfacility Name

 — Location Description

 — PCS Property

IMPORTANT: At least two of these criteria must be input before a unit can be 
successfully mapped. Facilities meeting the requirements for mapping will be 
highlighted blue. 

 3. To manage unmapped facilities without matching Facility IDs or Engineering Unit Labels, click the 
drop down arrow for the information you want to search. To select units for exclusion from mapping, 
skip to step 6.

Figure  9-23. PCS Facility ID Drop Down

The PCS auto-mapping feature will provide a list of potential matches based on various data points, 
including Milepost, PCS GPS & Bullhorn reporting location, Facility IDs, and Location Description.

You may choose one of the option from the list, or click  Clear Selection and manually input search 
terms into the field to generate a response. 
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Figure  9-24. Manual Search

NOTE: Distance indicates how far a facility in the search results is from the Latitude and Longitude 
logged in PCS. No distance will be shown for facilities that do not have Latitude and Longitude 
information in PCS. Facilities more than half a mile away may not appear in the search results. 

Once search results have been selected for at least two of the required criteria, select the check box 
for the facility. 

 4. Ensure the check boxes for any facilities to be mapped are selected and click Save and Map in the 
blue Mapping window tool bar.

 5. Click OK in the Save Changes Prompt.
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Figure  9-25. Save Changes Prompt

NOTE: Selected facilities will appear under the Mapped tab in the Mapping window.

 6. Follow these steps to exclude facilities from mapping:

 a. Select the check boxes for any facilities under the Unmapped tab that you wish to exclude 
from mapping. 

 b. Click the Exclude from Mapping option in the blue Mapping tool bar. 

 c. Click OK in the Save Changes prompt. 

Figure  9-26. Save Changes Prompt

NOTE: Excluded facilities will appear under the Excluded from Configuration Mapping tab in 
the Mapping window.

Proceed to the steps in Facilities Excluded from Configuration Mapping.

Facilities Excluded from Configuration Mapping

Imported facilities that appear under the Exclude from Configuration Mapping were designated as Do Not 
Map in the Bullhorn Bridge configuration. Facilities under the Unmapped tab can be designated to be 
excluded from configuration mapping by a user with Bullhorn Integration permissions. A counter in the 
Exclude from Configuration Mapping tab indicates the total number of facilities that have been imported for 
the selected account/group. 

Follow these steps to review and manage facilities excluded from configuration mapping:
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 1. Select the Excluded from Configuration Mappingtab at the top of the Mapping window. 

Figure  9-27. Excluded From Configuration Mapping tab

 2. Review the information for each facility. 

 3. To move facilities to the Unmapped category, select their check boxes and click Move to Unmapped 
Rows in the Mapping window's blue tool bar. 

 4. Click OK in the Save Changes prompt. 

Figure  9-28. Save Changes Prompt

NOTE: Facilities will appear under the Unmapped tab in the Mapping window.

Issue Detection & Notification
PCS version 2.5 and later includes Enhanced Issue Detection features that proactively identify a variety of 
integration issues for mapped facilities. Integration issues that trigger notifications include:
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 l facilities marked Inactive in PCS

 l facility IDs not found in PCS

 l missing Bullhorn RMUs (due to decommission or other factors)

 l Bullhorn RMU label or channel changes in Bullhorn Web

 l mismatched GPS location information between PCS and Bullhorn Web

 l mismatched facility ID information between PCS and Bullhorn Web

 l Bullhorn RMUs not responding

Depending on configuration, users may receive within the interface and via email. Review the topics below 
for details:

Bullhorn Notification Icon

Bullhorn Integration Dashboard

Bullhorn Notification Icon

PCS version 2.5 and introduces the Bullhorn Notification icon, located in the upper right corner of the PCS 
menu bar.

Figure  9-29. Bullhorn Notification Icon

If PCS detects integration issues for mapped facilities, a badge appears on the Bullhorn Notification icon 
with a counter indicating the number of unresolved issues detected. 

NOTE: The Bullhorn Notification icon badge counter is capped at 99. If more than 99 unresolved issues 
are detected, the badge counter displays 99+. Refer to Bullhorn Integration Dashboard for details on 
viewing and resolving a complete list of detected issues.

Clicking the Bullhorn Notification icon opens the Bullhorn Integration window.

Bullhorn Integration Dashboard

The  Bullhorn Integration Dashboard provides a comprehensive list of detected integration issues for 
mapped facilities, including warning messages for facility-specific issues. 

Follow the steps below to access the Bullhorn Integration Dashboard.
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 1. Select Bullhorn Integration from the Tools menu, or click the Bullhorn Notification icon. 

 2. Click the Dashboard tab on the left side of the Bullhorn Integration window. If PCS detects integration 
issues for mapped facilities, the Dashboard tab displays a warning icon and a counter indicating the 
number of unresolved issues detected. 

Figure  9-30. Dashboard

NOTE: The number of unresolved issues displayed in the Dashboard window can be adjusted by 
changing the Bullhorn Account/Group filter under the Mapping tab. Refer to Working with Bullhorn 
Bridge Mapping Import Results for details.

 3. To launch the Resolution Wizard, click on any data point for a desired facility or select the Resolve 
Issues option in the Dashboard menu bar. 
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Chapter 10: Bridge
Bridge is an optional add-on feature that allows you to transfer data between PCS and an external system, 
such as a GIS (geographic information system) or work management system. If you have an account on 
Bullhorn Web, you can transfer facility survey data to PCS, such as rectifier, bond, or test point inspection 
readings.

If your company purchased the optional Bridge add-on or you plan to transfer data from Bullhorn Web in 
PCS, running Bridge for the first time requires you to enter a Bridge activation key. If you are unable to locate 
your Bridge activation key, contact Technical Support for assistance at support@aiworldwide.com. For 
more information, refer to Activate Bridge Import for Operation on page 2.

This chapter  includes the following topics:

 l The Bridge Transition File

 l Use a Facility Key in Bridge

 l Add  a Basic Bridge Definition

 l Add  a Bridge Import Definition for a Stationary Survey File

 l Add  a Bullhorn Bridge Definition

 l Export a Bridge Definition

 l Import a Bridge Definition

 l Import Pipeline Series

 l Run the Bridge

 l Run a Bullhorn Bridge

 l View Bridge Job Status and Log

Refer to the Knowledge Base article Why and How do I Export to Table? for more information on creating an 
Export definition.

The Bridge Transition File
Bridge uses a transition file to import and export data. The import file is in a format that both Bridge and the 
external system can read and write. File formats supported by Bridge include those in the following list:

mailto:support@aiworldwide.com?subject=AI Support
../../../../../Content/knowledge_base/export-to-table.htm
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 l Excel Spreadsheet 2007 or higher (.xlsx)

 l ASCII, comma-delimited (.txt or .csv)

 l Extensible Markup Language (.xml)

Use a Facility Key in Bridge
Bridge provides the option of associating a facility key in PCS with an external system ID when setting up a 
Bridge import definition. The facility key allows you to map (or link) existing facilities in PCS with an external 
system. It is used to update existing facilities' facility IDs, mileposts, ROWs, or primary ROW links for multi-
linked facilities (such as rectifiers). You can also use a facility key to import sub-facility information or 
inspection records or facility inspection or maintenance records.

A facility key can be a user-defined field set up in PCS and must be unique for each facility. The external 
system ID is typically a unique identifier generated by an external system, such as a GIS or work 
management system. Importing records using a facility key will update an existing facility, but will only 
create a new facility if one does not yet exist in PCS. The facility key is used in place of the PCS  ROW Code 
or Milepost field when setting up the Bridge import definition. If the ROW Code or Milepost associated with 
a facility key differs between the external data and the existing PCS data, the ROW Code or Milepost 
associated  values will be updated to match the imported data.

Complete the following steps to add a facility key for an external system IDs:

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window.

 2. Open the Facility Surveys folder and then the Common to All Facilities folder in the selection tree. 
Then click ROW and Pipeline to display related fields in the grid.

NOTE: Click the Properties header bar to collapse the Properties pane to expand the view of the 
grid. Click the bar again to expand the Properties pane.
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Figure  10-1. Field and UDF Customizations - ROW and Pipeline Table

 3. Click  Normal in the toolbar to open the Add Normal Field window.

Figure  10-2. Add Normal Field - Character Type

 4. Type a unique name for the UDF in the Caption field, such as MyFacilityKey to help identify this 
UDF. 

 5. Click  Save to save changes and close the window.
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The UDF is now ready to be used as the Facility Key in a Bridge import or export definition file.

Add  a Basic Bridge Definition
A Bridge import definition specifies the property settings and options for importing data into PCS. A Bridge 
export definition specifies the property settings and options for exporting data from PCS. These definitions 
define the data transfer options, file format and location of the import or export file, and the data to be 
imported or exported.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

To add a new Bridge definition, click Tools > Bridge to open the Bridge window.

Click  Basic to open the basic definition pane  and perform the following tasks:

 l Set  Basic Bridge Definition Properties

 l Define Data Items for Basic Bridge Definition on page 584

 l Set Filters for All or Selected Data Items on page 593 — this topic can be used for both Basic Bridge 
Definitions and Bridge Definitions for SDL survey files. 

 l Preview the Bridge Import                 

NOTE: It is recommended to click  Save frequently while creating the Bridge definition.

Set  Basic Bridge Definition Properties

The Basic Bridge definition properties include data transfer, public option, rename file on bridge runs 
option, and reindex after import option.

Complete the following steps set basic Bridge  properties:
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 1. Click Tools > Bridge to open the Bridge window.

Figure  10-3. Bridge

 2. Click  Basic to open the basic definition pane. The Selected ROWs and Bridge Definitions panes 
can be moved or closed.
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Figure  10-4. Basic Bridge Definition

 3. Type a unique name for the Bridge definition in the Name field.

 4. Click the Import or Export check box for the type of Bridge you are setting up. If both Import and 
Export are checked, the data items mapped and options configured for the Bridge definition will 
apply to both the import and export Bridge runs. 

 5. To set the import or export Bridge job to run automatically at a scheduled time, click the Scheduled 

check box next to the selected Bridge type. Click the  icon and complete the following steps in the 
Schedule Frequency window:
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Figure  10-5. Schedule Frequency Window

 a. Determine the Import or Export Start Date — enter a start date in the field provided or select 
the drop-down next to the field and select a date from the calendar that appears. The entered 
date determines when the first import or export occurs.

 b. Create a Schedule for the Imports or Exports  — decide how often Bridge imports or exports 
should run by selecting one of the following:

 i. Daily: Select Daily to perform the import or export after a certain number of days has 
passed since the last import. Enter a number in the Recurs every field and a time in the 
day(s) at field.

Figure  10-6. Schedule Frequency - Daily
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 ii. Weekly: Select Weekly to perform the import or export on certain days of the week. 
Enter a number in the field provided to determine how many weeks should pass 
between imports. Select the check box next to the day(s) of the week that the import 
should be sent.

Figure  10-7. Schedule Frequency - Weekly

 iii. Monthly: Select Monthly to perform the import or export after a certain number of 
months has passed since the last import. You can select one of the following 
schedules:

 1. Select the first radio button on the right to perform the import or export only one 
time during the month. Select the day the import will run in the Day field, the 
frequency in the of every month(s) field, and enter a time a time in the last text 
field.

Figure  10-8. Schedule Frequency - Monthly
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 2. Select the second radio button on the right to perform the import or export twice 
during specified months. Select which days the import will run in the two Day 
fields. Select the frequency in the of every month(s) field and enter a time a time in 
the second text field.

Figure  10-9. Schedule Frequency - Monthly with Specific Months and Time

 iv. Quarterly: Select Quarterly to run the import or export on the first day of every quarter. 
Enter a time in the text field.

Figure  10-10. Schedule Frequency - Quarterly

 c. Click  Save to save schedule.

When scheduling a time to run Bridge, choose a time that does not impact other network services or 
computer resources. For example, consider a staggered time schedule instead of running Bridge at 
the same time as other scheduled network services.
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 6. For Bridge exports, select which records to export from the From Selected ROWs drop-down list. 

Figure  10-11. From Selected ROWs Drop-down List

When performing the Bridge export manually, the data included for the Bridge export is restricted to 
the data selected in Selected ROWs. For scheduled exports, the data included for the Bridge export 
comes from the entire PCS database. 

 7. Click the Public check box if you want the import/export definition file available for use by all PCS 
users. When the check box is cleared, the definition file will be available only to the user who creates 
it.

 8. If you want to use a facility key for facilities in the import file, click the Use Facility Keycheck box. This 
option is not currently available for facilities in the export file. For more information about facility keys, 
refer to Use a Facility Key in Bridge on page 575.

When facilities are not mapped to a facility key, they are mapped to the following required fields: 
ROW Code, Milepost, and Facility ID.

 9. If you expect to run the import/export file manually and want Bridge to rename the file, click the  
Rename files on manual bridge runs check box. 

 10. For Bridge imports that import large amounts of data, click the Reindex after import check box to 
reindex the PCS database after the import process completes.
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This prevents the system from slowing down due to index fragmentation in the PCS database. You 
can also reindex the database using the Reindex Database option in Job Service Viewer (Tools > Job 
Service Viewer).

 11. Click  Save to save definition.

Define Data Items for Basic Bridge Definition

You can add data items to the Bridge definition that will be included in the import or export. Each data item 
added must also be configured to ensure the fields are mapped correctly, the correct data is exported, and 
the data is exported to the desired location. 

Complete the following steps to add and configure data item(s) for import or export from PCS:

 1. Open the Bridge definition for which you would like to add data items.

Figure  10-12. Basic Bridge Definition

 2. Click  Add Data Item to open the Data Items window.
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Figure  10-13. Data Items Window

 3. Navigate to the folder(s) containing the data item(s) you want to import or export. Click the  icon 
next to a top-level folder to expand it.

 4. Select a data item and click the  button to move it to the right pane of the window. You can also 
double-click an item to move it. 
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Figure  10-14. Data Items

The right pane of the Data Items window lists all selected data items for import or export. To remove a 

data item, select it and then click the  button  to move it back to the left pane. You can also 
double-click an item to move it. 

 5. Repeat these steps as needed until all desired data items are listed in the right pane.    

 6. Click  OK to close the window and return to the Bridge definition window. The data items are 

shown on the left side of the lower pane of the Bridge Definition window. You can click  Full View to 

view just this area. Click  Full View again to expand the view.
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Figure  10-15. Data Items Pane

 7. To delete a data item, click select the data item in the left-hand list and click  Delete in the 
associated Detail pane.

Figure  10-16. Data Item Details Pane

 8. To configure each data item, select the data item and complete the following steps for each one. The 
name of the data item will display as the header of the configuration pane:



PCS v2.5 User Guide

Chapter 10: Bridge 588

 a. For Bridge imports, select an import file in Import File Name field. Click the ellipsis button … in 
the Import File Name field to open the Import File window. Navigate to a folder on your 
computer where you want to save the export file. Then click Open to close the window and 
return to the definition window.

NOTE: If you did not select Export in the Data Transfer pane, the Export Directory, Export File 
Name, and Export Format fields will not display.

Figure  10-17. Data Item Import and Export Information

 b.  a. For Bridge exports, select an Export Directory, enter an Export File Name, and select a Export 
Format for the export file. Options include Excel files (*.xlsx) and Text files (*.txt, *.csv). Click the 
ellipsis button … in the Export Directory field to open the Browse For Folder window. Navigate 
to a folder on your computer where you want to save the export file. Then click OK to close the 
window and return to the definition window.

 c. To assign inspections to an annual survey folder based on the inspection date of the record, 
select the Assign inspections to an Annual Survey check box.

Figure  10-18. Data Items Options

 d. To assign inspections to a periodic survey folder based on the inspection date of the record, 
select the Assign inspections to a Periodic Survey check box.

 e. Apply a filter to the data item. You can set up one or more filters that are applied to only the 
currently selected data item in the export definition. If the export definition is set up to run at a 
scheduled time, the filters will apply automatically. However, if an export definition is run 
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manually, you will be prompted to select which filters to apply before running the export 
definition. 

Click  Edit in the Filters pane and define the filters that apply to the selected data item in the 
Edit Filters window. For detailed information about editing filters, refer to Set Filters for All or 
Selected Data Items.

Figure  10-19. Filters Pane

 f. Map PCS fields to transition field in the Maps pane. 

Figure  10-20. Maps Pane
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 i. Click  Edit to open a field selection window.

Figure  10-21. Edit Map Window

 ii. Click   Auto Map to allow PCS to map PCS fields with fields from the import file based 
on column names. The Transition Field cell for the mapped Internal Field will auto-
populate.

Figure  10-22. Transition Field Mapped

 iii. If the PCS field(s) you wish to map to data in a column of the imported file or to export to 
a file is not listed in the Mappings pane, navigate to and select the PCS fields in the 

Internal Fields pane and click the  button or double-click the field(s) to move the 
selected fields to the Mappings pane.

 iv. For Bridge exports, select a row in the Mappings pane and type a column name in the 
Transition Field cell.

For Bridge imports, locate the corresponding column name in the Transition Fields 

pane and  click the  button or double-click the field to map the selected fields.

 v. If the Choose a conversion.. field is present in the Mappings pane for one or more 
mapped fields and you want to apply a conversion option, click the Choose a 
conversion .. field and select an option in the resulting list.
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 vi. To remove a field in the Mappings pane, double-click the field and then click  Yes in 
the Warning window.

Figure  10-23. Warning Message to Delete Map

Fields with a  lock icon are required and should not be removed, such as ROW Code, 
Milepost, Facility ID, and Inspection Date.

 vii. Click  Preview to view how the data in the import file would map with the configured 
mappings. Click  Close to close the preview window.

You can also click  Preview from the pane of the Definitions window to view the 
Preview Maps window. Click  Close to close the window.

Figure  10-24. Preview Maps Window

 g. Click  OK to close the field selection window and return to the definition window. 
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 h. View whether the data item is valid or not in the Validations pane. Valid data items will have the 
message <data item> is Valid in green in this pane.

Figure  10-25. Validations for Data Items

 i. Correct any problems shown in the Validations pane before continuing. Examples may include 
the following:

Figure  10-26. Validations Pane with Actions Required

 9. Click  Save to save changes to the definition.
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Set Filters for All or Selected Data Items

The Filters pane consists of a set of pre-defined filters as well as on demand filters grouped together with 
AND or OR joins. A filter group is a named set of one or more filters that affect the data returned. Adding an 
AND filter group produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. PCS processes all filters in AND filter groups 
together then processes all filters in OR filter groups together. 

If the import or export definition is set up to run at a scheduled time, the filters will apply automatically. 
However, if an import or export definition is run manually, you will be prompted to select which filters to 
apply before running the import or export definition. You can set up filters to apply to all data items or set up 
filters that apply to a single data item. 

Complete the following steps to select all or a single data item for filters:

 1. Open the Bridge definition for which you would like to add data items.

Figure  10-27. Basic Bridge Definition

 2. To filter all data items for the basic Bridge definition, click  Edit in the Bridge Filters pane of the 
Bridge definition window. 
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Figure  10-28. Filters for All Data Items

 3. To set up filters for an individual data item, select the data item and then click  Edit in the data 
item's Filters pane. 
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Figure  10-29. Filters for Single Data Item

For either method, the Edit Filter window opens. 
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Figure  10-30. Edit Filter Window

Complete the following steps to create either an AND or an OR filter group:

 1. To create a new And group, click New 'And' Group  to open the filter properties group box.         

Figure  10-31. And Group Filters 

 2. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         
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Figure  10-32. Or Group Filters 

 3. Type a name for the filter group in the Filter Group Caption field. 

 4. Select the Filter Is Always On option to keep the filter on.

 5. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 a. When adding a date filter, set a date range using a calendar or dynamic dates in one of the 
following ways:       

 l Type a date in the start and end date fields. Enter a start and end date using the format 
M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.         

 l To set a date range using dynamic start and end dates, click the  calculator icon in the 
start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields. 

 b. Type a name for the filter in the Enter Custom Filter Caption field. 

 c. If additional filters are needed within the filter group, click  and repeat these steps.       

 6. If necessary, click the  edit icon for a filter to open that filter's property settings and change 
settings as needed. 

 7. Click  Save to save the filter group.         

 8. Click  Save and Close when finished saving all filter groups.         

 10. Click  OK to close the Edit Filter window and return to the Definitions window.

Preview the Bridge Import

You can preview a Basic Bridge definition before importing the data into PCS. Bullhorn Bridge definitions do 
not have the preview function.
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NOTE: All data items must be validated and all definitions complete before you can preview the import. 
Refer to Define Data Items for Basic Bridge Definition for more information.

Complete the following steps to preview the data from a Basic Bridge definition before importing into PCS:

 1. In the Bridge Definition pane, click  Preview. 

Figure  10-33. Bridge Definitions - Preview

The Preview Status window displays in place of the Definition pane with an initial status of Queued.
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Figure  10-34. Queued Preview Status

As soon as the Bridge preview task starts, the status updates to Running. Once the initial analysis of 
the Bridge data is complete, the status updates to Previews Available, and the Preview window 
opens.

Figure  10-35. Previews Available Status
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Some data in the Preview window is shaded in a color, to identify whether the data will import into 
PCS successfully or needs attention prior to import.

The following bridge preview data properties are represented by colored cells:

 l Green — New. Indicates data that, once the bridge transition file is imported, will be entered 
into PCS.

 l Red — Rejected. Indicates invalid data that, during the bridge transition file import, PCS would 
reject and not allow in PCS.

 l Blue — Redundant. Indicates data that matches data already in PCS or elsewhere within the 
bridge transition file and therefore will not be imported.

 l Yellow — Warning. Indicates data that has warning messages. It is recommended that you 
review this data to ensure that it the data displayed is the data that you want in PCS.

 l Pink — Reformatted. Indicates the data that, during the bridge transition file import, will be 
reformatted to conform to PCS standards. It is recommended that you review this data to 
ensure that it is reformatted correctly.

 2. To filter the Preview window to show a subset of Bridge data, click on a Bridge preview data property 
button, which include the following:

 l All — shows all data rows from the bridge transition file.

 l New — shows only data rows that contain new data that would be entered into PCS once the 
bridge transition file is imported.

 l Rejected — shows only data rows that contain data that PCS would reject and not put into 
PCS.

 l Redundant — shows only data rows that contain redundant data that will not be imported.

 l Warning — shows only data rows that contain data with warning messages.

 l Reformatted — shows only data rows that contain data that, during the bridge transition file 
import, will be reformatted to conform to PCS standards. It is recommended that you review 
reformatted data to ensure that it is reformatted correctly.

 3. To filter the Preview window based on bridge preview data properties and data type, click the   icon 
next to the desired data property button. Select a data type from the New Items window and click  
Apply. 
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Figure  10-36. New Items Window

The Preview window updates to show only the data that matches the selected data property and 
data type.

 4. To clear the filter and show all data in the Preview window, click All or  Clear Filter.

 5. To sort the data in the Preview window, click  By Source or  By Intelligent Key to sort the data 
according to the original sort order of the source document or according to the data's intelligent key, 
respectively.

 6. After you have reviewed the data in the Preview window, you can either accept, reject, or defer the 
Bridge import:

 a. To reject the data in the Preview window and not import any data, click Reject in the header 
bar. The header bar turns red to indicate the data will not be imported. Click  Run.

 b. To accept the data in the Preview window and import the data, click Accept in the header bar. 
The header bar turns green to indicate the data is set to be accepted. Click  Run.

 c. To defer the data in the Preview window and postpone importing the data until a later time, 

click  Defer or  Cancel. The preview will remain available for future reviews and can be 
accessed using the Job Status tab in the Bridge window.

Add  a Bridge Import Definition for a Stationary Survey File
You can set up a Bridge definition for importing one or more stationary data logger (SDL) survey files. This 
Bridge definition specifies property settings and options for importing data in PCS, defines the data transfer 
options, and identifies the location of the SDL survey file(s).
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IMPORTANT: Bridge Import is an optional add-on that requires an activation key for operation. Running 
Bridge Import for the first time requires you to enter your Bridge activation key. If you are unable to locate 
your Bridge activation key, contact Technical Support for assistance at support@aiworldwide.com. For 
more information, refer to Activate Bridge Import for Operation on page 2.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

To add a new Bridge definition to import an SDL file, click Tools > Bridge in the header bar to open the 
Bridge window.

Click  Basic to open the basic definition pane and then perform the following tasks:

 l Set  SDL Bridge Import Properties

 l Define Data Items for SDL Imports on page 608

 l Set Filters for All or Selected Data Items on page 593 — this topic can be used for both Basic Bridge 
Definitions and Bridge Definitions for SDL survey files.                 

NOTE: It is recommended to click  Save frequently while creating the Bridge definition.

Set  SDL Bridge Import Properties

The Basic Bridge definition properties for an SDL survey file include data transfer, public option, rename file 
on bridge runs option, and reindex after import option.

Complete the following steps set basic Bridge properties for an SDL survey file:

mailto:support@aiworldwide.com?subject=AI Support
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 1. Click Tools > Bridge to open the Bridge window.

Figure  10-37. Bridge

 2. Click  Basic to open the basic definition pane. The Selected ROWs and Bridge Definitions panes 
can be moved or closed.
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Figure  10-38. Basic Bridge Definition

 3. Type a unique name for the definition in the Name field.

 4. Click the Import or Export check box for the type of Bridge you are setting up. If both Import and 
Export are checked, the data items mapped and options configured for the Bridge definition will 
apply to both the import and export Bridge runs. 

 5. Since SDL imports are typically run on-demand, there is no need to set schedule properties. 
However, if your company has SDL imports to run on a regular basis, click the Import check box and 

click the Scheduled check box next to the selected Bridge type. Click the  icon and complete the 
following steps in the Schedule Frequency window:
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Figure  10-39. Schedule Frequency Window

 a. Determine the Import or Export Start Date — enter a start date in the field provided or select 
the drop-down next to the field and select a date from the calendar that appears. The entered 
date determines when the first import or export occurs.

 b. Create a Schedule for the Imports or Exports  — decide how often Bridge imports or exports 
should run by selecting one of the following:

 i. Daily: Select Daily to perform the import or export after a certain number of days has 
passed since the last import. Enter a number in the Recurs every field and a time in the 
day(s) at field.

Figure  10-40. Schedule Frequency - Daily
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 ii. Weekly: Select Weekly to perform the import or export on certain days of the week. 
Enter a number in the field provided to determine how many weeks should pass 
between imports. Select the check box next to the day(s) of the week that the import 
should be sent.

Figure  10-41. Schedule Frequency - Weekly

 iii. Monthly: Select Monthly to perform the import or export after a certain number of 
months has passed since the last import. You can select one of the following 
schedules:

 1. Select the first radio button on the right to perform the import or export only one 
time during the month. Select the day the import will run in the Day field, the 
frequency in the of every month(s) field, and enter a time a time in the last text 
field.

Figure  10-42. Schedule Frequency - Monthly
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 2. Select the second radio button on the right to perform the import or export twice 
during specified months. Select which days the import will run in the two Day 
fields. Select the frequency in the of every month(s) field and enter a time a time in 
the second text field.

Figure  10-43. Schedule Frequency - Monthly with Specific Months and Time

 iv. Quarterly: Select Quarterly to run the import or export on the first day of every quarter. 
Enter a time in the text field.

Figure  10-44. Schedule Frequency - Quarterly

When scheduling a time to run Bridge, choose a time that does not impact other network services or 
computer resources. For example, consider a staggered time schedule instead of running Bridge at 
the same time as other scheduled network services.

 6. Click  Save to save schedule.



PCS v2.5 User Guide

Chapter 10: Bridge 608

 7. Click the Public check box if you want the import definition file available for use by all PCS users. 
When the check box is cleared, the definition file will be available only to the user who creates it.

 8. Leave the Use Facility Key unchecked. This property does not apply to SDL imports. 

 9. If you want Bridge to rename the file upon manual imports, click the Rename files on manual bridge 
runs check box. 

 10. For Bridge imports that import large amounts of data, click the Reindex after import check box to 
reindex the PCS database after the import process completes.

This prevents the system from slowing down due to index fragmentation in the PCS database. You 
can also reindex the database using the Reindex Database option in Job Service Viewer (Tools > Job 
Service Viewer).

 11. Click  Save to save definition.

Define Data Items for SDL Imports

You can add data items to the Bridge definition that will be included in the import. Each data item added 
must also be configured to ensure the fields are mapped correctly, the correct data is exported, and the 
data is exported to the desired location. 

Complete the following steps to add and configure data item(s) for import or export from PCS:
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 1. Open the Bridge definition for which you would like to add data items.

Figure  10-45. Basic Bridge Definition for Stationary Survey

 2. Click  Add Data Item to open the Data Items window.
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Figure  10-46. Data Items Window

 3. Navigate to the folder(s) containing the Stationary Survey Measurement.  Click the  icon next to a 
top-level folder to expand it.

 4. Select the data item and click the  button to move it to the right pane of the window. You can 
also double-click an item to move it. 
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Figure  10-47. Data Items - Stationary Survey Measurement

 5. Click  OK to close the window and return to the Bridge definition window. The data items are 

shown on the left side of the lower pane of the Bridge Definition window. You can click  Full View to 

view just this area. Click  Full View again to expand the view.
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Figure  10-48. Data Items Pane

 6. To assign the SDL survey to a survey folder based on the survey date, complete one or both of the 
following steps in the Options pane as required:

Figure  10-49. Data Items Options

 a. If you want to assign the SDL survey to an annual survey folder, select the  Assign inspections 
to an Annual Survey check box.

 b. If you want to assign the SDL Survey to a periodic survey folder, select the  Assign inspections 
to a Periodic Survey check box.

 7. To configure the data item added, select the data item and complete the following steps:

 a. Click the ellipsis button … in the Import File Name field to open the Import File window. 

 b. Navigate to a folder on your computer where you want to save the export file. 
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 c. Click Open to close the window and return to the definition window.

 8. In the Stationary Survey(s) window opens, select the SDL survey file.

A yellow  Snap To Facility button indicates the SDL survey file is matched to an unregistered 
milepost location. A green Snap To Facility button indicates the SDL survey file has been 
automatically matched to a milepost location already established in PCS. A blue Snap To Facility 
button indicates a match was not found for the pipeline segment or pipeline Series.

Figure  10-50. Stationary Survey(s)

 9. Click the Snap To Facility button to open the Snap To Facility window.

Figure  10-51. Snap To Facility Window

 10. When the milepost location of the SDL survey does not match a pipeline segment already 
established in PCS, it is identified as an UnRegistered Milepost.
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When the milepost location of the SDL survey does match an existing pipeline segment in PCS, use 
the Snap To Facility window to match the SDL survey to a milepost location on the pipeline segment. 
This process ensures telluric compensation calculations are accurate.

Complete the following steps match the SDL survey to an existing milepost location:

 a. Click Existing Facilities to enable the grid for use.

 b. If the pipeline segment is not selected in the ROW field, click the down arrow and select the 
pipeline segment in the selection list.

 c. Select a milepost record in the grid and then click OK to snap the SDL survey to the 
selected milepost.

 11. When the Stationary Survey(s) window opens, click  Process Files to automatically map data fields 
in the SDL survey with data fields in PCS.

Figure  10-52. Process Files / Stationary Survey(s)

After processing files, the definition window opens. The Maps pane includes a list of field mappings in 
the columns labeled Internal Field (PCS) and Transition Field (SDL survey).

 12. Map PCS fields to transition field in the Maps pane. 

Figure  10-53. Maps Pane
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 a. Click Edit to open a field selection window.

Figure  10-54. Edit Map Window

 b. Click  Auto Map to allow PCS to map PCS fields with fields from the import file based on 
column names.

 c. If the PCS field(s) you wish to map to data in a column of the imported file or to export to a file is 
not listed in the Mappings pane, navigate to and select the PCS fields in the Internal Fields 

pane and click the  button or double-click the field(s) to move the selected fields to the 
Mappings pane.

 d. Select a row in the Mappings pane and either type a column name in the Transition Field cell 
(for Bridge exports) or locate the corresponding column name in the Transition Field pane and  

click the  button or double-click the field (for Bridge imports) to map the selected fields.

 e. If the Choose a conversion.. field is present in the Mappings pane for one or more mapped 
fields and you want to apply a conversion option, click the Choose a conversion .. field and 
select an option in the resulting list.

 f. To remove a field in the Mappings pane, double-click the field and then click Yes in the 
Warning window.

Figure  10-55. Warning Message to Delete Map
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Fields with a  lock icon are required and should not be removed, such as ROW Code, 
Milepost, Facility ID, and Inspection Date.

 g. Click  Preview to view how the data in the import file would map with the configured 
mappings. Click Close to close the preview window.

 13. Apply a filter to the data item. You can set up one or more filters that are applied to only the currently 
selected data item in the import definition. If the import definition is set up to run at a scheduled time, 
the filters will apply automatically. However, if an import definition is run manually, you will be 
prompted to select which filters to apply before running the import definition. 

Click  Edit in the Filters pane and define the filters that apply to the selected data item in the Edit 
Filters window. For detailed information about editing filters, refer to Set Filters for All or Selected Data 
Items.

 14. Click  Save to save the definition file.

Add  a Bullhorn Bridge Definition
A Bullhorn Bridge definition specifies the property settings and options for importing data into PCS from a 
user account on Bullhorn Web. The definition defines the bridge frequency  and field mappings for PCS and 
data imported from Bullhorn Web. Dates imported into PCS are imported in UTC format, which may display 
differently in PCS than it did in Bullhorn Web.

The definition is defined by a name and a unique Key (token) that is generated from an Extract report in  
Bullhorn Web. Only a user with Admin privileges in Bullhorn Web can create Extracts.

Also refer to Set Bullhorn Options for information on setting options for integrating with Bullhorn Web.

After running a Bullhorn Bridge definition, PCS automatically adds the phrase Bullhorn Import in the 
Inspection Remarks field of the facility data entry grid.

To add a new Bridge definition, from the main menu click Tools > Bridge to open the Bridge window.

../../../../../Content/feat_options/Setting_Bullhorn_Options.htm
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Figure  10-56. Bridge

NOTE: External and Import Definition options are not available in the Hosted environment.

Click  Bullhorn to open the Bullhorn definition pane. Refer to the following topics for additional 
information:

 l Before Creating a Bullhorn Bridge Definition on page 617

 l Set  Bullhorn Bridge Properties on page 618

 l Map Bullhorn Bridge Fields on page 622

 l Update a Bullhorn Bridge Definition on page 627

 l Run a Bullhorn Bridge on page 636

NOTE: It is recommended to click  Save frequently while creating the Bridge definition.

Before Creating a Bullhorn Bridge Definition

When a Bullhorn Bridge definition is created in PCS, PCS attempts to automatically map RMUs to PCS 
Facilities and channel data to PCS fields if the Facility ID and Engineering Units match, respectively. This 
auto-mapping only occurs when the Bullhorn Web Facility ID and Engineering Units fields match the 
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corresponding Facilities and Fields in PCS. Therefore, before creating a Bullhorn Bridge definition, it is 
recommended that you verify all Bullhorn RMU configuration settings to match what is currently in PCS.

Complete the following best practices to help avoid issues during auto-mapping:

 l Ensure that the RMU "Engineering Units" Scaled Label from Bullhorn Web matches fields currently in 
PCS. For example:

 — Ensure that all RMUs have a Facility ID that corresponds to a PCS Facility.

 — Ensure that all RMU channels' Engineering Units are the same for a given reading type; ensure 
that the Engineering Unit aligns with PCS.

 l Correct or add information in Bullhorn Web that may be missing or different from what is in PCS. 

Refer to Update a Bullhorn Bridge Definition for information on how to fix mis-matches after creating the 
Bullhorn Bridge definition.

Set  Bullhorn Bridge Properties

NOTE: To create a Bullhorn Bridge definition, you must have a unique Key (token) that is generated from 
an Extract in  Bullhorn Web. Only a user with Admin privileges in Bullhorn Web can create an Extract.

Figure  10-57. Bullhorn Bridge Definition

Complete the following steps to add a Bullhorn Bridge definition:
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NOTE: It is recommended to click  Save frequently while creating the Bridge definition.

 1. Type a unique name for the definition in the Name field.

 2. To set the Bullhorn Bridge job to run automatically at a scheduled time, click the Scheduled check 

box. Then click the  (pencil icon) next to Scheduled and select one of the following schedules:

 a. Daily: Select Daily to perform Bullhorn imports after a certain number of days has passed since 
the last import. Enter a number in the Recurs every field and a time in the day(s) at field.

Figure  10-58. Schedule Frequency - Daily

 b. Weekly: Select Weekly to perform Bullhorn imports on certain days of the week. Enter a 
number in the field provided to determine how many weeks should pass between imports. 
Select the check box next to the day(s) of the week that the import should be sent.
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Figure  10-59. Schedule Frequency - Weekly

 c. Monthly: Select Monthly to perform Bullhorn imports after a certain number of months has 
passed since the last import. You can select one of the following schedules:

 i. Select the first radio button on the right to perform Bullhorn imports only one time during 
the month. Select the day the import will run in the Day field, the frequency in the of 
every month(s) field, and enter a time a time in the last text field.

Figure  10-60. Schedule Frequency - Monthly

 ii. Select the second radio button on the right to perform imports twice during specified 
months. Select which days the import will run in the two Day fields. Select the frequency 
in the of every month(s) field and enter a time a time in the second text field.
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Figure  10-61. Schedule Frequency - Monthly with Specific Months and Time

 d. Quarterly: Select Quarterly to run Bullhorn imports on the first day of every quarter. Enter a time 
in the text field.

Figure  10-62. Schedule Frequency - Quarterly

NOTE: When scheduling a time to run Bridge, choose a time that does not impact other network 
services or computer resources. For example, consider a staggered time schedule instead of 
running Bridge at the same time as other scheduled network services.

 3. Enter the unique Key that was generated from an Extract in your Bullhorn Web account in the 
Bullhorn Token field.



PCS v2.5 User Guide

Chapter 10: Bridge 622

NOTE: You cannot run a Bullhorn Bridge Definition without this token. 

 4. To assign survey readings to a survey folder based on the inspection date, complete one or both of 
the following as required:

 l To assign inspections to an annual survey folder, click the check box Assign inspections to an 
Annual Survey.

 l To assign inspections to a periodic survey folder, click the check box Assign inspections to a 
Periodic Survey.

 5. Click  Save. 

 6. Continue with Map Bullhorn Bridge Fields to complete the Bullhorn Bridge Definition.

Map Bullhorn Bridge Fields

After the Bullhorn Bridge definition has been saved (refer to Set  Bullhorn Bridge Properties), the Bullhorn 
Web data is imported into PCS, and matching fields are auto-mapped. However, there may be some 
records that do not map automatically. In these cases, you will need to map them manually or update the 
unit configuration in Bullhorn Web and sync the changes in PCS (refer to Update a Bullhorn Bridge 
Definition).

NOTE: Dates imported into PCS are imported in UTC format, which may display differently in PCS than it 
did in Bullhorn Web.

Complete the following steps to view mis-matched records or manually map Bullhorn Web data points to 
PCS fields:

 1. In the Mappings pane, click the All option to display all Bullhorn Web records. The following figure 
shows an example of records that were imported without being mapped to a PCS Facility. 
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Figure  10-63. Mappings pane - Expanded

Records are colored to show if they are mapped correctly. For example:

 l Green —  facility and the Bullhorn RMU are mapped correctly.

 l Red —  indicates a mismatch between Facility ID or Engineering Units. 

NOTE: Rectifier Negatives will show in red even if they are mapped correctly.

 l Yellow — warning that the record will import but may not be within the required range.
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 2. Select a PCS module from the drop-down that will receive imported data.

Figure  10-64. PCS Modules List

NOTE: You can click the  Full View button to expand the panels and hide the panel above. Click 
 Full View again to expand the window to show all panels.

 3. To view only records that do not match, select either the Facility Id Mismatch or Eng. Units Mismatch 
radio buttons. These fields will be marked in red. Fix issues with unmapped or mismatched fields, as 
needed. 

 4. Click any of the other mapping options to filter the records that display in the Mappings pane based 
on the selected option. The options include the following:

 a. Un-mapped — displays the records that do not have a mapped field. 

 b. Marked as Do Not Map — rows or records that have been marked as Do Not Map (see below).

 c. Mapped — records that have been mapped. 

 d. Has Sync Changes — something has changed from the last sync. For example, a new unit 
was installed in the field and now when syncing the import recognizes that the new unit, a 
Facility ID, or other field has changed.
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 5. If you do not want to map a record, click the Do Not Map check box for each of those Bullhorn Web 
data points.

Figure  10-65. Do Not Map Check Box

 6. You can search for a record in any of the panes using the Search field at the top of the pane. The 
search includes a "Contains" filter that looks at all fields to filter out rows that do not contain the 
keywords specified.

 7. To filter based on Facility Type, select from the selection of buttons on the banner: Test Point, 
Rectifier, Foreign Bond, Galvanic Anode, or Tank. The associated records display in the Facilities 
pane. 

Figure  10-66. Facility Types and Records - Rectifier Example

 8. Manually map PCS fields with a Bullhorn Web data point:

 a. Select a row in the Mappings pane that includes the Bullhorn Web data point and engineering 
units you want to map.
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 b. In the Facilities pane, double-click on the record to map a PCS facility to the Bullhorn Web data 
point selected in the Mappings pane.  The record is added to the Mappings pane.

Figure  10-67. Mapping Example

 c. To unmap a facility, double-click on the a mapped field in the Mappings pane. When a 
message displays, click Yes to unmap the selected field, or  No to cancel the operation.

Figure  10-68. Remove This Mapping Message

 d. If needed, in the Fields pane, map a PCS field to the Field column in the Mappings pane. 
Double-click a PCS field in the Fields pane to move it to the Field column in the Mappings 
pane. The field is added to the Mappings pane's Field column.
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Figure  10-69. Map Fields to Mappings Field Example

 e. Select another facility type as needed and map additional fields.

 9. Repeat these steps as needed. When finished, click  Save. 

Update a Bullhorn Bridge Definition

You may need to update the Bullhorn Bridge definition for changes to Bullhorn units or if mis-matches 
occur.

Refer to Before Creating a Bullhorn Bridge Definition for best practices to help avoid mis-matches.

Complete the steps outlined in each of the following scenarios, depending on why you are updating your 
Bullhorn Bridge definition:

 l If Bullhorn units are replaced (refer to Bullhorn Web Support - Replace a Unit for more information 
about replacing units):

 — In Bullhorn Web: do a unit swap (Replace) so the data from the old unit is moved to the new 
unit. 

 — In PCS: in the Mappings pane, double-click the mapping for that facility to remove the 

mapping, and click  Sync to automatically map unmapped items based on the Facility ID 
and Engineering Units and update the definition file.

 — If mismatches still appear after the Sync, edit the Bullhorn Web configurations to match PCS 
Facility ID and other Bullhorn fields.

http://support.aiworldwide.com/products/bh1/content/bullhornweb/configuration/replace_a_unit.htm?tocpath=Bullhorn%20Web%20User%20Guide%7CUnit%20Configuration%7CCommon%20Configuration%20Tasks%7CReplace%20a%20Unit%7C_____0
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Figure  10-70. Bullhorn Bridge Definition - Updating

 l If new Bullhorn units are added or existing units are removed in the unit group or if the client name 
changes:

 — In PCS, click the  Sync button to automatically map unmapped items based on the Facility 
ID and Engineering Units and update the definition file.

 l If there are mis-matches for other reasons:

 — Double-click on each mis-matched record to unmap it.

 — Click the  Sync button.

 — Select the Eng. Units Mismatch and Facility ID Mismatch radio buttons to note which records 
have mis-matched engineering units.

 — If mis-matches remain, edit the Bullhorn Web configurations for those units to match PCS 
Facility ID and the other Bullhorn fields.

 — In PCS, in the Mappings pane,  click  Sync to automatically map unmapped items based on 
the Facility ID and Engineering Units and update the definition file.

Export a Bridge Definition
Bridge definition can be exported for use by other PCS users.

Complete the following steps to export a Bridge Definition:
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 1. Click Tools > Bridge to open the Bridge window.

Figure  10-71. Bridge

 2. Open the definition you wish to export.

Figure  10-72. Bridge Definition

 3. Click  Export Definition.
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 4. Navigate the location on your computer where you would like to save the definition.

 5. If desired, change the name of the definition in the File name field.

 6. Click Save. A confirmation message displays to acknowledge the saved definition.

Figure  10-73. Exported Bridge Definition Confirmation

Import a Bridge Definition
Exported Bridge definitions can be imported.

Complete the following steps to import a Bridge Definition:
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 1. Click Tools > Bridge to open the Bridge window.

Figure  10-74. Bridge

 2. Click  Import Definition.

 3. Navigate the location on your computer where the saved definition resides.

 4. Click Open. The imported Bridge definition is added to the list of your saved Bridge definitions.

Import Pipeline Series
Use Bridge to import pipeline series in PCS. The import transition file must include fields that you can map 
to the following required PCS fields:

 l ROW Code

 l Series Number

 l Start Milepost

 l End Milepost

Refer to Set  Basic Bridge Definition Properties for more information on creating a Basic Bridge definition.
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Complete the following steps to import pipeline series:

 2. Click Tools > Bridge to open the Bridge window. Then click  Basic to open the basic definition 
pane. The Selected ROWs and Bridge Definitions panes can be moved or closed.

Figure  10-75. Basic Definition pane

 3. Type a unique name for the Bridge definition in the Name field.

 4. Click the Import check box. 

 5. If you want PCS to automatically run the import file at a scheduled time, click the Scheduled check 

box and then click the  icon to set up frequency, dates, and times for the schedule. Refer to Set  
Basic Bridge Definition Properties for additional details on schedules.

 a. When the import file is not scheduled to run automatically, click  Importto run it manually.

 b. When scheduling a time to run Bridge, choose a time that does not impact other net work 
services or computer resources. For example, consider a staggered time schedule instead of 
running Bridge at the same time as other scheduled network services.

 6. Set properties in the Options pane:

 a. Click the Public check box if you want the import definition file available for use by all PCS 
users. When the check box is empty, the definition file is available only to the user who creates 
it.
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 b. Do not enable the option Use Facility Key. It is not required to import pipeline series. See Use a 
Facility Key in Bridge on page 575 for more information if needed.

 c. If you plan to run the Bridge definition manually and want Bridge to rename the file after 
importing data, select the Rename files on manual bridge runs check box.

 7. Click  Save and then click  Full View to hide the Data Transfer and Options panes. Clicking Full 
View again displays these panes.

Clicking the  toggle button in the  information bar displays important information related to 
required property settings.

 8. Click  Add Data Item to open the Data Items window and then complete the following steps:

 a. Open the System Items folder and then double-click Series to move the data item to the right 
pane of the window.

Figure  10-76. Data Items - Series

 b. Click  OK to close the window and return to the definition pane.

 c. Click  Save.

 9. Click the ellipsis button … in the Import File Name field to open the Import File window. Navigate to 
the import file and then select it. Click Open to close the window and return to the definition pane. 
The path to the import transition file displays in the Import File Name.

 10. To assign inspections to a survey folder based on the inspection date, complete one or both of the 
following steps in the Options pane as required:
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 a. If you want to assign inspections to an annual survey folder, click the check box Assign 
inspections to an Annual Survey.

 b. If you want to assign inspections to a periodic survey folder, click the check box Assign 
inspections to a Periodic Survey.

 11. To map fields in PCS with fields in the import transition file, follow these steps:

 a. Click  Edit in the Maps pane to open a field mapping window.

Fields in the Mappings pane with  are required fields for mapping, such as ROW Code, 
Series, End Milepost, and Start Milepost.

Figure  10-77. Field Mappings

 b. If you want to sort import fields listed in the Transition Fields pane in alphabetical order, click 
the check box Sort Alphabetically.

 c. To map PCS fields with fields in the import transition file, follow these steps:

 l Select a PCS field in the Mappings pane.

 l Map the selected field to a field in the import file by double-clicking a field listed in the 
Transition Fields pane. Repeat this step for remaining fields.

When the  Auto Map option is enabled and the names of fields in the import transition file 
match those in PCS, double-clicking a PCS field in the Mappings pane automatically maps to 
an import field listed in the Transition Fields pane.

 d. Click  Preview to view how the data in the import file would map with the configured 
mappings. Click  Close to close the preview window.

 12. Click  OK to close the mapping window and return to the definition window. 

 13. Click  Save.
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Field mappings display in the Maps pane.

 14. To manually import the Pipeline Series in PCS, complete one of the following steps:

 a. If the Bridge Definitions window is open for the import file, click  Import.

 b. If the Job Status window is open, click  Run for a selected import file listed in the window. Then 

click  Refresh to update status information.

 15. To view the status of a Bridge session, click  Job Status in the Definitions window to open the Job 
Status window. Click  Log for a Bridge session opens the log file for the selected session.

 16. To view the imported Pipeline Series, click Data Entry > Pipeline Series.

When the import transition file includes facility survey readings that have also been mapped in the 
Bridge definition, PCS imports this data in the facility Inspections grid (Data Entry > Edit <module> 
Data).

Run the Bridge
To manually import or export data from PCS, click  Import or  Export.

NOTE: Refer to View Bridge Job Status and Log for information on how to view the status and log for the 
definition.

If the import or export file is set up with one or more filters, complete the following steps to select which 
filters to apply:

 1. Click the All Data Items tab. Click the check box for each filter you want to apply to all data items in 
the import or export file.

 2. Click a data item tab. Click the check box for each filter you want to apply to the selected data item.

 3. Click OK to close the Export Filters window and run the Bridge export file.

 4. When the message Completed displays, click  View Job Status to open the Job Status window or 
Return to Definition to open the Definitions window.

To view the status of a Bridge session, click  Job Status in the Definitions window to open the Job Status 
window. Click the  icon in the Log cell for a Bridge session to open the log file for the selected session.
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Run a Bullhorn Bridge
After adding a Bullhorn Bridge definition (Add  a Bullhorn Bridge Definition), PCS automatically adds the 
phrase Bullhorn Import in the Inspection Remarks field of the facility Inspection data entry grid.

Complete the following steps to manually run the Bullhorn Bridge definition:

NOTE: Refer to View Bridge Job Status and Log for information on how to view the status and log for the 
definition.

 1. From the main menu, click Tools > Bridge to open the Bridge window.

Figure  10-78. Bridge Window

NOTE: External and Import Definition options are not available in the Hosted environment.

 2. Open the Bridge definition you want to run by clicking on the name.

 3. Click  Run in the Definitions tab window.
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Figure  10-79. Definitions Tab Window

 4. In the Select a data range for manual run window opens, specify a date range for the data you want 
to import from Bullhorn Web. Type a date in the Start Date and End Date fields or click the down 
arrow in these fields to select a date using a calendar.

NOTE: The days must be within 120 days of each other.

Figure  10-80. Select a Date Range Window

 5. Click  Apply to run the Bullhorn Bridge definition.

 6. When Done displays, click View Job Status to open the Job Status window or Return to Definition to 
open the Definitions window.
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Figure  10-81. Done Window

PCS adds the phrase Bullhorn Import in the Inspection Remarks field of the facility Inspection data 
entry grid.

View Bridge Job Status and Log
Complete the following steps to view the job status and log for all types of Bridge definitions:

 1. Click Tools > Bridge to open the Bridge window.

Figure  10-82. Select Definition

 2. Click the Job Status tab to open the job status window.
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Figure  10-83. Job Status Window

 3. Select a Definition from the Definition drop-down list and/or a date range from the Date range drop-
down list.

Figure  10-84. Job Status Window

 4. Click the  icon in the Log cell for a selected definition to open a window with detailed information.

You can also view historic jobs from the Tools > Job Service Viewer menu.
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Figure  10-85. Job Summary Log
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Chapter 11: Job Service Viewer
When you need to know which job is currently running, which jobs are in the queue waiting to run, or a 
history of jobs that have run, use Job Service Viewer to view details for each of these scenarios.

This chapter  includes the following topics:

 l About Job Service Viewer on page 641

 l View Current and Past Jobs on page 645

 l Restart PCS Job Service on page 646

NOTE: For information about activating a Bridge license using Job Service Viewer, see Activate Bridge 
Import for Operation on page 2. For information about Reindex Database, see Database Management on 
page 894.

About Job Service Viewer
Information in this section explains how to view job status information for the following types of PCS jobs.

NOTE: For information about activating the optional Bridge add-on, refer to Activate Bridge Import for 
Operation on page 2. See Database Management on page 894 for information about Reindex Database.

Job Service Viewer provides status information for the type of jobs in the following list. Status information 
identifies which job is currently running, which jobs are waiting in the queue to run, and a history of 
completed jobs.
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Figure  11-1. Current Jobs

 l Bridge Import, Bridge Export, and Bridge Import/Export

 l Email Notification

 l Field Computer Receive

The Current Jobs grid displays by default when you first open Job Service Viewer. You can also display the 
grid by clicking the Current Jobs button. Use the Job Type field near the top of the window to filter data in 
the window. For example, if you only want to view Bridge job types, click the down arrow in the Job Type 
field and select Bridge in the selection list.

Information in the following table identifies the type of information that displays in the Current Jobs grid.
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Field Description

Job Type Job types include:

 l Bridge: Displays for all Bridge and Field Computer Receive jobs.

 l EmailReports: Displays for Email Notification jobs.

 l ResendEmailReport: Displays when you resend an Email Notification.

 l Reindex Database: Displays for a Reindex Database job type. For 
important information about using this function, see Database 
Management on page 894.

Direction Import displays for a Bridge import job. Export displays for a Bridge export job.

State Identifies the status of a job as:

 l Running: Job currently in progress.

 l Waiting: Job waiting in the queue to run.

 l Validated: Indicates data has been validated for a manually run Bridge 
Import job. When the job begins processing, the status changes from 
Validated to Running.

Last Update Job status date and time stamp.

Suspended When a job is in a Waiting or Validated state, clicking the gold Suspended  icon 
suspends processing of the job. Other jobs in the queue continue to process.

Clicking the  Suspended icon displays the Resume Job message. Click Yes to 
resume processing of the job or  No to continue suspending the job and close 
the message.

NOTE: A job with a Running, Completed, or Failed state cannot be suspended.

Delete If you want to delete a job that is in a Suspended state, click  Delete. Jobs in any 
other state cannot be deleted, such as Running, Waiting, Validated, Failed, or 
Completed.

Table 11-15.  Current Jobs Grid Field Descriptions       

Click the Job History button to display the Job History grid. This grid provides status information for past 
jobs (completed and failed jobs). Use the Job Type and Date range fields near the top of the window to filter 
data in the window.
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Figure  11-2. Job History

For example, if you only want to view Bridge job types for a particular date range:

 1. Click the down arrow in the Job Type field and select Bridge in the selection list.

 2. Click the down arrow in the Date range field and select an item in the selection list, such as All, Today, 
or Last 72 hours.

For a description of the various fields in the Job History grid, see the table below.

Field Description

Job Type Job types include:

 l Bridge: Displays for all Bridge and Field Computer Receive jobs.

 l EmailReports: Displays for Email Notification jobs.

 l ResendEmailReport: Displays when you resend an Email 
Notification.

 l Reindex Database: Displays for a Reindex Database job type. For 
important information about using this function, see Database 
Management on page 894.

Direction Import displays for a Bridge import job. Export displays for a Bridge export 
job.

Table 11-16.  Job History Grid Field Descriptions       
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Field Description

State Identifies the status of a job as:

 l Completed: Jobs that have run successfully are labeled Completed.

 l Failed: Jobs that have not run successfully are labeled Failed.

Enqueue Time Date and time stamp showing when a job was placed in the queue to run.

Start Time Date and time stamp showing when a job began running.

End Time Date and time stamp showing when a job finished running.

Duration Time stamp showing the total amount of time a job was processed.

Log Log with job summary information.

Detail Log Log with job summary and status information. You can also re-send an 
Email Notification report to one or more email recipients by clicking the 
ReSend check box.

Delete If you want to delete an entry in the Job History grid, select an entry and 
then click Delete. The grid also supports multiple selections by pressing 
either the Shift or Ctrl key on the computer keyboard while selecting 
multiple entries.

Table 11-16.  Job History Grid Field Descriptions        cont'd

View Current and Past Jobs
Complete the following steps to view current and past jobs:

 1. Click Tools > Job Service Viewer to open the Job Service Console.

Figure  11-3. Current Jobs
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 2. To view jobs that are currently running and in the queue, click Current Jobs.

 3. To view a list of all past jobs that have previously run, click Job History. If you want to view additional 
information about a job listed in the Job History grid, click the  icon for that job.

 4. If you want to filter the data view in the console to only view a particular job type, click the down arrow 
in the Job Type field and select an option in the list, such as Email Reports or Field Computer.

Restart PCS Job Service
PCS Job Service monitors the job queue and initiates jobs as they become available.

If the message Not Running displays in the Status field of the Job Service Console, you will need to restart 
the PCS Job Service. 

Figure  11-4. Job Service Status

Complete the following steps to verify connection settings are correct and restart the PCS Job Service:

 1. If the PCS database and PCS Job Service are installed on the same computer, start PCS Connection 
Manager and verify connection settings specify the correct server and database as follows (if not, 
refer to the next step):

 a. Verify the server name is correct in the Server field and the database name is correct in the 

Database field. If either is incorrect, click  Select in the Server field to select the correct 

server or click  Select in the Database field to select the correct database.
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Figure  11-5. PCS Connection Manager

 b. Verify the Connection String field includes the correct server and database name.

 c. Click  Save and then click  Test to verify connection settings. When connection settings 
are correct, the message Connection successful displays. 

If connection settings are incorrect, contact your company's Database Administrator or IT 
Administrator for the name of the correct server and database. The information will then need 
to be set in PCS Connection Manager using the steps in this procedure.

 d. Click  OK to close the message.

 e. Click  Close to exit PCS Connection Manager.

 f. Skip the following step and continue with the last step to restart the service.

 2. If the PCS database and PCS Job Service are installed on two different network servers, complete 
the following steps to set up a user account to log on as a service. The user account must be a 
member of the Axis_Users group and have access to the central database server and PCS 
database.

 a. Click the Windows Start button and enter Computer Management. Select the shortcut to 
open the Computer Management console.
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Figure  11-6. Computer Management Window

 b. Expand Services and Applications in the left pane of the console and then click Services to 
display a list of services in the middle pane. Search for PCS Job Service v#

NOTE: The PCS Job Service shown will reflect your current version of PCS.
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Figure  11-7. Computer Management Console

 c. Right-click PCS Job Service  and select Properties in the shortcut menu to open the Properties 
window.
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Figure  11-8. PCS Job Services Properties Window

 d. Click the Log On tab and select the This account option. To set up a user account to log on as 
a service, type the user name and password in the appropriate fields. You can also view a list 
of appropriate user accounts by clicking Browse > Advanced > Find Now.
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Figure  11-9. PCS Job Service Properties - Log On Tab

 e. Click Apply and then OK to close the Properties window and return to the Computer 
Management console.

 3. Complete the following steps in the Computer Management console to restart the PCS Job Service:

 a. Click the Windows Start button and enter Computer Management. Select the shortcut to 
open the Computer Management console.
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Figure  11-10. Computer Management Window

 b. Expand Services and Applications in the left pane of the console and then click Services to 
display a list of services in the middle pane. Search for PCS Job Service v#.

NOTE: The PCS Job Service shown will reflect your current version of PCS.
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Figure  11-11. Computer Management Console

 c. Click Start the Service.

 d. Close the Computer Management console.

 e. In PCS, verify the message Running displays in the Status field of the Job Service Console.

If the PCS Job Service does not start, contact AI Technical Support using the contact information 
in Technical Support on page 10.     
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Chapter 12: Email Notification
A PCS Admin can use Email Notification to email reports to specific people at regular intervals. Both PCS 
users and non-PCS users can be recipients of the email notifications, and the notification's report can be 
sent to multiple email addresses for an individual recipient. PDF reports are generated according to the 
email report's schedule and emailed to assigned recipients.

Email reports are configured based on any existing PCS report, though any further modifications to the 
email report will not impact the original PCS report. The data in each emailed report may vary based on the 
hierarchy that the recipient has access to in PCS, the hierarchy the recipient is set up to receive in emails, 
and the hierarchy and filters set up in the email notification.

NOTE: Email notifications can only be configured by PCS Admins.

PDF reports that contain a large amount of data may exceed the email size limit your company's email 
server allows. To help monitor this, you can configure PCS to not send emails that are larger than a 
specified file size. For instructions setting up PCS to send emails and restrict emails larger than a specific 
size, refer to Configure PCS to Send Emails.

To open the Email Notification window, click   Tools > Email Notificationfrom the main header.
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Figure  12-1. Email Notification

Refer to the following topics for detailed instructions setting up email notifications:

 l Manage Email Recipients on page 656

 l Create and Manage Email Reports on page 662

 l Manage Email Assignments on page 671

 l Review Emailed Notifications on page 673

When setting up email notifications, it is recommended that you limit the amount of data in a report to 
ensure that reports are successfully sent through the email server. This can be done by restricting a user's 
email reports to a limited hierarchy or by setting up a restrictive email report hierarchy and filter options. 

Configure PCS to Send Emails
Before you can send email notifications, PCS must be configured to send emails. To set up PCS for emails, 
go to the Email Notification tab in the Options window (Tools > Options). 

Configure the Simple Mail Transfer Protocol (SMTP) settings for your company's email server, enable or 
disable email notifications, and define email notification defaults, log retention policy, and size limitations. 
For detailed instructions on configuring PCS for emails, refer to Set Email Notification Options on page 29
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Manage Email Recipients
The Recipients tab in the Email Notification window lists all PCS and non-PCS users that can receive email 
notifications. You must add these users as a potential email recipients prior to assigning recipients to an 
email notification. When adding users to the list of recipients, you can define the hierarchy the recipient's 
emailed reports will be limited to. Any data that an email notification may contain would be further limited by 
the recipient's hierarchy defined in the Recipients tab. 

To manage email recipients, click on the Recipients tab in Email Notification.

Figure  12-2. Email Notification Recipients Tab

You can complete any of the following actions regarding emails:

 l Add an Email Recipient

 l Edit an Email Recipient

 l Remove an Email Recipient

Add an Email Recipient

To add an email recipient, access the Recipients tab of the Email Notification window and perform the 
following steps:

 1. To add a recipient that exists in User Management, click Add PCS User. The Recipients tab 
updates to show a list of PCS users add as recipients or show options to create a new external user 
as a recipient.
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Figure  12-3. Add PCS User

 2. Click   Add External User to add a recipient that does not use PCS. The Recipients tab updates to 
show options to create a new external user as a recipient.

Figure  12-4. Add External User Email

 3. Define the user by completing one of the following options:
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 l PCS User — select a user from the list. 

Figure  12-5. PCS Users

 l External User — enter a First Name, Middle Initial, and Last Name in the fields provided. 

Figure  12-6. External Users Information

 4. Define the hierarchy for the user's email notifications by selecting a Hierarchy option from the drop-
down and, if available, select the desired ROWs' check boxes in the Hierarchy pane. Any hierarchy 
defined for a recipient will be used to determine which ROWs are allowed to be included in any email 
reports to the user.
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The following options are available:

 l By Recipient Security — allows you to define the hierarchy for the recipient's email reports. 
Select the check boxes next to the desired ROWs in the Hierarchy pane to assign pipeline 
segments to the recipient's report hierarchy.

If a user's hierarchy has been limited with Hierarchy Security in User Management, the 
hierarchy defined in Email Notification will not overwrite the user's hierarchy; instead, the 
hierarchy in Email Notification is used to further restrict the data that is sent to the user in email 
reports. 

 l By Hierarchy Security — uses the hierarchy defined for the user in User Management to 
determine the ROWs to be included in an email report sent to the user. By Hierarchy Security 
will only be available in the drop-down if Hierarchy Selection is enabled in Options.

Add email addresses to the user as needed. Email notifications assigned to the user are sent to each 
email address listed for the user. Each user must have at least one email address. For each email 
address you need to add, click  Add Email and enter the email address in the field provided. Click 

 OK to save and close the window.

Figure  12-7. Add Email Address Window

 5. Click  Save to save the new recipient. The user can now be assigned to receive email notifications.

Edit an Email Recipient

To edit an email recipient, access the Recipients tab of the Email Notification window and perform the 
following steps:
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 1. Select a recipient in the list and click  Edit.

Figure  12-8. Email Receipients

 2. If available, modify the user's First Name, Middle Initial, and Last Name in the fields provided. These 
fields will only be available for edits for external users. PCS users' name can only be modified in User 
Management.

Figure  12-9. Edit Email Recipient Information

 3. Add or remove the user's email addresses as needed. Email notifications assigned to the user are 
sent to each email address listed for the user. Each user must have at least one email address. 
Perform the following as necessary:

 l To add an email address, click  Add Email and enter the email address in the field provided. 
Click  OK.
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 l To remove an email address, click  next to the email address to be removed. Email 
addresses that were defined for a PCS user in User Management cannot be removed in Email 
Notification.

Figure  12-10. Remove an Email Address for a Recipient

 4. If necessary, modify the hierarchy for the user's email notifications by selecting a Hierarchy option 
from the drop-down. Refer to Add an Email Recipient for more information. 

 5. Click  Save to save the changes to the recipient.

Remove an Email Recipient

To remove an email recipient, access the Recipients tab of the Email Notificationwindow. Select the user 
from the list, and click  Delete. 

Figure  12-11. Email Recipients
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Click Yes in the Confirm Delete window to remove the user as a potential email recipient and delete any 
existing assignments for that user. 

Figure  12-12. Confirm Delete Window

Removing a PCS user from the list of email recipients will not affect the user in User Management.

Create and Manage Email Reports
Email Reports determine an email notification's delivery settings and report contents. The time and 
frequency of the email notifications, the start date, and even the subject line of the emails can be defined, 
along with the type of report that is sent and the filters applied to the report.

An email report can include any columnar report available in the Reports/Graph menu. Custom columnar 
reports must also be set up with the public property setting. Graph reports are not currently supported in 
the Email Notification window. Email reports are set up independently of email recipients. This allows you to 
assign the same email report to more than one recipient.

Refer to the following topics for information on creating and managing email reports:

 l Create an Email Report

 l Configure or Edit an Email Report

 l Edit an Email Report

 l Send an Email Report to All Recipients

 l Reset the Last Run Date for Email Report Data

Create an Email Report

To create an email report, access the Email Reports tab of the Email Notification window and perform the 
following steps:
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Figure  12-13. Email Reports Tab

 1. Click  Add to create a new email report. The Add Associated Report window opens. 

Figure  12-14. Add Associated Report Window

 2. Select a report to serve as a base your new email report from in the list of reports in the left pane. 
Changes made to the new email report do not affect the original report and changes made in the 
future to the original report will not affect the email report.

The email report name will be used as the subject line for created emails and the identifier for the 
report creation job in the Email Notification Log and the Job Service Viewer.

 3. Click  Save. A new email report is created based on the selected report and is available for editing 
in the Email Reports tab.

 4. Refer to Edit an Email Report to set properties of the report.
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Configure or Edit an Email Report

After creating a new email report, set the properties for it. After saving the report, the report can be editing 
using the instructions in this topic.

After you create a new email report, the options for the report display in the Email Reports tab of the Email 
Notification window. 

Figure  12-15. Email Report Options

Complete the following steps to configure or edit an email report:

 1. Enter a new name for the email report in the Name field, if desired. The email report name will be used 
as the subject line for created emails and the identifier for the report creation job in the Email 
Notification Log and the Job Service Viewer.

 2. Decide How to Handle Empty Reports — select the Send No Data Found check box to send the 
email reports even when the reports contain no data. Click to clear the Send No Data Found check 
box to prevent email reports from being sent when the report contains no data.

 3. Select one of the following options from the Mode drop-down list to select how much data to include 
in the report:

 l Select Full to include all unchanged, new, and updated data in the emailed report.

 l Select Incremental to only include data that has changed as a result of changes to intelligent 
key data. Data in an incremental report would include changes to calculated or derived fields.
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 l Select Data Changed Since Last Run to include only data that has changed since the last 
report was run.

 l Select Data Inserted Since Last Run to include only data that has been added to PCS since 
the last report was run.

 4. Select an option from the Hierarchy drop-down list to determine the pipeline segments to include in 
the report:

 l Select By Assigned Recipient to only include data in the report for those pipeline segments the 
email recipient has access to, as defined for the recipient in the Recipients tab of the Email 
Notification window. If Hierarchical Security is turned on in Options, the data in the report is 
further limited by the pipeline segments defined for the recipient in User Management.

 l Select By Email Report Selection to only include data in the report for the pipeline segments 
assigned to the email report. To assign pipeline segments to the report, select the check box 
next to the desired pipeline segment in the in the Hierarchy pane.

If Hierarchical Security is turned on in Options, the data in the report is further limited by the 
pipeline segments defined for the recipient in User Management.

 5. Click the next to Frequency to set up a schedule. 

Figure  12-16. Schedule Frequency Window

 a. Decide how often the report should run by selecting one of the following:

 i. Daily: Select Daily to run the report after a certain number of days has passed since the 
report. Enter a number in the Recurs every field and a time in the day(s) at field.
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 ii. Weekly: Select Weekly to run the report on certain days of the week. Enter a number in 
the field provided to determine how many weeks should pass between imports. Select 
the check box next to the day(s) of the week that the report should be sent.

Figure  12-17. Schedule Frequency - Weekly

 iii. Monthly: Select Monthly to run the report after a certain number of months has passed 
since the last run. You can select one of the following schedules:

 1. Select the first radio button on the right to run the report only one time during the 
month. Select the day the report will run in the Day field, the frequency in the of 
every month(s) field, and enter a time a time in the last text field.

Figure  12-18. Schedule Frequency - Monthly
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 2. Select the second radio button on the right to run the report twice during 
specified months. Select which days the report will run in the two Day fields. 
Select the frequency in the of every month(s) field and enter a time a time in the 
second text field.

Figure  12-19. Schedule Frequency - Monthly with Specific Months and Time

 iv. Quarterly: Select Quarterly to run the report on the first day of every quarter. Enter a time 
in the text field.

Figure  12-20. Schedule Frequency - Quarterly

 i. Click  Saveto save schedule.

 6. Select View and Sort Options. 

 7. Add filters, if necessary. Refer to Add, Edit, and Apply an AND or Or Filter Group for more information.
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 8. Click  Save to save all changes to the email report. Click  Save and Close to return to the list of 
configured email reports. In order to send an email report to email recipients, a recipient must be 
assigned to the report. Refer to Manage Email Assignments for more information.

Edit an Email Report

After saving an email report, the report can be edited from the Email Reports tab of the Email Notification 
window. 

The changes made to the new email report do not affect the original report, and changes made in the future 
to the original report will not affect the email report.

Figure  12-21. Email Reports

Complete the following steps to edit an email report:
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 1. Select the report from the Email Report grid and click Edit. The options for the report display.

Figure  12-22. Email Report Options

 2. Edit fields and options as needed. Refer to Configure or Edit an Email Report if needed.

 3. Click  Save to save all changes to the email report. Click Save and Close to return to the list of 
configured email reports. In order to send an email report to email recipients, a recipient must be 
assigned to the report. Refer to Manage Email Assignments on page 671 for more information.

Send an Email Report to All Recipients

If an email report has one or more recipients, the report can be sent to all recipients on demand. If an email 
report is sent manually, the last run/reset date updates to the current time.

To send an email report manually, access the Email Reports tab of the Email Notification window. 
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Figure  12-23. Email Reports

Select the email report from the list and click Send. Click Yes to confirm sending the email and click OK 
when prompted. The job to create the report to send to the recipients is added to the Job Service Viewer's 
job queue.

Reset the Last Run Date for Email Report Data

If desired, you can reset the last run/incremental date for a selected email report. If an email report's last 
run/incremental date is reset, the data included in the next run of the report includes the data changed 
between the next run time and the time the reset button was pressed. Resetting the last run date is helpful 
when a large amount of data was inserted into PCS, such as through a large bridge import, and you don't 
want the report to contain the imported data.

To reset the last run/incremental date, access the Email Reports tab of the Email Notification window. 

Figure  12-24. Email Reports
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Select the email report from the list and click Reset Date. A job is added to the Job Service Viewer's job 
queue to set the current time as the new baseline for the report's data.

Manage Email Assignments
In order for a report to be sent to PCS users or external email addresses, the user must be identified as an 
email recipient in the Recipients tab of the Email Notifications window and then assigned to the report in the 
Assignments tab. Once a recipient is assigned to an email report, you can preview the report that will be 
sent to the user, change the hierarchy for an individual recipients' report, and remove a recipient from a 
report.

Add or Remove a Recipient to a Report

To assign or remove recipients to a report or to preview the report that will be sent, access the Assignments 
tab of the Email Notifications window. 

Figure  12-25. Assignments Tab

Complete the following steps to assign or remove recipients to a report or preview the report: 
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 1. Click  Add/Remove Assignments.

Figure  12-26. Assign Report By Recipient

 2. To assign or remove a single recipient to one or more reports, click By Recipient. Select an email 

recipient in the grid and then click the  button or double-click each desired report in the Available 
Email Reports pane to move the report(s) to the Assignments pane. Repeat this step as needed for 
other recipients listed in the grid. 

Figure  12-27. Available Reports and Assignment Panes
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 a. To remove a report assigned to a recipient, move the report out of the Assignments pane by 

selecting it and clicking the  button or double-clicking the name.

 3. To assign or remove one or more recipients to a single report, click By Email Report. Select an email 

report in the grid and then click the  button or double-click each desired recipient user name in 
the Available Recipients pane to move the user(s) to the Assignments pane. Repeat this step as 
needed for other email reports listed in the grid.

Figure  12-28. Assign by Email Report

 a. To remove a report assigned to a recipient, move the report out of the Assignments pane by 

selecting it and clicking the  button or double-clicking the name.

 4. Click  Save to save changes and continue or Save and Close to close the window and return to 
the Assignments tab window.

Review Emailed Notifications
The Email Notification log is an activity log that identifies PCS reports sent to email recipients. It includes a 
transmission date, whether or not email reports transmitted successfully, and set up information such as 
Frequency and Mode settings in the Email Reports tab of the Email Notification window.
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Figure  12-29. Email Reports Tab

To open the Email Notification log and review emailed notifications,  click the Log tab. 

Figure  12-30. Log Tab

Click the Date range drop-down and select a time range to narrow the list of emailed reports to those sent 
during a specific period of time.
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View the Sent Reports

To view a copy of a report sent to an email recipient:

 1. In the Email Notification window, click Log tab.

Figure  12-31. Log Tab

 2. Click  Refresh if you don't see the report in the Recipients Forpane.

 3. Select a report in the list and then select an email recipient in the Recipients For pane. Information 
related to your selections display in the Details For pane below the Recipients For pane.

Figure  12-32. Details For Pane

 4. Click  Preview to open a copy of the selected report in Adobe Reader.
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Re-send Email Notifications

Access the Log tab of the Email Notifications and complete the following steps to re-send a report to an 
email recipient:

 1. Select a report in the list and then select an email recipient in the Recipients For pane.

Figure  12-33. Log Tab

 2. Click the Re-Send check box for the selected recipient to place a check mark inside the check box.

 3. Click  Re-Send. The report is sent as a PDF attachment in an email to the recipient.

 4. Click  Refresh to update the information displaying in the window.
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Chapter 13: Field Computer
PCS can send and receive survey files from a computer, mobile device, or field computer. Those survey 
files can then be sent back to PCS for integration into your database.

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Send and Receive Files

 l Work with Themes and Filter Groups on page 693

 l View the Field Computer Log on page 717

Send and Receive Files
The procedures listed below explain how to send and receive survey files to and from your computer, a 
mobile device, or a field computer. The process for sending a survey file to a field computer or mobile device 
requires selection of a prompt, layout, and sorting method themes. If themes have not previously been set 
up in PCS, begin with the section Work with Themes and Filter Groups on page 693 and then continue with 
any of the following procedures for sending or receiving a survey file.

If you want to allow the user to add a new facility record while using the field computer or mobile device, the 
PCS user who will send surveys to the field computer or mobile device must be set up with the Can Create 
New Facilities On The Allegro option enabled. For more information about setting up a PCS user account, 
refer to User Management on page 160.

This chapter  includes the following topics:

 l Send a Facility Survey on page 678

 l Receive a Facility Survey on page 685

 l Receive an Indirect Survey on page 689
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Send a Facility Survey

You can send a facility survey to the Allegro field computer, mobile device, or  a folder on your computer. 
The survey file includes facilities for inspection based on selected pipeline segments in the Select ROWs 
window.

The facility survey can be based on any of the following:

 l Selected ROWs — the survey file includes facilities for inspection based on selected pipeline 
segments in the Select ROWs window.

 l Route — the facilities included in the survey are those that are included in a custom Route. Note that 
all facilities are included in the survey that pertain to a route regardless of what ROWs are selected in 
the hierarchy. A route needs to be created in Define Routes window (Data Entry>Define Routes) 
before it can be used to send a facility survey. Refer to Routes for additional information.

 l Schedule — the survey file includes facilities based on a defined schedule.

 l Import Exported List — based on a survey file that was previously exported and then altered by a 
third party software.

Use the following procedure when you plan to take inspection readings using the Periodic Survey software 
on the Allegro or mobile device, or if you plan to use the survey file with a third party application.

Complete the following steps to send a facility survey:

 1. If you intend to send the survey file to a field computer or mobile device, verify the device is 
connected to your computer. Refer to the device's user guide for information about how to connect 
to the device.

 2. Click Field Computer > Send to open the Field Computer Send window.
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Figure  13-1. Field Computer Send

 3. Select which option the survey file will the based on: Selected ROWs, Route, Schedule, or Import 
Exported List. 

NOTE: Click the  toggle button in the  information bar to view important information related to 
required settings.

Figure  13-2. Based on Options

 a. For Selected ROWs, select either  a facility type theme from the drop-down list or 
select/deselect the facility types you want from the group panes on the right.

NOTE: Ad Hoc Theme is automatically selected when you select or deselect individual facility 
types.

NOTE: Only public facility type themes  are available for selection from the drop-down lists. If 
you would like to use a private theme, your company's system administrator must make your 
private theme a public one.
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Figure  13-3. Facility Type Drop-down List

If using Ad Hoc Theme, click the check box for each facility type you want to view in the grid, or 

click the  Select All button  to select all facility types.

Figure  13-4. Ad Hoc Theme Radio Button

NOTE: An Ad Hoc Theme only applies to the current session and is not saved. A facility type is 
selected when a check mark appears inside the check box. To clear the check mark, click the 
check box again.

 b. For Route, select a Route from the drop-down list. If you don't see the desired route, make 
sure you have at least one ROW Code selected that has facilities contained in the route.

Figure  13-5. Field Computer Send - Route

 c. For Schedule, select a schedule definition from the drop-down list.
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Figure  13-6. Field Computer Send - Schedule

 i. Select Start Date and End Date using the format MM/DD/YYYY to indicate the month, 
day, and year.

 1. For a dynamic date range, click the icon to expand the fields. Select a Start 
Date from the drop-down list, enter an offset value in the second field, and select 

the time period from the third field's drop-down list. Click the to close. If 
desired, repeat for the End Date.

Figure  13-7. Dynamic Dates Start Date Drop-down

 d. For Import Exported List, click the  … icon in the Import Exported List field to display the Open 
window. Navigate to the altered survey file and select it. Click Open to close the window and 
return to the Field Computer Send window.

 4. To include historical readings for each selected facility, enter the number of readings to include in the 

Previous Reading Count field. To not include any historical readings, enter 0. The maximum amount 
of readings that can be entered here is defined in Options. Refer to Set Field Computer Options on 
page 32 for more information about the maximum number of readings.

These readings are stored in a .hst file that is included in the .dat file.

Figure  13-8. Previous Reading Count
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 5. If the Predefined Repair Codes check box is available for selection, click the check box to pre-
populate a repair code in the maintenance repair code field.

This option is only available when the repair code for the facility is a picklist (refer to Edit a Standard or 
Dynamic Picklist), and the facility repair code prompt is included in the currently selected prompt 
theme.

 6. Click  Apply to update the grid.

 7. In the View pane, select a prompt, layout, and sorting theme:

Figure  13-9. View Pane

NOTE: For Import Exported List, only the Select Prompt Theme field is available.

 a. Click the down arrow in Select Prompt Theme and select a prompt theme in the selection list.

 b. Click the down arrow in Select Layout Theme and select a layout theme in the selection list.

 c. If available, click the down arrow in Select Sort Theme and select a sorting theme in the 
selection list. The Select Sort Theme option may not be available if Selectable Sorting themes 
were pre-selected as part of the Prompt.

 d. For Scheduled option, also select a Sort Dates option - Oldest First or Newest First.

Figure  13-10. Scheduled Option Sort Dates

 8. In the Options pane, complete the following selections:

Figure  13-11. Options Pane
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 a. Type a name in the Output File field if you want to rename the file.

 b. Select one of the options for where to send the file:

 l  Send to Allegro -  for sending facility survey data directly to Allegro QX field computers.

 l Send Allegro to Disk -  for file-based transfers of facility survey data to Allegro QX field 
computers.

 l Send to Mobile -  for sending facility survey data directly to Mesa 3 and Allegro AX field 
computers running the PCSField Data Collector app. 

 l Send Mobile to Disk - for file-based transfers of facility survey data to Mesa 3 and 
Allegro AX field computers running the PCSField Data Collector app. 

NOTE: PCSField Data Collector file formats can be exported directly without use of a 
transformation tool.

 l Send to Cloud - for sending facility surveys to [[[Undefined variable productsInfo_
ai/cn/sm.softwareName]]] using PCS Wirelessly Sync. Existing configurations and 
customizations can be used when sending survey data to the cloud. 

NOTE: The Send to Cloud option will not appear if no token is configured in the 
Integration pane under Options. Refer to Set Integration Options for details.

 c. To include historical readings for each selected facility,  type the number of readings to include 
in the Number of Previous Readings field. The maximum amount of readings that can be 
entered here is defined in Options. Refer to Set Field Computer Options on page 32 for more 

information about the maximum number of readings. These readings are stored in a .hst file.

 d. If the Predefined Repair Codes check box is available for selection, click the check box to pre-
populate a repair code in the maintenance repair code field. This option is only available when 
the repair code for the facility is a picklist (refer to Edit a Standard or Dynamic Picklist), and the 
facility repair code prompt is included in the currently selected prompt theme.

 e. For the Send to Allegro Disk and Send to Mobile Disk options, enter the output directory 
location in the Output Directory field or search for the directory using the ... ellipses button to 
locate the directory.

 f. For Send to Mobile options (for mobile devices such as the Allegro AX or Mesa 3), select an 
Output Device from the drop-down list.
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Refer to the following Allegro or mobile device user guides for more information on using these 
devices:

 l Allegro QX Support Site.

 l PCS Field Data Collector Support Site for the Allegro AX and Mesa 3.

 9. OPTIONAL: If you want to work with a subset of facility records that meet certain filter conditions, 
complete the following steps:

 a. Click  Filters to open the Filters pane.

Figure  13-12. Filters Pane

 b. Click  (add) to open the filter properties group box.

Figure  13-13. Filter Criteria

 c. Select a PCS field, operator, and filter condition(s) using filter selection fields.

 d. To add additional filters, click  to add another row of filter selection fields. Select a PCS field, 
operator, and filter condition(s) to set up filter criteria. 

 e. Repeat as needed. 

 f. You can also add 'And' and 'Or' filters to the list of filter. Refer to Work with Themes and Filter 
Groups for more details about these types of filters.

 g. When finished, click  Filters to close the Filters pane.

NOTE: The filters are used only for the current session. If you close and return to this window, 
the filters will not be set. To save any filter settings, you will need to customize the setup in the 
Customize window.

http://support.aiworldwide.com/products/al2/content/topics/index.htm
http://support.aiworldwide.com/products/al3/content/topics/index.htm
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 10. Click  Apply to update the grid.

 11. Click  Send. Based on your selection earlier, the survey file is sent to the specified location. If the 
Send to Cloud option is selected, a progress window is displayed.

Figure  13-14. Send to Cloud Progress Window

 12. When a message displays confirming the send process is complete, click  OK to close the 
message.

If you selected to send the survey file to a field computer or mobile device, PCS sends the survey file 

to the PSData folder on the device.

Figure  13-15. Send Process Complete

IMPORTANT: Facility survey data sent to the cloud must be imported into [[[Undefined variable 
productsInfo_ai/cn/sm.softwareName]]]. Refer to Import Facility Survey Data for details. 

Receive a Facility Survey

Facility data can include periodic surveys or other types of facility data.

Complete the following steps to receive facility data into PCS from a field computer, a storage location on 
your computer, or a mobile device:

http://support.aiworldwide.com/products/cn1/content/feat_facilitysurvey/facility_import.htm?tocpath=PCS%20Survey%20Manager%20User%20Guide%7CFacility%20Survey%20Module%7C_____3
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 1. If receiving data directly from a field computer or mobile device, verify the device is connected to your 
computer. If needed, refer to the device's user guide for information about how to connect the 
device.

Refer to the following Allegro or mobile device user guides for more information on using these 
devices:

 l Allegro QX Support Site.

 l PCS Field Data Collector Support Site for the Allegro AX and Mesa 3.

 2. Click Field Computer > Receive to open the Field Computer Receive Data window.

Figure  13-16. Field Computer Receive

 3. Click Receive Facility Data radio button.

 4. Identify the location of the survey data by doing one of the following:

 l To receive data directly from a connected field computer, click the Allegro option.

 l To receive data that has been saved to a file on your computer,  click the Disk option. Click the 
Choose Folder ellipsis and navigate to and select the folder containing the  (.dat or .dva) files. 
Click OK. The field updates to list the path to the selected folder.

 l To receive data from a mobile device, such as the Allegro AX or Mesa 3, click Mobile and 
select your device from the drop-down field. If the device does not display, click Refresh. Refer 
to the CartoPac Cathodic Protection Support Site for more information about connecting the 
Allegro AX or Mesa 3 to your computer.

http://support.aiworldwide.com/products/al2/content/topics/index.htm
http://support.aiworldwide.com/products/al3/content/topics/index.htm
http://support.aiworldwide.com/products/al3/content/topics/index.htm
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 5. To receive data that has been saved to a file on your computer,  click the Disk option. Click the 
Choose Folder ellipsis and navigate to and select the folder containing the field computer (.dat or 
.dva) files. Click OK. The Choose Folder field updates to list the path to the selected folder.

 6. Click  Retrieve Data to view a list of periodic survey files available for selection.

Figure  13-17. Files Available from Retrieval

 7. Select the survey files you want to transfer. Click the check box for one or more survey files in the list 
of files available for selection.

 8. Click the   for a selected survey file to view the following options for assigning survey data to a PCS 
survey folder:
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Figure  13-18. Survey Assignment

 a. Select No Survey Assignments if you do not want to assign survey data to a survey folder.

 b. Select Automatic Assignment and then select one of the following options to have PCS 
automatically assign  survey data to a survey folder:

 i. Assign Survey: Select this option if you want PCS to automatically assign survey data to 
an annual or multi-year survey folder based on the inspection date of the retrieved 
survey data.

 ii. Assign Periodic Survey and Year: Select this option if you want PCS to automatically 
assign survey data to a periodic survey folder based on the inspection date of the 
retrieved survey data.

 c. Select Manual Assignment and then select one of the following options to manually select a 
survey folder for assigning field computer survey data:

 l Survey: Select this option to choose an annual or multi-year survey folder for assigning 
field computer survey data. Click the down arrow in the Survey field and select a survey 
in the selection list.

 l Periodic Survey, Year: Select this option to choose a periodic survey folder and the 
survey year for assigning the retrieved survey data. Click the down arrow in the Periodic 
Survey field and select a periodic survey folder in the selection list. Then click the down 
arrow in the Year field and select the survey year.

 d. Click Apply to all selected files to apply the selected survey folder option to all selected survey 
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files.

 e. If necessary, select another file or files and set assignment options for those.

 9. Click  Import to import selected survey file(s) into PCS.

The Field Computer Receive Status window displays showing the status of the import process.

Figure  13-19. Field Computer Receive Status

NOTE: If you are using the optional Telluric Compensation feature in PCS, inspection readings for 
subfacilities received from the Allegro field computer display in the Uncompensated On and 
Uncompensated Off fields of the Test Point Detail Inspection mini-grid. For more information, refer to View 
Test Point Inspections Eligible for Compensation on page 741.

Receive an Indirect Survey

IMPORTANT: For data to transfer properly, the name of the pipeline entered in the Segment field of the 
Allegro or mobile device close interval survey file must     match the ROW Code in PCS. The survey name 
entered in the Run field of the      close interval survey file is used to create a survey folder in PCS (Data      Entry > 
Survey Folder Maintenance). Refer to the Allegro User  Guide or the  PCS Field Data Collector User Guide 
for more information about setting properties in a close interval  survey file.

http://support.aiworldwide.com/products/al2/content/topics/index.htm
http://support.aiworldwide.com/products/al3/content/topics/index.htm
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Indirect survey data can include close interval surveys.

Complete the following steps to receive an  indirect survey file into PCS from a storage location on your 
computer, a field computer, or a mobile device:

 1. If receiving data directly from a field computer or mobile device, verify the device is connected to your 
computer. If needed, refer to the device's user guide for information about how to connect the 
device.

 2. Click Field Computer > Receive to open               the Field Computer Receive Data window.

Figure  13-20. Field       Computer Receive

 3. Click Receive Indirect Survey Data radio button.

 4. Identify the location of the survey data by doing one of the following:

 l To receive data directly from a connected field computer, click the Allegro option.

 l To receive data that has been saved to a file on your computer, click the Disk option. Click the 
Choose Folder ellipsis and navigate to and select the folder containing the  (.dat or .dva) files. 
Click OK. The field updates to list the path to the selected folder.

 l To receive data from a mobile device, such as the Allegro AX or Mesa 3, click Mobile and 
select your device from the drop-down field. If the device does not display, click Refresh.

 5. Click  Retrieve Data to view a list of periodic survey files available for selection.

 6. Select the survey files you want to transfer. Click the check box for one or more survey files in the list 
of files available for selection.

 7. Click  Import to import selected survey file(s) into PCS.
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The Field Computer Receive Status window displays showing the status of the import process.

Figure  13-21. Field Computer Receive Status

 8. If you are using pipeline Series — to associate one or more existing pipeline Series with the survey, 
complete the following steps (skip this step if you are not using pipeline Series):
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 a. Click the  next to the Row name to open the Edit Survey Information window.

Figure  13-22. Edit Survey Information

 b. Click the Row field and select a pipeline segment in the selection list that you want to associate 
with the survey.

 c. Click the Series field and select a pipeline Series in the selection list that you want to associate 
with the survey.

 d. If you want to change the date the survey was taken, click the down arrow in the Survey Date 
field and choose a survey date using a calendar. You can also type a survey date in the field 
using the format MM/DD/YYYY to indicate the month, day, and year.

 e. If you want to change the name of the survey file, type a survey name in the Survey Name field.

 f. If you want to add or change the name of the person who took the survey, type a name in the 
Surveyor field.

 g. Click OK.

 9. Click  OK to open the Field Computer Receive Status window.
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Figure  13-23. Field Computer Receive Status Window

 10. Click  to close the window.

NOTE: If you are using the optional Telluric Compensation feature in PCS, close interval survey inspection 
readings received from the Allegro field computer display in the CIS Structure P/S Uncompensated and 
CIS Structure IRF Uncompensated fields. For more information, refer to View CI Inspections Eligible for 
Compensation.

Work with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort theme. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 
themes available to all PCS users. These themes are identified with a globe icon and PCS in brackets [PCS], 

such as  [PCS] Facility ID.
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NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you would like to use 
a private theme, your company's system administrator must make your private theme a public one.

A filter group is a named set of one or more filters that affect the data output in the grid of Field Computer 
Send grid and subsequently the file sent to the Allegro. PCS provides two types of filter groups you can 
define. These include the AND and OR filter groups.

When you add a filter group, you define filter conditions that determine which records to include or exclude. 
Adding an AND filter group produces a subset of records that meet all filter conditions. Adding an OR filter 
group produces a subset of records that meet any filter condition. When you apply a filter group, PCS 
processes filters in descending order beginning with the filter at the top of the group.

The following sections describe how to add a layout theme, sort theme, and one or more optional filter 
groups. Topics include those in the following list:

 l Add a Layout Theme

 l Manage a Prompt Theme on page 701

 l Adding a Sort Theme on page 710

 l Add or Edit an AND or Or Filter Group on page 713

 l Edit and Arrange Filters and Filter Groups on page 715

Add a Layout Theme

A layout theme is a group of fields in a grid layout. Adding a new layout theme allows you to choose which 
fields you want to include in the grid and then save the layout as a theme for later use. The following 
procedure applies to the grid layout in Field Computer Send.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Click Field Computer > Send to open the Field Computer Send window.
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Figure  13-24. Field Computer Send

Complete the following steps to create a new layout theme:

 1. Choose one of the following options for displaying facility records in the grid:

 l Based on Selected ROWs  — to view facility records based on pipeline segment(s) selected in 
the Select ROWs window:
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 a. Click the Selected ROWs option.

Figure  13-25. Field Computer Send Based on Selected ROWs

 b. Choose one or more facility types using one of the following options:

 — Select a facility type theme in the drop-down list, such as  [PCS] Rectifier 
Survey.

 — Click Ad Hoc Theme and then click the check box for each facility type you want 
to view in the grid.

 — Click Select All  to view all facility types in the grid.

 c. Click  Apply to update the grid.

 l Based on a Route — To view facility records based on a route, complete the following steps:

 a. Click the Route option and then select a route in the selection box.

 b. Click  Apply.
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Figure  13-26. Field Computer Send Based on Route

 l Based on a Schedule —To view facility records based on a schedule, complete the following 
steps:

 a. Click the Schedule option. Then click the down arrow in the Select Schedule Definition 
field, and choose a schedule definition in the selection list.

Figure  13-27. Field Computer Send Based on Schedule

 b. Complete one of the following steps to either enter a schedule date range to set a 
schedule date range using dynamic dates:

 — Type a start date in the Start Date field and an end date in the End Date field.

 — To set a schedule date range using dynamic start and end dates:

 i. Click the  Start Date  to open dynamic start date fields. Set properties in 
these fields in the following manner:

 1. Click the down arrow in the Start Date field and select one of the 
following options: Today, Beginning Of Month, End Of Month, 
Beginning of Year, or End Of Year.
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 2. In the remaining two fields, type an offset value in the first field and 
then click the down arrow in the second field and select one of the 
following options: Day(s), Month(s), or Year(s). Click the  pencil 
button to close dynamic start date fields.

 ii. Click the  End Date  to open dynamic end date fields. Set properties in 
these fields in the following manner:

 1. Click the down arrow in the End Date field and select one of the foll 
owing options: Beginning Of Month, End Of Month, Beginning of 
Year, or End Of Year.

 2. In the remaining two fields, type an offset value in the first field and 
then click the down arrow in the second field and select one of the 
following options: Day(s), Month(s), or Year(s). Click the  icon to 
close dynamic end date fields.

 iii. Click the  …icon in the field to display the Open window. Navigate to the file 
and select it. Click Open to close the window and return to the Field 
Computer Send window.

 iv. Click  Apply to update the grid.

 l Based on an import exported file — To view facility records based on an import exported list 
file, complete the following steps:
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 a. Click the Import Exported List option.

Figure  13-28. Field Computer Send Based on Exported List

 b. Click the  … icon in the field to display the Open window. Navigate to the file and select it. 
Click Open to close the window and return to the Field Computer Send window.

 c. Click  Apply to update the grid.

 2. Click the  Customize tab then the  Add icon to open the New Layout Theme window.
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Figure  13-29. New Layout Theme

 3. Type a name for the layout theme in the Enter Theme Name field. If you want to create a public 
theme, click the Public check box to place a check mark inside the check box. When the check box 
is empty, the layout saves as a private theme.

 4. If you want to copy fields from another theme to the new layout theme, select the  Copy Content 
check box. Then select a theme from the  Copy Fields From Theme drop-down list.

 5. Click  OK to save changes and return to the Layouts window.

 6. Verify the name of the new layout theme displays in the Select Layout Theme field. If not, select the 
new theme from the Select Layout Theme drop-down list.

 7. Complete the following steps to add and remove fields in the new layout theme as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click All Fields.
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 b. Check the check box for the field and click   or double-click the field. 

 c. Repeat this step as needed. The grid layout theme includes all fields listed in the right pane of 
the Layouts window.

 d. To remove a field in the layout theme, select the field and click  or double-click a field listed 
in the right pane to move it to the left pane. Repeat this step as needed.

 8. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  button.

 9. Click  Save and Closeto return to the Field Computer Send window.

 10. To apply the new layout theme to the grid, click the Options tab  to open the Options window (if not 
open) and select the layout theme from the Select Layout Theme drop-down list. Click  Apply to 
update the grid.

Manage a Prompt Theme

A prompt theme is a named arrangement of fields that provide information and prompt the user for survey 
data when performing a survey using the Allegro. Prompt themes are created for specific based on modes; 
a prompt theme for a Field Computer Send based on Selected ROWs will not be available for a Field 
Computer Send based on a Route.

Adding a prompt theme allows you to choose which fields and prompts to include in the survey file sent to 
the Allegro. The same prompt theme can include multiple facility types, such as test points, rectifiers, 
bonds, valves, and so on. Each facility type can also include up to eight pages of inspection and 
maintenance prompts and information fields.

When viewing the survey file on the Allegro, prompts display in either the top or bottom frame of the 
window. Information fields display in the top frame while inspection and maintenance prompts display in the 
bottom frame. See the Allegro User Guide for more information about working with a survey file on the 
Allegro.

Refer to the following topics for more information:

 l Open the Prompts Editor

 l Add a New Prompts Theme on page 703

 l Edit a Prompts Theme on page 704

 l Use the Prompt Theme on page 710
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Open the Prompts Editor

The Prompts editor allows you to create a new prompt theme or edit an existing theme for the currently 
selected Based On mode. Once in edit mode, prompt pages can be configured for each facility type, and 
site settings (such as searchable fields, selectable sorting themes, and site lists) can be defined. 

With one or more pipeline segments selected in the Selected Rows pane, complete the following steps to 
access the Prompts editor:

 1. Click Field Computer > Send to open the Field Computer Send window.

Figure  13-30. Field Computer Send Window

 2. Select the radio dial for the based on mode that you are creating a prompt for - Selected ROWs, 
Route, Schedule, or Import Exported List.

 3. Click the Customize tab and then the Prompts tab to open the Prompts editor for the selected based 
on mode.
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Figure  13-31. Field Computer Send Prompts

The Prompts editor shows existing prompt themes for the current Based On mode. From this screen, you 
can edit a theme or create a new one. Once a prompt theme is saved, it can be used in the Field Computer 
Send window.

Refer to the following topics for more information:

 l Add a New Prompts Theme on page 703

 l Edit a Prompts Theme on page 704

 l Manage the Prompts Theme

 l Use the Prompt Theme on page 710

Add a New Prompts Theme

Follow these steps to add a prompt theme from within the Prompts editor of the Field Computer Send 
Customize window:

../../../../../Content/PCS_UserGuide/Manage_the_Prompts_Theme.htm
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 1. Click  Add to open the New Prompt window. Fields marked with  are required.

Figure  13-32. New Prompt Window

 2. Enter a name for the prompt theme in the  Enter Theme Name field.

 3. To create a public theme, click to select the Public check box. To create a private theme, leave the 
Public check box deselected.

 4. If you want to copy fields from an existing prompt theme, select the Copy Content check box. Then 
select a theme from the Copy Fields From Theme drop-down list.

If you do not want to copy fields from an existing prompt theme, click to deselect the Copy Content 
check box.

 5. Click  OK to create a prompt theme return to the Prompts page to edit the prompt theme. 

Edit a Prompts Theme

A prompt theme can contain prompt templates for multiple facility types. Each facility type's prompt 
template can contain up to eight pages of inspection and maintenance prompts and information fields. Test 
point prompt template pages can also have test point detail inspection templates. The following site 
settings can also be defined for the prompt theme: searchable fields, selectable sorting themes, and site 
lists.

To edit a prompt theme,  select a prompt theme from the Select Prompt drop-down list. Complete the 
following steps to  edit the selected prompt theme:

 l Add and edit facility type prompt templates. Refer to Manage Facility Type Prompt Templates for 
detailed instructions.
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 l Add searchable fields, selectable sorting themes, and site lists. Refer to Configure Site Settings for 
detailed instructions.

Once you are finished editing the prompt theme, you can save and close the theme or, if desired, revert your 
changes to the theme or delete the theme. Refer to Manage the Prompts Theme for more information.

Manage Facility Type Prompt Templates

Each facility type's prompt template can contain up to eight pages of inspection and maintenance prompts 
and information fields. Test point prompt template pages can also have test point detail inspection 
templates.

For each facility type's prompt template you need to edit, select the desired facility type from the Select 
Facility Type drop-down list. The prompt template for the selected facility type is loaded in the Prompts 
editor. From here you can Create Prompt Template Pages and Edit Prompt Template Pages.

Create Prompt Template Pages

Multiple pages can be created for a prompt template, with each page edited to contain different inspection 
and maintenance prompts and information fields. The information fields will appear above the horizontal line 
on the Allegro, while inspection and maintenance prompts will appear below the horizontal line. Information 
fields and maintenance prompts can exist on multiple pages, but inspection prompts can only exist on a 
single prompt page.

To add a new blank page of prompts, identify a page in the Pages pane that has not been defined by finding 
the first pair of information and inspection/maintenance numbered circles that are both gray. Click one of 
the identified gray numbered circles to load a blank page ready for editing.

To add a new page of prompts that contains the same information fields or maintenance prompts as the 
currently selected prompt page, click  Copy in the right pane of the Facility, Information and ROW Fields 
section or, if the button is available, in the right pane of the Inspection and Maintenance Fields section. A 
new page is created and with the fields from the selected section copied to the new page.

Edit Prompt Template Pages

To configure a prompt template page, click on a green numbered circle in the Pages pane that corresponds 
to the page you wish to configure and do any of the following to add, remove, or reorder fields and prompts 
from the page:

 l Add information fields — locate each field you wish to include in the left pane of the Facility, 
Information and ROW Fields section and either double-click the field(s) or select the field(s) and click 

. The field(s) move to the right pane and are included on this page in the prompt theme.

 l Remove information fields — locate each field you wish to remove in the right pane of the Facility, 
Information and ROW Fields section and either double-click the field(s) or select the field(s) and click 

. The field(s) move to the left pane and are no longer included on this page in the prompt theme.

../../../../../Content/PCS_UserGuide/Manage_the_Prompts_Theme.htm


PCS v2.5 User Guide

Chapter 13: Field Computer 706

 l Rearrange configured information fields — select a field in the right pane of the Facility, Information 

and ROW Fields section and either drag the field up or down to the desired position or click the  

or  buttons.

 l Add inspection and maintenance prompts — locate each field you wish to include in the left pane of 
the Inspection and Maintenance Fields section and either double-click the field(s) or select the field(s) 

and click . The field(s) move to the right pane and are included on this page as a prompt in the 
prompt theme. If using more than one maintenance page, be sure there are the same number of 
repair codes to match the number of maintenance pages.

 l Add test point detail inspection templates — determine how many test point detail inspection 
templates are needed and which test point subfacility inspection prompts should be added to the 
templates. Test point detail inspection templates allow an Allegro user to create test point subfacility 
records that, once imported into PCS, will be visible in the Test Point Detail Inspection pane of the 
Edit <Module> Data grid. Each test point detail inspection template on the Allegro or mobile device 
will consist of the selected Test Point Subfacility Inspection prompts, a Name prompt, and a PCS 
Field Name drop-down list. Refer to Link Multiple Subfacilities to a Parent Test Point Facility on page 
279 for more information about parent facilities and test point detail subfacilities. Also refer to the 
mobile device's user guide for more information about creating new facilities.

To define the test point detail inspection templates, enter the number of templates that will be 
included in the current test point's prompt page in the Number of Templates field in the right pane of 
the Inspection and Maintenance Fields section. Then locate the Test Point Subfacility Inspection 
Fields you wish to include in the left pane of the Inspection and Maintenance Fields section and either 

double-click the field(s) or select the field(s) and click . The field(s) move to the right pane and are 
included as prompts in the test point detail inspection templates.

Both of the fields in an exported subfacility's parent facility On/Off pair must be included in the 
prompt definition if both a Test Point Subfacility Inspection prompt and one of the fields in the 
subfacility's parent facility On/Off pair is also included in the prompt definition.

 l Remove inspection and maintenance prompts — locate each prompt you wish to remove in the right 
pane of the Inspection and Maintenance Fields section and either double-click the prompt(s) or 

select the prompt(s) and click . The prompt(s) move to the left pane and are no longer included 
on this page in the prompt theme.

 l Rearrange configured inspection or maintenance field prompts — select a prompt in the right pane 
of the Inspection and Maintenance Fields section and either drag the prompt to the desired position 

or click the  or  buttons.

Configure Site Settings

Click  Site Settings to access site settings options, such as searchable fields, selectable sorting themes, 
and site list.
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Figure  13-33. Site Settings Pane

Complete the following steps to add site list prompts that help identify one facility from another when using 
the Allegro. Site list prompts are included with each facility and can be viewed in the Allegro or mobile 
device's Site List window.

 1. In the Site List pane, click  Edit to view a list of fields available for selection in a Select Site String 
window.

Figure  13-34. Select Site Strings Window

 2. Locate and select each field you wish to use in the site list in the left pane and click the  button or 
double-click the field. The fields move to the right pane and are included in the prompt theme as part 
of the site list.

 3. To remove a field from the left pane, select the field and then click the  button or double-click the 
field.
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 4. To rearrange fields, use the  and  buttons to move fields up or down.

 5. Click  Close to return to the Prompts screen.

Add Selectable Sorting Themes

Multiple sorting themes can be sent to the Allegro or mobile device with this prompt. When multiple sorting 
themes are included with a prompt, the Allegro user will be able to change the sort order of the sites to one 
of the included sorting themes while using the field computer. If no sorting themes are selected in the 
prompt definition, the PCS user will be able to select a single sorting theme when sending data to the 
Allegro. Complete the following steps to add multiple selectable sorting themes to the prompt.

 1. In the Selectable Sorting Themes pane, click  Edit  to view a list of sort themes available for 
selection in a Select Site Sort Themes window.

Figure  13-35. Select Site Sort Theme Window

 2. Locate and select each field you wish to use in the site list in the left pane and click the  button or 
double-click the field. The fields move to the right pane and are included in the prompt theme as part 
of the site list.

 3. To remove a field from the left pane, select the field and then click the  button or double-click the 
field.

 4. To rearrange fields, use the  and  buttons to move fields up or down.

 5. Click  Close to return to the Prompts screen.

Add Searchable Fields

Complete the following steps to add searchable fields that allow an Allegro user to search for a survey 
based on values in searchable fields while using the field computer.
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 1. In the Searchable Fields pane, click  Edit  to view a list of sort themes available for selection in a 
Select Site Searches window.

Figure  13-36. Select Site Searches Window

 2. Locate and select each field you wish to use in the site list in the left pane and click the  button or 
double-click the field. The fields move to the right pane and are included in the prompt theme as part 
of the site list.

 3. To remove a field from the left pane, select the field and then click the  button or double-click the 
field.

 4. To rearrange fields, use the  and  buttons to move fields up or down.

 5. Click  Close to return to the Prompts screen.

Manage Prompt Theme

 1. Click  Save in the Customize Prompts window to save changes or 

 2. To undo all recent changes, click  Cancel. All prompt themes are reverted to their latest saved 
state.

 3. To remove the currently selected prompt theme, click  Delete   and Yes in the Confirm Delete 
window. The currently selected prompt theme is removed from PCS.

 4. To close the Prompts editor and save the prompt, click  Save and Close.

 5. To close the Prompts editor without saving, click  Close. If there are unsaved changes to a prompt 
theme in the Prompts editor, a Save Changes window displays. Click Yes to save all changes in the 
prompt themes, No to close without saving changes, or Cancel to return to the Prompts editor.

icon_black_circle_check.png
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Use the Prompt Theme

To apply the new prompt theme in the Field Computer Send screen, select the prompt theme from the 
Select Prompt drop-down list. Then click  Apply to update the Filters grid. 

Adding a Sort Theme

A sorting theme determines how PCS sorts grid records in the Field Computer Send window. Adding a 
sorting theme allows you to choose which field(s) to sort data by and if data sorts alphanumerically in 
ascending or descending order.

Complete the following steps to add a sorting theme:

 1. Click Field Computer > Send to open the Field Computer Send window.

Figure  13-37. Field Computer Send

 2. Choose a mode for displaying records in the grid by selecting the option Select ROWs, Route, or 
Schedule. Then click  Apply to update the grid.

 3. Click the  Customize tab and then  the Sorts tab.
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Figure  13-38. Sorts Window

 4. Click the  Add to open the New Sort Theme window.
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Figure  13-39. New Sort Theme

 5. Type a name for the sorting theme in the field Enter Theme Name. Fields marked with  are required.

 6. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the sorting theme saves as a private theme.

 7. If you want to copy fields from another theme to the new layout theme, select the  Copy Content 
check box. Then select a theme from the  Copy Fields From Theme drop-down list.

 8. Click  OK to save changes and return to the Sorts page.

 9. Complete the following steps to add and remove fields in the new sorting theme:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click All Fields.

 b. Check the check box for the field and click   or double-click the field. 

 c. Repeat this step as needed. The grid layout theme includes all fields listed in the right pane of 
the Layouts window.
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 d. To remove a field in the layout theme, select the field and click  or double-click a field listed 
in the right pane to move it to the left pane. Repeat this step as needed.

 10. To change the order of fields listed in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or  button.

 11. Select a sorting method for each field listed in the right pane. To sort grid records in ascending order, 

click the toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 12. Click  Save and Closeto return to the Field Computer Send window.

 13. To apply the new layout theme to the grid, click the Options tab  to open the Options window (if not 
open) and select the layout theme from the Select Sort Theme drop-down list. Click  Apply to 
update the grid.

Add or Edit an AND or Or Filter Group

You can add an AND filter group to restrict the data returned  in the grid of Field Computer Send so it only 
contains a subset of records that meet all filter conditions. The filter group applied will also subsequently the 
affect the data included in the file sent to the field computer or mobile device.

An OR filter group is a named set of one or more filters that affect the data output in the grid of Field 
Computer Send and subsequently the file sent to the field computer. Adding an OR filter group produces a 
subset of records that meet any filter condition. PCS processes filters in a filter group in descending order 
beginning with the filter at the top of the filter group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to add and/or edit an AND or an OR filter group for use in the Field Computer 
Send window:

 1. Click Field Computer > Send to open the Field Computer Send window.

 2. Choose a mode for displaying records in the grid by selecting the option Select ROWs, Route, or 
Schedule.

 3. Click  Apply to update the grid.

 4. Click the  Customize tab and then the  Filters tab to open the Filters window.

 5. To create a new And group, click New 'And' Group  to open the filter properties group box.         
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Figure  13-40. And Group Filters 

 6. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         

Figure  13-41. Or Group Filters 

 7. Type a name for the filter group in the Filter Group Caption field. 

 8. Select the Filter Is Always On option to keep the filter on.

 9. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 a. When adding a date filter, set a date range using a calendar or dynamic dates in one of the 
following ways:       

 l Type a date in the start and end date fields. Enter a start and end date using the format 
M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.         

 l To set a date range using dynamic start and end dates, click the  calculator icon in the 
start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields. 

 b. Type a name for the filter in the Enter Custom Filter Caption field. 

 c. If additional filters are needed within the filter group, click  and repeat these steps.       
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 10. If necessary, click the  edit icon for a filter to open that filter's property settings and change 
settings as needed. 

 11. Click  Save to save the filter group.         

 12. Click  Save and Close when finished saving all filter groups.         

Edit and Arrange Filters and Filter Groups

PCS processes filters in a filter group in descending order beginning with the filter at the top of the filter 
group. Filter groups are processed similarly. Information in this section explains how to edit filter property 
settings and how to arrange filters and filter groups.

Complete the following steps to edit and arrange filters and filter groups:

 1. Click Field Computer > Send to open the Field Computer Send window.

Figure  13-42. Field Computer Send

 2. Choose a mode for displaying records in the grid by selecting either the Select ROWs, Route, 
Schedule, or Import Exported List option. Then click  Apply to update the grid.

 3. Click the  Customize tab, then the Filters tab to open the Filters page.
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Figure  13-43. Edit Filters

 4. Click the  icon to display a filter's property settings.

 5. To rename a filter, type a description in the filter's name field.

 6. To change filter criteria, use filter selection fields to select a PCS field, operator, and one or more filter 
conditions.

 7. To enable a filter for all sessions of the data entry grid, click the check box Filter is Always On to place 
a check mark inside the check box. When this check box is not selected, toggle the filter on and off in 
the options page using the filter's check box.

 8. To delete a filter in a filter group, click the filter's  icon. Then click  OK in the Delete message 
window.

 9. Click the close button to close the filter's property settings group box.

 10. Click  Save and Close to close the filters page and return to the grid in Field Computer Send.

 11. To apply filter changes to the grid in Field Computer Send and subsequently in the file sent to the 
Allegro or mobile device, follow these steps:
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Figure  13-44. Filters

 a. Click the   Filters icon to open the Filters pane if it is not open.

 b. Click one or more check boxes in Filters and then click  Apply. For example, click Currently 
Active Facilities Only to only include active facilities in the grid and in the file sent to the Allegro.

 c. Click the   Filters icon to close the Filters pane.

View the Field Computer Log
The Field Computer log includes a Send Log and Receive Log. The Send Log lists the facility records sent to 
the Allegro with the date and time records were processed. Likewise, the Receive Log identifies facility 
records received in PCS from the field computer or mobile device, as well as the date and time they were 
received. Only those facility records updated by the field computer or mobile device are processed and 
included in the Receive Log.

You can use information in the Field Computer Log to:

 l verify which facility records have been sent and received

 l compare both logs to verify all facilities that were inspected contain survey data
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 l troubleshoot issues if a problem occurs during data transfer

Complete the following steps to view the Field Computer Log:

 1. Click Field Computer > Log to open the Field Computer Log window.

 2. Click the Receive Log tab to view facility records received in PCS from a field computer, mobile 
device, or disk.

Figure  13-45. Field Computer Log / Receive Log

 3. Click the Send Log tab to view facility records sent to a field computer or mobile device.
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Figure  13-46. Field Computer Log / Send Log
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Chapter 14: Telluric Compensation
After importing stationary data logger (SDL) files and field computer or mobile device survey files in PCS, 
use the information in this chapter  to prepare survey files and run telluric compensation. 

 l  PCS Telluric Compensation Set Up on page 720

 l PCS Telluric Compensation Workflow, page 1

 l Stationary Survey Maintenance on page 722

 l Run Telluric Compensation on page 740

IMPORTANT: Bridge Import is an optional add-on that requires an activation key for operation. Running 
Bridge Import for the first time requires you to enter your Bridge activation key. If you are unable to locate 
your Bridge activation key, contact Technical Support for assistance at support@aiworldwide.com. For 
more information, refer to Activate Bridge Import for Operation on page 2.

 PCS Telluric Compensation Set Up
The following tasks should be done when configuring PCS for Telluric Compensation capabilities:

 l Activate Telluric Compensation feature in PCS. Refer to Activate Telluric Compensation on page 4 
for more information.

 l View or edit default system setting for telluric threshold. Refer to Set Criteria Options on page 22for 
more information.

 l Add a layout theme for the Information data grid in the Edit ROW Detail window that includes the 
Telluric Compensation Currently Required field, which will enable the field for each pipeline segment 
requiring telluric compensation. Refer to Themes and Filter Groups for Pipeline Records on page 
217.

 l Add a prompt theme that includes Test Point Detail Inspection fields to be used with the Allegro or 
mobile device in an annual or periodic survey. Refer to Manage a Prompt Theme on page 701 in the 
Field Computer chapter for more information.

 l Add a Bridge Import Definition for importing stationary data logger (SDL) survey files. Refer to Add  a 
Bridge Import Definition for a Stationary Survey File on page 601 for more information.

mailto:support@aiworldwide.com?subject=AI Support
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 l Using Bridge Import to import data in PCS requires a Bridge activation key. Refer to Activate Bridge 
Import for Operation on page 2 for more information.

PCS Telluric Compensation Workflow
The figure below identifies the process for working with telluric compensation in PCS.

Figure  14-1. PCSTelluric Compensation Workflow

Refer to the following topics to perform the tasks described in the Telluric Compensation Workflow:

 l To enable pipeline(s) for Telluric Compensation, add a layout theme for the Information data grid in 
the Edit ROW Detail window that includes the Telluric Compensation Required field. Then enable this 
field for each pipeline segment requiring telluric compensation. Refer to Themes and Filter Groups for 
Pipeline Records on page 217 for more information.
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 l To evaluate and modify imported SDL survey files (upstream/downstream data set pairs), refer to 
Stationary Survey Maintenance on page 722.

 l To review Allegro or mobile device survey data, evaluate and modify uncompensated test point 
inspections using CPDM and/or ISM. Refer to Telluric Compensation in CPDM on page 741 and 
Telluric Compensation in ISM on page 751.

 l To run compensation in CPDM and/or ISM for test points with telluric effects, refer to Telluric 
Compensation in CPDM on page 741 and Telluric Compensation in ISM on page 751.

Stationary Survey Maintenance
Stationary Survey Maintenance allows you to determine if telluric current effects are present on a pipeline 
segment. After importing stationary surveys in PCS, use Stationary Survey Maintenance to view and edit 
stationary survey files.

You can complete the following tasks in the Stationary Survey Maintenance window:

 l View a Stationary Survey on page 722

 l Delete a Stationary Survey on page 727

 l View Telluric Summary Information on page 729

 l View a Stationary Survey Graph on page 731

 l View Compensation Runs on page 733

 l View a Survey Record Waveform on page 734

 l Match a Stationary Survey to an Existing Milepost Location on page 736

 l Exclude Survey Records in a Stationary Survey on page 738

NOTE: A stationary survey includes a pair of survey files provided by two stationary data loggers (SDLs). 
One SDL provides a survey file with upstream voltage measurements while the other SDL provides a 
survey file with downstream voltage measurements.

View a Stationary Survey

The Stationary Survey Maintenance window displays a list of imported stationary surveys and associated 
survey records. Stationary Survey Maintenance is available for use when working with either the CPDM 
module (Modules > Cathodic Protection Data Manager (CPDM)) or ISM module (Modules > Indirect Survey 
Manager (ISM)).
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These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Compete the following steps to open Stationary Survey Maintenance and view imported stationary 
surveys:

 1. Click Data Entry > Stationary Survey Maintenance.

Figure  14-2. Stationary Survey Maintenance

 2. If you want to filter the data view to view stationary surveys only for a particular time period, date 
range, or all stationary surveys, click the down arrow in the Date range field and select an option in 
the selection list. Then click  Refresh.

Survey records with a problem are identified with an  error or  warning icon in the survey records 
grid. A survey record with an error must be resolved prior to running telluric compensation. A survey 
record with a warning does not require resolution, however problems may occur during telluric 
compensation.

Conditions resulting in an  error icon include: missing ON and/or OFF voltage measurement; 
missing survey date and time. A  warning icon is present when the same voltage measurement is 
used for both the ON and OFF reading.
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Item Description

Stationary Surveys A list of stationary surveys for the pipeline segment(s) currently selected in 
the Select ROWs window display in the Stationary Surveys grid located on 
the left side of the window.

When you want to view stationary surveys for a particular time period, date 
range, or all stationary surveys, click the down arrow in the Date range field 
and select an option in the selection list. Then click Refresh to update data 
showing in the Stationary Surveys grid.

Clicking the Stationary Surveys title bar collapses the pane allowing you to 
view more of the graph and survey records grid. Clicking the title bar again 
expands the pane.

Table 14-17.  Description of Stationary Survey Maintenance Window       
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Item Description

Button/Information Bar Located above the graph is a button/information bar with the following 
features:

Snap To Facility: If the currently selected stationary survey includes 
milepost locations that do not match milepost locations in PCS, click Snap 
To Facility to open a window and match the stationary survey to an existing 
milepost location already established in PCS. Using this feature ensures 
accurate telluric compensation calculations. For more information, refer to 
Match a Stationary Survey to an Existing Milepost Location on page 736.

Stationary Survey, ROW Code, Milepost: Selecting a stationary survey 
displays related information above the graph. Information includes the 
name of the stationary survey, ROW Code (pipeline segment), and milepost 
(survey location).

Info: Click this button to open the Stationary Telluric Info window and view a 
telluric summary for the stationary survey currently selected in the 
Stationary Surveys grid. Use this feature to quickly determine if telluric 
current effects are present. For more information, refer to View Telluric 
Summary Information on page 729.

Compensation Run(s): Click this button to open the Compensation Runs 
window. Use the window to view information about a telluric compensation 
run for the currently selected stationary survey. Or if required, 
uncompensate or reverse (undo) a compensation run.

Show Waveform: This button is available for use when the currently 
selected stationary survey includes one or more survey records with a 
waveform. Click the button to open the Waveform window and view a 
survey record in a waveform graph. Refer to View a Survey Record 
Waveform on page 734 for more information.

Chart Exclusions: Click this button to show or hide excluded survey records 
in the graph. The default state shows excluded survey records as indicated 
by the highlighted button.

Table 14-17.  Description of Stationary Survey Maintenance Window        cont'd
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Item Description

Graph Selecting a stationary survey displays associated survey measurements in 
a graph. Features included with the graph include those in the following list. 
Refer to View a Stationary Survey Graph on page 731 for more information.

 l Selection Mode: Select this check box to hide or show the ON/OFF 
tooltips that display when hovering the mouse over a graph line.

 l Show Legend: Select this check box to show or hide the graph 
legend.

 l Stroke Thickness: Click the up/down arrows to adjust the thickness 
of the graph line. You can also type a value in this field to adjust the 
thickness.

 l Zoom In: If the Selection Mode check box includes a check mark, 
click the check box to clear the check mark. Then click and hold the 
mouse while dragging a selection over the graph to zoom in on the 
selected area of the graph.

 l Survey Record Selection: Click anywhere on a graph line to highlight 
the corresponding survey record in the list of survey records in the 
bottom pane. A survey record with an  arrow and a dashed selection 
box denotes a survey record selection.

Table 14-17.  Description of Stationary Survey Maintenance Window        cont'd
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Item Description

Survey Measurement 
Records

The grid in the bottom pane of the window includes a list of all survey 
measurement records associated with the stationary survey currently 
selected in the Stationary Surveys pane. Features included with this grid 
include:

Double-click Measurements To Exclude: Double-clicking a survey 
measurement record excludes it from the telluric compensation calculation. 
PCS identifies an excluded record with a red highlight; the exclusion date; 
and the name of the person who excluded the record.

Use either of the following multi-select methods to exclude several records 
at one time:

 l Press and hold the Ctrl key on your computer keyboard while 
selecting each record you want to exclude. Then click Exclude.

 l To multi-select records in sequential order, press and hold the Shift 
key, click the first record and then the last record. Click  Exclude.

Exclude: Clicking this button excludes selected survey measurement 
records from the telluric compensation calculation.

Survey Measurement 
Records

Include: To include one or more survey measurement records in the telluric 
compensation calculation that have previously been excluded, select the 
excluded record(s) and then click Include.

Filter the Data View: Click any of the following buttons to filter the data view 
in the survey measurement records grid:

Show Errors: Click this button to only view records with errors.

Show Warnings: Click this button to only view records with warnings.

Show Errors And Warning: Click this button to view only records with errors 
and warnings.

Show All: Click this button to view all records in the grid; this includes 
records with and without errors and warnings.

Table 14-17.  Description of Stationary Survey Maintenance Window        cont'd

Delete a Stationary Survey

You can delete a stationary survey with associated survey measurement records if it has not been used in 
telluric compensation. 

When a stationary survey has been used in telluric compensation, the  Delete button is disabled to prevent 
accidental deletion.
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Compete the following steps to delete a stationary survey:

 2. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

Figure  14-3. Stationary Survey Maintenance

 3. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 4. Click  Refresh.

 5. Select the stationary survey in the Stationary Surveys grid you want to delete and then click  
Delete.

 6. Click Yes in the Delete Stationary Survey message to delete the stationary survey or  No to 
cancel the operation.

Figure  14-4. Delete Stationary Survey
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View Telluric Summary Information

A telluric summary is available for each stationary survey listed in the Stationary Survey Maintenance 
window. Use this feature to quickly determine if telluric current effects are present.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to view a telluric summary for a stationary survey:

 1. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

Figure  14-5. Stationary Survey Maintenance

 2. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 3. Click  Refresh.

 4. Select a stationary survey in the Stationary Surveys grid and then click  Info to open the Stationary 
Telluric Info window.
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Figure  14-6. Stationary Telluric Info

Field Name Description

Survey Stationary survey file name.

Telluric Effects Identifies if the stationary survey shows telluric effects. Result for 
this field is either True or False.

On Avg (V) Average ON voltage measurement.

On Min (V) Lowest ON voltage measurement.

On Max (V) Highest ON voltage measurement.

Off Avg (V) Average OFF voltage measurement.

Off Min (V) Lowest OFF voltage measurement.

Off Max (V) Highest OFF voltage measurement.

Threshold (V) +/– System default telluric threshold set in system Options (Tools > 
Options > Criteria).

On Max – On Avg (V) Highest ON voltage measurement minus the average ON voltage 
measurement.

On Min – On Avg (V) Lowest ON voltage measurement minus the average ON voltage 
measurement.

Off Max – Off Avg (V) Highest OFF voltage measurement minus the average OFF 
voltage measurement.

Off Min – Off Avg (V) Lowest OFF voltage measurement minus the average OFF 
voltage measurement.

Table 14-18.  Stationary Telluric Info       
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View a Stationary Survey Graph

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to view a graph of voltage measurements associated with a stationary survey:

 1. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

 2. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 3. Click  Refresh.

 4. Select a stationary survey in the Stationary Surveys grid. A graph of survey measurements 
associated with the selected stationary survey display in the top-right pane of the window.

Figure  14-7. Stationary Survey Maintenance

The stationary survey graph supports the following functions:
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Figure  14-8. Tooltips with ON/OFF Measurements

 l Tooltips with ON/OFF Measurements: Placing the mouse over a point in the graph displays 
tooltips with corresponding ON/OFF voltage measurements.

 l Selection Mode: Select this check box to hide or show the ON/OFF tooltips that display when 
hovering the mouse over a point in the graph.

 l Show Legend: Select this check box to show or hide the graph legend. You can also click one 
or more check boxes in the graph legend to hide or show the selected graph element.

 l Stroke Thickness: Click the up/down arrows to adjust the thickness of the graph line. You can 
also type a value in this field to adjust the thickness.

 l Zoom In: If the Selection Mode check box includes a check mark, click the check box to clear 
the check mark. Then click and hold the mouse while dragging a selection over the graph to 
zoom in on the selected area of the graph. Double-click anywhere inside the graph to return to 
normal graph view.

Figure  14-9. Zoom In On Graph
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 l Survey Record Selection: Click anywhere on a graph line to highlight the corresponding survey 
record in the survey record grid in the bottom pane. A survey record with an  arrow denotes a 
selection in the grid. For example, the survey record with an On Time of 9/4/2014 2:16:11 PM 
is selected in the following example.

Figure  14-10. Select Survey Record in Grid

View Compensation Runs

Use the Show Runs link in the top grid of Stationary Survey Maintenance to view information about a telluric 
compensation run for a selected stationary survey and if required, uncompensate or reverse (undo) the 
compensation run.

Complete the following steps to view information or reverse a compensation run for a selected stationary 
survey:

 1. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

 2. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 3. Click  Refresh.

 4. Select a stationary survey in the Stationary Surveys grid and then click  Compensation Run(s) to 
open the Compensation Runs window
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Figure  14-11. Compensation Runs

 5. If you want to reverse (undo) the compensation run, click the check box associated with the 
compensation run you want to reverse. Then click  Save to reverse the selected compensation 
run.

View a Survey Record Waveform

When one or more survey records in a stationary survey include an associated waveform, click the  
Show Waveform button to open the WaveForm window and view survey measurements in both a graph 
and a grid.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to view a survey record waveform:

 1. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

 2. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 3. Click  Refresh.

 4. Select a stationary survey in the Stationary Surveys grid and then click  Show Waveform to open 
the Waveform window.
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Figure  14-12. WaveForm

The waveform supports the following functions:

 l Tooltips with ON/OFF Measurements: Placing the mouse over a point in the waveform 
displays tooltips with corresponding ON/OFF voltage measurements.

Figure  14-13. Tooltips with ON/OFF Measurements

 l Show Legend: Select this check box to show or hide the graph legend. You can also click one 
or more check boxes in the graph legend to hide or show the selected graph element.

 l Stroke Thickness: Click the up/down arrows to adjust the thickness of the graph line. You can 
also type a value in this field to adjust the thickness.
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 l Zoom In: Click and hold the mouse while dragging a selection over the graph to zoom in on the 
selected area of the graph. Double-click anywhere inside the graph to return to normal graph 
view.

Figure  14-14. Zoom In On Graph

Match a Stationary Survey to an Existing Milepost Location

When a stationary survey includes milepost locations that do not match existing milepost locations already 
established in PCS, these mileposts are identified as Unregistered Milepost. Unregistered mileposts relate 
only to the associated stationary survey and are not considered as facilities in PCS.

To ensure telluric compensation calculations are accurate, use  Snap To Facility to match milepost 
locations in a stationary survey to existing milepost locations already established in PCS.

Complete the following steps to match milepost locations in a stationary survey to existing milepost 
locations in PCS:

 2. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

 3. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 4. Click  Refresh.

 5. Select a stationary survey in the Stationary Surveys grid and then click the  Snap To Facility to open 
the Snap To Facility window .
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Figure  14-15. Snap To Facility

 6. Click Existing Facilities to enable the grid for use.

PCS automatically selects the closest existing milepost location as indicated by the highlighted 
record labeled LG123-A, 1.243 shown in the following figure. You can however change the selection 
if needed.
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Figure  14-16. Snap To Facility

 7. To snap the stationary survey to an existing milepost location, select a milepost record in the grid and 
then click  OK.

 8. When the Snap To Facility window closes, click  Save in the Stationary Survey Maintenance 
window to save changes.

Exclude Survey Records in a Stationary Survey

When a stationary survey includes one or more survey records with problems, the survey records are 
identified with an  error or  warning icon. A survey record with one or more errors must be resolved prior to 
running telluric compensation. A survey record with a warning does not require resolution, however 
problems may occur during telluric compensation.

Information in this section explains how to exclude survey records in the compensation calculation. A 
stationary survey with any of the following characteristics that include an error or warning are eligible for 
exclusion:

 l Missing ON and/or OFF voltage measurement.

 l Missing survey date and time.

 l Same voltage measurement for both the ON and OFF reading.

Complete the following steps to exclude one or more survey records in the compensation calculation:
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 2. Click Data Entry > Stationary Survey Maintenance to open the Stationary Survey Maintenance 
window.

 3. Select an option from the Date range drop-down list to filter the data view in the Stationary Surveys 
grid. 

 4. Click  Refresh.

 5. Select a stationary survey in the Stationary Surveys grid.

Figure  14-17. Select Stationary Survey

 6. If you want to filter data in the survey record grid, complete one of the following steps:

Figure  14-18. Survey Record Grid
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 a. Click  Show Exclusions to display exclusions.

 b. Click  Show Errors to only display survey records with errors.

 c. Click  Show Warnings to only display survey records with warnings.

 d. Click  Show Errors and Warnings to only display survey records with errors and warnings.

 e. Click  Show All to display all survey records related to the selected stationary survey 
including those with and without errors and warnings.

 7. Use any of the methods in the following list to exclude one or more survey records. PCS highlights 
excluded survey records in red as shown in the following figure. The fields labeled Exclusion Change 
User and Exclusion Change Date also identify who excluded the survey record and when it was 
excluded.

 l Double-click the survey record.

 l Select a survey record and then right-click the mouse and choose Exclude Selected in the 
shortcut menu that opens.

 l To select multiple survey records in consecutive order, click the first survey record, press and 
hold the Shift key, then click the last survey record. Right-click the mouse and choose Exclude 
Selected in the shortcut menu.

 l To select multiple survey records in non-consecutive order, press and hold the Ctrl key, then 
click each survey record you want to exclude. Right-click the mouse and choose Exclude 
Selected in the shortcut menu.

 8. To include a survey record in telluric compensation that has previously been excluded, select the 
excluded survey record and then click  Include.

 9. Use the  Chart Exclusions to show or hide excluded survey records in the graph.

Run Telluric Compensation
After receiving Allegro or mobile device survey files in PCS and importing, evaluating, and modifying 
stationary data logger (SDL) survey files in Stationary Survey Maintenance, use the information in this 
section to run telluric compensation and related functionality using features available in the CPDM and ISM 
modules.

 l Telluric Compensation in CPDM

 l Telluric Compensation in ISM on page 751
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Telluric Compensation in CPDM

When working with test point inspections in a periodic or annual survey that require telluric compensation, 
use the Telluric workspace in the CPDM Test Point Inspection grid to perform compensation and other 
related functions.

Test point records associated with the selected pipeline segment display in the Test Point Inspection grid 
and the Test Point Inspection Detail mini-grid. Test point inspections eligible for telluric compensation 
display in the Telluric workspace based on your selection of SDL survey files (upstream/downstream data 
set).

Refer to the following topics for more information on using Telluric Compensation in the CPDM module:

 l View Test Point Inspections Eligible for Compensation on page 741

 l Change the Compensation Requirement on page 742

 l Run Telluric Compensation in CPDM on page 744

 l Reverse a Compensation Run for a Selected Survey Date on page 748

 l Uncompensate Test Point Inspections on page 750

View Test Point Inspections Eligible for Compensation

Complete the following steps to view test point inspections eligible for telluric compensation in CPDM:

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

 1. Click Data Entry > Edit CPDM Data to open the Edit CPDM Data window.

 2. Click Inspection and then the Test Point  tab  to open the Test Point Inspection grid. Test points 
eligible for compensation include voltage measurements in the  Uncompensated On and 
Uncompensated Off fields in the Test Point Detail Inspection mini-grid.



PCS v2.5 User Guide

Chapter 14: Telluric Compensation 742

Figure  14-19. Edit CPDM Data - Uncompensated On and Off Fields

Change the Compensation Requirement

If you need to change the compensation requirement for a pipeline segment and related test point 
inspections, use the Maintenance window available in the Telluric workspace to apply the features labeled 
Add Requirement or Remove Requirement as needed.

IMPORTANT: Changing the compensation requirement must occur prior to running telluric 
compensation for the pipeline survey. The compensation requirement cannot be changed once telluric 
compensation has completed and results have been applied to the PCS database.

Complete the following steps to change the compensation requirement for a pipeline segment:

 1. Open the Telluric workspace in CPDM module. Click Data Entry > Edit CPDM Data >Inspection > 
Test Point and then the Telluric tab.

NOTE: If you see the Options window, click  Apply or press Enter.

 2. Locate the upstream and downstream SDL survey files associated with the selected pipeline 
segment by clicking the down arrow in the Survey Date field and selecting a survey date using a 
calendar. You can also type a survey date in the field using the format MM/DD/YYYY to indicate the 
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month, day, and year. Then click  Find.

 3. Click  Maintenance to open the Maintenance window and then click the Compensation 
Requirements tab.

Figure  14-20. Compensation Maintenance Window - Compensation Requirements Tab

 4. select a pipeline segment from the ROW Code and Pipe drop-down lists to view related test point 
inspections in the grid.

 5. Complete one of the following steps:

 a. To add the compensation requirement to the selected pipeline segment, click  Add 
Requirement.

 b. To remove the compensation requirement from the selected pipeline segment, click  
Remove Requirement.

After adding or removing the compensation requirement, PCS closes the Maintenance 
window and returns to the Telluric workspace.

 c. If you want to close the window without changing the current compensation requirement, click 

 Cancel to return to the Telluric workspace.
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Run Telluric Compensation in CPDM

Running telluric compensation takes place in the Telluric workspace of the Test Point Inspection grid. After 
receiving field computer or mobile device survey files and importing and evaluating SDL survey files, use the 
information in this section to run telluric compensation for test point inspections in a periodic or annual 
survey that include telluric effects and require compensation.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to run telluric compensation in CPDM module:

 1. Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > Test Point > Inspection 
> Telluric tab.

NOTE: If you see the Options window, click  Apply or press Enter.

Figure  14-21. Telluric Workspace

 2. Locate the upstream and downstream SDL survey files associated with the selected pipeline 
segment by selecting a survey date from the Survey Date calendar. You can also type a survey date 
in the field using the format MM/DD/YYYY to indicate the month, day, and year. 

 3. Click  Find.
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A list of SDL survey files related to the entered survey date display in the Stationary Surveys group 
box of the Telluric workspace.

Figure  14-22. Stationary Surveys in Telluric Workspace

 4. If you want to view a telluric summary of an SDL survey listed in the Stationary Surveys group box, 
click the Info link to open the Stationary Telluric Info window. For a description of this window, refer to 
View Telluric Summary Information on page 729.

 5. If you want to view voltage measurements associated with an SDL survey listed in the Stationary 
Surveys group box, click the Edit link to open the Stationary Survey Maintenance window. A 
description of this window is available in the section entitled Stationary Survey Maintenance on page 
722.

 6. To run telluric compensation, follow these steps:

 a. Select the SDL upstream/downstream data set pair to use in the compensation run. Click the 
check box associated with the upstream and downstream SDL survey files.

 b. Click  Run to begin the compensation process and open the Compensation Results 
window.
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Figure  14-23. Compensation Results

 c. If an error occurs during the compensation run, a  warning icon displays in the Compensation 
Results window. A description of the error and how to resolve it also display.

In the following example, the survey measurement must be changed to zero to apply no telluric 
correction and successfully run compensation. Refer to Uncompensate Test Point 
Inspections on page 750 for information about how to apply ForceZero and Exclude to survey 
measurements.

 d. When the compensation process completes, click  Preview to view a graph of 
compensation results.
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Figure  14-24. Compensation Run Preview

 e. To view more details in the graph, move your mouse over the graph.

Figure  14-25. View Additional Data on Graph
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 f. When you finish viewing the graph, click the  close button to close the graph and return to the 
Compensation Results window.

 g. If you want to apply compensation results to the PCS database, click  Save in the 
Compensation Results window.

 h. Click  Cancel to cancels the compensation process. PCS closes the window and returns to 
the Telluric workspace. Compensation results are not applied to the PCS database.

Reverse a Compensation Run for a Selected Survey Date

If you need to reverse (undo) one or more compensation runs for a selected survey date, use the 
Maintenance window available in the Telluric workspace to view a list of completed compensation runs 
available for uncompensation. After reversing a compensation run, the Test Point Inspection grid and 
associated Detail mini-grid update with uncompensated test point inspection readings for the selected 
pipeline segment.

Complete the following steps to reverse a compensation run for a selected survey date:

 1. Select the pipeline segment you want to work with in the Select ROWs window. Then click  Save to 
close the window.

 2. Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data >  Inspection > Test 
Point> Telluric tab.
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Figure  14-26. Telluric Workspace

 3. Locate the upstream and downstream SDL survey files associated with the selected pipeline 
segment by selecting a survey date from the Survey Date calendar. You can also type a survey date 
in the field using the format MM/DD/YYYY to indicate the month, day, and year. 

 4. Then click  Find. A list of SDL survey files related to the entered survey date display in the 
Stationary Surveys group box of the Telluric workspace.

 5. Click  Maintenance to open the Maintenance window.

Figure  14-27. Maintenance
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 6. If the Compensation Run(s) grid is not visible, click the Compensation Run(s) tab to view a list of 
compensation runs.

 7. Click the check box associated with the compensation run you want to reverse. Then click  Save to 

reverse (undo) the selected compensation run. Or click Cancel to close the window without 
completing the action.

Uncompensate Test Point Inspections

If you want to exclude one or more test point inspections in a compensation run, or want to change the 
inspection reading to zero (0) for one or more test points, use the Un-Compensated Inspections window in 
the Telluric workspace to apply ForceZero or Exclude as needed.

ForceZero applies no telluric correction to the selected test point inspection(s). Exclude removes the 
selected test point inspection(s) from the compensation run.

Complete the following steps to uncompensate one or more test point inspections in a compensation run:

 1. Select the pipeline segment you want to work with in the Select ROWs window. Then click  Save to 
close the window.

Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > Test Point > Inspection 
> Telluric tab.

Figure  14-28. Telluric Workspace
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 2. Locate the upstream and downstream SDL survey files associated with the selected pipeline 
segment by selecting a survey date from the Survey Date calendar. You can also type a survey date 
in the field using the format MM/DD/YYYY to indicate the month, day, and year. 

 3. Click  Find.

 4. Click  Un-Compensated Inspections to open the Un-Compensated Inspections window. 

 5. Select records you want to un-compensate either individually or click  Select All to select all 

records. To clear all selections, click  Clear All.

Figure  14-29. Uncompensated Inspections

Selected records display in green.

 6. Click the check box for each test point you want to un-compensate. Click  Save to begin the un-
compensate process or  Cancel to close the window and return to the Telluric workspace.

Telluric Compensation in ISM

When working with inspections in a close interval (CI) continuous survey that require telluric compensation, 
use the Telluric workspace in Edit ISM Data window to perform compensation and other related functions.

After selecting a CI continuous survey to work with, inspection records associated with the selected CI 
survey and pipeline segment display in the data grid of Edit ISM Data. Inspection records eligible for telluric 
compensation display in the Telluric workspace based on your selection of SDL survey files 
(upstream/downstream data set) associated with the selected CI survey.

Refer to the following topics for more information on using Telluric Compensation in the ISM module:
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 l View CI Inspections Eligible for Compensation on page 752

 l Change the Compensation Requirement on page 753

 l Run Telluric Compensation in ISM on page 755

 l Reverse a Compensation Run in ISM on page 760

 l Uncompensate CI Test Point Inspections on page 762

NOTE: Several options are available for customizing a grid layout and sorting order, as well as applying 
data filters that allow you to work with a subset of CI inspection records. For information about how to 
apply data filters, refer to Viewing Records in a Grid. Refer to Themes and Filter Groups on page 368 for 
information about customizing the grid layout and sorting order.

View CI Inspections Eligible for Compensation

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to view close interval (CI) inspections eligible for telluric compensation in ISM:

 1. If the ISM module is not open, click Modules > Indirect Survey Manager (ISM).

 2. Click Data Entry > Edit ISM Data to open the Edit ISM Data window.

Figure  14-30. Edit ISM Data

 3. Click the CIS tab to work with close interval survey data.

 4. Select a survey folder with CI inspection readings you want to run telluric compensation. Click the 
down arrow in the field Selected Continuous Survey and select a survey folder in the selection list.
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Figure  14-31. Edit ISM Data

Inspection records eligible for compensation include voltage measurements in the CIS Structure P/S 
Uncompensated and CIS Structure IRF Uncompensated fields .

Change the Compensation Requirement

If you want to change the compensation requirement for a pipeline segment and related close interval (CI) 
inspections, use the Maintenance window available in the Telluric workspace to apply Add Requirement or 
Remove Requirement as needed.

IMPORTANT: Changing the compensation requirement must occur prior to running telluric 
compensation for a pipeline segment and associated CI inspections. The compensation requirement 
cannot be changed once telluric compensation has completed and results have been applied to the PCS 
database.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

the following steps to change the compensation requirement for a pipeline segment and associated CI 
inspections:

 1. Open the CIS data grid in Edit ISM Data. Click Data Entry > Edit ISM Data  and then the CIS tab.

 2. Select a survey folder with survey readings you want to change the compensation requirement from 
the Selected Continuous Survey drop-down list.
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Figure  14-32. Edit ISM Data

 3. Click the Telluric tab  to open the Telluric workspace.

Figure  14-33. ISM Telluric Workspace

 4. Click  Maintenance to open the Maintenance window and then click the Compensation 
Requirements tab.
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Figure  14-34. Maintenance

 5. Select a pipeline segment from the ROW Code and Pipe drop-down list to view related CI 
inspections in the grid.

 6. Complete one of the following steps:

 a. To add the compensation requirement to the selected pipeline segment, click  Add 
Requirement.

 b. To remove the compensation requirement from the selected pipeline segment, click  
Remove Requirement.

After adding or removing the compensation requirement, PCS closes the Maintenance 
window and returns to the Telluric workspace.

 c. If you want to close the window without changing the current compensation requirement, click 

 Cancel to return to the Telluric workspace.

Run Telluric Compensation in ISM

Running telluric compensation takes place in the Telluric workspace of the Edit ISM Data grid. After 
receiving field computer or mobile device survey files and importing and evaluating SDL survey files, use the 
information in this section to run telluric compensation for inspections in a close interval (CI) survey that 
include telluric effects and require compensation.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to run telluric compensation in the ISM module:
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 1. Click Data Entry > Edit ISM Data and then the CIS tab to open the CIS data grid in Edit ISM Data.

 2. Select a survey folder with CI inspections that you want to run compensation from the  Selected 
Continuous Surveydrop-down list.

Figure  14-35. Edit ISM Data

 3. Click the Telluric tab  to open the Telluric workspace.
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Figure  14-36. Telluric Workspace

A list of stationary data logger (SDL) survey files related to the selected pipeline segment and CI 
survey display in the Stationary Surveys group box of the Telluric workspace.

 4. If you want to view a telluric summary of an SDL survey listed in the Stationary Surveys group box, 
click the Info link to open the Stationary Telluric Info window. For a description of this window, refer to 
View Telluric Summary Information on page 729.

 5. If you want to view voltage measurements associated with an SDL survey listed in the Stationary 
Surveys group box, click the Edit link to open the Stationary Survey Maintenance window. A 
description of this window is available in Stationary Survey Maintenance on page 722.

 6. To run telluric compensation, follow these steps:

 a. Select the SDL upstream/downstream data set pair to use in the compensation run. Click the 
check box associated with the upstream and downstream SDL survey files.

 b. Click  Run to begin the compensation process and open the Compensation Results 
window.
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Figure  14-37. Compensation Results

 c. If an error occurs during the compensation run, a  warning icon displays in the Compensation 
Results window. A description of the error and how to resolve it also display.

 d. When the compensation process completes, click  Preview to view a graph of 
compensation results.
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Figure  14-38. Compensation Run Preview

 e. To view more details in the graph, move your mouse over the graph.

Figure  14-39. View Additional Data on Graph
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 f. When you finish viewing the graph, click the  close button to close the graph and return to the 
Compensation Results window.

 g. If you want to apply compensation results to the PCS database, click  Save in the 
Compensation Results window.

 h. Click  Cancel to cancels the compensation process. PCS closes the window and returns to 
the Telluric workspace. Compensation results are not applied to the PCS database.

Reverse a Compensation Run in ISM

If you want to reverse (undo) one or more compensation runs in ISM, use the Maintenance window available 
in the Telluric workspace to view a list of completed compensation runs available for uncompensation. After 
reversing a compensation run, the data grid in Edit ISM Data updates with uncompensated close interval 
(CI) inspections.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to reverse a compensation run in ISM:

 1. Click Data Entry > Edit ISM Data and then the CIS tab to open the CIS data grid in Edit ISM Data. 

 2. Select a survey folder with CI inspections you want to reverse (undo) a compensation run from the 
Selected Continuous Survey drop-down list.

Figure  14-40. Edit ISM Data

 3. Click the  Telluric tab to open the Telluric workspace.



PCS v2.5 User Guide

Chapter 14: Telluric Compensation 761

Figure  14-41. ISM Telluric Workspace

 4. Click  Maintenance to open the Maintenance window.

Figure  14-42. Maintenance
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 5. If the Compensation Run(s) grid is not visible, click the Compensation Run(s) tab to view a list of 
compensation runs.

 6. Click the check box associated with the compensation run you want to reverse. Then click  Save to 

reverse (undo) the selected compensation run. Or click Cancel to close the window without 
completing the action.

Uncompensate CI Test Point Inspections

If you want to exclude one or more close interval (CI) inspections in a compensation run, or want to change 
the telluric compensation to zero (0) for one or more CI inspections, use the Un-Compensated Inspections 
window in the Telluric workspace to apply ForceZero or Exclude as needed.

ForceZero applies no telluric correction to the selected CI inspection(s). Exclude removes the selected CI 
inspection(s) from the compensation run.

Complete the following steps to uncompensate one or more CI inspections in a compensation run:

 1. Click Data Entry > Edit ISM Data and then the CIS tab to open the CIS data grid in Edit ISM Data. 

 2. Select a survey folder with CI inspections you want to reverse (undo) a compensation run from the 
Selected Continuous Survey drop-down list.

Figure  14-43. Edit ISM Data

 3. Click the Telluric tab  to open the Telluric workspace.
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Figure  14-44. ISM Telluric Workspace

 4. Click  Un-Compensated Inspections to open the Un-Compensated Inspections window. 

 5. Select records you want to un-compensate either individually or click  Select All to select all 

records. To clear all selections, click  Clear All.

Selected records display in green.

Figure  14-45. Uncompensated Inspections
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 6. Click  Save to begin the uncompensate process or Cancel to close the window and return to the 
Telluric workspace.



15
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Chapter 15: Themes
Facility type themes can be managed in the Facility Type Themes window. All themes can be managed in 
the Themes Management window. Both of these windows can be accessed from the Tools main menu.

NOTE: The information in this section or sections is/are intended for users with SysAdmin security 
permissions, unless noted otherwise. 

This chapter  includes the following topics:

 l Work with a Facility Type Theme

 l Manage Themes on page 770

Work with a Facility Type Theme
A facility type theme is a named set of one or more facility types, such as test point, rectifier, valve, and 
atmospheric facility types. Certain features in PCS require you to select a facility type theme to complete an 
operation, such as selecting a facility type theme when working in Define Routes (Data Entry > Define 
Routes) or Field Computer Send (Field Computer > Send).

Two types of facility type themes are available for use. They include installed and addition facility type 
themes. An installed facility type theme is one that has been installed during the PCS software installation. A 
facility type theme addition is one that you create.

Information in this section explains how to work with a facility type theme in Facility Type Themes 
Management. Topics include those in the following list:

 l Edit an Installed Facility Type Theme on page 765

 l Add a Facility Type Theme Addition on page 767

 l Edit a Facility Type Theme Addition on page 769

Edit an Installed Facility Type Theme

An installed facility type theme includes [PCS] in the name of the theme, such as  [PCS] Rectifier Survey. 
You can add or remove a facility type or revert an installed facility type theme. 

Complete the following steps to edit an installed facility type theme:
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 1. Click Tools > Facility Type Themes to open the Facility Type Themes window.

Figure  15-1. Facility Type Themes

 2. Select a PCS installed theme from the Select Facility Type Theme drop-down list, such as [PCS] 
P/S Survey.

 3. To add one or more facility types in an installed theme, click the check box for each facility type you 
want to add.

 4. Click  Save to save changes. 

 5. To remove one or more facility types in an installed theme, click the check box to clear the check 
mark for each facility type you want to remove. 

 6. Click  Save to save changes.

 7. To revert a facility type theme and restore settings prior to editing, click  Revert. Click Yes in the 
Confirm Revert message window.

Figure  15-2. Confirm Revert Message Window
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Add a Facility Type Theme Addition

Complete the following steps to add a facility type theme addition:

 1. If the Facility Type Themes window is not open, click Tools > Facility Type Themes.

Figure  15-3. Facility Type Themes Management

 2. Click  Add to open the New Facility Type Theme window.
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Figure  15-4. New Facility Type Theme

 3. Type a name for the new theme in the field Enter Theme Name.

 4. Select the Public check box if you want the new theme available to all PCS users.

When a theme is not public, it is a private theme. A public theme is available for use by all PCS users. 
A private theme is available only to the user who creates it.

 5. Select an existing facility type theme with facility types you want to copy to the new theme from the 
Copy Facility Types From drop-down list.

 6. Click  Save to save changes and close the window.

 7. To add one or more facility types in the new theme, click the check box for each facility type you want 
to add. You can also click  Select All to add all facility types in the new theme. A check mark inside 
a check box indicates a selection.
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 8. To remove one or more facility types from the new theme, click the check box to clear the check 
mark for each facility type you want to remove. You can also click  Clear All to removes all facility 
types in the new theme.

 9. Click  Save to save changes.

The facility type theme is now available for selection in the Define Routes window (Data Entry > Define 
Routes; refer to Routes on page 439) and the Field Computer Send window (Field Computer > Send; 
refer to Field Computer on page 677).

Edit a Facility Type Theme Addition

You can to add or remove facility types in a facility type theme addition or delete a facility type theme 
addition.

Complete the following steps to edit a facility type theme addition:

 1. Click Tools > Facility Type Themes to open the Facility Type Themes window.

Figure  15-5. Facility Type Themes Management

 2. Select a facility type theme addition from the Select Facility Type Theme drop-down list.

 3. To add one or more facility types, click the check box for each facility type you want to add. You can 

also click  Select All to add all facility types. A check mark inside a check box indicates a selection. 
Click  Save to save changes.
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 4. To remove one or more facility types, click the check box to clear the check mark for each facility type 
you want to remove. You can also click  Clear Allto clear all selections. Click  Save to save 
changes.

 5. To revert a facility type theme and restore settings prior to editing, click  Revert, then click  Yes 
in the Confirm Revert message window.

 6. To delete a facility type theme addition, click  Delete and then click Yes in the Confirm Delete 
message window.

Manage Themes
Themes Management allows you to perform the following tasks for any PCS installed and user-created 
theme in the system:

 l Change the Based On method for working with facility records

 l Rename a theme

 l Change a theme from Public to Private or from Private to Public

 l Assign a Private theme to a user

 l Delete a theme

 l Import and export a theme

NOTE: Importing and exporting themes is only available for form themes. Not all themes can be 
imported and exported.

Complete the following steps to manage themes in the system:
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 1. Click Tools > Themes Management to open the Themes Management window.

Figure  15-6. Themes Management

 2. Open a grid with the theme you want to edit. For example, to edit a grid layout theme, click the Editing 
tab and then the Grid Column Themes tab.

 3. To edit the Based On method for a theme:

 a. Select a theme in the grid.

 b. Select one of the options available from the Based On drop-down list to select a mode for 
displaying facility records in a data entry grid, report, or survey file sent to the Allegro field 
computer or mobile device. Options may include Selected ROWs, Route, Schedule, or 
Exported.

 4. To rename a theme, select a theme in the grid and then type a name in the Theme column cell.

 5. To change a theme from Public to Private:

 a. Select a theme in the grid and then click the  Is Publiccheck box to remove the check mark.

 b. Assign the Private theme to a user. Select a user name from the Assigned To drop-down list.
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 6. To change a theme from Private to Public, select a theme in the grid and then click the  Is Public check 
box to place a check mark inside the check box. PCS automatically removes the user name 
associated with the private theme in the Assigned To column cell.

 7. To delete a theme, select a theme in the grid and then click  Delete. Click Yes in the Confirm Delete 
message window to confirm the deletion. 

 8. To import a previously exported theme, select a theme in the grid and click  Import. Navigate to 
and select an exported theme (.csv or .txt) file and click Open then Yes to import the selected theme.

 9. To export a theme to a file, select a theme in the grid and click Export.  Navigate to a location on 
your hard drive or network, enter a name in the field provided, and click Save to export the selected 
theme.
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Chapter 16: Reports and Graphs
PCS can generate and several different reports and graphs based on the data within your database.

Most PCS users can generate these reports and graphs.

The reports and graphs are available from the Reports/Graphs main menu.

This chapter  includes the following topics:

 l Value of PCS Reports

 l KPI Dashboard

 l Overview of Reports on page 789

 l Work With Reports Based on a Style on page 814

 l Add a Custom Report on page 823

 l Report Themes and Filter Groups on page 827

Value of PCS Reports
PCS reporting supports a variety of business applications. A few example include managing data collection 
and data entry, reviewing the quality of cathodic protection (CP) data, providing information for an audit, 
and examining the effectiveness of a maintenance program.

The following list describes how you can use PCS reporting in your business:

 l Manage data collection and data entry.

Provide a printed copy of the Survey Report or Data Collection Report to technicians and vendors for 
recording CP data in the field. Update the PCS database using completed reports submitted by 
technicians and vendors. Using PCS reports in this manner allows you to verify consistent data 
collection and data entry in PCS.

 l Review data quality.

Use PCS reporting to check the quality of survey data submitted by vendors. The quickest method is 
to view the Survey Report to determine which facilities have not been surveyed. Blank report fields 
indicate no survey data. If a vendor is using the Allegro field computer to collect survey data, view the 
Field Computer Log to determine which facilities have not been surveyed.
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Another method for checking the quality of survey data is to generate an Exceptions or Comparisons 
report. The Exceptions report allows you to compare surveys from previous years. Look for dramatic 
changes between surveys. You can also use the Exceptions report to check for data entry mistakes. 
This is helpful when range checking is not used or when personnel enter data using survey data 
recorded in a printed form. The Comparisons report compares multiple years of survey data. Use the 
Comparisons report to review changes in data and check for mistakes that might have been made 
during data entry.

 l Provide information for an audit.

The Survey Report and facility Inspections Graph contain most of the information needed for an 
audit. When an audit requires more specific information, create a custom facility report using a 
columnar, summary, or graph report style.

To prepare for an audit, generate a Delinquency Report to help with creating a plan for bringing a 
pipeline system into compliance. Another method for preparing for an audit is to generate a Survey 
Report or any custom summary report to provide data for an audit. All other PCS reports are also 
beneficial in providing information for an audit.

 l Determine the effectiveness of a maintenance program.

PCS reporting provides several reports and graphs that help with determining the effectiveness of a 
maintenance program. For example, use the CPDM Rectifier Output History Report to review the 
output of a rectifier over time. Look for changes in the rectifier output and any survey remarks or 
permanent comments that identify reasons for the change. Another method for determining a 
maintenance program's effectiveness is to generate the Survey Report and review the number of 
inspection readings for a particular survey period. Also look for changes among facilities.

KPI Dashboard
Key performance indicators (KPIs) are displayed on a dashboard for easy access to database information. 

The dashboard can be access through the Reports/Graphs > Dashboard menu.
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Figure  16-1. KPI Dashboard

Before data can be visualized on the dashboard, you must run four bridge definitions. Refer to Set Up the 
KPI Dashboard for additional information.

The dashboard includes the following KPIs:

 l Survey Completion — displays the percentage of facilities that have an inspection marked as 
Surveyed in the filtered date range in the current hierarchy selection.

 l Facilities by Type — displays the number of facilities in the current hierarchy selection.

 l Maintenance Status — displays the current status of all maintenance items that fall into the filtered 
date range in the current hierarchy selection.

 l Test Point Exceptions — displays the number of exception for the most recent inspection records 
that violates the following criteria:

 — Structure Below Criteria: shows the number of inspections that are not meeting their defined 
Test Point Protection Criteria.

 — Shorted Casing: shows the number of inspections that have a Structure P/S-Casing P/S 
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within the threshold defined in Options.

 — High AC P/S: shows the number of inspections that have and AC PS reading greater than 3.

You can view source data associated with any of the KPIs by selecting a subsection of an individual KPI. 
Refer to Drill Down into Dashboard Data for additional information.

The dashboard can be filtered by active facilities, date range, and facility type.
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Figure  16-2. Dashboard Filters

 l Facility Type — select a facility type theme or Ad Hoc Theme. For Ad Hoc Theme, select either  
Select All or individual facility types.
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 l Active Facilities — select either Active or All.

 l Date Range — select begin and end dates from the drop-down fields. You can also use the slider 
above the fields to adjust either date. 

Figure  16-3. Date Range Slider

 — Click and slide the  icon on the slider to adjust the begin date.

 — Click and slide the   icon on the slider to adjust the end date.

 l Reset to Default — resets the filter to original settings.

The KPI Dashboard updates as changes are made.

Set Up the KPI Dashboard

The data that is displayed on the KPI (key performance indicators) Dashboard (Reports/Graphs > 
Dashboard) comes directly from your database.

When first setting up PCS 2.5 you must run four bridge definitions that are automatically added to your list of 
bridge definitions. For the dashboard to update on an automated basis, ensure that the dashboard has 
been configured to run automatically to ensure that all changes to the database are captured and available 
to display on the dashboard. Refer to  Set  Basic Bridge Definition Properties for more information on setting 
schedules for Bridge definitions.

NOTE: Changes to the database will not be available for display on the dashboard until the four dashboard 
bridge definitions are run.

The pre-defined bridge definitions that are used to populate the KPI Dashboard include:

 l Dashboard Facilities by Type

 l Dashboard Maintenance Status

 l Dashboard Survey Completion

 l Dashboard Test Point Exception

Complete the following steps to schedule and run the four bridge definitions:
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 1. From the main menu, click Tools > Bridge to open the Bridge window.

Figure  16-4. Bridge Window - Dashboard Definitions

 2. Complete the following steps for each of the four Dashboard bridge definitions:

 a. Select the bridge definition.

 b. Select Scheduled check box. The default setting is daily.
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Figure  16-5. Scheduled Bridge Definition

 c. Click the icon to open the Schedule Frequency window and set the date to current date 
and the time to a convenient time for your organization. Click Save to close the window.

Figure  16-6. Schedule Frequency Window
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 d. Click Save in the Bridge window.

 e. Click  Export.

Drill Down into Dashboard Data

You can access the source data from any of the KPIs (key performance indicators) on the dashboard.

Figure  16-7. KPI Dashboard

NOTE: To view descriptions about any of the KPI panes, hover your mouse over the  icon in the upper 
left-hand corner of the pane.

Survey Completion KPI

This KPI displays the percentage of facilities that have an inspection marked as Surveyed in the filtered date 
range in the current hierarchy selection. As default, the KPI displays completed (COMP).
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Figure  16-8. Survey Completion - Percent Completed

To view facilities that do not have an inspection marked as Surveyed in the filtered date range in the current 
hierarchy selection, click the slider bar to display INCOMP.

Figure  16-9. Survey Completion - Percent Incomplete

The facility records associated with the selected view display in the drilldown below the KPIs. The 
information automatically updates as you change views.
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Figure  16-10. Survey Completion and Associated Facilities

To unselect a KPI, click the x in the upper right-hand corner of the KPI. This will also close the drilldown 
pane associated with it.

Facilities By Type KPI

This KPI displays the quantity of facilities grouped by facility type associated with the current hierarchy 
selection in a bar graph format.
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Figure  16-11. Facilities By Type Pane

To view the facility type and number and percentage of facilities for any of the categories (for example, 
Atmospheric), click in the KPI and hover your mouse over the bar. 

Figure  16-12. Atmospheric Data

To display the facilities in the drilldown pane, click on the bar in the KPI. The bar changes to shaded to 
indicate that it is selected.
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Figure  16-13. Facilities By Type - Selected Facility Type and Associated Data

To unselect a KPI, click the x in the upper right-hand corner of the KPI. This will also close the drilldown 
pane associated with it.

Maintenance Status KPI

This KPI displays the current status of all maintenance items that fall into the filtered date range in the 
current hierarchy selection in a doughnut chart.
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Figure  16-14. Maintenance Status Pane

To view the number of facilities for any of the categorizes plotted on the doughnut chart (shown: 
Completed, In Progress, and Not Initiated), click in the KPI, and then hover your mouse over a section of the 
chart. The example below shows Completed selected on the doughnut  chart.

Figure  16-15. Maintenance Status - Number Completed

To display the facilities in the drilldown pane below the KPI, click on a section of the doughnut chart. The 
section changes to shaded to indicate that it is selected.
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Figure  16-16. Maintenance Status - Selected Status and Associated Data

To unselect a KPI, click the x in the upper right-hand corner of the KPI. This will also close the drilldown 
pane associated with it.

Test Point Exceptions KPI

This KPI displays the number of exceptions for the most recent inspection records that violate Structure 
Below Criteria, Shorted Casings, and High AC P/S in a bar chart.

Figure  16-17. Test Point Exception Pane

To view the number of facilities for any of the categorizes plotted on the chart, click in the KPI, and then 
hover your mouse over a section of the bar chart. The example below shows Structure Below Criteria 
selected on the chart.
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Figure  16-18. Test Point Exceptions - Facility Count for Structure Below Criteria

To display the facilities in the drilldown pane below the KPIs, click on a section of the bar chart. The section 
changes to shaded to indicate that it is selected.
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Figure  16-19. Test Point Exceptions - Selected Status and Associated Data

To unselect a KPI, click the x in the upper right-hand corner of the KPI. This will also close the drilldown 
pane associated with it.

Overview of Reports
Information in this section provides an overview of the report types and styles available in PCS, including a 
description of each PCS report. 

This chapter  includes the following topics:

 l PCS Reports

 l Description of All PCS Reports on page 794
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 l Report Styles on page 790

 l Summary Drilldown Report on page 807

Report Styles

The reports available in PCS can be generated in one or more of the following styles:

 l Columnar Report Style

 l Summary Report Style on page 790

 l Graph Report Style on page 791

 l Form Report Style on page 792

Columnar Report Style

The columnar report style organizes data in columns and rows, with each row representing a record. You 
configure a layout, sorting, and filtering theme, as well as setting paper and print options for the report 
theme.

Figure  16-20. Example of Columnar Report Style

Summary Report Style

The summary report allows you to analyze large amounts of pipeline data easily in a familiar spreadsheet 
format. The report provides a summary of totals, subtotals, and aggregated numeric data for facilities on a 
pipeline.
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Figure  16-21. Example of Summary Report Style

The summary report style provides an optional Drilldown feature for viewing summary data in a pivot table. 
You can add, remove, and arrange data columns in the pivot table to obtain a desired report of summary 
data. Double-clicking a field in the grid opens a window with drilldown information.

Figure  16-22. Summary Drilldown Report

Graph Report Style

A graph report presents data in a line graph format. The report shows survey data versus distance or time. 
You can graph several bands of survey data on one report. Each band includes an X-axis, Y-axis, and 
survey readings.
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Figure  16-23. Example of Graph Report Style

Form Report Style

A form report separates report data into sections, with each section describing a single record. The 
sections of the report present the record's information in a consistent format using the same form design. 
The form report allows for a closer examination of an individual record's information and can show 
information difficult to present in other report styles, such as a record's images.
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Figure  16-24. Example of Form Report Style
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PCS Reports

PCS includes the following types of reports:

 l Compliance: This type of report includes statistics, such as: number of test points; number of test 
points surveyed; missing test points; delinquent test points; and test points below criteria. Each one 
provides a concise data summary. Compliance reports are a key report typically used for auditing 
purposes.

 l Delinquency: A delinquency report includes information about facilities that are currently delinquent 
or have been delinquent based on regulatory survey intervals. This type of report includes both 
interval violations and calendar year violations.

 l Exceptions: Report includes survey data and other related information only for facilities that fail to 
meet certain criteria. For example, based on filter options selected in Exception Filters, the report can 
include facilities with missing structure readings, structure readings less negative than –0.85, or 
structure readings more negative than –2.0. This type of report is helpful when trying to quickly locate 
a problem in the maintenance of a pipeline.

 l Facility Schedules: A list of facilities (such as test points, rectifiers, bonds, and galvanic anodes) that 
need to be surveyed based on the last survey date and target survey month.

 l Survey: All data collected for each facility for a specific survey period.

Description of All PCS Reports

PCS organizes reports in categories, such as PCS reports, module survey reports, facility type reports, 
pipeline reports, and continuous survey reports. Most reports in each of these categories are available for 
set up as a columnar, summary, or graph report style. 

If you frequently use one or more reports, you can designate these reports as a "favorite" in the report set up 
window to have them listed in the Favorite Reports sub-menu (under Reports/Graphs) for quicker access.

The following topics describe the different types of PCS reports found under the Reports/Graphs main 
menu and provide examples of the reports:

 l PCS Reports

 l Module Reports on page 798

 l Facility Type Reports on page 800

 l ROW Reports on page 808

 l Continuous Survey (CIS) Reports on page 810
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PCS Reports

The following reports and graphs are available through the Reports/Graphs > PCS Reports main menu:

 l PCS Schedule Report — this report is not available in the ISM module.

 l PCS Delinquency Report — this report is not available in the ISM module.                 

 l PCS Inspections Graph

PCS Schedule Report

The PCS Schedule Report lists facilities that require inspection using the schedule definition selected for the 
report. The schedule definition and a calculation based on the last inspection date and target survey month 
determine which facilities the report includes. Information is presented in a columnar report style in two 
formats: as a monthly calendar overview and as a detailed list.

To view the report, click  Print in the PCS Schedule Report window.
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Figure  16-25. Example of PCS Schedule Report

PCS Delinquency Report

The PCS Delinquency Report is a compliance report that identifies delinquent facilities based on a survey 
schedule. Information is presented in a columnar style with a list of delinquent facilities, missing and 
surveyed facilities, facilities not included in a survey, and facilities below criteria.

To view the report, click  Print in the PCS Delinquency Report window.
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Figure  16-26. Example of PCS Delinquency Report

When the report is customized using the Summary report style, it is a statistical status report with a concise 
summary of the cathodic protection system. It includes the number of delinquent facilities, missing and 
surveyed facilities, and facilities below criteria. As an option, the report also provides drilldown functionality 
for further analysis of delinquent facilities.

Example: A facility with a 12-month inspection cycle was initially inspected 1/15/2013. The facility became 
delinquent on 4/15/2014; this includes the 12-month inspection cycle plus the grace period. An inspection 
was recorded for the facility on 4/27/2014. If the report option labeled Include only delinquent facilities is not 
set, the facility is included in the Delinquency Report because it was delinquent from 4/15 to 4/26.

PCS Inspections Graph

The PCS Inspections graph includes inspection readings in a facility survey or survey readings in a 
continuous survey based on property settings in the Graph tab. Property settings include selection of one 
or more band fields, survey folders, and graph options. Band fields are equivalent to data fields in a data 
entry grid, such as Structure P/S in the Edit CPDM Data grid and CIS Structure P/S in the Edit ISM Data 
grid.
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Areas of the graph with spikes indicate areas where survey data should be reviewed closely. Locations in 
the graph marked with the letter C indicate Casing P/S. Those marked with the letter F indicate Foreign 
Bond. Hovering the mouse over either of these captions displays a yellow tooltip with measurement data as 
shown in the next example. To toggle these and other captions on or off when viewing the graph, click 
Options and then click a check box labeled with the caption you want to toggle on or off, such as Show 
Casing P/S.

To view the graph, click  Graph in the PCS Inspections Graph window.

Figure  16-27. Example of PCS Inspections Graph

Module Reports

The following reports are available through the Reports/Graphs > <module> Reports main menu:

NOTE: For a list of reports available in the ISM module, refer to Continuous Survey (CIS) Reports
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 l Module Survey Report on page 799

 l Module Data Collection Report on page 800                

Module Survey Report

The survey report includes survey information by module, such as the CPDM Survey Report. It is available in 
a columnar, summary, or graph report style. The report includes all facility data in the survey period selected 
for the report, such as facility data in a survey period for the CPDM Survey Report.

To view the report, click  Print in the <module> Survey Report window.

Figure  16-28. Example of CPDM Survey Report
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Module Data Collection Report

The data collection report is a blank report used by technicians and vendors to record survey readings in 
the field. It is available for selection in all modules except ISM. The report uses a columnar report style and 
includes survey information by module, such as the CPDM Data Collection Report. Based on the survey 
type selected when setting up the report, it includes a list of facilities and related data, such as previous 
survey readings.

To view the report, click  Print in the <module> Data Collections Report window.

Figure  16-29. Example of CPDM Data Collection Report

Facility Type Reports

The following reports are available through the Reports/Graphs > <facility type> Reports main menu iin any 
module except ISM: 

NOTE: For a list of reports available in the ISM module, refer to Continuous Survey (CIS) Reports
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 l Facility Type Information Report

 l Facility Type Detail Information Report

 l Facility Type Inspections Report on page 804

 l Facility Type Detail Inspection Report

 l Facility Type Maintenance Report on page 805

 l Facility Type Exceptions Report on page 806

 l Summary Drilldown Report

Facility Type Information Report

A report based on the columnar report style that includes information entered in the Information data entry 
grid for a facility type, such as the Test Point Information report. Depending on how the report is set up, it 
can include information for user-selected fields such as ROW Name and Code, Milepost number, Effective 
Date, Active/Inactive status, Protection Criteria, and so on. The report does not include survey readings.

To view the report, click  Print in the <facility type> Information Report window.
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Figure  16-30. Example of CPDM Test Point Information Report

Facility Type Detail Information Report

The detail information report includes information entered in the Detail Information mini-grid for a particular 
facility type. It is available as a columnar report.

To view the report, click  Print in the <facility type> Detail Information Report window.
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Figure  16-31. Example CPDM Data Test Point Detail Information Report



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 804

Facility Type Inspections Report

The inspections report includes information entered in the Inspection data entry grid for a particular facility 
type. It is available as a columnar, summary, or graph report. For example, the Test Points Inspection report 
includes all survey data collected at a test point but does not include other facility types such as rectifiers 
and bonds. Rectifier and bonds are included in a report specific to these facility types.

To view the report, click  Print in the <facility type> Inspections Report window.

Figure  16-32. Example of CPDM Test Point Inspections Report

Facility Type Detail Inspection Report

The detail inspection report includes information entered in the Detail Inspections mini-grid for a particular 
facility type. It is available as a columnar report.

To view the report, click  Print in the <facility type> Detail Inspections Report window.
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Figure  16-33. Example of CPDM Test Point Detail Inspections Report

Facility Type Maintenance Report

A report based on the columnar report style that includes information entered in the Maintenance data entry 
grid for a facility type. For example, the Test Points Maintenance report includes a detail listing of all current, 
pending, and completed repairs for test points.

To view the report, click  Print in the <facility type> Maintenance Report window.
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Figure  16-34. Example of CPDM Test Point Maintenance Report

Facility Type Exceptions Report

A report based on the columnar report style that includes survey data and other related information only for 
facilities that fail to meet certain criteria. For example, based on filter options selected in Exception Filters, 
the report can include facilities with missing structure readings; structure readings less negative than –0.85; 
or structure readings more negative than –2.0. This type of report is helpful when trying to quickly locate a 
problem in the maintenance of a pipeline.

To view the report, click  Print in the <facility type> Exceptions Report window.
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Figure  16-35. Example of CPDM Test Point Exceptions Report

Summary Drilldown Report

The Summary report includes the Drilldown option for displaying data in an interactive pivot table format. 

To view a Drilldown of the Summary report for a report that includes a Summary tab, click  Drilldown in the 
<facility type> <report type> Report window. Examples of reports that include the Summary tab are Test 
Point Information Report and Test Point Inspection Report.

The following example is from the CPDM module and found through Reports/Graphs > Test Point Reports 
> Test Point Inspection Report > Summary > Drilldown.
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Figure  16-36. Summary Drilldown Report

Drilldown allows you to display different representations of the same summary data. You can add, remove, 
and rearrange filters to display a subset of summary data for easier analysis of large amounts of data. 
Double-clicking a field opens a window with detailed drill-down information for the selected summation 
type. The following list describes operations you can perform in a pivot table:

 l Arrange Column Fields in the Grid — the arrangement of filter buttons corresponds to the 
arrangement of column fields in the grid. Drag a filter button to a different position within the group of 
buttons to rearrange column fields in the grid. Hover your mouse over a filter button to display a tool 
tip with the filter name.

 l Remove Column Fields in the Grid — drag a filter button to the area of the pivot table labeled Drop 
Column Fields Here to remove the selected column from the grid.

 l Remove Filters from Calculations — drag a filter button to the area of the pivot table labeled Drop 
Filter Fields Here to remove the selected filter from calculations.

 l View or print a section of the drilldown table — double-click a total or sub-total.

ROW Reports

The following reports are available for selection in any module except ISM:

NOTE: For a list of reports available in the ISM module, refer to Continuous Survey (CIS) Reports

 l ROW Information Report

 l ROW Maintenance Report on page 809
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ROW Information Report

A report based on the columnar report style that includes pipeline system information entered in the Edit 
ROW Detail Information grid. Depending on how the report is set up, it includes information for user-
selected fields such as pipeline name and size, total footage, default location format, surface area, and so 
on.

To view the report, click  Print in the ROW Information Report window.

Figure  16-37. Example of ROW Information Report

ROW Maintenance Report

A report based on the columnar report style that includes pipeline system information entered in the Edit 
ROW Detail Maintenance grid. It includes a detail listing of all current, pending, and completed repairs.

To view the report, click  Print in the ROW Maintenance Report window.



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 810

Figure  16-38. Example of ROW Maintenance Report

Continuous Survey (CIS) Reports

The following reports are available for selection under Reports/Graphs main menu in the ISM Module:

 l CIS Survey Report and Graph on page 810

 l CIS Criteria Report

 l CIS Survey Folders Report on page 813

CIS Survey Report and Graph

A report based on the columnar or graph report style that includes station numbers with associated survey 
readings for a selected survey folder and pipeline segment(s) selected in the Select ROWs window.
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NOTE: This report is only available in the ISM Module.

To view the report, select a Continuous Survey from the drop-down list and then click  Print in the CIS 
Survey Report window.

Figure  16-39. Example of Continuous Survey Report (Columnar Report Style)

To view a graph version of the report, click the Graph tab in the CIS Survey Report window. Select a survey 
from the list shown in the Survey Selections pane of the window, and then click  Graph.
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Figure  16-40. Example of Continuous Survey Report (Graph Report Style)

CIS Criteria Report

A report based on the columnar report style that lists survey data for on/off and native state surveys.

The CIS Criteria Report allows you to include or exclude survey readings based on the following fields: 
native (no cathodic protection); on potential (cathodic protection system on); and instant off (regular timed 
interruptions from the current source). If other report information is required, you can create a custom 
criteria report that meets those requirements. Report information also allows you to quickly determine if 
survey readings are out of specification or were recorded incorrectly.

NOTE: This report is only available in the ISM Module.

To view the report, under Options, select an On Off Survey and Native Survey from the drop-down lists, and 
then click  Print in the CIS Criteria Report window.
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Figure  16-41. Example of CIS Criteria Report (Continuous Survey)

CIS Survey Folders Report

A report based on the columnar report style that lists all survey folders associated with the currently 
selected pipeline segment in the Select ROWs window. The report includes the survey folder name, start 
date, and total number of survey readings for each survey folder included in the report.

NOTE: This report is only available in the ISM Module.

To view the report, click  Print in the CIS Survey Folders Report window.
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Figure  16-42. Example of Continuous Survey Folders Report

Work With Reports Based on a Style
For PCS reports, facility type, and ROW reports,  print, export, or create a graph. Some of the reports, such 
as the Test Point Inspection Report (Reports/Graphs > Test Point Reports > Test Point Inspection Report) 
include multiple report styles of that report. 

To set up a report for printing, exporting, or creating a graph you first select various options and (optional) 
filters for filtering data.

Refer to the following topics for more information on working with the different report styles:

 l Work With Columnar Style Reports

 l Work With Summary Style Reports on page 818
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 l Work with Graph Style Reports on page 820

 l Work With Form Style Reports on page 822

Work With Columnar Style Reports

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps  to set up and print or export a columnar style report:

 1. Click Reports/Graphs and then select a report in a columnar style from the menu to open a window 
with the report's property settings. For example (in the CPDM module) Reports/Graphs > Test Point 
Reports > Test Point Detail Information Report.

Figure  16-43. Test Point Detail Information Report

 2. Select one of the following options to choose which facility records to include in the report:

 a. Select the  Selected ROWs option to include facilities associated with the pipeline selection(s) 
in the Select ROWs window.

 b. Select the Route option and then select a route to include facilities associated with the 
selected route.
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 c. Select the Schedule option and then select a schedule definition and a start and end date. 

Figure  16-44. Based On Schedule for Columnar Report

NOTE: Not all columnar reports include the Schedule option.

 3. Select a layout theme from the  Select Layout Theme drop-down list. The layout theme determines 
which fields are included in the report, paper and font settings, and additional print options such as 
including a signature line in the report.

 4. Select a sorting theme from the  Select Sort Theme drop-down list. The sorting theme determines 
how PCS sorts report data.

 5. Choose a method for sorting inspection dates. Click Oldest First or Newest First in Sort Dates to sort 
records with the oldest or newest inspection dates first.

 6. Choose an option for inserting a line between different groups of report data. Select an option from 
the  Insert Lines Between Groups drop-down list.

 7. Choose an option that determines where a page break occurs in the report. Select an option from the 
Page Breaks drop-down list.

 8. Select one or more of the following options as needed in the Options pane, depending on the type of 
columnar report. Date range in filter criteria is determined by considering all time frame filters, such as 
inspection date, survey, and periodic survey filters.

 l Only the most recent information record for each facility — includes the most recent record for 
each facility.

 l Only show facilities with inspections— When time frame filters are not selected in the Filters 
group box, such as inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period.

If one or more time frame filters are selected in the Filters group box, the report only includes 
inspections for the selected time frame filter(s).
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 l All inspections that meet the filter criteria— Report includes all inspections that meet filter 
criteria based on selections in the Filter group box.

 l Apply other filters to the most recent inspection found within report timeframe: This option 
finds the latest inspection within the reporting time frame first, and then applies all other filters 
selected in the Filter group box. The report only includes inspections for facilities when the 
latest record within the date range meets other filters.

 l The most recent inspection after the filter criteria has been met — This option applies all filter 
criteria first based on selections in the Filter group box, and then finds the latest inspection.

 l Indicate missing inspection readings — This option includes an empty box in the report for 
each missing inspection reading.

 9. Select one or more options in the Filters pane to filter report data according to your filter selection(s). 
For example, click Currently Active Facilities Only to only include currently active facilities in the 
report.

PCS disables the Only show facilities with inspection records option when the Columnar report 
includes any of the following filter settings: Inspection Date is between, Survey is equal to, Periodic 
Survey is equal to, or Periodic Survey Year is equal to.

When adding a date filter, such as Inspection Date is between, set a date range using a calendar or 
dynamic dates in the following manner:

 l To set a date range using a calendar, click the down arrow in the start date field to open a 
calendar and select a date. Repeat this step for the end date field.

 l To set a date range using dynamic start and end dates, click the  icon in the start date field 
and set up dynamic date properties. Repeat this step for the end date field. Clicking the 
calculator button opens and closes dynamic date property fields.

 10. If you want to add the report in Favorite Reports (Reports/Graphs > Favorite Reports), click  Add 

Favorite. To remove it from the list, click  Remove Favorite.

 11. To export the report, click  Export to open the Export File window. Navigate to the location where 
you would like to save the file. Select an export file type from the Save as type drop-down list. Click 
Save.

 12. To print the report, click  Print to open the report in a preview window. 

 13. To print the report using the default printer set up in Windows, click the  Quick Print icon. To select a 

printer other than the default printer, click the  Print icon.

 14. When finished, click the close icon to close the print preview window.
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Work With Summary Style Reports

The following procedure explains how to set up and print or export a report based on the summary report 
style. Also included are instructions for using the optional Drilldown feature.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps  to set up, drilldown, and print or export a summary style report:

 1. Click Reports/Graphs and then select a report in a summary style from the menu to open a window 
with the report's property settings. For example, (in the CPDM module) Report/Graphs > Test Point 
Reports > Test Point Inspection Report. Click the Summary tab to see the options for this report.

Figure  16-45. Test Point Inspection Report (Summary)

 2. Select one of the following options to choose which facility records to include in the report:

 a. Select the  Selected ROWs option to include facilities associated with the pipeline selection(s) 
in the Select ROWs window.
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 b. Select the Route option and then select a route to include facilities associated with the 
selected route.

 3. Select a layout theme from the  Select Layout Theme drop-down list. The layout theme determines 
which fields are included in the report.

Only public themes are available for selection. If you would like to use a private theme, your 
company's system administrator must make your private theme a public one.

 4. Select one or more of the following options as needed in the Options pane. Date range in filter criteria 
is determined by considering all time frame filters, such as inspection date, survey, and periodic 
survey filters.

 l Only show facilities with inspections: When time frame filters are not selected in the Filters 
group box, such as inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period.

If one or more time frame filters are selected in the Filters group box, the report only includes 
inspections for the selected time frame filter(s).

 l All inspections that meet the filter criteria: Report includes all inspections that meet filter criteria 
based on selections in the Filter group box.

 l Apply other filters to the most recent inspection found within report timeframe: This option 
finds the latest inspection within the reporting time frame first, and then applies all other filters 
selected in the Filter group box. The report only includes inspections for facilities when the 
latest record within the date range meets other filters.

 l The most recent inspection after the filter criteria has been met: This option applies all filter 
criteria first based on selections in the Filter group box, and then finds the latest inspection.

 5. Select one or more of the survey filters in the Filters pane. The summary report requires at least one of 
these filter settings:

 l Survey is equal to

 l Periodic Survey is equal to

 l Periodic Survey Year is equal to

PCS disables the Only show facilities with inspection records option when the summary report 
includes any of the following filter settings: Inspection Date is between, Survey is equal to, Periodic 
Survey is equal to, or Periodic Survey Year is equal to.

 6. Select additional filters in the Filters pane as required. For example, click Currently Active Facilities 
Only to only include active facilities in the report.
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 7. When adding a date filter, such as Inspection Date is between, set a date range using a calendar or 
dynamic dates in the following manner:

 l To set a date range using a calendar, click the down arrow in the start date field to open a 
calendar and select a date. Repeat this step for the end date field.

 l To set a date range using dynamic start and end dates, click the  icon in the start date field 
and set up dynamic date properties. Repeat this step for the end date field. Clicking the 
calculator button opens and closes dynamic date property fields.

 8. If you want to add the report in Favorite Reports (Reports/Graphs > Favorite Reports), click  Add 

Favorite. To remove it from the list, click Remove Favorite.

 9. If you want to work with report data in an interactive pivot table, click  Drilldown to open the report 
in a new window. Refer to Summary Drilldown Report on page 807 for a more information.

 10. To print the report, click  Print to open the report in a preview window. 

 11. To print the report using the default printer set up in Windows, click the Quick Print icon. To select a 

printer other than the default printer, click the Print icon.

 12. When finished, click the close icon to close the print preview window.

Work with Graph Style Reports

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps  to set up and print or export a graph style report:

 1. Click Reports/Graphs and then select a report in a columnar style from the menu to open a window 
with the report's property settings. For example, (in the CPDM module) Report/Graphs > Test Point 
Reports > Test Point Inspection Report. Click the Graph tab to see the options for this report.
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Figure  16-46. Test Point Inspection Report - Graph Report

 2. Select a layout theme from the  Select Layout Theme drop-down list. The layout theme determines 
which fields are included in the report.

Only public themes are available for selection. If you would like to use a private theme, your 
company's system administrator must make your private theme a public one.

 3. In the Band Fields pane, click the check box for more or more types of survey data you want to 
include in the graph.

 4. In the Survey Selections pane, select one or more Facility Surveys. To select facility surveys in 
sequential order, press Shift and then click each survey. To select facility survey in non-sequential 
order, press Ctrl and then click each survey.

 5. To include all parallel pipelines on one page, select the  Include all parallel pipes on one pagecheck 
box.

 6. To show all selected pipelines on a single page,  select the Combine all selected ROWs on one page 
check box.

 7. Select additional filters in the Filters pane as required.
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 8. If you want to add the report in Favorite Reports (Reports/Graphs > Favorite Reports), click Add 

Favorite. To remove it from the list, click Remove Favorite.

 9. To view the graph, click  Graph to open the graph in a preview window. Then click the  Print 
button to print the graph.

Work With Form Style Reports

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps  to set up and print or export a form style report:

 1. Click Reports/Graphs and then select a report that includes a form style from the menu to open a 
window with the report's property settings.

 2. Click the Form tab to open the form report. If the Form tab is not available, a form report theme has to 
be created. Refer to Form Report Designer Themes on page 847 to create a theme.

Figure  16-47. Form Report
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 3. Select one of the following options to choose which facility records to include in the report:

 a. Select the  Selected ROWs option to include facilities associated with the pipeline selection(s) 
in the Select ROWs window.

 b. Select the Route option and then select a route to include facilities associated with the 
selected route.

 4. Select a public layout theme from the Select Form Theme drop-down to determine which form 
design is used for the report.

 5. Select one or more of the options as needed in the Options pane.

 6. Select additional filters in the Filters pane as needed.

 7. If you want to add the report in Favorite Reports (Reports/Graphs > Favorite Reports), click  Add 

Favorite. To remove it from the list, click  Remove Favorite.

 8. If the option is available, click  Export to export the report information to an Excel file

 9. To print the report, click  Print to open the report in a preview window. 

 10. To print the report using the default printer set up in Windows, click the Quick Print icon. To select a 

printer other than the default printer, click the Print icon.

 11. When finished, click the close icon to close the print preview window.

Add a Custom Report
The following procedure explains how to add a custom report and set up report options. For information 
about deleting a custom report or changing a custom report from Public to Private or Private to Public, refer 
to the instructions in Themes on page 765.

Complete the following steps with one or more pipeline segments chosen in the Select ROWs window:
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 1. Click Reports/Graphs, navigate to a report in the list, then click  Add Report.

Figure  16-48. Add Report Menu Item

For example, click Reports/Graphs > Test Point Reports >Test Point Inspection Report > Add 
Report to open the Add Custom Report window.

Figure  16-49. Add Custom Report

 2. Type a name for the report in the Name field. This field is required.

 3. If you want to add information about the report, type the information in the Description field.

 4. Select the Public check box if you want the report available to all PCS users. When a report is not 
public, it is a private report that is only available to the user who created it.

 5. Click  Save.
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 6. When the report options window opens, select one of the following options to choose which facility 
records to include in the report:

Figure  16-50. Custom Report Options

 a. Click the Selected ROWs option to include facilities associated with the pipeline selection(s) in 
the Select ROWs window.

 b. Click the Route option and then select a route to include facilities associated with the selected 
route.

 c. Click the Schedule option and then select a schedule definition and start and end dates.

 7. Select a layout theme from the Select Layout Theme drop-down list. The layout theme determines 
which fields are included in the report.

For information about adding new report themes, such as a report layout theme, sorting theme, and 
filter theme, refer to Report Themes and Filter Groups on page 827.

 8. Complete the following steps in the Sort Options pane:

 a. Select a sorting theme from the Select Sort Theme drop-down list. The sorting theme 
determines how PCS sorts report data.
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 b. Select a method for sorting inspection dates. Click either the Oldest First or Newest First radio 
button under Sort Dates to sort records with the oldest or newest inspection dates first.

 c. Select an option for inserting a line between different groups of report data from the Insert 
Lines Between Groups drop-down list.

 d. Select an option that determines where a page break occurs in the report from the Page 
Breaks drop-down list.

 9. Select one or more of the following options as needed in the Options pane. Date range in filter criteria 
is determined by considering all time frame filters, such as inspection date, survey, and periodic 
survey filters.

 l Only show facilities with inspections— when time frame filters are not selected in the Filters 
pane, such as inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period.

If one or more time frame filters are selected in the Filters group box, the report only includes 
inspections for the selected time frame filter(s).

 l All inspections that meet the filter criteria— report includes all inspections that meet filter 
criteria based on selections in the Filters group box.

 l Apply other filters to the most recent inspection found within report timeframe— this option 
finds the latest inspection within the reporting time frame first, and then applies all other filters 
selected in the Filters group box. The report only includes inspections for facilities when the 
latest record within the date range meets other filters.

 l The most recent inspection after the filter criteria has been met — this option applies all filter 
criteria first based on selections in the Filters group box, and then finds the latest inspection.

 l Indicate missing inspection readings — this option includes an empty box in the report for 
each missing inspection reading.

 10. Select optional filters in the Filters pane as required. For example, click Currently Active Facilities Only 
to include only currently active facilities in the report.

When adding a date filter, such as Inspection Date is between, set a date range using a calendar or 
dynamic dates in the following manner:

 l To set a date range using a calendar, click the down arrow in the start date field to open a 
calendar and select a date. Repeat this step for the end date field.

 l To set a date range using dynamic start and end dates, click the  calculator button in the start 
date field and set up dynamic date properties. Repeat this step for the end date field. Clicking 
the calculator button opens and closes dynamic date property fields.



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 827

 11. If you want to add the report to the Favorite Reports sub-menu of the Reports/Graphs main menu, 

click  Add Favorite. The link then changes to  Remove Favorite.

If you want to remove a favorite report listed in the Favorite Reports sub-menu of the Reports/Graphs 

main menu, open the report and click  Remove Favorite.

 12. To print the report, click  Print to open the report in a preview window.

 a. To print the report using the default printer set up in Windows, click the  Quick Print button. 
To select a printer other than the default printer, click the  Print button.

Report Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a report layout or sort theme. Themes are 
either public or private. A public theme is available for use by all PCS users. A private theme is available only 
to the user who creates it.

Several installed themes are provided with the PCS software installation. PCS installed themes are public 
themes available to all PCS users. These themes are identified with a globe icon and PCS in brackets [PCS], 

such as  [PCS] Test Point Inspections.

A filter group is a named set of one or more filters that affect the data output of a report. PCS provides two 
types of filter groups you can define and include in the property settings of a report. These include the AND 
and OR filter groups.

When you add a filter group, you define filter conditions that determine which records to include or exclude 
in a report. Adding an AND filter group produces a subset of records that meet all filter conditions. Adding 
an OR filter group produces a subset of records that meet any filter condition. When you generate the 
report, PCS processes filters in descending order beginning with the filter at the top of the filter group.

The following topics describe how to add a report layout theme, a graph sort theme, and an optional filter 
group:

 l Add a Columnar Report Layout Theme on page 828

 l Add a Summary Report Layout Theme on page 832

 l Graph Report Layout Themes on page 838

 l Form Report Designer Themes on page 847

 l Add a Report Sort Theme on page 885

 l Add or Edit an AND or OR Filter Group on page 889

 l Edit and Arrange Filter Groups on page 890
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Add a Columnar Report Layout Theme

A columnar report layout theme is a group of settings for a columnar report layout that have been saved as a 
theme for later use. Settings include choosing which fields to include in the report, paper settings, and print 
options. The following procedure applies to a columnar report layout theme for any columnar report in PCS.

Complete the following steps to add a columnar report layout theme:

 1. Select the report you want to work with in the Reports/Graphs menu. Click Report/Graphs and then 
select a report in the list.

For example, click Reports/Graphs > Test Point Reports > Test Point Inspection Report.

 2. Click the  Customize tab and then the Columnar Layout tab to open the Layouts page.

Figure  16-51. Report Layouts

 3. Click  Add to open the New Layout Theme window.
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Figure  16-52. New Layout Theme

 4. Enter a name for the layout theme in the Enter Theme Name field. This field is required.

 5. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 6. If you want to copy fields from another layout theme, click the Copy Content check box and then 
select a theme from the  Copy Fields From Theme drop-down list.

 7. Click  OK to save changes and return to the Layouts window.
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Figure  16-53. Layouts Window With New Layout

 8. Complete the following steps to add and remove fields in the report layout theme as needed:

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click  All Fields.

 b. Select a field by clicking in the check box for the field and then click the  button to move it 
to the left pane. You can also double-click a field  to move it to the right pane. Repeat this step 
as needed. The report layout theme includes all fields in the right pane of the Layouts window.

 c. To remove a field in the layout theme, select the filed in the left pane and then click the  
button to move it to the right pane. You can also double-click a field  to move it to the left pane. 
Repeat this step as needed.

 d. To change the order of fields in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or   button.

 9. Click the Wrap check box in Report Paper Size Estimate for each field you want text to wrap.
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Figure  16-54. Wrap Option for Text Fields

 10. To adjust the width of report columns:

 a. Place the mouse over a column boundary to change the cursor to a horizontal resize cursor 
.

 b. Click and drag a column boundary to adjust the width of the report column.

Figure  16-55. Resizing a Column

 c. If the adjustment extends report columns outside of the page, a red "out of bounds" message 
displays. Click and drag the column boundary to make adjustments as needed to clear the 
message.

 11. Click  Paper Settings to open the property settings pane.

Figure  16-56. Paper Settings

 12. Set options as needed in the Paper Settings and Print Options panes. 
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 a. To increase or decrease the font size, adjust the Min and Max settings for the font selected.

 b. To adjust the space between columns, enter or adjust the value in the Column Spacing field.

 c. Select either Portrait or Landscape radio button to set orientation. 

 d. To adjust the left margin, enter or adjust the value in the Left Margin field.

 e. Select any of the option under Print Options as needed.

 13. Click  Save and Close to save changes and return to the report options window.

 14. To apply the layout theme to the report, select the new layout theme from the Select Layout Theme 
drop-down list.

Add a Summary Report Layout Theme

A layout theme is a group of named settings saved for later use. You can define a Summary layout theme 
with report settings that define the table row, column, and data fields as well as the aggregate functions 
(average, sum, count, and percentage) used to calculate data fields in a Summary report. Summation 
fields, field operators, filters, drilldown fields, drilldown sorting fields, horizontal and vertical field groupings, 
as well as paper settings can all be saved in a Summary layout theme.

A Summary report presents data in a cross tab table view. It provides a "big picture" of pipeline and facility 
data by summarizing and analyzing the data. You can control how PCS summarizes the data, for example 
by sum, average, count, or percentage. Using a Summary report can help with analyzing data, making 
comparisons, and detecting patterns in the pipeline system.

Complete the following steps to add a summary layout theme:

 1. Select the report you want to work with in the Reports/Graphs menu. Click Report/Graphs and then 
select a report in the list.

For example, click Reports/Graphs > Test Point Reports > Test Point Inspection Report.

 2. Click the Customize tab and then the  Summary Layouts tab to open the Summaries window.



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 833

Figure  16-57. Summary Layouts

 3. Click  Add to open the New Summary window.

Figure  16-58. New Summary

 4. Enter a name for the summary layout theme in the Enter Theme Name field. 
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Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who created it.

 5. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.

 6. If you want to copy fields from another layout theme, click the Copy Content check box and then 
select a theme from the  Copy Fields From Theme drop-down list.

 7. Click  OK to save changes and return to the Summaries window.

Figure  16-59. Summaries Window With New Theme

 8. Complete the following steps to select one or more PCS fields to be used as horizontal table rows in 
the report. Field selections display in the Horizontal Groups pane. In a Summary report, these fields 
display horizontally on the left side of the report.

 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click All Fields.

 b. Select a field by clicking in the check box for the field and then click the  button to move it 
to the left pane. You can also double-click a field  to move it to the right pane. Repeat this step 
as needed. 

As an example, when selecting System and ROW Code, each time a System table row is 
included in the report, a ROW Code table row is also included.
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 c. In the Horizontal Groups pane, if you want the data collapsed for a table row when you first 
open the Summary report, click the Collapsed check box for that table row.  An 
expand/collapse button is available when viewing the report to expand and collapse data as 
needed.

Figure  16-60. Horizontal Groups Pane

 d. In the Horizontal Groups pane, if you want to rename the caption of a table row, enter a name 
in the Caption field for that table row. When this field is empty, the caption of the table row uses 
the default PCS description.

Click the  icon in the Horizontal Groups, Vertical Grouping, or Field Operations panes opens 
a window with information related to current property settings.

 e. To change the order of fields in the Horizontal Groups pane and subsequently in the Summary 
report, click and drag a field to a new position in the grid, or select a field and then click the up 

 or down  button.

 9. Vertical Grouping is an optional setting. It allows you to group horizontal table rows by a vertical 
column. For example, selecting Inspection Date displays data by Month, Quarter, or Year based on 
the Data Group Interval option you select.

To group horizontal table rows by a vertical column, complete the following steps in the Vertical 
Grouping pane:

 a. Select a PCS field you want to use as the vertical column from the Field drop-down list.

 b. If you want to use a different caption other than the name of the selected PCS field, enter a 
name in the Caption field.

 10. Click  Full View to hide all the panes under Options. Click Full View again to display these pane.

 11. Identify how you want data calculated. Set up one or more summations in the following manner:
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 a. Click  Add Summation.

Figure  16-61. Add Summation Fields

 b. Enter a name in the Caption field.

 c. Choose an aggregate function used to calculate data fields (average, sum, count, or 
percentage) by selecting an option in the Single, Composite, Compare Summations, or Sum 
Of Total Facilities panes in the Field Operations pane.

Figure  16-62. Field Operations Panes
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 d. If you selected an option in either the  Single or Sum Of Total Facilities pane, select the PCS 
field you want to use in the calculation from the Field drop-down list

 e. If you want to compare two summations, select Percentage or Difference in the Compare 
Summations pane. Then select a summation from the First Summationdrop-down list and a 
second summation from the Second Summation drop-down list.

 f. Repeat as needed to add additional summations.

 g. To delete a summation, select a summation tab and then click  Delete. Click Yes in the 
Delete message window.

Figure  16-63. Select a Summation

 12. If you want to filter the data output in the report, select a PCS field from the Optional Required 
Runtime Filter drop-down list in the Filters pane. Or click Edit to set up an AND or OR filter group. 
Refer to Report Themes and Filter Groups on page 827 for related information.
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Figure  16-64. Filters Panes

 13. Click Edit in the Drilldown Fields pane and select one or more fields you want to use as drilldown 
fields. When viewing the report in PCS, clicking a drilldown field displays another data view with more 
information about the field.

 14. Click Edit in the Drilldown Sorts pane and select one or more fields that determine how data sorts. 

Click   to sort data in ascending order or   to sort in descending order.

 15. Click  Paper Settings and set paper, font, and print options as needed. Refer to Add a Columnar 
Report Layout Theme for more information about these settings.

 16. Click Save and Close to save changes and return to the report options window.

Graph Report Layout Themes

A graph report layout theme is a named layout of fields that determine what data is displayed in a graph and 
how that data is displayed. The theme can be saved as either public or private; a public theme is available 
for all users, whereas a private theme is only available to the user who creates it.
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Open the Graph Layouts Editor

The Graph Layouts editor allows you to create a new graph layout theme or edit an existing theme. Once in 
edit mode, you can modify which fields are charted in the graph, which data fields are charted in the same 
graph band, and whether a graph band should have data charted on both the right and left axis. Graph 
properties, including captions, legends, and axis range, can also be modified in the Graphs Layouts editor.

To access the Graph Layouts editor, click the Customize tab from a graph report and then click  Graph 
Layouts.

Figure  16-65. Graph Layouts Editor

From within the Graph Layouts editor, a new graph report layout theme can be created, a new or existing 
theme can be modified, and the theme can be saved or deleted. Once the theme is saved, it can be used in 
Reports/Graphs. Refer to the following topics for more information:

 l Add a New Graph Report Layout Theme

 l Edit a Graph Report Layout Theme on page 840

 l Manage the Graph Report Layout Theme on page 846

 l Use the Graph Report Layout Theme on page 846

Add a New Graph Report Layout Theme

Complete the following steps to create a new theme from the Graph Layouts editor:
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 1. Click  Add to open the New Graph Layout window.

Figure  16-66. New Graph Layout

 2. Enter a name for the theme in the Enter Theme Name field.

 3. Click the Public check box to mark the theme as public and available to all users. To keep the theme 
private, ensure the check box is clear.

 4. To copy the contents of an existing theme, keep the Copy Content check box checked and select a 
theme from the Copy Fields From Theme drop-down list.

To start with a blank theme with no pre-existing fields or properties, click to clear the Copy Content 
check box.

 5. Click  OK. A new graph report layout theme is created and ready for editing in the Graph Layouts 
editor.

Edit a Graph Report Layout Theme

You can edit a graph report layout theme's display properties, add, remove, or re-size graph bands, add 
new fields  to a graph band, or modify graph band properties.

To edit a graph report layout theme, click to select a theme from the Select Graph Theme drop-down. The 
workspace area updates to show the selected theme.
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Figure  16-67. Graph Theme Ready to Edit

The theme can have multiple graph bands with each graph band consisting of one chart with all of its band 
fields' data plotted. The number of graph bands, the fields plotted in the graph bands, and the way that the 
data is displayed in the graph bands can be modified to fit your report's needs. Refer to the following topics 
for more information:

 l Configure Graph Report Layout Theme Properties

 l Add or Remove Graph Bands on page 842

 l Re-size Graph Bands on page 843

 l Set Graphing Parameters in a Graph Band on page 844

Configure Graph Report Layout Theme Properties

Graph report layout theme properties that apply to all graph bands can be modified in the Graph Theme 
Header.

Select an option from the Graph Mode drop-down to dictate whether the graphs in the graph bands will be 
plotted based on time or distance. The X axis in the graphs will display time- or distance-based intervals, 
respectively.
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Figure  16-68. Graph Mode Drop-down List

Enter a value in the Starting Height Magnification field or click the arrows next to the field to increase or 
decrease the height of all graph bands.

Add or Remove Graph Bands

Graph bands can be added or removed as needed for the current report type. 

To add a graph band, click  Add Band. A new band is added at the bottom of the list of graph bands. The 
band can be re-sized and the graphing parameters can be defined. 

Figure  16-69. New Band Added to Band Heights Pane
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To remove a graph band, click  next to the graph band Description field, and then click Yes in the 
Delete Band confirmation window.

Figure  16-70. Delete a Graph Band

Re-size Graph Bands

All graph bands that exist in the graph report are stacked vertically on the screen. A graph band can be 
made larger or smaller as needed.

To resize a graph band in the current theme, click to select the divider bar ( ) above or below 
the graph band and drag the divider bar to increase or decrease the graph band size.
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Figure  16-71. Re-size a Graph Band

Set Graphing Parameters in a Graph Band

Each graph band consists of one chart with all of its band fields' data plotted. Data can be graphed on 
either the right or left axes or, if desired, both axes can be used to graph data. Click to select the Use Right 
Axis and/or Use Left Axis check box and set the following parameters for the selected axis or axes:



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 845

Figure  16-72. Use Left Axis and Use Right Axis Panes

 l Caption — enter new text in the Caption field to set a caption for the current axis.

 l Fields — click Add/Remove Fields. In the Edit Layout window, identify the fields that you want to add 
or remove from the graph band. Up to ten fields can be graphed on an axis at a time.

To add new fields, select the desired field(s) from the pane on the left and click . To remove 

existing fields, select the desired field(s) from the pane on the right and click . Once the correct 
fields are showing in the pane on the right, click OK.

 l Modify Fields — you can further modify fields by selecting any of the following options:

 — Always show survey date check box: shows survey date. 

 — Show reference line at check box: change the value, if necessary, in the text field provided.

 — Hide items with no data check box: do not show items that do not have data. 

 l Modify the Data Fields Displayed — to further modify what data is plotted and how it is displayed, do 
any of the following:
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 — To show the date of the survey alongside the survey data in the legend, select the Always 
show survey date in legend check box.

 — To plot only surveys that have data in the graph, select the Hide items with no data check box.

 l Axis Range — select the desired axis range. The following options are available:

 — Auto-Range: click the Auto-Range radio dial to have the axis range automatically determined 
based on the charted values.

 — Specify Base Range: click the Specify Base Range radio button and enter lower and upper 
values in the text fields provided below the range options. The axis range is determined by the 
values entered, unless the data plotted would exist out of the bounds of the lower and upper 
values entered. In this situation, the axis range would be extended to display all data points.

 — Specify Absolute Range: click the Specify Absolute Range radio button and enter lower and 
upper values in the text fields provided below the range options. The axis range is determined 
by the values entered. The axis range will not be extended, even if a data point plotted exists 
out of the bounds of the lower and upper values entered.

 — Add room for remarks check box: add space in the axis to accommodate remarks.

 — Invert Axis check box: the axis range and data plotted will be flipped vertically.

Manage the Graph Report Layout Theme

Complete the following actions when working with or finishing creating a graph report layout theme.

 l To undo all recent changes that have not yet been saved, click  Cancel. All graph layout themes 
are reverted to their latest saved state.

 l To save the graph report layout theme, click  Save. All changes made to the theme is saved.

 l To remove the currently selected theme, click  Delete  in the header row and then  Yes in the 
Confirm Delete window. The currently selected theme is removed from PCS.

 l To save the theme and close the Graph Layouts editor, click  Save and Close. All changes made to 
the theme is saved and the Graph Layouts editor is closed.

 l To close the Graph Layouts editor, click  Close. If there are unsaved changes to a graph report 

layout theme in the Graph Layouts editor, a Save Changes? window displays. Click  Yes to save 

all changes in the themes,  No to close without saving changes, or  Cancel to return to the 
Graph Layouts editor.

Use the Graph Report Layout Theme

Complete the following steps to apply the theme in a graph when creating a new graph report:
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 1. In the report's Graph tab, select a theme from the Select Layout Theme drop-down list.

Figure  16-73. Select Layout Theme Drop-down List

 2. Select the desired fields to graph, configure data filters (if desired), and select the appropriate survey
(s),(if available). Refer to Work with Graph Style Reports on page 820 for detailed instructions.

 3. Click  Graph to open the graph in a preview window.

 4. Click  Print to print the graph.

Form Report Designer Themes

A form report separates report data into sections, with each section describing a single record. Each 
section presents the record's information in a consistent format, using the same form design. A form report 
theme determines the contents and page settings of a form report, including what details are included each 
section of a form report and how the data is displayed. A form report theme can be saved as either public or 
private; a public theme is available for all users, whereas a private theme is only available to the user who 
creates it.

Refer to the following topics for more information on creating a form report theme:

 l Open the Form Designer

 l Add a New Form Report Theme
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 l Edit a Form Report Theme

 l Manage the Form Report Theme

 l Use the Form Report Theme

Open the Form Designer

The Form Designer allows you to create a new form report theme or edit an existing theme. Once in edit 
mode, you can decide which fields are displayed on the form theme, how the information in the fields are 
displayed, what other elements to include in the theme, and what page settings to change.

You can access the Form Designer from a report that supports a forms layout, such as the Test Point 
Inspection Report (CPDM module).

In the report window, click  Customize. If the report supports forms, Form Designer will be listed on the 
right. 

Click  Form Designer to open the Form Designerwindow.
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Figure  16-74. Form Designer

From within the Form Designer, a new form report theme can be created, a new or existing form report 
theme can be modified, and the theme can be saved or deleted. Once a form report theme is saved, it can 
be used in Reports/Graphs. Refer to the following topics for more information:

 l Add a New Form Report Theme on page 849

 l Edit a Form Report Theme on page 850

 l Manage the Form Report Theme on page 883

 l Use the Form Report Theme on page 884

Add a New Form Report Theme

Complete the following steps to create a new theme from the Form Designer:
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 1. Click  Add to open the Add Form Theme window.

Figure  16-75. New Form Theme

 2. Type a name for the theme in the Enter Theme Name field.

 3. Click the Public check box to mark the theme as public and available to all users. To keep the theme 
private, ensure the check box is clear.

 4. To copy the contents of an existing theme, keep the Copy Content check box checked and select a 
theme from the Copy Fields From Theme drop-down list.

 5. To start with a blank theme with no pre-existing fields or properties, click to clear the Copy Content 
check box.

 6. Click  OK. A new form report theme is created and ready for editing in the Form Designer.

Edit a Form Report Theme

To modify a form report theme, you can add objects from the Field List or Control toolbar to the workspace 
area and modify the object's properties in the Properties pane or in the ribbon. When adding an object to 
the workspace area, you can add it to a margin or a detail section. TopMargin1 and BottomMargin1 
represent the space at the top and bottom of every page of the report, similar to the header and footer of a 
Word document. Detail1 represents the space in a report reserved for a record's data. Changes to the 
Detail1 section of the workspace applies to every record's section of the report. Unless a page break is 
added to the workspace area or the properties of Detail1 include a page break after each record, the record 
sections are stacked vertically without adding space between the sections.

To edit a form report theme, click to select a theme from the Select Form Theme drop-down. The 
workspace area updates to show the selected theme. Refer to the following topics for more information 
about editing a form report theme:
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 l Create and Manage Form Theme Styles

 l Modify Form Report Page Properties on page 858

 l Modify Form Report Margins on page 865

 l Modify Form Report Detail Section on page 870

 l Add Objects to a Margin or Section on page 872

 l Edit Objects in a Margin or Section on page 876

 l Arrange Objects in a Margin or Section on page 882

 l Re-size Objects in a Margin or Section on page 883

Create and Manage Form Theme Styles

Theme styles are saved collections of color, border, padding, and font properties that can be applied to 
objects on the form or set as defaults in report sections or margins. When a style is applied to an object on 
the form, the object's background, border, font, and padding properties follow the properties defined in the 
style. To apply a style to an object, select an object on the form theme. In the Properties pane, locate a 
Styles property and select the style from the drop-down.

To view, create, and edit a theme style, click  Styles. The Edit Styles window opens.
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Figure  16-76. Edit Styles

Complete the following steps to create, edit, remove, save, or load a style:

 1. Click . A new style is created with a default name and set of properties. Select the newly created style 
in the list on the left to edit the style
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Figure  16-77. New Style

 2. Edit the style using the property selections on the right side of the window.

 a. Name — to rename the style, select the text in the Name field and enter a new value.

 b. Background Color — to change the background color for the style, select the Background 
Color drop-down. A grid of available and standard colors appears. Select a color from the grid 
or click  More Colors to switch to the custom color selector and create a custom color by doing 
any of the following:

 i. Select a color with the color slider and color field.

 ii. Enter a hexadecimal value in the field provided.

 iii. Select a color model in the drop-down provided and enter the following in the fields 
provided:

 l For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 l For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 854

 l For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 l For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 iv. Click  to activate the color picker and move your mouse over a spot on your computer 
that has the color you wish to use. Click your mouse to select the color.

 c. Border Color — to change the color of the border for the style, select the Border Color drop-
down. A grid of available and standard colors appears. Select a color from the grid or click  
More Colors to switch to the custom color selector and create a custom color by doing any of 
the following:

 i. Select a color with the color slider and color field.

 ii. Enter a hexadecimal value in the field provided.

 iii. Select a color model in the drop-down provided and enter the following in the fields 
provided:

 l For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 l For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 l For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 l For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 iv. Click  to activate the color picker and move your mouse over a spot on your computer 
that has the color you wish to use. Click your mouse to select the color.

 d. Border Dash Style — To change the type of line used for the border, select one of the following 
options from the Border Dash Style drop-down:

 i. Solid — for a single solid line

 ii. Dash — for a consistent dashed line

 iii. Dot — for a consistent dotted line

 iv. Dash-Dot — for a line that alternates between dashes and dots

 v. Dash-Dot-Dot — for a line that alternates between dashes and two dots

 vi. Double — for two solid lines

 e. Border Width — to change the thickness of the border, enter a value in pixels in the Border 
Width text field.
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 f. Borders — to determine what sides will have borders, click the Borders drop-down and 
complete the following steps:

 l Click All to have borders on all sides of the object the style is applied to.

 l Click None to not have any borders on the object the style is applied to.

 l Click  at the top, bottom, left, or right edge of the border drop-down to toggle whether 
the top, bottom, left, or right border is applied for the style.

 g. Font — click the ellipsis (...) next to the Font field to open the Font window. Select a font family, 
style, size, effect, and script for the object the style is applied to and click OK.

 h. Foreground Color — to change the color of the text for the style, select the Foreground Color 
drop-down. A grid of available and standard colors appears. Select a color from the grid or 
click  More Colors to switch to the custom color selector and create a custom color by doing 
any of the following:

 l Select a color with the color slider and color field.

 l Enter a hexadecimal value in the field provided.

 l Select a color model in the drop-down provided and enter the following in the fields 
provided:

 — For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 — For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 — For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 — For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 l Click  to activate the color picker and move your mouse over a spot on your computer 
that has the color you wish to use. Click your mouse to select the color.

 i. Padding — to control the amount of space between the form object's contents and the border 
click the arrow next to Padding to expand the padding options. Enter values in pixels in the 
fields available.

 j. Text Alignment — to set the alignment of the object's text, select one of the following values 
from the Text Alignment drop-down: Top Left, Top Center, Top Right, Middle Left, Middle 
Center, Middle Right, Bottom Left, Bottom Center, Bottom Right, Top Justify, Middle Justify, 
and Bottom Justify.

 3. To remove a single style, select the style from the list on the left and click  (remove a style). The style is 
removed from the Edit Styles window and cleared from any object that the style was applied to.
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 4. To remove all styles, click  (Clear Styles). The all styles are removed from the Edit Styles window and 
cleared from any object that styles have been applied to.

 5. To remove only the styles that have not been applied to objects on the form theme, click  (delete 
unused styles). Any unused styles are removed from the Edit Styles window.

 6. Click  Save to save all created styles. A Save As wndow opens. Navigate to a location where you 
wish to save the style, enter a name for the style, and click Save.

 7. Click OK to close the Edit Styles window.

 8. To load saved styles, click  (load styles from a folder), navigate and select the style, then click 
Open.

 9. To use a style for an object, such as text, select the style. Then click the  next to Styles to expand it, 
then click the  in the Style line, and select one of the saved styles. 

NOTE: If you click the ellipses button next to (Collection), the Styles Editor window will open. You 
can make edits to styles this way as well as through the Styles button.
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Figure  16-78. Selecting a Style for an Object in the Form

The style is applied to the object once you click anywhere outside of it.
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Figure  16-79. Style Applied to Object

Modify Form Report Page Properties

When the Form Report page is selected, you can define the report watermark, all page settings, record 
printing options, set the default appearance settings for objects added to the form, and the behavior of the 
form designer itself. 

The ribbon allows you to modify most watermark and page settings, while the Properties pane can be used 
to configure advanced page and watermark settings, form designer behavior, and default appearance 
settings.

You can use either of the following sections of the Form Designer window to modify appearances and 
properties of the form:

 l Use Ribbon to Modify a Report Form Page Setup

 l Use Properties Pane to Modify a Report Form Page Setup

Use Ribbon to Modify a Report Form Page Setup

Use the ribbon to set simple page settings. Options available from the ribbon include selecting a standard 
page size, defining page margins, and choosing an orientation for the page. To set more advanced page 
properties or to define a custom page size or use a custom page size that is already defined in your printer 
settings, or to set watermark options, use the Properties pane. Refer to Use Properties Pane to Modify a 
Report Form Page Setup on page 859.
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 1. Click  Page Setup to open the Page Setup window. 

Figure  16-80. Page Setup Window

 2. Select a size from the Paper Size drop-down.

 3. Select an Orientation radio button.

 4. Enter a margins in inches for the Left, Right, Top, and Bottom margins in the fields provided. 

 5. Click OK to save the page settings and close the Page Setup window or click Cancel to undo any 
changes made in the Page Setup window before closing the window.

Use Properties Pane to Modify a Report Form Page Setup

You can use the Properties pane for a form report theme to define the report watermark, all page settings, 
record printing options, the default appearance settings for objects added to the form, and the behavior of 
the form designer itself.

To modify the properties of a form report theme, with a form report theme selected in the Form Designer 
click in the gray edges outside of the workspace area. The form report theme's available properties load in 
the Properties pane. You will need to scroll down to see all of the properties.
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Figure  16-81. Properties Pane

If a property can be reset, the check box will be filled in black. To reset a property, click the check box to the 
far right of the property name line. 

Figure  16-82. Resetting a Property
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When you click on a Property, a definition of the property displays at the bottom of the screen. For example, 
Background Color has been selected in the following image. The definition for Background Color is shown 
in the pane below Properties. Use these definitions to understand each of the properties listed in this pane.

Figure  16-83. Property Descriptions

Appearance properties. When a report theme's default appearance settings are configured, any Control 
object added to the form will inherit that setting from the report theme unless it's configured elsewhere. If 
the same appearance setting is also changed in the margin properties (for Control objects placed in the Top 
or Bottom margins) or detail properties (for Control objects placed in the Detail section), they will inherit the 
margin or detail properties instead.

If the appearance setting is changed on the Control object itself, then any defaults set in the report theme, 
margins, or details are ignored and the Control object's settings are used.

The following default appearance settings are available for the report theme:
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 l Background Color — to change the default background color for a Control object added to the form, 
select the Background Color drop-down. A grid of available and standard colors appears. Select a 
color from the grid or click More Colors to switch to the custom color selector and create a custom 
color by doing any of the following:

 — Select a color with the color slider and color field.

 — Enter a hexadecimal value in the field provided.

 — Select a color model in the drop-down provided and enter the following in the fields provided:

 — For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 — For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 — For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 — For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 — Click  to activate the color picker and move your mouse over a spot on your computer that has 
the color you wish to use. Click your mouse to select the color.

 l Border Color — to change the default color of the border for a Control object added to the form, 
select the Border Color drop-down. A grid of available and standard colors appears. Select a color 
from the grid or click More Colors to switch to the custom color selector (see above for options).

 l Border Dash Style — To change the default type of line used for a border of a Control object added to 
the form, select one of the following options from the Border Dash Style drop-down:

 — Solid : for a single solid line

 — Dash : for a consistent dashed line

 — Dot : for a consistent dotted line

 — Dash-Dot: for a line that alternates between dashes and dots

 — Dash-Dot-Dot: for a line that alternates between dashes and two dots

 — Double : for two solid lines

 l Border Width — to change the default thickness for a border of a Control object added to the form, 
enter a value in pixels in the Border Width text field.

 l Borders — to determine what sides of a object will have borders by default, click the Borders drop-
down and complete the following steps:

 — Click All to have borders on all sides of the objects added to the form.

 — Click None to not have any borders on the objects added to the form.
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 — Click  at the top, bottom, left, or right edge of the border drop-down to toggle whether the 
top, bottom, left, or right border is applied to objects added to the form

 l Font — click the ellipsis (...) next to the Font field to open the Font window. Select a default font 
family, style, size, effect, and script for text-based objects added to the form and click OK.

 l Foreground Color — to change the default text color for text-based objects added to the form, select 
the Foreground Color drop-down. A grid of available and standard colors appears. Select a color 
from the grid or click More Colors to switch to the custom color selector and create a custom color 
(see Background Color, above).

 l Padding — to control the default amount of space between a Control object's contents and the 
border click the arrow next to Padding to expand the padding options. Enter values in pixels in the 
fields available.

 l Text Alignment — to set the alignment of the object's text, select one of the following values from the 
Text Alignment drop-down: Top Left, Top Center, Top Right, Middle Left, Middle Center, Middle 
Right, Bottom Left, Bottom Center, Bottom Right, Top Justify, Middle Justify, and Bottom Justify.

Appearance properties. The following properties are available to modify for the report's appearance:

 l Page Color — to change the background color of the page, select the Page Color drop-down. A grid 
of available and standard colors appears. Select a color from the grid or click  More Colors to 
switch to the custom color selector and create a custom color (see Background Color, above).

 l  Style Sheet — click the ellipsis (...) next to the Style Sheet field to open the Styles Editor. Add, edit, or 
remove styles defined in the form report theme as desired. Refer to Create and Manage Form Theme 
Styles for more information about form report theme styles.

 l Watermark — double-click the Watermark field to open the ribbon's Watermark window and fill out 
the Text Watermark, Picture Watermark, Position, and Page Range options as desired. Refer to Use 
Properties Pane to Modify a Report Form Page Setup on page 859 for instructions detailing the 
watermark properties available from the ribbon.

 — To edit the watermark options in the Properties pane, click to expand the Watermark field and 
modify the Font, Foreground Color, Image, Image Alignment, Image Tiling, Image 
Transparency, Image View Mode, Page Range, Show Behind, Text, Text Direction, and Text 
Transparency properties.

Behavior properties. Behavior properties determine the units of measurement used in the form report 
theme, as well as how the form report should handle objects that extend beyond the page margins. The 
following behavior properties are available for editing:
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 l Horizontal Content Splitting — to determine what should happen when a horizontal page break 
would naturally occur in the middle of an object or group of objects, select the Horizontal Content 
Splitting drop-down and choose one of the following options:

 l Exact — allows a page break to occur in the middle of an object or group of objects; objects or 
groups of objects that are split in two so they can continue on the next page.

 l Smart — whenever possible, moves the entire object or group of objects to the next page if a page 
break would have occurred in the middle of the object(s).

 l Measure Units — to change the units of measurement used in the form report theme, select an 
option from the Measure Units drop-down.

 l Vertical Content Splitting — to determine what should happen when a vertical page break would 
naturally occur in the middle of an object or group of objects, select the Vertical Content Splitting 
drop-down and choose one of the following options:

 l Exact — allows a page break to occur in the middle of an object or group of objects; objects or 
groups of objects that are split in two so they can continue on the next page.

Design properties. Design properties determine how objects in the form report theme are displayed and 
used in the designer. The following Design properties are available:

 l Display Name — to change the name of the form report theme, replace the text in the (Name) field 
with a new name.

 l Designer Options — to show or hide popup hints and warnings in the Report Designer. Optins 
include:

 — Show Designer's Hints

 — Show Export Warnings

 — Show Printing Warnings

 l l Draw the Grid — to show or hide the grid on the designer, click to select or clear the Draw the Grid 
check box, respectively.

 l Draw the Watermark — if a Watermark has been added, this option gets or sets a value indicating 
whether or not to draw a watermark at design time.

 l Snap Grid Size — to change the amount of space between the grid lines, select the text in the Snap 
Grid Size field and enter a new value.

 l Snap to Grid — to allow objects to snap to the grid when moving or resizing, click to select the Snap 
to Grid check box. To disable this feature, click to clear the check box.
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 l Snapping Mode — specifies the mode in which report elements are snapped to each other when 
they are re-sized or being relocated.

Page Settings properties. These properties define the paper's size, margins, and orientation. Unlike the 
page setup options found in the ribbon, the Properties pane also allows you to use custom page sizes. 
Custom page sizes can be predefined sizes found in a local printer or defined manually in the Properties 
pane.

 l Landscape — select the Landscape check box to orient the page to landscape mode or clear the 
check box to orient the page to portrait mode.

 l Margins — to set amount of space at the edge of the paper to be reserved for the margins, click the 
arrow next to Margins to expand the Margins options. Enter values in hundredths of an inch in the 
fields available.

 l Page Height — to define the paper's height for a custom paper size, enter a height in the field 
provided. This field only enabled if a custom Paper Kind is selected.

 l Page Width — to define the paper's width for a custom paper size, enter a width in the field provided. 
This field is only enabled if a custom Paper Kind is selected.

 l Paper Kind — to set the paper size for the form report, select a Paper Kind from the drop-down. The 
Page Height and Page Width fields update to match the height and width of the selected paper kind, 
however the Page Height and Page Width fields are only editable if a Custom paper kind was 
selected.

 l Paper Name — to use a paper size that's been predefined in printer preferences for the printer 
selected in the Printer Name field, enter the name of the paper size exactly as it's defined in the 
printer's printer preferences.

 l Printer Name — to use the paper sizes predefined in a specific printer's printer preferences, select 
the desired printer from the Printer Name drop-down. The Printer Name field is used alongside the 
Paper Name field when Custom paper kind was selected.

Modify Form Report Margins

You can use the Properties pane for a form report theme's top or bottom margin to define the margin height 
as well as default appearance settings for objects added to the margin.

To modify the properties of a form report margin, with a form report theme selected in the Form Designer 
click a margin to select TopMargin1 or BottomMargin1 of the workspace area. The selected margin's 
available properties load in the Properties pane.
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Figure  16-84. Margin Properties

If a property can be reset, the check box will be filled in black. To reset a property, click the check box to the 
far right of the property name line. 
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Figure  16-85. Resetting a Property

When you click on a Property, a definition of the property displays at the bottom of the screen. For example, 
Background Color has been selected in the following image. The definition for Background Color is shown 
in the pane below Properties. Use these definitions to understand each of the properties listed in this pane.
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Figure  16-86. Property Descriptions

Appearance properties. When a margin's default appearance settings are configured, any Control object 
added to the margin will inherit its property settings from the margin's appearance properties and any 
appearance properties defined in the margin's Properties pane will override properties set in the form report 
theme. If the appearance properties for an object are defined in the object's Properties pane, any defaults 
set in the margin are ignored and the Control object's settings are used.

The following default appearance settings are available for the margin:

 l Background Color — to change the default background color for a Control object added to the 
margin, select the Background Color drop-down. A grid of available and standard colors appears. 
Select a color from the grid or click  More Colors to switch to the custom color selector and create 
a custom color           by doing any of the following:

 — Select a color with the color slider and color field.

 — Enter a hexadecimal value in the field provided.

 — Select a color model in the drop-down provided and enter the following in the fields provided:
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 ¡ For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 ¡ For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 ¡ For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 ¡ For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 — Click  to activate the color picker and move your mouse over a spot on your computer that has 
the color you wish to use. Click your mouse to select the color.

 l Border Color — to change the default color of the border for a Control object added to the margin, 
select the Border Color drop-down. A grid of available and standard colors appears. Select a color 
from the grid or click  More Colors to switch to the custom color selector and create a custom 
color (see Background Color).

 l Border Dash Style — to change the default type of line used for a border of a Control object added to 
the form, select one of the following options from the Border Dash Style drop-down:

 — Solid : for a single solid line

 — Dash : for a consistent dashed line

 — Dot : for a consistent dotted line

 — Dash-Dot: for a line that alternates between dashes and dots

 — Dash-Dot-Dot: for a line that alternates between dashes and two dots

 — Double : for two solid lines

 l Border Width — To change the default thickness for a border of a Control object added to the 
margin, enter a value in pixels in the Border Width text field.

 l Borders — To determine what sides of a object will have borders by default, click the Borders drop-
down and complete the following steps:

 — Click All to have borders on all sides of the objects added to the form.

 — Click None to not have any borders on the objects added to the form.

 — Click  at the top, bottom, left, or right edge of the border drop-down to toggle whether the 
top, bottom, left, or right border is applied to objects added to the form

 l Font — click the ellipsis (...) next to the Font field to open the Font window. Select a default font 
family, style, size, effect, and script for text-based objects added to the margin and click OK.
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 l Foreground Color — to change the default text color for text-based objects added to the margin, 
select the Foreground Color drop-down. A grid of available and standard colors appears. Select a 
color from the grid or click  More Colors to switch to the custom color selector and create a 
custom color (see Background Color).

 l Padding — to control the default amount of space between a Control object's contents and the 
border click the arrow next to Padding to expand the padding options. Enter values in pixels in the 
fields available.

 l Text Alignment — to set the alignment of the object's text, select one of the following values from the 
Text Alignment drop-down: Top Left, Top Center, Top Right, Middle Left, Middle Center, Middle 
Right, Bottom Left, Bottom Center, Bottom Right, Top Justify, Middle Justify, and Bottom Justify.

Layout properties. Layout properties define the margin's height.

 l Height — to define the margin's height for a custom paper size, enter a height in hundredths of an 
inch in the field provided.

Modify Form Report Detail Section

You can use the Properties pane for a form report theme's detail section to define the details for every 
sections' height as well as default appearance settings for objects added to the section and whether 
there's a page break at the end of each section.

To modify the properties of a form report detail section, with a form report theme selected in the Form 
Designer click the center of the workspace area to select Detail1. The detail section's available properties 
load in the Properties pane.

Appearance properties. When a detail section's default appearance settings are configured, any Control 
object added to the detail section will inherit its property settings from the detail's appearance properties 
and any appearance properties defined in the detail section's Properties pane will override properties set in 
the detail section. If the appearance properties for an object are defined in the object's Properties pane, any 
defaults set in the detail section are ignored and the Control object's settings are used.

The following default appearance settings are available for the detail section:

 l Background Color — to change the default background color for a Control object added to the detail 
section, select the Background Color drop-down. A grid of available and standard colors appears. 
Select a color from the grid or click  More Colors to switch to the custom color selector and create 
a custom color by doing any of the following:

 — Select a color with the color slider and color field.

 — Enter a hexadecimal value in the field provided.

 — Select a color model in the drop-down provided and enter the following in the fields provided:
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 — For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 — For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 — For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values

 — For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 — Click  to activate the color picker and move your mouse over a spot on your computer that has 
the color you wish to use. Click your mouse to select the color.

 l Border Color — to change the default color of the border for a Control object added to the detail 
section, select the Border Color drop-down. A grid of available and standard colors appears. Select 
a color from the grid or click  More Colors to switch to the custom color selector and create a 
custom color by doing any of the following:

 l Border Dash Style — to change the default type of line used for a border of a Control object added to 
the form, select one of the following options from the Border Dash Style drop-down:

 — Solid : for a single solid line

 — Dash : for a consistent dashed line

 — Dot : for a consistent dotted line

 — Dash-Dot: for a line that alternates between dashes and dots

 — Dash-Dot-Dot: for a line that alternates between dashes and two dots

 — Double : for two solid lines

 l Border Width — to change the default thickness for a border of a Control object added to the form, 
enter a value in pixels in the Border Width text field.

 l Borders — to determine what sides of a object will have borders by default, click the Borders drop-
down and complete the following steps:

 — Click All to have borders on all sides of the objects added to the form.

 — Click None to not have any borders on the objects added to the form.

 — Click  at the top, bottom, left, or right edge of the border drop-down to toggle whether the 
top, bottom, left, or right border is applied to objects added to the form

 l Font — click the ellipsis (...) next to the Font field to open the Font window. Select a default font 
family, style, size, effect, and script for text-based objects added to the form and click OK.
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 l Foreground Color — to change the default text color for text-based objects added to the form, select 
the Foreground Color drop-down. A grid of available and standard colors appears. Select a color 
from the grid or click More Colors to switch to the custom color selector and create a custom color 
(see Background Color, above).

 l Padding — to control the default amount of space between a Control object's contents and the 
border click the arrow next to Padding to expand the padding options. Enter values in pixels in the 
fields available.

 l Text Alignment — To set the alignment of the object's text, select one of the following values from the 
Text Alignment drop-down: Top Left, Top Center, Top Right, Middle Left, Middle Center, Middle 
Right, Bottom Left, Bottom Center, Bottom Right, Top Justify, Middle Justify, and Bottom Justify.

Behavior properties. Behavior properties determine whether each report section starts on their own page 
or continues where the previous section ended.

 l Page Break — to set a page break for each section, select an option from the Page Break drop-
down.

Layout properties. Layout properties define the detail section's height.

 l Height — to define the detail section's minimum height, enter a height in hundredths of an inch in the 
field provided. When the form report is generated, each section will take up at least the height 
designated in the field. If page breaks are set up for a report, the space used by the section may 
increase.

Add Objects to a Margin or Section

The same data fields that can be shown in a data entry form can be added to a form report theme. In 
addition, labels, rich text fields, static pictures, lines, and shapes can be added to improve the design of the 
form report. panes can be added, which allow form report objects to be grouped together. Page breaks are 
available to control when objects should appear on different pages in a report, while PCS Report Info and 
Page Info controls can be added to the margins to provide contextual information for a report.

When an object is added to a detail section, When an object is added to a top or bottom margin, it will 
appear at the top or bottom of every page. If a data field is added to a margin, the information that appears 
in the margin on the report's page comes from the first record to appear on that page.

If a property can be reset, the check box will be filled in black. To reset a property, click the check box to the 
far right of the property name line. 
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Figure  16-87. Resetting a Property

When you click on a Property, a definition of the property displays at the bottom of the screen. For example, 
Background Color has been selected in the following image. The definition for Background Color is shown 
in the pane below Properties. Use these definitions to understand each of the properties listed in this pane.
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Figure  16-88. Property Descriptions

 l Add Data Fields. To add a field to the form report theme, find the desired field in the Field List pane. 
Click to select the field and drag it to the form report theme. A data field is added to the form report 
theme. The colors, borders, padding, font, size, location, and alignment of the field can be edited in 
the Properties pane, as well as what type of caption should accompany the field and if the field's text 
should wrap to the next line.

 l Add Images Fields. To add an images field to the form report theme, find the desired field in the Field 
List pane. Click to select the field and drag it to the form report theme. The images field is added to 
the form report theme. The caption, colors, borders, padding, font, size, location, and alignment of 
the field can be edited in the Properties pane, as well as which images from the images field should 
be included in the form report and how the images are displayed.

 l Add Labels, Pictures, Lines, and Shapes. To add a text label, rich text field, picture, shape, or line to 
the form report theme, click to select the desired control from the Control toolbar and drag it to the 
form report theme.
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Depending on the control added, various properties can be edited in the Properties pane. A label's 
color, border, padding, angle, size, location, text alignment and trimming, label text, word wrap and 
multiline capabilities, and font style can be edited; a rich text field's color, border, padding, size, 
location, and font style can be modified; a picture's source file can be identified and its color, border, 
padding, size, location, and alignment can determined; and a shape and line's color, padding, 
border, size, and location can be set. A shape's angle and shape type can also be defined.

 l Rich Text Fields. Rich text fields allow you to load text from a formatted document into the control 
and retain formatting that exists in the file. To add a rich text field to the form report theme, click to 
select the control from the Control toolbar and drag it to the form report theme. Right-click on the rich 
text field and select Load File from the context menu. Navigate to and select the file that contains the 
formatted text and click Open. The text in the document loads into the rich text field control, retaining 
any compatible formatting.

A rich text field's color, border, padding, size, location, and font style can be modified in the 
Properties pane.

 l Add panes. panes allow form report objects to be grouped together. To add a pane to the form 
report theme, click to select the pane from the Control toolbar and drag it to the form report theme. 
Once added to the form report theme, edit the colors, borders, padding, size, and location of the 
pane in the Properties pane.

 l Add PCS Report Info. The PCS Report Info control is a text control that will display the company 
name (configured in Options) and the report title, selected ROWs, selected filters, and selected 
options for the report (configured when creating or editing the Form Report). This control is most 
often added to a form report margin.

To add the PCS Report Info to the form report theme, click to select the control from the Control 
toolbar and drag it to the theme. Once added to the form report theme, the PCS Report Info's color, 
border, padding, size, location, text alignment and trimming, word wrap, and font style can be 
modified.

 l Add Page Info. To add a page number, current date, user name, or page count to the form report 
theme, click to select Page Info from the Control toolbar and drag it to the theme. This control is most 
often added to a form report margin. Once added to the form report theme, the Page Info control's 
color, border, padding, size, location, text alignment, word wrap, and font style can be modified, as 
well as the page info format and starting page number.

 l Add Page Breaks. To add a page break to the form report theme, click to select the Page Break 
control from the Control toolbar and drag it to the theme. Anything added below the page break in 
the theme will be moved to the next page in the generated form report. The location of the page 
break can be modified in the Properties pane.

Once objects are placed on the form report theme, they are ready for editing, resizing, and rearranging.
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Edit Objects in a Margin or Section

When an object is added to the form, it inherits the default styles set in the margin or section that the object 
was added. If no default was set for the margin or section, the report page's defaults are used. You can 
override these defaults by modifying the objects' properties in the Properties pane.

Appearance properties. Appearance properties define the color, borders, and padding of the space 
allotted for the object.

When the appearance properties for an object added to the form are modified in the Properties pane, any 
defaults set in the form report, the margin, or the detail section are ignored and the object's settings are 
used. Depending on the object selected, the appearance properties available in the Properties pane will 
vary.

If a property can be reset, the check box will be filled in black. To reset a property, click the check box to the 
far right of the property name line. 

Figure  16-89. Resetting a Property

When you click on a Property, a definition of the property displays at the bottom of the screen. For example, 
Background Color has been selected in the following image. The definition for Background Color is shown 
in the pane below Properties. Use these definitions to understand each of the properties listed in this pane.



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 877

Figure  16-90. Property Descriptions

The following appearance settings may be available for the object:

 l Background Color — to change the background color for an object added to the form, select the 
Background Color drop-down. A grid of available and standard colors appears. Select a color from 
the grid or click  More Colors to switch to the custom color selector and create a custom color            by 
doing any of the following:

 — Select a color with the color slider and color field.

 — Enter a hexadecimal value in the field provided.

 — Select a color model in the drop-down provided and enter the following in the fields provided:

 — For RGB color model: Red (R), Green (G), Blue (B), and Alpha (A) values

 — For CYMK color model: Cyan (C), Magenta (M), Yellow (Y), and Black (K) values

 — For HSL color model: Hue (H), Lightness (L), Saturation (S), and Alpha (A) values
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 — For HSB color model: Hue (H), Saturation (S), Brightness (B), and Alpha (A) values

 — Click  to activate the color picker and move your mouse over a spot on your computer that has 
the color you wish to use. Click your mouse to select the color.

 l Border Color — to change the color of the border for an object added to the form, select the Border 
Color drop-down. A grid of available and standard colors appears. Select a color from the grid or 
click  More Colors to switch to the custom color selector and create a custom color (see 
Background Color, above).

 l Border Dash Style — To change the default type of line used for a border of a Control object added to 
the form, select one of the following options from the Border Dash Style drop-down:

 — Solid : for a single solid line

 — Dash : for a consistent dashed line

 — Dot : for a consistent dotted line

 — Dash-Dot: for a line that alternates between dashes and dots

 — Dash-Dot-Dot: for a line that alternates between dashes and two dots

 — Double : for two solid lines

 l Border Width — to change the default thickness for a border of a Control object added to the form, 
enter a value in pixels in the Border Width text field.

 l Borders — to determine what sides of a object will have borders by default, click the Borders drop-
down and complete the following steps:

 — Click All to have borders on all sides of the objects added to the form.

 — Click None to not have any borders on the objects added to the form.

 — Click  at the top, bottom, left, or right edge of the border drop-down to toggle whether the 
top, bottom, left, or right border is applied to objects added to the form

 l Fill Color — to change the fill color for shapes added to the form, select the Foreground Color drop-
down. A grid of available and standard colors appears. Select a color from the grid or click  More 
Colors to switch to the custom color selector and create a custom color (see Background Color, 
above).

 l Font — click the ellipsis (...) next to the Font field to open the Font window. Select a font family, style, 
size, effect, and script for text-based objects added to the form and click OK.
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 l Foreground Color — to change the text color for text-based objects added to the form or the line 
color for lines and shapes added to the form, select the Foreground Color drop-down. A grid of 
available and standard colors appears. Select a color from the grid or click  More Colors to switch 
to the custom color selector and create a custom color (see Background Color, above).

 l Line Direction — to change the direction the line is drawn for a line object, select the preferred 
direction from the Line Direction drop-down.

 l Line Style — to change the type of line used for the outline of a shape or line object added to the form, 
select one of the following options from the Line Style drop-down:

 — Solid : for a single solid line

 — Dash : for a consistent dashed line

 — Dot : for a consistent dotted line

 — Dash-Dot: for a line that alternates between dashes and dots

 — Dash-Dot-Dot: for a line that alternates between dashes and two dots

 — Double : for two solid lines

 l Line Width — to change the thickness of the line for a shape or line object added to the form, enter a 
value in pixels in the Line Width text field.

 l Padding — to control the amount of space between a Control object's contents and the border click 
the arrow next to Padding to expand the padding options. Enter values in pixels in the fields available.

 l Text Alignment — to set the alignment of the object's text, select one of the following values from the 
Text Alignment drop-down: Top Left, Top Center, Top Right, Middle Left, Middle Center, Middle 
Right, Bottom Left, Bottom Center, Bottom Right, Top Justify, Middle Justify, and Bottom Justify.

 l Text Trimming — to define what should happen when the text for the field extends beyond the space 
allotted for the control, select one of the following values from the Text Trimming drop-down:

 — None: does not trim the text content in any special way.

 — Character: trims the text after the last character to fully fit within the bounds of the field.

 — Word: trims the text after the last word to fully fit within the bounds of the field.

 — Ellipsis Character: trims the text after the last character to fully fit within the bounds of the field 
and adds an ellipsis (...) in place of remaining text.

 — Ellipsis Word: trims the text after the last word to fully fit within the bounds of the field and adds 
an ellipsis (...) in place of remaining text.
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 — Ellipsis Path: trims enough text from the middle of the text to fully fit within the bounds of the 
field and adds an ellipsis (...) in place of removed text. This selection is useful for displaying file 
paths, since the filename at the end of the path contains the most relevant information.

Behavior properties. Behavior properties determine how the object fills the space allotted for the object.

 l Angle — enter a value in degrees in the Angle text field to rotate the object.

 l Format — to show the page information in a customized format, click the ellipsis (...) next to the 
Format field to open the Format String Editor window. Select a category from the list on the left and a 
format from the pane on the right and click OK.

 l Image Alignment — to set the alignment of the image in the space available for the control, select one 
of the following values from the Image Alignment drop-down: Top Left, Top Center, Top Right, 
Middle Left, Middle Center, Middle Right, Bottom Left, Bottom Center, and Bottom Right

 l Keep Together — to keep the entire object together on the same page, click to select the Keep 
Together check box. If a page break would naturally occur in the middle of the object, it will move to 
the next page instead of breaking across pages.

 l Multiline — to allow multiple lines of text to be entered in the label, click to select the Multiline check 
box. If the check box is cleared, text that is entered on multiple lines in the label will combine into one 
long string of text.

 l Page Information — select an option from the Page Information drop-down to define what 
information is shown in the control.

 l Shape — select a shape from the drop-down provided to change the shape that's drawn on the form 
report.

 l Sizing — select an option in the Sizing drop-down to determine if the image should fill the space 
available for the control and how it should be filled.

 l Start Page Number — if the information showing in the control is a page number, enter a value in the 
Start Page Number to indicate what page number should be displayed for this control on the first 
page of the report. This is useful mainly if you combine the PCS report with other materials to form a 
single report and wish for the page numbers to be accurate for the final report.

 l Stretch — to stretch the shape to fill the space available for the control, click to select the Stretch 
check box. To maintain the exact angle defined in the Angle property, click to clear the Stretch check 
box.

 l Word Wrap — to define what should happen when the text for the field extends past the first line, 
click to select or to clear the Word Wrap check box. To have the text wrap to the second line, the 
check box should be selected. To trim the text, the check box should be cleared.

Data properties. Data properties define what content is displayed in the control.
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 l Image — to preview the image identified for the image control, click once in the Image field. The 
following actions are available with the image preview box showing:

 — Clear the Image — to clear the image from the image control, click Clear.

 — Define an Image — to define or redefine the image that shows in the image control, click the 
image preview box and navigate to the image in the Open window that appears. Select the 
image and click Open.

 l Image URL — to define the image that shows in the image control by file path or URL, enter the path 
to an image in the Image URL field.

 l Text — enter text in the field provided to define the text shown in the label.

Design properties. The design property identifies a unique name for the object selected on the form. This 
field does not need to be edited.

Display properties. Display properties define how and if the caption, images, and barcode should show in 
the report.

 l Caption Text — enter text in the Caption Text field to change the text that appears alongside the 
value of the data field.

 l Description Height — enter a value in hundredths of an inch to define the space available for an 
image's description.

 l Display Mode — select an option from the Display Mode drop-down to define how the field and 
caption should be shown on the form report. If either BarCodeAndValue or 
BarCodeValueAndCaption is selected, make sure the control on the form is tall enough to show a bar 
code below the value.

 l Image Columns — to show several images in an images field on one row, enter the number of images 
that should be shown on a single row in the field provided.

 l Image Count — if Count is selected in Image Display Mode, enter the number of images from the 
selected images field that should be included in the report.

 l Image Display Mode — select from the following options from the Image Display Mode drop-down to 
define which images from the selected images field should be included in the report:

 — All — includes all images from the selected images field

 — Count — includes a specified number of images from the selected images field, as defined in 
the Images Count property. The order the images are defined in the images field determines 
which images will be included in the report.
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 — PrimaryOnly — only displays the image defined as the images field's primary image. If no 
primary image is defined for the images field, no image will be displayed.

 — PrimaryOrFirst — displays the image defined as the images field's primary image. If no primary 
image is defined for the images field, the first image in the list of images for the field is 
displayed.

 l Show Caption — click to select the Show Caption check box if you want to show the caption for 
images fields. Click to clear the check box to hide the caption on the report.

Layout properties. Layout properties define the control's size and location on the form report.

 l Location — to modify the control's location in relation to the margin, section, or pane the object's 
placed in, click to expand the Location property and enter an X or Y value in hundredths of an inch in 
the fields provided.

 l Size — to modify the control's size, click to expand the Size property and enter a Height and Width in 
hundredths of an inch in the fields provided.

Arrange Objects in a Margin or Section

Form report objects can be repositioned on the form report theme to a general location using the mouse or 
to a precise location using the keyboard or alignment buttons. When a pane is moved, the objects within 
the pane move with the pane.

Objects must be selected on the form report theme before rearranging. Do any of the following:

 l To select a single object, click to select the form report object.

 l To select multiple objects, click to select a form report object, then press the shift key and click to 
select additional form report objects.

 l To select a group of objects located near each other, click in an empty spot on the form report theme 
and drag to create a selection box around the objects. Release the mouse to select the objects within 
the selection box.

Move Objects Manually

Form objects can be manually moved to a general location using the mouse or to a precise location using 
the keyboard. Select one or more form objects and do one of the following:

 l Click and drag the form object(s) to the desired location.

 l Press the left, right, up, or down arrow keys on the keyboard to move the form object(s) incrementally 
to the left, right, up, or down.



PCS v2.5 User Guide

Chapter 16: Reports and Graphs 883

Align Objects

Form objects can be repositioned so that the objects' edges or center points are aligned. When form 
objects are aligned, they are repositioned according to the location of the first selected object.

Horizontal alignment — select multiple form objects and click , , or  to align the objects according to 
the first selected object's left edge, horizontal center, or right edge.

Vertical alignment — select multiple form objects and click , , or  to align the objects according to 
the first selected object's top edge, vertical center, or bottom edge.

Distribute Objects

Form objects can be repositioned so that the the is an equal amount of space vertically or horizontally 
between the selected objects. The top-most and bottom-most form objects stay in place while all other 
form objects are distributed between those two form objects. Select multiple form objects and click 
Horizontal or Vertical to distribute the form objects horizontally or vertically on the form theme.

Re-size Objects in a Margin or Section

Form report objects can be manually re-sized to a general size and shape using the mouse or to match the 
size to other form report objects using buttons in the ribbon. Select one or more form report object(s) and 
do one of the following:

 l Hover the mouse over a corner or edge of the form object until the cursor changes to , , . Click 
and drag the corner or edge until the form object(s) reach the desired size or shape.

 l Click , , or  to resize all selected form object(s) to match the width, height, or full size of the first 
selected object's width, height, or full size.

Manage the Form Report Theme

Complete the following actions when working with or finishing creating a form report theme.

 l To undo all recent changes that have not yet been saved, click  Cancel. All graph layout themes 
are reverted to their latest saved state.

 l To save the graph report layout theme, click  Save. All changes made to the theme is saved.

 l To remove the currently selected theme, click  Delete  in the header row and then  Yes in the 
Confirm Delete window. The currently selected theme is removed from PCS.

 l To save the theme and close the Graph Layouts editor, click  Save and Close. All changes made to 
the theme is saved and the Graph Layouts editor is closed.
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 l To close the Forms editor, click  Close. If there are unsaved changes to a graph report layout 

theme in the Forms editor, a Save Changes? window displays. Click  Yes to save all changes in 

the themes,  No to close without saving changes, or Cancel to return to the Forms editor.

Use the Form Report Theme

Complete the following steps to apply the theme in a form report when creating a new form report:

 1. Click to select a theme from the Select Form Theme drop-down list.

Figure  16-91. Select Form Theme Drop-down List

 2. Select the desired fields filter and sort options. Refer to Work With Form Style Reports on page 822 
for detailed instructions.

 3. Click  Print to open the report in a Print Preview window.
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Add a Report Sort Theme

A sort theme determines how PCS sorts and groups records in the report. Adding a sort theme allows you 
to choose which field(s) to sort and group records by, such as sorting by name or ROW code. A sort theme 
also allows you to set options for sorting records alphanumerically in either ascending or descending order. 
Including a group filter in the sorting theme allows you to organize records in a group for easier analysis.

These instructions start with the assumption that  the correct pipeline segments have been selected. For 
information detailing how to select pipeline segments, refer to Select ROWs on page 171.

Complete the following steps to add a report sort themes:

 1. Select the report you want to work with in the Reports/Graphs menu. Click Report/Graphs and then 
select a report in the list.

For example, click Reports/Graphs > Test Point Reports > Test Point Inspection Report.

 2. Click the  Customize tab then the Sorts tab to open the Sorts window.

Figure  16-92. Report Sorts Window

 3. Click  Add to open the New Sort Layout window.
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Figure  16-93. New Sort Layout

 4. Enter a name for the sorting theme in the field Enter Theme Name. 

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 5. If you want to create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme.

Themes are either public or private. A public theme is available for use by all PCS users. A private 
theme is available only to the user who creates it.

 6. If you want to copy fields from another layout theme, click the Copy Content check box and then 
select a theme from the  Copy Fields From Theme drop-down list.

 7. Click  OK to save changes and return to the Sorts window.

 8. Complete the following steps to add and remove fields in the report sort theme as needed:
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 a. Click the toggle arrow  for a field category in the left pane of the window to view a list of fields 
available for selection. For example, click  All Fields.

 b. Select a field by clicking in the check box for the field and then click the  button to move it 
to the left pane. You can also double-click a field  to move it to the right pane. Repeat this step 
as needed. The report layout theme includes all fields in the right pane of the Layouts window.

 c. To remove a field in the layout theme, select the filed in the left pane and then click the  
button to move it to the right pane. You can also double-click a field  to move it to the left pane. 
Repeat this step as needed.

 d. Select a sorting method for each field listed in the right pane. To sort grid records in ascending 

order, click the toggle button to select  . To sort in descending order, click the 

toggle button to select  .

 e. To change the order of fields in the right pane and subsequently in the grid, click and drag a 

field to a new position in the list. Or, select a field and then click the  or   button.

 9. Complete the following steps to add a new group with one or more fields that determine how records 
sort in the report:

 a. Click  Add group to add a new group.

Figure  16-94. Sort Theme Groups

Click the  icon for an existing group (such as City) to open a group box with current settings 
and edit if needed.
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 b. Select which PCS field starts the new group when that field's value changes. Select a field in 
the Start a new group when this value changes drop-down list.

 c. If you want to add another field in the group, click  Add Additional Field. Then select a field in 
the selection list. The title bar of group includes the name of each field.

 d. Select a sorting method for the new group. To sort the group in ascending order, click the 

toggle button to select  . To sort in descending order, click the toggle button to 

select  .

 e. To change the position of the new group within the set of other groups in the theme, click the 

 or   button. PCS processes groups in descending order beginning with the group at 
the top of the set.

 f. To apply optional settings to the new group, click the check box for the following options as 
needed:

 l Click the check box Print group field in group header to have the group name print as a 
heading at the beginning of each group.

 l Click the check box New page for each group to have each group print on a new page.

 l Click the check box Print sums in group footer to have the total number of records in a 
group print at the end of each group.

 g. Choose which fields to include in the new group. Click the toggle arrow  for a field category in 
the left pane of the window to view fields available for selection. 

 h. Double-click a field listed in the left pane to move it to the right pane, such as Facility ID shown 
in the next figure. Repeat this step as needed. The theme includes all fields listed in the right 
pane.

 i. Choose a sorting method for each field added in the new group. To sort fields in ascending 

order, click the toggle button to select  . To sort in descending order, click the 

toggle button to select  .

 j. To change the position of fields in the new group, click the  or   button.

 10. Click  Save and Close to save changes and return to the report options window.

 11. To apply the sorting theme to a report, click the down arrow in Select Sort Theme and select the 
sorting theme in the selection list.
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Add or Edit an AND or OR Filter Group

The Filters pane consists of a set of pre-defined filters as well as on demand filters grouped together with 
AND or OR joins. A filter group is a named set of one or more filters that affect the data returned. Adding an 
AND filter group produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. PCS processes all filters in AND filter groups 
together then processes all filters in OR filter groups together. 

You can add an AND filter group to restrict the data returned in a report so it only contains a subset of 
records that meet all filter conditions. PCS processes filters in a filter group in descending order beginning 
with the filter at the top of the filter group.

An OR filter group is a named set of one or more filters that affect the data output of a route selected in 
Define Routes. Adding an OR filter group produces a subset of records that meet any filter condition. PCS 
processes filters in a filter group in descending order beginning with the filter at the top of the filter group.

These instructions start with the assumption that a PCS module is already selected and the correct pipeline 
segments have been selected. For information detailing how to select pipeline segments, refer to Select 
ROWs on page 171.

Complete the following steps to create or edit an AND or an OR filter group for use in the Reports/Graphs 
window:

 1. Choose the report you want to work with in the Reports/Graphs menu.

 2. Click Report/Graphs and then select a report, such as Test Point Inspection Report, to open the 
report options window.

 3. Click the Customize tab and then the Filters tab to open the Filters window.

 1. To create a new And group, click New 'And' Group  to open the filter properties group box.         

Figure  16-95. And Group Filters 

 2. To create a new Or group, click New 'Or' Group  to open the filter properties group box.         
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Figure  16-96. Or Group Filters 

 3. Type a name for the filter group in the Filter Group Caption field. 

 4. Select the Filter Is Always On option to keep the filter on.

 5. Use filter selection fields to set up filter criteria. Select a PCS field, operator, and one or more filter 
conditions.

 a. When adding a date filter, set a date range using a calendar or dynamic dates in one of the 
following ways:       

 l Type a date in the start and end date fields. Enter a start and end date using the format 
M/DD/YYYY to indicate the month, day, and year.               

 l To set a date range using a calendar, click the down arrow in the start date field to open 
a calendar and select a date. Repeat this step for the end date field.         

 l To set a date range using dynamic start and end dates, click the  calculator icon in the 
start date field and set up dynamic date properties. Repeat this step for the end date 
field. Clicking the calculator button opens and closes dynamic date property fields. 

 b. Type a name for the filter in the Enter Custom Filter Caption field. 

 c. If additional filters are needed within the filter group, click  and repeat these steps.       

 6. If necessary, click the  edit icon for a filter to open that filter's property settings and change 
settings as needed. 

 7. Click  Save to save the filter group.         

 8. Click  Save and Close when finished saving all filter groups.         

Edit and Arrange Filter Groups

PCS processes filters in a filter group in descending order beginning with the filter at the top of the filter 
group. Information in this section explains how to edit filter property settings and also how to arrange filters 
in a group of filters.

Complete the following steps to edit and arrange filter groups:
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 1. Click Report/Graphs and then select a report, such as Test Point Inspection Report, to open the 
report options window.

Figure  16-97. Report Options

 2. Click the Customize tab then the  Filters tab to open the Filters window.
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Figure  16-98. Filters

 3. Click the edit icon  to display a filter's property settings. In the following example, property settings 
for Inspection Data Is between are visible.

Figure  16-99. Inspection Date Is Between

 4. To rename the filter, type a description in the Enter Custom Filter Caption field.

 5. To change filter criteria, use filter selection fields to select a PCS field, operator, and one or more filter 
conditions. When adding a date filter, such as Inspection Date Is Between, set a date range using a 
calendar or dynamic dates in the following manner:
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 6. To enable the filter for all sessions of the report, select the Filter is Always On check box. When this 
check box is not selected, toggle the filter on and off in the report options page using the filter's check 
box.

 7. To set a date range using a calendar, click the down arrow in the start date field to open a calendar 
and select a date. Repeat this step for the end date field.

 8. To set a date range using dynamic start and end dates, click the  icon in the start date field and set 
up dynamic date properties. Repeat this step for the end date field. Clicking the calculator button 
opens and closes dynamic date property fields.

 9. To delete a filter in a filter group, click the  icon.

Figure  16-100. Deleting a Filter Group Box

 10. To close the filter's property settings group box, click the  icon next to the filter name.

Figure  16-101. Close the Filter Group Box

 11. Click  Save and Close to return to the report options window.
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Appendix A: Database Management
The information in this section is intended for the PCS Administrator or a user with SysAdmin permissions. 

Database management includes such tasks as tracking data changes, running database integrity checks 
or re-indexing, or moving records using the Data Modification Utility.

This chapter  includes the following topics:

 l Overview of the PCS Databases on page 894

 l Track Data Changes on page 896

 l Run Database Integrity Check on page 917

 l Run Reindex Database on page 919

 l Move Records With Data Modification Utility on page 920

Overview of the PCS Databases
The PCS application uses three databases to store and manage PCS data: the main PCS database, an 
Images database, and an Export database.

 l Main PCS database — contains all data necessary for the successful use of PCS, including PCS 
data, settings, and customizations.

 l Images database — named by appending _Images to the end of the main PCS database name; 
contains all images that have been attached to an images field for a record in PCS.

 l Export database — named by appending _Export to the end of the main PCS database name; 
contains the data exported by the beta Export to Table feature.

While the Images and Export databases must exist alongside the PCS database to use the Image 
Management and Export to Table features, we have designed PCS to work independent of the data in the 
Images and Export databases. References to the images, as well as the descriptions and properties of the 
image, exist within the main PCS database. If the corresponding image does not exist in the Images 
database, the image will not show but all other information for the image remains.

The following are some common questions about the creation, use, and maintenance of the PCS 
databases.
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Can I Create My Own PCS Databases

No. PCS depends upon a specific schema in the PCS databases, and in the case of the main PCS 
database, certain data must exist in the database. To create missing PCS databases, such as the Images 
or Export database, click Create/Upgrade in the PCS Connection Manager. The missing databases will 
be created with the proper schema but without PCS data.

Any user who clicks  Create/Upgrade in the PCS Connection Manager during the upgrade/installation 
process must have permissions to create and modify a SQL database.

If you have any questions or need further assistance, give us a call at 1-800-229-3404 or email us at 
support@aiworldwide.com.

Which PCS Databases Should I Backup?

You should regularly back up all or some of your PCS databases based on the needs of your organization, 
including complying with state and federal regulations and corporate IT policies. This may mean that both 
the main PCS and the Images databases are backed up, or if server space is a concern, only a portion of 
the main PCS database is backed up on a regular basis. Since it contains a subset of the data that existed in 
the PCS database at a specific point of time, the Export database does not typically need to be backed up.

If you restore the backup of the PCS database without an Images database, records in the backup with 
attached images will still contain the information about the images, but the images themselves will not be 
made available. If, however, you restore the Images database with the main PCS database or the original 
Images database still exists when you restored the backup, those images will be available in PCS.

Do I Have to Have the Images and Export Databases?

Yes, if you want to use either the Image Management or Export to Table features. These databases can 
remain empty of actual PCS content, but in order to use the corresponding feature in PCS, they must have 
been created in the PCS Connection Manager.

If you do not have an Images database in your SQL instance, you cannot use an images field in a grid layout 
or form of Edit Module Data, include an images field in a report, or have an images field in a prompt sent to 
or received from a field computer. Adding these fields to a layout or form theme or in a report, or sending or 
receiving field computer data with the images field in a prompt will result in errors.

The Export database must exist if you use the Export to Table feature in the Bridge.

How Do I Send PCS Databases for Technical Assistance

You can send a backup of just the main PCS database to AI Support for troubleshooting assistance or data 
projects without impacting the use of images in PCS. Simply backup and send your main PCS database to 
AI or your database administrator. The AI Support team can assist in your data needs without accessing the 
images or impacting links to images in the Images database.

mailto:support@aiworldwide.com?subject=AI Support
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Track Data Changes
If enabled in the Options window (Tools > Options), PCS keeps a log of all changes made to PCS data. 
When data changes are tracked, additions, modifications, and deletions of data are stored in the PCS 
database. Additional information about the data change is recorded, such as who made the change, what 
tool was used to make the change, when the change was made, and what the data was before the change. 
With this information, data audits become more reliable and troubleshooting data abnormalities is made 
easier.

When PCS is upgraded, custom modules or user defined fields are created, or data usage changes, an 
update to change tracking set ups may be necessary. A review should be done to ensure any new tables or 
fields have the correct change tracking settings and all existing tables and fields' settings are still 
appropriate.

If you configure enhanced change tracking with CDC and SQL Server Agent is used to pull changes into 
PCS, ensure SQL Server Agent is running at all times. In this scenario, if SQL Server Agent is not running, 
changes to data in CDC-enabled tables will still be tracked in the SQL transaction log. However, they will 
not be available to PCS and the PCS job service until the SQL Server Agent is restored. If the SQL Server 
Agent is still not running when a SQL backup occurs, changes that were made while the SQL Server Agent 
was stopped will be lost. 

For more information about setting up, modifying, disabling, and using change tracking, refer to the 
following topics:

 l Configure Change Tracking

 l Update or Modify Change Tracking on page 907

 l Disable Change Tracking on page 914

 l Access Change History Records on page 915

Configure Change Tracking

Change history can be configured two different ways: using a simple trigger or enhancing the triggers with 
change data capture (CDC). A trigger is very easy to set up and is compatible with all PCS setups but can 
cause large operations, such as bulk imports or updates of data, to take slightly longer to complete. 
Enhancing change tracking with CDC requires an enterprise version of Microsoft SQL Server and some 
advanced configurations, including granting elevated SQL rights to PCS users, but has key advantages. 
When CDC is enabled, performance is optimized for recording changes and you have more control over the 
configuration and performance of the change tracking process.

You can configure CDC-based change tracking for all track-able tables in the database or for a subset of 
the tables. It is recommended to configure CDC-based tracking for any table that undergoes high-volume 
operations. Any table that PCS tracks but is not configured for CDC-based tracking will use a trigger to 
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record the database changes. If a table or field is set up to be tracked using CDC but System-Enable 
Change History is set to No in PCS, records of the changes will not be accessible from within PCS and may 
not be retained.

If you need help in determining which configuration is best for your company, refer to the following decision 
tree.

Figure  A-1. Change Tracking Configuration Decision Tree

To set up or modify change tracking with a trigger or CDC, refer to the following topics:

 l Set Up Change Tracking with a Simple Trigger

 l Set Up Enhanced Change Tracking with CDC

It is recommended that change tracking configurations are made during the initial configuration of PCS or 
while performing system maintenance. A field becomes locked while its change history setting is modified 
in Field and UDF Customizations. Users are prevented from adding, modifying, or deleting data that 
contains the field.
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If  SQL Server Agent is not running, changes to data in CDC-enabled tables will still be tracked. However, 
they will not be pulled into PCS until the SQL Server Agent is restored. If the SQL Server Agent is down for 
greater than 60 days, changes that were made more than 60 days ago will be lost.

Set Up Change Tracking with a Simple Trigger

Configuring PCS to track data changes with a trigger can be done from within PCS using the Field and UDF 
Customizations and Options menus under the Tools main menu. 

IMPORTANT: It is recommended that change tracking configurations are only made during the initial 
configuration of PCS or while performing system maintenance.

The following steps describe how to track data changes using a trigger either for all of PCS or individual 
fields.

Complete the following steps to enable overall change history for PCS:

 1. Click Tools > Options.

Figure  A-2. Options Window

 2. In the All pane, scroll down to Turn On Change Tracking and select it.
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Figure  A-3. Turn On Change Tracking Option

Complete the following steps to modify change tracking settings for individual fields as needed:         

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window. 

Figure  A-4. Field and UDF Customization Window

 2. Select a table in the Properties panel that includes the field you want to modify for change history. 

 3. In the grid, select the field you want to set up for change tracking.               
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 4. In the System-Track Changes column, select Yes to track changes made in the selected field while 
change history is enabled. Select No to not record any changes made in the field, even if change 
history is enabled in Options.               

 5. Repeat steps for additional fields. 

Set Up Enhanced Change Tracking with CDC

Configuring PCS to track data changes with change data capture (CDC) must be done both in SQL Server 
Management Studio and from within PCS using the Field and UDF Customizations and Options menus 
under the Tools main menu. 

IMPORTANT: It is recommended that change tracking configurations are made during the initial 
configuration of PCS or while performing system maintenance to avoid any impact to PCS users.

If  SQL Server Agent is not running, changes to data in CDC-enabled tables will still be tracked. However, 
they will not be pulled into PCS until the SQL Server Agent is restored. If the SQL Server Agent is down for 
greater than 60 days, changes that were made more than 60 days ago will be lost.

To set up enhanced change tracking using CDC, first complete either the steps to enable overall change 
history for PCS or for individual fields. Then complete the last set of steps to set up the SQL server.

Complete the following steps to enable overall change history for PCS:

 1. Click Tools > Options.

Figure  A-5. Options Window

 2. In the All pane, scroll down to Turn On Change Tracking and select it.
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Figure  A-6. Turn On Change Tracking Option

Complete the following steps to modify change tracking settings for individual fields as needed:         

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window. 

Figure  A-7. Field and UDF Customization Window

 2. Select a table in the Properties panel that includes the field you want to modify for change history. 

 3. In the grid, select the field you want to set up for change tracking.               
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 4. In the System-Track Changes column, select Yes to track changes made in the selected field while 
change history is enabled. Select No to not record any changes made in the field, even if change 
history is enabled in Options.               

 5. Repeat steps for additional fields. 

Complete the following steps to set up SQL Server:

 1. Connect to your PCS database using Microsoft SQL Server Management Studio.

 2. Open a new query window to enter SQL commands.

 3. Enter text to enable CDC with either of the following configurations:

 a. Continuous Mode— SQL Server Agent will run the process to capture changes on a regular 
basis, scheduled by default to run every five minutes. Enter the following text in the Query 

pane, replacing <databasename> with the actual name of your PCS database:

USE <databasename>
                      EXEC configureChangeTrackingCDCSettings @enableCDC = 1

 b. Continuous Mode with a Custom Polling Interval — SQL Server Agent will run the process to 
capture changes on a regular basis, scheduled to run according to your desired polling 

interval. Enter the following text in the Query pane, replacing <databasename> with the 
actual name of your PCS database and xx with the desired polling interval in seconds:

USE <databasename>
                      EXEC configureChangeTrackingCDCSettings @enableCDC = 1, 
@oneshotmode = 0, @pollingInterval = xx
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Figure  A-8. Enable CDC Mode in SQL Server Management Studio

 4. Select the entered text and click Execute.

To configure the SQL Server Agent to capture the changes, enter the following text in the Query 

pane, replacing <databasename> with the actual name of your PCS database:

USE <databasename>
                DECLARE @settings nvarcharkeyvaluepair
                INSERT @settings
                VALUES
                ( 'CDCCapture_MSCDC_Capture_Job_ExecutionMode', 'None' )
                EXEC configureChangeTrackingSettings @settings = @settings

Then right-click on SQL Server Agent and select Start.

 5. Grant each PCS user VIEW SERVER STATE privileges to the database. VIEW SERVER STATE 
privileges are required so PCS can match the transaction log, which stores the history of data 
changes, with user information. To grant each user VIEW SERVER STATE privileges, execute the 
stored procedure grantAxisUsersChangeTrackingPermissions saved in the PCS database.

Alternatively, you can manually grant each user database permissions. For more information, refer to 
the MSDN article GRANT Server Permissions (Transact-SQL) (https://msdn.microsoft.com/en-
us/library/ms186717.aspx).

 6.  1. Enable CDC for tables in the PCS database by doing the following:         

https://msdn.microsoft.com/en-us/library/ms186717.aspx
https://msdn.microsoft.com/en-us/library/ms186717.aspx
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 a. Determine which tables you want to enable CDC-based change tracking. Some tables are not 
tracked by PCS change tracking; tables that are not tracked by PCS should not be configured 
for CDC-based change tracking.

To get a list of all tables in the PCS database that are tracked by PCS change tracking but are 
not (yet) configured to use CDC to track changes, enter the following text in the Query pane, 

replacing <databasename> with the actual name of your PCS database:               

USE <databasename>
                      GO
                      SELECT OBJECT_NAME ( parent_id )
                      FROM sys.triggers
                      WHERE name LIKE '%changelogging'
                      AND name NOT IN (
                      SELECT name FROM sys.tables WHERE is_tracked_by_cdc = 
1 )
                      ORDER BY name
                      GO                     

Select the entered text and click Execute.               

It is recommended to configure CDC-based tracking for any table that undergoes high-
volume operations. You can configure CDC-based change tracking for all tables in the 
resulting list or for a subset of the tables. Any table that PCS tracks but is not configured for 
CDC-based tracking will use a trigger to record the database changes.               

If a table or field is set up to be tracked using CDC but System-Enable Change History is set to 
No in PCS, records of the changes will not be accessible from within PCS and may not be 
retained.               

 b. Enter the following text in the Query pane, replacing <databasename> with the actual name 
of your PCS database, replacing <tablename> with the name of the first table you wish to 
track using CDC, and adding , ( '<tablename>' ) for each additional table you wish to 
track with CDC to the end of the text statement:               

USE <databasename>
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( '<tablename>' )                     

Once all tables have been added to the statement in the Query pane, enter the following text to 
the end of the statement:               

EXEC configureChangeTrackingCDCTables @enable = 1, 
@tables = @tables                     

Select the text entered  and click Execute.               
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EXAMPLE: 
The following example script sets up the PCSAppTest database to track the 
ACCAInspection, ACVGSurveyFolder, and CISurveyFolder tables with CDC-
based tracking:               

USE PCSAppTest
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( 'ACCAInspection' ), ('ACVGSurveyFolder'), 
('CISurveyFolder')
EXEC configureChangeTrackingCDCTables  @enable 
= 1, @tables = @tables 

 2. If CDC is set up to track changes on specific tables that you wish to stop tracking, disable CDC for 
those tables in the PCS database by doing the following:         

 a. Determine which tables you want to stop CDC-based change tracking. Any table that PCS 
tracks but is not configured for CDC-based tracking will use a trigger to record the database 
changes. It is recommended to configure CDC-based tracking for any table that undergoes 
high-volume operations.

To get a list of all tables in the PCS database that currently have change tracking enabled with 

CDC, enter the following text in the Query pane, replacing <databasename> with the actual 
name of your PCS database:               

USE <databasename>
                      GO
                      SELECT *
                      FROM sys.tables
                      WHERE is_tracked_by_cdc = 1
                      ORDER BY name
                      GO                     

Select the entered text and click Execute.               

 b. Enter the following text in the Query pane, replacing <databasename> with the actual name 
of your PCS database, replacing <tablename> with the name of the first table you wish to 
stop tracking with CDC, and adding , ( '<tablename>' ) for each additional table you 
wish to stop tracking with CDC to the end of the text statement:               

USE <databasename>
                      DECLARE @tables nvarcharlist
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                      INSERT @tables
                      VALUES
                      ( '<tablename>' )                     

The following example script stops using CDC to track the ACCAInspection, 
ACVGSurveyFolder, and CISurveyFolder tables in the PCSAppTest database:               

USE PCSAppTest
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( 'ACCAInspection' ), ('ACVGSurveyFolder'), 
('CISurveyFolder')                     

 c. Once all desired tables have been added to the statement in the Query pane, enter the 
following text to the end of the statement:               

exec configureChangeTrackingCDCTables @enable = 0, 
@tables = @tables

 d. Select the text entered in steps and click Execute.               

 3. Update the change history setting in PCS by clicking to clear the Change History check box and then 
clicking to re-select the check box.         

 7. If CDC is set up to track changes on specific tables that you wish to stop tracking, disable CDC for 
those tables in the PCS database by doing the following:

 a. Determine which tables you want to stop CDC-based change tracking. Any table that PCS 
tracks but is not configured for CDC-based tracking will use a trigger to record the database 
changes. It is recommended to configure CDC-based tracking for any table that undergoes 
high-volume operations.

To get a list of all tables in the PCS database that currently have change tracking enabled with 

CDC, enter the following text in the Query pane, replacing <databasename> with the actual 
name of your PCS database:

USE <databasename>
                      GO
                      SELECT *
                      FROM sys.tables
                      WHERE is_tracked_by_cdc = 1
                      ORDER BY name
                      GO

Select the entered text and click Execute.
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 b. Enter the following text in the Query pane, replacing <databasename> with the actual name 
of your PCS database, replacing <tablename> with the name of the first table you wish to 
stop tracking with CDC, and adding , ( '<tablename>' ) for each additional table you 
wish to stop tracking with CDC to the end of the text statement:

USE <databasename>
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( '<tablename>' )

Once all desired tables have been added to the statement in the Query pane, enter the 
following text to the end of the statement:

exec configureChangeTrackingCDCTables @enable = 0, 
@tables = @tables

Select the entered text entered and click Execute.

EXAMPLE: 
The following example script stops using CDC to track the ACCAInspection, 
ACVGSurveyFolder, and CISurveyFolder tables in the PCSAppTest database:

USE PCSAppTest
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( 'ACCAInspection' ), ('ACVGSurveyFolder'), 
('CISurveyFolder')

 8. Update the change history setting in PCS by clicking to clear the Change History check box and then 
clicking to re-select the check box.

Update or Modify Change Tracking

Changes to whether a field's change history is retained can be made easily within PCS and tables can have 
CDC-based tracking enabled or disabled as needed. It is recommended that change tracking 
modifications are made during the initial configuration of PCS or while performing system maintenance to 
avoid any impact to PCS users. The following are some scenarios that warrant a review of the change 
tracking settings and may result in updates to change tracking configurations:

 l PCS is upgraded — when installing new versions of PCS, new tables or fields may be added to the 
database. As a result, you may want to enable or disable fields from being tracked in the Field and 
UDF Customizations window. If your configuration of change tracking is enhanced with CDC, then 
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you may want to enable CDC on the new tables and verify that CDC is not enabled on legacy tables.

 l New custom module or user defined field is created — when creating a new custom module or user 
defined field, new tables and fields are created and added to the database and set to be change 
tracked through simple triggers only, if change tracking is enabled. If your configuration of change 
tracking is enhanced with CDC, then you may want to enable CDC on the new tables. Or, depending 
on your company needs, you may want to disable the newly created fields from being tracked in the 
Field and UDF Customizations window.

 l Data usage changes — if your company's general usage of PCS evolves so that the tables involved 
in large operations changes, you may want to change which tables are tracked using CDC.

For instructions detailing how to update your simple trigger-based or CDC-enhanced change tracking 
configuration, refer to Update Simple Trigger-Based Change Tracking or Update CDC-Enhanced Change 
Tracking, respectively.

Update Simple Trigger-Based Change Tracking

Updating change tracking options when using a simple trigger can be done from within PCS using the Field 
and UDF Customizations and Options windows. It is recommended that modifications to change tracking 
are only made during the initial configuration of PCS or while performing system maintenance.

Perform the following steps to track data changes using a trigger:

Complete the following steps to enable overall change history for PCS:

 1. Click Tools > Options.

Figure  A-9. Options Window
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 2. In the All pane, scroll down to Turn On Change Tracking and select it.

Figure  A-10. Turn On Change Tracking Option

Complete the following steps to modify change tracking settings for individual fields as needed:         

 1. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations window. 

Figure  A-11. Field and UDF Customization Window

 2. Select a table in the Properties panel that includes the field you want to modify for change history. 

 3. In the grid, select the field you want to set up for change tracking.               
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 4. In the System-Track Changes column, select Yes to track changes made in the selected field while 
change history is enabled. Select No to not record any changes made in the field, even if change 
history is enabled in Options.               

 5. Repeat steps for additional fields. 

Update CDC-Enhanced Change Tracking

Changes to how PCS tracks data changes while using change data capture (CDC) must be done both in 
SQL Server Management Studio and from within PCS using the Field and UDF Customizations and Options 
windows. It is recommended that change tracking modifications are made during the initial configuration of 
PCS or while performing system maintenance to avoid any impact to PCS users.

Complete the following steps to update enhanced change tracking using CDC:

 1. Review the PCS Job Service queue to ensure that all current jobs have finished.

 2. Stop the PCS Job Service.

 3. Complete the following steps to enable overall change history for PCS:

 a. Click Tools > Options.

Figure  A-12. Options Window

 b. In the All pane, scroll down to Turn On Change Tracking and select it.
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Figure  A-13. Turn On Change Tracking Option

Complete the following steps to modify change tracking settings for individual fields as needed:         

 a. Click Tools > Field and UDF Customizations to open the Field and UDF Customizations 
window. 

Figure  A-14. Field and UDF Customization Window

 b. Select a table in the Properties panel that includes the field you want to modify for change 
history. 

 c. In the grid, select the field you want to set up for change tracking.               
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 d. In the System-Track Changes column, select Yes to track changes made in the selected field 
while change history is enabled. Select No to not record any changes made in the field, even if 
change history is enabled in Options.               

 e. Repeat steps for additional fields. 

 4. Enable CDC for tables in the PCS database by doing the following:         

 a. Determine which tables you want to enable CDC-based change tracking. Some tables are not 
tracked by PCS change tracking; tables that are not tracked by PCS should not be configured 
for CDC-based change tracking.

To get a list of all tables in the PCS database that are tracked by PCS change tracking but are 
not (yet) configured to use CDC to track changes, enter the following text in the Query pane, 

replacing <databasename> with the actual name of your PCS database:               

USE <databasename>
                      GO
                      SELECT OBJECT_NAME ( parent_id )
                      FROM sys.triggers
                      WHERE name LIKE '%changelogging'
                      AND name NOT IN (
                      SELECT name FROM sys.tables WHERE is_tracked_by_cdc = 
1 )
                      ORDER BY name
                      GO                     

Select the entered text and click Execute.               

It is recommended to configure CDC-based tracking for any table that undergoes high-
volume operations. You can configure CDC-based change tracking for all tables in the 
resulting list or for a subset of the tables. Any table that PCS tracks but is not configured for 
CDC-based tracking will use a trigger to record the database changes.               

If a table or field is set up to be tracked using CDC but System-Enable Change History is set to 
No in PCS, records of the changes will not be accessible from within PCS and may not be 
retained.               

 b. Enter the following text in the Query pane, replacing <databasename> with the actual name 
of your PCS database, replacing <tablename> with the name of the first table you wish to 
track using CDC, and adding , ( '<tablename>' ) for each additional table you wish to 
track with CDC to the end of the text statement:               

USE <databasename>
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( '<tablename>' )                     
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Once all tables have been added to the statement in the Query pane, enter the following text to 
the end of the statement:               

EXEC configureChangeTrackingCDCTables @enable = 1, 
@tables = @tables                     

Select the text entered  and click Execute.               

EXAMPLE: 
The following example script sets up the PCSAppTest database to track the 
ACCAInspection, ACVGSurveyFolder, and CISurveyFolder tables with CDC-
based tracking:               

USE PCSAppTest
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( 'ACCAInspection' ), ('ACVGSurveyFolder'), 
('CISurveyFolder')
EXEC configureChangeTrackingCDCTables  @enable 
= 1, @tables = @tables 

 5. If CDC is set up to track changes on specific tables that you wish to stop tracking, disable CDC for 
those tables in the PCS database by doing the following:         

 a. Determine which tables you want to stop CDC-based change tracking. Any table that PCS 
tracks but is not configured for CDC-based tracking will use a trigger to record the database 
changes. It is recommended to configure CDC-based tracking for any table that undergoes 
high-volume operations.

To get a list of all tables in the PCS database that currently have change tracking enabled with 

CDC, enter the following text in the Query pane, replacing <databasename> with the actual 
name of your PCS database:               

USE <databasename>
                      GO
                      SELECT *
                      FROM sys.tables
                      WHERE is_tracked_by_cdc = 1
                      ORDER BY name
                      GO                     

Select the entered text and click Execute.               
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 b. Enter the following text in the Query pane, replacing <databasename> with the actual name 
of your PCS database, replacing <tablename> with the name of the first table you wish to 
stop tracking with CDC, and adding , ( '<tablename>' ) for each additional table you 
wish to stop tracking with CDC to the end of the text statement:               

USE <databasename>
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( '<tablename>' )                     

The following example script stops using CDC to track the ACCAInspection, 
ACVGSurveyFolder, and CISurveyFolder tables in the PCSAppTest database:               

USE PCSAppTest
                      DECLARE @tables nvarcharlist
                      INSERT @tables
                      VALUES
                      ( 'ACCAInspection' ), ('ACVGSurveyFolder'), 
('CISurveyFolder')                     

 c. Once all desired tables have been added to the statement in the Query pane, enter the 
following text to the end of the statement:               

exec configureChangeTrackingCDCTables @enable = 0, 
@tables = @tables

 d. Select the text entered in steps and click Execute.               

 6. Update the change history setting in PCS by clicking to clear the Change History check box and then 
clicking to re-select the check box.         

 7. Start the PCS Job Service.

Disable Change Tracking

When change tracking is disabled, the records of changes made to the data while change tracking was 
enabled are retained, but future changes are no longer recorded. Disabling change tracking is the last 
action recorded in the change history.

Refer to the following topics for more information on disabling change tracking:

 l Disable Change Tracking with a Trigger

 l Disable Change Tracking with CDC
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Disable Change Tracking with a Trigger

To stop tracking data changes using a trigger, click to clear the Change History check box in Options.

Disable Change Tracking with CDC

Complete the following steps to stop tracking data changes using CDC:

 1. Connect to your PCS database using Microsoft SQL Server Management Studio.

 2. Create a new query to enter SQL commands.

 3. Enter the following text in the Query pane:

exec configureChangeTrackingCDCSettings @enableCDC = 0

 4. Select the entered text and click Execute.

 5. Disable change history for PCS by clicking to clear the Change History check box in Options. If 
change history was already disabled, update the setting by clicking to select the Change History 
check box and then clicking to clear the check box again.

Access Change History Records

When change tracking is enabled, additions and modifications of individual records can be viewed by any 
user from within PCS. Data deletions and changes to data other than records, such as themes or change 
tracking settings, will only be visible in SQL Server Management Studio. Contact AI Support at 1-800-229-
3404 for assistance with accessing this data.

Complete the following steps to view the history of the changes made to an individual record:



PCS v2.5 User Guide

Appendix A: Database Management 916

 1. In PCS, identify and select the record in the data grid.

Figure  A-15. Changed Record Selected

 2. Click  Change History. The Change History window opens reporting all changes made to the 
selected record in the last year.

Figure  A-16. Change History
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 3. Review the changes that are associated with the selected record. For each change found, the 
record's old and new values are listed, as well as the date and time of the change, the type of change 
made, which user was logged in when the change was made, and what application made the 
changes to the data.

To view all changes made to PCS while change tracking is enabled, open SQL Server Management Studio 
and access the ChangeLog table.

Run Database Integrity Check
In the unlikely event data becomes corrupted in the database, use Database Integrity Check to identify and 
resolve instances of data inconsistencies. The process performs an audit of the database searching for 
issues that may prevent PCS from loading or performing basic functions. Its purpose is to clean up data 
issues that may cause problems for users. For example, database issues the auditing process detects and 
corrects include:

 l Orphan records.

 l Invalid hierarchy nodes.

 l Outdated or incorrect derived fields. Refer to Work with Derived Fields on page 296 for information 
about derived fields.

 l Invalid field characters, hierarchy nodes, or folders outside hierarchy levels.

 l Duplicate or missing right-of-ways (ROWs) and pipes.

 l Blank hierarchy level names and empty or missing hierarchy folders.

 l Missing base effective dates (facilities and pipelines).

 l Invalid foreign keys in database tables. (A foreign key is a field in a database table that refers to a 
record in another database table.)

Complete the following steps to run Database Integrity Check:

 l Click Tools > Database Integrity Check to open the Data Auditor window. Then click  Run. 

The message Running displays during the database audit process.
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Figure  A-17. Data Auditor

When the process completes, the results of the database audit display in the Data Auditor window. 
You can select and then copy text in the window to the Windows clipboard. The copied text can then 
be pasted in another software program such as Microsoft Excel or Word.
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Figure  A-18. Database Integrity Check Completed

Run Reindex Database
The PCS database uses indexes to accelerate the process of locating records in the database. As you add 
and delete records, these indexes become fragmented which in turn slow down database performance. 
The Reindex Database process restores database efficiency by updating the indexes.

IMPORTANT: Before running Reindex Database, it is recommended that you make a backup of the PCS 
database using Microsoft SQL Server Management Studio (SSMS). For more information about SSMS, 
see the AI document entitled PCS Database Backup and Restore.

To run Reindex Database:
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 1. Click Tools > Job Service Viewer to open the Job Service Console window.

Figure  A-19. Job Service Console

 2. Click Reindex Database.

 3. When a warning message opens, click  Yes to continue the reindexing process.

Figure  A-20. Warning Message

Status information displays in the queue while running Reindex Database. When the process 
completes, status information then displays in the Job History pane.

Move Records With Data Modification Utility
The Data Modification Utility is a stand-alone feature that allows you to permanently move pipeline ROW 
records, including subfacility, inspection, and maintenance records, from one facility to another facility. Use 
this feature when splitting or combining pipeline segments.
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The Data Modification Utility is accessed from the Tools menu.

IMPORTANT: Only users with SysAdmin privileges will be able to access and use the Data Modification 
Utility.

This chapter  includes the following topics:

 l Move Facility Records

 l Move Sub Facility Records on page 926

 l Move Inspections Records on page 931

 l Move Maintenance Records on page 934

Move Facility Records

You can move facility records from one ROW to another ROW  in Data Modification Utility.

Complete the following steps to move facility records:
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 1. Click Tools > Data Modification Utility to open the Data Modification Utility window.

Figure  A-21. Data Modification Utility - Facility

 2. If necessary, re-size the Selected ROWs pane to view the data better.

 3. Select a ROW in the top Selected ROWs pane that will be moved to another ROW. This is the source 
ROW.

 4. Select a ROW in the lower Selected ROWs pane where the records will be moved. This is the target 
ROW. The records from the top pane are moved to the ROW selected in the lower pane.

You cannot select the same ROW that was selected in the top pane.

 5. Select the facility type(s) you want to work with using the method described in either of the following:

 a. To select a facility type, click the facility type option button and then click the down arrow and 

select a facility type in the list, such as  [PCS] Rectifier Survey.
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 b. To select multiple facility types, click the Ad Hoc Theme option button and then click the check 
box for one or more facility types, such as Test Point, Rectifier, and Foreign Bond).

 i. Click  Select All to select all the facilities. Click  Clear All to clear all facilities.

An Ad Hoc Theme only applies to the current session and is not saved. A facility type is 
selected when a check mark appears inside the check box. To clear the check mark, click the 
check box again.

 6. Click the Selected ROWs and Facility Types bars to close these panes.

Figure  A-22. Facility Move panes

 7. To customize the layout of the facility move panes, click  Customize to open an Edit Layout window.
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Figure  A-23. Edit Layout Window

 a. Add or remove fields as desired.

 b. Click  OK to save changes and close the  window.

 8. Move records from the top pane to the lower pane in any of the following ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

The records are moved to the lower pane and are highlighted in green.
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Figure  A-24. Moved Facility Records

 9. Move records from the lower pane back to the top pane in any of the following ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

 d. Click  Clear All to clear all records.

The records are moved back to the top pane and are highlighted in green.

 10. Click  Cancel to revert the recent moves.

 11. To save the changes and permanently move the records, click  Apply.

IMPORTANT: You cannot click Cancel to revert moves after clicking  Apply.

 12. Click  Yes in the Warning window to complete the move.
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Figure  A-25. Warning Message

Move Sub Facility Records

You can move sub facility records from one ROW facility to another in Data Modification Utility.

Complete the following steps to move sub-facility records from one ROW facility to another:

 1. Click Tools > Data Modification Utility to open the Data Modification Utility window, and then click the 
Sub Facility tab.

Figure  A-26. Data Modification Utility - Sub Facility
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 2. If necessary, re-size the Selected ROWs pane to view the data better.

 3. Select a ROW in the top Selected ROWs pane with the subfacility records that will be moved to 
another facility. This is the source ROW.

 4. Select a ROW in the lower Selected ROWs pane where the subfacility records will be moved. This is 
the target ROW. The records from the top pane are moved to the subfacility selected in the lower 
pane.

 5. Click the Selected ROWs bar to close this pane.

Figure  A-27. Sub Facility Move

 6. To customize the layout of the subfacility move panes, click  Customize  to open an Edit Layout 
window.
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Figure  A-28. Edit Layout Window

 a. Add or remove fields as desired.

 b. Click  OK to save changes and close the window.

 7. Select a facility type from the Select Facility drop-down list.
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Figure  A-29. Select Facility

 8. Select a subfacility type from the Sub Facility drop down list.

Figure  A-30. Select Sub Facility

 9. Move subfacility records from the top right pane to the lower right pane in any of the following ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.
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 c. Click  Select All to select all the records.

The records are moved to the lower right pane and are highlighted in green.

Figure  A-31. Moved Sub Facility Records

 10. Move subfacility records from the lower right pane back to the top right pane in any of the following 
ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

 d. Click  Clear All to clear all records.

The records are moved back to the top right pane and are highlighted in green.

 11. Click  Cancel to revert the recent moves.

 12. To save the changes and permanently move the records, click  Apply.

IMPORTANT: You cannot click  Cancel to revert moves after clicking  Apply.
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 13. Click Yes in the Warning window to complete the move.

Move Inspections Records

Information in this section explains how to move inspections records from one ROW to another  in Data 
Modification Utility.

Complete the following steps to move inspections records:

 1. Click Tools > Data Modification Utility to open the Data Modification Utility window, and then click the 
Inspections tab.

Figure  A-32. Data Modification Utility - Inspections

 2. If necessary, re-size the Selected ROWs pane to view the data better.

 3. Select a ROW in the top Selected ROWs pane with the inspection records that will be moved. This is 
the source ROW.

 4. Select a ROW in the lower Selected ROWs pane where the records will be moved. This is the target 
ROW. The records from the top pane are moved to the ROW selected in the lower pane.

 5. Click the Select ROWs bar to close this pane.
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Figure  A-33. Inspections Move

 6. To customize the layout of the inspections move panes, click  Customize to open an Edit Layout 
window.

Figure  A-34. Edit Layout Window
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 a. Add or remove fields as desired.

 b. Click  OK to save changes and close the window.

 7. Select a facility type from the Select Facility drop-down list.

Figure  A-35. Select Facility Drop-down List

 8. Move inspection records from the top right pane to the lower right pane in any of the following ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

The records are moved to the lower right pane and are highlighted in green.
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Figure  A-36. Moved Inspection Records

 9. Move inspection records from the lower right pane back to the top right pane in any of the following 
ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

 d. Click  Clear All to clear all records.

The records are moved back to the top right pane and are highlighted in green.

 10. Click  Cancel to revert the recent moves.

 11. To save the changes and permanently move the records, click  Apply.

IMPORTANT: You cannot click  Cancel to revert moves after clicking  Apply.

 12. Click Yes in the Warning window to complete the move.

Move Maintenance Records

You can move maintenance records from one ROW to another  in Data Modification Utility.
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Complete the following steps to move maintenance records:

 1. Click Tools > Data Modification Utility to open the Data Modification Utility window, and then click the 
Maintenance tab.

Figure  A-37. Data Modification Utility - Maintenance

 2. If necessary, re-size the Selected ROWs pane to view the data better.

 3. Select a ROW in the top Selected ROWs pane with the maintenance records that will be moved. This 
the source ROW.

 4. Select a ROW in the lower Selected ROWs pane where the records will be moved. This is the target 
ROW. The records from the top pane are moved to the ROW selected in the lower pane.

 5. Click the Select ROWs bar to close this pane.
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Figure  A-38. Inspections Move

 6. To customize the layout of the inspections move panes, click  Customize  to open an Edit Layout 
window.

Figure  A-39. Edit Layout Window
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 a. Add or remove fields as desired.

 b. Click  OK to save changes and close the window.

 7. Select a facility type from the  Select Facility drop-down list.

Figure  A-40. Select Facility

 8. Move inspection records from the top right pane to the lower right pane in any of the following ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

The records are moved to the lower right pane and are highlighted in green.
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Figure  A-41. Moved Maintenance Records 

 9. Move inspection records from the lower right pane back to the top right pane in any of the following 
ways:

 a. Double-click the name of the record.

 b. Click the check box next to the name of the record.

 c. Click  Select All to select all the records.

 d. Click   Clear All to clear all records.

The records are moved back to the top right pane and are highlighted in green.

 10. Click  Cancel to revert the recent moves.

 11. To save the changes and permanently move the records, click  Apply.

IMPORTANT: You cannot click  Cancel to revert moves after clicking  Apply.

 12. Click Yes in the Warning window to complete the move.
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Appendix B:  System Field Descriptions
Fields that include Activate in the field name share the same description as their counterpart, such as 
Activate AC Power and AC Power. The Activate AC Power field must be added in the Information grid to 
enter data in the AC Power field in the Inspections grid.

NOTE: The menu path included in some field descriptions may include the placeholder text <module>, 
such as Data Entry > Edit <module> Data. The placeholder text indicates the field description applies to 
more than one module, such as CPDM, VM, ACM, ICM, or LSM.

The following table includes definitions and descriptions of system fields.

Name Description

AC Input Alternating Current Input. Voltage coming into the rectifier from a power 
source. See CPDM module, Data Entry > Edit CPDM Data > Rectifier 
Information grid > Customize > Layouts.

AC P/S (Volts) Alternating Current Pipe-to-Soil. Potential measurement in volts. AC 
measurements are recorded using a voltmeter when conducting an AC CIS 
survey to determine AC interference from sources such as overhead power 
transmission lines near the pipeline.

See ISM, Data Entry > Edit ISM Data > AC CIS.

AC Power Alternating Current Power. Power consumed by a rectifier from a power 
source (watts). This value is system-supplied and calculated as follows:

AC Service Alternating Current Service. History information field that identifies the 
complete source of incoming AC power; such as data for AC voltage, AC 
current, number of phases and so on. See CPDM module Data Entry > Edit 
CPDM Data > Rectifier Inspections grid > Customize > Layouts.

Account Power company account number. Can also be the customer's account 
number for gas service. See CPDM module, Data Entry > Edit CPDM Data 
> Rectifier Inspections grid > Customize > Layouts.

Activate Cardinal Points Add this field in the Tank Information grid, then enable the field's check box 
to allow data entry in the Tank Inspection grid for the following fields: North 
P/S, South P/S, East P/S, and West P/S. See CPDM, Data Entry > Edit 
CPDM Data > Tank > Information and Inspection grids > Customize > 
Layouts.

Table B-19.  System Field Descriptions       
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Name Description

Activate Center P/S Activate Center Pipe-to-Soil Add this field in the Tank Information grid, then 
enable the field's check box to allow data entry in the Center P/S field in the 
Tank Inspection grid. See CPDM, Data Entry > Edit CPDM Data > Tank > 
Information and Inspection grids > Customize > Layouts.

Activate Intercardinal 
Points

Add this field in the Tank Information grid, then enable the field's check box 
to allow data entry in the Tank Inspection grid for the following fields: NE 
P/S, SE P/S, NW P/S, and SW P/S. See CPDM, Data Entry > Edit CPDM 
Data > Tank > Information and Inspection grids > Customize > Layouts.

Activate Mid P/S Activate Mid Pipe-to-Soil. Add this field in the Tank Information grid, then 
enable the field's check box to allow data entry in the field Mid P/S in the 
Tank Inspection grid. See CPDM, Data Entry > Edit CPDM Data > Tank > 
Information and Inspection grids > Customize > Layouts.

Activate Secondary 
Intercardinal Points

Add this field in the Tank Informationgrid, then enable the field's check box 
to allow data entry in the Tank Inspection grid for the following fields: ENE 
P/S, ESE P/S, NNE P/S, NNW P/S, SSE P/S, WNW P/S, and WSW P/S. 
See CPDM, Data Entry > Edit CPDM Data > Tank > Information and 
Inspection grids > Customize > Layouts.

Address System calculated field based on information entered in the following fields: 
Address Post-Direction; Address Pre-Direction; Address Street; Address 
Street Number; and Address Suffix. This field is available for use in all 
modules and can be added in the Information grid. See Data Entry > Edit 
<module> Data > Information grid > Customize > Layouts.

Address Pre-Direction Tag at the beginning of a street name used to indicate direction, such as 
125 E Grand Bluff St. NW, where E is the pre-direction. This field is available 
for use in all modules and can be added in the Information grid. See Data 
Entry > Edit <module> Data > Information grid > Customize > Layouts.

Alignment Sheet Number Record number assigned to an alignment sheet for a pipeline right-of-way. 
Add this field in either the Rectifier Information or Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier > Information or Inspection 
grids > Customize > Layout.

Allegro Survey Information System-generated field showing properties in a close interval survey file 
transferred from the Allegro. Properties include configuration settings, 
ROW code, survey date, surveyor, type of survey, and so on.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Anomaly Direction If survey readings were taken at regular intervals during an ACVG survey, 
use this field to indicate if the anomaly is in front of or behind the surveyor. 
This field does not apply to ACVG surveys that only record an ACVG point 
at the anomaly. Typical entries for this field are Forward or Reverse.

See ISM, Data Entry > Edit Indirect Survey Data > ACVG grid.

APB (Ppm) Acid Reducing Bacteria parts-per-million. Measurement of APB in parts-
per-million (Ppm). Add Activate APB (Ppm) in the Information grid to allow 
data entry in the Inspections grid. See ICM, Data Entry > Edit ICM Data > 
Samples > Information and Inspection grids > Customize > Layouts.

Apparent Leak Location Leak location. See LSM, Data Entry > Edit LSM Data > Maintenance grid > 
Customize > Layouts.

Attached Documents Use this field to attach or link a document to a record in the grid. This field is 
available in all modules. See Attach a Document to a Grid Record on page 
305.

Average P/S Average Pipe-to-Soil. Reading measured in volts. Add the Activate Average 
P/S field in the Test Point Information grid to enable data entry in the 
Average P/S field in the Test Point Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Test Point Information and Inspection grid > Customize 
> Layouts.

Bond Current Adjusted Click the check box to indicate a change was made to the bond current. 
This field works in conjunction with the Bond Current Found and Bond 
Current Left fields when the Activate field for both of these fields has been 
added in the Information grid.

When adjusting the bond current (1) click the Bond Current Adjusted check 
box; (2) enter the pre-adjusted value (in amps) in the field Bond Current 
Found; and then (3) enter the adjusted value (in amps) in the Bond Current 
Left field. See CPDM, Data Entry > Edit CPDM Data > Foreign Bond 
Information and Inspection grid > Customize > Layouts.

Bond Current Found Bond current measured during an inspection (in Amps). This field works in 
conjunction with the Bond Current Adjusted and Bond Current Left fields 
when the Activate field for both of these fields has been added in the 
Foreign Bond Information grid. See CPDM, Data Entry > Edit CPDM Data > 
Foreign Bond Information and Inspection grid > Customize > Layouts.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Bond Current Left Bond current measured after an inspection (in Amps). This field works in 
conjunction with the Bond Current Adjusted and Bond Current Found fields 
when the Activate field for both of these fields has been added in the 
Foreign Bond Information grid. See CPDM, Data Entry > Edit CPDM Data > 
Foreign Bond Information and Inspection grid > Customize > Layouts.

Bond Shunt Factor Multiplying factor measured in Amps. Used in converting the voltage drop 
across the shunt to current. Voltage drop and shunt resistance are used to 
calculate the current. Add the Bond Shunt Factor field in either the Foreign 
Bond Information or Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Foreign Bond Information and Inspection grid > Customize > 
Layouts.

Bond Shunt Rating Shunt size measured in millivolts and Amps (mV/A). Add the field in either 
the Foreign Bond Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Foreign Bond Information and Inspection grid > 
Customize > Layouts.

Bond Shunt Resistance Shunt resistance measured in Ohms. Add the field in either the Foreign 
Bond Information or Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Foreign Bond Information and Inspection grid > Customize > 
Layouts.

Bond Type Type of bond, such as resistance or direct. Add the field in either the Bond 
Information or Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Foreign Bond Information and Inspection grid > Customize > Layouts.

>Casing IRF Casing IR free (IRF) reading. Voltage measurement indicating the potential 
of the casing relative to the soil with interrupted rectifier current. Add the 
Activate Casing IRF field in the Test Point Information grid to enable data 
entry in the Casing IRF field in the Test Point Inspection grid. See CPDM, 
Data Entry > Edit CPDM Data > Test Point Information and Inspection grid 
> Customize > Layouts.

Casing IRF Minimum and 
Maximum

Minimum and maximum value allowed for data entry in the Casing IRF field. 
Add the Casing IRF Minimum and Casing IRF Maximum fields in either the 
Test Point Information or Inspection grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point Information or Inspection grid > Customize > 
Layouts.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Casing P/S Casing Pipe-to-Soil. Voltage measurement indicating the potential of the 
casing relative to the soil. Add the field Activate Casing P/S in the 
Information grid to enable data entry in the Casing P/S field in the Inspection 
grid. See CPDM, Data Entry > Edit CPDM Data > Test Point Information 
and Inspection grid > Customize > Layouts.

Casing P/S Minimum and 
Maximum

Minimum and maximum value allowed for data entry in the Casing P/S field. 
Add the Casing P/S Minimum and Casing P/S Maximum fields in either the 
Test Point Information or Inspection grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point Information or Inspection grid > Customize > 
Layouts.

Casing Status Status of the casing, such as short, not short, electrolytic, or metallic. Add 
the Activate Casing Status field in the Information grid to enable data entry 
in the Casing Status field in the Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Test Point Information and Inspection grid > Customize 
> Layouts.

Center P/S Center Pipe-to-Soil. Structure reading in volts when a half-cell is under the 
center of the tank. Add the field Activate Casing P/S in the Information grid 
to enable data entry in the Casing P/S field in the Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Tank Information and Inspection 
grid > Customize > Layouts.

Center P/S Minimum and 
Maximum

Minimum and maximum value (voltage reading) allowed for data entry in the 
Center P/S field. Add the fields Center P/S Minimum and Center P/S 
Maximum in either the Tank Information or Inspection grid. See CPDM, 
Data Entry > Edit CPDM Data > Tank Information or Inspection grid > 
Customize > Layouts.

City City where a facility is located. This field is available for use in all modules; 
add the field in either the Information or Inspection grid. See Data Entry > 
Edit <module> Data > Information or Inspection grid > Customize > 
Layouts.

Close Direction Direction the valve wheel turns to close the valve. Enter data such as CW for 
clockwise or CCW for counter clockwise. See VM, Data Entry > Edit VM 
Data > Information or Inspection grid > Customize > Layouts.

Coating Type of coating applied to the pipeline, such as tape or epoxy. Add this field 
in either the Information or Inspection grid. See ACM, Data Entry > Edit 
ACM Data > Information or Inspection grid > Customize > Layouts.

Coating Condition Description of coating condition. See ACM, Data Entry > Edit ACM Data > 
Inspection grid > Customize > Layouts.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Coke Breeze Type Type of coke breeze, such as metallurgical and petroleum-based. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier Information, Inspection, or 
Maintenance grid > Customize > Layouts.

Coke Breeze Type Type of coke breeze such as metallurgical and petroleum-based. Add this 
field in either the Rectifier Information or Inspection grid.

See CPDM, Data Entry > Edit CPDM Data > Rectifier > Information or 
Inspection grids > Customize > Layout.

Completed Maintenance Total number of maintenance records for a facility that have the field 
Completed Date populated. This is a read-only, facility level calculated field. 
Add this field in the Rectifier Information, Inspection, or Maintenance grid.

See CPDM, Data Entry > Edit CPDM Data > Rectifier > Information, 
Inspection, or Maintenance grids > Customize > Layouts.

Conductivity Numeric field supporting decimal numbers with up to seven digits 
resolution, including two numbers after the decimal. Use this field to record 
conductivity measurements as measured by the inspection tool during a 
Soil Resistivity survey. Measurements are in microsiemens (µS), a metric 
unit of measurement for conductivity.

See ISM module, Data Entry > Edit ISM Data > Soil Resistivity.

Connection Type Type of connection used to secure a valve to the pipeline.

See VM, Data Entry > Edit VM Data > Information or Inspection grid > 
Customize > Layouts.

Contact Name of a contact person at the company responsible for the foreign bond.

See CPDM, Data Entry > Edit CPDM Data > Foreign Bond Information grid 
> Customize > Layouts.

Creation Date Date a facility record was created in a grid. Add this field in either the 
Rectifier Information or Inspection grid.

See CPDM, Data Entry > Edit CPDM Data > Rectifier > Information or 
Inspection grids > Customize > Layouts.

Critical Bond Check box for indicating if a bond is critical based on location and 
connection. Critical bond is used in scheduling. Click to place a check mark 
inside the check box if the bond is considered a critical bond.

See CPDM, Data Entry > Edit CPDM Data > Foreign Bond Information, 
Inspection, or Maintenance grid > Customize > Layouts.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Days Since First Bad 
Reading

Derived field showing the number of days since the first bad reading 
(reading does not meet criteria). Field available in all modules in the 
Information or Inspection grid. See Work with Derived Fields on page 296.

Days Since Last Good 
Reading

Derived field showing the number of days since the last good reading 
(reading meets criteria). Field available in all modules in the Information or 
Inspection grid. See Work with Derived Fields on page 296.

Days Until Delinquent Read-only, system calculated field. Number of days until a facility 
inspection becomes delinquent. Field is available in all modules.

See Data Entry > Edit <module> Data > Information or Inspection grid > 
Customize > Layouts.

Decibel Reading (dB) Decibel reading measured in millibels (mB, decibel microvolts) by the 
inspection tool using the A-Frame method during an ACVG survey.

See ISM, Data Entry > Edit ISM Data > ACVG.

Default Location Format Read-only field showing the format used in numbering facilities on a 
pipeline segment. Default Location Format is set up before adding or linking 
facilities to a pipeline segment. Valid entries are: Metric Milepost, Milepost 
(4 decimals), Location ID, Milepost (3 decimals), Miles/Station Number, 
Reading Number, and Station Number.

Default Location Format is available in all modules. See Data Entry > Edit 
<module> Data > Information or Inspection grid > Customize > Layout.

Delinquent Date From 
Schedule

Read-only field showing the date a facility becomes delinquent based on 
scheduling properties set up in Edit Schedule Settings (Data Entry > Edit 
Schedule Settings). This field is available in all modules. See Data Entry > 
Edit <module> Data > Information or Inspection grid > Customize > Layout.

Depth Numeric field supporting decimal numbers with up to 6 digits resolution, 
including two numbers after the decimal. Use this field to enter the pipeline 
depth reading in inches as measured by the PCM inspection tool during an 
ACCA survey.

See ISM, Data Entry > Edit ISM Data > ACCA.

Diameter Distance from wall to wall across a tank. See CPDM, Data Entry > Edit 
CPDM Data > Tank Information, Inspection or Maintenance grid > 
Customize > Layouts.

Diode Rating Amperage rating of the diode in the rectifier. See CPDM, Data Entry > Edit 
CPDM Data > Information or Inspection grid > Customize > Layout.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Due Date From Schedule Date a facility is scheduled for survey based on settings in Edit Schedule 
Settings (Data Entry >Edit Schedule Settings). This field is available for use 
in all modules; add the field in either the Information or Inspection grid.

See Data Entry > Edit <module> Data > Information or Inspection grid > 
Customize > Layouts.

Due Date From Schedule Read-only field showing the date a facility is due for inspection based on 
scheduling properties set up in Edit Schedule Settings (Data Entry > Edit 
Schedule Settings). This field is available in all modules. See Data Entry > 
Edit <module> Data > Information or Inspection grid > Customize > Layout.

East P/S East Pipe-to-Soil. Structure reading in volts when a half-cell is placed near 
the east side of a tank. Add and enable Activate Cardinal Points in the 
Information grid to allow data entry in the Inspections grid. See CPDM, Data 
Entry > Edit CPDM Data > Tank > Information and Inspection grids > 
Customize > Layouts.

East P/S 
Maximum/Minimum

Maximum and minimum voltage value allowed for data entry in the field East 
P/S in the Tank Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Tank > Information or Inspection grid > Customize > Layouts.

Effective Date Required system field automatically present in all grids. Effective Date is the 
date a history record becomes effective. New history records are created 
with an Effective Date when important permanent information changes. For 
example, changes to important permanent information include changing 
the protection criteria value for a test point; changing the operational status 
from active to inactive or from inactive to active; and when a pipeline 
becomes inactive or is taken out of service.

For more information, see Create History Records Using an Effective Date 
on page 285.

Efficiency System-provided value that is calculated using the formula shown below. A 
value can be manually entered, but is not recommended. See CPDM, Data 
Entry > Edit CPDM Data > Rectifier > Information or Inspection grid > 
Customize > Layouts.

Rectifier Output Volts Left x Rectifier Output Current Left x 100
              AC Power (Watts)

Efficiency Filter Check box for indicating whether or not a rectifier is using an efficiency filter. 
Click to place a check mark inside the check box when an efficiency filter is 
present. See CPDM, Data Entry > Edit CPDM Data > Rectifier > Information 
or Inspection grid > Customize > Layouts.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Elevation Elevation in feet for a facility, survey point, or anomaly on a pipeline as 
reported by a GPS device. This field is available for use in all modules.

See Data Entry > Edit <module> Data > Information or Inspection >grid  
Customize > Layouts.

End Date Last day of a start and end date range, such as a start date of 05/04/2012 
and an end date of 08/06/2012. A date range is typically used when 
generating a schedule or when defining a survey folder. This field is 
available in all modules.

See Data Entry > Edit <module> Data > Information or Inspection grid > 
Customize > Layout.

Existing Facilities An existing facility is a milepost in an imported stationary survey that 
matches an existing milepost in PCS for the currently selected ROW 
(pipeline segment). Existing facilities are used in telluric compensation. Also 
refer to Unregistered Milepost. See CPDM, Data Entry > Stationary Survey 
Maintenance > Snap To Facility.

Facility Active Check box to indicate whether or not a facility is active or inactive according 
to survey status. Add this field in either the Information or Inspection grid.

See CPDM, Data Entry > Edit CPDM Data > Information or Inspection grid > 
Customize > Layouts.

Facility and ROW 
Currently Active

Read-only system field showing the status of linked facilities on a ROW. 
Check box indicates whether or not a facility and ROW are active or inactive 
based on survey status. Add this field in either the Information or Inspection 
grid.

See CPDM, Data Entry > Edit CPDM Data > Information or Inspection grid > 
Customize > Layouts.

Facility Attached 
Document

Field for attaching a file (document or image) or Internet link to a facility or 
ROW. File attachment or link can be previewed or edited in PCS with the 
appropriate viewer or file editor if installed locally on the computer.

Use this field to link or embed a file attachment and detach an attached file. 
This field is available in all modules and can be added in the Information, 
Inspection, and Maintenance grids. See any module, Data Entry > Edit 
<module> Data > Information, Inspection, or Maintenance grid > 
Customize > Layout.

Table B-19.  System Field Descriptions        cont'd
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Name Description

Facility Delinquent Date Date a facility is considered to be past due for inspection. This is a PCS 
calculated field based on schedule settings set up in Edit Schedule Settings 
(Data Entry > Edit Schedule Settings). Available for use in all modules; add 
the field in either the Information or Inspection grid. See Data Entry > Edit 
<module> Data > Information or Inspection grid > Customize > Layouts.

Facility ID Identification code that identifies a facility. This field is available for use in all 
modules; add the field in either the Information or Inspection grid. See Data 
Entry > Edit <module> Data > Information or Inspection grid > Customize > 
Layouts.

Foreign IRF Foreign IR free reading. Voltage measurement indicating the potential of a 
foreign line at a foreign line crossing relative to the soil with interrupted 
rectifier current.

Add and enable Activate Foreign IRF in the Test Point Information grid to 
allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point > Information and Inspection grids > Customize > 
Layouts.

Foreign P/S Foreign Pipe-to-Soil. Potential reading of foreign line at a foreign line 
crossing relative to the soil. Use this field to enter pipe-to-soil "on" 
measurements taken at a site with all DC sources operational.

Add and enable Activate Foreign P/S in the Test Point Information grid to 
allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point > Information and Inspection grids > Customize > 
Layouts.

Galvanic Anode Initial 
Current

Initial current output at install. Additional readings should be recorded in the 
field Galvanic Current in the Galvanic Anode Inspection grid.

To record data in the Galvanic Current field in the Inspection grid: (1) add 
Activate Galvanic Current in the Information grid, then enable the field's 
check box, (2) add the field Galvanic Current in the Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Galvanic Anode > Information and 
Inspection grids > Customize > Layouts.
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Name Description

Galvanic Anode Shunt 
Factor

Amperage value of the galvanic anode shunt factor. Shunt factor includes 
the value in this field and the millivolt/amperage (mV/A) value entered in the 
Galvanic Anode Shunt Rating field.

Add the fields Galvanic Anode Shunt Factor and Galvanic Anode Shunt 
Rating in either the Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Galvanic Anode > Information or Inspection grids > 
Customize > Layouts.

Galvanic Anode Size Weight in pounds (lbs) of sacrificial anode. Add this field in either the 
Information or Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Galvanic Anode > Information or Inspection grids > Customize > Layouts.

Galvanic Anode To Soil Driving potential of the anode relative to the soil. Value entered in volts. Add 
this field in either the Information or Inspection grid. See CPDM, Data Entry 
> Edit CPDM Data > Galvanic Anode > Information or Inspection grids > 
Customize > Layouts.

Galvanic Anode Type Type of anode such as magnesium, aluminum, or zinc. Add this field in the 
Information or Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Galvanic Anode > Information or Inspection grids > Customize > Layouts.

Galvanic Current 
Maximum/Minimum

Maximum and minimum current output. See CPDM, Data Entry > Edit 
CPDM Data > Galvanic Anode > Information or Inspection grids > 
Customize > Layouts.

Galvanic Number of 
Anodes

Rectifier facilities: Number of impressed current anodes at a 
rectifier/ground bed installation. If there are multiple ground beds at a 
rectifier, this will be the total number of anodes associated with that rectifier.

Galvanic Anodes: Number of sacrificial anodes at a galvanic anode 
installation.

See CPDM, Data Entry > Edit CPDM Data > Galvanic Anode > Information 
or Inspection grids > Customize > Layouts.

Gas Indicator Leak Test Remark field in the LSM module for describing the condition of the valve 
coating at inspection.

To record data in the field Gas Indicator Leak Test in the Inspection grid: (1) 
add the field Activate Gas Indicator Leak Test in the Information grid, then 
enable the field's check box, (2) add the field Gas Indicator Leak Test in the 
Inspection grid. See LSM, Data Entry > Edit LSM Data > Information and 
Inspection grids > Customize > Layouts.
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Name Description

Holiday Use this field to indicate a survey location with a pipeline coating anomaly 
(hole) as detected by the inspection tool during an ACVG survey. A check 
mark inside the check box indicates a survey location with a holiday. To 
remove the check mark, click the check box again.

See ISM module, Data Entry > Edit ISM Data > ACVG.

Indication Classification Use this field to classify or prioritize the severity of an indication. For 
example, classifications such as minor, moderate, severe, immediate, 
scheduled, or monitored might be used to prioritize the severity of 
indications. Typical indications include coating faults, holidays, corrosion 
activity, electrical shorts, interference, geologic current shielding, and other 
types of anomalies that have been discovered during an above ground, 
indirect survey.

If your company uses a coding system for describing the severity of 
indications, you can type the code in the field; select the code and its 
description from a drop-down list if a picklist has previously been setup in 
Field and UDF Customizations (see Set Properties in Field and UDF 
Customizations on page 1); or import the code in PCS using Bridge (see 
Bridge on page 1).

Indication Score Alphanumeric field that accepts up to two characters, numbers, or a 
combination of both. Use this field to rank, prioritize, quantify the actual 
size, or grade the severity of an indication classification.

Inspection Remarks Survey comment associated with a facility, anomaly, or landmark. Field is 
available for use in all modules. See any module, Data Entry > Edit 
<module> Data > Inspection > Customize > Layouts.

Insulator IRF Insulator IR Free. Voltage measurement indicating the potential of an 
insulated flange relative to the soil with interrupted rectifier current.

Add and enable Activate Insulator IRF in the Test Point Information grid to 
allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point > Information and Inspection grids > Customize > 
Layouts.
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Insulator P/S Insulator Pipe-to-Soil. Potential reading for the other side of an insulated 
flange, relative to the soil. Also referred to as an "insulator-to-soil" potential 
reading.

Add and enable Activate Insulator P/S in the Test Point Information grid to 
allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Test Point > Information and Inspection grids > Customize > 
Layouts.

Insulator Shunt Factor Amperage value of the insulator shunt factor. Shunt factor consists of the 
value in this field and the value (mV/A) in the field Insulator Shunt Rating.

See CPDM, Data Entry > Edit CPDM Data > Test Point > Information or 
Inspection grid > Customize > Layouts.

IR (percentage) Numeric field supporting a 5 digit decimal number, including two numbers 
after the decimal. Use this field to enter a value that represents the 
estimated size or severity of a holiday as a percentage. The value you enter 
is the difference between the over-the-line (OTL) to remote earth (RE) 
readings divided by the signal strength (SS) of the voltage gradient at the 
anomaly.

IR (percentage) = (OTL – RE or RE – OTL) ÷ SS at anomaly

See ISM, Data Entry > Edit ISM Data > DCVG.

Is Gps Time Read-only field indicating whether or not the P/S and IRF (ON/OFF) 
inspection date and time is GPS time. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Detail Inspection mini-grid.

KWH Meter Kilowatt hours (KWH) recorded from a power meter for rectifier power 
usage. Add and enable Activate KWH Meter in the Rectifier Information grid 
to allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier > Information and Inspection grid > Customize > 
Layouts.

Latitude Numeric field that accepts up to twelve digits. Use this field to enter data 
that identifies the GPS latitude coordinate (north/south) for a test point, 
rectifier, bond, anomaly, or other location type on a pipeline. Field is 
available in all modules.

Level 1 Name through 
Level 5 Name

User setting for the names of the system hierarchy levels. PCS supports up 
to five hierarchy levels. See Tools > Customize > Hierarchy.
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Locate Current (mA) Use this field to enter a current reading in milliamps (mA) as measured by 
the PCM inspection tool for survey points located directly over the pipeline 
during an ACCA survey.

See ISM, Data Entry > Edit ISM Data > ACCA.

Location Code Alphanumeric code assigned to a pipeline segment. The field accepts up to 
five alphanumeric characters.

Location Code is available for use in all modules and can be added in either 
the Information or Inspection grid. See Data Entry > Edit <module> Data > 
Information or Inspection grid > Customize > Layouts.

Log Number Numeric field that supports up to 6 digits. This field is typically used for 
sequential log numbers generated by a PCM (pipeline current mapper) data 
logger for survey readings taken during an ACCA survey.

See ISM, Data Entry > Edit ISM Data > ACCA.

Longitude Numeric field that accepts up to twelve digits. Use this field to enter data 
that identifies the GPS longitude coordinate (east/west) for a test point, 
rectifier, bond, anomaly, or other location type on a pipeline. Field is 
available in all modules.

Loss per Distance (dB/Ft) Numeric field supporting positive or negative decimal numbers with up to 5 
digits resolution, including 2 numbers after the decimal. Use this field to 
enter the "dB loss per foot" value as calculated by the PCM inspection tool 
during an ACCA survey. The calculated value indicates the "current loss per 
distance ratio".

See ISM, Data Entry > Edit ISM Data > ACCA.

Manufacturer Manufacturer of the rectifier being installed. See CPDM module, Data Entry 
> Edit CPDM Data > Rectifier Inspections grid > Customize > Layouts.

Milepost Number representing a testing or facility location on a pipeline such as 
23+123. May also be referred to as station number, milepost marker, or 
station marker.

See Tools > Customize > General > User Location Name.

Native P/S Native Pipe-to-Soil. Voltage reading taken prior to any current placed on 
the pipeline. Also referred to as depolarized or static potential.

Negative Shunt Factor Amperage value of the negative shunt factor. This field is available in the 
Rectifier Negative Inspections mini-grid. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier Inspections grid > Rectifier Negative Inspections 
mini-grid. 
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Number of Crossings PCS calculated field showing the total number of crossings, such as road 
crossings, railroad crossings, foreign pipeline crossings, and fence lines. 
See CPDM, Data Entry > Edit CPDM Data > Test Point > Information or 
Inspection grid > Customize > Layouts.

Number of Leaks Numeric field for entering the number of leaks. Add the Activate Number of 
Leaks field in the Information grid to allow data entry in the Inspection grid. 
See LSM, Data Entry > Edit LSM Data > Information and Inspection grid > 
Customize > Layouts.

Number of Negatives PCS calculated field in either the Rectifier Information or Inspection grid. 
This field shows the number of negatives in the Rectifier Negative 
Information mini-grid. See CPDM, Data Entry > Edit CPDM Data > Rectifier 
> Information or Inspection grid > Customize > Layouts.

Number of Readings in 
Survey

A derived field showing the total number of survey readings in a continuous 
survey. See continuous survey types CIS, AC CIS, DCVG and so on in 
Indirect Survey Manager (ISM). Also see Work with Derived Fields on page 
296.

Number of Turns Number of turns to open a valve. Add the Activate Number of Turns field in 
the Information grid to allow data entry in the Inspection grid. See VM, Data 
Entry > Edit VM Data > Information and Inspection grid > Customize > 
Layouts.

Off Delta A value showing the difference between the uncompensated and 
compensated OFF values.

On Delta A value showing the difference between the uncompensated and 
compensated ON values.

Original Station Number The initial or original station number before re-aligning station numbers 
using the Rubber Banding feature in Survey Maintenance.

See ISM, Data Entry > Edit ISM Data > Survey Maintenance.

OTL to Remote Earth (mV) Over-the-Line to Remote Earth. Use this field to enter a value in millivolts 
(mV) that represents the sum of all side drain measurements taken during a 
DCVG survey for a survey point on the pipeline.

See ISM, Data Entry > Edit ISM Data > DCVG.
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P/S Offset Pipe-to-Soil Offset. Offset added to a pipe-to-soil (P/S) reading collected 
on the Allegro field computer or mobile device. Use this field when using a 
permanent reference cell other than copper-copper sulfate. PCS uses the 
value to convert the reading to the equivalent copper-copper sulfate 
reading. See CPDM, Data Entry > Edit CPDM Data > Test Point > 
Information or Inspection grid > Customize > Layouts.

Parallel Line Two (2) pipelines within the same ROW (right-of way) and parallel to each 
other. Use the fields Pipeline Code and Pipeline Name in Select ROWs to 
identify a parallel pipeline. Also see Pipe, Pipeline Code, and Pipeline Name.

PBN Dial Reading Measurement reading taken at inspection. Add the field Activate PBN Dial 
Reading in the Information grid to allow data entry in the Inspection grid. 
See ICM, Data Entry > Edit ICM Data > Probe > Information and Inspection 
grid > Customize > Layouts.

PCM Current (dB) Numeric field that supports decimal numbers with up to 6 digits resolution, 
including two numbers after the decimal point. Use this field to enter the 
PCM current reading as measured in mA and dB by the PCM inspection 
tool during an ACCA survey.

See ISM, Data Entry > Edit ISM Data > ACCA.

PCS Field Name Selection list that allows you to choose the type of potential reading 
associated with a test lead record in the Test Point Detail Information and 
Inspection mini-grid. The test lead inspection record controls which 
ON/OFF values copy to the Inspection grid P/S and IRF fields for 
compliance reporting. See CPDM, Data Entry > Edit CPDM Data > Test 
Point Detail Information and Inspection mini-grids.

Periodic Survey A survey conducted more often than every 12 months, such as monthly or 
bi-monthly rectifier surveys. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Inspection grid > Customize > Layouts.

Periodic Survey Year Year a periodic survey is performed. See CPDM, Data Entry > Edit CPDM 
Data > Rectifier > Inspection grid > Customize > Layouts.

Permanent Comments Comments permanently associated with a facility. This type of comment 
does not typically change during each survey year. This field is available for 
use in all modules and can be added in the Information grid. See Data Entry 
> Edit <module> Data > Information grid > Customize > Layouts.

Comments that apply to a particular survey should be entered in the Survey 
Remarks field.
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Phone Number Phone number of the person to contact at another company about a 
foreign bond. See CPDM, Data Entry > Edit CPDM Data > Foreign Bond > 
Information or Inspection grid > Customize > Layouts.

Pipe Two digit alphanumeric code used to identify a parallel pipeline in a 
common ROW with an existing pipeline. Also see Pipeline Code, Pipeline 
Name, and Parallel Line.

Pipeline Code Two digit alphanumeric code used to identify a parallel pipeline in a 
common ROW with an existing pipeline. Also see Pipe, Pipeline Name, and 
Parallel Line.

Pipeline Name Name of a parallel pipeline in a common ROW with an existing pipeline. Also 
see Pipeline Code, Pipeline Name, and Parallel Line.

Plot This Point Use this field to include or exclude continuous survey readings in reports 
and graphs. To include a survey reading, click the check box to place a 
check mark in the check box. To exclude a survey reading, clear the check 
mark by clicking the check box. This field is enabled by default with all 
survey readings included in reports and graphs.

See ISM, Data Entry > Edit ISM Data > any survey type.

Polarity Direction of current flow at a foreign bond. Add the field Activate Polarity in 
the Information grid to allow data entry in the Inspection grid.

See CPDM, Data Entry > Edit CPDM Data > Foreign Bond > Information 
and Inspection grid > Customize > Layouts.

Power Company Phone 
Number

Phone number of the power company for a rectifier installation site. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier > Information or Inspection 
grid > Customize > Layouts.

Pre-Install P/S Pipe-to-soil reading taken before installation of galvanic anodes. See 
CPDM, Data Entry > Edit CPDM Data > Galvanic Anode > Information or 
Inspection grid > Customize > Layouts.

Property Rights Code that identifies any property rights that might impact inspection or 
access to a pipeline. The field supports up to 10 alphanumeric characters 
including spaces, such as B #1234567. See LSM, Data Entry > Edit LSM 
Data > Maintenance grid > Customize > Layouts.

Rectifier Anode Size Dimensions of impressed current anodes such as 3 x 60. Add the field in 
either the Rectifier Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information or Inspection grids > Customize > 
Layouts.
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Rectifier Anode Type Type of anode such as graphite or high silicon material. Add the field in 
either the Rectifier Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information or Inspection grids > Customize > 
Layouts.

Rectifier Current Adjusted Check box for indicating a change was made to the rectifier current at 
inspection. When a change is made (1) click to add a check mark in the 
Rectifier Current Adjusted check box, (2) enter the adjusted reading in the 
fields Rectifier Output Volts Left and Rectifier Output Current Left. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier > Inspection grids > 
Customize > Layouts.

Rectifier Current Density A calculated report field indicating the amount of current required per 
square foot to change a structure's potential to –0.85 volts.

Rectifier Current 
Distributions

Number of pipelines receiving current from a rectifier. This field is generated 
by PCS as current distributions are added. See CPDM module, 
Reports/Graphs > Survey Report.

Rectifier Output Current 
Found

Initial rectifier reading at inspection measured in Amps. Add the Activate 
Rectifier Output Current Found field in the Information grid to allow data 
entry in the Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information and Inspection grids > Customize > Layouts.

PCS multiplies the initial rectifier reading by the rectifier shunt factor when 
the fields Rated Rectifier Output Volts and Rated Rectifier Output Current 
are populated in the Rectifiers Information grid.

Rectifier Output Current 
Found 
Maximum/Minimum

Maximum and minimum value (measured in Amps) allowed for data entry in 
the field Rectifier Output Current Found. Add the fields in either the Rectifier 
Information or Inspection grid. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information or Inspection grids > Customize > Layouts.

Rectifier Output Current 
Left

Rectifier reading after making adjustments to the rectifier output current at 
inspection (measured in Amps). Also see description for Rectifier Output 
Current Found. See CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Inspection grids > Customize > Layouts.

Rectifier Output Shunt 
Factor

Amperage value of the anode shunt factor. Refers to the shunt used to 
measure the output current of each anode in a positive junction box. Shunt 
factor includes the value in this field and the value entered in the field 
Rectifier Output Shunt Rating. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information or Inspection grids > Customize > Layouts.
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Rectifier Output Volts 
Found

Initial rectifier reading at inspection measured in volts. Add and enable the 
Activate Rectifier Output Volts Found field in the Rectifier Information grid to 
allow data entry in the Inspections grid. Also refer to the description 
Rectifier Current Adjusted. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information and Inspection grids > Customize > Layout.

Rectifier Output Volts 
Found 
Maximum/Minimum

Maximum and minimum voltage value allowed for data entry in the field 
Rectifier Output Volts Found. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information or Inspection grids > Customize > Layouts.

Rectifier Output Volts Left See description for Rectifier Current Adjusted.

Repair Priority Code number for identifying how soon repair work should begin. The field 
accepts up to five alphanumeric characters including spaces, such as A 
#123. This field is available for use in all modules. See Data Entry > Edit 
<module> Data > Maintenance grid > Customize > Layouts.

Revolutions Number of times a power meter wheel has rotated in a specific time period. 
This field is used to calculate the value in the Efficiency field. Add and enable 
the field Activate Revolutions in the Rectifier Information grid to allow data 
entry in the Inspections grid. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information and Inspection grids > Customize > Layout.

RFID Radio-frequency identification number populated either by transferring an 
Allegro Periodic Survey (PS) to PCS or manual entry in a grid. This field is 
available for use in all modules. See Data Entry > Edit <module> Data > 
Information, Inspection, or Maintenance grid > Customize > Layouts.

ROW Currently Active Check box for indicating when a pipeline is active or inactive according to 
survey status. Field is available for use in all modules. See Data Entry > Edit 
<module> Data > Information grid.

Seconds Amount of time in seconds that has elapsed for the number of Revolutions. 
This field is used to calculate the value in the Efficiency field. Add and enable 
the field Activate Seconds in the Rectifier Information grid to allow data 
entry in the Inspections grid. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information and Inspection grids > Customize > Layout.

Series Use Series to adjust or shift milepost numbers for a pipeline when adding a 
pipeline extension, re-routing a pipeline, or designating two pipelines as 
parallel lines. The calculated milepost number resulting from a Series is 
referred to as Relative Milepost. See CPDM module Data Entry > Pipeline 
Series.
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Signal Strength Signal strength of the voltage gradient (IR drop) at survey points along the 
pipeline as measured in millivolts (mV) by a voltmeter during a DCVG 
survey.

See ISM, Data Entry > Edit ISM Data > DCVG.

Soil Resistivity (Ohm/cm) Use this field to record soil resistivity measurements along the pipeline. 
Measurements are in Ohm-centimeters (Ohm/cm).

See ISM, Data Entry > Edit ISM Data > Soil Resistivity.

South P/S Structure reading in volts when a half-cell is placed near the east side of a 
tank. Add and enable Activate Cardinal Points in the Tank Information grid 
to allow data entry in the Inspections grid.

See CPDM, Data Entry > Edit CPDM Data > Tank > Information and 
Inspection grids > Customize > Layouts.

South P/S 
Maximum/Minimum

Maximum and minimum voltage value allowed for data entry when entering 
a structure reading in the South P/S field.

SRB Amount of sulfate-reducing bacteria (SRB) measured as parts per million 
(Ppm). Add and enable Activate SRB in the Samples Information grid to 
allow data entry in the Inspections grid. See ICM, Data Entry > Edit CPDM 
Data > Samples > Information and Inspection grids > Customize > Layouts.

Start Date First day of a start and end date range, such as a start date of 05/04/2012 
and an end date of 08/06/2012. A date range is typically used when 
generating a schedule or when defining a survey folder. This field is 
available in all modules. See Data Entry > Edit <module> Data > Information 
or Inspection grid.

Station Marker See description for Milepost.

Station Number Use this field to enter testing or facility location numbers on a pipeline (such 
as 23+124). Station numbers are also referred to as milepost, milepost 
marker, or station marker.

Station Number 
Maximum

A derived field showing the highest station number from survey readings in 
a continuous survey. See continuous survey types CIS, AC CIS, DCVG and 
so on in Indirect Survey Manager (ISM). Also see Work with Derived Fields 
on page 296.

Station Number Minimum A derived field showing the lowest station number from survey readings in a 
continuous survey.

Table B-19.  System Field Descriptions        cont'd



PCS v2.5 User Guide

Appendix B: System Field Descriptions 959

Name Description

Structure IRF and 
Structure IRF-CIS

Potential of the pipe, relative to the soil, with interrupted rectifier current 
(measured in volts). Use this field to enter pipe-to-soil "off" measurements 
taken at a site with all DC sources interrupted.

See ISM, Data Entry > Edit ISM Data > CIS.

In CPDM, add and enable Activate Structure IRF in the Test Point 
Information grid to allow data entry in the Inspections grid.

Structure P/S and 
Structure P/S-CIS

Potential of the pipe relative to the soil measured in volts. Use this field to 
enter pipe-to-soil "on" measurements taken at a site with all DC sources 
operational.

See ISM, Data Entry > Edit ISM Data > CIS.

In CPDM, add and enable the field Activate Structure P/S in the Test Point 
Information grid to allow data entry in the Inspections grid.

Surface Area Total length and width of the pipeline expressed in feet. This field is used to 
determine Efficiency in the Current Density report. See any module > Data 
Entry > Edit ROW Detail.

Surface Condition Surface condition of the pipeline. The field accepts up to five alphanumeric 
characters. See LSM, Data Entry > Edit LSM Data > Maintenance grid > 
Customize > Layouts.

Surface Covering Type of coating or covering on the pipeline. See LSM, Data Entry > Edit 
LSM Data > Maintenance grid > Customize > Layouts.

Survey Date Date an inspection or survey reading was taken.

Survey Interval Potential measurements taken at regular intervals for assessing the level of 
cathodic protection (CP). The system default is 2.5 feet for DC and AC 
close interval surveys (CIS and AC CIS) in ISM.

Survey Name Identifies the survey folder where a survey reading is assigned. Field is 
available for use in all modules. See Data Entry > Edit <module> Data > 
Inspection grid > Customize > Layouts. For periodic survey readings in 
CPDM, use the fields Periodic Survey and Periodic Survey Year instead.

Survey Remarks Remark or comment associated with a test point, rectifier, bond, anomaly, 
or landmark for a particular survey.

Surveyor Name of person conducting a survey.

Tap Settings Coarse or fine tap settings for rectifier output adjustment, such as C2F3. 
Add and enable Activate Tap Settings in the Rectifier Information grid to 
allow data entry in the Inspections grid. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier > Information and Inspection grids > Customize > 
Layouts.
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Total Footage Total number of feet for pipeline segment.

Uncompensated Off Pipe-to-soil "OFF" (P/S) value received from the Allegro. This is the raw 
reading without telluric compensation. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Detail Inspection mini-grid.

Uncompensated On Pipe-to-soil "On" (P/S) value received from the Allegro. This is the raw 
reading without telluric compensation. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Detail Inspection mini-grid.

Unregistered Milepost An unregistered milepost is a milepost in an imported stationary survey that 
does not match an existing milepost in PCS for the currently selected ROW 
(pipeline segment). Unregistered mileposts relate only to the associated 
stationary survey and are not considered as facilities in PCS. Unregistered 
mileposts are however used in telluric compensation. Also refer to Existing 
Facilities. See CPDM, Data Entry > Stationary Survey Maintenance > Snap 
To Facility.

User IR Correction When a value is entered in User IR Correction, PCS uses the value to 
calculate Target P/S instead of using the absolute difference between 
Structure P/S and Structure IRF. See CPDM, Data Entry > Edit CPDM Data 
> Test Point > Inspection grid > Customize > Layouts.

Valve Coating Condition of valve coating at inspection. Add and enable Activate Valve 
Coating in the Information grid to allow data entry in the Inspections grid. 
See VM, Data Entry > Edit VM Data > Information and Inspection grids > 
Customize > Layouts.

Valve Condition General condition of valve at inspection. Add and enable Activate Valve 
Condition in the Information grid to allow data entry in the Inspections grid. 
See VM, Data Entry > Edit VM Data > Information and Inspection grids > 
Customize > Layouts.

Valve Operated Check box for indicating if the valve was manually operated. Add and 
enable Activate Valve Operated in the Information grid to allow use of the 
field in the Inspections grid. See VM, Data Entry > Edit VM Data > 
Information and Inspection grids > Customize > Layouts.

Valve Pass/Fail Status of the valve after inspection. Add and enable Activate Valve 
Pass/Fail in the Information grid to allow data entry in the Inspections grid. 
See VM, Data Entry > Edit VM Data > Information and Inspection grids > 
Customize > Layouts.
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Valve Secured Check box for indicating if the value was left secured. Add and enable 
Activate Valve Secured in the Information grid to allow use of the field in the 
Inspections grid. See VM, Data Entry > Edit VM Data > Information and 
Inspection grids > Customize > Layouts.

Valve Type Type of valve such as block or plug. See VM, Data Entry > Edit VM Data > 
Information or Inspection grid > Customize > Layouts.

Vendor Name of the company providing a service.
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Appendix C:   System Security
PCS security is based on a user role method. A user role is a collection of permissions that tell the system 
which features a user has access to and whether or not the user is allowed to add, edit, or delete data. The 
system supports the following PCS installed user roles:

 l SysAdmin

 l User

 l Read Only

The SysAdmin user role has full control of all PCS features and functions. The SysAdmin assigns the 
SysAdmin, User, or Read Only user role to all other users of the PCS system. User role assignments are set 
up in User Management (Tools > User Management).

The following table identifies system permissions included with the User and Read Only user roles. 
Information is organized based on PCS menu and menu functions, then by permission level and user role.

Menu Function Permission User Read 
Only

File File Menu Access Yes Yes

File Select ROWs Access Yes Yes

File Select ROWs Edit (move, rename), Add, 
Delete

Yes No

File Select ROWs Find, Change, Make 
Selections, Clear

Yes Yes

File Database Integrity Check Access No No

Modules Modules Menu Access Yes Yes

Modules CPDM, VM, ACM, ICM, 
LSM, ISM, CMM

Access Yes Yes

Data Entry Data Entry Menu Access Yes Yes

Data Entry Edit Module Data Access Yes Yes

Data Entry Edit Module Data Edit, Add, Delete Yes No

Data Entry Edit Module Data > Build 
Survey

Access Yes No
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Data Entry Edit Module Data > Mini-
grid

Access Yes Yes

Data Entry Edit Module Data > Options Access Yes Yes

Data Entry Edit Module Data > Public 
Layout Themes

Access Yes Yes

Data Entry Edit Module Data > Public 
Layout Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private 
Layout Themes

Access, Edit, Add,
              Delete

Yes Yes

Data Entry Edit Module Data > Public 
Sort Themes

Access Yes Yes

Data Entry Edit Module Data > Public 
Sort Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private 
Sort Themes

Access, Edit, Add,
              Delete

Yes Yes

Data Entry Edit Module Data > Public 
Filter Themes

Access Yes Yes

Data Entry Edit Module Data > Public 
Filter Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private 
Filter Themes

Access, Edit, Add,
Delete

Yes Yes

Data Entry Edit Module Data > Ad Hoc 
Filters

Edit, Add, Delete Yes Yes

Data Entry Define Routes Menu Access Yes Yes

Data Entry Define Routes Edit, Add, Delete/Undelete Yes No

Data Entry Define Schedules Menu Access Yes Yes

Data Entry Define Schedules Edit No No

Data Entry Edit Schedule Settings 
Menu

Access Yes Yes

Data Entry Edit Schedule Settings Edit No No

Data Entry Edit ROW Detail Menu Access Yes Yes

Data Entry Edit ROW Detail Edit, Add, Delete/Undelete Yes No

Data Entry Pipeline Series Access Yes Yes

Data Entry Pipeline Series Edit/Add/Delete/Undelete No No

Data Entry Survey Folder Maintenance Access Yes Yes
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Data Entry Survey Folder Maintenance Edit, Add, Delete/Undelete No No

Reports/Graphs Reports/Graphs Menu, 
Reports, Graphs, Custom 
Reports

Access Yes Yes

Tools Tools Menu Access Yes Yes

Tools Bridge Menu; 
Bridge

Access, Edit Yes No

Tools Field and UDF 
Customization Menu

Access Yes No

Tools Field and UDF 
Customization

Edit, Add, Delete No No

Tools Data Modification Utility Access No No

Tools Data Utilities > Data 
Modification Utility

Access Yes No

Tools Email Notification Access No No

Tools Themes Management 
Menu

Access Yes Yes

Tools Themes Management Edit No No

Tools Activation Key Access Yes Yes

Tools Facility Type Themes 
Management Menu

Access Yes Yes

Tools Facility Type Themes 
Management

Edit No No

Tools User Management Menu Access No No

Tools User Management Edit No No

Tools Application Schemes Menu Access Yes No

Tools Application Schemes Edit Yes No

Tools Options Menu Access Yes No

Table C-20.  Permissions for Installed User Roles        cont'd
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Menu Function Permission User Read 
Only

Tools Options > Bullhorn
Options > Criteria
Options > Editing
Options > Field Computer
Options > General
Options >Hierarchy
Options > Reports
Options > Security

Edit No No

Field Computer Field Computer Menu
Send
Receive
Log

Access Yes No

Help Help Menu
About PCS
Technical Support

Access Yes Yes

Table C-20.  Permissions for Installed User Roles        cont'd
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