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1 
Getting Started

This guide explains how to install Bullhorn® RM4012 units and then configure 
them for service using the Universal Configuration Toolkit (UCT) software. The 
RM4012 use the SkyWave-Inmarsat satellite network services for communication 
with the Bullhorn Asset Tracker (BAT)website. 

This guide includes the following chapters and appendix for help in installing 
and configuring the RM4012:

 Chapter 1 - Installation

 Chapter 2 - Configuration

 Appendix A - Optional Selectable Current Transducer Installation

The CD provided in the installation kit includes a copy of this document in 
Adobe® PDF format. You can also download a copy from the BAT website 
through the Help menu. Use Adobe® Reader® version 5 or higher to view the 
PDF. If needed, visit the Adobe website at http://www.adobe.com to download a 
free copy of the software. 

NOTE: For information about how to download files from the BAT website, see 
Installing the UCT Software on page 5.
1
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ESD Precautions

WARNING: To prevent electrostatic discharge (ESD) damage when handling 
electronic equipment, always wear an antistatic wrist strap attached to an 
unpainted, grounded metal object. Ensure the wrist strap has maximum contact 
with bare skin. If an antistatic wrist strap is unavailable, discharge static 
electricity from yourself and your clothing by touching a grounded metal object 
before handling electronic equipment.

Bullhorn System Overview
Bullhorn is a wireless, telemetry system that provides scheduled and by-
exception inbound reporting for field equipment typically located in remote 
areas. Data and alarm packets transmit from remote field locations to your 
account on the secure, Bullhorn Asset Tracker (BAT) website (http://
www.bullhornsys.com) using digital cellular or satellite communication networks. 
You can quickly determine the status of field equipment anytime using 
information that posts to your BAT website account. 

Bullhorn units provide remote monitoring with full coverage using GSM digital 
cellular, GEOS satellite (SkyWave-Inmarsat), or LEOS satellite (ORBCOMM) 
communication networks.

RM4012 Overview
The RM4012 is a remote alarm point monitor and pulse count accumulator that 
features two AC monitors.

RM4012 units are designed to monitor various types of devices, such as cathodic 
protection rectifiers, test points, critical bonds, tanks, and meters. After installing 
an RM4012 unit, it is then configured for service using the Universal 
Configuration Toolkit (UCT) software. The UCT software allows you to set 
specific parameters that enable the unit to report measurements, alarm 
conditions, state changes, health check intervals, and accumulated counts.

RM4012 units transmit data (input channel measurements and alarms) using 
satellite communication networks. The RM4012 transmits data using the 
SkyWave-Inmarsat satellite network. Visit the following website to view satellite 
coverage maps: 
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 SkyWave-Inmarsat coverage map:
http://www.inmarsat.com

AC Monitors
The RM4012 includes two AC monitors. An AC monitor is a module that converts 
AC voltage to DC voltage. It supports an input voltage of 0–100 VAC from an AC 
connection on a test point, grounding mat, Kirk Cell®, or similar device. The 
module converts AC voltage to DC voltage in a range of 0–5V DC for output. The 
AC monitor is typically used to detect hazardous, AC voltage on a pipeline that 
shares the same right-of-way as high voltage power lines.

Required Tools and Equipment
The following tools and equipment are required for installing and configuring the 
unit for service:

 Antistatic wrist strap

 Small slotted screwdriver

 Small Phillips head screwdriver

 Wire stripper

 Wire cutter

 Voltmeter

 Adjustable wrench (for solar panel battery charger installation)

 Socket or open end wrench set

 Compass

 Waterproof sealing tape

 silicone adhesive

 Mounting hardware (appropriate type for mounting surface; supplied by
customer)

 Appropriate tools for preparing the mounting surface for installation (such
as a hand drill and metal, masonry, or wood drilling bit)
Getting Started 3
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 Installation drawing (provided in installation kit)

 Configuration cable (provided in installation kit; standard mini USB cable 
typically used with most digital cameras)

Hardware
IBM-compatible computer with the following hardware and software 
specifications: 

 Pentium® processor or equivalent

 256 MB RAM (minimum)

 70 MB free hard drive space

 Spare USB port

Software
 Microsoft® Windows XP operating system with Service Pack 2 or 3; Vista® 

Home Premium, Business, or Ultimate with Service Pack 1 or higher; or 
Windows 7® Home Premium, Professional, or Ultimate

 Universal Configuration Toolkit Software (provided in the installation kit)

 Windows .NET Framework version 2.0 or higher (provided in installation 
kit)

 USB device driver (provided in the installation kit)

 Windows® Internet Explorer® version 8.0 or higher

 Adobe® Reader® version 5.0 or higher

Universal Configuration Toolkit Software
Universal Configuration Toolkit (UCT) is a software program you use to set and 
read the adjustable parameters of the unit. After installing the unit, you then 
configure it for service using the UCT software. 

The UCT software also provides diagnostic tools for checking input channel 
measurements, RSSI level, and transmitting a test packet to confirm 
communications with the BAT website. 
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Using the UCT software requires that your computer be installed with Microsoft® 
.NET Framework version 2.0 or higher. To use the USB configuration port on the 
RM4012, your computer must be installed with the appropriate USB device 
driver. 

NOTE: You must log on as an administrator or your computer user name must 
be a member of the Administrators group in order to install the USB device 
driver. If needed, contact your network administrator or IT department to 
determine if your user name is setup with administrator rights or privileges.

The installation kit provides a CD that includes the UCT software, .NET 
Framework, and USB device driver. Installation procedures are provided in the 
next chapter. 

NOTE: Before you begin the field installation, visit the BAT website 
(www.bullhornsys.com) to verify you have the latest version of the UCT or .NET 
Framework software. Click Help > Support Files > Support Files for Download to 
view a list of files available for download. 

Installing .NET Framework
1 Using the CD provided in the installation kit, insert the CD in the CD-ROM 

drive of your computer.

2 Double-click the dotnetfx.exe file to begin installing .NET Framework on 
your computer.

3 Follow the prompts to complete the installation.

Installing the UCT Software
If you have a previous version of the UCT software installed on your computer, 
review the following information prior to installing a new version of the software. 
Also see Figure 1-1 on page 6. 

 Everyone Installation Option: If you installed a previous version of the 
UCT software using the Everyone option, the previous version must first 
be uninstalled prior to installing the new version.
Getting Started 5
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 Just Me Installation Option: If you installed a previous version of the 
UCT software using the Just Me option, it is not necessary to uninstall the 
previous version prior to installing the new version.

Figure 1-1.  Configuration Toolkit Installation Options

The following procedure explains how to install the UCT software using the CD 
included in the installation kit. 

NOTE:  If the installation CD is unavailable, visit the BAT website 
(www.bullhornsys.com) to download a copy of the UCT installation file. Click 
Help > Support Files > Support Files for Download > Universal Configuration 
Toolkit (UCT). Use the procedure in this section to install the UCT software. 

Complete the following steps:

1 If a previous version of the software is installed using the installation 
option “Everyone”, uninstall the software as follows: 

a Click Start in the Windows Start menu and then select Settings > 
Control Panel.

b Click Add or Remove Programs.

c Click Configuration Toolkit and then click Remove.

d After the UCT software uninstalls, click the Windows close icon (X). 
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2 To install the UCT software using the installation CD:

a Insert the CD in the CD-ROM drive of the computer.

b Double-click setup.exe and then follow the prompts to install the UCT 
software. 

c Continue with the next section to install the USB device driver.

3 To install the UCT software using the file downloaded from the BAT 
website: 

a Double-click UniversalConfigToolkit.zip to extract files in a folder on 
the computer. 

b Double-click setup.exe and then follow the prompts to install the UCT 
software. 

c Continue with the next section to install the USB device driver.

Installing the USB Device Driver
If the unit includes a USB configuration port, use the procedure in this section to 
install the USB device driver. Installing the driver is a one-time process and does 
not need to be repeated if you have already installed it on the computer. 

IMPORTANT: Installing the USB device driver requires that you log on the 
computer as an administrator. Or, your computer user name must be a member of 
the Administrators group. If needed, contact your network administrator or IT 
department to determine if your user name is set up with administrator rights or 
privileges. 

Complete the following steps to install the USB device driver:

1 If you are installing the driver from the CD in the installation kit, insert the 
CD in the CD-ROM drive and then open Windows Explorer to view the 
contents of the CD. 

2 Double-click the file labeled CP210x_VCP_Win2K_XP_S2K3_vista.exe and 
then follow on-screen prompts to install the driver.
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3 Connect the USB configuration cable (included in the installation kit) in an 
available USB port on the computer. Connect the other end of the cable in 
the USB configuration port on the unit. 

4 If the driver does not automatically install, click Install from a list or 
specific location (Advanced) when Windows automatically displays the 
Found New Hardware Wizard (Figure 1-2). 

Figure 1-2.  Found New Hardware Wizard (page 1)

5 Click Next to display page 2 of Found New Hardware Wizard (Figure 1-3).

Figure 1-3.  Found New Hardware Wizard (page 2)
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6 Complete the following steps on page 2 of Found New Hardware Wizard: 

a Click the option Search for the best driver in these locations.

b Click the option Include this location in the search.

c Click Browse and then navigate to the following computer directory:

C:\SiLabs\MCU\CP210x

d Click Next to install the USB device driver.

NOTE: If Windows displays a message that states the USB device driver 
has not passed Windows Logo testing, click Continue Anyway to proceed 
with the installation. The USB device driver that AI supplies has passed 
“Windows Logo” testing by the USB chipset manufacturer. However, once 
it has been customized to identify the USB device as a Bullhorn unit, the 
USB device driver appears to Windows as “untested”. 

7 Click Next to install the driver. 

8 When the installation completes, page 3 of Found New Hardware Wizard 
displays (Figure 1-4). Click Finish to complete the installation and close the 
window. 

Figure 1-4.  Found New Hardware Wizard (page 3)
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Bullhorn Information Line
The Bullhorn Information Line is an automated attendant telephone system. It is 
typically used when installing units in the field. The system identifies when the 
last data transmission (or test packet) was received on your website account for a 
unit you specify.

Complete the following steps to use the Bullhorn Information Line:

1 Call the Bullhorn Information Line at 866-287-6739.

2 Press 1 to access the packet log when prompted.

3 Use your telephone keypad to enter the unit serial number when 
prompted. The unit serial number is included on the bar code label on the 
side of the unit. It is also included on the label of the shipping carton. If 
required, repeat this step to check another unit.

Contacting Technical Support
If you need assistance with the installation or configuration, contact American 
Innovations (AI) Technical Support in any of the following ways.

Telephone: 512-249-3400

Email: bhtechservices@aiworldwide.com

Address: American Innovations, Ltd. 
ATTN. FDD Technical Services 
12211 Technology Blvd. 
Austin, TX 78727

Fax: 512-249-3444
10 Getting Started



2
Installation

The procedures in this chapter explain how to install the RM4012. 

NOTE: Because of the variations in customers’ installation and grounding 
methods, AI cannot warranty any damage to equipment caused by lightning 
strikes. 

The RM4012 (Figure 2-1) is housed in an aluminum enclosure. It uses the 
SkyWave-Inmarsat satellite communication network and includes two AC 
monitors.

The RM4012 supports the following inputs: 

 PCR AC AMPS (CH1): Selectable amp setting (30, 60 or 120A AC).

 P/S DC Volts (CH2): ±5V DC.

 Current Density (CH3): 0-200mA AC.

 P/S AC Volts (CH4): 0-100V AC.

 Digital Input (CH5 and CH6): Digital dry contact closure or active digital.

NOTE: PCR = Polarized Cell Replacement 
P/S = Pipe to Soil
11
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Figure 2-1.  RM4012 Hardware Configuration

IMPORTANT: The Bullhorn Asset Tracker (BAT) website includes a SkyWave 
coverage map. If you plan to install the RM4012 outside the United States, use the 
coverage map and the procedure in Confirming Satellite Communication on 
page 22 to correctly install the satellite terminal. To view the coverage map, visit 
the BAT website, then click Help, and then click Coverage Maps. 
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IMPORTANT: If you plan to install the RM4012 in the United States, install the 
satellite terminal so that it faces in a southeast direction. The satellite terminal is 
programmed at the factory for communications with the SkyWave-Inmarsat 
satellite positioned southeast of the United States.

Installation Overview
The following list provides an overview of a typical installation performed in the 
field: 

 Determine where to install the unit, making sure objects or the terrain do
not interfere with satellite communications.

 Confirm communications with the SkyWave-Inmarsat satellite network.

 Mount the enclosure; install the satellite terminal; install the solar panel
battery charger.

 Install the Current Density Transducer.

 OPTIONAL: Install the Selectable Current Transducer (see Appendix A on
page 45 for installation instructions).

The entire installation of both current transducers is shown in the following 
wiring diagram (Figure 2-2).
Installation 13
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Figure 2-2.  Transducer Wiring Diagram

IMPORTANT: Electrostatic Discharge (ESD) can damage electronic 
components. Provide ESD protection by wearing an antistatic wrist strap attached 
to any unpainted metal surface before opening the enclosure door of the unit or 
handling electronic parts. If an antistatic wrist strap is unavailable, discharge 
static electricity from yourself and your clothing by touching a nearby metal 
surface before opening the enclosure door of the unit or handling electronic 
components.

Preparing for the Installation
Use the following items as a checklist prior to installing an RM4012:

1 Does the installation area provide enough room to easily open the 
enclosure? When you finish the installation, you’ll need to open the 
enclosure to connect input wires and to configure the unit for service using 
the UCT software.

2 Is the latest version of the UCT software installed on the computer you 
plan to use during the installation? For more information, see Universal 
Configuration Toolkit Software on page 4.

-
+ C

h3 Current Density

-
+ C

h4 P/S AC Volts

-
+ C

h2 P/S DC Volts

4 conductor
cable

Jumper

Test StationTest Coupon

Pipe / Structure

Ref Cell

Added
Bannana

Jack

-
+ C

h1 PRC AC Amps

PRC
Current Sensor

Bullhorn Inputs

Current Density 
Transducer 
Assembly 

Remote Monitoring 
Unit Inputs 

PCR AC Amps 

PCR 
Selectable Current 
Transducer 
14 Installation



RM4012 Installation and Configuration Guide
3 To ensure uninterrupted service, the location you plan to install the 
satellite terminal must meet the following qualifications:

• The area must be clear of all obstructions such as buildings, trees, and
hills.

• The satellite terminal should be located at least 6-½ feet from objects
taller than 1-¾ feet in the direction of the satellite.

• The satellite terminal must have a clear line-of-sight facing in a
southeast direction so that it faces the satellite located southeast of the
U.S.

• The satellite terminal should not be installed in an area where standing
water may occur. The drain holes in the slots on the bottom of the
terminal should not be blocked.

Mounting Requirements
The RM4012 enclosure (Figure 2-3) can be mounted anywhere with a few 
precautions. The list below identifies conditions to consider when choosing a 
location. Mounting hardware suitable for the type of mounting surface is 
provided by the customer.

Figure 2-3.  Enclosure Dimensions

 Mount the enclosure in a clear, unobstructed area.
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 The installation area should provide enough working space to easily open
the enclosure when performing routine maintenance or configuring the
RM4012 for service.

Installing the RM4012
For quicker communication with the satellite, install the enclosure and satellite 
terminal first, and then complete the remainder of the installation while the 
RM4012 acquires a communications link with the SkyWave-Inmarsat satellite.

Mounting the Enclosure
The enclosure comes with two (2) metal mounting brackets installed on the back 
for easy mounting to either a flat surface or pole.

The enclosure comes with a pole mounting kit that includes the following items:

 U-bolts, 2 each (for top and bottom metal bracket).

 Pipe brackets, 2 each (for top and bottom metal bracket).

 Mounting hardware, 4 each (nuts and washers for the u-bolts).

To mount the enclosure, use the procedure in any of the following sections.

Mounting the Enclosure on a Flat Surface or Telephone Pole
To install the enclosure against a telephone pole using the factory-installed metal 
brackets, complete the following steps:

1 Place the enclosure against the surface in the location you plan to mount it.

2 Mark the hole locations of the top and bottom center holes. Set the 
enclosure aside. Use a hand drill and a metal, masonry, or wood drilling 
bit to drill two holes in the mounting surface where you marked their 
locations in step 2, one for the top bracket and one for the bottom bracket.

3 Place the enclosure back in place where the holes line up and drive in lag 
bolts or other appropriate fasteners to hold the enclosure in place.

4 Continue with Satellite Terminal Assembly on page 17.
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Mounting the Enclosure on a Pole or Pipe
To install the enclosure on a pole or pipe (the typical method), complete the 
following steps:

1 Install one u-bolt around the pole, through the pipe bracket, and then 
through the top mounting bracket. 

2 Secure the u-bolt using washers and nuts provided in the installation kit. 
Tighten nuts. 

3 Repeat steps 1 and 2 for the bottom mounting bracket.

4 Continue with Satellite Terminal Assembly.

Satellite Terminal Assembly
Before installing the satellite terminal, assemble the terminal for use in either a 
non-hazardous installation site (see below) or a hazardous installation site (see 
page 19). 

Satellite Terminal Assembly for a Non-Hazardous Installation Site
Complete the following steps to assemble the satellite terminal, mounting bracket, 
and u-bolt: 

1 Remove four (4) screws labeled A and B or C and D in the next figure 
(Figure 2-4). 

Figure 2-4.  Removing Satellite Terminal Screws

A

B

C

D
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2 Install the satellite terminal on the mounting bracket (Figure 2-5) using 
four #6 x 5/8 Plastite screws provided in the installation kit. 

Figure 2-5.  Mounting Bracket and Satellite Terminal (Non-
Hazardous Installation Site)

3 Plug the mating connector on the interface cable in the connector on the 
bottom of the satellite terminal. Apply non-conductive silicone grease 
on the mating connector and then wrap with waterproof sealing tape. 

4 Create a strain relief for the interface cable using a tie wrap and one of the 
mounting holes on the mounting bracket as shown in the next figure 
(Figure 2-6). 

5 Fasten the u-bolt and mounting bracket to the satellite terminal mounting 
bracket using two ¼–20 nuts and split washers (Figure 2-6). Tighten
hardware using an adjustable wrench. 

Satellite Terminal

Satellite Terminal Mounting Bracket
Interface Cable

#6 x 5/8 Plastite Screw
(4 Places)
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Figure 2-6.  U-bolt and Mounting Bracket Installation (Non-
Hazardous Installation Site)

6 Continue with Installing the Satellite Terminal on page 21. 

Satellite Terminal Assembly for a Hazardous Installation Site
Complete the following steps to assemble the satellite terminal, gasket, adapter 
base, and interface cable:

1 Remove the lock nut from the adapter base (1-¼ inch PVC male threaded 
conduit adapter). Set aside for re-installation later. 

2 Place the gasket in the space on the top of the adapter (Figure 2-7).

Interface Cable 

U-bolt 

Mounting Bracket 

¼–20 Nut and 
Split Washer 
(2 Places) 

Satellite Terminal 

Satellite Terminal Mounting Bracket 
Tie Wrap (strain relief) 
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Figure 2-7.  Satellite Terminal Assembly for Hazardous 
Installation Site

3 Route the mating connector on the interface cable through the adapter base 
and gasket. 

4 Plug the mating connector on the interface cable in the connector on the 
bottom of the satellite terminal. Apply non-conductive silicone grease 
on the mating connector and then wrap with waterproof sealing tape. 

5 Install the adapter base on the satellite terminal using four (4) threaded 
studs, washers and nuts. 

6 Fasten the u-bolt and mounting bracket to the satellite terminal mounting 
bracket using two ¼–20 nuts and split washers as shown in the previous
figure. Tighten hardware using an adjustable wrench. 

7 Install the adapter base on the satellite terminal mounting bracket by 
routing the interface cable through the mounting hole on the bracket and 
then using the lock nut to secure the terminal. 

8 Continue with Installing the Satellite Terminal on page 21.

Satellite Terminal

Gasket

Adapter Base
(1 ¼ inch PVC Male Threaded Conduit Adapter) 

Satellite Terminal Mounting Bracket

Interface Cable

U-bolt and 
Mounting Bracket

Lock Nut

Washer and Nut
(4 Places)

¼–20 Nut and 
Split Washer
(2 Places)

Create strain relief for terminal 
interface cable using tie wrap 
and available mounting hole.  

Threaded Stud
(4 Places)
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Installing the Satellite Terminal
Complete the following steps: 

1 Install the satellite terminal on the mounting surface using the u-bolt 
(Figure 2-8). The satellite terminal must face in the direction of the 
SkyWave-Inmarsat satellite located southeast of the United States.

WARNING: The satellite terminal should not be installed in an area 
where standing water may occur. The drain holes in the slots on the 
bottom of the terminal should not be blocked. The installation area should 
provide a clear line of sight to the satellite with no obstructions such as 
building, trees, or hills. The satellite terminal should be facing in the 
direction of the Inmarsat satellite located southeast of the United States. 

Figure 2-8.  Example of Typical Satellite Terminal Installation

2 Route the satellite terminal interface cable through the water-tight fitting 
on the bottom of the enclosure. Connect the interface cable in the SAT 
TERMINAL connector on the faceplate of the RM4012 (Figure 2-1). The 
RADIO POWER LED will turn red when the satellite terminal is on or when 
the unit is transmitting a data packet. 

NOTE: The RM4012 makes a clicking sound after applying power. This is 
a normal function and indicates the unit is polling the input channels.

Satellite Terminal

Mounting Bracket
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3 Connect the configuration cable in an available USB port on your 
computer. Connect the other end of the cable in the USB CONFIG port on 
the faceplate of the RM4012 (Figure 2-1). 

4 Start the UCT software. When the Find Devices window displays, select 
your unit.

5 When the main configuration window displays, click Auto Update in the 
Communications group box. 

Confirming Satellite Communication
Use the following procedure at the location you plan to install the satellite 
terminal. The procedure will help confirm communication with the satellite 
before you install the equipment.

Complete the following steps:

1 Open the RM4012 unit enclosure. 

2 If you are installing the RM4012 outside the United States, use the BAT 
website Help>Coverage Maps (http://www.bullhornsys.com) to locate the 
satellite that covers the area where you plan to install the satellite terminal.

3 Connect one end of the satellite terminal interface cable in the connector on 
the bottom of the satellite terminal. Route cable through bottom of unit 
enclosure, through the smaller water-tight fitting.

4 Connect the other end of the cable to the SAT TERMINAL connector on the 
faceplate of the RM4012. 

5 Point the satellite terminal to the southwest - making sure it has a clear 
line-of-sight and the path is clear of all obstructions. If you are unsure of 
the nearest satellite, please contact Technical Support. 

6 The RADIO POWER LED turns on only when the satellite terminal is 
transmitting data to the satellite. 
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IMPORTANT: Footprint anomalies and intermittent obstacles on the 
horizon can cause satellite communications failure. Low look angles (less 
than 15 degrees elevation) may also be subject to fading due to rain, snow, 
clouds, and other weather conditions. Every attempt has been made to 
ensure the highest level of system availability and reliability. However, the 
previously mentioned conditions may have an impact on the provided 
service. 

Installing the Solar Panel Battery Charger
The procedure in this section explains how to assemble and install the 5 watt solar 
panel battery charger. 

Complete the following steps:

1 Prepare the mounting surface for the solar panel installation. Depending 
on the type of mounting surface, use a hand drill and a metal, masonry, or 
wood drilling bit. 

2 Assemble the solar panel mounting bracket and solar panel in the 
following manner:

a Install the provided hardware in the mounting holes on the solar panel 
mounting bracket (Figure 2-9).

Hardware includes (2) 5/16” hex head bolts with nuts and (4) washers 
and split-ring washers. 

Figure 2-9.  Solar Panel Mounting Bracket

b Place the solar panel face down on a flat surface. 
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c Install the solar panel mounting bracket in the left and right channels 
of the multi-mount frame (Figure 2-10). 

Figure 2-10.  Solar Panel Multi-Mount Frame

d Position the solar panel mounting bracket in the center of each channel. 
Use an adjustable wrench to loosely tighten hardware to prevent the 
bracket from moving.

e Using four (4) end caps provided in the installation kit, insert an end 
cap in both ends of each channel (Figure 2-11). 

Figure 2-11.  Installing End Caps
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f Install the solar panel on the mounting surface using the following 
guidelines: 

• To prevent signal interference during data transmissions, install 
the solar panel at least two (2) feet above the RM4012. 

• Install the solar panel using the solar panel mounting bracket and 
mounting hardware appropriate for the type of mounting surface. 
Mounting hardware is provided by the customer. 

• Position the solar panel 10 degrees above horizontal and facing 
south for full sun exposure. 

• If you plan to install the solar panel on a pipe, use the provided u-
bolt and pipe bracket with the solar panel mounting bracket 
(Figure 2-12). 

• Use an adjustable wrench to tighten mounting hardware. 

Figure 2-12.  U-bolt and Pipe Bracket Option

3 Route the solar panel cable through the water-tight fitting on the bottom of 
the RM4012 enclosure. 

4 Connect the solar panel cable in the positive (+) and negative (–) terminals 
of the SOLAR terminal block (Figure 2-1). Red wire connects to the positive 
(+) terminal; black wire connects to negative (–) terminal. 
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Installing the Current Density Transducer

WARNING: If wires are to be buried or covered, conduit must be used to 
protect the wires. 

Figure 2-13.  Current Density Transducer Assembly

Complete the following steps to connect the Current Density Transducer 
assembly to the RM4012:

1 Ensure that the RM4012 unit is powered off.

2 Drill a hole in the test station pipe that is large enough to fit the included 
.492” water-tight fitting. 

3 Remove the cap from the test station. 

4 Install the included blue banana jack lug to the terminal board (Figure 2-
14).

Current Sensor

Ring Tongue
Terminals

Wire
Coupler
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Figure 2-14.  Test Station Terminal Board - Before Installation

5 Route all input wires of the Current Density Transducer assembly through 
the opening of the test station so that the current sensor is on the back side 
(Figure 2-14) and the assembly wires are on the connector side (Front, 
Figure 2-14). See Figure 2-17 on page 29 for an example of a completed 
transducer installation.

6 Attach the Current Density Transducer assembly ring tongue terminals 
(blue wires, see Figure 2-13) to test station terminal board connectors, one 
to P/S and the other to the CP Coupon connectors.

7 Route the four-conductor cable (included) through water-tight fitting in 
test station pipe to terminal board.

8 Connect the black and white wires of the four-conductor cable to the screw 
terminal on the Current Density Transducer assembly (Figure 2-15), 
matching white to white and black to black. 

Front Back

Banana JacksConnectors
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Figure 2-15.  Current Density Transducer Assembly Screw 
Terminal

9 If a reference cell is installed, connect ring tongue terminals (included, 
Figure 2-16) to the ends of the red and green wires and then to the 
reference cell connector on the test station terminal board.

Figure 2-16.  Ring Tongue Terminal

The following examples show a typical installation of the Current Density 
Transducer to the test station:

Screw
Terminal
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Figure 2-17.  Test Station Terminal Board - After Installation

10 Route the four-conductor cable through the water-tight fitting on the 
bottom of the RM4012 enclosure and toward the terminal block labeled 
CURRENT DENSITY (CH1). 

11 Attach the black and white wires of the four-conductor cable to the 
CURRENT DENSITY (CH1) terminal block.

12 Attach the green and red wires of the four-conductor cable to the P/S AC 
VOLTS (CH4) terminal block.

13 To measure for DC volts, jump the red and green wires to the P/S DC 
VOLTS (CH4) terminal block (Figure 2-18).

Figure 2-18.  Wire Jumping from P/S AC VOLTS to P/S DC 
VOLTS

Front Back
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14 If needed, dress input wires inside the RM4012 enclosure using provided 
tie-wraps and adhesive tie-wrap holders. 

15 Replace the cap on the test station.

16 Turn ON the RM4012.

NOTE: The RM4012 makes a clicking sound after turning on the power 
switch. This is a normal function and indicates the unit is polling the input 
channels.

17 Push and hold the AC Monitor Reset button for at least 5 seconds.

18 Continue with Chapter 3, Configuration on page 31 to configure the 
RM4012 for service. 
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3
Configuration

This chapter explains how to configure the RM4012 for service using the UCT 
software. 

The configuration process includes the following tasks: 

1 If present, disable any synchronization software (page 32).

2 Connect the unit to your computer. Start UCT and select a unit to configure 
(page 32).

3 Load a template (page 33).

4 Choose a folder on your computer to store templates and log files 
(page 34).

5 Set up battery information, controller clock, and a transmission schedule 
(page 34-35).

6 Set up input channels and alarms (page 36).

7 Save settings in the Event Log (page 43).

8 Transmit a test packet (page 43). 

9 Save settings in a template (page 44).

10 Exit UCT and close the enclosure (page 44).
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Disable Synchronization Software
If you use a synchronization software to synchronize a mobile device with your 
computer, temporarily disable the software before starting UCT. 

If you use Microsoft ActiveSync to synchronize the Allegro field computer with 
your computer, complete the following steps to temporarily disable the software:

1 Click Start > Programs > Microsoft ActiveSync.

2 Click File > Connection Settings. If enabled, click to remove the check 
mark and disable COM port, USB, and network options. 

3 Click OK to close Connection Settings. 

4 Click File > Close to exit ActiveSync.

Connect the Unit and Start UCT
Complete the following steps:

1 Connect the configuration cable in the USB port of your computer. Connect 
the other end of the cable in the configuration port of the unit. 

2 Double-click the Bullhorn icon on the desktop to start the UCT software. 
Or click Start > Programs > American Innovations > Configuration 
Toolkit. 

3 Select your unit in the drop-down list of the Find Devices window 
(Figure 3-1) and then click Select. 

Figure 3-1.  Find Devices
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4 The main configuration window displays after selecting a unit (Figure 3-2). 
Press F2 or click Tools > Read Unit Settings to verify UCT and the unit are 
communicating.

Figure 3-2.  Main Configuration Window

Load a Template
Load a template (if available) using the following steps: 

1 Click Tools > Advanced > Template > Load from Template (Figure 3-3).

Figure 3-3.  Load From Template
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2 When the Open Template window displays, locate the template. Double-
click on the template (do not select OPEN). 

3 After UCT applies the template, press F2 to read settings or click Tools > 
Read Unit Settings. 

4 Click File > Save Current Setup in Event Log to save settings.

Choose a Folder for Templates and Log Files
Templates and log files are stored in My Documents by default. If you want to 
store these files in a different folder on your computer, complete the following 
steps: 

1 Click Tools > Options to display the Options window. 

2 Click Folder for Log files to display the Browse for folder window.

3 Select an existing folder or click Make New Folder to create a new folder.

4 Click Ok and then click Done to close the window. 

Set Up Battery Information
Complete the following steps to identify the type of battery installed in the unit 
and the battery installation date: 

1 Click Change in Battery Information to display the Power/Battery 
window. 

2 Select an option in the Battery Type drop-down list. 

3 Click Installed Today if the battery was installed today. Or, click Installed 
Date and use the calendar to choose an installation date. 

4 Click Save. 
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Set Up Controller Clock
The controller clock is a time-of-day clock running inside the unit. It does not 
keep track of the month or year and also does not correct itself for daylight 
savings time. The unit uses the controller clock as a basis for all time-related 
operations.

Complete the following steps to set up the controller clock: 

1 Click Change in Controller Clock. 

2 Select Set to PC Time.

3 Click Save.

Set Up Transmission Schedule
Transmission schedule determines when and how often input channel readings 
transmit to your website account.

Complete the following steps:

1 Click Change in Transmission Schedule to display the Transmission 
Schedule window.

2 Select a field in the Transmit report at field. Use the up and down arrows 
to adjust the time. Repeat this step for remaining time fields as needed. 

3 If you want to include a delay in the transmission schedule, click Add 
Delay to place a check mark in the check box. 

NOTE: Add Delay is based on the unit serial number. The unit serial 
number is equivalent to the number of seconds added to the reporting 
time. This feature is typically used to offset the transmission schedule for 
several units set up with the same reporting time.

4 Select 1 Hour from the And repeat every drop-down list (Figure 3-4) to 
have the unit call in every hour.
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Figure 3-4.   Transmission Schedule - Repeat Transmission

5 Click Save. 

Set Up Input Channels and Alarms
Based on the type of input device connected to the input channels of the unit, use 
the procedure in the following sections to set up channels and alarms:

 Set Up an Input Channel for Millivolt Readings (page 36)

 Set Up an Input Channel for Analog Readings (page 39)

 Set Up an Input Channel for Digital Readings (page 41)

Set Up an Input Channel for Millivolt Readings
Complete the following steps to set up channels 1, 3, or 4 for millivolt readings. 
Refer to the Glossary on page 51 for UCT field descriptions. 

1 Based on the input channel the input device is connected to, click Ch1, Ch3, 
or Ch4 to display the channel configuration window (Figure 3-5). 
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Figure 3-5.  Example of Channel 1 (Ch1) Millivolt Settings

2 Click Enable, Analog, and +/– 50mV to enable the channel for service and 
millivolt readings. 

3 Type the unit of measurement used by the input device in the Engineering 
Units (on transducer) field. 

4 Based on shunt size, scale the input channel and input device as follows: 

a Type the minimum and maximum voltage level supported by the 
input channel in the top and bottom fields of Raw voltage values (on 
unit input), respectively. 

b Type the minimum and maximum voltage level supported by the 
input device in the top and bottom fields of Engineering Units (on 
transducer), respectively. 

5 If you want to apply an optional response filter to the input channel, click 
the Response Filter Time button and select a time option. 

6 If you want the unit to transmit an alarm packet when a low alarm 
condition occurs, click Transmit Low Alarm and then type a value in the 
Low Alarm field. 

The unit transmits an alarm packet when the input channel reading is 
lower than the value entered in the Low Alarm field. 
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7 If you want the unit to continue transmitting low alarms until the alarm 
condition is removed in the field, click Repeat Low Alarm and then type a 
value in the Repeat delay in minutes field. 

The Repeat delay in minutes value is the number of minutes between 
repeated alarm transmissions for both low and high alarm conditions. 

8 If you want the unit to transmit an alarm packet when a high alarm 
condition occurs, click Transmit High Alarm and then type a value in the 
High Alarm field. 

The unit transmits an alarm packet when the input channel reading is 
higher than the value entered in the High Alarm field. 

9 If you want to include deadband in low and/or high alarms, type a value 
in the low and/or high alarm Deadband fields.

Valid entries are any positive scaled value that does not cause the alarm 
point to be lower than the minimum scale value or higher than the 
maximum scale value in Engineering Units (on transducer). Entering zero 
disables deadband.

10 If you want to apply a persistence filter to low and/or high alarms, type a 
value in the Persistence field. Valid entries are any number from 1 to 
65535. Entering zero (0) disables persistence.

11 Click Validate/Check Entries to verify configuration settings are correct 
and then click Save. 

Text boxes display green or red to indicate whether or not an entered value 
is correct. If a text box is red, enter a different value and then validate 
again. If all text boxes are green, settings are correct. 
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Set Up an Input Channel for Analog Readings 
Complete the following steps to set up channels 1, 2, 3, or 4 in analog mode. Refer 
to the Glossary on page 51 for UCT field descriptions. 

1 Based on the input channel the input device is connected to, click Ch1, Ch2, 
Ch3, or Ch4 to display the channel configuration window (Figure 3-6). 

Figure 3-6.  Example of Channel 2 (Ch2) Analog Settings

2 Click Enable and Analog to enable the channel for service and analog 
mode. 

3 Click +/– 5V or +/– 100V if the input device has a voltage output of ±5VDC 
or ±100VDC, respectively. 

4 Type the unit of measurement used by the input device in the Engineering 
Units (on transducer) field. 

5 Scale the input channel and input device as follows: 

a Type the minimum and maximum voltage level supported by the 
input channel in the top and bottom fields of Raw voltage values (on 
unit input), respectively. 

For example, to set up the input channel for AC amps, type 0 in the top 
text box and 5 in the bottom text box.
Configuration 39



RM4012 Installation and Configuration Guide
b Type the minimum and maximum voltage levels supported by the 
input device in the top and bottom fields of Engineering Units (on 
transducer), respectively. 

For example, to set up the input channel for pipe-to-soil readings, type 
0 in the top text box and the maximum amps from the transducer to CT 
in the bottom text box.

6 If you want to apply an optional response filter to the input channel, click 
the Response Filter Time button and select a time option. 

7 If you want the unit to transmit an alarm packet when a low alarm 
condition occurs, click Transmit Low Alarm and then type a value in the 
Low Alarm field. 

The unit transmits an alarm packet when the input channel reading is 
lower than the value entered in the Low Alarm field. 

8 If you want the unit to continue transmitting low alarms until the alarm 
condition is removed in the field, click Repeat Low Alarm and then type a 
value in the Repeat delay in minutes field. 

The Repeat delay in minutes value is the number of minutes between 
repeated alarm transmissions for both low and high alarm conditions. 

9 If you want the unit to transmit an alarm packet when a high alarm 
condition occurs, click Transmit High Alarm and then type a value in the 
High Alarm field. 

The unit transmits an alarm packet when the input channel reading is 
higher than the value entered in the High Alarm field. 

10 If you want to include deadband in low and/or high alarms, type a value 
in the low and/or high alarm Deadband fields.

Valid entries are any positive scaled value that does not cause the alarm 
point to be lower than the minimum scale value or higher than the 
maximum scale value in Engineering Units (on transducer). Entering zero 
disables deadband.

11 If you want to apply a persistence filter to low and/or high alarms, type a 
value in the Persistence field. Valid entries are any number from 1 to 
65535. Entering zero (0) disables persistence.

12 Click Validate/Check Entries to verify configuration settings are correct 
and then click Save. 
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Text boxes display green or red to indicate whether or not an entered value 
is correct. If a text box is red, enter a different value and then validate 
again. If all text boxes are green, settings are correct. 

Set Up an Input Channel for Digital Readings 
Complete the following steps to set up channel 5 or 6 in either Digital Dry Contact 
or Active Digital mode. Refer to the Glossary on page 51 for UCT field 
descriptions.

NOTE: For the RM4012 units, digital channels are not typically used for the AC 
application.

1 Based on the input channel the input device is connected to, click Ch5 or 
Ch6 to display the channel configuration window (Figure 3-7). 

Figure 3-7.  Example of Channel 5 (Ch5) Digital Settings

2 Click Enable to enable the channel for service. 

3 Click Active Digital or Digital Dry Contact. 
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4 If you want to include an optional Debounce filter in alarm settings, type 
the number of seconds the input channel must remain in an alarm state 
before the unit transmits an alarm packet. If you want alarm states 
recognized immediately, enter zero (0) in the field. 

5 If the channel is set up in Active Digital mode, complete the following 
steps to set up channel alarms:

a Click Transmit Low Alarm to have an alarm transmitted when the 
input voltage is lower than the threshold value. 

b Click Transmit High Alarm to have an alarm transmitted when the 
input voltage is higher than the threshold value. 

c Click Repeat Low Alarm and/or Repeat High Alarm if you want the 
unit to continue transmitting alarms until the alarm condition is 
removed in the field. 

Type a value in the Repeat delay in minutes field that indicates the 
number of minutes between repeated alarm transmissions. 

6 If the channel is set up in Digital Dry Contact mode, complete the 
following steps to set up channel alarms:

a Click Transmit Closed Alarm to have an alarm transmitted when the 
input device is in a closed state. 

b Click Transmit Open Alarm to have an alarm transmitted when the 
input device is in a open state. 

c Click Repeat Closed Alarm and/or Repeat Open Alarm if you want 
the unit to continue transmitting alarms until the alarm condition is 
removed in the field. 

Type a value in the Repeat delay in minutes field that indicates the 
number of minutes between repeated alarm transmissions. 

7 Click Validate/Check Entries to verify configuration settings are correct 
and then click Save. 

Text boxes display green or red to indicate whether or not an entered value 
is correct. If a text box is red, enter a different value and then validate 
again. If all text boxes are green, settings are correct. 
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Save Settings in the Event Log
To save configuration settings, click File > Save Current Setup in Event Log.

NOTE: The Event Log is used later when setting up the unit on the BAT website. 
The file saves on your hard drive in the same folder as the UCT software. The 
UCT software automatically assigns a file name using the unit serial number with 
a .bhs extension. 

Transmit a Test Packet
To transmit a test packet, click Transmit in Communication Settings.

Status messages display in the window beside the Transmit button. When the 
status message Acknowledgement received from server appears, communication 
has been established.

IMPORTANT: If the status message Test Packet Return Transmission Failed 
appears, communication has not been established with the server. Click Transmit 
again to send another test packet. If communication cannot be established after 
several attempts, please call Technical Support for assistance.
Configuration 43



RM4012 Installation and Configuration Guide
Save Settings in a Template
Settings can be saved as a template that can be used to set up another unit of the 
same type.

Complete the following steps to save the settings to a template:

1 Click Tools > Advanced > Template > Save to Template to display the Save 
Template window. 

2 Open an existing folder or create a new folder to store the template. 

3 If you want to change the default file name of the template, type a name for 
the template in the File name field making sure to use the .bht file 
extension. 

4 Click Save when you finish. 

Exit UCT and Close the Enclosure
Complete the following steps to:

1 Click File > Exit or press Alt+F4.

2 Disconnect the configuration cable from the unit and your computer.

3 Close and latch the enclosure door.

4 Tighten water-tight fittings on the bottom of the enclosure.

5 Re-enable any synchronization software disabled earlier in this chapter. 

The installation and configuration are now complete.
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A
Optional Selectable Current 
Transducer Installation

The information in this section explains how to install the optional Selectable 
Current Transducer on an existing Polarized Cell Replacement (PCR) and how to 
connect the transducer to an installed RM4012. Refer to the previous chapters for 
the procedures for installing and configuring the RM4012. 

Figure A-1.  Selectable Current Transducer
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Complete the following steps: 

1 Clamp the Selectable Current Transducer (SCT) to the wires running from 
the PCR (an example installation is shown in Figure A-2). 

Figure A-2.  Selectable Current Transducer - Installed

2 Select the setting on the SCT selector switch (Figure A-3) to above the 
current maximum output on the PCR. For example, if the maximum PCR 
current is 55 amps, set the SCT selector switch to 60.

Figure A-3.  Selectable Current Transducer - Selector Switch
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3 Run the SCT wires to the RM4012 and through the larger of the two water-
tight fittings towards the terminal block marked PCR AC AMPS (CH1) 
(refer to Figure 2-1 on page 12 for location of fitting and terminal block 
location).

4 Connect wires to the terminal block marked PCR AC AMPS (CH1).

5 If needed, refer to Chapter 3 - Configuration on page 31 for information on 
using the Universal Configuration Toolkit to configure the RM4012 unit.
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B 
Regulatory Notices

FCC Requirements
The following FCC requirements are met by the products described in this guide.

This equipment has been tested and found to comply with the limits for a Class B 
digital device, pursuant to part 15 of the FCC Rules. These limits are designed to 
provide reasonable protection against harmful interference in a residential 
installation. This equipment generates, uses, and can radiate radio frequency 
energy and, if not installed and used in accordance with the instructions, may 
cause harmful interference to radio communications. However, there is no 
guarantee that interference will not occur in a particular installation. If this 
equipment does cause harmful interference to radio or television reception, which 
can be determined by turning the equipment off and on, the user is encouraged to 
try to correct the interference by one or more of the following measures:

 Reorient or relocate the receiving antenna.

 Increase the separation between the equipment and receiver.

 Connect the equipment in an outlet on a circuit different from that to 
which the receiver is connected.

 Consult the dealer or an experienced radio/TV technician for help.
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Export Control Classification Number
The Export Control Classification Number (ECCN) assigned to the Bullhorn 
Universal Configuration Toolkit (UCT) software by the U.S. Bureau of Industry 
and Security (BIS) is as follows:

 ECCN Classification: No Classification

 ECCN Code: EAR99 or NLR
50 Regulatory Notices



C 
Glossary

The following information is an alphabetical list of technical terms and UCT 
software fields identified in this manual. 

 

Table C-1.  Glossary 

Term Definition

Controller Clock Time-of-day clock running inside the unit. The clock is 
used for all time-related operations such as transmission 
schedules.

Controller Rev Firmware version of the controller board installed in the 
unit. 

Current Density The measure of the density of flow of a conserved 
charge.

Deadband Deadband applies hysteresis to low and high alarm 
values; it is an area of equal value above and below the 
alarm values. When the input voltage passes below the 
deadband area, this is the alarm point that triggers a low 
alarm transmission. Likewise, when the input voltage 
passes above the deadband area, this is the alarm point 
that triggers a high alarm transmission. 

Debounce filter Debounce is an optional filter that applies to alarms. The 
filter uses the entered value as the number of seconds an 
input channel must remain in an alarm state before the 
unit transmits an alarm. The purpose of the filter is to 
prevent short spurious noise pulses from triggering an 
alarm. If the input channel goes out of alarm during the 
polling cycle, the unit resets and does not transmit an 
alarm. When Debounce is set to zero (0), no filter is 
applied and the alarm state is recognized immediately. 

HI, HI Rpt, LO, LO Rpt Abbreviations for alarm labels high, high repeat, low, 
and low repeat respectively. 

IMEI International Mobile Equipment Identity. Unique 
number assigned to the digital cellular radio by the 
manufacturer for identification purposes. 
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LED Light Emitting Diode. Status indicator. 

Persistence Persistence is the number of samples an input channel 
must complete while in a particular state before that 
state is recognized as an alarm. 

For example, if an input channel is set up with a high 
alarm and a persistence value of 5, the input channel 
must complete 6 samples in a high state before it is 
recognized as a high alarm. 

PCR Polarization Cell Replacement. A solid-state device 
designed to simultaneously provide DC decoupling and 
AC continuity/grounding when used with cathodically 
protected structures, such as pipelines, tanks, grounding 
systems, and cable casings. 

P/S Pipe to Soil (or Pipe to Structure).

Radio ISN Radio Identification Serial Number. The SkyWave 
satellite terminal and Bullhorn unit ship from the factory 
as a matching pair. Both are assigned the same ISN by 
AI for identification purposes. Also see Unit ISN. 

Radio Version Version number assigned to an analog cellular radio by 
the manufacturer. The UCT software displays  
“n/a” (not applicable, not available) for digital cellular 
and satellite unit types. 

Response Filter Time Optional filter for input channels set up in analog mode. 
The response filter slows the unit’s response to sudden 
changes in the input signal. The purpose of the filter is to 
help eliminate false alarm transmissions in unstable 
environments that have a tendency to produce 
temporary noise

Input channels include hardware filters suitable for 
rectifier outputs such as those used in line-powered CP 
systems. Response Filter Time applies a response time to 
the input channel in addition to a hardware filter 
response. Actual response time may vary based on 
variables such as the current input voltage level and 
position of the unit’s polling cycle. 

Table C-1.  Glossary (continued)

Term Definition
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RSSI Receive Signal Strength Indicator. RSSI value and green 
or red status bar are static indicators of the last RSSI 
reading. Clicking Auto Update forces the UCT to 
display a “live” RSSI reading. The RSSI value should 
meet the following qualifications:

RM4012 units use an RSSI scale of 0.00dB to 50.00dB. 
RSSI of 14dB and higher indicates a strong signal; levels 
below 14dB indicate no satellite communication. 

Serial No. Unique serial number assigned to the unit at the factory 
for identification purposes. 

SIM Subscriber Identity Module. Unique identification 
number assigned to the digital cellular radio by the 
service provider. 

Status Indicators, UCT UCT software includes the following three (3) status 
indicators in the bottom, right hand side of the main 
configuration screen:

 Green/red indicator: Green indicator remains lit 
when running UCT. After transmitting a test packet, 
green indicator begins flashing. Green indicator 
changes to a flashing red indicator when 
communication cannot be established with the 
network. 

 Yellow indicator: Flashes when unit transmits data. 

 Black indicator: Not currently used. 

Transmission Schedule Scheduled data transmission at regular time intervals. 

Transmit Click the Transmit button to force the unit to send a test 
packet for communications testing. Status messages 
display beside the button to describe the process, such as 
Test Packet Status, Preparing, and Sending test packet. 

Transmit Retries Number of times the unit resends a data or alarm packet 
when an acknowledgment is not received from the 
communication network. 

UCT Universal Configuration Toolkit. Software program 
used to configure a unit for service and view status 
information such as channel measurements, battery 
voltage level, and RSSI. 

Unit ISN Unit Identification Serial Number. The Bullhorn unit 
and SkyWave satellite terminal ship from the factory as 
a matching pair. Both are assigned the same ISN by AI 
for identification purposes. Also see Radio ISN. 

Table C-1.  Glossary (continued)

Term Definition
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Update/Auto Update Click Update to display a current reading for all input 
channels. Click Auto Update to automatically display a 
current reading every 16 seconds. 

USB Universal Serial Bus. Communication protocol used by a 
computer for communications with an externally 
connected device. 

Table C-1.  Glossary (continued)

Term Definition
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Installation site qualifications   14

L
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Main configuration window (UCT)
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Universal Configuration Toolkit. See 
UCT software

Update
auto update   53

USB   54

USB Config port   12

USB driver
installing   7

W
Wiring diagram

transducers   14
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