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Chapter 1: Getting Started
This guide explains how to install and configure Bullhorn RM3000 Series units, including the 
RM3011, RM3012, and RM3250, for service. This guide includes instructions for installing and 
configuring units, optional equipment that is available to be installed with select units, technical 
specifications for different unit types, and other related information.      

This chapter includes the following topics:

 l RM3011 Unit Overview on page 1

 l RM3012 Unit Overview on page 2

 l RM3250 Unit Overview  on page 3

 l Bullhorn System Overview on page 5

 l Installing Conduit on page 5

 l Required Tools and Equipment on page 6

 l Required Hardware and Software on page 6

 l Safety and Equipment Symbols on page 7

 l Electrostatic Discharge on page 8

 l Bullhorn Information Line on page 9

 l Technical Services on page 9

RM3011 Unit Overview
The RM3011 is capable of collecting and reporting register readings for equipment located in 
remote areas, including compressors and electronic flow meters (EFMs). Additional functionality 
includes items in the following list: 

 l Reads shutdown codes, hour meter, and rpms on compressor annunciators. Also reads suction 
and discharge pressures if measured through the annunciator.

 l Reads alarm conditions or shutdown codes without using a digital dry contact by polling the 
annunciator and looking for changes in the shutdown codes.
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 l The RM3011 transmits data using the SkyWave-Inmarsat satellite network. To view a SkyWave-
Immarsat satellite coverage map,  visit the SkyWave-Immarsat website at 
http://www.inmarsat.com.

 l The RM3011 collects and transmits register readings for equipment located in remote areas 
(such as compressors) to your account on Bullhorn Web. 

 l Registers: supports up to sixteen 6-digit registers, eight 12-digit registers, or a combination 
of both. 

 l DTR output: supports an optional DTR output (data terminal ready) for devices that require a 
handshake signal from the RM3011. 

 l Alarm input: supports an optional alarm input for devices that support an alarm output. 

NOTE: The RM3011 transmits data using the SkyWave-Inmarsat satellite network. To view a 
SkyWave-Immarsat satellite coverage map, visit the SkyWave-Immarsat website at 
http://www.inmarsat.com.       

IMPORTANT: To ensure consistent communication with the satellite, the enclosure must be 
pointing in the direction of the satellite with no obstructions between the two, such as buildings, 
trees, or hills.       

RM3012 Unit Overview
The BullhornRM3012 remote monitoring units accurately, regularly, and reliably calculate gas or 
liquid volume by measuring the digital pulse output or querying MODBUS or Mercury registers via 
RS232 from a positive displacement (PD), gas, or lease automatic custody transfer meter (LACT). 
Meter readings are automatically uploaded via cellular communications to Bullhorn Web, where they 
can be used to calculate the volume of gas delivered to customers, optimize the system, and/or 
populate a gas measurement database. The RM3012 is a fully-integrated unit that is easily installed. 
All components, including the antenna, are internal. This design makes it easier to transport, install, 
and maintain. The RM3012 can be installed either as a stand alone device, installed with an attached 
index, or installed on an existing index using an adapter.     

The RM3012 is housed in a NEMA-rated weatherproof enclosure that measures 7" x 5" x 5". The unit 
transmits data to Bullhorn Web using the SkyWave-Inmarsat satellite network and includes the 
following product specifications:     

 l Data collection: collects and transmits register readings for equipment located in remote 
areas (such as compressors).         

https://www.bullhornsys.com/
https://www.bullhornsys.com/
https://www.bullhornsys.com/
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 l Registers: supports up to sixteen 6-digit registers, eight 12-digit registers, or a combination 
of both.         

 l DTR output: supports an optional DTR output (data terminal ready) for devices that require a 
handshake signal from the RM3012.         

 l Alarm input: supports an optional alarm input for devices that support an alarm output.         

 l Reads shutdown codes, hour meter, and rpms on compressor annunciators. Also reads suction 
and discharge pressures if measured through the annunciator.         

 l Includes a backup battery in case of power loss from the compressor. The backup battery 
allows the unit to continue to monitor the compressor as well as to send alarms until the 
battery is drained. These alarms include when power is lost and when it is restored. For more 
information on the backup battery, including how to replace it, refer to Battery Replacement.         

 l An LED light, located below the power switch, indicates when messages are being sent or if 
the unit is low on power. During normal operation, the LED light remains on. However, the LED 
flashes on and off if the unit is idle, sending messages, or if the battery power is low.         

NOTE: The RM3012 transmits data using the SkyWave-Inmarsat satellite network. To view a 
SkyWave-Immarsat satellite coverage map, visit the SkyWave-Immarsat website at 
http://www.inmarsat.com.       

IMPORTANT: To ensure consistent communication with the satellite, the enclosure must be 
pointing in the direction of the satellite with no obstructions between the two, such as buildings, 
trees, or hills.       

RM3250 Unit Overview 
The RM3250 is housed in a weatherproof enclosure that can be easily installed and configured.  The 
RM3250 is designed primarily for metering applications and supports two-way communication with 
Bullhorn Web through a GSM cellular network. 
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Figure 1-1.   RM3250 Enclosure     

The        RM3250 unit automatically read meters to accumulate and report pulse counts. The unit utilize 
cellular networks for two-way communication with Bullhorn Web, a cloud-based asset manager 
where readings can be monitored. Reports and extracts are also available through the Bullhorn Web 
account to view the data from the units.     

The RM3250 is a fully-integrated unit that can be mounted alone or on top of a meter. The RM3250 
supports Modbus RTU protocols. All components, including the antenna, are internal to make it 
easier to transport, install, and maintain.     

The RM3250 supports 10 registers and 1 digital contact closure/accumulator input. The RM3250 
inputs can be measured and configured locally using the Bullhorn Tools software on a laptop, using 
a Bluetooth connection. Bullhorn Tools software is available for download from the Bullhorn Tools 
launch page. Refer to RM3250 Technical Specifications on page 94 for more details on the inputs.     

The input connections and battery placement for the RM3250: 

https://www.bullhornsys.com/
http://install.bullhornsys.com/BullhornTools/
http://install.bullhornsys.com/BullhornTools/
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Figure 1-2.   RM3250 Inputs and Batteries 

NOTE: The battery is the only field-serviceable item in the RM3250.       

After installation, the RM3250 can be configured with the Bullhorn Tools configuration software on a 
laptop, using a Bluetooth connection. Bullhorn Tools can display reading, set up transmission 
schedules, set alarms, send a test message, or send an email to Technical Services. Refer to 
Configuring the RM3250 with Bullhorn Tools Software on page 74 for more information on using 
Bullhorn Tools.     

NOTE: Because of the variations in customer's installation and grounding methods, AI cannot 
warranty any damage to equipment caused by lightning strikes.       

Bullhorn System Overview
Bullhorn is a wireless telemetry system that provides scheduled and by-exception inbound reporting 
for field equipment typically located in remote areas. Data and alarm packets transmit from remote 
field locations to your account on the secure Bullhorn Web using digital cellular or satellite 
communication networks. You can quickly determine the status of field equipment anytime using 
information that posts to your website account.     

The Bullhorn system provides remote monitoring with full coverage using GSM cellular network, 
GEOS satellite (SkyWave-Inmarsat), or LEOS satellite (ORBCOMM) communication networks.     

Installing Conduit
If a remote monitoring unit is installed outside the rectifier, or if wires are to be buried or covered, 

https://www.bullhornsys.com/
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ensure that conduit is used to protect the wiring from physical damage, electrical interference, or 
weather. 

The conduit should not be greater than 1/2" in diameter. Conduit is provided by the customer.     

Required Tools and Equipment
The following tools and equipment are required for installing and configuring the unit for service:

 l anti-static wrist strap

 l magnet         

 l small slotted screwdriver

 l small Phillips head screwdriver

 l wire stripper

 l wire cutter

 l voltmeter

 l adjustable wrench

 l socket or open end wrench set

 l compass

 l waterproof sealing tape

 l 1/2” wide Teflon tape

 l configuration cable (provided in installation kit; standard mini USB cable typically used with 
most digital cameras)

 l Optional: mounting hardware (appropriate type for mounting surface; supplied by customer)

 l Optional: appropriate tools for preparing the mounting surface for installation (such as a hand 
drill and metal, masonry, or wood drilling bit)

Required Hardware and Software
To configure an RM3000 Series unit in the field using a laptop computer or mobile device, you will 
need the following hardware and software specifications:     
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 l Pentium processor or equivalent with USB port         

 l 2 GB RAM (minimum)         

 l 400 MB free hard drive space 

 l Spare USB port         

 l Microsoft Windows operating system — Windows 10; XP with Service Pack 2 or 3; Vista Home 
Premium, Business, or Ultimate with Service Pack 1 or higher; or Windows 7 Home Premium, 
Professional, or Ultimate        

 l For the RM3011 and RM3012 configuration:

 — Universal Configuration Toolkit software (provided in the installation kit) 

 — Windows .NET Framework version 4.0 or higher (provided in installation kit) 

 — USB device driver (provided in the installation kit)  

 — Windows Internet Explorer version 8.0 or higher

 — Adobe Reader version 5.0 or higher        

 l For the RM3250  configuration: 

 — smartphone or tablet (with Bluetooth), running either iOS 8 or Android 7

 — Bullhorn Tools (available from Bullhorn Tools launch page) or Bullhorn Tools Mobile 
(available from Apple App Store or Google Play)

Safety and Equipment Symbols

WARNING: If a Bullhorn remote monitoring unit is used in a manner not specified by AI, the 
protection provided for the equipment may be impaired.       

The following table provides a description of various safety and equipment symbols. Safety symbols 
alert you to safety hazards or conditions that have the potential to cause personal injury, death, or 
equipment damage. Equipment symbols may indicate a functional state (such as on and off) and 
connections (such as a Earth ground terminal).     

http://install.bullhornsys.com/BullhornTools/
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Symbol             Description             
 

 

Caution — Failure to observe this warning may result in personal injury, death, 
or equipment damage. A potential risk exists if the installation instructions are 
not followed.             

  Warning — Risk of electrical shock. Failure to observe this warning may result 
in personal injury, death, or equipment damage. A potential risk exists if the 
installation instructions are not followed.             

 

 

Earth (ground) terminal — Indicates a protective earth ground connection is 
required.             

 

 

On (Supply) — Indicates power is on when the toggle switch is in the "ON" 
position.             

 

 

Off (Supply) — Indicates power is off when the toggle switch is in the "OFF" 
position.             

 

 

DC power — Indicates that the input requires DC power.             

 

 

AC/DC — Both direct and alternating current.             

 

 

Positive — Indicates a positive input.             

Negative — Indicates a negative input.             

Table 1-1.  Safety and Equipment Symbols       

Electrostatic Discharge
Electrostatic Discharge (ESD) can damage electronic components. To prevent ESD damage when 
handling electronic equipment, always wear an anti-static wrist strap attached to an unpainted, 
grounded metal object. Ensure the wrist strap has maximum contact with bare skin. If an anti-static 
wrist strap is available, discharge static electricity from yourself and your clothing by touching a 
grounded metal object before handling electronic equipment.     
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Bullhorn Information Line
The Bullhorn Information Line is an automated attendant telephone system. It is typically used when 
installing units in the field. The system identifies when the last data transmission (or test packet) was 
received on your website account for a unit you specify.     

Complete the following steps to use the Bullhorn Information Line:     

 1. Call the Bullhorn Information Line at 866-287-6739.

 2. Press 1 to access the packet log when prompted.         

 3. Use your telephone keypad to enter the unit serial number when prompted. The unit serial 
number is included on the bar code label on the unit. It is also included on the label of the 
shipping carton. If required, repeat this step to check another unit.         

Technical Services
AI Technical Support is available to provide assistance with Bullhorn Remote Monitoring Units, 
accept feedback about Bullhorn Remote Monitoring Units, or discuss your organization’s training 
needs. Use the following information to contact AI Technical Support:

Telephone:

1-800-229-3404

Email:

techservices@aiworldwide.com

Address:

American Innovations, Ltd.
Attn: AI Technical Support
12211 Technology Blvd.
Austin, TX 78727

mailto:techservices@aiworldwide.com?subject=AI Technical Support
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Chapter 2: RM3011 Installation
The RM3011 is housed in a NEMA-rated weatherproof enclosure that includes four magnets for 
quickly attaching the unit to a metal surface. The unit can also be mounted on a pole using 
additional hardware. 

NOTE: To ensure consistent communication with the satellite, the enclosure must be pointing in 
the direction of the satellite with no obstructions between the two, such as buildings, trees, or hills.

This chapter includes the following topics:

 l Preparing to Install the RM3011 on page 10

 l Mounting the RM3011 on page 11

 l Installing the RM3011 on page 11

 l Connecting Devices to the RM3011 on page 11

Preparing to Install the RM3011
Use the following items as a checklist prior to installing the RM3011:     

 l Is the latest version of the UCT software installed on the computer you plan to use during the 
installation? For more information, refer to Installing the UCT and Support Files on page 31.        

 l To ensure uninterrupted service, the location you plan to install the satellite terminal must 
meet the following qualifications:         

 — The area must be clear of all obstructions such as buildings, trees, and hills.               

 — The satellite terminal must have a clear line-of sight pointing in the same direction as 
the satellite. To ensure consistent communication with the satellite, use the UCT 
software to determine which direction to point the satellite terminal.               

NOTE: Because of the variations in customer's installation and grounding methods, AI cannot 
warranty any damage to equipment caused by lightning strikes.       
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Mounting the RM3011
The RM3011 enclosure is shipped with four mounting magnets. The enclosure is typically mounted 
on top of the compressor, with the enclosure sitting face-up. The enclosure can also be mounted to 
the side of the compressor.

Figure 2-1.   RM3011 Enclosure (Bottom) with Magnetic Mounts

Optionally, the enclosure can be mounted on a pole with additional hardware. Please contact 
Technical Services for ordering and installation information.

Installing the RM3011
The following steps provide an overview of a typical installation and set up for an RM3011.      

 1. Mount the RM3011 enclosure using the mounting magnets or alternative mounting hardware.

 2. Connect devices to the unit. Refer to Connecting Devices to the RM3011 on page 11  for details.      

 3. Start Universal Configuration Toolkit   software and configure the RM3011 for service.        

Connecting Devices to the RM3011

NOTE: To ensure a clean, stable reading, keep field wiring as short as possible and use shielded 
twisted pair wire such as Alpha 2463C.       

The RM3011 is connected to the oil sensor switch, annunciator, and a DC power source with the 
circular 9-pin cable assembly, which is shipped with the unit.     
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Figure 2-1.   Circular 9-Pin Cable Assembly     

The cable assembly is labeled with wiring descriptions to help with the installation of the oil sensor 
switch, annunciator, and DC power.     

Front Panel Pin             Wire Color             Description             
3             Orange             -Alarm/GND             
4             Blue             +Alarm             
5             Brown             Gnd (ground)             
1             White             TxD             
2             Green             RxD             
8             Black             -Vin (voltage in)             
9             Red             +Vin (voltage in)             

Table 2-1.  Circular 9-Pin Cable Assembly Wiring       

Complete the following steps to connect the devices to the RM3011:     

 1. Splice the oil line into the compression tee. Secure the line by tightening the end bolts.         

Figure 2-2.   Compression Tee         
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 2. Wrap Teflon tape around the oil sensor threads.         

 3. Attach the oil sensor switch to the compression tee.         

Figure 2-3.   Oil Pressure Sensor Switch         

 4. If needed, connect spade lugs to the alarm wires (blue/orange) for connection to the oil 
sensor switch terminals.         

 5. Connect alarm wires to the oil sensor switch terminals.         

 6. If applicable, connect the receive/transmit/ground wires (white/green/brown) to annunciator.         

 7. For Altronic annunciators, connect the receive/transmit/ground wires to the screw terminals of 
the DB-9 adapter, using the following connections:         

 a. Connect green wire to wire terminal marked RXD (2).               

 b. Connect white wire to the screw terminal marked TXD (3).               

 c. Connect ground (brown) wire to the screw terminal marked GND (5).               
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Figure 2-4.   Annunciator DB-9 Adapter         

 8. Connect voltage wires (black = negative; red = positive) to DC source on compressor (requires 
12-36Vdc input).         
Connect the voltage wires from the 9-pin cable assembly to the non-switched side of the 
power strip of the compressor or to a continuous power source. This will ensure that power to 
the RM3011 is not interrupted if the compressor shuts down.         

 9. Line up notch on the circular 9-pin connector to the 9-pin connector on the RM3011. Secure 
connector by tightening coupling ring until it clicks in place.         

Figure 2-5.   RM3011 9-Pin Connector and USB Port         

Continue with RM3011 Configuration on page 34 to configure the RM3011 for service.         
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Chapter 3: RM3012 Installation
The RM3012 is housed in a NEMA-rated weatherproof enclosure that includes four magnets for 
quickly attaching the unit to a metal surface. The unit can also be mounted on a pole using 
additional hardware. 

NOTE: To ensure consistent communication with the satellite, the enclosure must be pointing in 
the direction of the satellite with no obstructions between the two, such as buildings, trees, or hills.

This chapter includes the following topics:

 l Preparing to Install the RM3012 on page 15

 l Mounting the RM3012 on page 16

 l Installing the RM3012    on page 16

 l Connecting Devices to the RM3012 on page 16

Preparing to Install the RM3012
Use the following items as a checklist prior to installing the RM3012:     

 l Is the latest version of the UCT software installed on the computer you plan to use during the 
installation? For more information, refer to Installing the UCT and Support Files on page 31.        

 l To ensure uninterrupted service, the location you plan to install the satellite terminal must 
meet the following qualifications:         

 — The area must be clear of all obstructions such as buildings, trees, and hills.               

 — The satellite terminal must have a clear line-of sight pointing in the same direction as 
the satellite. To ensure consistent communication with the satellite, use the UCT 
software to determine which direction to point the satellite terminal.               

NOTE: Because of the variations in customer's installation and grounding methods, AI cannot 
warranty any damage to equipment caused by lightning strikes.       
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Mounting the RM3012
The RM3012 enclosure is shipped with four mounting magnets. The enclosure is typically mounted 
on top of the compressor, with the enclosure sitting face-up. The enclosure can also be mounted to 
the side of the compressor or other metal surface. 

Figure 3-1.   RM3012 Enclosure (Bottom) with Magnetic Mounts     

NOTE: Optionally, the enclosure can be mounted on a pole with additional hardware. Please 
contact Technical Services for ordering and installation information.       

Installing the RM3012   
The following steps provide an overview of a typical installation and set up for an RM3012.      

 1. Mount the RM3012 enclosure using the mounting magnets or alternative mounting hardware.

 2. Connect devices to the unit. Refer to Connecting Devices to the RM3012 on page 16  for details.      

 3. Start Universal Configuration Toolkit   software and configure the RM3012 for service.        

Connecting Devices to the RM3012

NOTE: To ensure a clean, stable reading, keep field wiring as short as possible and use shielded 
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twisted pair wire such as Alpha 2463C.       

The RM3012 is connected to the oil sensor switch, annunciator, and a DC power source with the 
circular 9-pin cable assembly, which is shipped with the unit. The cable assembly is 20 feet long.     

Figure 3-1.   Circular 9-Pin Cable Assembly     

The cable assembly is labeled with wiring descriptions to help with the installation of the oil sensor 
switch, annunciator, and DC power.     

Front Panel Pin             Wire Color             Description             
3             Orange             -Alarm/GND             
4             Blue             +Alarm             
5             Brown             Gnd (ground)             
1             White             TxD             
2             Green             RxD             
8             Black             -Vin (voltage in)             
9             Red             +Vin (voltage in)             

Table 3-1.  Circular 9-Pin Cable Assembly Wiring       
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Complete the following steps to connect the devices to the RM3012:     

 1. Splice the compressor oil line into the compression tee. Secure the line by tightening the end 
compression fittings.         

Figure 3-2.   Compression Tee         

 2. Wrap Teflon tape around the oil sensor threads.         

 3. Attach the oil pressure sensor switch to the compression tee.         

Figure 3-3.   Oil Pressure Sensor Switch         

 4. If needed, connect spade lugs to the alarm wires (blue/orange) for connection to the oil 
pressure sensor switch terminals.         

 5. Connect alarm wires to the oil pressure sensor switch terminals.         

 6. If applicable, connect the receive/transmit/ground wires (white/green/brown) to annunciator.         

 7. For Altronic annunciators, connect the receive/transmit/ground wires to the screw terminals of 
the DB-9 adapter, using the following connections:         

 a. Connect green wire to wire terminal marked RXD (2).               

 b. Connect white wire to the screw terminal marked TXD (3).               

 c. Connect ground (brown) wire to the screw terminal marked GND (5).               
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Figure 3-4.   Annunciator DB-9 Adapter               

 8. Connect voltage wires (black = negative; red = positive) to DC source on compressor (requires 
12-36Vdc input).         
Connect the voltage wires from the 9-pin cable assembly to the non-switched side of the 
power strip of the compressor or to a continuous power source. A backup battery will provide 
temporary power to the RM3012 if the compressor or other power source shuts down.         

 9. Line up notch on the circular 9-pin connector to the 9-pin connector on the RM3012. Secure 
connector by tightening the wing nut ring until it clicks in place. The RM3012 powers on as 
soon as a connection is made with the connector pins.         

Figure 3-5.   RM3012 Front Panel Features         

The LED light located below the 9-pin connector will begin to flash on and off if you do not 
connect and power on an external DC power source to the RM3012. The RM3012 will use the 
internal battery, and the LED will continue to flash (except when transmitting when the light 
remains on), until a DC power source is supplied. Refer to Battery Replacement on page 91 for 
instruction on how to replace the internal backup battery.         

Continue with RM3012 Configuration on page 53 to configure the RM3012 for service.     



4

RM3000 Series 20

Chapter 4: RM3250 Installation
The RM3250 is typically installed on a flat base and connected to an index or other pulse device. 
Alternate mounting options and accessories are available for purchase. Contact the American 
Innovations Sales team at sales@aiworldwide.com.    

For technical details on the input ratings, accessories, and part numbers, refer to RM3250 Technical 
Specifications on page 94.    

IMPORTANT: If the RM3250 is used in a manner not specified by American Innovations, the 
protection provided by the equipment may be impaired.

This chapter includes the following topics:

 l Pre-installation Notes on page 20

 l Preparing to Install the RM3250 on page 21

 l RM3250 Enclosure Dimensions on page 21

 l Installing the RM3250 on page 22

 l Testing Satellite Reception on page 27

 l RM3250 Maintenance on page 28

Pre-installation Notes
Before you install an RM3250, use the following information as a checklist to ensure a successful 
installation:     

Power Disconnect and Branch Circuit Protection — A customer-supplied, power disconnect 
device is required for the unit installation. The power disconnect device (such as a switch, main 
circuit breaker, or other type of power disconnect) should provide an easy and accessible means for 
removing the main input supply power source from the unit. Multiple-pole circuit breakers shall 
interrupt all neutral and ungrounded connectors of mains supply simultaneously. The power 
disconnect device must be clearly marked to identify it as the disconnect device for the unit. The 
power disconnect or separate overcurrent protection device should also provide overcurrent 
protection in the form of a 20 amp fuse or circuit breaker suitable for branch circuit protection per 
local codes and requirements.     

mailto:sales@aiworldwide.com
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Backup Battery — Please contact Sales for information about purchasing a replacement battery 
(American Innovations part number 517206-000).     

Wiring Requirements — For optimum protection from transient voltages, all analog inputs must be 
in their own multi-conductor jacket cable (such as cable AI part number 211061-000 - Belden 
5308UE, or its equivalent). All cables must have intact outer jackets, except for end cuts. Do not 
remove cable jackets as they protect the unit input cable from transient voltages. Cable insulation 
should be suited for voltage range of inputs. Cables should be rated at a minimum of 600 V and 
105° C.     

Input Channel Voltage Levels — All input channels are marked with acceptable input voltage 
ranges. Ensure that devices connected to the RM3250 units fall within the voltages ranges listed next 
to the channel input connections.     

Mounting the Enclosure — Choose an area that provides enough room to easily access the unit or 
to perform routine maintenance after completing the installation.     

Preparing to Install the RM3250

WARNING: Only accessories that meet American Innovations specifications may be used with the 
RM3250. Refer to RM3250 Technical Specifications on page 94 for a list of approved accessories.       

Use the following items as a checklist prior to installing the RM3250:     

 1. For information regarding safety symbols found on the unit, refer to Safety and Equipment 
Symbols on page 7.         

 2. Ensure that the latest version of Bullhorn Tools or Bullhorn Tools Mobile is installed on the 
computer or mobile device that you plan to use to configure the unit. Bullhorn Tools can be 
downloaded from the Bullhorn Tools launch page. For more information, refer to RM3250 
Configuration on page 73.         

RM3250 Enclosure Dimensions
The RM3250 is designed for easy installation and configuration. The unit is housed in a dome 
enclosure and fits onto a customized base. The dimensions of the unit dome enclosure are shown 
below.     

mailto:sales@aiworldwide.com?subject=Replacement Battery
http://install.bullhornsys.com/BullhornTools/
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Figure 4-1.   RM3250 Enclosure Dimensions     

Before installing the unit, ensure that the area around the installation site provides enough working 
space to easily access the unit to wire inputs, configure the unit for service, or perform routine 
maintenance.     

Installing the RM3250

IMPORTANT: Electrostatic Discharge (ESD) can damage electronic components. Provide ESD 
protection by wearing an anti-static wrist strap attached to any unpainted metal surface before 
accessing the unit or handling electronic parts. If an anti-static wrist strap is unavailable, discharge 
static electricity from yourself and your clothing by touching a nearby metal surface before 
accessing the unit or handling electronic components.       

The following section explains how to install the RM3250 with the flat base. For alternative 
installation options, please contact Technical Services (techservices@aiworldwide.com).         

NOTE: To ensure a clean stable reading, keep field wiring as short as possible and use shielded 
twisted pair wire such as Alpha 2463C. American Innovations recommends using AI part number 
211061-000 (Belden 5308UE), or equivalent, for wiring inputs.       

Complete the following steps to install the RM3250:     

 1. Attach the flat base to a mounting bracket (either an existing bracket or the optional 
adjustable bracket).         
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Figure 4-1.   RM3250 Flat Base and Adjustable Mounting Bracket         

 2. If necessary, mount assembly to a structure, such as a pole, which is near the external device.         

 3. Bring the wires connecting the external device up through the bottom of the flat base.         

 4. Connect the external device to the 10-pin terminal.         

 5. Connect the 10-pin terminal to the corresponding connection on the RM3250.         

Figure 4-2.   RM3250 10-pin Terminal and Connection         

 6. Install the batteries into the bracket inside the RM3250. Secure with strap.         
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Figure 4-3.   Battery Bracket and Battery Placement (wired with optional Solar connection)         

 7. Connect the two battery connectors to the battery connections on the RM3250 board.         
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Figure 4-4.   Battery Connections         

 a. Connect the larger, round battery to the P4 connection.               

 b. Connect the bundled pair of batteries to the P3 connection.               

Once the batteries are connected to the unit, a Startup packet is sent to yourBullhorn Web 
account.         

 8. Place the RM3250 unit onto the base. Align the cut-out below the Bullhorn label on the dome 
to the screw (next to blue dot) on the base.         
If you plan to configure the unit using a USB 5-pin mini-b cable instead of Bluetooth, do not 
place the unit on the flat base. Configure the unit first and then secure the unit on the base. 
Refer to RM3250 Configuration on page 73 for configuration instructions. Otherwise, continue 
with next step.    



RM3000 Series

Chapter 4: RM3250 Installation 26

Figure 4-5.   RM3250 Aligned to Base         

 9. Optionally, you can test the satellite signal before completing the installation. Refer to Testing 
Satellite Reception on page 27 and then continue with the next step.           

 10. Secure the unit by tightening the screws. Torque the dome screws and fitting to the following 
measurements:         

 l dome screws - 10-12 in-lbs.               

 l cord grip body - 60 in-lbs.               

 l cord grip gland nut - 30 in-lbs.               

Do not twist the dome on the base if the cut-outs do not line up with the screws. Lift the 
dome off of the adapter and replace it in the correct position.         
Only if using AC power — turn rectifier ON to restore power to field wiring.         

 

Continue with RM3250 Configuration on page 73 to configure the RM3250 for service.         
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Testing Satellite Reception
Before completing the final installation, you can ensure that the RM3250 has adequate satellite 
signal to communicate with the Bullhorn Web account using Bullhorn Tools - either the software 
version or the mobile app. If reception is minimal, the unit may not be able to send information to . 
The Radio SNR reading should be at least 40 dB for a stable communication link with the satellite. If 
this reading falls below 37 dB, contact  Technical Services on page 9 for instructions. You can also 
email Technical Services by tapping  in Bullhorn Tools Mobile, which will include unit information 
and a log file with your email.     

NOTE: For instructions on how to use the Bullhorn Tools software on a laptop to verify signal 
strength, refer to RM3250 Configuration on page 73.       

 1. Activate the unit by swiping a magnet across the access point on the unit (marked with an 
arrow on the enclosure). A red light flashes to indicates that the unit is waiting to pair with 
your device.         

Figure 4-1.   RM3250 Access Point - Activated         

 2. Depending on whether you are using Bullhorn Tools on a mobile device or on a laptop, 
ensure that one of the following has been completed:         

 a. Bluetooth is enabled on your iOS device.               

 b. The AI USB Bluetooth dongle has been plugged into your laptop's USB port.               

 3. Open Bullhorn Tools and connect to the unit. The unit name includes the unit serial number 
(S/N), which can be found on the Bullhorn sticker on the dome.         
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Figure 4-2.   RM3250 Unit Label         

 4. Click or tap Refresh on the main window to update the Radio SNR reading. The Radio SNR 
reading should be at least 40 dB.         

 5. Complete the final installation step of securing the unit to the bracket (return to Installing the 
RM3250 on page 22).         

RM3250 Maintenance
If performing maintenance on the RM3250, first disconnect the equipment from hazardous voltages 
before gaining access to the enclosure.     
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Chapter 5: Configuration Overview
Bullhorn RM3000 Series remote monitoring units can be configured for service using unit-specific 
configuration software. Depending on the unit type, you can use one (or sometimes two) of the 
following configuration software versions:

 l Universal Configuration Toolkit Software — installed on your computer or laptop.

 l Bullhorn Tools Software on page 32 — installed on your computer or laptop.                 

 l Bullhorn Tools Mobile — downloaded as an app to your mobile device running either iOS or 
Android. 

The RM3000 Series units and the configuration software used to configure them are as follows:

 l RM3011 and RM3012  units can be configured with the Universal Configuration Toolkit. 

 l RM3250 units can be configured with either Bullhorn Tools  configuration software or with 
Bullhorn Tools Mobile.

Universal Configuration Toolkit Software
Universal Configuration Toolkit (UCT) is a software program you use to set and read the adjustable 
parameters of the unit. After installing the unit, you then configure it for service using the UCT 
software. 

The UCT software also provides diagnostic tools for checking input channel measurements, RSSI 
level, and transmitting a test packet to confirm communications with Bullhorn Web. 

The UCT software requires your computer be installed with Microsoft .NET Framework version 2.0 or 
higher. Also, your computer must be installed with the appropriate USB device driver. All three of 
these programs are included in the BATtools Suite Installer  that was included in the installation kit.

You must log on as an administrator or your computer user name must be a member of the 
Administrators group in order to install the USB device driver. If needed, contact your network 
administrator or IT department to determine if your user name is setup with administrator rights or 
privileges.
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BATtools Suite Installer
Before installing BATtools Suite Installer (includes UCT and support files), review the following 
information if a prior version of the software is installed on your computer. If a previous version of 
the UCT is not installed on your computer, continue with installing the software.

Everyone Installation Option If you installed a previous version of the UCT software using the 
Everyone option, the previous version must first be uninstalled prior to installing the new version.

Just Me Installation Option If you installed a previous version of the UCT  software using the Just 
Me option, it is not necessary to uninstall the previous version prior to installing the new version.

Figure 5-1.   Just me Option for Configuration Toolkit

NOTE: If the installation media is unavailable, download the files from Bullhorn Remote Monitoring 
Units Downloads page. 

Microsoft .NET Framework

Microsoft .NET Framework is a set of software components that enable your computer to run any 
software program that has been developed using Microsoft .NET technology.       Your computer must 
be installed with Microsoft .NET Framework version 4.0 or higher in order to use 

http://support.aiworldwide.com/products/bh1/content/topics/index_dl.htm?tocpath=Downloads%7C_____0
http://support.aiworldwide.com/products/bh1/content/topics/index_dl.htm?tocpath=Downloads%7C_____0
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Bullhornconfiguration software. Microsoft .NET Framework is automatically installed during 
installation  if the software detects that your computer does not already have it installed.  For more 
information about Microsoft .NET Framework, visit the Microsoft website 
(http://www.microsoft.com).     

USB Device Driver

The USB device driver is software that allows your computer to communicate with the Bullhorn unit 
via the USB configuration cable when configuring the unit for service. Installing the USB device 
driver is a one-time process and does not need to be repeated if you have already installed the 
driver on your computer. Once it is installed on your computer, it will work for any Bullhorn unit that 
includes a USB configuration port. The USB device driver should be installed prior to connecting the 
Bullhorn unit to your computer. If the USB device driver is not installed and you connect the Bullhorn 
unit to the USB port on your computer, Windows displays the “Found New Hardware” message and 
icon in the System Tray of your computer. Windows will then attempt to locate a suitable device 
driver already installed on your computer. Exit any open windows and then complete the procedure 
in the next section to install the USB device driver.

Installing the UCT and Support Files
To install the UCT, Microsoft .NET Framework, and USB driver using the BATtools Suite Installer:     

IMPORTANT: In order to install the USB device driver on your computer, you must log on as an 
administrator or your computer user name must be a member of the Administrators group. If 
needed, contact your network administrator or IT department to determine if your user name is 
setup with administrator rights or privileges.       

 1. Copy BATtools Suite Installer to your computer from the media included in the configuration 
kit or download the executable file from the Bullhorn Remote Monitoring Support Downloads 
page. Make sure that all files are extracted.         

 2. If necessary, open BATtools.zip file to extract all files.

 3. Double-click the BatToolsSuiteInstaller.exe file to begin the installation.         

 4. Check the Universal Config Tool check box.         

 5. Check the Silicon Laboratories USB to UART Driver check box and the Microsoft .NET 
Framework check box, if available and unchecked. If either of these are already installed on 
your computer, a check box will not display next to the name.         

NOTE: The MicroMax Programmer is included in the BATtools Suite Installer. You will not 

http://www.microsoft.com/
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need to install this program.         

 6. Click the Install button.         
The battery and power cable does not need to be connected to the Bullhorn unit in order for 
Windows to recognize the Bullhorn USB connection. The Bullhorn USB connection draws 
power from the USB port on your computer.         

 7. Follow the prompts to install the programs.         

Bullhorn Tools Software
Bullhorn Tools is a software program you use to set and read the adjustable parameters of the unit 
after the unit has been installed. Bullhorn Tools also allows you to set alarms and transmission 
schedules or transmit a test packet to confirm communications with Bullhorn Web. Bullhorn Tools is 
available in a software version and as a mobile app. The software can be downloaded from the 
Bullhorn Tools launch page.  The mobile app is available from the Apple App store or Google Play.

Refer to the unit's configuration section for instructions on using Bullhorn Tools.   

NOTE: Bullhorn Tools requires a minimum of 194MB of hard disk space.       

To install the software for the first time, complete the following steps:     

 1. Use the Bullhorn Tools launch page to download Bullhorn Tools.         

 2. Click Launch.         

 3. Depending on your browser, either click Run (or Save to save the file to you computer) or 
double-click the downloaded setup.exe file. The software installs and launches.         

 4. To start Bullhorn Tools after installation, click the Bullhorn Tools desktop icon or click 
Windows  Start menu and select Bullhorn Tools.         

After you have successfully installed and opened Bullhorn Tools, whenever you open Bullhorn Tools 
in the future, it automatically updates when updates are available. You will not need to download 
and install new versions of Bullhorn Tools to the computer where Bullhorn Tools has been installed. 

Bullhorn Tools Mobile App
Bullhorn Tools Mobile is the mobile version of the Bullhorn Tools configuration program. The 
mobile app gives you the ability to configure remote monitoring units using your mobile device 

http://install.bullhornsys.com/BullhornTools/
http://install.bullhornsys.com/BullhornTools/
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running either iOS or Android. Only remote monitoring units with Bluetooth capability can use the 
mobile app. 

Bullhorn Tools Mobile can be downloaded from Apple iTunes store (iOS) or Google Play (Android). 
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Chapter 6: RM3011 Configuration
RM3011remote monitoring units units are configured for compressor application during 
production. The RM3011 is shipped with the Universal Configuration Toolkit (UCT), which is used to 
verify the Skywave signal level, set up input channels for an annunciator, and to send test packets. 

For information on how to upgrade the unit firmware, refer to Updating RM3011 Firmware on page 
87.

RM3011 Configuration Overview
The RM3011 configuration process includes the following tasks:     

 l Connecting the RM3011 and Starting UCT on page 34

 l Selecting a Folder for Templates and Log Files      on page 36

 l Loading a Template on page 36

 l Verifying Satellite Signal Strength on page 37

 l Setting Up the Controller Clock on page 38

 l Set Up Transmission Schedule on page 38

 l Setting Up an Alarm Delay on page 39

 l Setting Up Alarm Input and Debounce Setting on page 39

 l Setting Up Modbus Comm Settings on page 40

 l Mapping Registers to ChannelsSetting Up Modbus Comm Settings on page 40

 l Unmapping a Register on page 50

 l Transmitting a Test Packet on page 50

 l Saving Settings in the Event Log on page 51

 l Saving Settings in a Template on page 51

Connecting the RM3011 and Starting UCT
Complete the following steps to begin the configuration process:     



RM3000 Series

Chapter 6: RM3011 Configuration 35

 1. Connect the configuration cable in the USB port of your computer. Connect the other end of 
the cable in the USB CONFIG port on the front panel of the unit.         

 2. Double-click the UCT program icon on the desktop to start the UCT software. Or click Start > 
Programs > Configuration Toolkit.         

 3. Select a unit in the drop-down list of the Find Devices window and then click Select.

Figure 6-1.   Find Devices         

 4. The main configuration window displays. Press F2 to read unit settings and verify that the unit 
and UCT software are communicating.         
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Figure 6-2.   RM3011 Main Configuration Window         

Selecting a Folder for Templates and Log Files     
Templates and log files store in My Documents by default. If you want to store these files in a 
different folder on your computer, complete the following steps:     

 1. Click Tools > Options to display the Options window.         

 2. Click Folder for Log files to display the Browse for folder window.         

 3. Select an existing folder or click Make New Folder to create a new folder.         

 4. Click Ok and then click Done to close the window.         

Loading a Template
If a template is available, load the template using the following steps:     
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 1. Click Tools > Advanced > Template > Load from Template.         

 2. When the Open Template window displays, locate the folder that contains the template. Select 
the template and then click Open.         

 3. After UCT applies the template, press F2 to read settings or click Tools > Read Unit Settings. 
Click File > Save Current Setup in Event Log to save settings.         

Verifying Satellite Signal Strength
The signal strength of the SkyWave satellite for the RM3011 can be viewed in the Communications 
Settings box on the main configuration window.     

Figure 6-1.   Satellite Signal Strength     

The satellite signal strength is displayed in the RSSI field. The RM3011 uses an RSSI scale of 0.00dB 
to 50.00dB. If the signal strength is weak (less than 10.5 dB for more than 30 seconds), a pop-up 
message will display to notify the user. The pop-up window also includes a Satellite Wizard tool to 
help acquire a stronger signal.     

Use the following information to verify that the RM3011 is receiving a strong satellite signal:     

 l Click Auto Update to display latest "live" RSSI reading.         

 l An RSSI of 14dB or higher indicates a strong signal.         

 l Levels below 14dB indicate no satellite communication.         

 l A green status bar in the RSSI field indicates that satellites have been found.         

 l A red status bar in the RSSI field indicates that no satellites have been found.         

If the RSSI signal is below 14dB or if the status bar is red, adjust the RM3011 enclosure and recheck 
the satellite signal strength.     
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Setting Up the Controller Clock
The controller clock is a time-of-day clock running inside the unit. It does not keep track of the 
month or year, or correct itself for daylight savings time. The unit uses the controller clock as a basis 
for all time-related operations.     

Complete the following steps to set up the controller clock:     

 1. Click Change in Controller Clock.         

 2. Select a Controller time field. Use the up and down arrows to adjust the time. Repeat this 
step for remaining time fields as needed.         
Or, click Set to PC Time if your computer is set up with the correct date and time in Windows 
Control Panel.         

 3. If you want to match a time zone, click the up or down arrow in the UTC Offset (h) field to 
subtract or add hours from Coordinated Universal Time (UTC), which is the same as Greenwich 
Mean Time. 

 4. Click Save when finished.         

Set Up Transmission Schedule
A transmission schedule determines when and how often channel readings are transmitted to your 
website account.     

Complete the following steps:     

 1. Click Change in Transmission Schedule.         

 2. Select a field in the Transmit report at field. Use the up and down arrows to adjust the time. 
Repeat this step for remaining time fields as needed.         

 3. If you want to include a delay in the transmission schedule, click Add Delay to place a check 
mark in the check box.         
Add Delay is based on the unit serial number. The unit serial number is equivalent to the 
number of seconds added to the reporting time. This feature is typically used to offset the 
transmission schedule for several units set up with the same reporting time.         

 4. Choose a repeat interval option in the And repeat every drop-down list.         

 5. Click Save.         
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Setting Up an Alarm Delay
Complete the following steps to set up an alarm delay:     

 1. Click Change in Alarm Delay.         

 2. Type the number of seconds in the alarm delay field that indicates how much time should 
pass between recognized alarms.         

 3. Click Save.         

Setting Up Alarm Input and Debounce Setting
Before setting up the alarm and Debounce setting, complete the following:     

 1. Click the Read Now button in Channels to read the value(s) of any input or register connected 
to the RM3011.         

 2. Click the Auto Update check box to have the values of inputs continuously updated.         

Complete the following steps to set up alarms based on an input state and an optional Debounce 
setting:     

 1. Click Settings in Channels to display the Digital Input State Trigger window.         

Figure 6-1.   Input State Selection and Debounce Settings         

 2. Select one of the following options that specifies which digital input state should trigger an 
alarm packet transmission:         

 l High (open)               

 l Low (closed)               

 l Both (High and Low)               

 l None
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 3. If you want to include an optional Debounce setting in alarm settings, type the number of 
seconds the input switch must remain in an alarm state before the RM3011 transmits an alarm 
packet.         
If you want alarm states recognized immediately, enter zero (0) in the Debounce Settings 
field.         

 4. Click Save.         

Setting Up Modbus Comm Settings
This procedure explains how to set up communication parameters for the RM3011 based on the 
type of input device connected to the unit.     

Complete the following steps to set up the Modbus communication settings:     

 1. Click Change in Modbus Comm Settings to view the Modbus Communication Settings window.         

Figure 6-1.   Modbus Communication Settings         

 2. Select a protocol from the list of options in the Protocol field that identifies the type of input 
device connected to the RM3011.         
If you are working with a Dresser input device, choose Dresser I if the input device was 
manufactured before 2005 or Dresser II if the device was manufactured after 2005.         
If needed, refer to the input device technical specifications or contact the manufacturer to 
determine the appropriate settings for the remaining steps in this procedure.         
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 3. Select a Baud rate from the list of options in the Baud Rate field.         

 4. In the Parity field, select N (none), E (even), or O (odd).         

 5. In the Data Bits field, select either 7 or 8.         

 6. In the Stop Bits field, select either 1 or 2.         

 7. Verify 1:RS232 is selected in the Interface Type field.         

 8. If the input device requires a handshake signal from the RM3011, use the up and down arrows 
in the Delay field to choose a time option. Valid selections are in a range of 0 to 10 seconds 
with 0 indicating an instant response.         

 9. If you are working with a Modbus ASCII or RTU, Mercury, or Reynolds input device, complete 
one of the following steps:         

 a. Modbus ASCII or RTU: Type the unit address assigned to the input device in the Unit 
Address field. Valid entries are any number from 1 to 255. Entering zero (0) disables this 
feature.               

 b. Mercury: Select an option in the Instrument Type field that identifies the type of 
Mercury device connected to the RM3011.               

 c. Reynolds: Type the unit identification number assigned to the Reynolds input device in 
the Unit Id field. Valid entries are any number from 1 to 255. Entering zero disables this 
feature.               

 10. Click Save.         

Mapping Registers to Channels
The information in the following sections explain how to map registers to the input channels of the 
RM3011. Instructions for unmapping a register are provided in Unmapping a Register on page 50

The RM3011 supports up to sixteen 6-digit registers, eight 12-digit registers, or a combination of 
both. Registers are mapped to the RM3011 by clicking a particular channel number listed in the 
Channels group box on the main configuration window. Channels are labeled Channel 1 through 
Channel 16.     

If you plan to map one or more 12-digit registers, use only the odd-numbered Channel 
configuration windows (channel 1, 3, 5, and so on). These windows include an option labeled 
Double Register that refers to a 12-digit register.     
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Figure 6-1.   Channel 1 Configuration     

The Double Register option is unavailable for selection on even-numbered Channel configuration 
windows. When an odd-numbered Channel is configured for a 12-digit register, the next even-
numbered Channel on the main configuration window is unavailable for selection.     

When mapping a register for a Modbus RTU or ASCII input device, you'll need to specify the register 
Data Type and Register Type in order for the RM3011 to correctly read the register. If you are 
working with a Mercury, Reynolds 16-bit, or Reynolds 32-bit input device, you only need to specify 
the register Data Type. The RM3011 does not require either type of information when working with 
a Dresser input device. If needed, refer to the technical specifications for the input device or contact 
the manufacturer to help determine the correct Data Type and Register Type.     

Depending on the type of input device connected to the RM3011, map the registers using the 
instructions in the following sections:     

 l Modbus ASCII or RTU — If you are working with a Modbus ASCII or RTU input device, 
continue with Mapping Registers for Modbus ASCII or RTU Input Device on page 43.         

 l Reynolds 16 or 32-Bit —   If you are working with a Reynolds 16- or 32-bit input device, 
continue with Mapping Registers for Reynolds 16- or 32-Bit Input Device on page 45

 l Mercury —  If you are working with a Mercury input device, continue with Mapping Registers 
for Mercury Input Device on page 46.         
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 l Dresser  — If you are working with a Dresser input device, continue with Mapping Registers for 
Dresser Input Device on page 48.         

NOTE: If you need to unmap a register, refer to Unmapping a Register on page 50.       

Mapping Registers for Modbus ASCII or RTU Input Device
Complete the following steps to map a register to a Modbus ASCII or RTU device:   

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 1 to display a window similar to the example shown below.         
You can also display a channel configuration window by clicking Tools > Settings > Channels. 
When the window displays, click Next Register to display the channel number you want to 
configure.     If you are mapping a 12-digit register, make sure to select an odd-numbered 
channel on the main configuration window.         

Figure 6-1.   Modbus ASCII or RTU Configuration         

 2. Type the unit address assigned to the input device in the Unit Address text box. Valid entries 
are any number from 1 to 255. Entering zero (0) disables this feature.         

 3. Type the register address of the input device in the Register Address text box. Valid entries 
include any address from 1 to 9,999. Entering zero disables this feature.         

 4. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3011 uses to scale a 
raw register readings is as follows:         
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 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6 or 12-digit register and the scaled reading is larger than 6 or 12 
digits respectively, the RM3011 reports a register reading of "999999". The Bullhorn website 
displays scaled readings according to the "multiplier" value you select on the website.         

 5. Click the arrow in the Data Type list box and select an option from the list that identifies the 
register data type.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3011 to report an incorrect register reading.         

 6. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 7. Identify the Register Type by clicking the Coil Status, Input Status, Input Register, or 
Holding Register option button.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help you determine the correct register type. An incorrect register type 
causes the RM3011 to report an incorrect register reading.         
After choosing a register type, the UCT software modifies the register address by applying an 
offset value. The modified register address displays in the Register column of the Channels 
group box on the main configuration window. Offset values are automatically applied as 
follows:         

 l Coil Status: zero (0) offset value               

 l Input Status: 10,000 offset value               

 l Input Register: 30,000 offset value               

 l Holding Register: 40,000 offset value               

 8. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 9. Click Save + Next Register to save settings and display the next Channel Configuration 
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window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Mapping Registers for Reynolds 16- or 32-Bit Input Device
Complete the following steps to map a register for a Reynolds device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 1 to display a window similar to the figure below.         
You can also display a channel configuration window by clicking Tools > Settings > Channels. 
When the window displays, click Next Register to display the channel number you want to 
configure.                  If you are mapping a 12-digit register, make sure to select an odd-numbered 
channel on the main configuration window.            If you are mapping a 12-digit register, make sure 
to choose an odd-numbered channel on the main configuration window.         

Figure 6-1.   Reynolds Register Configuration         

 2. Type the unit address assigned to the input device in the Unit Address text box. Valid entries 
are any number from 1 to 255. Entering zero (0) disables this feature.         

 3. Type the register address of the input device in the Register text box. Valid entries include 
any address from 1 to 65,535. Entering zero (0) disables this feature.         

 4. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3011 to scale a raw 
register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
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twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6 or 12-digit register and the scaled reading is larger than 6 or 12 
digits respectively, the RM3011 reports a register reading of "999999". The Bullhorn website 
displays scaled readings according to the "multiplier" value you select on the website.         

 5. Click the arrow in the Data Type list box and select an option from the list that identifies the 
register data type.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3011 to report an incorrect register reading.         
The options in the Register Type group box are unavailable for selection.         

 6. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 7. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 8. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Mapping Registers for Mercury Input Device
Complete the following steps to map a register for a mercury device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 1 to display a window similar to the figure below.                    
You can also display a channel configuration window by clicking Tools > Settings > Channels. 
When the window displays, click Next Register to display the channel number you want to 
configure.                  If you are mapping a 12-digit register, make sure to select an odd-numbered 
channel on the main configuration window. 
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Figure 6-1.   Mercury Register Configuration         

 2. The Instr Type (instrument type) list box shows the current selection. To change the 
instrument type, click the arrow in the list box and choose an option from the list.         
Selecting an instrument type for one channel configures all remaining channels with the same 
instrument type. Each instrument type is assigned an identification (ID) number by the UCT 
software. The ID number displays in the Instr Type column on the main configuration window 
instead of the name of the instrument type. When changing the instrument type, make sure 
the RM3011 is configured with the correct Mercury item number and scale value.         

 3. Type the item number of the Mercury instrument you want to monitor in the Item No. text 
box. Valid entries are any number from 1 to 999. Entering zero (0) disables this feature.         
For example, if the Mercury instrument is configured to report item number "522" (Batt Low 
Volt Limit) and you want the RM3011 to monitor this item number, type 522 in the Item No. 
text box.         

 4. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3011 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               
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If you are working with a 6 or 12-digit register and the scaled reading is larger than 6 or 12 
digits respectively, the RM3011 reports a register reading of "999999". The Bullhorn website 
displays scaled readings according to the "multiplier" value you select on the website.         

 5. Click the arrow in the Data Type list box and select an option from the list that identifies the 
register data type.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3011 to report an incorrect register reading.         
Channel readings in the Channels group box on the main configuration window display as a 5 
or 6 digit number when you configure the channel with the Data Type option labeled 
Mercury String Date/Time format. For example, the UCT software displays the date 
03/02/2008 as 30208.         

 6. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 7. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 8. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Mapping Registers for Dresser Input Device
Complete the following steps to map a register for a Dresser device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, Channel 1. For example, click Channel 1 to display a window similar to the example 
shown below.         
You can also display a channel configuration window by clicking Tools > Settings > Channels. 
When the window displays, click Next Register to display the channel number you want to 
configure.                  If you are mapping a 12-digit register, make sure to select an odd-numbered 
channel on the main configuration window. 
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Figure 6-1.   Dresser Register Configuration         

 2. Type the register address (or variable number) of the input device in the Register text box.         
Valid register addresses are any number from 4,000 to 9,999 when the RM3011 is configured 
with the Dresser I communication protocol. When configured with the Dresser II protocol, 
valid register addresses are any number from 1 to 18. Entering zero (0) disables this feature. 
For a list of valid register addresses or variable numbers, also refer to the manufacturer's 
documentation provided with the Dresser input device.         
After you enter a register address, the UCT software automatically enters a value in the 
Number Bytes text box. The options in the group boxes Data Type and Register Type are 
unavailable for selection.         

 3. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3011 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6 or 12-digit register and the scaled reading is larger than 6 or 12 
digits respectively, the RM3011 reports a register reading of "999999". The Bullhorn website 
displays scaled readings according to the "multiplier" value you select on the website.         
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 4. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 5. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Unmapping a Register
Complete the following steps to unmap a register that has previously been mapped to a channel on 
the RM3011:     

 1. On the main configuration window, click the channel number you want to unmap.         

 2. Click Unmap to unmap the register and close the channel configuration window. When you 
open the channel configuration window again, Not Mapped displays near the top of the 
window to indicate the channel is not mapped to a register.         

 3. Save all configuration settings in the event log by clicking File > Save Current Setup in Event 
Log.         
For more information about the Event Log, refer to the sections Transmitting a Test Packet on 
page 50 and Saving Settings in the Event Log on page 51.         

 4. When you finish configuring the RM3011, continue with Transmitting a Test Packet on page 50.
         

Transmitting a Test Packet
To transmit a test packet, click Transmit in Communication Settings on the main configuration 
window.     

Status messages display in the window beside the Transmit button. When the status message 
Acknowledgement received from server appears, communication has been established.     

IMPORTANT: If the status message Test Packet Return Transmission Failed appears, 
communication has not been established with the server. Click Transmit again to send another test 
packet. If communication cannot be established after several attempts, please call Technical 
Support for assistance.       
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Saving Settings in the Event Log
To save configuration settings, click File > Save Current Setup in Event Log.     

NOTE: The Event Log is used later when setting up the unit on Bullhorn Web. The file is saved on 
your hard drive in the same folder as the UCT software. The UCTsoftware automatically gives the 
Event Log a file name that includes the unit's serial number with a .bhs extension.       

Saving Settings in a Template
Unit settings can be saved in a template, which can then be used to set up another unit of the same 
type.     

Complete the following steps to save settings to a template:     

 1. Click Tools > Advanced > Template > Save to Template to display the Save Template 
window.         

 2. Open an existing folder or create a new folder to store the template.         

 3. If you want to change the default file name of the template, type a name for the template in 
the File name field making sure to use the .bht file extension. Click Save when you finish.         

Completing Configuration and Installation
Complete the following steps to exit the UCT and close the enclosure:     

 1. Click File > Exit or press Alt+F4.         

 2. Disconnect the configuration cable from the unit and your computer.         

 3. Line up the notch on the USB port cap to the USB port on the RM3011. Secure cap by 
tightening ring until it clicks in place. 

 



RM3000 Series

Chapter 6: RM3011 Configuration 52

 
Figure 6-1.   USB Port     
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Chapter 7: RM3012 Configuration
RM3012  remote monitoring units are configured for compressor application during production. 
The RM3012 is shipped with the Universal Configuration Toolkit (UCT), which is used to verify the 
Skywave signal level, set up input channels for an annunciator, and to send test packets. This chapter 
contains information on how to use the UCT software with RM3012 units that are configured for 
compressor applications.     

NOTE: You will need UCT version 2.2.22.0 or later to configure the RM3012.      

For information on how to upgrade the unit firmware, refer to Firmware Updates on page 87.

RM3012 Configuration Overview
The RM3012 configuration process includes the following tasks:     

 l Connecting the RM3012 and Starting UCT on page 54

 l Selecting a Folder for Templates and Log Files on page 55

 l Loading a Template on page 55

 l Verifying Satellite Signal Strength on page 56

 l Setting a Transmission Schedule on page 57

 l Setting Up an Alarm Delay on page 58

 l Setting Up Alarm Input and Debounce Setting on page 58

 l Setting Up Modbus Comm Settings on page 59

 l Mapping Registers to Channels on page 61

 l Unmapping a Register on page 69

 l Setting Battery Install Date on page 70

 l Transmitting a Test Packet on page 70

 l Saving Settings in the Event Log on page 71

 l Saving Settings in a Template on page 71
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Connecting the RM3012 and Starting UCT
Complete the following steps to begin the configuration process:     

 1. Connect the configuration cable to the USB port of your computer. Connect the other end of 
the cable to the USB port on the front panel of the unit.         

Figure 7-1.   RM3012 USB Port               

 2. Double-click the UCT program icon on the desktop to start the UCT software. Or click Start > 
Programs > Configuration Toolkit.         

 3. Select a unit in the drop-down list of the Find Devices window, and then click Select.         

Figure 7-2.   Find Devices               

 4. The main configuration window displays. Press F2 to read unit settings and verify that the unit 
and UCT software are communicating.         
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Figure 7-3.   UCT Main Configuration Window               

Selecting a Folder for Templates and Log Files
Templates and log files store in My Documents by default. If you want to store these files in a 
different folder on your computer, complete the following steps:     

 1. Click Tools > Options to display the Options window.         

 2. Click Folder for Log files to display the Browse for folder window.         

 3. Select an existing folder or click Make New Folder to create a new folder.         

 4. Click OK and then click Done to close the window.         

Loading a Template
If a template is available, load the template using the following steps:     
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 1. Click Tools > Advanced > Template > Load from Template.         

 2. When theOpen Template window displays, locate the folder that contains the template. 
Select the template and then click Open.         

 3. After UCT applies the template, press F2 to read settings or click Tools > Read Unit Settings. 
Click File > Save Current Setup in Event Log to save settings.         

Verifying Satellite Signal Strength
The current satellite for the RM3012 can be viewed in the Communications Settings pane on the 
main configuration window. Verify that the current satellite is in the region near your location.     

Figure 7-1.   Satellite Signal Strength

The satellite signal strength is displayed in the Signal Strength field. The RM3012 uses a scale of 
0.00dB to 50.00dB for satellite signal strength. If the signal strength is weak (less than 10.5 dB for 
more than 30 seconds), a pop-up message will display to notify the user. The pop-up window also 
includes a Satellite Wizard tool to help acquire a stronger signal. 

NOTE: If the unit is moved, you must re-verify that the unit is acquiring satellite signal.         

Use the following information to verify that the RM3012 is receiving a strong satellite signal:     

 l Satellite Status is Acquired.         

 l Signal Strength of 14dB or higher indicates a strong signal; levels below 14dB indicate no 
satellite communication.         

 l A green status bar in the Signal Strength field indicates that satellites have been found.         

 l A red status bar in the Signal Strength field indicates that no satellites have been found.         
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NOTE: If the Signal Strength is below 14dB, or if the status bar is red, adjust the RM3012 enclosure 
and recheck the satellite signal strength.       

Setting a Transmission Schedule
A transmission schedule determines when and how often channel readings are transmitted to your 
Bullhorn Web account.     

Complete the following steps to set up a transmission schedule:     

 1. Click Change in the Transmission Schedule pane on the main configuration window to open 
the Transmission Schedule window.         

Figure 7-1.   Transmission Schedule Window         

 2. Select a time in the Transmit report at field. Use the up and down arrows to adjust the time.         

 3. If you want to include a delay in the transmission schedule, click Add Delay to place a check 
mark in the check box.         
Add Delay is based on the unit serial number. The unit serial number is equivalent to the 
number of seconds added to the reporting time. This feature is typically used to offset the 
transmission schedule for several units set up with the same reporting time.         
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 4. Choose a repeat interval option in the And repeat every drop-down list.         

 5. Click Save.         

Setting Up an Alarm Delay
Complete the following steps to set up an alarm delay:     

 1. Click Change in the Alarm Delay pane on the main configuration window to open the Alarm 
Delay window.         

Figure 7-1.   Alarm Delay Window         

 2. Type the number of seconds in the field to indicate how much time should pass between 
recognized alarms. The value should be between 0 and 86400 seconds.         

 3. Click Save.         

Setting Up Alarm Input and Debounce Setting
Before setting up the alarm and Debounce setting, complete the following:     

 1. Click the Read Now button on the Channels pane of the main configuration window to read 
the value(s) of any input or register connected to the RM3012.         

 2. Click the Auto Update check box to have the values of inputs continuously updated.         

Complete the following steps to set up alarms based on an input state and an optional Debounce 
setting:     

 l Click Settings in the Channels pane on the main configuration window to display the Digital 
Input State Trigger window.         
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Figure 7-1.   Input State Trigger and Debounce Settings         

 l Select one of the following options that specifies which digital input state should trigger an 
alarm packet transmission:         

 — High (open)               

 — Low (closed)               

 — Both (High and Low)               

 — None

 l If you want to include an optional Debounce setting in alarm settings, type the number of 
seconds the input switch must remain in an alarm state before the RM3012 transmits an alarm 
packet.         
If you want alarm states recognized immediately, enter zero (0) in the Debounce Settings 
field.         

 l Click Save.         

Setting Up Modbus Comm Settings
This procedure explains how to set up communication parameters for the RM3012 based on the 
type of input device connected to the unit.     

Complete the following steps to set up the Modbus communication settings:     

 1. Click Change in the Modbus Comm Settings pane on the main configuration window to view 
the Modbus Communication Settingswindow.         
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Figure 7-1.   Modbus Communication Settings Window         

 2. Select a protocol from the list of options in the Protocol field that identifies the type of input 
device connected to the RM3012.         
If you are working with a Dresser input device, choose Dresser I if the input device was 
manufactured before 2005 or Dresser II if the device was manufactured after 2005.         
If needed, refer to the input device technical specifications or contact the manufacturer to 
determine the appropriate settings for the remaining steps in this procedure.         

 3. Select a Baud rate from the list of options in the Baud Rate field.         

 4. In the Parity field, select N (none), E (even), or O (odd).         

 5. In the Data Bits field, select either 7 or 8.         

 6. In the Stop Bits field, select either 1 or 2.         

 7. Verify that 1:RS232 is selected in the Interface Type field.         

 8. If the input device requires a handshake signal from the RM3012, use the up and down arrows 
in the Delay field to choose a time option. Valid selections are in a range of 0 to 10 seconds 
with 0 indicating an instant response.         

 9. If you are working with a Modbus ASCII or RTU, Mercury, or Reynolds input device, complete 
one of the following steps:         
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 a. Modbus ASCII or RTU: Type the unit address assigned to the input device in the Unit 
Address field. Valid entries are any number from 1 to 255. To disable this feature, enter 
a zero (0).               

 b. Mercury: Select an option in the Instrument Type field that identifies the type of 
Mercury device connected to the RM3012.               

 c. Reynolds: Type the unit identification number assigned to the Reynolds input device in 
the Unit Id field. Valid entries are any number from 1 to 255. To disable this feature, 
enter a zero (0).               

 10. Click Save.         

Mapping Registers to Channels
The information in the following sections explain how to map registers to the input channels of the 
RM3012 . Instructions for unmapping a register are provided in Unmapping a Register on page 69.     

The RM3012 supports up to sixteen 6-digit registers, eight 12-digit registers, or a combination of 
both. Registers are mapped to the RM3012 by clicking a particular channel number listed in the 
Channels pane on the main configuration window. Channels are labeled Channel 1 through Channel 
16.     

If you plan to map one or more 12-digit registers, use only the odd-numbered Channel 
Configuration windows (channel 1, 3, 5, and so on). These windows include an option labeled 
Double Register that refers to a 12-digit register.     

Figure 7-1.   Channel 1 Configuration Window     

The Double Register option is unavailable for selection on even-numbered Channel Configuration 
windows. When an odd-numbered Channel is configured for a 12-digit register, the next even-
numbered Channel on the main configuration window is unavailable for selection.     



RM3000 Series

Chapter 7: RM3012 Configuration 62

When mapping a register for a Modbus RTU or ASCII input device, you must specify the register 
Data Type and Register Type for the RM3012 to correctly read the register. If you are working with 
a Mercury, Reynolds 16-bit, or Reynolds 32-bit input device, you only need to specify the register 
Data Type. The RM3012 does not require either type of information when working with a Dresser 
input device. If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct Data Type and Register Type.     

Depending on the type of input device connected to the RM3012, map the registers using the 
instructions in the following sections:     

 l Modbus ASCII or RTU: If you are working with a Modbus ASCII or RTU input device, continue 
with the section Map Registers for Modbus ASCII or RTU Input Device.         

 l Reynolds 16- or 32-Bit: If you are working with a Reynolds 16- or 32-bit input device, 
continue with Mapping Registers for Reynolds 16- or 32-Bit Input Device on page 64.         

 l Mercury: If you are working with a Mercury input device, continue with the Mapping Registers 
for Mercury Input Device      on page 66.         

 l Dresser: If you are working with a Dresser input device, continue with Mapping Registers for 
Dresser Input Device  on page 68.         

NOTE: If you need to unmap a register, refer to Unmapping a Register on page 69.       

Mapping Registers for Modbus ASCII or RTU Input Device
Complete the following steps to map a register for a Modbuss ASCII or RTU device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 2.         
You can also display a channel configuration window by clicking Tools > Settings > Channels. 
When the window displays, click Next Register to display the channel number you want to 
configure.         
If you are mapping a 12-digit register, make sure to choose an odd-numbered channel on the 
main configuration window. For more information, refer to Mapping Registers to Channels on 
page 61
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Figure 7-1.   Modbus ASCII or RTU Configuration     

 2. Type the unit address assigned to the input device in the Unit Address text box. Valid entries 
are any number from 1 to 255. To disable this feature, enter a zero (0).         

 3. Type the register address of the input device in the Register Address text box. Valid entries 
include any address from 1 to 9,999. To disable this feature, enter a zero (0).         

 4. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3012 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6- or 12-digit register and the scaled reading is larger than 6 or 12 
digits, respectively, the RM3012 reports a register reading of "999999". Bullhorn Web displays 
scaled readings according to the "multiplier" value you select on the website.         

 5. Click the arrow in the Data Type list box and select an option from the list that identifies the 
register data type.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3012 to report an incorrect register reading.         
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 6. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 7. Identify the Register Type by clicking the Coil Status, Input Status, Input Register, or 
Holding Register option button.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help you determine the correct register type. An incorrect register type 
causes the RM3012 to report an incorrect register reading.         
After choosing a register type, the UCT software modifies the register address by applying an 
offset value. The modified register address displays in the Register column of the Channels 
pane on the main configuration window. Offset values are automatically applied as follows:         

 l Coil Status: zero (0) offset value               

 l Input Status: 10,000 offset value               

 l Input Register: 30,000 offset value               

 l Holding Register: 40,000 offset value               

 8. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 9. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Mapping Registers for Reynolds 16- or 32-Bit Input Device
Complete the following steps to map a register for a Reynolds device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 2 to display a Channel Configuration window.         
If you are mapping a 12-digit register, make sure to choose an odd-numbered channel on the 
main configuration window. 
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Figure 7-1.   Reynolds Register Configuration         

 2. Type the unit address assigned to the input device in the Unit Address text box. Valid entries 
are any number from 1 to 255. To disable this feature, enter a zero (0).         

 3. Type the register address of the input device in the Register text box. Valid entries include 
any address from 1 to 65,535. To disable this feature, enter a zero (0).         

 4. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3012 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6- or 12-digit register and the scaled reading is larger than 6 or 12 
digits, respectively, the RM3012 reports a register reading of "999999". Bullhorn Web displays 
scaled readings according to the "multiplier" value you select on the website.         

 5. Click the arrow in the Data Type list box, and select an option from the list that identifies the 
register data type.         
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If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3012 to report an incorrect register reading.         
The options in the Register Type group box are unavailable for selection.         

 6. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 7. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 8. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

 9. When you finish configuring all channels, continue with Setting Battery Install Date on page 70. 

Mapping Registers for Mercury Input Device     
Complete the following steps to map a register for a Mercury device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, click Channel 1 to display a Channel Configuration window.         
If you are mapping a 12-digit register, make sure to choose an odd-numbered channel on the 
main configuration window. For more information, refer to Mapping Registers to Channels on 
page 61.         

Figure 7-1.   Mercury Register Configuration         

The Instr Type (instrument type) list box shows the current selection. To change the 
instrument type, click the arrow in the list box and choose an option from the list.         
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Selecting an instrument type for one channel configures all remaining channels with the same 
instrument type. Each instrument type is assigned an identification (ID) number by the UCT 
software. The ID number displays in the Instr Type column on the main configuration window 
instead of the name of the instrument type. When changing the instrument type, make sure 
the RM3012 is configured with the correct Mercury item number and scale value.         

 2. Type the item number of the Mercury instrument you want to monitor in the Item No. text 
box. Valid entries are any number from 1 to 999. To disable this feature, enter a zero (0).         
For example, if the Mercury instrument is configured to report item number "522" (Batt Low 
Volt Limit), and you want the RM3012 to monitor this item number, type 522 in the Item No. 
text box.         

 3. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3012 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6- or 12-digit register and the scaled reading is larger than 6 or 12 
digits, respectively, the RM3012 reports a register reading of "999999". Bullhorn Web displays 
scaled readings according to the "multiplier" value you select on the website.         

 4. Click the arrow in the Data Type list box, and select an option from the list that identifies the 
register data type.         
If needed, refer to the technical specifications for the input device or contact the 
manufacturer to help determine the correct data type. An incorrect data type causes the 
RM3012 to report an incorrect register reading.         
Channel readings in the Channels pane on the main configuration window display as a 5 or 6 
digit number when you configure the channel with the Data Type option labeled Mercury 
String Date/Time format. For example, the UCT software displays the date 03/02/2008 as 
30208.         

 5. Choose either a Normal Packet or Alarm Packet from Packet Options.         

 6. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
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click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 7. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Mapping Registers for Dresser Input Device 
Complete the following steps to map a register for a Dresser device:     

 1. On the main configuration window, click the channel number you want to configure. For 
example, Channel 1. For example, click Channel 1 to display a Channel Configuration window         
If you are mapping a 12-digit register, make sure to choose an odd-numbered channel on the 
main configuration window. For more information, refer to Mapping Registers to Channels on 
page 61.         

Figure 7-1.   Dresser Register Configuration         

 2. Type the register address (or variable number) of the input device in the Register text box.         
Valid register addresses are any number from 4,000 to 9,999 when the RM3012 is configured 
with the Dresser I communication protocol. When configured with the Dresser II protocol, 
valid register addresses are any number from 1 to 18. To disable this feature, enter a zero (0). 
For a list of valid register addresses or variable numbers, also refer to the manufacturer's 
documentation provided with the Dresser input device.         
After you enter a register address, the UCT software automatically enters a value in the 
Number Bytes text box. The options in the group boxes Data Type and Register Type are 
unavailable for selection.         

 3. Choose a scale value by clicking the up or down arrow buttons located next to the Scale text 
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box. The up arrow moves the decimal to the left and the down arrow moves the decimal to 
the right.         
The scale value you select displays below the text box. It shows an example of how the 
selected scale value applies to the register reading. The process the RM3012 uses to scale a 
raw register readings is as follows:         

 l Divide the raw reading by the scale value.               

 l Select the first six digits to the left of the decimal point for a 6-digit register or the first 
twelve digits to the left of the decimal point if working with a Double Register (12-digit 
register).               

 l If necessary, add leading zeroes to the left of the number to produce either a 6-digit 
scaled reading or a 12-digit scaled reading if working with a Double Register.               

If you are working with a 6- or 12-digit register and the scaled reading is larger than 6 or 12 
digits, respectively, the RM3012 reports a register reading of "999999". Bullhorn Web displays 
scaled readings according to the "multiplier" value you select on the website.         

 4. If you are working with an odd-numbered channel and you want to map a 12-digit register, 
click the Double Register option box.         
A check mark inside the check box indicates the channel is enabled. To disable the channel, 
clear the check mark by clicking the check box again.         

 5. Click Save + Next Register to save settings and display the next Channel Configuration 
window. If you do not want to configure another channel, click Save to save settings and close 
the configuration window.         

Unmapping a Register
Complete the following steps to unmap a register that has previously been mapped to a channel on 
the RM3012:     

 1. On the main configuration window, click the channel number you want to unmap.         

 2. Click Unmap to unmap the register, and close the channel configuration window. When you 
open the channel configuration window again, Not Mapped displays near the top of the 
window to indicate the channel is not mapped to a register.         

 3. Save all configuration settings in the event log by clicking File > Save Current Setup in Event 
Log.         
For more information about the Event Log, refer to Setting Battery Install Date on page 70 and 
Saving Settings in the Event Log on page 71.         
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 4. When you finish configuring the RM3012, continue with Setting Battery Install Date on page 70.
         

Setting Battery Install Date
Complete the following steps to set the installation date for the RM3012 internal backup battery:     

 l Click Change in Power Information pane to display the Power/Battery window.         

Figure 7-1.   Power/Battery         

 l Select date from Installed Date field or check the Installed Today check box.         

 l Click Save.         

Transmitting a Test Packet
To transmit a test packet, click Transmit in the Communications Settings pane on the main 
configuration window.     

Status messages display in the window beside the Transmit button. When the status message 
Acknowledgment received from server appears, communication has been established.     

IMPORTANT: If the status message Test Packet Return Transmission Failed appears, 
communication has not been established with the server. Click Transmit again to send another test 
packet. If communication cannot be established after several attempts, please call Technical 
Support for assistance.       
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Saving Settings in the Event Log
To save configuration settings, click File > Save Current Setup in Event Log.     

NOTE: The Event Log is used later when setting up the unit on Bullhorn Web. The file is saved on 
your hard drive in the same folder as the UCT software. The UCT software automatically gives the 
Event Log a file name that includes the unit's serial number with a .bhs extension.       

Saving Settings in a Template
Unit settings can be saved in a template, which can then be used to set up another unit of the same 
type.     

Complete the following steps to save settings to a template:     

 1. Click Tools > Advanced > Template > Save to Template to display the Save Template 
window.         

 2. Open an existing folder or create a new folder to store the template.         

 3. If you want to change the default file name of the template, type a name for the template in 
the File name field making sure to use the .bht file extension. Click Save when you finish.         

Completing Configuration and Installation
Complete the following steps to exit the UCT and close the enclosure:     

 1. Click File > Exit or press Alt+F4.         

 2. Disconnect the configuration cable from the unit and your computer.         

 3. Line up the notch on the USB port cap to the USB port on the RM3012. Secure cap by 
tightening ring until it clicks in place. 
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Figure 7-1.   USB Port     
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Chapter 8: RM3250 Configuration
Remote monitoring units with Bluetooth, such as the RM3250, can be configured for service using 
Bullhorn Tools - either on your laptop with the software version or on a smartphone or tablet 
running iOS 8.1 or Android 7. The software version can be downloaded from Bullhorn Tools launch 
page, while Bullhorn Tools Mobile can be downloaded from the Apple App Store or Google Play. 
This section describes the process for configuring units with the software version of Bullhorn Tools. 
For instructions on using the mobile app, refer to Bullhorn Tools Mobile User Guide.     

After configuring the unit, the unit information and settings can be accessed through Bullhorn Web. 

Before beginning the configuration process, download and install Bullhorn Tools software from the 
Bullhorn Tools launch page. If the software is already loaded on your laptop or computer, any 
updates to the software will automatically be installed when you open Bullhorn Tools (with Internet 
access).

Configuration Overview
The configuration process for  the RM3250 includes the following tasks:     

 1. Activating Bluetooth on page 73            — activate Bluetooth on the unit (or connect USB cable to 
unit).         

 2. Configuring the RM3250 with Bullhorn Tools Software on page 74 — including viewing unit 
information, setting serial settings, and configuring readings. 

 3. De-activate Bluetooth on page 86 —  when finished with configuring the unit, de-active the 
unit's Bluetooth.

Activating Bluetooth
Complete the following steps to activate the unit's Bluetooth to enable it for configuration via a 
Bluetooth connection.     

NOTE: The unit will disconnect automatically after 10 minutes. It is not necessary to swipe the 
activation point again unless you wish to de-activate the Bluetooth connection immediately.       

http://install.bullhornsys.com/BullhornTools/
http://install.bullhornsys.com/BullhornTools/
http://support.aiworldwide.com/downloads/bh2/BullhornToolsMobile-UserGuide.pdf
https://www.bullhornsys.com/
http://install.bullhornsys.com/BullhornTools/
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 1. Swipe a magnet across the access point on the unit (marked with an arrow on the enclosure. A 
red light flashes to indicates that the unit is waiting to pair with a Bluetooth-enabled device.         
If you are using Bullhorn Tools on a laptop and connecting to the unit with a USB mini-b cable 
instead of the Bluetooth connection, you do not need to activate the unit. The unit will be 
ready to configure with Bullhorn Tools once the cable has been connected to both the unit 
and the laptop.         

Figure 8-1.   Access Point - Activated 

NOTE: The unit will stop waiting to pair (light flashing) after 10 minutes. It is not necessary to 
swipe the activation point again unless you wish to de-activate the Bluetooth connection 
immediately.       

Configuring the RM3250 with Bullhorn Tools Software
Use Bullhorn Tools to complete the following configuration tasks on the RM3250 unit:     

 l Viewing Unit Information on page 75 — the main RM3250 Unit Overview window displays 
current unit information. You can also enable or disable Scaling by clicking the Scaling 
slider on the Readings line.         

 l Loading or Importing a Template on page 76 — units can be configured from a previously-
saved template that contains unit settings. Current unit settings are overwritten by the applied 
template.         

 l Setting Reporting and Battery Information on page 76 — set a transmission schedule and the 
battery install date.         

 l Setting Serial Settings on page 77 — set communication parameters for the device that the 
RM3250 is connected to and communicating with.         

 l Enabling or Disabling Readings on page 78 — enable or disable the unit registers as necessary.         
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 l Configuring Readings on page 80 — configure up to ten Readings (registers) and one digital 
input.         

 l Sending a Test Message on page 82 — send a test message to the unit to verify 
communications.         

 l Working with Templates on page 83 — to save time when configuring multiple units, unit 
settings can be saved to a template that can be used to configure other similar units.         

 l Upgrading RM3250 Firmware on page 85 — if available, firmware upgrades can be done 
through Bullhorn Tools.         

When finished, click File > Disconnect to disconnect from the unit or File > Exit to close Bullhorn 
Tools.     

Viewing Unit Information
Use the following steps to check unit and transmission information:     

 1. Click the name of the unit in the navigation pane to view Readings, Test Message Status, 
Power, Unit Information, Reporting, and Serial Settings panes.         

Figure 8-1.   Unit Overview - No Enabled Registers         

 2. If registers have not yet be enabled, the Readings pane will be empty. After enabling registers 
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(refer to Enabling or Disabling Readings on page 78), click  Refresh to update the 
information.         

Loading or Importing a Template
If a template is available for the unit type you plan to configure, you can load the template using the 
following steps:     

 1. Click File > Load Template.         

 2. In the Apply Template window, select a saved template from the Select template list.         

Figure 8-1.   Apply Template         

 3. Verify unit information, then click Apply.         

Setting Reporting and Battery Information
The reporting schedule determines when and how often Reading measurements transmit to your 
Bullhorn Web account.     

Complete the following steps to schedule reports or add a battery installation date:     
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 1. Click  Reporting & Power to open the Reporting window.         

Figure 8-1.   Reporting & Power Settings         

 2. Select a reporting transmission interval (4 Hour, 6 Hour, or Daily) in the Interval field or leave 
blank for no transmission.         

 3. Enter a time in Start Time field. For example, typing a 2 will display 2:00 AM.         
If the data log becomes full, the unit may report to the website in-between the scheduled 
interval time.         

 4. Select a date from the pop-up calendar in the Battery Install Date.         

 5. Click  Save to save settings or  Cancel to clear all fields.         

Setting Serial Settings
Complete the following steps to configure the serial settings on the enabled registers:     
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 1. Click  Serial Settings.         

Figure 8-1.   Serial Settings               

 2. Select a protocol from the Protocol drop-down list: either Mercury or Modbus RTU.         

 3. Complete one of the following, depending on the protocol selected in the Protocol field:         

 a. For Mercury protocol, select a device from the Instrument Type drop-down list: either 
Mini-AT or Mini-Max.               

 b. For Modbus RTU protocol, enter a unit address in the Unit Address field: a number from 
1 to 9.               

 4. Select a baud rate from the Baud Rate drop-down list: 115200, 19200, or 9600.         

 5. Enter a value for delay in the Delay field.         

 6. Select a parity from the Parity drop-down list: either None or Even.         

 7. Click  Save to save settings or  Cancel to clear all fields.         

Enabling or Disabling Readings
Registers must be enabled through Bullhorn Tools as well as on the Bullhorn Web account. When 
the register is enabled through Bullhorn Tools, a reading is captured for that register. Then, when 
data is sent to the Bullhorn Web account, that value is decoded, paired with the same enabled 
register that was enabled through Bullhorn Tools, and then displayed on the unit's Unit Detail page.     

Enabled registers on Bullhorn Web will only display correct data if the corresponding register was 
enabled through Bullhorn Tools.     
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Complete the following steps to enable or disable unit Readings (registers).     

 1. Click  Readings.         
Double-click Readings or click the expand arrow next to Readings to show the enabled 
readings.         

Figure 8-1.   Enable/Disable Readings         

 2. To enable a reading, select Enabled.         

 3. To disable a reading, select Disabled.         

 4. Click   Save to save settings or  Cancel to clear all fields.         

 5. Click  Refresh to update the information. Enabled Register information will update.         



RM3000 Series

Chapter 8: RM3250 Configuration 80

Figure 8-2.   Unit Overview with Register Readings         

Configuring Readings
Complete the following steps to configure the enabled registers and the digital input:     

 1. Click the name of the register under  Readings.
Only enabled registers display in the list.         

 2. For each enabled register, complete the following fields in the Register Settings pane: 
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Figure 8-1.   Register Settings       

 a. Item Number — user-defined number for the register.               

 b. Scale — sets a scaling value for the register's value when read from the meters, which is 
multiplied or divided by factors of 10. Accepted scaling values include 0.00001, 0.0001, 
0.001, 0.01, 0.1, 1, 10, 100, 1000, 10000, or 100000.               

 3. Click  Save to save settings or  Cancel to clear all fields.         

 4. For digital inputs, complete the following configuration steps in the Digital Input 1 pane:         
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Figure 8-2.   Digital Input Settings and Alarms         

 a. The Input State is a fixed field.               

 b. Enter a value (in milliseconds) to set how long the input must remain in a state other 
than the current state before an alarm is sent in the Input Persistence field.               

 c. To set an alarm that will send an alarm packet to your Bullhorn Web account whenever 
there is a change to the Input State, enable one or both of the alarms (Open or Closed).
               

 5. Click   Save to save settings or  Cancel to clear all fields.         

 6. Click  Refresh to update the information.         

Sending a Test Message
Complete the following steps to send a test message to the Bullhorn Web account:     

NOTE: After the batteries have been connected, the unit sends a Startup packet to the Bullhorn 
Web account. Refer to Installing the RM3250 on page 22.       

 1. Click the  Send Test Message button or select Action > Send Test Message.         

 2. In the Info message window, click OK.         
A packet is sent to your Bullhorn Web account with current data point information. View the 
packet (labeled Test) on the Unit Detail page, under the Incoming Packets tab.         
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Figure 8-1.   Unit Detail on Bullhorn Web

Working with Templates
After configuring a unit, the settings can be saved in a template. You can use the template to set up 
another unit of the same type. The saved templates can also be exported to your computer or 
deleted.     

 l Creating Templates on page 83

 l  Importing, Exporting, and Deleting Templates on page 84

Creating Templates
Complete the following steps to create a new template:     

 1. Click File > Create Template.         

 2. Enter a name for the new template in the Name field.         
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Figure 8-1.   Create New Template     

 3. Click  Save to save settings or  Cancel to reset all fields.         

Importing, Exporting, and Deleting Templates
Saved templates can be imported or exported to your computer or deleted from Bullhorn Tools.     

Complete the following steps to import, export, or delete a template:     

 1. Click File > Template Management.         

Figure 8-1.   Template Management         

 2. To import a saved template from your computer, click Import. Browse to the saved 
template and click Open. The template is added to the list of available templates.         

 3. To export a saved template to your computer as a Bullhorn Template (.bht) file:         

 a. Select the template from the Select template drop-down list.               

 b. Click  Export.               

 c. Select a destination for the file, and then click Save.               

 4. To delete a template, select the template from the drop-down list and click  Delete.         
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Figure 8-2.   Template Management - Select Template         

Upgrading RM3250 Firmware
Available upgrades to the RM3250 firmware can be applied to the unit using Bullhorn Tools. 
Complete the following steps to upgrade unit firmware:     

NOTE: Contact the Technical Services team for more information on the latest firmware available.       

 1. Click Action > Upgrade Firmware.         

Figure 8-1.   Upgrade Firmware         

 2. Click Browse to search for the firmware file. This file should have the extension .bhf.

 a. Open the firmware file.               

 b. Click Send.               

After the upgrade process is complete, the unit will reset. If you are using a Bluetooth 
connection with Bullhorn Tools, you may have to re-activate the unit.        

 3. To verify that the firmware was updated, click the unit name in the navigation pane. Firmware 

mailto:bhtechservices@aiworldwide.com
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Version is displayed in the Unit Information pane of the Unit Overview window. The firmware 
version number should match the version you just sent to the unit.         

Figure 8-2.   Firmware Version         

De-activate Bluetooth
The unit will disconnect automatically after 10 minutes. It is not necessary to swipe the activation 
point again unless you wish to de-activate the Bluetooth connection immediately.     
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Appendix A: Firmware Updates
When firmware updates are available, they can be applied to the unit using one of the following 
methods:

 l Bullhorn Tools software or mobile app ꟷ the RM3250 can be upgraded using either of the 
Bullhorn Tools applications. Refer to Upgrading RM3250 Firmware on page 85 for more 
information.

 l The Field Update Tool (FUT) ꟷ the RM3011 and RM3012 use a FUT to update the unit's 
firmware. The FUT includes a 10-pin ISP (In System Programming) connector. It may take 
between 50 seconds and 5 minutes to update the firmware.     

WARNING: The firmware on the FUT device is compatible ONLY with the type of unit identified on 
the label of the FUT device. Also make sure NOT to update the with an older version of firmware. 
Use the UCT software to compare the firmware version of the unit with the firmware version on the 
FUT label.       

Use the FUT to update firmware on the following RM3000 Series units:

 l Updating RM3011 Firmware on page 87

 l Updating RM3012 Firmware on page 89

Updating RM3011 Firmware

WARNING: To prevent electrostatic discharge (ESD) damage when handling electronic equipment, 
always wear an anti-static wrist strap attached to an unpainted, grounded metal object. Ensure the 
wrist strap has maximum contact with bare skin. If an anti-static wrist strap is unavailable, discharge 
static electricity from yourself and your clothing by touching a grounded metal object before 
handling electronic equipment.       

Complete the following steps to update the RM3011 firmware:     

 1. Open the enclosure of the RM3011 and then verify the unit is receiving power.         

 2. Run the UCT software and then record all RM3011 configuration settings including the 
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accumulator value, if applicable.         

 3. Exit the UCT software and then disconnect the configuration cable from the RM3011.         

 4. Plug one end of the provided FUT cable in the ISP connector on the RM3011. Plug the other 
end of the cable in the 10-pin connector on the FUT. 

IMPORTANT: Do not disconnect the FUT cable during the firmware update. If the cable 
disconnects, reconnect the cable to restart the process.       

 5. Verify the update process by viewing the following LEDs (light emitting diodes) on the FUT 
device: 

Figure A-1.   LED Lights            

 l Yellow Activity Indicator: Begins flashing five (5) seconds after connecting the cable. 
FUT device is verifying if the RM3011 requires updating.               

 l Red Status and Yellow Activity Indicators: Red LED turns ON, and yellow LED flashes 
during the update.               

 l Green Status Indicator: Green LED turns ON when update completes or if the firmware 
does not require updating.               

 l When the green status indicator turns ON, disconnect the cable from the FUT device 
and the RM3011.               

 6. Power cycle the unit.         

 7. Run the UCT software and then complete the following steps:         

 a. Reconfigure the time.               

 b. If applicable, reconfigure the accumulator value.               

 c. Verify all configuration settings are correct.               

 8. Secure the enclosure covering.         
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Updating RM3012 Firmware

WARNING: To prevent electrostatic discharge (ESD) damage when handling electronic equipment, 
always wear an anti-static wrist strap attached to an unpainted, grounded metal object. Ensure the 
wrist strap has maximum contact with bare skin. If an anti-static wrist strap is unavailable, discharge 
static electricity from yourself and your clothing by touching a grounded metal object before 
handling electronic equipment.       

Complete the following steps:     

 1. Place RM3012 on a flat surface.         

 2. Use a screwdriver to loosen the screws at each corner of the enclosure top.         
You do not need to remove the screws from the enclosure; only loosen enough to remove 
cover.         

Figure A-1.   Enclosure Cover Screws         

 3. Remove cover and set next to enclosure bottom.         
The RM3012 internal battery should still be connected and supplying power even if external 
DC source is terminated.         

 4. Run the UCT software and then record all RM3012 configuration settings including the 
accumulator value, if applicable.         

 5. Exit the UCT software and then disconnect the configuration cable from the RM3012.         
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 6. Plug one end of the provided FUT cable in the ISP connector on the RM3012. Plug the other 
end of the cable in the 10-pin connector on the FUT. 

IMPORTANT: Do not disconnect the FUT cable during the firmware update. If the cable 
disconnects, reconnect the cable to restart the process.       

Figure A-2.   ISP Connector               

 7. Verify the update process by viewing the following LEDs (light emitting diodes) on the FUT 
device:         

Figure A-3.   LED Lights            

 l Yellow Activity Indicator — begins flashing five (5) seconds after connecting the cable. FUT 
device is verifying if the RM3012 requires updating.         

 l Red Status and Yellow Activity Indicators — red LED turns ON, and yellow LED flashes 
during the update.         

 l Green Status Indicator — green LED turns ON when update completes or if the firmware 
does not require updating.         
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Appendix B: Battery Replacement
The RM3012 backup 12 volt sealed, rechargeable battery that is installed inside the enclosure can be 
replaced.     

CAUTION: If the RM3012 is operating in low power mode or if power is terminated to the 
RM3012, the unit will be unable to send any information to Bullhorn Web.       

Replacing the Backup Battery

WARNING: To prevent electrostatic discharge (ESD) damage when handling electronic equipment, 
always wear an anti-static wrist strap attached to an unpainted, grounded metal object. Ensure the 
wrist strap has maximum contact with bare skin. If an anti-static wrist strap is unavailable, discharge 
static electricity from yourself and your clothing by touching a grounded metal object before 
handling electronic equipment.       

Complete the following steps:     

 1. Turn OFF DC power to the RM3012.         

 2. Power off the RM3012 by disconnecting the cable assembly from the 9-pin connector.         

Figure B-1.   RM3012 Connector         

 3. Place RM3012 on a flat surface.         

 4. Use a screwdriver to loosen the screws at each corner of the enclosure top.         

 5. You do not need to remove the screws from the enclosure; only loosen enough to remove 
cover.         
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Figure B-2.   Enclosure Cover Screws         

 6. Remove cover and set next to enclosure bottom.         

 7. Disconnect battery connection.         

Figure B-3.   Battery Connection and Bracket         

 8. Remove battery bracket screws.         

 9. Remove battery bracket.         

 10. Remove battery.         

 11. Place new battery in enclosure and replace battery bracket. Ensure that the battery cable is free 
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from the bracket.         

 12. Replace the cover over the battery compartment. Ensure that the battery cable and connector 
are secure in enclosure.         

 13. Tighten the four (4) corner screws on cover.         

 14. Reconnect input wiring to 9-pin connector         

 15. Turn DC power ON to restore power to field wiring.         
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Appendix C: Technical Specifications
The technical specifications for the following RM3000 Series units include important information to 
consider before installing or configuring a unit for service. If available, American Innovations parts 
numbers are included for reference. If you need to order new or replacement parts or accessories 
for any unit, please contact the American Innovations sales team at sales@aiworldwide.com. 

 l RM3012 Technical Specifications on page 94

 l RM3250 Technical Specifications on page 94

RM3012 Technical Specifications
This appendix includes technical specifications for the RM3012 and any included parts.     

 l Inputs
 — up to sixteen 6-digit register readings

 — eight 12-digit registers readings

 — or combination of both

 l Power — 12 - 36 V DC input with backup battery

 l Included Parts: 

 — four mounting magnets 

 — circular 9-pin cable assembly 

 — oil sensor switch      

RM3250 Technical Specifications
This appendix includes technical specifications for theRM3250 and any included parts.     

mailto:sales@aiworldwide.com?subject=Product Inquiry
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 l Environmental conditions:         

 — Indoor or outdoor use         

 — Maximum altitude: 3,000 m         

 — Temperature range: -30° C to +60° C         

 — Units can be used in 100% humidity (rain)         

 l Inputs — 10 registers and 1 digital dry contact closure         

 — Dry contact: 

 ¡ 100 μA source current

 ¡ Maximum cycle rate = 8 cycle/s; minimum state change duration = 125 ms  

 — Digital input:         

 ¡ Accumulates up to a 9-digit reading         

 ¡ Minimum Logic 1 = 1 V; maximum Logic 0 = 800 mV         

 ¡ Accumulator: maximum rate = 8 count/second         

 ¡ Minimum state change duration = 125 ms         

 l Interconnect cable — Belden 5308UE; 300 Vrms; rated FT4; 600 V - 105° C, or equivalent.         

 l Battery — Specified batteries shall be used - part number 517206-000 (included).         

 l Included Parts:         

 — dome assembly (part number 826552-000)         

 — flat base adapter (part number 517208-000)         

 — batteries, set of 2 (part number 517206-000):         

 — Li-Ion, 7.4 V, 2.0 Ah capacity         

 — Lithium, 3.6 V, 13.0 Ah capacity         

 — American Innovations USB dongle (part number 626595-000)         
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Appendix D: Equipment and Regulatory 
Notices
The following regulatory notices pertain to the RM3000 Series  remote monitoring units included in 
this User Guide:     

 l RM3250 Equipment Notes on page 96

 l FCC Requirements on page 96

 l Export Control Classification Number on page 97

RM3250 Equipment Notes
This equipment is suitable for use in Class I, Division 2, Groups A, B, C, D Hazardous Locations or 
Non-Hazardous Locations only.     

The RM3250 are intended for transmissions at a frequency of no greater than once per hour.     

FCC Requirements
The following FCC requirements are met by the products described in this guide.     

This equipment has been tested and found to comply with the limits for a Class B digital device, 
pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection 
against harmful interference in a residential installation. This equipment generates, uses, and can 
radiate radio frequency energy and, if not installed and used in accordance with the instructions, 
may cause harmful interference to radio communications. However, there is no guarantee that 
interference will not occur in a particular installation. If this equipment does cause harmful 
interference to radio or television reception, which can be determined by turning the equipment off 
and on, the user is encouraged to try to correct the interference by one or more of the following 
measures:     

 l Reorient or relocate the receiving antenna.         

 l Increase the separation between the equipment and receiver.         
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 l Connect the equipment in an outlet on a circuit different from that to which the receiver is 
connected.         

 l Consult the dealer or an experienced radio/TV technician for help.         

Export Control Classification Number
The Export Control Classification Number (ECCN) assigned to the Bullhorn Tools software by the U.S. 
Bureau of Industry and Security (BIS) is as follows:     

 l ECCN Classification: No Classification         

 l ECCN Code: EAR99 or NLR         
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