
PCS Technical Document:  
Setting Up For a Pipeline Compliance System (PCS)-Bullhorn (BAT) 
Interface 

The Bullhorn Super Extract is an optional report that contains data from Bullhorn remote 
monitoring units so they can be imported into PCS program, and finally into any of its module 
facility types. The report transmits from a Bullhorn user's Bullhorn Asset Tracker (BAT) web 
account to an FTP (file transfer protocol) site for PCS import. Importing the report requires 
correct set-up in both PCS and BAT. This document explains how to setup and import Bullhorn 
Super Extract reports.  
 
Topics covered in this document include:  

• Section 1: Verifying FTP Settings 
• Section 2: PCS System Settings 
• Section 3: Bullhorn Asset Tracker (BAT) website – Unit Setup 
• Section 4: Setting Up a BAT Unit Group 
• Section 5: Setting Up the BAT Super Extract Report 
• Section 6: PCS Bullhorn Interface Feature 

 
Note: The Bullhorn Super Extract report now uses the .bul file extension. In previous versions of 
PCS, the report used the .dat file extension instead. PCS 7 supports both file extensions.  

Section 1: Verifying FTP Settings 

PCS Version 7 allows the user to choose to FTP or Email settings for the Super Extract report 
within BAT.  If users employ a FTP server other than American Innovations’ FTP server, the 
following must be in place before setting up communication between PCS and BAT:  
 

 

• The IT network administrator has setup the FTP server with “write” access privileges for 
the BAT website. This allows Bullhorn Super Extract reports to transfer to a folder on the FTP 
server.  

• The IT network administrator has assigned the user “read/write” access privileges to the 
folder that stores Bullhorn Super Extract reports. This allows the user to import reports 
when running the PCS Bullhorn Interface command (read-only function). It also allows 
users to manage processed Bullhorn Super Extract reports, including  deleting or moving 
processed reports. 

• The IT network administrator has provided the user with the following information: 
• FTP site URL.
• The name of the folder on the FTP server that stores Bullhorn Super Extract 

reports.
• The User Name and Password for the FTP site that allows the user to access the 

FTP server and folder designated for the report. 



 
In order to ease this process, American Innovations can host an FTP site for the customer for a 
one-time setup fee and will provide the above settings and permissions as noted above.  
Please contact a PCS or Bullhorn Technical Services for details.    
 
Note:  FTP is an abbreviation for file transfer protocol.  It is the protocol format used for 
exchanging files over the Internet. URL is an abbreviation for uniform resource locator. It refers 
to an address on the Internet, such as an FTP URL or FTP site address. 

  
 
Section 2: PCS System Settings 

This section explains how to set up the PCS System Settings for importing Bullhorn Super Extract 
reports. Two methods are available for importing the report:
 
1.  Import the report directly from the FTP server.
2.  Import the report from a folder on a network drive or the user's computer hard drive.  

To set up PCS System Settings: Bullhorn 

 

If PCS is not running, click Start > Programs > Pipeline Compliance System to start the 
software and login. 
 

 

1.  Click Tools > System Settings.
2.  Click the Bullhorn tab. 

 
  

 



     4.  

    3.  In the Setting column for the field "American Innovations customer ID", enter the Bullhorn 
         Client ID. This information is assigned to a user by American Innovations for logging in to BAT.  If this  
         information is not available, please contact Technical Services for assistance. 
 

 

In the Setting column for the field "Assign Bullhorn Inspections to a Periodic Survey based on 
         the Survey Date", click the check box if inspection readings automatically linked to a 
         periodic survey based on the inspection survey date are desired. 
  
Note: A check mark inside the check box indicates a selection. To cancel a selection, clear the 
check mark by clicking the check box again.  
 

 

    

 

 
     5.  In the Setting column for the field “Bullhorn download from a disk drive”, complete one of 
          the following steps: 
 

   a. Type the network path of the shared folder in the form of \\server name\shared folder 
   to import Bullhorn Super Extract reports from a shared folder on a company network. 

 



 
   

   b. Type the drive letter and folder path in the form of c:\folder name to import Bullhorn 
   Super Extract reports from a folder to a user's computer hard drive. 

   

 

 
 



Importing Bullhorn Super Extract reports from an FTP server  
 
To import the Bullhorn Super Extract Reports, following these steps:  
 

 

1. In the Setting column for the field "Bullhorn FTP site URL", type the address of the FTP 
site where Bullhorn Super Extract reports will be stored in the form of 
ftp site: ftp.servername.com. The address is either the AI FTP site at 
ftp.bullhornsys.com or the address of the user's company FTP site. 

 

2. In the Setting column for the field "Bullhorn FTP site folder", type the name of the 
folder on the FTP server where Bullhorn Super Extract reports will be stored.  
Note: If using the AI FTP site, use the folder name provided by AI. If using a company 
FTP server, use the folder name provided by the company’s IT network administrator.  

3. In the Setting column for the field "Bullhorn FTP site password", type the password 
required to access files on the FTP server. 
Note:  Use the password provided by AI if you are using the AI FTP site. If planning on 
using the company’s FTP server, use the password provided by the company’s IT network 
administrator.  

4. In the Setting column for the field "Bullhorn FTP site username", type the user name 
required to access files on the FTP server. 

 
      Note: If using the AI FTP site, enter the username provided by AI. If using a company FTP server, 
      use the folder name provided by the company’s IT network administrator.   

 
5.  In the Export Setting column, click the check box for each setting to include in a PCS 
     export file (File > Export Data).  
 
 Note:  If using the optional two-way synchronization feature, settings also export during 

replication with other PCS users.     
     



 

Verifying PCS Facility ID and Bullhorn-Engineering Unit 

Certain fields in PCS must match certain fields in BAT to successfully populate a PCS data grid 
with data in a Bullhorn Super Extract report. They include the fields identified in the following 
list:  
 

 

• The "Facility ID" field in a PCS data grid must match the "Serial" field on the BAT.  The 
PCS facility type (Test Point, Rectifier, Inhibitor, etc.) for a location with the field called 
“Facility ID” has to match on the BAT Unit>Unit Details>Settings and the field called 
“Serial”.  Note: Fields are not case-sensitive.  

 

• "Bullhorn-Engineering Unit" in the PCS Field and UDF (User Defined Field) Customization 
must match the "Channel Engineering Unit Label".  The description in the "Bullhorn-
Engineering Unit" field of the PCS>Tools>Data Utilities>Field and UDF Customizations 
grid must match the description in the Unit Admin>Channel>Engineering Unit Label 
field of the BAT website for EACH channel appropriately.  These fields are not case-
sensitive but are required to have the same punctuation such as underscores and 
hyphens. 

 
Measurement data populates a PCS data grid based on the "Facility ID" and the data attribute 
based on the Bullhorn-Engineering Unit description. The Bullhorn-Engineering Unit description 
identifies the data grid such as "Rectifier Inspections" for the field "Rectifier Output Current 
Found" or "Rectifier Volts Found", while the "Facility ID" identifies the milepost or station 
number. 
 
When the import completes, PCS adds "Bullhorn Inspection in the Survey Remarks" column of 



the data grid to identify which inspection readings were imported from a Bullhorn Super Extract 
report.  
 
A list of default PCS descriptions for Bullhorn-Engineering Unit are identified in the next table, 
along with the corresponding facility type and data grid column. 
 

Facility Type Data Grid Column 
Bullhorn-Engineering 
Unit  

Test Point Casing IRF CASING IOX 

 Casing P/S CASING 

 Foreign IRF FOREIGN IOX 

 Foreign P/S FOREIGN 

 Insulator IRF INSUL IOX 

 Insulator P/S INSUL 

 Structure IRF P/S IOX 

 Structure P/S P/S 

Rectifier Rectifier Output Current 
Found 

AMP 

 Rectifier Output Volts Found VOLT 

 Negative Current Found NEG 

Foreign Bond Bond Current Found BOND 

Probe Probe Corr. Rate PROBE RATE 

Inhibitor 
Injector 

Quantity INJECTOR RATE 

 

To view or edit default Bullhorn-Engineering Unit descriptions 

 

If part of a PCS two-way system, only PCS administrators can do some of the following steps on 
the master database.  Users may only have the ability to view these settings, not change them. 
 



Note:  It is important that two-way users and all the field techs use the same naming convention 
for all components below for each of their BAT website accounts. 
 
PCS v6 was designed to look only for rectifier channel Engineering Units set to "DC_Volts" for 
"Rectifier Volts Found" and "DC_Amps" for "Rectifier Volts Found".  All other field defaults in 
the above table are the same.  For this reason, most customers that have migrated to PCS v7 
have had to Edit the "Rectifier Output Volts Found" and "Rectifier Output Volts Left" from 
“Volt” to “DC_Volts”.  This also applies to editing the "Rectifier Output Current Found" and 
"Rectifier Output Current Left" from “Amp” to “DC_Amps”. 
 

 
 
Update the Bullhorn - Engineering Unit field for each as indicated below. 
 

 



The user can change any default description in the Bullhorn-Engineering Unit column as needed. 
However, use the same description in the BAT website for the Unit 
Admin>Channel>Engineering Unit Label field when setting up the BAT web site for EACH 
channel. 

Creating Custom User Defined Fields in PCS for Bullhorn monitored sites 

With PCS running, Click Tools > Data Utilities > Field and UDF Customizations.  
 

 

When the grid opens, expand the CPDM folder and then select the name of a data grid. For 
example, click CPDM > Test Point > Test Point Inspections.  For example, see the image below 
for User Defined Fields for Coupon Test Stationat which Bullhorn is monitoring  AC mitigation 
point data.  The Bullhorn – Engineering Unit field for each of the new fields are NOT populated 
but users can enter a name (15 characters in width) that AI Technical Services has confirmed for 
each of the fields being monitored by Bullhorn channel(s). 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
If the Bullhorn-Engineering Unit column does not provide a description that the user would like 
to use as a data point from a Remote Monitor Unit (RMU) for a reading field, then the user can 
add a description for as many reading fields as needed.  See the example below, where UDFs 
were called "Coupon TS – ON P/S AC", "Coupon TS – AC Current Density", and "Coupon TS – AC 
DeCoupling Drain".  The Engineering Unit Label field in the BAT website will also need to be 
set up with the same description used in PCS. 
 

 
 
 
 

 

 

 

 

 



 
Section 3: Bullhorn Asset Tracker (BAT) website – Unit Setup 

This section outlines a typical Bullhorn RMU unit configuration for the Bullhorn Interface.  The 
following process explains how to set up the Bullhorn "Unit Admin Serial" field to match up with 
the PCS "Facility ID" in the appropriate facility type and location based on the "Channel 
Engineering Unit Label" field. 
 
To begin the process, go to the BAT website at:  http://www.bullhornsys.com and login.  View 
the account and select a Bullhorn unit that needs to be edited to support the Super Extract 
report settings needed for a Bullhorn Interface.  Users may have to go through multiple pages 
to locate the unit.    

 

Setting Up the BAT Serial field to match PCS Facility ID 

This section will be based on the selection of "New Unit in Hobbs, NM" from the previous 
screen. 
 

http://www.bullhornsys.com/�


 
 
After selecting the desired BH unit, click "Settings". 
 

 
 
Populate “Name" with appropriate location information and any other fields.  The “Serial” field 
has to match the “Facility ID” from PCS.  Click “Save” when finished. 



 
 

BAT Channel Engineering Unit Label Configuration 

Click the Template tab and choose a template from the list.  If no templates have been created, 
please contact Bullhorn Technical Services for assistance. 
 

 
 
 
 
 



After selecting the template from the list check to see if the items are correct. Click Apply.  An 
Apply Template message displays, asking to apply these settings. Click Yes.  The channels in red will be 
disabled. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
After applying the template, the user will get an "Applied" confirmation and the channels on 
the left will be updated with how the template was setup. 
 

 
 
 
 
The template in the example below was setup to monitor a rectifier for "Channel 1 Analog - 
Rectifier Total Amps" and "Channel 2 Analog – Rectifier Volts".  The user can have more 
channels (depending on Bullhorn model) setup for different data such as Negative(s), or 
channels for Bond data where Bond Current could be coming in on Channel 1, Structure P/S on 
Channel 3 and Foreign P/S on Channel 4.  A buried permanent reference cell is required to read 
and monitor pipe-to-soils. 
 
The channel setup can be accessed by clicking the "Channel 1 Analog [Input 1]" or in the case of 
the example below "Channel 1 Analog [Rectifier Total Amps]". 
 
The Data Point tab shows the user can update the Alias field to "Rectifier Total Amps" to better 
describe the channel at that location.  The Engineering Unit Label can be set to "DC_Amps", 
which matches PCS Bullhorn Engineering Unit setting for the "Rectifier Output Current Found" 
field. 



 
 
 
The channel 2 setup can be accessed by clicking the "Channel 2 Analog [Input 2]" or in the case 
of the example "Channel 2 Analog [Rectifier Volts]". 
 
The Data Point tab shows the user can update the Alias field to "Rectifier Volts" to better 
describe the channel for the user at that location.  The Engineering Unit Label can be set to 
"DC_Volts", which matches PCS Bullhorn Engineering Unit setting for the "Rectifier Output Volts 
Found" field. 



 
 
 As indicated, the user can set up more than two channels for rectifiers and can have channel 3 
monitor negative current, as pictured in the screen shot below. 
 
 
 
 
 
 
 
 
 
 

 



Alias is set to what the user calls one of the negatives, and the Engineering Units Label is set 
with the word negative "Blue".  During the Bullhorn Interface process, PCS looks for keywords 
such as “NEG” or “negative” and looks for the 8 characters after the space.  If the user has NEG 
CRUDE 10 in BAT, PCS should have a Negative called "CRUDE 10" and the data from the Super 
Extract report would be populated at a Rectifier "Facility ID" called "BLGD-MP-283" during the 
Bullhorn Interface process. 
 
Other channel settings can be configured depending on the application and Bullhorn product.  
Refer to the table in Section 1.   
 
Configure all unit channels as indicated above before moving on to the next step. 

Section 4: Setting Up a BAT Unit Group 

The BAT website dashboard view defaults to an "All Units" group where all unit types are visible 
upon login.  Users can setup groups as needed by Systems, Tech Area and more.  Different 
permissions can be set for each user and the corresponding Unit Groups as indicated by the 
account administrator.  The following process explains how to create a new unit group with 
Bullhorn units to include in the Bullhorn Super Extract report.  Users can select the All Units 
default group or create additional groups specifically for the Super Extract report. 

To Create a New Unit Group 

 

After BAT login,  click Units>Unit Admin 
 

 
 
 



 
 
 
 

Then, click Add for the units to add to the group. 

 



 
Type in the name of the group, such as "Southern Region", and click the green + sign. 
 

 
 



The group is created, and the user can continue with another group name or close the Add 
Group dialog box. 

After closing the Add Group dialog box, double-click the new group called: "Southern 
Region" and click the Add button. 
 

 
 
 
At the Add Unit/Group dialog, the user can create sub-groups or Select Units for the 
designated group (" Southern Group").  Users can search for units to add by using the Search 
function. Search can only locate units by Unit Name, ID, Type, Serial, or System Serial not in 
current group.  In the example below, the user searched for "RM4020" and received the 
following results.  



 
 
Double-click the units to include in the group, which will move the selections to the right-side, 
or highlight the unit(s) by using holding down the CTRL key and multi-selecting the units on the 
left side and then click the right arrow in the middle to move these units to the right side.  
When finished selecting units, click the Add Units button. 



 
 
The "Southern Region" group is updated with the selected units.  If correct, click 
the “X” to exit the Add Unit/Group dialog box. 
 

 

Double click to 
move units from 
this box to the 
next 



Setting Up the BAT Super Extract Report 

The following process explains how to setup the Bullhorn Super Extract report with a unit 
group. 
 

 

From the BAT home page, click on the menu tab called Reports>Extract. 
 

 
 
If the user has already created Extract report(s), they will be listed.  If none have been created, 
it should look like the following: 
 

 
 
Click the Add New Report button. 
 



 
 
Populate the "Extract Name" field and choose the "UnitGroup To Use".  If this Extract report is for an 
FTP site hosted by American Innovations (AI), an AI representative would have sent you the 
following settings, which are the same settings used  in the PCS System settings: 
 

 
 
The fields for the FTP will need to be populated using these settings:   
 
      •  Default Folder Name – Bullhorn FTP site folder (ACME) 
      •  FTP Destination - Bullhorn FTP site URL ( ftp.bullhornsys.com) 
      •  User ID – Bullhorn FTP Site username (ACME) 
      •  Password – Bullhorn FTP site password (123456) 
 
Other Extract report settings include: 
 

• PCS 6 or PCS Generic.  This setting will be dependent on the PCS version.  For PCS 

ftp://ftp.bullhornsys.com/�


version 6 choose "PCS 6".  For PCS version 7 and later, choose "PCS Generic". 
• Email or FTP.  A user can have the report emailed to him if PCS is setup for 

this option.  The FTP option requires all the settings mentioned above.  To select both 
options, the user must set up two Extracts, one for email and one for FTP.  Note:  The 
BAT Super Extract report(s) will charge the user account $20 for each report based on 
the frequency chosen in the setup. 

• Records to include.  This option sets a filter or queries the data stored on BAT website 
for the account and designated group as indicated below in the drop-down box.  A 
typical choice is "Latest Non-Alarm Record per unit in period". 

 

 
 

• Initial Run Date.  This setting has to be set sometime in the future on the day of the 
month desired.  Based on the "Records to Include" setting, the report will have the 
latest non-alarm reading for each unit of "Southern Region" group.  Depending on when 
each Bullhorn unit was set up to transmit (typically weekly for rectifiers), the report 
should have a reading for each unit in the last week of June 2011. 

 



 
 

• Re-run the Extract Every.  This setting tells BAT to run the report starting with "every 
hour" to "every two months".   

• Initial Run Time.  This setting tells BAT the time of day to run the report.  Note:  Users 
can choose an "off time", such as 1am, to minimize network traffic. 

• Time Zone.  This is to account for the user's time zone.  
• Observe Daylight Savings Time.  This adjusts the time for states that observe Daylight 

Savings Time. 
 

 
 
Click the Add button to create this extract report.  To Edit the report, the user can click the 
pencil icon to modify the settings.  To create another report, click on the Add New Report. 
 



 
 
The user can also run the report as On-Demand by clicking the right arrow next the pencil.  The 
user can also delete the report by clicking the minus sign. 

Section 6: Performing the PCS Bullhorn Interface 

Once the earlier steps are complete the user can test and run the Bullhorn Interface.  AI 
suggests that first-time users contact PCS Technical Support to assure everything is set up 
correctly before running reports.  Users should always perform a PCS backup prior to running 
the Bullhorn Interface to ensure all settings are correct and the expected data is processed 
correctly.  There is a Bullhorn Log that will help the user determine what was processed and 
what was not (under "Tools" tab). 
 

 

To perform the Bullhorn Interface in PCS, click Tools>Bullhorn Interface.  Based on the system 
settings configured in PCS, the software will make the connection, read the files that have yet 
to be processed in the database from the location selected, close the connection and start 
processing the files from BAT into the PCS database. 
 



 
 

 
 
 
The user can view the "Bullhorn Log" to see how many records were processed and what 
locations were not in the PCS database. 
 



 
 
In the PCS "Rectifier Inspection Grid", the results of the query shows that the location specified 
is being monitored by Bullhorn units, that the data that was received from the units to the BAT 
website, and then was posted to the report for that period. 

 



 
For questions and assistance with PCS or BAT setup, contact American 
Innovations Technical Service at 512-249-3400. 
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