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Chapter 1: Getting Started
This guide explains how to set up and use American Innovations software installed on the Allegro QX. This 
chapter includes the following topics:     

 l Equipment List

 l Preparing the Allegro QX for Use on page 2

 l Overview of the Allegro QX Hardware on page 4

 l Overview of AI Allegro QX Software on page 6

 l Navigating an Allegro on page 7

 l Connecting to an RFID Pen on page 13

 l Al Allegro QX Documentation on page 14

 l Contacting Technical Services on page 14

Equipment List
Your Allegro QX ships with the following items:     

 l Rechargeable Lithium-ion battery pack        

 l AC wall charger         

 l Wall charger international adapter plugs         

 l DC car charger         

 l Micro-USB cable (6 ft)         

 l Screw driver         

 l Pen-style stylus         

 l Hand strap

 l SD card (comes installed in the Allegro)         

 l Digital Voltmeter (DVM) (comes installed in the Allegro)         
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Several optional add-ons are available for purchase. For a complete list of add-ons and accessories, 
contact AI Sales at 1-800-229-3404.     

Preparing the Allegro QX for Use
When you first receive the Allegro QX from AI, perform the following tasks to prepare the device for 
service:     

 l Install the Battery Pack

 l Transfer Utility Files to PCS on page 3

Install the Battery Pack

The battery compartment is located on the back of the Allegro QX. Charge the battery pack until 
completely full, about 2-4 hours.     

WARNING: Improper battery use may result in a fire, explosion or other hazard. Refer to the Allegro 2 
Owner's Manual by Juniper Systems, Inc. for additional battery handling information.       

Figure 1-1.   Allegro QX Battery Compartment     

 1. Battery door         

 2. Screws for the battery door         

 3. Battery compartment         

 4. Mini SIM card slot         

 5. Micro SD/SDHC card slot         
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 6. Battery pack         

 7. Positive ( ) connection symbol         

Complete the following steps to install and charge the battery pack:    

 1. Loosen the four captive screws holding the battery compartment door in place using a #1 Phillips 
screwdriver. Remove the door.         

The Allegro QX is not sealed against water and dust when the battery door is not installed.         

 2. If you are using a micro SD card for additional memory you can install it now before you install the 
battery pack.         

 3. Place the Lithium-ion battery pack in the compartment. Make sure the  symbols on the battery 
pack label align with the symbols inside the compartment. Push the battery pack down to secure it 
in place.         

 4. Replace the door and tighten the screws.         

 5. Plug the AC wall power charger that came with the Allegro QX into a wall socket. Plug the other end 
into the DC power jack on the bottom of the Allegro QX. The red LED on the keyboard blinks when 
the battery pack is charging.         

 6. The Update Time screen displays. Adjust the time zone, date, and time if necessary, and tap OK.         

Figure 1-2.   Update Time Settings         

Transfer Utility Files to PCS

Updated utility files are included with the Allegro QX installation to facilitate PCS integration. If you use 
PCS software with the Allegro QX, the utility files (wToCmd.exe and CeFileXfer.exe) need to be transferred 
from the Allegro QX device to the PCS executable directory on your computer.     

Complete the following steps:     
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 1. Navigate to your PCS executable folder. To find your PCS executable folder, right-click on the PCS 
shortcut in the Start Menu and select Properties. Click on the Shortcut tab and find the path to the 
PCS executable in the Target field. Click Open File Location to quickly navigate to the executable 
folder.         

 2. Connect the Allegro QX to your computer. Once successfully connected, browse the contents of 
the Allegro device using Windows Explorer.         

 3. Navigate to the folder \AI\PCS Interface Files on the Allegro device.         

 4. Copy the two files in the PCS Interface Files folder (wToCmd.exe and CeFileXfer.exe) and 
paste them in the PCS executable folder on your computer.         

Figure 1-1.   PCS Executable Folder         

 5. If prompted, click the option to replace and overwrite existing files.         

Overview of the Allegro QX Hardware
The Allegro QX includes a Digital Voltmeter (DVM), touchscreen display, keypad, and function keys. 
Optional add-ons are available for purchase. Contact AI Sales at 1-800-229-3404 for more information.     
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Figure 1-1.   Allegro QX Components 

Refer to the following topics for more information about the Allegro hardware components:

 l DVM

 l Connector Panel

DVM

The DVM is located at the top of the Allegro QX.     

Figure 1-1.   Allegro QX DVM     

The DVM supports the following connections:     

 l Remote trigger for data cane or wire counter (3-pin connector)         

 l DVM test leads         
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Connector Panel

The connector panel is located at the bottom of the Allegro QX.     

Figure 1-1.   Allegro QX Connector Panel 

Overview of AI Allegro QX Software
The Allegro QX ships with the following AI Allegro QX applications factory-installed. AI Allegro QX software 
version 7.2 is compatible with PCS software versions 7 and newer.     

               Digital Voltmeter (AiDvm)                            Close Interval (CeCi)             

Measures voltage and current.             Records potential readings for close interval (CI) surveys.             

DC Voltage Gradient (DCVG)                            Periodic Survey             

Records indications of pipeline coating defects.             Records voltage readings for annual and periodic surveys.             

Figure 1-1.   AI Allegro QX Software Applications Overview     
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Navigating an Allegro

 l Touchscreen Display

 l Keypad and Shortcut Keys

 l Allegro QX Icons and Soft Keys

Touchscreen Display

Use the provided stylus to tap the touchscreen and activate a software program or make a selection. 
Several system icons are available for selection that allow you to navigate to applications or perform 
actions.     

IMPORTANT: Avoid using sharp objects that may scratch or puncture the touchscreen display.       

The Allegro QX includes a high-contrast, pressure-sensitive display with an adjustable backlight. The 
touchscreen can be toggled on/off as necessary, especially when working in harsh conditions such as a 

rainstorm or in high brush. Press the BLUE shift and  keys to enable or disable the touchscreen.

You can also disable the touchscreen by pressing and holding the power key and selecting Disable TS 
from the list of options.     

Realign the Touchscreen Display

If the touchscreen does not respond accurately to stylus or finger taps, complete the following steps:     

 1. Tap Start > Settings > System > Screen.         

 2. Scroll down until you see the Align Screen button. Tap Align Screen.         
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Figure 1-1.   Realign Touchscreen         

 3. Tap Yes to go to the Touch Control Panel.         

 4. Tap the Mode that you will be using (Stylus, Finger, or Water), and then tap Load.         

 5. When the process completes, tap OK to close the current screen; tap OK again to return to the 
System menu.         

Keypad and Shortcut Keys

The Allegro QX keypad is similar to a computer keyboard. The keypad provides the following functionality:     

 l Alphanumeric and symbol keys for data entry on a QWERTY keypad.         

 l Left and Right Tab keys, Enter key, Space bar, and Navigation Wheel keys for moving the cursor.         

 l F1 through F6 keys to perform softkey operations in certain software programs.         

 l Blue and Orange keys that allow other keys on the keypad to perform special functions.         

Figure 1-1.   Allegro QX Keypad     

Refer to  Keyboard Shortcuts for a list of common keyboard shortcuts.     
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Allegro QX Icons and Soft Keys

The Allegro QX uses icons and soft keys for shortcuts to provide an alternate method for navigation during 
an Allegro QX session. Certain system icons regularly display when running software. For example, the 
Windows logo icon, OK, Menu, and keyboard icons all display when running any software. Other types of 
system icons are used to notify you of current operating status conditions, such as battery power status 
and software currently running on the Allegro QX. 

Figure 1-1.   Allegro QX Main Screen     

Title Bar and Pop-up Icons

The title bar is at the top of every screen. It identifies the page and shows status icons indicating functions 
like connectivity status, audio, power, and time. Tap the title bar to bring up larger, touchable icons in a 
horizontal-scrolling bar. Select an icon to use or to view the settings and adjust them as desired.     

Figure 1-1.   Title Bar and Pop-up Icons     
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Favorites Bar

The favorites bar consists of shortcuts to specific applications. It is located below the dashboard when the 
screen is in portrait mode and to the side of the dashboard when it is in landscape mode. Tap on a 
shortcut icon to launch an application.     

Figure 1-1.   Favorites Bar     

You can use the favorites bar to jump between the applications you use most. While running an 

application, press the  Home key and select a different application from your favorites. To return to the 

first application, press the  Home key again, then tap on the first application you were running.     

You can customize which application shortcuts are shown. Tap and hold on the shortcut you want to 
change to bring up a list of available applications.     
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Figure 1-2.   Applications for Shortcuts     

Tap on your selection. The icon on the home screen changes to the icon associated with the new 
application.     

Dashboard

The dashboard consists of a background image and up to six dashboard gadgets that serve as functional 
indicators and control keys.     

You can switch between two color schemes and select which gadgets are shown. Tap on the  soft key 
and select either Switch Color Scheme to change color schemes or Configure to select gadgets. In 
Configure mode, the current gadgets are covered with a blue symbol.     
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Figure 1-1.   Gadgets in Configure Mode     

Follow these steps to replace a gadget:     

 1. Top on a gadget's icon. A list of available gadgets displays.         

 2. Tap the name of gadget you want to display on the dashboard in place of the one selected in step 1. 
If you tap None, the space becomes blank.         

Tiles and Soft Keys

Touchable tiles (or soft keys) are shown in the tile bar at the bottom of each screen. Up to five tiles are 
shown, depending on which screen you are on.     
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Icon             Action             

Go to Startmenu.             

Navigate back.             

Minimize.             

Configure menu.             

Lock.             

Edit.             

Delete.             

On-screen keyboard.             

Table 1-1.  Tiles and Soft Key Actions       

Connecting to an RFID Pen
To connect to a supported RFID pen, do the following:     

 1. Open the Bluetooth COM application on the Allegro QX.         

 2. Turn on bluetooth for your RFID pen. For the Microsensys pen, press and hold the power button to 
turn both the pen and its bluetooth capabilities on.         

 3. In the Bluetooth COM application, click Discover Devices and select the RFID pen from the list. For 
the Microsensys pen, the name will start with iID PENsolid.         

 4. Click Connect. When the pen has successfully connected, take note of the COM port listed in the 
Port column.         

 5. In the Periodic Survey application, open Options, found in the View menu. Select the pen and its 
associated COM port from the drop downs available in the RFID tab.
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Al Allegro QX Documentation
An electronic version of this document and the software release notes are included with the software 
installation files for the Allegro QX and available in the American Innovations Support Site. Use Adobe 
Reader on a laptop or desktop computer to view the PDF documents.    

You can access Allegro QX documentation from either of the following places:     

 l Copy from the Allegro:            If the Allegro QX is not connected to your computer, connect the device. 
Once successfully connected, browse the contents of the Allegro device using Windows Explorer. 
Navigate to the folder \AI\Documentation and copy the files into a folder on your computer.

 l            AI Allegro Support Site: Access the Allegro QX section of the Support Site at 
http://support.aiworldwide.com/products/al2/index.htm.         

Contacting Technical Services
AI Support is available to provide assistance with Allegro QX, accept feedback about Allegro QX, or 
discuss your organization’s training needs. Use the following information to contact AI Support:

Telephone:

1-800-229-3404

Email:

support@aiworldwide.com

Address:

American Innovations, Ltd.
Attn: AI Support
12211 Technology Blvd.
Austin, TX 78727

http://support.aiworldwide.com/products/al2
mailto:support@aiworldwide.com?subject=AI Support
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Chapter 2: Digital Voltmeter (AiDvm)
The American Innovations Digital Voltmeter (AiDvm) measures voltage and current as a fully functional 
digital voltmeter (DVM) and as an integrated DVM to complement the following AI software: CeCi (close 
interval), DCVG (direct current voltage gradient), and Periodic Survey (annual/periodic survey).     

You can view measurements either in the main window of AiDvm or as a waveform graph. Optional 
settings are available for measuring current interrupter on/off potentials and operating in GPS Sync mode 
when using GPS-synchronized current interrupters.     

Tap Start > AiDvm to display the main DVM window.     

Figure 2-1.   DVM Main Window     

This chapter includes the following topics:     
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 l {Hyperlink-crossref}Safety Precautions{Default ¹ Font}

 l Connect Test Leads to the Allegro QX on page 16

 l Measure Voltage and Current on page 16

 l View the DVM Graph on page 19

 l View the Data Logger on page 21

Connect Test Leads to the Allegro QX
Plug the tests lead into the red INPUT and black COM connectors on the DVM.     

Figure 2-1.   Allegro QX Connections Configuration for DVM     

Measure Voltage and Current

 l Set Test Function, Voltage Range, and Sample Rate 

 l Set DVM Options

Set Test Function, Voltage Range, and Sample Rate

 1. Choose a test function by tapping Vdc, Vac, DC Amp, AC Amp, or AC mA.         

 2. Set the voltage range either manually by tapping the up or down arrow buttons or, tapping Auto to 
use autoranging instead.         

 3. Tap Options. If using autoranging, tap the drop-down arrow in the Minimum range field and select a 
minimum voltage range.         

 4. Tap the drop-down arrow in the Sample rate field and select either 50 Hz (European Standard) or 
60 Hz (US Standard). Tap Ok to save settings and return to the main DVM window.         
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Set DVM Options

To set the properties and other options for the currently selected test function, tap Options. The following 
tabs should be configured for the test function:     

 l Configure the On/Off Tab

 l Configure the GPS Tab

 l Configure the Amps Mode Tab

 l Configure the Data Logger Tab

Configure the On/Off Tab

On/Off options are only available with the Vdc test function.     

 1. If not already in the Options window, tap Options.         

 2. Tap the On/Off tab and tap Enable On/Off mode.         

 3. Select one of the following options in the Method field:         

 l HiLo — for an interrupted survey using non-GPS synchronized interrupters. An On/off 
High/low survey will sample 60 times per second and discard the most negative and least 
negative values in a cycle based on the On/Off Delays. Of the remaining values in the cycle, 
the most negative value will be on reading and the least negative value will be the off reading.
               

 l Gps-sync — for an interrupted survey using GPS synchronized interrupter with shorter on 
and off intervals.               

 4. If available, enter on/off times and cycle begins with settings to match those on the current 
interrupter in the ON time, OFF time, and Cycle begins with fields. The Cycle begins with field is not 
available with HiLo survey types.         

 5. When available, enter the delay times for the survey. These fields are not available for 
uninterrupted surveys. The following delay time fields may be available for interrupted surveys:         

 l On Delay is the amount of time after the off-to-on transition occurred. The On Delay 
determines the number of high (most negative) values that are discarded in a cycle. This field 
is available for HiLo survey types.               

 l On Setup is the amount of time before the on-to-off transition occurred, at which point the 
"on" reading is recorded. This field is only available for the Gps Sync survey type.               

 l Off Delay is the amount of time after the on-to-off transition occurred, at which point the "off" 
reading is recorded. This field is available for all interrupted surveys. For HiLo survey types, 
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the Off Delay determines the number of low (least negative) values that are discarded in a 
cycle. For Gps Sync survey types, the Off reading is the value that is recorded after the Off 
Delay time.               

 6. Tap Ok to save settings and return to the main DVM window or tap another tab to set additional 
properties.         

Configure the GPS Tab

 1. If not already in the Options window, tap Options in the main DVM window.         

 2. Tap the GPS tab.         

 3. Verify the Comm Port is COM8 (internal) and Baudrate is 115200.         

 4. Tap Ok to save changes and return to the main DVM window or tap another tab to set additional 
options.         

Configure the Amps Mode Tab

These properties need to be configured to measure current through an external shunt and should be 
configured when the DC Amp or AC Amp test function is chosen.     

 1. If not already in the Options window, tap Options in the main DVM window.         

 2. Tap the Amps Mode tab.         

 3. Complete one of the following steps:         

 l Tap as R value and enter a shunt resistance value in the Resistance field.               

 l Tap as Amp/mV values and enter a shunt size in the mV and Amps fields to have the DVM 
automatically calculate shunt resistance.               

 4. Tap Ok to save changes and return to the main DVM window or tap another tab to set additional 
options.         

Configure the Data Logger Tab

 1. If not already in the Options window, tap Options in the main DVM window.         

 2. Tap the Data Logger tab.         

 3. Tap Enable logging.         

 4. Set a time interval by tapping the drop-down arrow in the first Update interval field and selecting a 
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value (1-50). Tap the drop-down arrow in the second Update interval field and select a 
measurement of time (seconds, minutes, or hours).         

When recording an hour or more of data, use the external AC power adapter to prevent draining 
the Allegro QX battery. The automatic power-down feature of the Allegro QX is disabled during data 
logging.         

 5. Tap Browse to display the Save As window and complete the following steps:         

 a. Type a name for the file in the Name field.               

 b. Tap the drop-down arrow in the Type field and choose a file format.               

 c. Tap OK to save settings and close the Save As window.               

 6. Tap Append to include all readings in the file with the most recent reading at the end of the file.         

 7. Tap Timestamp to include a time stamp with each reading.         

 8. Tap Ok to save changes and return to the main DVM window or tap another tab to configure 
additional properties.         

When the data logger is active, DVM - Logging displays in the AiDvm AI-DVM title bar. To stop the data 
logging session, tap Options > Data Logger tab > Enable logging.     

View the DVM Graph
AiDvm displays the on/off interruption cycle in real-time as a waveform graph in addition to the digital 
display in the main DVM window.     

When using AiDvm during an on/off survey, tap Graph to view a waveform graph of the interruption cycle.     
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Figure 2-1.   DVM Graph     

The graph includes a status line below the reading. The status line identifies the voltage range, test 
function, and on/off method. If setup includes GPS Sync mode, the status line also identifies the number 
of satellites in view.     

For example, a status line of 5VDC DGPS (5) PZ indicates the following information:     

 l 5VDC: voltage range and test function         

 l DGPS: differential GPS is available         

 l (5): number of satellites in view         

 l P: PPS time signal has been received         

 l Z: ZDA message has been received         

Other indicators that may appear in the status line include the following:     

 l GPS (n): indicates GPS and the number of satellites in view         

 l HiLo: indicates high/low readings         



Allegro QX v7.2 User Guide

Chapter 2: Digital Voltmeter (AiDvm) 21

 l GPS (n HiLo): indicates GPS mode is selected but HiLo is used because the GPS signal is 
unavailable. The lowercase n represents the number of satellites in view.         

View the Data Logger
Unless specified differently during setup, data logger files save in the DvmData folder by default. To 
access the folder, tap Start > File Explorer > My Device > AI > DvmData. Tap the desired log file. The data 
logger file includes the following information:     

 l log file date and time stamp         

 l reading mode (on/off or single reading)         

 l readings with date and time stamp         

 l update interval and voltage range         

If AiDvm is setup in GPS Sync mode, GPS status is included in the log file. Readings include a lower case 
g next to the time stamp to indicate GPS time.     
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Figure 2-1.   Data Logger File     
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Chapter 3: Close Interval Survey (CeCi)
CeCi records pipeline potential readings for close interval (CI) surveys. The software collects survey 
readings from a data cane or wire counter connected to the Allegro QX. CeCi measures voltage using the 
digital voltmeter (DVM) inside the Allegro QX.     

To display the main CeCi window, tap  and CeCi.     

Figure 3-1.   CeCi Main Window     

This chapter includes the following topics:     

 l Connect Test Leads and Data Canes to Allegro QX

 l Perform a Survey in CeCi on page 28

 l Add Remarks on page 33

 l View Survey Records on page 34

 l Export a Survey File on page 35

 l Transfer a Survey File to PCS on page 36

Connect Test Leads and Data Canes to Allegro QX
CeCi software records potential readings using the Allegro QX digital voltmeter (DVM) and either a data 
cane or wire counter connected to the DVM. To set up the Allegro for close interval surveys, connect the 
test leads and data cane(s) to the DVM.     
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Test Leads Connection

To connect the test leads, plug test leads in the red INPUT and black COM jacks on the DVM.     

Figure 3-1.   Allegro QX Connections Configuration for CeCi     

Data Cane Connections

Connect the data cane into the Remote Trigger connection using one of the following configurations:     

 l Flagged Surveys Using Both Data Canes

 l Flagged Surveys Using One Data Cane

 l Fixed Increment Surveys

Flagged Surveys Using Both Data Canes

For Flagged surveys using both data canes as triggers, use a Y-connector to plug each data cane's 3-pin 
connector into the Remote Trigger connection on the DVM. 

If using a survey tray with data canes, connect the survey tray's 3-pin connector into the Remote Trigger 
connection on the Allegro QX. Connect the data canes' 3-pin connectors to the survey tray junction box.     
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Figure 3-1.   Allegro QX Using a Survey Tray to Connect to Two Data Canes     

Flagged Surveys Using One Data Cane

For Flagged surveys using only one data cane as a trigger, plug one connector to the Remote Trigger 
connection on the Allegro QX.     

Figure 3-1.   Allegro QX Connected to One Data Cane     

Fixed Increment Surveys

For Fixed Increment survey, connect the data canes and hip pack (chainer).     

Figure 3-1.   Allegro QX with Hip Pack (Chainer)     
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Set CeCi Options
To set optional features in CeCi, tap View > Options. The following tabs should be configured for the CeCi 
application:     

 l Configure the Misc Tab — the fields in the Misc tab set audio and double-click properties.         

 l Configure the File Tab on page 26 — the fields in the File tab set auto-backup and skip mode 
properties.         

 l Configure the Gps Tab on page 27 — the fields in the Gps tab set the GPS properties.         

 l Configure the Colors Tab on page 27 — the fields in the Colors tab determine the colors of the fields 
in CeCi. Enabling the colors options will automatically highlight data that exceeds an acceptable 
voltage value.         

 l Configure the Graph Tab on page 28 — the fields in the Graph tab change the display of the graph.         

Configure the Misc Tab

 1. If not already in the Options window, tap View > Options to display the Misc tab.         

 2. Select Beep on every Reading if you want the Allegro QX to beep each time a reading is taken.         

 3. If you want the Allegro QX to beep when the voltage value is less negative than a specific value, tap 
Beep for voltages less negative than this value and enter a warning value in the Voltage level field.         

 4. Tap Beep when overwrite existing data if you want the Allegro QX to warn you when a survey 
reading is overwritten.         

 5. If you want to double-click the data cane to mark a record with a flag in CeCi, tap Enable double-
click detection.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the File Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap the File tab and select Enable Autosave.         

 3. Enter a time interval in the Interval (minutes) field to have CeCi automatically save a survey file at 
regular time intervals.         

 4. Tap Retain Skipped records in Skip mode if you want CeCi to keep the reading for the current 
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record when skipping to another record during Skip mode.         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the Gps Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap the Gps tab.         

 3. If you want CeCi to remove existing GPS coordinates when updated coordinates are unavailable 
after a specified amount of time, tap Clear GPS location after and enter the number of seconds in 
the seconds without updates field.         

When GPS coordinates are older than 15 seconds, CeCi inserts an asterisk (*) in the bottom right 
corner of the survey/in the status line.         

 4. Tap the drop-down arrow in GPS display Format and select either Degrees and Decimal minutes or 
Decimal degrees.        

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the Colors Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap the Colors tab and select Enable color.         

 3. Select a field type in the list and then select a color in the color grid to change the color of the 
selected field. Repeat this step for each item in the list you want to assign a color. The following 
field types are available:         

 l Text — change the font color for a standard survey field.               

 l Text Bkgnd — change the background color for a standard survey field.               

 l P/S Value — change the font color for a valid pipe-to-soil reading field. A valid reading is 
determined by the warning value entered in the Voltage level field in the Misc tab.               

 l P/S Bkgnd — change the background color for a valid pipe-to-soil reading field. A valid 
reading is determined by the warning value entered in the Voltage level field in the Misc tab.               

 l Invalid Value — change the font color for an invalid pipe-to-soil reading field. An invalid 
reading is determined by the warning value entered in the Voltage level field in the Misc tab.               

 l Invalid Bkgnd — change the background color for An invalid pipe-to-soil reading field. An 
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invalid reading is determined by the warning value entered in the Voltage level field in the 
Misc tab.               

 4. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the Graph Tab

 1. If not already in the Options window, tap View > Options to display the Options window or double-
tap inside the graph.         

 2. Tap the Graph tab and select Show Graph.         

 3. Set upper voltage by entering a value in the Upper value field or tapping the up/down arrows.         

 4. Set lower voltage by entering a value in the Lower value field or tapping the up/down arrows.         

 5. Indicate how much data to display by entering a value (in feet) in the Width field or tapping the 
up/down arrows.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Perform a Survey in CeCi
When CeCi first opens, a new blank survey file is displayed. To open an existing survey file for editing, tap 
File > Open. Select the survey file from the list and tap OK. To create a new survey file, tap File > New. 
The CeCi properties window displays.     

NOTE: It is recommended that you save the survey file before and after entering data.       

Once a survey file is created or opened for editing, the following actions can be performed:     

 l Set CeCi Survey Properties

 l Record Inspection Readings

 l Add Remarks

 l Save the Survey File

Set CeCi Survey Properties

To set the properties for the current close interval survey, tap File > Properties. The following tabs should 
be configured for a CeCi survey:     
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 l Configure the Survey Tab on page 29 — the fields in the Survey tab identify the current survey and 
correspond to PCS ROW Code, Pipeline Code, and Surveyer fields. The Segment field is a required 
field and must be defined before defining properties in additional tabs or saving the survey file.         

 l Configure the Type Tab on page 30 — the fields in the Type tab determine whether the survey is an 
AC or DC survey.         

 l Configure the Modes Tab on page 30 — the fields in the Modes tab determine whether the survey 
is a flagged or a fixed increment survey and define the flagged or fixed increment properties.         

 l Configure the On/Off Tab on page 31 — the fields in the On/Off tab define the type of survey to be 
performed and, depending on the defined survey type, the on and off time settings.         

 l Configure the GPS Tab on page 32 — the fields in the Gps tab dictate the frequency at which the 
GPS location should be recorded and GPS details that are associated with that location record.         

It is recommended that you save the survey file before entering data.     

Configure the Survey Tab

 1. If not already in the Properties window, tap File > Properties to display the Survey tab.         

 2. Provide information in the following fields of the Survey tab:         

 l Segment: Enter the name of the ROW (right-of-way) in this required field. You can enter up to 
100 characters.               

If you plan to transfer the survey file to PCS, the name entered in the Segment field must 
match the ROW Code in PCS. If these fields do not match, PCS creates a new ROW Code 
and folder with the label Unknown in the hierarchy of PCS.               

 l Pipe: Enter a pipeline code in this optional field.               

If you plan to transfer the survey file to PCS, Pipe in CeCi is equivalent to Pipeline Code in 
PCS. If the ROW Code entered earlier in the Segment field includes multiple, parallel 
pipelines with different pipeline codes, enter the appropriate pipeline code. If pipeline codes 
have not been created in PCS, leave this field empty.               

 l Tech: Enter the surveyor's name in this optional field. If you plan to transfer the survey file to 
PCS, the name entered in the Tech field populates the Surveyor field in the Indirect Survey 
Manager (ISM) module.               

 l Run: Enter a unique survey name in this optional field. If transferring the survey file to PCS, 
data in this field creates a new CI survey folder in ISM. Examples of a unique survey name 
are: station number, milepost number, date, or a combination of date and station or milepost 
number.               
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 l Date: Enter a date or use the one automatically entered by CeCi.               

 3. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the Type Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. To set the survey type, tap the Type tab. Tap the drop-down arrow in the Survey Type field and 
select either AC Survey or DC Survey.         

Once you begin the survey, Survey Type cannot be changed.         

 3. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the Modes Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the Modes tab. Tap the drop-down arrow in the Mode field and select either Flagged or Fixed 
increment.         

To complete setting the Modes properties, follow the instructions under either Set Flagged Mode 
Properties or Set Fixed Increment Mode Properties.         

Set Flagged Mode Properties

 1. If using a metric data cane to trigger reads, tap Metric to record readings in meters.         

 2. Enter the distance between flags or station markers in the Flag distance field.         

 3. Tap the drop-down arrow in the Direction field and select Ascending or Descending to indicate how 
station numbers increment in the survey file.         

 4. If using Flagged mode and you want to take timed readings using a data cane, tap Enable Timed 
Readings and then enter the number of reads per minute in the Readings/minute field.         

You must also enable double-click detection in the Misc tab of Options (View > Options > Misc tab). 
When you double-click the data cane, a survey record is marked with an F flag. To pause or 
resume timed readings, triple-click the data can. You can pause or resume timed readings by 
pressing F5 or <Ctrl>+<P> on the Allegro QX keypad.         

 5. If using Flagged mode and you want to monitor the number of reads per flag, tap Monitor record 
count per flag and then click the drop-down arrow in the Warn at above average field and select a 
percentage value. The Allegro QX beeps 3 times as a warning when the number of reads for the 
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current flag session is more than the average percentage of reads taken for previous flag sessions.
         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Set Fixed Increment Mode Properties

 1. If using a metric wire counter (chainer) to trigger reads, tap Metric to record readings in meters.         

 2. Enter the distance between reads in the Increment field. If using a wire counter, the distance 
should be in increments of 2.5 feet or 1 meter for metric mode.         

 3. Tap the drop-down arrow in the Direction field and select Ascending or Descending to indicate how 
station numbers increment in the survey file.         

 4. Tap Use wire counter if survey readings will be taken using a wire counter (chainer).         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the On/Off Tab

For suggested on/off settings, see Interrupted On/Off Settings.     

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the On/Off tab.         

 3. Tap the drop-down arrow in the Survey Type field and select one of the following options:         

 l On (single reading) — for an uninterrupted survey, including an on, native, static, or 
depolarized survey.               

 l On/off High/Low — for an interrupted survey using non-GPS synchronized interrupters. An 
On/off High/low survey will sample 60 times per second and discard the most negative and 
least negative values in a cycle based on the On/Off Delays. Of the remaining values in the 
cycle, the most negative value will be on reading and the least negative value will be the off 
reading.               

 l On/off Gps Sync — for an interrupted survey using GPS synchronized interrupter with 
shorter on and off intervals.               

 l On/off GPS Real-time — for an interrupted survey using GPS synchronized interrupter with 
longer on and off intervals.               

 4. If available, enter on/off times and cycle begins with settings to match those on the current 
interrupter in the ON time, OFF time, and Cycle begins with fields. These fields are not available for 
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uninterrupted surveys. The Cycle begins with field is not available with On/off High/Low survey 
types.         

 5. When available, enter the delay times for the survey. These fields are not available for 
uninterrupted surveys. The following delay time fields may be available for interrupted surveys:         

 l On Delay is the amount of time after the off-to-on transition occurred. This field is available 
for On/off High/Low and On/off GPS Real-time survey types.               

For High/Low survey types, the On Delay determines the number of high (most negative) 
values that are discarded in a cycle. For GPS Real-time survey types, the On reading is the 
value that is recorded after the On Delay time.               

 l On Setup is the amount of time before the on-to-off transition occurred, at which point the 
"on" reading is recorded. This field is only available for the On/off Gps Sync survey type.               

 l Off Delay is the amount of time after the on-to-off transition occurred, at which point the "off" 
reading is recorded. This field is available for all interrupted surveys. For High/Low survey 
types, the Off Delay determines the number of low (least negative) values that are discarded 
in a cycle. For Gps Sync and GPS Real-time survey types, the Off reading is the value that is 
recorded after the Off Delay time.               

 l GPS-RT Setup Time is the time before the an on-to-off or off-to-on transition. This field is only 
available for the On/off GPS Real-time survey type.               

If a reading is recorded during these transition times, the last available reading before the transition 
is recorded.         

 6. Tap One reading per cycle to limit each cycle to one recorded reading.         

 7. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the GPS Tab

If you are taking an On/off Gps Sync or On/off GPS Real-time survey, the GPS settings should be 
configured in the GPS tab.     

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the Gps tab to set up GPS properties.         

 3. Tap Record GPS Location to include coordinates with survey readings. Tap the drop-down arrow 
in the Record GPS Location field and select an interval option that defines how often coordinates 
are included with readings.         

 4. Tap Record time of reading to include a GPS time stamp with readings.         
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 5. Tap Show message when GPS is lost to show an alert when the GPS signal is not available.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Record Inspection Readings

If using a data cane, press Enter on the Allegro QX keypad or single-click the data cane to record 
readings in the survey file. If using a wire counter (chainer), readings are automatically recorded in the 
survey file.     

Add Remarks

Additional information about the survey record, such as a geographical reference, depth of cover, or 
facility measurements, can be recorded in the remarks field. Remarks can be added directly in the 
remarks field, by entering or capturing data in a Test Point Information window, or by selecting an option 
from a standardized list of remarks.     

Add a Remark Directly in the Remarks Field

 1. Select the desired survey record and tap the remarks field.         

 2. Enter text in the field to add a remark to the record.         

Select from a Standardized List of Remarks

 1. Select a survey record and then tap Remark in the main menu.         

 2. Double-tap a remark or enter the remarks code number. CeCi inserts the remark in the remarks 
field of the currently selected record.         

Add Test Point Information

 1. Select a survey record and then tap View > Test Point Info.         

 2. Double-tap a test point and take a reading or enter required values when prompted.         

 3. Tap OK to enter the information in the survey record and return to the survey file.         

Save the Survey File

Tap the Save icon  or tap File > Save to save changes to the survey file. The Save As window displays 
when working with a new survey file that has not previously been saved. Enter a name for the new survey 
file in the Name field and then tap OK.     
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When you save a file, the survey (.svy) file is saved to the root drive under the \AI\CiData folder. A backup 
of the survey file (.svy) is also saved to the SD card.

View Survey Records
To open an existing survey file for review, tap File > Open. Select the survey file from the list and tap OK. 
You can view survey records either as a list or single record. Tap View > Single record or List.     

The following diagram shows the type of information that displays in a survey file.     

Figure 3-1.   CeCi Survey File Features     
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Show Bearing to Site
When viewing a single record with GPS coordinates, double-tap the GPS field or tap View > Show 
bearing to site to display the Site Locator window.     

The Site Locator window shows bearing and distance to a target location. Bearing is blank when the 
Allegro QX is not receiving a valid GPS fix. The message Out of Range displays when the following 
conditions occur:

 l The difference in latitude and longitude is more than 5 degrees.         

 l Latitude is above 85 degrees north or below 85 degrees south. It is also expressed as 85-90N 
degrees latitude (northern hemisphere) and 85-90S degrees latitude (southern hemisphere).         

Figure 3-1.   Site Locator     

Export a Survey File
You can export CeCi survey files as a dBase file (.dbf) or comma separated file (.csv) for use with other 
software applications, such as Microsoft Excel.     

To export a survey file, follow these steps:     

 1. Tap File > Export.         

 2. Tap the Type field and select an export format from the list of options. Enter a file name in the field. 
Ensure that the file extension in your file name matches the type of export file. For example, if 
exporting as a comma separated file, include the extension .csv in your file name.         

 3. Tap OK to close the window.         
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 4. Use Windows Mobile Device Center to move a copy from the Allegro QX CiData folder to your 
computer (Start > File Explorer > My Devices > AI > CiData).         

Transfer a Survey File to PCS
Utility files labeled wToCmd.exe and CeFileXer.exe must be updated for the current release of Allegro QX 
software in order for survey files to transfer properly from the Allegro QX to PCS. For more information, 
refer to Transfer Utility Files to PCS on page 3.     

To transfer a CeCi survey file to PCS:     

 1. Connect the provided USB serial cable to your computer and the Allegro QX. If you are using a USB 
power dock, connect the USB cable to the power dock and your computer.         

 2. To transfer a survey file to PCS version 1.x, follow these steps:         

 a. Click Field Computer > Receive to open the Field Computer Receive Data window.               

 b. Click the options Receive Cis Data and Allegro QX.               

 c. Click Retrieve File(s) to display a list of CeCi survey files available for transfer.               

 d. Select each survey file you want to transfer.               

 e. Click Import to transfer survey files from the Allegro QX to PCS.               

 f. When the Mark Native dialog box opens, click the check box for any Native Data survey files 
and then click OK to continue the transfer.               

The Field Computer Receive Status window opens showing the status of the file transfer. 
Refer to the PCS User Guide for information about viewing and managing survey data in ISM.
               

 3. To transfer a survey file to any version of PCS 7, follow these steps:         

 a. Click Field Computer > Receive Data.               

 b. Click Receive CIS Data and From Allegro QX

 c. Click Retrieve File Listing and select the survey files you want to transfer.               

 d. Click Receive and then click OK when the message Processing file completed displays. 
Refer to the PCS 7 manual for information about viewing and managing survey data in ISM.               
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Chapter 4: DC Voltage Gradient (DCVG)
DCVG locates indications of pipeline coating defects. The software records the voltage gradient and GPS 
location for further review and analysis later. DCVG collects data from data canes connected to the 
Allegro QX.     

To display the main DCVG window, tap  and DCVG.     

Figure 4-1.   DCVG Main Window     

The reading area at the top of the DCVG window displays the IR gradient (on reading minus the off 
reading); millivolt reading (shown as 1 mV in the next example); and polarity if enabled in the DCVG tab of 
Properties. The polarity arrow displays when readings are greater than 3mV or less than –3mV.     

This chapter includes the following topics:     

 l Connect Data Canes to Allegro QX

 l Set DCVG Options on page 38

 l Perform a Survey in DCVG on page 40

 l View Survey Records on page 46

 l Show Bearing to Site on page 47

 l Export a Survey File on page 47
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Connect Data Canes to Allegro QX
DCVG collects data using two data canes connected to the red and black jacks on the DVM. When an 
indication is detected, you can then define the size of the indication. To connect the data canes to the 
Allegro QX, plug data canes in the red INPUT and black COM jacks on the DVM.     

Figure 4-1.   DCVG Setup     

Set DCVG Options
To set optional features in DCVG, tap View > Options. The following tabs should be configured for the 
DCVG application:     

 l Configure the Misc Tab

 l Configure the File Tab on page 39

 l Configure the Gps Tab on page 39

 l Configure the Colors Tab on page 39

Configure the Misc Tab

 1. If not already in the Options window, tap View > Options to display the Misc tab.         

 2. If you want the Allegro QX to beep when the absolute value of the voltage is above a specific value, 
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tap Beep for voltages above this absolute value, and enter a warning value in the Voltage level field.
         

 3. Tap Beep when overwrite existing data if you want the Allegro QX to beep when a survey reading is 
overwritten.         

 4. If you want to double-click the data cane to mark a survey record with a flag, tap Enable double-
click detection.         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the File Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap Enable Autosave.         

 3. Enter a time interval in the Interval (minutes) field. This allows DCVG to automatically save a survey 
file at regular time intervals based on the Interval (minutes) you specify.         

 4. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the Gps Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap the Gps tab.         

 3. If you want DCVG to remove existing GPS coordinates when updated coordinates are unavailable 
after a specified amount of time, tap Clear GPS location after and enter the number of seconds in 
the seconds without updates field.         

When GPS coordinates are older than 30 seconds, DCVG displays the time since the last GPS 
update. When GPS coordinates are older than 15 seconds, DCVG inserts an asterisk (*) after the 
coordinates.         

 4. Tap the drop-down arrow in GPS display Format and select either Degrees and Decimal minutes or 
Decimal degrees.         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Configure the Colors Tab

 1. If not already in the Options window, tap View > Options to display the Options window.         

 2. Tap the Colors tab and select Enable color.         
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 3. Select an option in the list and then select a color in the color grid. Repeat this step for each item in 
the list you want to assign a color.         

For example, to have readings that do not meet criteria display in red text, select Invalid Value and 
the color red in the color grid.         

 4. Tap Ok to save changes and return to the survey file or tap another tab to set additional options.         

Perform a Survey in DCVG
When DCVG first opens, a new blank survey file is displayed. To open an existing survey file for editing, 
tap File > Open. Select the survey file from the list and tap OK. To create a new survey file, tap File > New. 
The DCVG properties window displays.     

NOTE: It is recommended that you save the survey file before and after entering data.       

Once a survey file is created or opened for editing, the following actions can be performed:     

 l Set DCVG Survey Properties

 l Record Inspection Readings on page 44

 l Add Remarks on page 44

 l Save the Survey File on page 46

Set DCVG Survey Properties

To set the properties for the current close interval survey, tap File > Properties to display the properties 
window for the current survey. The following tabs should be configured for a DCVG survey:     

 l Configure the Survey Tab on page 41 — the fields in the Survey tab identify the current survey and 
correspond to PCS ROW Code, Pipeline Code, and Surveyer fields. The Segment field is a required 
field and must be defined before defining properties in additional tabs or saving the survey file.         

 l Configure the Modes Tab on page 41 — the fields in the Modes tab determine whether the survey 
is a flagged or a fixed increment survey and define the flagged or fixed increment properties.         

 l Configure the On/Off Tab on page 42 — the fields in the On/Off tab define the type of survey to be 
performed and the on and off time settings.         

 l Configure the DCVG Tab on page 43 — the fields in the DCVG tab define additional P/S and half-
cell calibration settings.         
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 l Configure the Gps Tab on page 44 — the fields in the Gps tab dictate the frequency at which the 
GPS location should be recorded and GPS details that are associated with that location record.         

Configure the Survey Tab

The fields in the Survey tab identify the current survey and, if imported into PCS using Bridge, will 
correspond to PCS ROW Code, Pipeline Code, and Surveyer fields. PCS does not currently support direct 
import of Allegro QX DCVG survey files (Field Computer > Receive Data). However, you can use Bridge to 
import data in PCS. See the PCS User Guide for more information.     

 1. If not already in the Properties window, tap File > Properties to display the Survey tab.         

 2. Provide information in the following fields of the Survey tab:         

 l Segment: Enter the name of the ROW (right-of-way) in this required field. You can enter up to 
100 characters.               

If you plan to import DCVG data in PCS using Bridge, Segment name must match ROW Code 
in PCS. If these fields do not match, a new ROW Code and folder is created with the label 
Unknown in the hierarchy of PCS.               

 l Pipe: Enter a pipeline code in this optional field.               

If you plan to import DCVG data in using Bridge, Pipe is equivalent to Pipeline Code in PCS. If 
the ROW Code entered earlier includes multiple, parallel pipelines with different pipeline 
codes, enter the appropriate pipeline code. If pipeline codes have not been created in PCS, 
leave this field empty.               

 l Tech: Enter the surveyor's name in this optional field.               

If you plan to import DCVG data in PCS using Bridge, the name entered in the Tech field 
populates the Surveyor field in the Indirect Survey Manager (ISM) module.               

 l Run: Enter a unique survey name in this optional field.               

For example, include station number, milepost number, date, or a combination of station 
number and date, or milepost and station number. If you plan to import DCVG data in PCS 
using Bridge, data in this field creates a new CI survey folder in ISM.               

 l Date: Enter a date or use the one automatically entered by DCVG.               

 3. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the Modes Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the Modes tab. Tap the drop-down arrow in the Mode field and select either Flagged or Fixed 
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increment.         

To complete setting the Modes properties, follow the instructions under either Set Flagged Mode 
Properties or Set Fixed Increment Mode Properties.         

Set Flagged Mode Properties

 1. Tap Metric if you want readings recorded in meters instead of feet.         

 2. Enter the distance between flags or station markers in the Flag distance field.         

 3. Tap the drop-down arrow in the Direction field and select Ascending or Descending to indicate how 
station numbers increment in the survey file.         

 4. If you want to monitor the number of reads per flag, tap Monitor record count per flag and then tap 
the drop-down arrow in the Warn at above average field and select a percentage value. The 
Allegro QX beeps 3 times as a warning when the number of reads for the current flag session is 
more than the average percentage of reads taken for previous flag sessions.         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Set Fixed Increment Mode Properties

 1. Tap Metric if you want readings recorded in meters instead of feet.         

 2. Enter the distance between reads in the Increment field.         

 3. Tap the drop-down arrow in the Direction field and select Ascending or Descending to indicate how 
station numbers increment in the survey file.         

 4. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the On/Off Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the On/Off tab.         

 3. Tap the drop-down arrow in the Survey Type field and select one of the following options:         

 l On/off High/Low — for an interrupted survey using non-GPS synchronized interrupters. An 
On/off High/Low survey will sample 60 times per second and discard the most negative and 
least negative values in a cycle based on the on/off delays. Of the remaining values in the 
cycle, the most negative value will be on reading and the least negative value will be the off 
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reading.               

 l On/off Gps Sync — for an interrupted survey using GPS synchronized interrupter.               

 4. Enter on/off times and cycle begins with settings to match those on the current interrupter in the 
ON time, OFF time, and Cycle begins with fields. These fields are not available for uninterrupted 
surveys. The Cycle begins with field is not available with On/off High/Low survey types.         

 5. When available, enter the delay times for the survey. The following delay time fields may be 
available:         

 l On Delay is the amount of time after the off-to-on transition occurred. This field is only 
available for On/off High/Low survey type. The On Delay determines the number of high 
(most negative) values that are discarded in a cycle.               

 l On Setup is the amount of time before the on-to-off transition occurred, at which point the 
"on" reading is recorded. This field is only available for the On/off Gps Sync survey type.               

 l Off Delay is the amount of time after the on-to-off transition occurred, at which point the "off" 
reading is recorded. This field is available for all interrupted surveys. For On/off High/Low 
survey types, the Off Delay determines the number of low (least negative) values that are 
discarded in a cycle. For On/off Gps Sync survey types, the Off reading is the value that is 
recorded after the Off Delay time.               

If a reading is recorded during these transition times, the last available reading before the transition 
is recorded.         

 6. Tap One reading per cycle to limit each cycle to one recorded reading.         

 7. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the DCVG Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the DCVG tab.         

 3. Measure and enter the on reading taken at the beginning and end of the survey in the P/S On Begin 
and P/S On End fields.         

 4. Measure the Off reading taken at the beginning and end of the survey in the P/S Off Begin, and P/S 
Off End fields. Tap the V button to view a live voltage reading and then press Enter on the Allegro 
QX keyboard to save the voltage reading.         

 5. Take readings at the beginning and end of the survey. Enter the difference in the Half-cell 
calibration Begin and Half-cell calibration End fields. Tap the V button to view a live voltage reading 
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for either of these fields.         

 6. Tap Show DCVG Polarity if you want a directional arrow to display in the main DCVG window 
indicating the polarity of the reading during the survey.         

 7. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the Gps Tab

 1. If not already in the Properties window, tap File > Properties to display the survey properties 
window.         

 2. Tap the Gps tab.         

 3. Tap Record GPS Location to include coordinates with survey readings. Tap the drop-down arrow 
in the Record GPS Location field and select an interval option that identifies how often coordinates 
are included with readings.         

 4. Tap Record time of reading to include a GPS time stamp with readings.         

 5. If you are using a second GPS receiver to record location, complete the following steps:         

 a. Tap the drop-down arrow in the Comm port field and select the COM port the GPS receiver is 
connected to.               

 b. Tap the drop-down arrow in the Baudrate field and select a baud rate supported by the GPS 
receiver.               

 6. Tap Show message when GPS is lost to show an alert when the GPS signal is not available.         

 7. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Record Inspection Readings

Press Enter on the Allegro QX keypad or single-click the data cane to record readings in the survey file.     

Add Remarks

Additional information about the survey record, such as a geographical reference, depth of cover, or 
facility measurements, can be recorded in the remarks field. Remarks can be added directly in the 
remarks field, by entering or capturing data in a Test Point Information window, by adding indication 
information in a Test Point Information window, or by selecting an option from a standardized list of 
remarks.     
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Add a Remark Directly in the Remarks Field

 1. Select the desired survey record and tap the remarks field.         

 2. Enter text in the field to add a remark to the record.         

Select from a Standardized List of Remarks

 1. Select a survey record and then tap Remark in the main menu.         

 2. Double-tap a remark or enter the code number for the remark. DCVG inserts the remark in the 
remarks field of the currently selected record.         

Add Indication Information

 1. Tap View > Test Point Info when an indication is found during the survey.         

 2. Double-tap Indication to display an indication sizing window.         

 3. Enter information about the indication in the following fields of the Summary tab:         

 a. ID: Enter an identification number for the indication.               

 b. Type: Tap the drop-arrow in the Type field and select the type of indication. Options include 
Unknown, Cathodic/Anodic, Anodic/Cathodic, Anodic/Anodic, and Cathodic/Cathodic.               

 c. Signal Strength: Enter the signal strength of the indication. DCVG automatically calculates 
and enters values in the Total IR and % IR fields.               

Signal strength is the pipe-to-soil On reading minus the pipe-to-soil Off reading (P/S On – P/S 
Off).               

 4. Tap the IRGradient tab and complete the following steps:         

 a. Take readings at the indication site until you reach remote earth. Press the data cane button 
to capture readings in DCVG, or press Enter on the Allegro QX keypad. DCVG automatically 
calculates Total IR.               

When GPS is available, tap the GPS Loc button to record the current GPS location. The GPS 
Loc button is disabled and unavailable for use when GPS is unavailable.               

 b. Tap OK to return to the survey file.               

Add Test Point Information

 1. Select a survey record and then tap View > Test Point Info.         

 2. Double-tap a test point and enter required values when prompted.         
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 3. Tap OK to enter the information in the survey record and return to the survey file.         

Save the Survey File

Tap  icon or File > Save. The Save As window displays when working with a new survey file that has not 
previously been saved. Enter a name for the new survey file in the Name field and then tap OK.     

When you save a file, the survey (.dvg) file is saved to the root drive under the \AI\CiData folder. 
A backup of the survey file (.dvg) is also saved to the SD card.

View Survey Records
To open an existing survey file for review, tap File > Open. Select the survey file from the list and tap OK. 
You can view survey records either as a list or single record. Tap View > Single record or List.     

The following diagram describes the type of information that displays in a DCVG survey file.     

Figure 4-1.   DCVG Survey File Features     
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Show Bearing to Site
When viewing a single record with GPS coordinates, double-tap the GPS field to display the Site Locator 
window. Tapping View > Show bearing to site also displays the window.     

The Site Locator window shows bearing and distance to a target location. Bearing is blank when the 
Allegro QX is not receiving a valid GPS fix. The message Out of Range displays when the following 
conditions occur:     

 l The difference in latitude and longitude is more than 5 degrees.         

 l Latitude is above 85 degrees north or below 85 degrees south, which is also expressed as 85-90N 
degrees latitude (northern hemisphere) and 85-90S degrees latitude (southern hemisphere).         

Figure 4-1.   Site Locator     

Export a Survey File
You can export DCVG survey files as a dBase file (.dbf) or comma separated file (.csv) for use with other 
software applications, such as Microsoft Excel.     

To export a survey file, follow these steps:     

 1. Tap File > Export.         

 2. Tap the Type field and select an export format from the list of options. Ensure that the file extension 
in your file name matches the type of export file. For example, if exporting as a comma separated 
file, include the extension .csv in your file name.         

 3. Tap OK to close the window.         
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 4. Use Windows Mobile Device Center to move a copy from the Allegro QX CiData folder to your 
computer (Start > File Explorer > My Devices > AI > CiData).         



5
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Chapter 5: Periodic Survey
Periodic Survey (PS) measures voltage readings for annual and periodic surveys. Periodic Survey is used 
in conjunction with American Innovations PCS software. Facility and inspection fields are established in 
PCS, then transferred to the Allegro QX. The Periodic Survey collects survey readings from test leads 
connected to the Allegro QX. After completing a survey, data is transferred from the Allegro QX back to 
PCS. For information about how to build and transfer a survey file to the Allegro QX, refer to the PCS User 
Guide.     

The Periodic Survey application handles up to 2,500 facilities.     

Tap Start > PeriodicSurvey to open the Periodic Survey application. If the application had been accessed 
previously, Periodic Survey opens the last opened file and returns to your last viewed site. If a previously 
opened file is not available, Periodic Survey prompts you to open a survey file.     

Figure 5-1.   Periodic Survey Site Screen.     

This chapter includes the following topics:     

 l Connect Test Leads to Allegro QX on page 50

 l Send Periodic Surveys to the Allegro QX on page 50

 l Open and Configure a Survey File on page 51

 l Manage Sites on page 54

 l Perform a Periodic Survey on page 56

 l Send Periodic Surveys to Your Computer on page 71
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Connect Test Leads to Allegro QX
Periodic Survey records facility inspection readings using the Allegro QX digital voltmeter (DVM) and a 
data cane connected to the red and black jacks on the DVM. Plug test leads to the red and black jacks on 
the DVM according to the diagram.     

Figure 5-1.   Allegro QX Connections Configuration for Periodic Survey     

Send Periodic Surveys to the Allegro QX
Utility files labeled wToCmd.exe and CeFileXer.exe must be updated for the current release of Allegro QX 
software in order for survey files to transfer properly from PCS to the Allegro QX. For more information, 
refer to Transfer Utility Files to PCS on page 3.     
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To transfer a Periodic Survey file from PCS, connect the Allegro to your computer and open the 
appropriate module in PCS. In the Field Computer Send window, select the based on mode, facility types, 
desired prompt theme, layout theme, and sort theme(s). Update the grid and select the data you want to 
send and press Send. For detailed instructions, refer to the PCS User Guide.     

Open and Configure a Survey File
To perform a periodic/annual survey in Periodic Survey, tap File > Open. Select a survey file in the Open 
window and then tap OK. The survey file opens in Periodic Survey.     

Alternatively, you can select a recently opened survey file from the File menu. The survey file opens to the 
last survey record viewed in that survey file.     

Once a survey file is opened, the following actions should be performed to configure the file for your 
survey:     

 l Set Periodic Survey Options

 l Set Additional GPS Properties     , page 1

It is recommended that you save the survey file before and after entering data. Refer to Save the Survey 
File on page 71.     

Set Periodic Survey Options

To set the options for the current periodic survey, tap View > Options to display the options window for the 
current survey. The following tabs should be configured for a periodic survey:     

 l Configure the On/Off Tab — the fields in the On/Off tab define the type of survey to be performed 
and on and off time settings.         

 l Configure the GPS Tab on page 52 — the fields in the Gps tab dictate the frequency at which the 
GPS location should be recorded and GPS details that are associated with that location record.         

 l Configure the RFID Tab on page 53 — the fields in the RFID tab configure the ports for the attached 
RFID device.         

 l Configure the Fonts Tab on page 54 — the fields in the Fonts tab change the look of the text in the 
Periodic Survey.         

 l Configure the Misc Tab on page 54 — the fields in the Misc tab set auto-backup and miscellaneous 
display options.         

It is recommended that you save the survey file before entering data.     
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Configure the On/Off Tab

For suggested on/off settings, see Appendix A, Interrupted On/Off Settings on page 74.     

 1. If not already in the Options window, tap View > Options to display the survey options window.         

 2. Tap the On/Off tab.         

 3. Tap the drop-down arrow in the Survey Type field and select one of the following options:         

 l High/Low — for an interrupted survey using non-GPS synchronized interrupters. A 
High/Low survey will sample 60 times per second and discard the most negative and least 
negative values in a cycle based on the on/off delays. Of the remaining values in the cycle, 
the most negative value will be on reading and the least negative value will be the off reading.
               

 l Gps Sync — for an interrupted survey using GPS synchronized interrupter.               

 l Disable — Select this option to disable the commands Insert GPS in the Edit menu and Turn 
ON in the Edit > GPS submenu.               

 4. If available, enter on/off times and cycle begins with settings to match those on the current 
interrupter in the ON time, OFF time, and Cycle begins with fields. The Cycle begins with field is not 
available with High/Low survey types.         

 5. When available, enter the delay times for the survey. The following delay time fields may be 
available:         

 l On Delay is the amount of time after the off-to-on transition occurred, at which point the "on" 
reading is recorded. The On Delay determines the number of high (most negative) values 
that are discarded in a cycle. This field is only available for High/Low survey types.               

 l Instant On Setup is the amount of time before the on-to-off transition occurred, at which point 
the "on" reading is recorded. This field is only available for the Gps Sync survey type.               

 l Instant Off Delay is the amount of time after the on-to-off transition occurred, at which point 
the "off" reading is recorded. This field is available for all interrupted surveys. For High/Low 
survey types, the Off Delay determines the number of low (least negative) values that are 
discarded in a cycle. For Gps Sync survey types, the Off reading is the value that is recorded 
after the Off Delay time.               

If a reading is recorded during these transition times, the last available reading before the transition 
is recorded.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the GPS Tab

If you are taking a Gps Sync survey, the GPS settings should be configured in the GPS tab. 
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Figure 5-1.   GPS Tab Configure   

 1. If not already in the Options window, tap View > Options to display the survey options window.         

 2. Tap the Gps tab to set up GPS properties. 

 3. If you are using a second GPS receiver (dual GPS), complete the following steps:

 a. Tap to select the Use an external GPS for locations check box.

 b. Tap the drop-down arrow in the Port field and select the COM port the GPS receiver is 
connected to.

 c. Tap the drop-down arrow in the Baudrate field and select a baud rate supported by the GPS 
receiver.

 4. Tap the drop-down arrow in the Display Format field and select either Degrees and Decimal 
minutes or Decimal degrees.         

 5. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

To include GPS coordinates with readings, turn GPS on by tapping View > Turn GPS ON.     

Configure the RFID Tab

 1. If not already in the Options window, tap View > Options to display the survey options window.         

 2. Select the appropriate Comm Port from the drop-down list that corresponds to the port that the 
RFID is attached to.         

 3. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         
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Configure the Fonts Tab

 1. If not already in the Options window, tap View > Options to display the survey options window.         

 2. Tap the drop-down arrow in the Item field and select Site List, Edit caption, or Edit field.         

Site List is a list of templates for adding a new site in the survey file (View > Site List). Edit caption 
refers to field names and Edit field refers to data entered in fields.         

 3. Tap the drop-down arrow in the Font field and select a font type.         

 4. Tap the drop-down arrow in the Size field and select a font size.         

 5. Repeat these steps to change font properties for another item in the Item field.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Configure the Misc Tab

 1. If not already in the Options window, tap View > Options to display the survey options window.         

 2. Tap Enable Auto-backup to automatically saves the survey file at regular intervals.         

 3. Select a time interval in the Interval (minutes) field to define the time interval for the automatic 
backup.         

 4. Tap Show Bearing-distance to site.         

 5. Tap Show Message about DVM input.         

 6. Tap Ok to save changes and return to the survey file or tap another tab to set additional properties.         

Manage Sites
Complete the following steps to rearrange the sites, add a new one, delete an added site, or assign a new 
RFID tag to a site. New sites added on the Allegro QX are marked with a bullet (•) in the Site List and can 
be deleted. The survey file must be set up in PCS to allow for adding and deleting sites in order to add or 
delete the sites on the Allegro.     

To find a specific site's record or view the record information, refer to Perform a Periodic Survey on page 
56.     

Rearrange Sites

The Site List shows all sites available in the current file and allows you to change the order the sites 
display in Periodic Survey or hide already-surveyed sites. Tap View > Site List to see all available sites in 
the current file.     
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To determine what order sites show in the list and whether some sites should be hidden, tap Options and 
do the following:     

 1. Tap the drop-down arrow in the Order site by field and select the desired sort order. The sort orders 
available depend what sort themes were included in the prompt sent to the Allegro QX from PCS.         

 2. Tap the drop-down arrow in the Show field and select either All sites or Only unsurveyed sites.         

 3. Tap OK to return to Site List. The sites are rearranged based on the sort order and show settings 
defined in Options.         

 4. Tap OK or Cancel to return to the survey file.         

Add a New Site

If the PCS user who created this survey file had permission to create new facilities on the Allegro, you can 
add new sites in the Site List window. Tap View > Site List to see all available sites in the current file and 
do the following:     

 1. Tap Add site.         

 2. Tap a facility type in the list to select a template for the new site.         

 3. Tap OK to close the window and return to the survey file.         

 4. Tap the drop-down arrow in the ROW Code field. Do one of the following to enter a ROW code:         

 l Select a ROW code from the list.               

 l Select Other and enter a new ROW code.             

To prevent entering an incorrect ROW code, it is recommended to copy an existing ROW 
code and paste it into the Other field, then edit the ROW code as necessary. Refer 
toKeyboard Shortcuts on page 85  for help with selecting, copying, and pasting text.

Tap OK to return to the survey file.               

If the ROW Code field is empty when the survey is transferred to PCS, a new ROW code is created 
in the PCS hierarchy labeled From Allegro QX.         

 5. Tap the Milepost field and enter the new site's milepost number.         

 6. Enter data for the new site in the Information fields. Information and Reading fields are separated 
with a horizontal line. Information fields are above the line and Readings fields are below the line.         
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Delete a Site

If the survey file was created with permissions to create new facilities on the Allegro, you can delete sites 
in the Site List window. Tap View > Site List to see all available sites in the current file and do the following:
     

 1. Tap a site marked with a bullet (•) and then tap Delete.         

 2. Tap Yes when the message Delete this site? displays.         

Assign an RFID Tag to a Site

If you have an RFID tag that has not yet been assigned to a site, you can assign the tag to a site in your 
survey file. Locate the survey record for the site (see Locate a Specific Survey Record on page 59) and 
do the following with the survey record showing:     

 1. Press the RFID pen's scan button while touching the pen's touch tip to the RFID tag.         

 2. When the RFID Event dialog displays, press Yes to assign the RFID tag to the current record's site.         

The RFID information field updates with the tag's ID. Whenever an RFID pen is used to scan the RFID tag 
again, Periodic Survey will display the survey record associated with that tag.     

Perform a Periodic Survey
In the Periodic Survey Site screen you can review a survey record's existing readings or take new ones. 
To search for a specific record, you can use Find, page between records, or jump to a specific record in 
the Site List.     

Changes made in a survey record are not saved until you move to a different record, manually save the 
file, or exit the application from the File menu. Backups of the survey file will be saved to the Allegro QX's 
SD card, though any images taken as part of a survey are not stored alongside the backup. Prior to 
resetting the Allegro QX or upgrading the software, it is recommended that you manually back up any PS 
folder that contains images to the SD card or a computer.     
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Figure 5-1.   Periodic Survey Site Screen     

Refer to the following topics for more information:     

 l Review a Survey Record — review existing data in information, inspection, and maintenance fields 
for an individual record.         

 l Locate a Specific Survey Record — search for a record using Find, page between records, or 
jump to a specific record in the Site List.         

 l Take Readings for a Specific Record — manually enter values in a record's fields, record readings 
from connected devices, and take pictures for images fields with the camera. 

 l Clear Readings — clear records, pages, or site editable fields.

 l Save the Survey File — save changes to your survey file.         
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Review a Survey Record

A survey record shows record details in three main areas — information fields, reading fields, and status 
panes. Information fields appear above the horizontal line while inspection and maintenance reading 
fields display below the horizontal line. The arrangement of these fields is defined in the prompt sent to the 
Allegro QX from PCS. Refer to the PCS User Guide for more information about creating prompt themes for 
the field computer.     

The status panes display information about the current record and/or currently selected field. Depending 
on the options configured for the Allegro and the information available in the file, the panes' content may 
vary.     

Figure 5-1.   Survey Record Screen     

Click  or  to show the next or previous page in the survey record.     
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Locate a Specific Survey Record

Survey records are shown in the order determined by the sort order selected in the Site List Options. 
There are many ways to locate specific survey records in Periodic Survey: paging through records, 
finding a record based on values in certain fields, jumping to a record from the Site List, and using an RFID 
pen to jump to a record.     

Page Between Records     

Survey records are shown in the order determined by the sort order selected in the Site List Options. 
When viewing a survey record, the status bar at the bottom of the screen tells you where within the survey 

file the current record exists. To move to the next or the previous record in the file, click  or , 
respectively.     

Find a Record     

Periodic Survey allows you to search for a specific record by specifying exactly where within a survey 
record you want search terms to be found.     

From the Site Record Screen, tap Find then tap Find in the Find menu. The Find screen shows the fields 
that were defined as searchable in the prompt sent to the Allegro QX from PCS.     
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Figure 5-1.   Find Screen     

Enter the text to find in the desired searchable field(s) and select a search constraint in the Find sites that 
dropdown. Tap Find to locate the first survey record that matches the search, tap Clear to remove all 
search terms from the fields, or tap Cancel to close the Find screen without performing a search.     

To find the next survey record that matches the search, tap Find then tap Find Next in the Find menu.     

To show the previous survey record that matches the search, tap Find then tap Find Previous in the Find 
menu.     

Jump to a Record with the Site List     

The Site List shows all sites available in the current file and allows you to quickly jump to a specific survey 
record. Tap View > Site List to see all available sites in the current file. Scroll up or down in the list if 
needed to find the survey record you want to view. Select the desired survey record and tap OK to display 
the selected record.     
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Jump to a Record with an RFID Pen     

If you have RFID tags assigned to specific sites, you can use an RFID pen to quickly jump to the survey 
record for the site. Simply press the RFID pen's scan button while touching the pen's touch tip to the RFID 
tag. If the RFID tag is already assigned to a site in your survey, the survey record associated with that site 
will display.     

Take Readings for a Specific Record

Changes made in a survey record are not saved until you move to a different record, manually save the 
file, or exit the application from the File menu. The following field types are available with a prompt.     

 l Text fields — Many fields in a survey accept text input. To enter text in a text field, tap the field and 
enter text with the keyboard.         

 l Picklists — For picklist fields, tap to select the picklist field, then tap again to display the picklist and 
select the desired item in the picklist.         

 l Multi-Select Picklists — For picklists that allow you to select more than one value, double-tap in the 
field to open the multi-select screen and select the values. Refer to Select a Value for Field with a 
Multi-Select Picklist for detailed instructions.         

 l Inspection Readings — For reading fields, tap the field and press Enter on the Allegro QX keypad 
twice. Refer to Record Inspection Readings for more information.         

 l Timed Readings — For timed readings, tap the timed reading field and press Enter to open the 
Averaged Reading Survey screen and tap Start and OK to take the readings. Refer to Record 
Timed Readings for detailed instructions.         

The following fields support timed readings:         

 — Min P/S

 — Max P/S

 — Average P/S

 — P/S Sample Time

 — IRF Avg

 — IRF Max

 — IRF Min

 l Images — You can take pictures that support inspection and maintenance records for a facility. For 
images fields, tap Add then press Enter on the Allegro QX keypad. Tap OK and enter a description 
in the field provided.         
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For instructions detailing how to add and manage images for an images field, refer to Capture and 
Manage Inspection Images. Pictures can be added to the following fields:         

 — Facility Inspection Images — attaches images to a facility inspection record.               

 — Facility Maintenance Images — attaches images to a facility maintenance record.               

Select a Value for Field with a Multi-Select Picklist

If a field was set up in PCS to include a picklist (similar to a drop-down list), complete the following steps to 
select one or more values for that field.     

 1. With the cursor in the field, double-tap in the field or press Enter to open the multi-select page.         

Figure 5-1.   Multi-select Page         

 2. Tap a value or multiple values to add to the field. The value(s) remain highlighted once selected.         

 3. (Optional) If available, tap Other and enter a value in the Other field to add a value that is not on the 
list.         

 4. Tap OK to add the selected values to the field or Cancel to return to the survey file without making 
changes.         
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Figure 5-2.   Multiple Selection Field         

Record Inspection Readings

Select a reading field and then press Enter on the Allegro QX keypad to activate the digital voltmeter. 
Press Enter again or single-click the data cane to capture the reading in the survey file.     

Record Timed Readings

When the survey is set up in PCS with Allegro QX prompts for the following fields, these same fields are 
available in PS for timed readings: Min P/S, Max P/S, Average P/S, P/S Sample Time, IRF Avg, IRF Max, 
and IRF Min.

To take timed readings, follow these steps:     
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 1. Select a timed reading field and then press Enter on the Allegro QX keypad.         

Figure 5-1.   Timed Reading Fields         

 2. When the Averaged Reading Survey window displays, tap the arrow in the Duration field and select 
the length of time the Allegro QX should take timed readings.         
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Figure 5-2.   Averaged Reading Survey         

 3. Tap Start to begin timed readings. When timed readings finish, tap OK to return to the survey file.         

Tapping Stop anytime during the cycle stops timed readings.         

Capture and Manage Inspection Images

The camera on the Allegro QX can help document corrosion in atmospheric surveys or to depict items 
described within the data fields in any survey. You can take pictures that support inspection and 
maintenance fields for a facility. These images can later be transferred to and viewed in PCS 1.13 or 
newer. PCS 7 does not receive or display images from the Allegro QX.     

Images can be added directly from the survey record screen. A manage images screen is available to see 
all images attached to the selected images field for the current record, add new images to the field, delete 
existing images, preview and modify existing images, and rearrange the order and priority of the images 
for the field. For more information, refer to Add Images from the Survey Record Screen on page 66 and 
Manage Images from the Manage Images Screen on page 67.     

Camera settings can be modified to optimize images for Allegro QX surveys. These settings include, but 
are not limited to, the following:     
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 l Mode — determine whether images are taken immediately or on a timer.         

 l Brightness — increase or decrease the brightness of the image, if needed.         

 l Resolution — increase the resolution of an image to retain greater detail in the image or decrease 
the resolution of the image to save file space on the Allegro QX and reduce file transfer time.         

 l Flash — turn the flash on in low-light situations or off if current lighting is sufficient.         

 l Geotag | Emboss Options — determines what information is embossed on the image and what the 
information looks like. We recommend turning off Emboss GPS.         

To change any of these settings, click Menu when the camera is open. Any changes made to the camera 
settings will persist outside of the Periodic Survey application.     

Add Images from the Survey Record Screen

You can add new pictures to an images field directly from the current survey record screen. Find the 
desired images field and do the following:     

 1. Tap Add next to the image count to open the camera.         

Figure 5-1.   Allegro QX Camera         

 2. If necessary, modify camera settings such as resolution, brightness, and flash by clicking Menu.

 3. Line up the camera so the desired scenes are in view.         

 4. Press Enter or the Select key on the Allegro QX keyboard to capture the image.

          Do NOT tap the OK button on the screen. Tapping OK will close the camera without taking a 
picture.         
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Figure 5-2.   Image Captured         

 5. Once the captured image displays on the screen, tap OK.         

 6. Enter a description of the image in the field provided and press OK to complete the image capture 
or Cancel to discard the image and return to the survey record screen.         

Figure 5-3.   Image Description Field         

The captured image is attached to the field and listed by its description in the manage images screen.     

Manage Images from the Manage Images Screen

The manage images screen lists all images attached to the selected images field for the current record. 
The images are listed by their description. From the manage images screen you can add new images to 
the field, delete existing images, preview and modify existing images, and rearrange the order of the 
images for the field. You can also designate an image as the primary image for the selected images field 
for the current record.     

To access the manage images screen from the survey record screen, double tap on the count of images 
for an images field.     
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Figure 5-1.   Manage Images Screen     

Add More Images     

You can add new pictures to an images field directly from an images field's manage images screen. From 
the manage images screen, do the following:     

 1. Tap Add next to the image count to open the camera.         

Figure 5-2.   Allegro QX Camera         

 2. If necessary, modify camera settings such as resolution, brightness, and flash by clicking Menu.

 3. Line up the camera so the desired scenes are in view.         

 4. Press Enter or the Select key on the Allegro QX keyboard to capture the image.

          Do NOT tap the OK button on the screen. Tapping OK will close the camera without taking a 
picture.         
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Figure 5-3.   Image Captured         

 5. Once the captured image displays on the screen, tap OK.         

 6. Enter a description of the image in the field provided and press OK to complete the image capture 
or Cancel to discard the image and return to the manage images screen.         

Figure 5-4.   Image Description Field         

The captured image is attached to the field and listed by its description in the manage images screen.     

Arrange Attached Images     

Images can be rearranged so they display in another order. The order of images for a field on the Allegro 
QX will be retained when the survey file is sent back to PCS.     

In the manage images screen, tap the image you would like to move and tap  or  to move the 
image up or down, respectively.     
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Set a Primary Image     

A field's primary image is used as the Quick View image in PCS and, depending on the configuration in 
the Form Report theme, is used as the image representing the field for a record in reports.     

In the manage images screen, tap the radio dial next to the image you want to be the primary image. This 
image will be set as this field's primary image for the current record, both in the Allegro QX and in PCS.     

Preview and Describe Attached Images     

To preview an image, in the manage images screen double-tap or press Enter on the desired image. The 
preview screen opens with the selected image displayed.     

Figure 5-5.   Image Preview Screen     

The following actions are available in the preview screen:     

 l Change the description — Delete the existing text in the Description field and enter the new text in 
the Description field.

          To simply add to the existing description, tap in the Description field and enter text as needed.         

 l Preview the next or previous image — Tap Prev or Next to view the previous or next image from the 
list of field images. The previous or next image opens in the preview screen.         

 l Return to the manage images screen — Tap Back to return to the manage images screen.         

Delete Attached Images     

To delete an image from a record's images field, in the manage images screen tap the image and tap Del. 
The image is deleted from the Allegro QX and no longer associated with the record.     
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Clear Readings

When a reading is taken accidentally or has invalid data, you can easily clear the value and its associated 
timestamp (if applicable) so the invalid reading is not included in the survey. You can also clear all 
readings on the current page or clear all readings in the current site. If you clear the value for a field that is 
a part of a set of dependent fields (such as on/off paired fields, min/max/avg fields, site GPS fields, a 
visibility expression, or a dynamic picklist) the other fields in the same set of fields will be cleared.

Clear a Single Reading

If a specific reading is invalid, you can easily clear the reading. Navigate to the field with the invalid 
reading and tap Edit > Clear Value. The reading for the current field is cleared, along with its associated 
timestamp. If the field was a GPS or RFID field, the value will revert to the original location or code that 
was sent with the survey file, if available. 

Clear the Current Page

If you have accidentally taken more than one reading on a page, you can clear all editable readings on the 
current page. Tap Edit > Clear Page. The readings for all editable fields in the current page are cleared, 
along with their associated timestamps. If any of the fields were a GPS or RFID field, the value will revert to 
the original location or code that was sent with the survey file, if available.

Clear the Current Site

If you want to clear a surveyed site of all readings and remove entered data in all of the site's editable 
fields, tap Edit > Reset Site. The readings for all editable fields in the entire site are cleared, along with 
their associated timestamps. If any of the fields were a GPS or RFID field, the value will revert to the 
original location or code that was sent with the survey file, if available.

Save the Survey File

Tap the save icon  or tap File > Save to save changes in the survey file.     

Send Periodic Surveys to Your Computer

 l Transfer a Periodic Survey to PCS

 l Copy a PS Survey to a Computer

Transfer a Periodic Survey to PCS

Utility files labeled wToCmd.exe and CeFileXer.exe must be updated for the current release of Allegro QX 
software in order for survey files to transfer properly from the Allegro QX to PCS. For more information, 
refer to Transfer Utility Files to PCS on page 3.     
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To transfer a Periodic Survey file to PCS, connect the Allegro to your computer and open the appropriate 
module in PCS. The Indirect Survey Manager is the only module that will not work with Periodic Surveys. 
For PCS version 1 or newer, follow the instructions under Transfer a PS Survey File to PCS Version 1 or 
Newer. For PCS version 7, follow the instructions under Transfer a PS Survey File to PCS 7.     

For detailed instructions transferring survey data to PCS, refer to the PCS User Guide.     

Transfer a PS Survey File to PCS Version 1 or Newer

 1. Click Field Computer > Receive to open the Field Computer Receive window.         

 2. Click the Receive Facility Data option and click the Allegro option.         

 3. Click Retrieve File(s). Click to select the checkbox next to the desired survey file name and click the 
arrow next to the selected checkbox.         

 4. Select the desired options and click Import to transfer the survey from the Allegro QX. When a 
message displays confirming the send process is complete, click OK to close the message.         

Transfer a PS Survey File to PCS 7

 1. Click Field Computer > Receive Data to display the Receive Allegro QX Data window.         

 2. Click Receive Facility Data > From Allegro QX > Retrieve File Listing.         

 3. Select the survey file(s) you want to transfer to PCS and then click Receive. When the window 
Options for Receiving Data displays, choose an option to assign a survey to Allegro QX data and 
then click Continue.         

 4. Click OK when the message Receive Allegro QX Data displays stating the process is complete.         

Copy a PS Survey to a Computer

Complete the following steps to copy one or more PS survey files to a computer:     

 1. Connect the provided USB serial cable to your computer and the Allegro QX. If you are using a USB 
power dock, connect the USB cable to the power dock and your computer.         

 2. At your computer, start Windows Media Device Center (WMDC) or ActiveSync. Follow on-screen 
prompts to establish communications. For ActiveSync users, click No when prompted to create a 
Partnership. This allows you to create a Guest connection instead.         

 3. In WMDC, point the mouse at File Management and then click Browse the contents of your device.         

In ActiveSync, click the Explore icon in the tool bar to display the contents of the Allegro QX in 
Windows Explorer.         
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 4. Click the AI folder (located at the root drive \AI\).         

 5. Double-click the PsData folder. Click the Name column in Windows Explorer to sort files by name.         

 6. Select and drag the entire folder whose name matches the name of the survey file.         
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Appendix A: Interrupted On/Off Settings
Interrupted surveys are set up and performed in the Allegro QX AiDvm, CeCi, or Periodic Survey 
applications. Refer to the table in Suggested On/Off Settings for recommended on/off settings for 
interrupted surveys.     

When a survey file is set up in On/Off GPS Sync or On/Off GPS Real-time mode, American Innovations 
recommends that the survey file is also set up with On/Off High/Low settings, which serves as a backup if 
the satellite signal is lost. In the event that the signal is lost, the Allegro QX defaults to On/Off High/Low 
survey mode until the satellite signal is re-acquired.     

Types of Interruption Cycles

 l High/Low: Filters out a set number of most negative and least negative values. Always reports the 
last complete on/off pair.         

 l GPS Sync: Captures On and Off readings (P/S potentials or interrupted current readings), 
multiplied by milliseconds, before and after the On to Off transition. Always reports the last on/off 
pair.         

 l Both High/Low and GPS Sync work well for fast cycles (complete cycle time of two seconds or 
less). These two types only refresh the values once per cycle.         

 l GPS Real Time (RT): Designed for slow cycle surveys (greater than a two-second complete cycle 
time). In the GPS RT mode, each reading trigger event will be added to either the ON or OFF 
column, depending on where in the cycle the event occurred.         
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Suggested On/Off Settings
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On/Off High/Low setup for 1 second cycle

A minimum/maximum reading from a sample of readings. Of the remaining 45 readings, the most negative 
reading is equal to the on reading and the least negative reading is equal to the off reading.             

60 readings per cycle (60 readings per second).             

0.7 on             

0.3 off             

0.8 on             

0.2 off             

200 mSec On Delay             

150 mSec Off Delay             

200 mSec On Delay             

100 mSec Off Delay             

Filters out 12 most negative readings             

Filters out 3 least negative readings             

Filters out 12 most negative readings             

Filters out 3 least negative readings             

On/Off High/Low setup for greater than 1 second cycle

A minimum/maximum reading from a sample of readings. Of the remaining 99 readings, the most negative 
reading is equal to the on reading and the least negative reading is equal to the off reading.             

120 readings per cycle (60 readings per second):             

1.5 on             

0.5 off             

250 mSec On Delay             

150 mSec Off Delay             

Filters out 15 most negative readings             

Filters out 6 least negative readings             

On/Off GPS Sync setup for 1 second cycle

A minimum/maximum reading from a sample of readings. Of the remaining 99 readings, the most negative 
reading is equal to the on reading and the least negative reading is equal to the off reading.             

A snapshot of readings in a certain time period:             

0.7 on             

0.3 off             

0.8 on             

0.2 off             

200 mSec On Setup             

150 mSec Off Delay             

200 mSec On Setup             

100 mSec Off Delay             

Takes reading 200 mSec before the on > offtransition.             

Takes reading 150 mSec after the on > offtransition.             

Takes reading 200 mSec before the on > offtransition.             

Takes reading 100 mSec after the on > offtransition.             

On/Off setup for greater than 1 second cycle

A minimum/maximum reading from a sample of readings. Of the remaining 45 readings, the most negative 
reading is equal to the on reading and the least negative reading is equal to the off reading.             

1.5 on             

0.5 off             

250 mSec On Setup             

250 mSec Off Delay             

Takes reading 200 mSec before the on > offtransition.             

Takes reading 150 mSec after the on > offtransition.             

On/Off GPS Real-time setup for greater than 2-second cycle

8.0 on             

2.0 off             

200 mSec On Delay             

250 mSec Off Delay             

Starts capturing readings 200 mSec after the on > off transition.             

Starts capturing readings 250 mSec after the on > off transition.             

Table A-1.  Suggested On/Off Settings for Interruption Surveys       
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GPS-RT
              Setup Time             

50 mSec             
No readings 50 mSec before off cycle to Off Delay.

No readings 50 mSec before on cycle to On Delay.

GPS Real Time delay

Does not capture any reading for 50 mSec before either the on > off or the off > on transition.             

Recommended GPS-RT Setup Time is 50 mSec for Mercury switches and 30 mSec for solid state switches.             

Table A-1.  Suggested On/Off Settings for Interruption Surveys        cont'd
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Appendix B: Utility Software
Information in this chapter explains how to use and set up the following utility software:     

 l GPS Status

 l GPS Pod Setup        

GPS Status
To start GPS Status, tap Start > GpsStatus to display the Gps Status window. 

Figure B-1.   GPS Status     

Use GPS Status to perform any of the following tasks:     

 l View current GPS data, such as number of satellites in view, GPS coordinates, amount of time 
since the last GPS fix, and current GPS time.         

 l Enable the Offset option to view the distance between two points.         

 l Enable the Beep option if you want the Allegro QX to beep when GPS readings update.         

 l Tap Options to:

 — Configure a second GPS receiver (dual GPS) by completing the following steps:

 1. Tap to select the Use an external GPS for locations check box.

 2. Tap the drop-down arrow in the Port field and select the COM port the GPS receiver is 
connected to.

 3. Tap the drop-down arrow in the Baudrate field and select a baud rate supported by 
the GPS receiver.

 — Set a Display Format for GPS coordinates (degrees and minutes or decimal degrees).         
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 l Tap Copy to copy GPS coordinates to the system clipboard.         Once copied to the clipboard, you can 
paste the coordinates into a document on the Allegro QX.

NOTE: If the Allegro QX is unable to open the COM port, the message Unable to open GPS port COM3 (-
2,317) displays. Exit and then restart GPS Status to allow the Allegro QX to open the port. The value 
shown in parentheses is an internal code used by AI for troubleshooting purposes.       
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Field             Description             

Satellites             

Current number of satellites tracked by the GPS receiver display in this status 
line. If using dual-GPS, status line displays the number of satellites as #/# 
Satellites in view. The first number applies to the external GPS receiver, the 
second number applies to the internal GPS receiver.             

Three (3) satellites are required for coordinate calculations. Four (4) satellites 
are required for calculating a 3D position (latitude, longitude, and elevation). 
The more satellites tracked, the higher accuracy of the GPS receiver.             

GPS status             

Status line may include any of the following messages:             

 l Receiving GPS             

 l Initializing             

 l Waiting             

Information about the serial connection displays in parentheses during the 
startup process, such as Initializing (V 236). It shows a GPS status byte (V or FF) 
and the number of received characters. GPS status bytes (V and FF) indicate 
whether or not the receiver is receiving GPS packets. V indicates valid GPS 
packets received and FF indicates no GPS packets received.             

If received characters is zero (0) or does not increase, verify the GPS receiver is 
securely connected to the Allegro QX and communication settings are correct 
(COM port and baud rate).             

GPS coordinates             

Shows longitude, latitude, and elevation coordinates received from a 
minimum of 3 satellites.             

Coordinates update every second. With a clear view of the sky, GPS accuracy 
without differential correction is about 10 meters (32.8 feet). Sub-meter 
accuracy is reported after applying differential correction when using a 
second GPS receiver (dual GPS), such as the Trimble GPS Pathfinder Pro XR.             

DOP values             

DOP (dilution of precision) values identify the accuracy of GPS readings. When 
a DOP value is zero (0), the GPS receiver does not report the value. When the 
value is between 1 and 3, GPS accuracy is good.             

PDOP refers to position dilution of precision; VDOP refers to vertical dilution 
of precision; HDOP refers to horizontal dilution of precision; and TDOP refers 
to time dilution of precision.             

Table B-1.  GPS Status Field Descriptions       
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Field             Description             

Age of fix             

Shows the time since the last GPS satellite fix. Age of fix appears only when the 
GPS satellite signal is lost. It appears ten seconds after losing the satellite 
signal. Information displays in the following manner:             

 l When age is less than 10 seconds, field is empty.             

 l When age is less than 1 minute, number of seconds display as nn sec, 
such as 35 sec.             

 l When age is less than 60 minutes, number of minutes and seconds 
display as mm:ss, such as 12:14.             

 l When age is undetermined, an asterisk (*) displays.             

GPS time             

GPS time displays when a GPS time signal is received and the Offset option is 
disabled.             

Updates display every second when GPS time is available. GPS time displays in 
24-hour format and may include the suffix letters P and/or Z. P indicates a PPS 
(one pulse-per-second) time signal is being received. Z indicates a GPS time 
packet is being received.             

When GPS time is unavailable or the GPS time signal is more than 10 minutes 
old, this area of the GPS Status window is empty. When Offset is enabled, 
offset values (such as 2, 1, 5) or asterisks (*, *, *) display instead of GPS time.             

Offset             

Offset shows the distance between two points. To use Offset, tap Offset and 
then move to a different location. Offset values display inside parentheses 
and are calculated as feet or miles. For example, with an offset of (1, 2, 3):             

 l 1 is the east-west offset (W positive)             

 l 2 is the north-south offset (N positive)             

 l 3 is the vertical offset             

An offset distance higher than 0.1 degree (about six miles) displays as 
asterisks inside parentheses (*,*,*). When Offset is enabled, GPS time does not 
display.             

Table B-1.  GPS Status Field Descriptions        cont'd
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Field             Description             

Beep             
If you want the Allegro QX to beep each time GPS readings update, tap Beep 
to enable the option.             

u-blox WGS84             
Status line showing the current datum setting for a u-blox compatible GPS 
receiver. This status line does not display for all other GPS receivers, such as a 
Trimble GPS receiver.             

Table B-1.  GPS Status Field Descriptions        cont'd

GPS Pod Setup
When a Power Reset is performed on the Allegro, the internal GPS pod loses factory settings for 
communication with AI applications. AI provides two utilities that allow you to reset the communication 
parameters of the internal GPS pod. If you use a u-blox compatible GPS receiver with the Allegro, reset 
communication parameters using the AMXU GPS Pod Setup utility. For all other GPS receivers (such as a 
Trimble GPS receiver), set communication parameters using the GPS Pod Setup utility. 

Each of the following options on the GPSPodSetup screen are NMEA sentences that are sent from the 
satellites:

 l GGA – latitude, longitude, and elevation.

 l GSA – the DOP reading (dilution of precision). DOP values identify the accuracy of GPS readings. 
When a DOP value is zero (0), the GPS receiver does not report the value. When the value is 
between 1 and 3, GPS accuracy is good; under 2 is excellent. The Allegro records only the PDOP 
in the CeCi surveys. Readings under 5 are considered good; under 2 is excellent.

 l ZDA – time.

 l SBAS/WAAS – separate constellation of satellites that are used to get differentially corrected GPS.

To reset the communication parameters of the internal GPS pod, refer to one of the following topics:

 l Using the AMXU Pod Setup - for configuring the communication parameters of a u-blox compatible 
GPS receiver with the Allegro QX

 l Using the GPS Pod Setup Application - for configuring the communication parameters of a Trimble 
GPS receiver with the Allegro QX

Using the AMXU Pod Setup

If you use the u-blox compatible GPS receiver with the Allegro, complete the following steps to reset the 
communication parameters of the internal GPS pod:
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 1. Tap Start > Programs > AMXU Pod Setup to open the AMXU GPS Pod Setup window. 

 2. Tap the AI button to apply the correct settings for AI applications. Settings are as follows and should 
match the following image

Figure B-1.   AMXU GPS Pod Setup

 3. Verify the following: 

The following items must be selected: 

 l GGA

 l GSA 

 l ZDA

The following item must be deselected:

 l GPS always on

 4. Verify the message Settings Saved displays in the Status box. If the Status box is empty, tap the AI 
button again to display the message.

 5. Tap OK to close the utility. 

Using the GPS Pod Setup Application

If you use a Trimble GPS receiver with the Allegro QX, complete the following steps to reset the 
communication parameters of the GPS pod: 

 1. Tap Start > Programs > GPSPodSetup to open the GPS Receiver Port Settings window. 

 2. Tap the AI button to apply the correct settings for AI applications. Settings are as follows and should 
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match those in the following image:

Figure B-1.   GPS Receiver Port Settings

 3. Verify the following: 

The following items must be selected: 

 l GGA

 l GSA 

 l ZDA

The following drop down options should be selected: 

 l Baud: 9600

 l Parity: None

 l Stop Bits: 1

 l GPS Data Format: NMEA

 4. Tap Apply Settings and then the Close icon (X).
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Appendix C: Keyboard Shortcuts
These are the default shortcuts and could change if Personal Buttons are modified in Allegro Settings. 
Many shortcuts only work when the cursor is in a certain field or tab.
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Global Shortcuts             

Start Menu <Orng><Home> Open the Windows Start menu.            

Home Screen             <Home>
Display the Home Screen in most apps. Does not work in 
AiDVM or GpsStatus.            

Orange Key Lock
<Orng><Orng> or 
<Blue><Orng>

Lock the Orange key in the On position. Press <Orange> 
again to unlock.            

Function Keys                         <Blue><F1-F6> Activate keys F7 through F12.            

Touchscreen <Blue><Backspace> Enable or disable touchscreen.            

Screen Capture <Orng><R> Capture the screen as an image.            

Task Manager
<Blue><Esc> or 
<Orng><T>

Open Task Manager.            

Display Backlight                         <Orng><F3>             Toggle backlight on and off.            

Display Brighten/Dim
 

<Orng><F4> or 
<Orng><Up Arrow>

Brighten the screen display.            

<Orng><F5> or 
<Orng><Down 
Arrow>

Dim the screen display             

Volume
<Orng><Right 
Arrow>

Increase volume sound       

<Orng><Left Arrow> Decrease volume sounds       

Switch Between Tabs <Ctrl><TAB>             Move from one tab within a window to another.             
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Navigate Screen

 

<TAB>             
Move cursor between fields & buttons. Left tab moves 
cursor backward; right tab moves cursor forward.             

<Up Arrow>

<Down Arrow>

<Left Arrow>

<Right Arrow>

Move cursor within a selected field. May also move cursor 
to the next/previous field or button.            

<Blue><Down 
Arrow>

Page Down            

<Blue><Up Arrow> Page Up

<ENTER> Select the current field/button.

<Blue><Left Arrow> Move to start of the line.

<Blue><Right Arrow> Move to end of the line.            

Drop-down <Alt><Down Arrow>             Open drop-down list.             

Select Data in a Field

<Shift><Left Arrow>             Select the previous character in the field.             

<Shift><Right 
Arrow>             

Select the next character in the field.             

Copy, Cut, Paste

<Ctrl><C>       Copy selection to clipboard.       

<Ctrl><X>       Remove selection and copy to clipboard.       

<Ctrl><V>       Paste content from clipboard.       

Caps Lock
<Shift><Shift> or 
<Blue><Shift>             

Toggle caps lock on and off.            

Help Menu <Orng><F1> Display a key combinations list for common actions.         

Close Window <Esc>             Close an open window.             

AiDVM Shortcuts                         

Graph <G> or <Alt><G>             Open graph.             

Option Window <N> or <Alt><N>             Open Options window.             

Copy / Paste
<Ctrl><C>             Copy current DVM reading.             

<Ctrl><V>             Paste DVM reading in an open file, such as Excel.             

Voltage Range

<Ctrl><Up Arrow>             Increase voltage range.             

<Ctrl><Down Arrow>             Decrease voltage range.             

<U> or <Alt><U>             Select autoranging.             
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VDC Test Function <D> or <Alt><D>             Select Vdc test function.             

VAC Test Function <A> or <Alt><A>             Select Vac test function.             

DC Amp <Ctrl><D>             Select DC Amp test function.             

AC Amp <Ctrl><A>             Select AC Amp test function.             

AC mA Test Function <M> or <Alt><M>             Select Amp test function.             

Autoranging <A>             Enable or disable autorange in DVM Options window.             

Jump to Sample Rate 
Field

<S>             Move cursor to Sample Rate field in DVM Options window.             

Capture Reading <Enter>             

In a reading field:              

 l <Enter> to activate digital voltmeter.             

 l <Enter> again to capture reading.             

In a timed reading field: Set up, start, stop, or cancel 
timed reading mode.             

Graph Remarks
<Tab> then <Enter>             

Show remarks window: In DVM graph window:

 1. <Tab> to move cursor to Save button 

 2. <Enter> to display window.

<Enter> Add a new line: <Enter> in graph remarks window.             

CECI Shortcuts

New <Ctrl><N>             Create new survey file.             

Open <Ctrl><O>             Open File Open window.             

Save <Ctrl><S>             Save survey file.             

Flag Marker <F>             Insert flag marker: flagged mode.             

Reset Flag Count <Ctrl><F>             Reset flag count.             

Gap Marker <G>             Insert gap marker: flagged mode.             

Capture Reading <Enter> Capture a reading.             

Go To <Ctrl><G>             Open Go To Location window.             

Skip <Ctrl><K>             Open Skip Distance window in Fixed Increment mode.             

Insert Record <Ctrl><Ins>             Insert new record.             

<F2> Display the Insert Record menu if in Flagged Mode.             
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Delete Record <Ctrl><Del>             Delete selected record.             

Skip/Lock/Normal <Ctrl><Z> or <F3> Toggle Skip, Lock, and Normal in Fixed Increment mode.             

Remark <Alt><R> or <F4> Open remark window.             

Pause/Resume <Ctrl><P> or <F5> Pause/resume timed readings.             

Test Point Information <Ctrl><T>             Open Test Point Information window.             

File Menu <Alt><F>             Open File menu.             

Move Menu <Alt><M>             Open Move menu.             

View Menu <Alt><V>             Open View window.             

Remark Window <Alt><R>             Open Remark window.             

Navigating Misc Tab in 
Options

<B>             Enable or disable Beep on every Reading.             

<V>             Move cursor to Voltage level.             

<W>             Enable or disable Beep when overwrite existing data.             

<D>             Enable or disable Enable double-click detection.             

Navigating File Tab in 
Options

<A>             Enable or disable Autosave.             

<I>             Move cursor to Interval (minutes).             

<R>             Enable or disable Retain Skipped records in Skip mode.             

Navigating GPS Tab in 
Options

<C>             Enable or disable Clear GPS Location After.             

<S>             Move cursor to Seconds Without Updates.             

<G>             Move cursor to GPS Display Format.             

Navigating Graph Tab 
in Options

<G>             Enable or disable Show Graph.             

With Show Graph enabled:

<U>       Move cursor to Upper Value.       

<L>             Move cursor to Lower Value.             

<W>             Move cursor to Width.             

Navigating Colors Tab 
in Options

<E>             Enable or disable Enable Color.             

With Enable Color enabled:

<Tab>             Move cursor between field selection list and color grid.             

<Up/Down/Left/Right 
Arrows>

Move cursor in field selection list or color grid.             

DCVG Shortcuts
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New <Ctrl><N>       Create new survey file.       

Open <Ctrl><O>       Open File Open window.       

Save <Ctrl><S>       Save survey file.       

Flag Marker <F>       Insert flag marker in flagged mode.       

Reset Flag Count <Ctrl><F>       Reset flag count.       

Gap Marker <G>       Insert gap marker in flagged mode.       

Capture Reading <Enter>       Capture a reading.       

Go To <Ctrl><G>       Open Go To Location window.       

Skip <Ctrl><K>       Open Skip Distance window in fixed increment mode.       

Insert Record <Ctrl><Ins>       Insert new record.       

Delete Record <Ctrl><Del>       Delete record.       

Remark <Alt><R>       Open remark window.       

Test Point Information <Ctrl><T>       Open Test Point Information window.       

GPS Status Shortcuts

Open Options <O> Open Options.       

Enable/Disable Read 
PPS from Internal GPS

<P>       
Enable or disable Read PPS from Internal GPS.       

Periodic Survey Shortcuts

Open <Ctrl><O>             Open File Open window.             

Save <Ctrl><S>             Save survey file.             

Undo <Ctrl><Z>             Undo last change.             

Next Page / Previous 
Page

<Ctrl><Down Arrow>
             

Display next page of a site.             

<Ctrl><Up Arrow>             Display previous page of a site.             

Next Site / Previous Site

<Shift><Down 
Arrow>             

Display next site.             

<Shift><Up Arrow>             Display previous site.             

Find <Ctrl><F> Initiate a Find.             

Find Next <Ctrl><N> Find the next record that matches the Find criteria.             

Find Previous <Ctrl><P> Find the previous record that matches the Find criteria.             
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Record GPS 
Coordinates

<Ctrl><G> or <F4> Records GPS coordinates when cursor is in reading field.             

Insert GPS Coordinates <Ctrl><I> or <F5> Inserts GPS coordinates when cursor is in reading field.             

Capture Reading <Enter>

               In a reading field: Capture a reading.

 1. <Enter> to activate digital voltmeter.

 2. <Enter> again to capture reading.

In a timed reading field: Setup, start, stop, or cancel timed 
reading mode reading.

Navigate Information 
and Reading Fields

<Alt><U> Move cursor between information and reading fields.

File Menu <Alt><F> Open File menu.

Edit Menu <Alt><E> Open Edit menu

View Menu <Alt><V> Open View menu.
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